SlideShare a Scribd company logo
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 1 of 12
CCNA Lab 5:
Configuring Inter-VLAN Routing
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 2 of 12
Table of Contents Page
1- Objectives...................................................................................................................................................4
2- Scenario .....................................................................................................................................................4
3- Equipment List............................................................................................................................................4
4- Topology Diagram ......................................................................................................................................5
5-Addressing Table.........................................................................................................................................6
6-Detailed Lab Steps ......................................................................................................................................7
6-1 Part 1: Prepare the Network (Cable, Erase, and Reload the Switch and Router)................................7
6-1-1- Designing and Configuration ........................................................................................................7
6-1-2- Verification ....................................................................................................................................7
6-1-3 Troubleshooting .............................................................................................................................7
6-2: Part 2: Perform Basic Device Configurations on Switchs and Router.................................................7
6-2-1- Designing and Configuration ........................................................................................................7
6-2-2- Verification ....................................................................................................................................8
6-3: Part 3: Configure Switch and Router to Accept Incoming SSH Connections......................................8
6-3-1- Designing and Configuration ........................................................................................................8
6-3-2- Verification ....................................................................................................................................8
6-4: Part 4: Configure and Activate Ethernet Interfaces .............................................................................8
6-5: Part 5: Configure VLANs on the Switch...............................................................................................9
6-5-1- Designing and Configuration ........................................................................................................9
6-5-2- Verification ................................................................................................................................. 10
6-6: Part 6: Configuring EtherChannels................................................................................................... 11
6-6-1- Designing and Configuration ..................................................................................................... 11
6-6-2- Verification ................................................................................................................................. 11
6-7: Part 7: Configuring Routing to VLANs using 802.1Q on Routers..................................................... 11
6-7-1- Designing and Configuration ..................................................................................................... 11
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 3 of 12
6-7-2- Verification ................................................................................................................................. 12
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 4 of 12
1- Objectives
Demonstrate and explain the impact of Layer 3 boundaries imposed by creating VLANs
Configure a router to support 802.1q trunking on a Fast Ethernet interface
Configure a router with subinterfaces corresponding to the configured VLANs
Demonstrate and explain inter-VLAN routing
2- Scenario
In this lab you will practice configuring routing to VLANs using 802.1Q on routers and verifying Inter-VLAN
routing.
3- Equipment List
Three Cisco Catalyst 2960 Switchs with Cisco IOS Release 12.2. The Cisco implementation of
SSH requires Cisco IOS Software to support RSA authentication and minimum DES encryption—
a cryptographic software image.
Cisco 1841 Integrated Services Router with Cisco IOS Software Release 12.4T
Three PCs that will run Windows XP or later
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 5 of 12
4- Topology Diagram
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 6 of 12
5-Addressing Table
Port Assignments – Switch 2
Interface Configuration Table – Router 1
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 7 of 12
6-Detailed Lab Steps
6-1 Part 1: Prepare the Network (Cable, Erase, and Reload the Switch and Router)
6-1-1- Designing and Configuration
Step 1: Cable a network
Cable a network that is similar to the one in the topology diagram.
Step 2: Clear the configuration on the switch and router
Clear the configuration on all the switchs based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed
Lab Steps, Part 1.
Remove the router startup configuration file from NVRAM.
Router#erase startup-config
6-1-2- Verification
Do the verification based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Part 1.
6-1-3 Troubleshooting
Do the troubleshooting based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Part
1.
6-2: Part 2: Perform Basic Device Configurations on Switchs and Router
6-2-1- Designing and Configuration
Perform Basic Device Configurations on all the switchs and router based on the “CCNA Lab 1-Configuring
a Switch Part I”, Detailed Lab Steps, Part 2.
Notice: Configure the Layer 3 address of the switchs.
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 8 of 12
For management purposes, we will use VLAN 99. First, you will create the new VLAN 99 on the switch.
Then you will set the IP address of the switch to 172.17.99.11 with a subnet mask of 255.255.255.0 on the
internal virtual interface VLAN 99.
S1(config-vlan)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#interface vlan99
S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown
Do the same configuration on switches S2 and S3 based on the Addressing Table.
A management VLAN is any VLAN that you configure to access the management capabilities of a switch.
6-2-2- Verification
Do the verification based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Detailed
Lab Steps, Part 2.
6-3: Part 3: Configure Switch and Router to Accept Incoming SSH Connections
6-3-1- Designing and Configuration
Configure all the switchs and router to accept Incoming SSH Connections based on the “CCNA Lab 2-
Configuring a Switch Part 2”, Detailed Lab Steps, Part 4.
6-3-2- Verification
Do the verification based on the the “CCNA Lab 2-Configuring a Switch Part 2”, Detailed Lab Steps, Part
4.
6-4: Part 4: Configure and Activate Ethernet Interfaces
Step 1: Configure the PCs
All three PCs with the IP addresses and default gateways should be configured.
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 9 of 12
6-5: Part 5: Configure VLANs on the Switch
6-5-1- Designing and Configuration
Step 1: Create VLANs on switch S1
There are four VLANS configured for this lab: VLAN 10 (faculty); VLAN 20 (students); VLAN 30 (guest);
and VLAN 99 (management).
S1(config)#vlan 10
S1(config-vlan)#name faculty
S1(config-vlan)#vlan 20
S1(config-vlan)#name students
S1(config-vlan)#vlan 30
S1(config-vlan)#name guest
S1(config-vlan)#end
Step 2: Configure and name VLANs on switches S2 and S3
Create and name VLANs 10, 20, 30, and 99 on S2 and S3 using the commands from Step 1.
Step 3: Assign switch ports to VLANs on S2
Refer to the port assignment table, ports are assigned to VLANs in interface configuration mode. The
commands are shown for S2.
S2(config)#interface range fa0/6-10
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#interface range fa0/11-17
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#interface range fa0/18-24
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#end
Step 4: Configure trunking and the native VLAN for the trunking ports on all switches
Use the interface range command in global configuration mode to simplify configuring trunking.
S1(config)#interface range fa0/1-4
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 10 of 12
S1(config-if)#switchport trunk allowed vlan 10,20,30,99
S1(config-if-range)#end
S2(config)# interface range fa0/1-4
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99
S2(config-if)#switchport trunk allowed vlan 10,20,30,99
S2(config-if-range)#end
S3(config)# interface range fa0/1-4
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if)#switchport trunk allowed vlan 10,20,30,99
S3(config-if-range)#end
6-5-2- Verification
Step 1: Verify that the VLANs have been created on S1, S2 and S3
Use the show vlan brief command to verify that the VLANs have been created.
S2#show vlan brief
Step 2: Determine which ports have been added
Use the show vlan id vlan-number command on S2 to see which ports are assigned to VLAN 10.
You can also view VLAN assignment information using the show interfaces interface
switchport command.
S2#show vlan id 30
S2#show interfaces fastEthernet 0/6 switchport
Step 3: Verify that the trunks have been configured on S1, S2 and S3
Verify that the trunks have been configured with the show interface trunk command.
S1#show interface trunk
S1#show interfaces status
Step 4: Verify that the switches can communicate
From S1, ping the management address on both S2 and S3.
S1#ping 172.17.99.12
S1#ping 172.17.99.13
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 11 of 12
6-6: Part 6: Configuring EtherChannels
6-6-1- Designing and Configuration
Step 1: Configuring Manual EtherChannel
S1(config)#interface range fa0/1-2
S1(config-if-range)# channel-group 1 mode on
S1(config)#interface range fa0/3-4
S1(config-if-range)# channel-group 2 mode on
S2(config)#interface range fa0/1-2
S2(config-if-range)# channel-group 1 mode on
S2(config)#interface range fa0/3-4
S2(config-if-range)# channel-group 2 mode on
S3(config)#interface range fa0/1-2
S3(config-if-range)# channel-group 1 mode on
S3(config)#interface range fa0/3-4
S3(config-if-range)# channel-group 2 mode on
6-6-2- Verification
Step 1: Verify that the PortChannels have been created on S1, S2 and S3
S1#show etherchannel summary
S1#show interfaces status
6-7: Part 7: Configuring Routing to VLANs using 802.1Q on Routers
6-7-1- Designing and Configuration
Step 1: Configure the trunking interface on R1
Router on a Stick (ROAS) uses router VLAN trunking configuration to give the router a logical router
interface connected to each VLAN, and therefore each subnet that sits on a separate VLAN.
amir-jafari.com
©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 12 of 12
R1(config)#interface fastethernet 0/1
R1(config-if)#no shutdown
R1(config-if)#interface fastethernet 0/1.1
R1(config-subif)#encapsulation dot1q 1
R1(config-subif)#ip address 172.17.1.1 255.255.255.0
R1(config-if)#interface fastethernet 0/1.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 172.17.10.1 255.255.255.0
R1(config-if)#interface fastethernet 0/1.20
R1(config-subif)#encapsulation dot1q 20
R1(config-subif)#ip address 172.17.20.1 255.255.255.0
R1(config-if)#interface fastethernet 0/1.30
R1(config-subif)#encapsulation dot1q 30
R1(config-subif)#ip address 172.17.30.1 255.255.255.0
R1(config-if)#interface fastethernet 0/1.99
R1(config-subif)#encapsulation dot1q 99 native
R1(config-subif)#ip address 172.17.99.1 255.255.255.0
6-7-2- Verification
Step 1: Checking the routing table on R1
R1#show ip route
Step 2: Verify Router Trunking Configuration
show vlans command to Match Sample Router Trunking Configuration.
R1#show vlans
Step 3: Ping PC1 from PC2
Ping from host PC2 to host PC1. Routing between VLANs has been configured so the ping should be
successful.

More Related Content

What's hot

Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
DH Da Lat
 
VLAN
VLANVLAN
Cisco Router and Switch Security Hardening Guide
Cisco Router and Switch Security Hardening GuideCisco Router and Switch Security Hardening Guide
Cisco Router and Switch Security Hardening Guide
Harris Andrea
 
CCNA Lab 3-VLAN Configuration on Switch
CCNA Lab 3-VLAN Configuration on SwitchCCNA Lab 3-VLAN Configuration on Switch
CCNA Lab 3-VLAN Configuration on Switch
Amir Jafari
 
Vlan
VlanVlan
Checkpoint Firewall for Dummies
Checkpoint Firewall for Dummies Checkpoint Firewall for Dummies
Checkpoint Firewall for Dummies
sushmil123
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
Salachudin Emir
 
CCNA Routing Protocols
CCNA Routing ProtocolsCCNA Routing Protocols
CCNA Routing ProtocolsDsunte Wilson
 
HSRP ccna
HSRP ccna HSRP ccna
HSRP ccna
MohamedJafar5
 
4.4.1.3 packet tracer configuring a zone-based policy firewall (zpf) instru...
4.4.1.3 packet tracer   configuring a zone-based policy firewall (zpf) instru...4.4.1.3 packet tracer   configuring a zone-based policy firewall (zpf) instru...
4.4.1.3 packet tracer configuring a zone-based policy firewall (zpf) instru...
Salem Trabelsi
 
CCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan RoutingCCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan Routing
Vuz Dở Hơi
 
Big ip f5 ltm load balancing methods
Big ip f5 ltm load balancing methodsBig ip f5 ltm load balancing methods
Big ip f5 ltm load balancing methods
Utpal Sinha
 
vlan
vlanvlan
CCNA Lab 2-Configuring a Switch Part II
CCNA Lab 2-Configuring a Switch Part IICCNA Lab 2-Configuring a Switch Part II
CCNA Lab 2-Configuring a Switch Part II
Amir Jafari
 
Tunneling vpn security and implementation
Tunneling vpn security and implementationTunneling vpn security and implementation
Tunneling vpn security and implementation
Mohibullah Saail
 
Cours VTP
Cours VTPCours VTP
Vlans and inter vlan routing
Vlans and inter vlan routingVlans and inter vlan routing
Vlans and inter vlan routing
Mohammedseleim
 

What's hot (20)

Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
VLAN
VLANVLAN
VLAN
 
Cisco Router and Switch Security Hardening Guide
Cisco Router and Switch Security Hardening GuideCisco Router and Switch Security Hardening Guide
Cisco Router and Switch Security Hardening Guide
 
CCNA Lab 3-VLAN Configuration on Switch
CCNA Lab 3-VLAN Configuration on SwitchCCNA Lab 3-VLAN Configuration on Switch
CCNA Lab 3-VLAN Configuration on Switch
 
Vlan
VlanVlan
Vlan
 
Checkpoint Firewall for Dummies
Checkpoint Firewall for Dummies Checkpoint Firewall for Dummies
Checkpoint Firewall for Dummies
 
First hop redundancy
First hop redundancyFirst hop redundancy
First hop redundancy
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
 
DMVPN
DMVPNDMVPN
DMVPN
 
CCNA Routing Protocols
CCNA Routing ProtocolsCCNA Routing Protocols
CCNA Routing Protocols
 
HSRP ccna
HSRP ccna HSRP ccna
HSRP ccna
 
4.4.1.3 packet tracer configuring a zone-based policy firewall (zpf) instru...
4.4.1.3 packet tracer   configuring a zone-based policy firewall (zpf) instru...4.4.1.3 packet tracer   configuring a zone-based policy firewall (zpf) instru...
4.4.1.3 packet tracer configuring a zone-based policy firewall (zpf) instru...
 
CCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan RoutingCCNAv5 - S2: Chapter5 Inter Vlan Routing
CCNAv5 - S2: Chapter5 Inter Vlan Routing
 
Big ip f5 ltm load balancing methods
Big ip f5 ltm load balancing methodsBig ip f5 ltm load balancing methods
Big ip f5 ltm load balancing methods
 
vlan
vlanvlan
vlan
 
CCNA Lab 2-Configuring a Switch Part II
CCNA Lab 2-Configuring a Switch Part IICCNA Lab 2-Configuring a Switch Part II
CCNA Lab 2-Configuring a Switch Part II
 
Tunneling vpn security and implementation
Tunneling vpn security and implementationTunneling vpn security and implementation
Tunneling vpn security and implementation
 
Cours VTP
Cours VTPCours VTP
Cours VTP
 
Router commands
Router commandsRouter commands
Router commands
 
Vlans and inter vlan routing
Vlans and inter vlan routingVlans and inter vlan routing
Vlans and inter vlan routing
 

Viewers also liked

CCNA R&S-16-Analyzing Classful IPv4 Networks
CCNA R&S-16-Analyzing Classful IPv4 NetworksCCNA R&S-16-Analyzing Classful IPv4 Networks
CCNA R&S-16-Analyzing Classful IPv4 Networks
Amir Jafari
 
CCNA R&S-06-Fundamentals of TCP-IP Transport and Applications
CCNA R&S-06-Fundamentals of TCP-IP Transport and ApplicationsCCNA R&S-06-Fundamentals of TCP-IP Transport and Applications
CCNA R&S-06-Fundamentals of TCP-IP Transport and Applications
Amir Jafari
 
CCNA R&S-10-Implementing Ethernet Virtual LANs
CCNA R&S-10-Implementing Ethernet Virtual LANsCCNA R&S-10-Implementing Ethernet Virtual LANs
CCNA R&S-10-Implementing Ethernet Virtual LANs
Amir Jafari
 
CCNA R&S-15-Perspectives on IPv4 Subnetting
CCNA R&S-15-Perspectives on IPv4 SubnettingCCNA R&S-15-Perspectives on IPv4 Subnetting
CCNA R&S-15-Perspectives on IPv4 Subnetting
Amir Jafari
 
CCNA R&S-01-Introduction to Cisco Certified Network Associate
CCNA R&S-01-Introduction to Cisco Certified Network AssociateCCNA R&S-01-Introduction to Cisco Certified Network Associate
CCNA R&S-01-Introduction to Cisco Certified Network Associate
Amir Jafari
 
CCNA R&S-17-Analyzing Subnet Masks
CCNA R&S-17-Analyzing Subnet MasksCCNA R&S-17-Analyzing Subnet Masks
CCNA R&S-17-Analyzing Subnet Masks
Amir Jafari
 
CCNA R&S-12-Spanning Tree Protocol Concepts
CCNA R&S-12-Spanning Tree Protocol ConceptsCCNA R&S-12-Spanning Tree Protocol Concepts
CCNA R&S-12-Spanning Tree Protocol Concepts
Amir Jafari
 
CCNA R&S-11-Troubleshooting Ethernet LANs
CCNA R&S-11-Troubleshooting Ethernet LANsCCNA R&S-11-Troubleshooting Ethernet LANs
CCNA R&S-11-Troubleshooting Ethernet LANs
Amir Jafari
 
CCNA R&S-09-Configuring Ethernet Switching
CCNA R&S-09-Configuring Ethernet SwitchingCCNA R&S-09-Configuring Ethernet Switching
CCNA R&S-09-Configuring Ethernet Switching
Amir Jafari
 
CCNA R&S-20-Configuring IPv4 Addresses and Routes
CCNA R&S-20-Configuring IPv4 Addresses and RoutesCCNA R&S-20-Configuring IPv4 Addresses and Routes
CCNA R&S-20-Configuring IPv4 Addresses and Routes
Amir Jafari
 
Smart powetr grids
Smart powetr gridsSmart powetr grids
Smart powetr grids
Amir Jafari
 
CCNA R&S-19-Operating Cisco Routers
CCNA R&S-19-Operating Cisco RoutersCCNA R&S-19-Operating Cisco Routers
CCNA R&S-19-Operating Cisco Routers
Amir Jafari
 
CCCNA R&S-03-Fundamentals of Ethernet LANs
CCCNA R&S-03-Fundamentals of Ethernet LANsCCCNA R&S-03-Fundamentals of Ethernet LANs
CCCNA R&S-03-Fundamentals of Ethernet LANs
Amir Jafari
 
CCNA R&S-13-Spanning Tree Protocol Implementation
CCNA R&S-13-Spanning Tree Protocol ImplementationCCNA R&S-13-Spanning Tree Protocol Implementation
CCNA R&S-13-Spanning Tree Protocol Implementation
Amir Jafari
 
CCCNA R&S-02-The TCP-IP and OSI Networking Models
CCCNA R&S-02-The TCP-IP and OSI Networking ModelsCCCNA R&S-02-The TCP-IP and OSI Networking Models
CCCNA R&S-02-The TCP-IP and OSI Networking Models
Amir Jafari
 
CCNA R&S-18-Analyzing Existing Subnets
CCNA R&S-18-Analyzing Existing SubnetsCCNA R&S-18-Analyzing Existing Subnets
CCNA R&S-18-Analyzing Existing Subnets
Amir Jafari
 
CCCNA R&S-04-Fundamentals of WANs
CCCNA R&S-04-Fundamentals of WANsCCCNA R&S-04-Fundamentals of WANs
CCCNA R&S-04-Fundamentals of WANs
Amir Jafari
 

Viewers also liked (17)

CCNA R&S-16-Analyzing Classful IPv4 Networks
CCNA R&S-16-Analyzing Classful IPv4 NetworksCCNA R&S-16-Analyzing Classful IPv4 Networks
CCNA R&S-16-Analyzing Classful IPv4 Networks
 
CCNA R&S-06-Fundamentals of TCP-IP Transport and Applications
CCNA R&S-06-Fundamentals of TCP-IP Transport and ApplicationsCCNA R&S-06-Fundamentals of TCP-IP Transport and Applications
CCNA R&S-06-Fundamentals of TCP-IP Transport and Applications
 
CCNA R&S-10-Implementing Ethernet Virtual LANs
CCNA R&S-10-Implementing Ethernet Virtual LANsCCNA R&S-10-Implementing Ethernet Virtual LANs
CCNA R&S-10-Implementing Ethernet Virtual LANs
 
CCNA R&S-15-Perspectives on IPv4 Subnetting
CCNA R&S-15-Perspectives on IPv4 SubnettingCCNA R&S-15-Perspectives on IPv4 Subnetting
CCNA R&S-15-Perspectives on IPv4 Subnetting
 
CCNA R&S-01-Introduction to Cisco Certified Network Associate
CCNA R&S-01-Introduction to Cisco Certified Network AssociateCCNA R&S-01-Introduction to Cisco Certified Network Associate
CCNA R&S-01-Introduction to Cisco Certified Network Associate
 
CCNA R&S-17-Analyzing Subnet Masks
CCNA R&S-17-Analyzing Subnet MasksCCNA R&S-17-Analyzing Subnet Masks
CCNA R&S-17-Analyzing Subnet Masks
 
CCNA R&S-12-Spanning Tree Protocol Concepts
CCNA R&S-12-Spanning Tree Protocol ConceptsCCNA R&S-12-Spanning Tree Protocol Concepts
CCNA R&S-12-Spanning Tree Protocol Concepts
 
CCNA R&S-11-Troubleshooting Ethernet LANs
CCNA R&S-11-Troubleshooting Ethernet LANsCCNA R&S-11-Troubleshooting Ethernet LANs
CCNA R&S-11-Troubleshooting Ethernet LANs
 
CCNA R&S-09-Configuring Ethernet Switching
CCNA R&S-09-Configuring Ethernet SwitchingCCNA R&S-09-Configuring Ethernet Switching
CCNA R&S-09-Configuring Ethernet Switching
 
CCNA R&S-20-Configuring IPv4 Addresses and Routes
CCNA R&S-20-Configuring IPv4 Addresses and RoutesCCNA R&S-20-Configuring IPv4 Addresses and Routes
CCNA R&S-20-Configuring IPv4 Addresses and Routes
 
Smart powetr grids
Smart powetr gridsSmart powetr grids
Smart powetr grids
 
CCNA R&S-19-Operating Cisco Routers
CCNA R&S-19-Operating Cisco RoutersCCNA R&S-19-Operating Cisco Routers
CCNA R&S-19-Operating Cisco Routers
 
CCCNA R&S-03-Fundamentals of Ethernet LANs
CCCNA R&S-03-Fundamentals of Ethernet LANsCCCNA R&S-03-Fundamentals of Ethernet LANs
CCCNA R&S-03-Fundamentals of Ethernet LANs
 
CCNA R&S-13-Spanning Tree Protocol Implementation
CCNA R&S-13-Spanning Tree Protocol ImplementationCCNA R&S-13-Spanning Tree Protocol Implementation
CCNA R&S-13-Spanning Tree Protocol Implementation
 
CCCNA R&S-02-The TCP-IP and OSI Networking Models
CCCNA R&S-02-The TCP-IP and OSI Networking ModelsCCCNA R&S-02-The TCP-IP and OSI Networking Models
CCCNA R&S-02-The TCP-IP and OSI Networking Models
 
CCNA R&S-18-Analyzing Existing Subnets
CCNA R&S-18-Analyzing Existing SubnetsCCNA R&S-18-Analyzing Existing Subnets
CCNA R&S-18-Analyzing Existing Subnets
 
CCCNA R&S-04-Fundamentals of WANs
CCCNA R&S-04-Fundamentals of WANsCCCNA R&S-04-Fundamentals of WANs
CCCNA R&S-04-Fundamentals of WANs
 

Similar to CCNA Lab 5-Configuring Inter-VLAN Routing

CCNA Lab 1-Configuring a Switch Part I
CCNA Lab 1-Configuring a Switch Part ICCNA Lab 1-Configuring a Switch Part I
CCNA Lab 1-Configuring a Switch Part I
Amir Jafari
 
3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf
arif hamidi
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2alan moreno
 
Vlan lab
Vlan labVlan lab
Vlan lab
tmim8
 
Lab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routingLab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routing
Muhd Mu'izuddin
 
Exercise 4c stp rapid pvst+ question
Exercise 4c   stp rapid pvst+ questionExercise 4c   stp rapid pvst+ question
Exercise 4c stp rapid pvst+ question
sufi1248
 
The bryant advantage 150 commands
The bryant advantage 150 commandsThe bryant advantage 150 commands
The bryant advantage 150 commandsAreej Khasawneh
 
Pe1 configuring pvst+ rapid pvst+
Pe1   configuring pvst+  rapid pvst+Pe1   configuring pvst+  rapid pvst+
Pe1 configuring pvst+ rapid pvst+
mohdsyahmi789
 
Praktikum Lab 14 - Switch Security Configuration.docx
Praktikum Lab 14 - Switch Security Configuration.docxPraktikum Lab 14 - Switch Security Configuration.docx
Praktikum Lab 14 - Switch Security Configuration.docx
Ihsan Ihsan
 
Day 14.2 configuringvla ns
Day 14.2 configuringvla nsDay 14.2 configuringvla ns
Day 14.2 configuringvla ns
CYBERINTELLIGENTS
 
ccna (vlanning exam)
ccna (vlanning  exam) ccna (vlanning  exam)
ccna (vlanning exam)
Mina Firoozgohar
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructor
Salem Trabelsi
 
Icnd210 s02l01
Icnd210 s02l01Icnd210 s02l01
Icnd210 s02l01
computerlenguyen
 
Creating ethernet vla ns on catalyst switches
Creating ethernet vla ns on catalyst switchesCreating ethernet vla ns on catalyst switches
Creating ethernet vla ns on catalyst switches
abeforu
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchi
Leandro Uglar
 
How to Configure QinQ?
How to Configure QinQ?How to Configure QinQ?
How to Configure QinQ?
Huanetwork
 
CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6
Chaing Ravuth
 
Ccnp3 lab 3_3_en
Ccnp3 lab 3_3_enCcnp3 lab 3_3_en
Ccnp3 lab 3_3_en
Omar Herrera
 

Similar to CCNA Lab 5-Configuring Inter-VLAN Routing (20)

CCNA Lab 1-Configuring a Switch Part I
CCNA Lab 1-Configuring a Switch Part ICCNA Lab 1-Configuring a Switch Part I
CCNA Lab 1-Configuring a Switch Part I
 
3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
 
Vlan lab
Vlan labVlan lab
Vlan lab
 
Lab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routingLab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routing
 
Lab6.4.1
Lab6.4.1Lab6.4.1
Lab6.4.1
 
Exercise 4c stp rapid pvst+ question
Exercise 4c   stp rapid pvst+ questionExercise 4c   stp rapid pvst+ question
Exercise 4c stp rapid pvst+ question
 
The bryant advantage 150 commands
The bryant advantage 150 commandsThe bryant advantage 150 commands
The bryant advantage 150 commands
 
Pe1 configuring pvst+ rapid pvst+
Pe1   configuring pvst+  rapid pvst+Pe1   configuring pvst+  rapid pvst+
Pe1 configuring pvst+ rapid pvst+
 
Praktikum Lab 14 - Switch Security Configuration.docx
Praktikum Lab 14 - Switch Security Configuration.docxPraktikum Lab 14 - Switch Security Configuration.docx
Praktikum Lab 14 - Switch Security Configuration.docx
 
Day 14.2 configuringvla ns
Day 14.2 configuringvla nsDay 14.2 configuringvla ns
Day 14.2 configuringvla ns
 
ccna (vlanning exam)
ccna (vlanning  exam) ccna (vlanning  exam)
ccna (vlanning exam)
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructor
 
Icnd210 s02l01
Icnd210 s02l01Icnd210 s02l01
Icnd210 s02l01
 
Creating ethernet vla ns on catalyst switches
Creating ethernet vla ns on catalyst switchesCreating ethernet vla ns on catalyst switches
Creating ethernet vla ns on catalyst switches
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchi
 
How to Configure QinQ?
How to Configure QinQ?How to Configure QinQ?
How to Configure QinQ?
 
CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6
 
RFI
RFIRFI
RFI
 
Ccnp3 lab 3_3_en
Ccnp3 lab 3_3_enCcnp3 lab 3_3_en
Ccnp3 lab 3_3_en
 

Recently uploaded

FIDO Alliance Osaka Seminar: FIDO Security Aspects.pdf
FIDO Alliance Osaka Seminar: FIDO Security Aspects.pdfFIDO Alliance Osaka Seminar: FIDO Security Aspects.pdf
FIDO Alliance Osaka Seminar: FIDO Security Aspects.pdf
FIDO Alliance
 
FIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdf
FIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdfFIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdf
FIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdf
FIDO Alliance
 
"Impact of front-end architecture on development cost", Viktor Turskyi
"Impact of front-end architecture on development cost", Viktor Turskyi"Impact of front-end architecture on development cost", Viktor Turskyi
"Impact of front-end architecture on development cost", Viktor Turskyi
Fwdays
 
Designing Great Products: The Power of Design and Leadership by Chief Designe...
Designing Great Products: The Power of Design and Leadership by Chief Designe...Designing Great Products: The Power of Design and Leadership by Chief Designe...
Designing Great Products: The Power of Design and Leadership by Chief Designe...
Product School
 
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
UiPathCommunity
 
JMeter webinar - integration with InfluxDB and Grafana
JMeter webinar - integration with InfluxDB and GrafanaJMeter webinar - integration with InfluxDB and Grafana
JMeter webinar - integration with InfluxDB and Grafana
RTTS
 
Bits & Pixels using AI for Good.........
Bits & Pixels using AI for Good.........Bits & Pixels using AI for Good.........
Bits & Pixels using AI for Good.........
Alison B. Lowndes
 
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
DanBrown980551
 
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMsTo Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
Paul Groth
 
Knowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and backKnowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and back
Elena Simperl
 
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Thierry Lestable
 
Accelerate your Kubernetes clusters with Varnish Caching
Accelerate your Kubernetes clusters with Varnish CachingAccelerate your Kubernetes clusters with Varnish Caching
Accelerate your Kubernetes clusters with Varnish Caching
Thijs Feryn
 
ODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User GroupODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User Group
CatarinaPereira64715
 
Transcript: Selling digital books in 2024: Insights from industry leaders - T...
Transcript: Selling digital books in 2024: Insights from industry leaders - T...Transcript: Selling digital books in 2024: Insights from industry leaders - T...
Transcript: Selling digital books in 2024: Insights from industry leaders - T...
BookNet Canada
 
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Ramesh Iyer
 
UiPath Test Automation using UiPath Test Suite series, part 4
UiPath Test Automation using UiPath Test Suite series, part 4UiPath Test Automation using UiPath Test Suite series, part 4
UiPath Test Automation using UiPath Test Suite series, part 4
DianaGray10
 
FIDO Alliance Osaka Seminar: Overview.pdf
FIDO Alliance Osaka Seminar: Overview.pdfFIDO Alliance Osaka Seminar: Overview.pdf
FIDO Alliance Osaka Seminar: Overview.pdf
FIDO Alliance
 
DevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA ConnectDevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA Connect
Kari Kakkonen
 
When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...
Elena Simperl
 
AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...
AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...
AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...
Product School
 

Recently uploaded (20)

FIDO Alliance Osaka Seminar: FIDO Security Aspects.pdf
FIDO Alliance Osaka Seminar: FIDO Security Aspects.pdfFIDO Alliance Osaka Seminar: FIDO Security Aspects.pdf
FIDO Alliance Osaka Seminar: FIDO Security Aspects.pdf
 
FIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdf
FIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdfFIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdf
FIDO Alliance Osaka Seminar: The WebAuthn API and Discoverable Credentials.pdf
 
"Impact of front-end architecture on development cost", Viktor Turskyi
"Impact of front-end architecture on development cost", Viktor Turskyi"Impact of front-end architecture on development cost", Viktor Turskyi
"Impact of front-end architecture on development cost", Viktor Turskyi
 
Designing Great Products: The Power of Design and Leadership by Chief Designe...
Designing Great Products: The Power of Design and Leadership by Chief Designe...Designing Great Products: The Power of Design and Leadership by Chief Designe...
Designing Great Products: The Power of Design and Leadership by Chief Designe...
 
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
 
JMeter webinar - integration with InfluxDB and Grafana
JMeter webinar - integration with InfluxDB and GrafanaJMeter webinar - integration with InfluxDB and Grafana
JMeter webinar - integration with InfluxDB and Grafana
 
Bits & Pixels using AI for Good.........
Bits & Pixels using AI for Good.........Bits & Pixels using AI for Good.........
Bits & Pixels using AI for Good.........
 
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
 
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMsTo Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
 
Knowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and backKnowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and back
 
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
 
Accelerate your Kubernetes clusters with Varnish Caching
Accelerate your Kubernetes clusters with Varnish CachingAccelerate your Kubernetes clusters with Varnish Caching
Accelerate your Kubernetes clusters with Varnish Caching
 
ODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User GroupODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User Group
 
Transcript: Selling digital books in 2024: Insights from industry leaders - T...
Transcript: Selling digital books in 2024: Insights from industry leaders - T...Transcript: Selling digital books in 2024: Insights from industry leaders - T...
Transcript: Selling digital books in 2024: Insights from industry leaders - T...
 
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
 
UiPath Test Automation using UiPath Test Suite series, part 4
UiPath Test Automation using UiPath Test Suite series, part 4UiPath Test Automation using UiPath Test Suite series, part 4
UiPath Test Automation using UiPath Test Suite series, part 4
 
FIDO Alliance Osaka Seminar: Overview.pdf
FIDO Alliance Osaka Seminar: Overview.pdfFIDO Alliance Osaka Seminar: Overview.pdf
FIDO Alliance Osaka Seminar: Overview.pdf
 
DevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA ConnectDevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA Connect
 
When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...
 
AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...
AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...
AI for Every Business: Unlocking Your Product's Universal Potential by VP of ...
 

CCNA Lab 5-Configuring Inter-VLAN Routing

  • 1. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 1 of 12 CCNA Lab 5: Configuring Inter-VLAN Routing
  • 2. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 2 of 12 Table of Contents Page 1- Objectives...................................................................................................................................................4 2- Scenario .....................................................................................................................................................4 3- Equipment List............................................................................................................................................4 4- Topology Diagram ......................................................................................................................................5 5-Addressing Table.........................................................................................................................................6 6-Detailed Lab Steps ......................................................................................................................................7 6-1 Part 1: Prepare the Network (Cable, Erase, and Reload the Switch and Router)................................7 6-1-1- Designing and Configuration ........................................................................................................7 6-1-2- Verification ....................................................................................................................................7 6-1-3 Troubleshooting .............................................................................................................................7 6-2: Part 2: Perform Basic Device Configurations on Switchs and Router.................................................7 6-2-1- Designing and Configuration ........................................................................................................7 6-2-2- Verification ....................................................................................................................................8 6-3: Part 3: Configure Switch and Router to Accept Incoming SSH Connections......................................8 6-3-1- Designing and Configuration ........................................................................................................8 6-3-2- Verification ....................................................................................................................................8 6-4: Part 4: Configure and Activate Ethernet Interfaces .............................................................................8 6-5: Part 5: Configure VLANs on the Switch...............................................................................................9 6-5-1- Designing and Configuration ........................................................................................................9 6-5-2- Verification ................................................................................................................................. 10 6-6: Part 6: Configuring EtherChannels................................................................................................... 11 6-6-1- Designing and Configuration ..................................................................................................... 11 6-6-2- Verification ................................................................................................................................. 11 6-7: Part 7: Configuring Routing to VLANs using 802.1Q on Routers..................................................... 11 6-7-1- Designing and Configuration ..................................................................................................... 11
  • 3. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 3 of 12 6-7-2- Verification ................................................................................................................................. 12
  • 4. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 4 of 12 1- Objectives Demonstrate and explain the impact of Layer 3 boundaries imposed by creating VLANs Configure a router to support 802.1q trunking on a Fast Ethernet interface Configure a router with subinterfaces corresponding to the configured VLANs Demonstrate and explain inter-VLAN routing 2- Scenario In this lab you will practice configuring routing to VLANs using 802.1Q on routers and verifying Inter-VLAN routing. 3- Equipment List Three Cisco Catalyst 2960 Switchs with Cisco IOS Release 12.2. The Cisco implementation of SSH requires Cisco IOS Software to support RSA authentication and minimum DES encryption— a cryptographic software image. Cisco 1841 Integrated Services Router with Cisco IOS Software Release 12.4T Three PCs that will run Windows XP or later
  • 5. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 5 of 12 4- Topology Diagram
  • 6. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 6 of 12 5-Addressing Table Port Assignments – Switch 2 Interface Configuration Table – Router 1
  • 7. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 7 of 12 6-Detailed Lab Steps 6-1 Part 1: Prepare the Network (Cable, Erase, and Reload the Switch and Router) 6-1-1- Designing and Configuration Step 1: Cable a network Cable a network that is similar to the one in the topology diagram. Step 2: Clear the configuration on the switch and router Clear the configuration on all the switchs based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Part 1. Remove the router startup configuration file from NVRAM. Router#erase startup-config 6-1-2- Verification Do the verification based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Part 1. 6-1-3 Troubleshooting Do the troubleshooting based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Part 1. 6-2: Part 2: Perform Basic Device Configurations on Switchs and Router 6-2-1- Designing and Configuration Perform Basic Device Configurations on all the switchs and router based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Part 2. Notice: Configure the Layer 3 address of the switchs.
  • 8. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 8 of 12 For management purposes, we will use VLAN 99. First, you will create the new VLAN 99 on the switch. Then you will set the IP address of the switch to 172.17.99.11 with a subnet mask of 255.255.255.0 on the internal virtual interface VLAN 99. S1(config-vlan)#vlan 99 S1(config-vlan)#name management S1(config-vlan)#exit S1(config)#interface vlan99 S1(config-if)#ip address 172.17.99.11 255.255.255.0 S1(config-if)#no shutdown Do the same configuration on switches S2 and S3 based on the Addressing Table. A management VLAN is any VLAN that you configure to access the management capabilities of a switch. 6-2-2- Verification Do the verification based on the “CCNA Lab 1-Configuring a Switch Part I”, Detailed Lab Steps, Detailed Lab Steps, Part 2. 6-3: Part 3: Configure Switch and Router to Accept Incoming SSH Connections 6-3-1- Designing and Configuration Configure all the switchs and router to accept Incoming SSH Connections based on the “CCNA Lab 2- Configuring a Switch Part 2”, Detailed Lab Steps, Part 4. 6-3-2- Verification Do the verification based on the the “CCNA Lab 2-Configuring a Switch Part 2”, Detailed Lab Steps, Part 4. 6-4: Part 4: Configure and Activate Ethernet Interfaces Step 1: Configure the PCs All three PCs with the IP addresses and default gateways should be configured.
  • 9. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 9 of 12 6-5: Part 5: Configure VLANs on the Switch 6-5-1- Designing and Configuration Step 1: Create VLANs on switch S1 There are four VLANS configured for this lab: VLAN 10 (faculty); VLAN 20 (students); VLAN 30 (guest); and VLAN 99 (management). S1(config)#vlan 10 S1(config-vlan)#name faculty S1(config-vlan)#vlan 20 S1(config-vlan)#name students S1(config-vlan)#vlan 30 S1(config-vlan)#name guest S1(config-vlan)#end Step 2: Configure and name VLANs on switches S2 and S3 Create and name VLANs 10, 20, 30, and 99 on S2 and S3 using the commands from Step 1. Step 3: Assign switch ports to VLANs on S2 Refer to the port assignment table, ports are assigned to VLANs in interface configuration mode. The commands are shown for S2. S2(config)#interface range fa0/6-10 S2(config-if-range)#switchport access vlan 30 S2(config-if-range)#interface range fa0/11-17 S2(config-if-range)#switchport access vlan 10 S2(config-if-range)#interface range fa0/18-24 S2(config-if-range)#switchport access vlan 20 S2(config-if-range)#end Step 4: Configure trunking and the native VLAN for the trunking ports on all switches Use the interface range command in global configuration mode to simplify configuring trunking. S1(config)#interface range fa0/1-4 S1(config-if-range)#switchport mode trunk S1(config-if-range)#switchport trunk native vlan 99
  • 10. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 10 of 12 S1(config-if)#switchport trunk allowed vlan 10,20,30,99 S1(config-if-range)#end S2(config)# interface range fa0/1-4 S2(config-if-range)#switchport mode trunk S2(config-if-range)#switchport trunk native vlan 99 S2(config-if)#switchport trunk allowed vlan 10,20,30,99 S2(config-if-range)#end S3(config)# interface range fa0/1-4 S3(config-if-range)#switchport mode trunk S3(config-if-range)#switchport trunk native vlan 99 S3(config-if)#switchport trunk allowed vlan 10,20,30,99 S3(config-if-range)#end 6-5-2- Verification Step 1: Verify that the VLANs have been created on S1, S2 and S3 Use the show vlan brief command to verify that the VLANs have been created. S2#show vlan brief Step 2: Determine which ports have been added Use the show vlan id vlan-number command on S2 to see which ports are assigned to VLAN 10. You can also view VLAN assignment information using the show interfaces interface switchport command. S2#show vlan id 30 S2#show interfaces fastEthernet 0/6 switchport Step 3: Verify that the trunks have been configured on S1, S2 and S3 Verify that the trunks have been configured with the show interface trunk command. S1#show interface trunk S1#show interfaces status Step 4: Verify that the switches can communicate From S1, ping the management address on both S2 and S3. S1#ping 172.17.99.12 S1#ping 172.17.99.13
  • 11. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 11 of 12 6-6: Part 6: Configuring EtherChannels 6-6-1- Designing and Configuration Step 1: Configuring Manual EtherChannel S1(config)#interface range fa0/1-2 S1(config-if-range)# channel-group 1 mode on S1(config)#interface range fa0/3-4 S1(config-if-range)# channel-group 2 mode on S2(config)#interface range fa0/1-2 S2(config-if-range)# channel-group 1 mode on S2(config)#interface range fa0/3-4 S2(config-if-range)# channel-group 2 mode on S3(config)#interface range fa0/1-2 S3(config-if-range)# channel-group 1 mode on S3(config)#interface range fa0/3-4 S3(config-if-range)# channel-group 2 mode on 6-6-2- Verification Step 1: Verify that the PortChannels have been created on S1, S2 and S3 S1#show etherchannel summary S1#show interfaces status 6-7: Part 7: Configuring Routing to VLANs using 802.1Q on Routers 6-7-1- Designing and Configuration Step 1: Configure the trunking interface on R1 Router on a Stick (ROAS) uses router VLAN trunking configuration to give the router a logical router interface connected to each VLAN, and therefore each subnet that sits on a separate VLAN.
  • 12. amir-jafari.com ©2015 Amir Jafari – www.amir-Jafari.com. All rights reserved. Page 12 of 12 R1(config)#interface fastethernet 0/1 R1(config-if)#no shutdown R1(config-if)#interface fastethernet 0/1.1 R1(config-subif)#encapsulation dot1q 1 R1(config-subif)#ip address 172.17.1.1 255.255.255.0 R1(config-if)#interface fastethernet 0/1.10 R1(config-subif)#encapsulation dot1q 10 R1(config-subif)#ip address 172.17.10.1 255.255.255.0 R1(config-if)#interface fastethernet 0/1.20 R1(config-subif)#encapsulation dot1q 20 R1(config-subif)#ip address 172.17.20.1 255.255.255.0 R1(config-if)#interface fastethernet 0/1.30 R1(config-subif)#encapsulation dot1q 30 R1(config-subif)#ip address 172.17.30.1 255.255.255.0 R1(config-if)#interface fastethernet 0/1.99 R1(config-subif)#encapsulation dot1q 99 native R1(config-subif)#ip address 172.17.99.1 255.255.255.0 6-7-2- Verification Step 1: Checking the routing table on R1 R1#show ip route Step 2: Verify Router Trunking Configuration show vlans command to Match Sample Router Trunking Configuration. R1#show vlans Step 3: Ping PC1 from PC2 Ping from host PC2 to host PC1. Routing between VLANs has been configured so the ping should be successful.