SlideShare a Scribd company logo
1 of 8
How to Configure QinQ?
The QinQ technology is called VLAN dot1q tunnel, 802.1Q tunnel, VLAN Stacking
technology. The standard comes from IEEE 802.1ad and it is the expansion of the
802.1Q protocol. QinQ adds one layer of 802.1Q tag (VLAN tag) based on the
original 802.1Q packet head. With the double layers of tags, the VLAN quantity is
increased to 802.1Q.
How to configure the QinQ? Here we will list two occasions and they can be applied
to Huawei switches higher level than Quidway S2700 and with EI version, Huawei
S3700 switches and Quidway S5700, etc.
Example for Configuring basic QinQ
Networking Requirements
As shown in Figure 1, there are two enterprises on the network, Enterprise 1 and
Enterprise 2. Enterprise 1 has two office locations, and Enterprise 2 has 2 office
locations. The office locations of the two enterprises access SwitchA and SwitchB of
the ISP network. A non-Huawei device with the TPID value 0x9100 exists on the
public network. The requirements are as follows:
 Enterprise 1 and Enterprise 2 plans their VLANs independently.
 Traffic of the two branches is transparently transmitted on the public network.
Users using the same services in the two branches are allowed to communicate
and users using different services are isolated.
You can configure QinQ to meet the preceding requirements. VLAN 100 provided by
the public network can be used to implement communication of Enterprise 1 in the
two branches and VLAN 200 is used for Enterprise 2. You can set the TPID value in
the outer VLAN on the interface that connects the non-Huawei device to implement
communication between devices.
Figure 1Configuring basic QinQ
1
Configuration Roadmap
The configuration roadmap is as follows:
1. Configure VLAN 100 and VLAN 200 on both SwitchA and SwitchB. Set the link
type of the interface to QinQ and add the interfaces to VLAN. In this way, different
outer VLAN tags are added to different services.
2. Add interfaces connecting to the public network on SwitchA and SwitchB to VLAN
100 and VLAN 200 to permit packets from these VLANs to pass through.
3. Set the TPID values in the outer VLAN tag on interfaces connecting to the public
network on SwitchA and SwitchB to implement communication between the device
with devices from other vendors.
Procedure
Step 1 Create VLANs.
# Create VLAN 100 and VLAN 200 on SwitchA.
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 100 200
# Create VLAN 100 and VLAN 200 on SwitchB.
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan batch 100 200
2
Step 2 Set the link type of the interface to QinQ.
# Configure GE0/0/1 and GE0/0/2 of SwitchA as QinQ interfaces. Set the VLAN of
GE0/0/1 to VLAN 100 and the VLAN of GE0/0/2 to VLAN 200.
[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/1] port default vlan 100
[SwitchA-GigabitEthernet0/0/1] quit
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type dot1q-tunnel
[SwitchA-GigabitEthernet0/0/2] port default vlan 200
[SwitchA-GigabitEthernet0/0/2] quit
# Configure GE0/0/1 and GE0/0/2 of SwitchB as QinQ interfaces. Set the VLAN of
GE0/0/1 to
VLAN 100 and the VLAN of GE0/0/2 to VLAN 200. The configuration procedure of
SwitchB is the same as that of SwitchA.
Step 3 Configure the interface connecting to the public network on the switch.
# Add GE0/0/3 of SwitchA to VLAN 100 and VLAN 200.
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] port link-type trunk
[SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200
[SwitchA-GigabitEthernet0/0/3] quit
# Add GE0/0/3 of SwitchB to VLAN 100 and VLAN 200. The configuration
procedure of
SwitchB is the same as that of SwitchA.
Step 4 Configure the TPID value for an outer VLAN tag
# Set the TPID value of an outer VLAN tag to 0x9100 on SwitchA.
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] qinq protocol 9100
# Set the TPID value of an outer VLAN tag to 0x9100 on SwitchB.
[SwitchB] interface gigabitethernet 0/0/3
[SwitchB-GigabitEthernet0/0/3] qinq protocol 9100
Step 5 Verify the configuration.
In Enterprise 1, ping a PC of a VLAN in a branch from a PC of the same VLAN in
another branch. If the two PCs can ping each other, internal users of Enterprise 1 can
communicate.
In Enterprise 2, ping a PC of a VLAN in a branch from a PC of the same VLAN in
3
another branch. If the two PCs can ping each other, internal users of Enterprise 2 can
communicate.
Ping a PC in a VLAN of Enterprise 2 in a branch from a PC in the same VLAN of
Enterprise 1 in either branch. If the two PCs cannot ping each other, users in
Enterprise 1 and Enterprise 2 are isolated.
----End
Configuration Files
Configuration file of SwitchA
#
sysname SwitchA
#
vlan batch 100 200
#
interface GigabitEthernet0/0/1
port link-type dot1q-tunnel
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type dot1q-tunnel
port default vlan 200
#
interface GigabitEthernet0/0/3
qinq protocol 9100
port link-type trunk
port trunk allow-pass vlan 100 200
#
return
Configuration file of SwitchB
#
sysname SwitchB
#
vlan batch 100 200
#
interface GigabitEthernet0/0/1
port link-type dot1q-tunnel
port default vlan 100
#
interface GigabitEthernet0/0/2
port link-type dot1q-tunnel
port default vlan 200
#
interface GigabitEthernet0/0/3
4
qinq protocol 9100
port link-type trunk
port trunk allow-pass vlan 100 200
#
return
Example for Configuring Selective QinQ
Networking Requirements
As shown in Figure 2, Internet access users (using PCs) and VoIP users (using VoIP
terminals) connect to the ISP network through SwitchA and SwitchB and
communicate with each other through the ISP network.
It is required that packets of PCs and VoIP terminals be tagged VLAN 2 and VLAN 3
when the packets are transmitted through the ISP network.
Figure 2 Networking diagram for configuring selective QinQ
Configuration Roadmap
The configuration roadmap is as follows:
1. Create VLANs on SwitchA and SwitchB.
2. Configure link types of interfaces on SwitchA and SwitchB and add interfaces to
VLANs.
3. Configure selective QinQ on the interfaces of SwitchA and SwitchB.
Procedure
Step 1 Create VLANs.
# On SwitchA, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN
tag to be added.
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 2 3
5
# On SwitchB, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN
tag to be added.
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan batch 2 3
Step 2 Configure selective QinQ on interfaces.
# Configure GE0/0/1 on SwitchA.
[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type hybrid
[SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3
[SwitchA-GigabitEthernet0/0/1] qinq vlan-translation enable
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2
[SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3
[SwitchA-GigabitEthernet0/0/1] quit
# Configure GE0/0/1 on SwitchB.
[SwitchB] interface gigabitethernet 0/0/1
[SwitchB-GigabitEthernet0/0/1] port link-type hybrid
[SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3
[SwitchB-GigabitEthernet0/0/1] qinq vlan-translation enable
[SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2
[SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3
[SwitchB-GigabitEthernet0/0/1] quit
Step 3 Configure other interfaces.
# Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchA.
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type trunk
[SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3
[SwitchA-GigabitEthernet0/0/2] quit
# Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchB.
[SwitchB] interface gigabitethernet 0/0/2
[SwitchB-GigabitEthernet0/0/2] port link-type trunk
[SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3
[SwitchB-GigabitEthernet0/0/2] quit
Step 4 Verify the configuration.
If the configurations on SwitchA and SwitchB are correct:
 PCs can communicate with each other through the ISP network.
 VoIP terminals can communicate with each other through the ISP network.
----End
6
Configuration Files
Configuration file of SwitchA
#
sysname SwitchA
#
vlan batch 2 to 3
#
interface GigabitEthernet0/0/1
qinq vlan-translation enable
port hybrid untagged vlan 2 to 3
port vlan-stacking vlan 100 stack-vlan 2
port vlan-stacking vlan 300 stack-vlan 3
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 3
#
return
Configuration file of SwitchB
#
sysname SwitchB
#
vlan batch 2 to 3
#
interface GigabitEthernet0/0/1
qinq vlan-translation enable
port hybrid untagged vlan 2 to 3
port vlan-stacking vlan 100 stack-vlan 2
port vlan-stacking vlan 300 stack-vlan 3
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 3
#
return
The more information about technical support you can consult with our engineer the
e-mail address is as below:
support@huanetwork.com
More related topics
7
How to Configure the QinQ VLAN?
The Difference between Layer2/Layer3 Switches
How to Replace a Power Module or Fan Module for Huawei Switches?
How to Configure the QinQ VLAN Private Line Service for Huawei MA5616?
More Huawei products and Reviews you can visit: http://www.huanetwork.com/blog
Huanetwork.com is a world leading Huawei networking products supplier, we supply original new
Huawei networking equipments, including Huawei switches, Huawei routers, Huaweisymantec
security products, Huawei IAD, Huawei SFP and other Huawei networking products. Our
customers include telecom operators, Huawei resellers, ISP and system integrators. Right now
most of our sales are contributed by regular customers.
In Huanetwork Lab, also we have Huawei OLT, MDU, DSLAM and switch for customer do
remote testing, any potential customer are welcome to login to our lab. If you need a total Huawei
FTTx solution or Huawei ADSL solution for your network, also you may feel free to contact us.
Our website: http://www.huanetwork.com
Telephone: +852-30501940
Email: sales@huanetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
8

More Related Content

What's hot

CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01Irsandi Hasan
 
How to configure port security in cisco switch
How to configure port security in cisco switchHow to configure port security in cisco switch
How to configure port security in cisco switchIT Tech
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)DH Da Lat
 
Huawei switch configuration commands
Huawei switch configuration commandsHuawei switch configuration commands
Huawei switch configuration commandsHuanetwork
 
MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)NetProtocol Xpert
 
Palo Alto Virtual firewall deployment guide on OpenStack Cloud
Palo Alto Virtual firewall deployment guide on OpenStack Cloud  Palo Alto Virtual firewall deployment guide on OpenStack Cloud
Palo Alto Virtual firewall deployment guide on OpenStack Cloud Ajeet Singh
 
Building DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPNBuilding DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPNCisco Canada
 
Switch configuration
Switch configurationSwitch configuration
Switch configurationMuuluu
 
Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Abdul Basit
 
Vlans and inter vlan routing
Vlans and inter vlan routingVlans and inter vlan routing
Vlans and inter vlan routingMohammedseleim
 

What's hot (20)

CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01CCNA v6.0 ITN - Chapter 01
CCNA v6.0 ITN - Chapter 01
 
How to configure port security in cisco switch
How to configure port security in cisco switchHow to configure port security in cisco switch
How to configure port security in cisco switch
 
Design of network
Design of networkDesign of network
Design of network
 
Inter-AS MPLS VPN Deployment
Inter-AS MPLS VPN DeploymentInter-AS MPLS VPN Deployment
Inter-AS MPLS VPN Deployment
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
Huawei switch configuration commands
Huawei switch configuration commandsHuawei switch configuration commands
Huawei switch configuration commands
 
13. eigrp and ospf
13. eigrp and ospf13. eigrp and ospf
13. eigrp and ospf
 
MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)
 
EVPN Introduction
EVPN IntroductionEVPN Introduction
EVPN Introduction
 
Ccna command
Ccna commandCcna command
Ccna command
 
Palo Alto Virtual firewall deployment guide on OpenStack Cloud
Palo Alto Virtual firewall deployment guide on OpenStack Cloud  Palo Alto Virtual firewall deployment guide on OpenStack Cloud
Palo Alto Virtual firewall deployment guide on OpenStack Cloud
 
Building DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPNBuilding DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPN
 
Mikrotik Tutorial
Mikrotik TutorialMikrotik Tutorial
Mikrotik Tutorial
 
About IPv6
About IPv6About IPv6
About IPv6
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
 
Switch configuration
Switch configurationSwitch configuration
Switch configuration
 
Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2
 
Vlans and inter vlan routing
Vlans and inter vlan routingVlans and inter vlan routing
Vlans and inter vlan routing
 
Ethernet
EthernetEthernet
Ethernet
 

Viewers also liked

Huawei Router Basic Configuration Command
Huawei Router Basic Configuration CommandHuawei Router Basic Configuration Command
Huawei Router Basic Configuration CommandHuanetwork
 
What’s the Difference Between GPON and EPON
What’s the Difference Between GPON and EPONWhat’s the Difference Between GPON and EPON
What’s the Difference Between GPON and EPONHuanetwork
 
How to configure the logical distance of gpon
How to configure the logical distance of gponHow to configure the logical distance of gpon
How to configure the logical distance of gponHuanetwork
 
How to configure eo c services for huawei ol ts
How to configure eo c services for huawei ol tsHow to configure eo c services for huawei ol ts
How to configure eo c services for huawei ol tsHuanetwork
 
The Review of Huawei OLT
The Review of Huawei OLTThe Review of Huawei OLT
The Review of Huawei OLTHuanetwork
 
Huawei s5710-ei-power-module-test-report
Huawei s5710-ei-power-module-test-reportHuawei s5710-ei-power-module-test-report
Huawei s5710-ei-power-module-test-reportHuanetwork
 
OptiX OSN 8800 Slot Description
OptiX OSN 8800 Slot DescriptionOptiX OSN 8800 Slot Description
OptiX OSN 8800 Slot DescriptionHuanetwork
 
Configuring the Device as a PPPoE Client on Huawei AR1200
Configuring the Device as a PPPoE Client on Huawei AR1200Configuring the Device as a PPPoE Client on Huawei AR1200
Configuring the Device as a PPPoE Client on Huawei AR1200Huanetwork
 
How to query traffic of a port on the huawei ma5616
How to query traffic of a port on the huawei ma5616How to query traffic of a port on the huawei ma5616
How to query traffic of a port on the huawei ma5616Huanetwork
 
Huawei HG8245 Two Version GE / FE
Huawei HG8245 Two Version GE / FEHuawei HG8245 Two Version GE / FE
Huawei HG8245 Two Version GE / FEHuanetwork
 
How to add and delete ont on the olt device
How to add and delete ont on the olt deviceHow to add and delete ont on the olt device
How to add and delete ont on the olt deviceHuanetwork
 
Huawei ftth c b e2 e solution
Huawei ftth c b e2 e solutionHuawei ftth c b e2 e solution
Huawei ftth c b e2 e solutionHuanetwork
 
Ont, olt and mdu in gpon technology
Ont, olt and mdu in gpon technologyOnt, olt and mdu in gpon technology
Ont, olt and mdu in gpon technologyHuanetwork
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsBootcamp SCL
 
Wiki and solution in ftth technology
Wiki and solution in ftth technologyWiki and solution in ftth technology
Wiki and solution in ftth technologyHuanetwork
 
Huawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuanetwork
 
dBm : a mathematical interpretation
dBm : a mathematical interpretationdBm : a mathematical interpretation
dBm : a mathematical interpretationMapYourTech
 

Viewers also liked (19)

Huawei Router Basic Configuration Command
Huawei Router Basic Configuration CommandHuawei Router Basic Configuration Command
Huawei Router Basic Configuration Command
 
What’s the Difference Between GPON and EPON
What’s the Difference Between GPON and EPONWhat’s the Difference Between GPON and EPON
What’s the Difference Between GPON and EPON
 
How to configure the logical distance of gpon
How to configure the logical distance of gponHow to configure the logical distance of gpon
How to configure the logical distance of gpon
 
How to configure eo c services for huawei ol ts
How to configure eo c services for huawei ol tsHow to configure eo c services for huawei ol ts
How to configure eo c services for huawei ol ts
 
The Review of Huawei OLT
The Review of Huawei OLTThe Review of Huawei OLT
The Review of Huawei OLT
 
Huawei ac6005
Huawei ac6005Huawei ac6005
Huawei ac6005
 
Huawei s5710-ei-power-module-test-report
Huawei s5710-ei-power-module-test-reportHuawei s5710-ei-power-module-test-report
Huawei s5710-ei-power-module-test-report
 
OptiX OSN 8800 Slot Description
OptiX OSN 8800 Slot DescriptionOptiX OSN 8800 Slot Description
OptiX OSN 8800 Slot Description
 
Configuring the Device as a PPPoE Client on Huawei AR1200
Configuring the Device as a PPPoE Client on Huawei AR1200Configuring the Device as a PPPoE Client on Huawei AR1200
Configuring the Device as a PPPoE Client on Huawei AR1200
 
What is gpon
What is gponWhat is gpon
What is gpon
 
How to query traffic of a port on the huawei ma5616
How to query traffic of a port on the huawei ma5616How to query traffic of a port on the huawei ma5616
How to query traffic of a port on the huawei ma5616
 
Huawei HG8245 Two Version GE / FE
Huawei HG8245 Two Version GE / FEHuawei HG8245 Two Version GE / FE
Huawei HG8245 Two Version GE / FE
 
How to add and delete ont on the olt device
How to add and delete ont on the olt deviceHow to add and delete ont on the olt device
How to add and delete ont on the olt device
 
Huawei ftth c b e2 e solution
Huawei ftth c b e2 e solutionHuawei ftth c b e2 e solution
Huawei ftth c b e2 e solution
 
Ont, olt and mdu in gpon technology
Ont, olt and mdu in gpon technologyOnt, olt and mdu in gpon technology
Ont, olt and mdu in gpon technology
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI Commands
 
Wiki and solution in ftth technology
Wiki and solution in ftth technologyWiki and solution in ftth technology
Wiki and solution in ftth technology
 
Huawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet mode
 
dBm : a mathematical interpretation
dBm : a mathematical interpretationdBm : a mathematical interpretation
dBm : a mathematical interpretation
 

Similar to How to Configure QinQ?

3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdfarif hamidi
 
VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANSanilinvns
 
Day 5 VIRTUAL LANS
Day 5 VIRTUAL LANSDay 5 VIRTUAL LANS
Day 5 VIRTUAL LANSanilinvns
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2alan moreno
 
Exercise 4c stp rapid pvst+ question
Exercise 4c   stp rapid pvst+ questionExercise 4c   stp rapid pvst+ question
Exercise 4c stp rapid pvst+ questionsufi1248
 
Pe1 configuring pvst+ rapid pvst+
Pe1   configuring pvst+  rapid pvst+Pe1   configuring pvst+  rapid pvst+
Pe1 configuring pvst+ rapid pvst+mohdsyahmi789
 
Vlan lab
Vlan labVlan lab
Vlan labtmim8
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructorSalem Trabelsi
 
Ccna3 lab 9_1_5b_en
Ccna3 lab 9_1_5b_enCcna3 lab 9_1_5b_en
Ccna3 lab 9_1_5b_envin424
 
Virtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptxVirtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptxmarunkumareee77
 
Switch inter vlan_routing
Switch inter vlan_routingSwitch inter vlan_routing
Switch inter vlan_routingRamesh Thumburu
 
69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phoneRayan Darine
 
Virtual Local Area Network
Virtual Local Area NetworkVirtual Local Area Network
Virtual Local Area NetworkAtakan ATAK
 
VLANs_Module_3.pptx
VLANs_Module_3.pptxVLANs_Module_3.pptx
VLANs_Module_3.pptxBOURY1
 
CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6Chaing Ravuth
 

Similar to How to Configure QinQ? (20)

3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf3.4.6-lab---configure-vlans-and-trunking.pdf
3.4.6-lab---configure-vlans-and-trunking.pdf
 
Presentation
PresentationPresentation
Presentation
 
Presentation
PresentationPresentation
Presentation
 
VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANS
 
Day 5 VIRTUAL LANS
Day 5 VIRTUAL LANSDay 5 VIRTUAL LANS
Day 5 VIRTUAL LANS
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
 
Exercise 4c stp rapid pvst+ question
Exercise 4c   stp rapid pvst+ questionExercise 4c   stp rapid pvst+ question
Exercise 4c stp rapid pvst+ question
 
Pe1 configuring pvst+ rapid pvst+
Pe1   configuring pvst+  rapid pvst+Pe1   configuring pvst+  rapid pvst+
Pe1 configuring pvst+ rapid pvst+
 
Vlan lab
Vlan labVlan lab
Vlan lab
 
6.5.1.3 packet tracer layer 2 vlan security instructor
6.5.1.3 packet tracer   layer 2 vlan security instructor6.5.1.3 packet tracer   layer 2 vlan security instructor
6.5.1.3 packet tracer layer 2 vlan security instructor
 
Ccna3 lab 9_1_5b_en
Ccna3 lab 9_1_5b_enCcna3 lab 9_1_5b_en
Ccna3 lab 9_1_5b_en
 
Virtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptxVirtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptx
 
Switch inter vlan_routing
Switch inter vlan_routingSwitch inter vlan_routing
Switch inter vlan_routing
 
69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone
 
Virtual Local Area Network
Virtual Local Area NetworkVirtual Local Area Network
Virtual Local Area Network
 
VLANs_Module_3.pptx
VLANs_Module_3.pptxVLANs_Module_3.pptx
VLANs_Module_3.pptx
 
Lab6.4.1
Lab6.4.1Lab6.4.1
Lab6.4.1
 
Day 14.2 configuringvla ns
Day 14.2 configuringvla nsDay 14.2 configuringvla ns
Day 14.2 configuringvla ns
 
corporate network
corporate networkcorporate network
corporate network
 
CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6
 

More from Huanetwork

Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)Huanetwork
 
What are the differences between huawei and cisco wlan products
What are the differences between huawei and cisco wlan productsWhat are the differences between huawei and cisco wlan products
What are the differences between huawei and cisco wlan productsHuanetwork
 
How to configure inband management for huawei ma5616
How to configure inband management for huawei ma5616How to configure inband management for huawei ma5616
How to configure inband management for huawei ma5616Huanetwork
 
What is huawei quidway s5300 gigabit switches
What is huawei quidway s5300 gigabit switchesWhat is huawei quidway s5300 gigabit switches
What is huawei quidway s5300 gigabit switchesHuanetwork
 
Huawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuanetwork
 
Huawei opti x osn 1500 boards
Huawei opti x osn 1500 boardsHuawei opti x osn 1500 boards
Huawei opti x osn 1500 boardsHuanetwork
 
Huawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and featuresHuawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and featuresHuanetwork
 
Huawei s3700 cables
Huawei s3700 cablesHuawei s3700 cables
Huawei s3700 cablesHuanetwork
 
Differences of Huawei S5700 Series LI, SI, EI and HI
Differences of Huawei S5700 Series LI, SI, EI and HIDifferences of Huawei S5700 Series LI, SI, EI and HI
Differences of Huawei S5700 Series LI, SI, EI and HIHuanetwork
 
Huawei s9300 terabit routing switch
Huawei s9300 terabit routing switchHuawei s9300 terabit routing switch
Huawei s9300 terabit routing switchHuanetwork
 
Huanetwork Design the Network Solution Free for You
Huanetwork Design the Network Solution Free for YouHuanetwork Design the Network Solution Free for You
Huanetwork Design the Network Solution Free for YouHuanetwork
 
Configuration difference between ipv6 and ipv4
Configuration difference between ipv6 and ipv4Configuration difference between ipv6 and ipv4
Configuration difference between ipv6 and ipv4Huanetwork
 
How to configure the gpon ftth layer 2 internet access service on the nms
How to configure the gpon ftth layer 2 internet access service on the nmsHow to configure the gpon ftth layer 2 internet access service on the nms
How to configure the gpon ftth layer 2 internet access service on the nmsHuanetwork
 
How to configure i pv6 services in the fttb c (no hgws) scenario
How to configure i pv6 services in the fttb c (no hgws) scenarioHow to configure i pv6 services in the fttb c (no hgws) scenario
How to configure i pv6 services in the fttb c (no hgws) scenarioHuanetwork
 
Version support for huawei s7700 components (1)
Version support for huawei s7700 components (1)Version support for huawei s7700 components (1)
Version support for huawei s7700 components (1)Huanetwork
 
Huawei router component selection guide – purchase list
Huawei router component selection guide – purchase listHuawei router component selection guide – purchase list
Huawei router component selection guide – purchase listHuanetwork
 
Naming conventions of huawei parts
Naming conventions of huawei partsNaming conventions of huawei parts
Naming conventions of huawei partsHuanetwork
 
Huawei AR Series Routers Application Comparison and Overview
Huawei AR Series Routers Application Comparison and OverviewHuawei AR Series Routers Application Comparison and Overview
Huawei AR Series Routers Application Comparison and OverviewHuanetwork
 
The feature of huawei ma5600
The feature of huawei ma5600The feature of huawei ma5600
The feature of huawei ma5600Huanetwork
 
Optical module
Optical moduleOptical module
Optical moduleHuanetwork
 

More from Huanetwork (20)

Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
Huanetwork x dsl solution - huawei adsl2+ and vdsl2 solution)
 
What are the differences between huawei and cisco wlan products
What are the differences between huawei and cisco wlan productsWhat are the differences between huawei and cisco wlan products
What are the differences between huawei and cisco wlan products
 
How to configure inband management for huawei ma5616
How to configure inband management for huawei ma5616How to configure inband management for huawei ma5616
How to configure inband management for huawei ma5616
 
What is huawei quidway s5300 gigabit switches
What is huawei quidway s5300 gigabit switchesWhat is huawei quidway s5300 gigabit switches
What is huawei quidway s5300 gigabit switches
 
Huawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet modeHuawei osn3500 typical networking in packet mode
Huawei osn3500 typical networking in packet mode
 
Huawei opti x osn 1500 boards
Huawei opti x osn 1500 boardsHuawei opti x osn 1500 boards
Huawei opti x osn 1500 boards
 
Huawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and featuresHuawei net engine5000e core router chassis and features
Huawei net engine5000e core router chassis and features
 
Huawei s3700 cables
Huawei s3700 cablesHuawei s3700 cables
Huawei s3700 cables
 
Differences of Huawei S5700 Series LI, SI, EI and HI
Differences of Huawei S5700 Series LI, SI, EI and HIDifferences of Huawei S5700 Series LI, SI, EI and HI
Differences of Huawei S5700 Series LI, SI, EI and HI
 
Huawei s9300 terabit routing switch
Huawei s9300 terabit routing switchHuawei s9300 terabit routing switch
Huawei s9300 terabit routing switch
 
Huanetwork Design the Network Solution Free for You
Huanetwork Design the Network Solution Free for YouHuanetwork Design the Network Solution Free for You
Huanetwork Design the Network Solution Free for You
 
Configuration difference between ipv6 and ipv4
Configuration difference between ipv6 and ipv4Configuration difference between ipv6 and ipv4
Configuration difference between ipv6 and ipv4
 
How to configure the gpon ftth layer 2 internet access service on the nms
How to configure the gpon ftth layer 2 internet access service on the nmsHow to configure the gpon ftth layer 2 internet access service on the nms
How to configure the gpon ftth layer 2 internet access service on the nms
 
How to configure i pv6 services in the fttb c (no hgws) scenario
How to configure i pv6 services in the fttb c (no hgws) scenarioHow to configure i pv6 services in the fttb c (no hgws) scenario
How to configure i pv6 services in the fttb c (no hgws) scenario
 
Version support for huawei s7700 components (1)
Version support for huawei s7700 components (1)Version support for huawei s7700 components (1)
Version support for huawei s7700 components (1)
 
Huawei router component selection guide – purchase list
Huawei router component selection guide – purchase listHuawei router component selection guide – purchase list
Huawei router component selection guide – purchase list
 
Naming conventions of huawei parts
Naming conventions of huawei partsNaming conventions of huawei parts
Naming conventions of huawei parts
 
Huawei AR Series Routers Application Comparison and Overview
Huawei AR Series Routers Application Comparison and OverviewHuawei AR Series Routers Application Comparison and Overview
Huawei AR Series Routers Application Comparison and Overview
 
The feature of huawei ma5600
The feature of huawei ma5600The feature of huawei ma5600
The feature of huawei ma5600
 
Optical module
Optical moduleOptical module
Optical module
 

Recently uploaded

APIForce Zurich 5 April Automation LPDG
APIForce Zurich 5 April  Automation LPDGAPIForce Zurich 5 April  Automation LPDG
APIForce Zurich 5 April Automation LPDGMarianaLemus7
 
Understanding the Laravel MVC Architecture
Understanding the Laravel MVC ArchitectureUnderstanding the Laravel MVC Architecture
Understanding the Laravel MVC ArchitecturePixlogix Infotech
 
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Mark Simos
 
"Federated learning: out of reach no matter how close",Oleksandr Lapshyn
"Federated learning: out of reach no matter how close",Oleksandr Lapshyn"Federated learning: out of reach no matter how close",Oleksandr Lapshyn
"Federated learning: out of reach no matter how close",Oleksandr LapshynFwdays
 
CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):comworks
 
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...Patryk Bandurski
 
"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr BaganFwdays
 
Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024Enterprise Knowledge
 
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024BookNet Canada
 
AI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsAI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsMemoori
 
Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Commit University
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii SoldatenkoFwdays
 
Powerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time ClashPowerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time Clashcharlottematthew16
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfAlex Barbosa Coqueiro
 
Dev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebDev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebUiPathCommunity
 
Install Stable Diffusion in windows machine
Install Stable Diffusion in windows machineInstall Stable Diffusion in windows machine
Install Stable Diffusion in windows machinePadma Pradeep
 
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek SchlawackFwdays
 
Vertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering TipsVertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering TipsMiki Katsuragi
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLScyllaDB
 

Recently uploaded (20)

APIForce Zurich 5 April Automation LPDG
APIForce Zurich 5 April  Automation LPDGAPIForce Zurich 5 April  Automation LPDG
APIForce Zurich 5 April Automation LPDG
 
Understanding the Laravel MVC Architecture
Understanding the Laravel MVC ArchitectureUnderstanding the Laravel MVC Architecture
Understanding the Laravel MVC Architecture
 
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
 
"Federated learning: out of reach no matter how close",Oleksandr Lapshyn
"Federated learning: out of reach no matter how close",Oleksandr Lapshyn"Federated learning: out of reach no matter how close",Oleksandr Lapshyn
"Federated learning: out of reach no matter how close",Oleksandr Lapshyn
 
CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):
 
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
 
"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan
 
Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024
 
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
 
AI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsAI as an Interface for Commercial Buildings
AI as an Interface for Commercial Buildings
 
Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko
 
DMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special EditionDMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special Edition
 
Powerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time ClashPowerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time Clash
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdf
 
Dev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebDev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio Web
 
Install Stable Diffusion in windows machine
Install Stable Diffusion in windows machineInstall Stable Diffusion in windows machine
Install Stable Diffusion in windows machine
 
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
 
Vertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering TipsVertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering Tips
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQL
 

How to Configure QinQ?

  • 1. How to Configure QinQ? The QinQ technology is called VLAN dot1q tunnel, 802.1Q tunnel, VLAN Stacking technology. The standard comes from IEEE 802.1ad and it is the expansion of the 802.1Q protocol. QinQ adds one layer of 802.1Q tag (VLAN tag) based on the original 802.1Q packet head. With the double layers of tags, the VLAN quantity is increased to 802.1Q. How to configure the QinQ? Here we will list two occasions and they can be applied to Huawei switches higher level than Quidway S2700 and with EI version, Huawei S3700 switches and Quidway S5700, etc. Example for Configuring basic QinQ Networking Requirements As shown in Figure 1, there are two enterprises on the network, Enterprise 1 and Enterprise 2. Enterprise 1 has two office locations, and Enterprise 2 has 2 office locations. The office locations of the two enterprises access SwitchA and SwitchB of the ISP network. A non-Huawei device with the TPID value 0x9100 exists on the public network. The requirements are as follows:  Enterprise 1 and Enterprise 2 plans their VLANs independently.  Traffic of the two branches is transparently transmitted on the public network. Users using the same services in the two branches are allowed to communicate and users using different services are isolated. You can configure QinQ to meet the preceding requirements. VLAN 100 provided by the public network can be used to implement communication of Enterprise 1 in the two branches and VLAN 200 is used for Enterprise 2. You can set the TPID value in the outer VLAN on the interface that connects the non-Huawei device to implement communication between devices. Figure 1Configuring basic QinQ 1
  • 2. Configuration Roadmap The configuration roadmap is as follows: 1. Configure VLAN 100 and VLAN 200 on both SwitchA and SwitchB. Set the link type of the interface to QinQ and add the interfaces to VLAN. In this way, different outer VLAN tags are added to different services. 2. Add interfaces connecting to the public network on SwitchA and SwitchB to VLAN 100 and VLAN 200 to permit packets from these VLANs to pass through. 3. Set the TPID values in the outer VLAN tag on interfaces connecting to the public network on SwitchA and SwitchB to implement communication between the device with devices from other vendors. Procedure Step 1 Create VLANs. # Create VLAN 100 and VLAN 200 on SwitchA. <HUAWEI> system-view [HUAWEI] sysname SwitchA [SwitchA] vlan batch 100 200 # Create VLAN 100 and VLAN 200 on SwitchB. <HUAWEI> system-view [HUAWEI] sysname SwitchB [SwitchB] vlan batch 100 200 2
  • 3. Step 2 Set the link type of the interface to QinQ. # Configure GE0/0/1 and GE0/0/2 of SwitchA as QinQ interfaces. Set the VLAN of GE0/0/1 to VLAN 100 and the VLAN of GE0/0/2 to VLAN 200. [SwitchA] interface gigabitethernet 0/0/1 [SwitchA-GigabitEthernet0/0/1] port link-type dot1q-tunnel [SwitchA-GigabitEthernet0/0/1] port default vlan 100 [SwitchA-GigabitEthernet0/0/1] quit [SwitchA] interface gigabitethernet 0/0/2 [SwitchA-GigabitEthernet0/0/2] port link-type dot1q-tunnel [SwitchA-GigabitEthernet0/0/2] port default vlan 200 [SwitchA-GigabitEthernet0/0/2] quit # Configure GE0/0/1 and GE0/0/2 of SwitchB as QinQ interfaces. Set the VLAN of GE0/0/1 to VLAN 100 and the VLAN of GE0/0/2 to VLAN 200. The configuration procedure of SwitchB is the same as that of SwitchA. Step 3 Configure the interface connecting to the public network on the switch. # Add GE0/0/3 of SwitchA to VLAN 100 and VLAN 200. [SwitchA] interface gigabitethernet 0/0/3 [SwitchA-GigabitEthernet0/0/3] port link-type trunk [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 200 [SwitchA-GigabitEthernet0/0/3] quit # Add GE0/0/3 of SwitchB to VLAN 100 and VLAN 200. The configuration procedure of SwitchB is the same as that of SwitchA. Step 4 Configure the TPID value for an outer VLAN tag # Set the TPID value of an outer VLAN tag to 0x9100 on SwitchA. [SwitchA] interface gigabitethernet 0/0/3 [SwitchA-GigabitEthernet0/0/3] qinq protocol 9100 # Set the TPID value of an outer VLAN tag to 0x9100 on SwitchB. [SwitchB] interface gigabitethernet 0/0/3 [SwitchB-GigabitEthernet0/0/3] qinq protocol 9100 Step 5 Verify the configuration. In Enterprise 1, ping a PC of a VLAN in a branch from a PC of the same VLAN in another branch. If the two PCs can ping each other, internal users of Enterprise 1 can communicate. In Enterprise 2, ping a PC of a VLAN in a branch from a PC of the same VLAN in 3
  • 4. another branch. If the two PCs can ping each other, internal users of Enterprise 2 can communicate. Ping a PC in a VLAN of Enterprise 2 in a branch from a PC in the same VLAN of Enterprise 1 in either branch. If the two PCs cannot ping each other, users in Enterprise 1 and Enterprise 2 are isolated. ----End Configuration Files Configuration file of SwitchA # sysname SwitchA # vlan batch 100 200 # interface GigabitEthernet0/0/1 port link-type dot1q-tunnel port default vlan 100 # interface GigabitEthernet0/0/2 port link-type dot1q-tunnel port default vlan 200 # interface GigabitEthernet0/0/3 qinq protocol 9100 port link-type trunk port trunk allow-pass vlan 100 200 # return Configuration file of SwitchB # sysname SwitchB # vlan batch 100 200 # interface GigabitEthernet0/0/1 port link-type dot1q-tunnel port default vlan 100 # interface GigabitEthernet0/0/2 port link-type dot1q-tunnel port default vlan 200 # interface GigabitEthernet0/0/3 4
  • 5. qinq protocol 9100 port link-type trunk port trunk allow-pass vlan 100 200 # return Example for Configuring Selective QinQ Networking Requirements As shown in Figure 2, Internet access users (using PCs) and VoIP users (using VoIP terminals) connect to the ISP network through SwitchA and SwitchB and communicate with each other through the ISP network. It is required that packets of PCs and VoIP terminals be tagged VLAN 2 and VLAN 3 when the packets are transmitted through the ISP network. Figure 2 Networking diagram for configuring selective QinQ Configuration Roadmap The configuration roadmap is as follows: 1. Create VLANs on SwitchA and SwitchB. 2. Configure link types of interfaces on SwitchA and SwitchB and add interfaces to VLANs. 3. Configure selective QinQ on the interfaces of SwitchA and SwitchB. Procedure Step 1 Create VLANs. # On SwitchA, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN tag to be added. <HUAWEI> system-view [HUAWEI] sysname SwitchA [SwitchA] vlan batch 2 3 5
  • 6. # On SwitchB, create VLAN 2 and VLAN 3, that is, VLAN IDs of the outer VLAN tag to be added. <HUAWEI> system-view [HUAWEI] sysname SwitchB [SwitchB] vlan batch 2 3 Step 2 Configure selective QinQ on interfaces. # Configure GE0/0/1 on SwitchA. [SwitchA] interface gigabitethernet 0/0/1 [SwitchA-GigabitEthernet0/0/1] port link-type hybrid [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3 [SwitchA-GigabitEthernet0/0/1] qinq vlan-translation enable [SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2 [SwitchA-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3 [SwitchA-GigabitEthernet0/0/1] quit # Configure GE0/0/1 on SwitchB. [SwitchB] interface gigabitethernet 0/0/1 [SwitchB-GigabitEthernet0/0/1] port link-type hybrid [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 2 3 [SwitchB-GigabitEthernet0/0/1] qinq vlan-translation enable [SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 100 stack-vlan 2 [SwitchB-GigabitEthernet0/0/1] port vlan-stacking vlan 300 stack-vlan 3 [SwitchB-GigabitEthernet0/0/1] quit Step 3 Configure other interfaces. # Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchA. [SwitchA] interface gigabitethernet 0/0/2 [SwitchA-GigabitEthernet0/0/2] port link-type trunk [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3 [SwitchA-GigabitEthernet0/0/2] quit # Add GE0/0/2 to VLAN 2 and VLAN 3 on SwitchB. [SwitchB] interface gigabitethernet 0/0/2 [SwitchB-GigabitEthernet0/0/2] port link-type trunk [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3 [SwitchB-GigabitEthernet0/0/2] quit Step 4 Verify the configuration. If the configurations on SwitchA and SwitchB are correct:  PCs can communicate with each other through the ISP network.  VoIP terminals can communicate with each other through the ISP network. ----End 6
  • 7. Configuration Files Configuration file of SwitchA # sysname SwitchA # vlan batch 2 to 3 # interface GigabitEthernet0/0/1 qinq vlan-translation enable port hybrid untagged vlan 2 to 3 port vlan-stacking vlan 100 stack-vlan 2 port vlan-stacking vlan 300 stack-vlan 3 # interface GigabitEthernet0/0/2 port link-type trunk port trunk allow-pass vlan 2 to 3 # return Configuration file of SwitchB # sysname SwitchB # vlan batch 2 to 3 # interface GigabitEthernet0/0/1 qinq vlan-translation enable port hybrid untagged vlan 2 to 3 port vlan-stacking vlan 100 stack-vlan 2 port vlan-stacking vlan 300 stack-vlan 3 # interface GigabitEthernet0/0/2 port link-type trunk port trunk allow-pass vlan 2 to 3 # return The more information about technical support you can consult with our engineer the e-mail address is as below: support@huanetwork.com More related topics 7
  • 8. How to Configure the QinQ VLAN? The Difference between Layer2/Layer3 Switches How to Replace a Power Module or Fan Module for Huawei Switches? How to Configure the QinQ VLAN Private Line Service for Huawei MA5616? More Huawei products and Reviews you can visit: http://www.huanetwork.com/blog Huanetwork.com is a world leading Huawei networking products supplier, we supply original new Huawei networking equipments, including Huawei switches, Huawei routers, Huaweisymantec security products, Huawei IAD, Huawei SFP and other Huawei networking products. Our customers include telecom operators, Huawei resellers, ISP and system integrators. Right now most of our sales are contributed by regular customers. In Huanetwork Lab, also we have Huawei OLT, MDU, DSLAM and switch for customer do remote testing, any potential customer are welcome to login to our lab. If you need a total Huawei FTTx solution or Huawei ADSL solution for your network, also you may feel free to contact us. Our website: http://www.huanetwork.com Telephone: +852-30501940 Email: sales@huanetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 8