SlideShare a Scribd company logo
Routing Basic Idea
Routing table
Switching Walkthrough
Directly connected Routes Walkthrough
Statically configured routes Walkthrough
Dynamic routing protocols
Passive inferfaces
Routing Information
Protocol (RIP)
Presented by,
Tharindu Sankalpa
17th batch
Routing Basic idea
 What is routing?
Routing is the process of selecting a optimal path to forward data packets in between or across
multiple networks.
 How routing happen?
Routers make routing decisions (path selection) based on routing information available on their
routing tables.
 Routing information?
Routing information can be considered as details about physical topology and status of the
network.
Routing table
Three types of routing table entries
 Directly connected routes are the routing table entries about a directly connected
destination network to one of the interfaces of the router.
 Statically configured routes are the routing table entries that network administers manually
configured on the router.
 Dynamically learned routes are the routing table entries learn by exchanging routing
information with the help of dynamic routing protocols.
Routing information base, is a data table stored in a router that
contain lists of routes to particular network destinations.
Let’s build the network
Device Models
Routers 2811
Switches 2960
192.168.4.0/24
192.168.1.0/24
192.168.2.0/24
192.168.3.0/24
Add serial ports
on R1 and R2
Power button
1.Turn OFF power
2. Add serial port
3. Turn ON power
Configure IP address on Hosts
Router(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.3 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface fastEthernet 0/1
R1(config-if)#ip address 192.168.4.2 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface serial 0/3/0
R1(config-if)#ip address 192.168.3.2 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1#write
Router(config)#hostname R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#interface serial 0/3/0
R2(config-if)#ip address 192.168.3.3 255.255.255.0
R2(config-if)#no shut
R2(config)#exit
R2#write
Router>
Router>en
Router#conf t
Router(config)#line con 0
Router(config-line)#exec-timeout 0
Router(config-line)#exit
Router(config)#no ip domain lookup
Configure R1 and R2
Let’s check the Routing tables
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, Serial0/3/0
C 192.168.4.0/24 is directly connected, FastEthernet0/1
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.2.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, Serial0/3/0
Switching Walkthrough
C:>ping 192.168.1.2
Pinging 192.168.1.2 with 32 bytes of data:
Reply from 192.168.1.2: bytes=32 time=31ms TTL=128
Reply from 192.168.1.2: bytes=32 time=7ms TTL=128
Reply from 192.168.1.2: bytes=32 time=13ms TTL=128
Reply from 192.168.1.2: bytes=32 time=16ms TTL=128
Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 7ms, Maximum = 31ms, Average = 16ms
Ping form Host A to Host B
Directly connected Routes
Walkthrough
Ping form Host A to Host C
C:>ping 192.168.4.1
Pinging 192.168.4.1 with 32 bytes of data:
Reply from 192.168.4.1: bytes=32 time=13ms TTL=127
Reply from 192.168.4.1: bytes=32 time=17ms TTL=127
Reply from 192.168.4.1: bytes=32 time=14ms TTL=127
Reply from 192.168.4.1: bytes=32 time=15ms TTL=127
Ping statistics for 192.168.4.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 13ms, Maximum = 17ms, Average = 14ms
Non-directly connected
routes Walkthrough
C:>ping 192.168.2.1
Pinging 192.168.2.1 with 32 bytes of data:
Reply from 192.168.1.3: Destination host unreachable.
Reply from 192.168.1.3: Destination host unreachable.
Reply from 192.168.1.3: Destination host unreachable.
Reply from 192.168.1.3: Destination host unreachable.
Ping statistics for 192.168.2.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
Ping form Host A to Host C
Non-directly connected
routes WalkthroughR1#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#ping 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/16 ms
Ping form R1 to Host C
Ping form R1 to R2
Dynamic Routing
Protocols
Dynamic routing protocols specify how routers automatically
exchange and distribute routing information.
Dynamic routing
protocols
Interior gateway
protocols (IGP)
Distance vector
protocols
Routing Information
Protocol (RIP)
Enhanced Interior
Gateway Routing
Protocol (EIGRP)
Link state routing
protocols
Open Shortest Path First
(OSPF)
Intermediate System to
Intermediate System
(IS-IS)
Exterior gateway
protocols (EGP)
Path vector routing
protocols
Border Gateway
Protocol (BGP)
Time to configure RIP
R1#show ip protocols
R1#conf t
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.3.0
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.4.0
R1(config-router)#^Z
R1#write
R2#conf t
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.2.0
R2(config-router)#^Z
R2#write
Let’s check the Routing tables
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, FastEthernet0/0
R 192.168.2.0/24 [120/1] via 192.168.3.3, 00:00:29, Serial0/3/0
C 192.168.3.0/24 is directly connected, Serial0/3/0
C 192.168.4.0/24 is directly connected, FastEthernet0/1
R1#show ip route rip
R 192.168.2.0/24 [120/1] via 192.168.3.3, 00:00:19, Serial0/3/0
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 192.168.1.0/24 [120/1] via 192.168.3.2, 00:00:19, Serial0/3/0
C 192.168.2.0/24 is directly connected, FastEthernet0/0
C 192.168.3.0/24 is directly connected, Serial0/3/0
R 192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:19, Serial0/3/0
R2#show ip route rip
R 192.168.1.0/24 [120/1] via 192.168.3.2, 00:00:17, Serial0/3/0
R 192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:17, Serial0/3/0
RIP routes Walkthrough
C:>ping 192.168.2.1
Pinging 192.168.2.1 with 32 bytes of data:
Reply from 192.168.2.1: bytes=32 time=36ms TTL=126
Reply from 192.168.2.1: bytes=32 time=14ms TTL=126
Reply from 192.168.2.1: bytes=32 time=26ms TTL=126
Reply from 192.168.2.1: bytes=32 time=15ms TTL=126
Ping statistics for 192.168.2.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 14ms, Maximum = 36ms, Average = 22ms
Ping form Host A to Host C
RIP routes Walkthrough
R1#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/37 ms
Ping form R1 to Host C
Passive interfaces
R1#conf t
R1(config)#router rip
R1(config-router)#passive-interface fastEthernet 0/0
R1(config-router)#passive-interface fastEthernet 0/1
R2#conf t
R2(config)#router rip
R2(config-router)#passive-interface fastEthernet 0/0
Full RIP update sending
Every 30 seconds

More Related Content

What's hot

Network Address Translation (NAT)
Network Address Translation (NAT)Network Address Translation (NAT)
Network Address Translation (NAT)
Joud Khattab
 
Static Routing
Static RoutingStatic Routing
Static Routing
Sachii Dosti
 
DDoS Mitigation using BGP Flowspec
DDoS Mitigation using BGP Flowspec DDoS Mitigation using BGP Flowspec
DDoS Mitigation using BGP Flowspec
APNIC
 
EIGRP (Enhanced Interior Gateway Routing Protocol)
EIGRP (Enhanced Interior Gateway Routing Protocol)EIGRP (Enhanced Interior Gateway Routing Protocol)
EIGRP (Enhanced Interior Gateway Routing Protocol)
NetProtocol Xpert
 
200 301-ccna
200 301-ccna200 301-ccna
200 301-ccna
Jasser Kouki
 
MPLS Traffic Engineering
MPLS Traffic EngineeringMPLS Traffic Engineering
MPLS Traffic Engineering
APNIC
 
OSPF Configuration
OSPF ConfigurationOSPF Configuration
OSPF Configuration
NetProtocol Xpert
 
MPLS (Multi-Protocol Label Switching)
MPLS (Multi-Protocol Label Switching)MPLS (Multi-Protocol Label Switching)
MPLS (Multi-Protocol Label Switching)
Vipin Sahu
 
CCNA Advanced Routing Protocols
CCNA Advanced Routing ProtocolsCCNA Advanced Routing Protocols
CCNA Advanced Routing ProtocolsDsunte Wilson
 
Routing Protocols
Routing Protocols Routing Protocols
Routing Protocols
KhushbirSinghSandhu
 
Vxlan deep dive session rev0.5 final
Vxlan deep dive session rev0.5   finalVxlan deep dive session rev0.5   final
Vxlan deep dive session rev0.5 final
KwonSun Bae
 
Ospf area types
Ospf area typesOspf area types
Ospf area types
Roger Perkin
 
Nat pat
Nat patNat pat
Routing Protocols
Routing ProtocolsRouting Protocols
Routing Protocols
NetProtocol Xpert
 
MPLS
MPLSMPLS

What's hot (20)

Network Address Translation (NAT)
Network Address Translation (NAT)Network Address Translation (NAT)
Network Address Translation (NAT)
 
Ospf.ppt
Ospf.pptOspf.ppt
Ospf.ppt
 
Static Routing
Static RoutingStatic Routing
Static Routing
 
DDoS Mitigation using BGP Flowspec
DDoS Mitigation using BGP Flowspec DDoS Mitigation using BGP Flowspec
DDoS Mitigation using BGP Flowspec
 
EIGRP (Enhanced Interior Gateway Routing Protocol)
EIGRP (Enhanced Interior Gateway Routing Protocol)EIGRP (Enhanced Interior Gateway Routing Protocol)
EIGRP (Enhanced Interior Gateway Routing Protocol)
 
200 301-ccna
200 301-ccna200 301-ccna
200 301-ccna
 
Doc6 mpls vpn-ppt
Doc6 mpls vpn-pptDoc6 mpls vpn-ppt
Doc6 mpls vpn-ppt
 
MPLS Traffic Engineering
MPLS Traffic EngineeringMPLS Traffic Engineering
MPLS Traffic Engineering
 
Ospf
 Ospf Ospf
Ospf
 
OSPF Configuration
OSPF ConfigurationOSPF Configuration
OSPF Configuration
 
MPLS (Multi-Protocol Label Switching)
MPLS (Multi-Protocol Label Switching)MPLS (Multi-Protocol Label Switching)
MPLS (Multi-Protocol Label Switching)
 
CCNA Advanced Routing Protocols
CCNA Advanced Routing ProtocolsCCNA Advanced Routing Protocols
CCNA Advanced Routing Protocols
 
Link state protocols.ppt
Link state protocols.pptLink state protocols.ppt
Link state protocols.ppt
 
Routing Protocols
Routing Protocols Routing Protocols
Routing Protocols
 
Vxlan deep dive session rev0.5 final
Vxlan deep dive session rev0.5   finalVxlan deep dive session rev0.5   final
Vxlan deep dive session rev0.5 final
 
Ospf area types
Ospf area typesOspf area types
Ospf area types
 
Nat pat
Nat patNat pat
Nat pat
 
Routing Protocols
Routing ProtocolsRouting Protocols
Routing Protocols
 
Mikro tik advanced training
Mikro tik advanced trainingMikro tik advanced training
Mikro tik advanced training
 
MPLS
MPLSMPLS
MPLS
 

Similar to Routing Information Protocol (RIP)

Chapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdfChapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdf
Buntha Chhay
 
Lab routing protocols eigrp
Lab routing protocols eigrpLab routing protocols eigrp
Lab routing protocols eigrpzafar85
 
Cisco Router EIGRP Config
Cisco Router EIGRP ConfigCisco Router EIGRP Config
Cisco Router EIGRP Config
Kadir CIKIS
 
第8讲 Rip和Igrp
第8讲 Rip和Igrp第8讲 Rip和Igrp
第8讲 Rip和IgrpF.l. Yu
 
Rip version1 configuration on Cisco router
Rip version1 configuration on Cisco routerRip version1 configuration on Cisco router
Rip version1 configuration on Cisco routertcpipguru
 
Eigrp
EigrpEigrp
EIGRP CCNA
EIGRP CCNAEIGRP CCNA
Network virtualization beyond vla ns-part2
Network virtualization beyond vla ns-part2Network virtualization beyond vla ns-part2
Network virtualization beyond vla ns-part2
IT Tech
 
Clase 4. Routing IP.pdf
Clase 4. Routing IP.pdfClase 4. Routing IP.pdf
Clase 4. Routing IP.pdf
FERNANDOBONILLA43
 
How to configure Default Routing
How to configure Default RoutingHow to configure Default Routing
How to configure Default Routingtcpipguru
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccnarobertoxe
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccnarobertoxe
 
Internet Technology Practical (Mumbai University) -2017
Internet Technology Practical  (Mumbai University) -2017Internet Technology Practical  (Mumbai University) -2017
Internet Technology Practical (Mumbai University) -2017
Satyendra Singh
 
Static Routing
Static RoutingStatic Routing
Static Routing
Kishore Kumar
 
02_N2_Chapter 2.pptx
02_N2_Chapter 2.pptx02_N2_Chapter 2.pptx
02_N2_Chapter 2.pptx
MohammadMahdiSoroush
 
06 tk 1073 network layer
06   tk 1073 network layer06   tk 1073 network layer
06 tk 1073 network layer
Setia Juli Irzal Ismail
 
Cisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel ConfigurationCisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel Configuration
Hamed Moghaddam
 

Similar to Routing Information Protocol (RIP) (20)

Chapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdfChapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdf
 
Lab routing protocols eigrp
Lab routing protocols eigrpLab routing protocols eigrp
Lab routing protocols eigrp
 
Cisco Router EIGRP Config
Cisco Router EIGRP ConfigCisco Router EIGRP Config
Cisco Router EIGRP Config
 
第8讲 Rip和Igrp
第8讲 Rip和Igrp第8讲 Rip和Igrp
第8讲 Rip和Igrp
 
Rip version1 configuration on Cisco router
Rip version1 configuration on Cisco routerRip version1 configuration on Cisco router
Rip version1 configuration on Cisco router
 
Eigrp
EigrpEigrp
Eigrp
 
EIGRP CCNA
EIGRP CCNAEIGRP CCNA
EIGRP CCNA
 
Network virtualization beyond vla ns-part2
Network virtualization beyond vla ns-part2Network virtualization beyond vla ns-part2
Network virtualization beyond vla ns-part2
 
Clase 4. Routing IP.pdf
Clase 4. Routing IP.pdfClase 4. Routing IP.pdf
Clase 4. Routing IP.pdf
 
How to configure Default Routing
How to configure Default RoutingHow to configure Default Routing
How to configure Default Routing
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Internet Technology Practical (Mumbai University) -2017
Internet Technology Practical  (Mumbai University) -2017Internet Technology Practical  (Mumbai University) -2017
Internet Technology Practical (Mumbai University) -2017
 
Static Routing
Static RoutingStatic Routing
Static Routing
 
Labs ospf
Labs ospfLabs ospf
Labs ospf
 
02_N2_Chapter 2.pptx
02_N2_Chapter 2.pptx02_N2_Chapter 2.pptx
02_N2_Chapter 2.pptx
 
06 tk 1073 network layer
06   tk 1073 network layer06   tk 1073 network layer
06 tk 1073 network layer
 
Cisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel ConfigurationCisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel Configuration
 

Recently uploaded

CFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptx
CFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptxCFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptx
CFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptx
R&R Consult
 
Final project report on grocery store management system..pdf
Final project report on grocery store management system..pdfFinal project report on grocery store management system..pdf
Final project report on grocery store management system..pdf
Kamal Acharya
 
Courier management system project report.pdf
Courier management system project report.pdfCourier management system project report.pdf
Courier management system project report.pdf
Kamal Acharya
 
Water Industry Process Automation and Control Monthly - May 2024.pdf
Water Industry Process Automation and Control Monthly - May 2024.pdfWater Industry Process Automation and Control Monthly - May 2024.pdf
Water Industry Process Automation and Control Monthly - May 2024.pdf
Water Industry Process Automation & Control
 
block diagram and signal flow graph representation
block diagram and signal flow graph representationblock diagram and signal flow graph representation
block diagram and signal flow graph representation
Divya Somashekar
 
Vaccine management system project report documentation..pdf
Vaccine management system project report documentation..pdfVaccine management system project report documentation..pdf
Vaccine management system project report documentation..pdf
Kamal Acharya
 
Immunizing Image Classifiers Against Localized Adversary Attacks
Immunizing Image Classifiers Against Localized Adversary AttacksImmunizing Image Classifiers Against Localized Adversary Attacks
Immunizing Image Classifiers Against Localized Adversary Attacks
gerogepatton
 
J.Yang, ICLR 2024, MLILAB, KAIST AI.pdf
J.Yang,  ICLR 2024, MLILAB, KAIST AI.pdfJ.Yang,  ICLR 2024, MLILAB, KAIST AI.pdf
J.Yang, ICLR 2024, MLILAB, KAIST AI.pdf
MLILAB
 
Gen AI Study Jams _ For the GDSC Leads in India.pdf
Gen AI Study Jams _ For the GDSC Leads in India.pdfGen AI Study Jams _ For the GDSC Leads in India.pdf
Gen AI Study Jams _ For the GDSC Leads in India.pdf
gdsczhcet
 
HYDROPOWER - Hydroelectric power generation
HYDROPOWER - Hydroelectric power generationHYDROPOWER - Hydroelectric power generation
HYDROPOWER - Hydroelectric power generation
Robbie Edward Sayers
 
NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...
NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...
NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...
Amil Baba Dawood bangali
 
The Benefits and Techniques of Trenchless Pipe Repair.pdf
The Benefits and Techniques of Trenchless Pipe Repair.pdfThe Benefits and Techniques of Trenchless Pipe Repair.pdf
The Benefits and Techniques of Trenchless Pipe Repair.pdf
Pipe Restoration Solutions
 
road safety engineering r s e unit 3.pdf
road safety engineering  r s e unit 3.pdfroad safety engineering  r s e unit 3.pdf
road safety engineering r s e unit 3.pdf
VENKATESHvenky89705
 
Automobile Management System Project Report.pdf
Automobile Management System Project Report.pdfAutomobile Management System Project Report.pdf
Automobile Management System Project Report.pdf
Kamal Acharya
 
ethical hacking in wireless-hacking1.ppt
ethical hacking in wireless-hacking1.pptethical hacking in wireless-hacking1.ppt
ethical hacking in wireless-hacking1.ppt
Jayaprasanna4
 
COLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdf
COLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdfCOLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdf
COLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdf
Kamal Acharya
 
power quality voltage fluctuation UNIT - I.pptx
power quality voltage fluctuation UNIT - I.pptxpower quality voltage fluctuation UNIT - I.pptx
power quality voltage fluctuation UNIT - I.pptx
ViniHema
 
Hybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdf
Hybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdfHybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdf
Hybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdf
fxintegritypublishin
 
Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...
Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...
Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...
AJAYKUMARPUND1
 
Democratizing Fuzzing at Scale by Abhishek Arya
Democratizing Fuzzing at Scale by Abhishek AryaDemocratizing Fuzzing at Scale by Abhishek Arya
Democratizing Fuzzing at Scale by Abhishek Arya
abh.arya
 

Recently uploaded (20)

CFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptx
CFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptxCFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptx
CFD Simulation of By-pass Flow in a HRSG module by R&R Consult.pptx
 
Final project report on grocery store management system..pdf
Final project report on grocery store management system..pdfFinal project report on grocery store management system..pdf
Final project report on grocery store management system..pdf
 
Courier management system project report.pdf
Courier management system project report.pdfCourier management system project report.pdf
Courier management system project report.pdf
 
Water Industry Process Automation and Control Monthly - May 2024.pdf
Water Industry Process Automation and Control Monthly - May 2024.pdfWater Industry Process Automation and Control Monthly - May 2024.pdf
Water Industry Process Automation and Control Monthly - May 2024.pdf
 
block diagram and signal flow graph representation
block diagram and signal flow graph representationblock diagram and signal flow graph representation
block diagram and signal flow graph representation
 
Vaccine management system project report documentation..pdf
Vaccine management system project report documentation..pdfVaccine management system project report documentation..pdf
Vaccine management system project report documentation..pdf
 
Immunizing Image Classifiers Against Localized Adversary Attacks
Immunizing Image Classifiers Against Localized Adversary AttacksImmunizing Image Classifiers Against Localized Adversary Attacks
Immunizing Image Classifiers Against Localized Adversary Attacks
 
J.Yang, ICLR 2024, MLILAB, KAIST AI.pdf
J.Yang,  ICLR 2024, MLILAB, KAIST AI.pdfJ.Yang,  ICLR 2024, MLILAB, KAIST AI.pdf
J.Yang, ICLR 2024, MLILAB, KAIST AI.pdf
 
Gen AI Study Jams _ For the GDSC Leads in India.pdf
Gen AI Study Jams _ For the GDSC Leads in India.pdfGen AI Study Jams _ For the GDSC Leads in India.pdf
Gen AI Study Jams _ For the GDSC Leads in India.pdf
 
HYDROPOWER - Hydroelectric power generation
HYDROPOWER - Hydroelectric power generationHYDROPOWER - Hydroelectric power generation
HYDROPOWER - Hydroelectric power generation
 
NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...
NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...
NO1 Uk best vashikaran specialist in delhi vashikaran baba near me online vas...
 
The Benefits and Techniques of Trenchless Pipe Repair.pdf
The Benefits and Techniques of Trenchless Pipe Repair.pdfThe Benefits and Techniques of Trenchless Pipe Repair.pdf
The Benefits and Techniques of Trenchless Pipe Repair.pdf
 
road safety engineering r s e unit 3.pdf
road safety engineering  r s e unit 3.pdfroad safety engineering  r s e unit 3.pdf
road safety engineering r s e unit 3.pdf
 
Automobile Management System Project Report.pdf
Automobile Management System Project Report.pdfAutomobile Management System Project Report.pdf
Automobile Management System Project Report.pdf
 
ethical hacking in wireless-hacking1.ppt
ethical hacking in wireless-hacking1.pptethical hacking in wireless-hacking1.ppt
ethical hacking in wireless-hacking1.ppt
 
COLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdf
COLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdfCOLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdf
COLLEGE BUS MANAGEMENT SYSTEM PROJECT REPORT.pdf
 
power quality voltage fluctuation UNIT - I.pptx
power quality voltage fluctuation UNIT - I.pptxpower quality voltage fluctuation UNIT - I.pptx
power quality voltage fluctuation UNIT - I.pptx
 
Hybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdf
Hybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdfHybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdf
Hybrid optimization of pumped hydro system and solar- Engr. Abdul-Azeez.pdf
 
Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...
Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...
Pile Foundation by Venkatesh Taduvai (Sub Geotechnical Engineering II)-conver...
 
Democratizing Fuzzing at Scale by Abhishek Arya
Democratizing Fuzzing at Scale by Abhishek AryaDemocratizing Fuzzing at Scale by Abhishek Arya
Democratizing Fuzzing at Scale by Abhishek Arya
 

Routing Information Protocol (RIP)

  • 1. Routing Basic Idea Routing table Switching Walkthrough Directly connected Routes Walkthrough Statically configured routes Walkthrough Dynamic routing protocols Passive inferfaces Routing Information Protocol (RIP) Presented by, Tharindu Sankalpa 17th batch
  • 2. Routing Basic idea  What is routing? Routing is the process of selecting a optimal path to forward data packets in between or across multiple networks.  How routing happen? Routers make routing decisions (path selection) based on routing information available on their routing tables.  Routing information? Routing information can be considered as details about physical topology and status of the network.
  • 3. Routing table Three types of routing table entries  Directly connected routes are the routing table entries about a directly connected destination network to one of the interfaces of the router.  Statically configured routes are the routing table entries that network administers manually configured on the router.  Dynamically learned routes are the routing table entries learn by exchanging routing information with the help of dynamic routing protocols. Routing information base, is a data table stored in a router that contain lists of routes to particular network destinations.
  • 4. Let’s build the network Device Models Routers 2811 Switches 2960 192.168.4.0/24 192.168.1.0/24 192.168.2.0/24 192.168.3.0/24
  • 5. Add serial ports on R1 and R2 Power button 1.Turn OFF power 2. Add serial port 3. Turn ON power
  • 7. Router(config)#hostname R1 R1(config)#interface fastEthernet 0/0 R1(config-if)#ip address 192.168.1.3 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface fastEthernet 0/1 R1(config-if)#ip address 192.168.4.2 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface serial 0/3/0 R1(config-if)#ip address 192.168.3.2 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1#write Router(config)#hostname R2 R2(config)#interface fastEthernet 0/0 R2(config-if)#ip address 192.168.2.2 255.255.255.0 R2(config-if)#no shut R2(config-if)#exit R2(config)#interface serial 0/3/0 R2(config-if)#ip address 192.168.3.3 255.255.255.0 R2(config-if)#no shut R2(config)#exit R2#write Router> Router>en Router#conf t Router(config)#line con 0 Router(config-line)#exec-timeout 0 Router(config-line)#exit Router(config)#no ip domain lookup Configure R1 and R2
  • 8. Let’s check the Routing tables R1#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.1.0/24 is directly connected, FastEthernet0/0 C 192.168.3.0/24 is directly connected, Serial0/3/0 C 192.168.4.0/24 is directly connected, FastEthernet0/1 R2#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.2.0/24 is directly connected, FastEthernet0/0 C 192.168.3.0/24 is directly connected, Serial0/3/0
  • 9. Switching Walkthrough C:>ping 192.168.1.2 Pinging 192.168.1.2 with 32 bytes of data: Reply from 192.168.1.2: bytes=32 time=31ms TTL=128 Reply from 192.168.1.2: bytes=32 time=7ms TTL=128 Reply from 192.168.1.2: bytes=32 time=13ms TTL=128 Reply from 192.168.1.2: bytes=32 time=16ms TTL=128 Ping statistics for 192.168.1.2: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 7ms, Maximum = 31ms, Average = 16ms Ping form Host A to Host B
  • 10. Directly connected Routes Walkthrough Ping form Host A to Host C C:>ping 192.168.4.1 Pinging 192.168.4.1 with 32 bytes of data: Reply from 192.168.4.1: bytes=32 time=13ms TTL=127 Reply from 192.168.4.1: bytes=32 time=17ms TTL=127 Reply from 192.168.4.1: bytes=32 time=14ms TTL=127 Reply from 192.168.4.1: bytes=32 time=15ms TTL=127 Ping statistics for 192.168.4.1: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 13ms, Maximum = 17ms, Average = 14ms
  • 11. Non-directly connected routes Walkthrough C:>ping 192.168.2.1 Pinging 192.168.2.1 with 32 bytes of data: Reply from 192.168.1.3: Destination host unreachable. Reply from 192.168.1.3: Destination host unreachable. Reply from 192.168.1.3: Destination host unreachable. Reply from 192.168.1.3: Destination host unreachable. Ping statistics for 192.168.2.1: Packets: Sent = 4, Received = 0, Lost = 4 (100% loss), Ping form Host A to Host C
  • 12. Non-directly connected routes WalkthroughR1#ping 192.168.2.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds: ..... Success rate is 0 percent (0/5) R1#ping 192.168.3.3 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/16 ms Ping form R1 to Host C Ping form R1 to R2
  • 13. Dynamic Routing Protocols Dynamic routing protocols specify how routers automatically exchange and distribute routing information. Dynamic routing protocols Interior gateway protocols (IGP) Distance vector protocols Routing Information Protocol (RIP) Enhanced Interior Gateway Routing Protocol (EIGRP) Link state routing protocols Open Shortest Path First (OSPF) Intermediate System to Intermediate System (IS-IS) Exterior gateway protocols (EGP) Path vector routing protocols Border Gateway Protocol (BGP)
  • 14. Time to configure RIP R1#show ip protocols R1#conf t R1(config)#router rip R1(config-router)#version 2 R1(config-router)#network 192.168.3.0 R1(config-router)#network 192.168.1.0 R1(config-router)#network 192.168.4.0 R1(config-router)#^Z R1#write R2#conf t R2(config)#router rip R2(config-router)#version 2 R2(config-router)#network 192.168.3.0 R2(config-router)#network 192.168.2.0 R2(config-router)#^Z R2#write
  • 15. Let’s check the Routing tables R1#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set C 192.168.1.0/24 is directly connected, FastEthernet0/0 R 192.168.2.0/24 [120/1] via 192.168.3.3, 00:00:29, Serial0/3/0 C 192.168.3.0/24 is directly connected, Serial0/3/0 C 192.168.4.0/24 is directly connected, FastEthernet0/1 R1#show ip route rip R 192.168.2.0/24 [120/1] via 192.168.3.3, 00:00:19, Serial0/3/0 R2#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set R 192.168.1.0/24 [120/1] via 192.168.3.2, 00:00:19, Serial0/3/0 C 192.168.2.0/24 is directly connected, FastEthernet0/0 C 192.168.3.0/24 is directly connected, Serial0/3/0 R 192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:19, Serial0/3/0 R2#show ip route rip R 192.168.1.0/24 [120/1] via 192.168.3.2, 00:00:17, Serial0/3/0 R 192.168.4.0/24 [120/1] via 192.168.3.2, 00:00:17, Serial0/3/0
  • 16. RIP routes Walkthrough C:>ping 192.168.2.1 Pinging 192.168.2.1 with 32 bytes of data: Reply from 192.168.2.1: bytes=32 time=36ms TTL=126 Reply from 192.168.2.1: bytes=32 time=14ms TTL=126 Reply from 192.168.2.1: bytes=32 time=26ms TTL=126 Reply from 192.168.2.1: bytes=32 time=15ms TTL=126 Ping statistics for 192.168.2.1: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 14ms, Maximum = 36ms, Average = 22ms Ping form Host A to Host C
  • 17. RIP routes Walkthrough R1#ping 192.168.2.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/37 ms Ping form R1 to Host C
  • 18. Passive interfaces R1#conf t R1(config)#router rip R1(config-router)#passive-interface fastEthernet 0/0 R1(config-router)#passive-interface fastEthernet 0/1 R2#conf t R2(config)#router rip R2(config-router)#passive-interface fastEthernet 0/0 Full RIP update sending Every 30 seconds