SlideShare a Scribd company logo
pkgsrc とは何か?
よもやま話
OBATA Akio (obache@NetBSD.org)
Nov. 16, 2013
Open Source Conference 2013 Fukuoka
で、pkgsrc って何なの?
パッケージ管理システム?
そうなような、そうでないような
rpm とか dpkg みたいなもの?
misc/rpm とか misc/dpkg あるよ
yum とか apt みたいなもの?
pkgtools/pkgin とか pkgtools/nih とか
01 26
だから pkgsrc って何なの?
The NetBSD package Collection
NetBSD の base に含まれない pkg の集合
FreeBSD ports から fork(1997)
/usr/pkg に追加のsrc でpkgsrc
他のソースと同じ: make install
13000+ のパッケージ
四半期に一度のリリース
02 26
基本的なの使い方
ソース一式を取得
cd CATEGORY/PKG && make install
fetch & configure & build & install
バイナリパッケージも作成可能
03 26
パッケージの内容物
Makefile
distinfo
PLIST
DESCR
patches
INSTALL/DEINSTALL
04 26
Makefile
# $NetBSD: Makefile,v 1.44 2013/06/29 11:54:45 obache Exp $
#
DISTNAME= rabbit-2.1.0
CATEGORIES= graphics ruby
MASTER_SITES= http://rabbit-shocker.org/download/
MAINTAINER= obache@NetBSD.org
HOMEPAGE= http://rabbit-shocker.org/
COMMENT= RD-document-based presentation application
LICENSE= gnu-gpl-v2 # or later
RUBY_VERSION_SUPPORTED= 193
DEPENDS+= ${RUBY_PKGPREFIX}-gnome2-gtk>=0.90.3:../../x11/ruby-gnome2-gtk
DEPENDS+= ${RUBY_PKGPREFIX}-gnome2-rsvg-[0-9]*:../../graphics/ruby-gnome2-rsvg
DEPENDS+= ${RUBY_PKGPREFIX}-gnome2-poppler-[0-9]*:../../print/ruby-gnome2-poppler
DEPENDS+= ${RUBY_PKGPREFIX}-hikidoc-[0-9]*:../../textproc/ruby-hikidoc
DEPENDS+= ${RUBY_PKGPREFIX}-nokogiri-[0-9]*:../../textproc/ruby-nokogiri
DEPENDS+= ${RUBY_PKGPREFIX}-rdtool>=0.6.20:../../textproc/ruby-rdtool
DEPENDS+= ${RUBY_PKGPREFIX}-rttool-[0-9]*:../../textproc/ruby-rttool
DEPENDS+= ${RUBY_PKGPREFIX}-coderay>=1.0.0:../../textproc/ruby-coderay
DEPENDS+= ${RUBY_PKGPREFIX}-kramdown-[0-9]*:../../textproc/ruby-kramdown
DEPENDS+= ${RUBY_PKGPREFIX}-gettext-[0-9]*:../../devel/ruby-gettext
DEPENDS+= ${RUBY_PKGPREFIX}-faraday-[0-9]*:../../www/ruby-faraday
USE_RUBY_SETUP= yes
USE_RUBY_SETUP_PKG= yes
CONFIGURE_ARGS+= --siteruby=${PREFIX}/${RUBY_VENDORLIB_BASE} 
--siterubyver=${PREFIX}/${RUBY_VENDORLIB} 
--siterubyverarch=${PREFIX}/${RUBY_VENDORARCHLIB}
.include "../../lang/ruby/modules.mk"
.include "../../mk/bsd.pkg.mk"
05 26
distinfo
$NetBSD: distinfo,v 1.33 2013/06/29 11:54:45 obache Exp $
SHA1 (rabbit-2.1.0.tar.gz) = 0ee3f21fafd944bdcc7ba9ad324ae12b1785f1fd
RMD160 (rabbit-2.1.0.tar.gz) = a2085abad1d4d9230d4a1f76277340af49e3de0d
Size (rabbit-2.1.0.tar.gz) = 5156905 bytes
06 26
PLIST
07 26
Portablility
基本機能の実装は make, sh, awk, sed...
ツールを準備すれば他OSでも使える!
bootstrap sh script=> bmake => ksh =>
sed, awk ...
08 26
Supported Platforms
21 platforms
AIX, BSD/OS, Cygwin, Mac OS X, Debian/
kFreeBSD, DragonFly, FreeBSD, FreeMiNT,
HP-UX, Haiku, IRIX, Interix, Linux, Minix3,
MirBSD, NetBSD, OSF1, OpenBSD, QNX,
SunOS, UnixWare
09 26
What is "Supported Platform"
基本ツールのインストール
その他ツールの状況
特権ユーザ名
システム固有情報
shlib type
hier
10 26
Supported Compilers
Compaq C Compilers (ccc)
Clang C and Objective-C compiler (clang)
Intel C++ Compiler (icc)
SGI IRIS Development Option cc (ido)
GNU Compiler Collection (gcc)
HP-UX C/aC++ compilers (hp)
Silicon Graphics, Inc. MIPSpro (mipspro)
11 26
Supported Compilers
Portable C Compiler (pcc)
Sun Microsystems, Inc. WorkShip/Forte/
Sun ONE Studio (sunpro)
IBM's XL C/C++ compiler suite (xlc)
compiler cache (ccache)
distributed C/C++ (distcc)
Fortran 77 to C compiler (f2c)
12 26
What is "Supported Compiler"
引数の違いを吸収
書き換え -pthread => -mt
順序の入れ替え
バージョンによる切り分け
13 26
Supported binary package formats
native- FreeBSD ports由来だが非互換
FreeBSD ports (wip)
rpm (wip)
deb (wip)
14 26
Additioanl usage
インストール先を変更可能 (ex /opt/pkg)
非特権ユーザ利用 (ex ${HOME}/pkg)
15 26
Version Selectable
複数バージョンからの選択可能
Ruby 1.8/1.9/2.0
Python 2.6/2.7/3.2/3.3
MySQL 5.0/5.2/5.5/5.6
Lua 5.1/5.2
Apache 1.3/2.0/2.2/2.4
16 26
bulk build
全てのパッケージを build する
バイナリパッケージの作成
テストの意味合いもある
ツール
pbulk
distbb
17 26
package management
バイナリパッケージ利用
pkgin
nih
(pkg_install)
18 26
何と戦っているか
#if !defined(__FreeBSD__) && !defined(__OpenBSD__)
#include <linux/sys.h>
#endif
Linux is the standard!
19 26
そして何と戦っているか?
if test x$have_foo == xyes; then
Bash-izm! Bash-izm!
20 26
どう戦っているか?
○○ for Linux
→たとえばNetBSDでおかしいよ?
←何がおかしいの?
→POSIX規格では云々
←ありがとう、直したよ!
commit log: Fixes for NetBSD
21 26
そしてどう戦っているか?
新しいパッケージ追加!
Solaris で build できない!
直す
パッケージアップデート
NetBSD/VAXで!
...
22 26
何に困るか
Commit log
リリースノートない
混沌とした summary
リリース技術の低下?
23 26
世界に戦いを挑む
Log Message:
Import mikutter-0.0.2.12 as net/mikutter.
For all mikker and ill of twitter users best twitter client.
Miku is so moe, so cute, so beautiful, fantastic, excellent,
magnificent, brilliant and my wife. moeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
24 26
pkgsrc Internals
暗黒世界
tools
wrapper
buildlink
25 26
never MATOME
Package once, use anywhere!
What is pkgsrc?
Welcome to new pkgsrc developers!
26 26

More Related Content

What's hot

2017年のFPGA Community活動について
2017年のFPGA Community活動について2017年のFPGA Community活動について
2017年のFPGA Community活動について
Mr. Vengineer
 
IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)
IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)
IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)
Hajime Tazaki
 
TensorFlow XLA : AOT編 チラ見版
TensorFlow XLA : AOT編 チラ見版TensorFlow XLA : AOT編 チラ見版
TensorFlow XLA : AOT編 チラ見版
Mr. Vengineer
 
Lagopus as open flow hybrid switch 実践編
Lagopus as open flow hybrid switch 実践編Lagopus as open flow hybrid switch 実践編
Lagopus as open flow hybrid switch 実践編
Masaru Oki
 
FPGAスタートアップ資料
FPGAスタートアップ資料FPGAスタートアップ資料
FPGAスタートアップ資料
marsee101
 
pkgsrc とは何か? - よもやま話
pkgsrc とは何か? - よもやま話pkgsrc とは何か? - よもやま話
pkgsrc とは何か? - よもやま話
Akio OBATA
 
DSPでディープラーニング
DSPでディープラーニングDSPでディープラーニング
DSPでディープラーニング
Mr. Vengineer
 
FreeBSD jail+vnetと戯れた話
FreeBSD jail+vnetと戯れた話FreeBSD jail+vnetと戯れた話
FreeBSD jail+vnetと戯れた話
Masaru Oki
 
ZynqMP勉強会
ZynqMP勉強会ZynqMP勉強会
ZynqMP勉強会
Hidemi Ishihara
 
第一回コンテナ情報交換会@関西
第一回コンテナ情報交換会@関西第一回コンテナ情報交換会@関西
第一回コンテナ情報交換会@関西
Masahide Yamamoto
 
Lagopus, raw socket build
Lagopus, raw socket buildLagopus, raw socket build
Lagopus, raw socket build
Masaru Oki
 
ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)
ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)
ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)
marsee101
 
OpenContrailのソースコードを探検しよう!
OpenContrailのソースコードを探検しよう!OpenContrailのソースコードを探検しよう!
OpenContrailのソースコードを探検しよう!
Takashi Sogabe
 
High Performance Networking with DPDK & Multi/Many Core
High Performance Networking with DPDK & Multi/Many CoreHigh Performance Networking with DPDK & Multi/Many Core
High Performance Networking with DPDK & Multi/Many Core
slankdev
 
Altera SDK for OpenCL解体新書 : ホストとデバイスの関係
Altera SDK for OpenCL解体新書 : ホストとデバイスの関係Altera SDK for OpenCL解体新書 : ホストとデバイスの関係
Altera SDK for OpenCL解体新書 : ホストとデバイスの関係
Mr. Vengineer
 
FPGA+SoC+Linux実践勉強会資料
FPGA+SoC+Linux実践勉強会資料FPGA+SoC+Linux実践勉強会資料
FPGA+SoC+Linux実践勉強会資料
一路 川染
 
Intel graphics
Intel graphicsIntel graphics
Intel graphics
Yuichiro Naito
 
Ietf97 ソウル報告
Ietf97 ソウル報告Ietf97 ソウル報告
Ietf97 ソウル報告
yuki-f
 
Lagopus 0.2.2
Lagopus 0.2.2Lagopus 0.2.2
Lagopus 0.2.2
Masaru Oki
 
Dockerと外部ルータを連携させる仕組みを作ってみた
Dockerと外部ルータを連携させる仕組みを作ってみたDockerと外部ルータを連携させる仕組みを作ってみた
Dockerと外部ルータを連携させる仕組みを作ってみた
npsg
 

What's hot (20)

2017年のFPGA Community活動について
2017年のFPGA Community活動について2017年のFPGA Community活動について
2017年のFPGA Community活動について
 
IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)
IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)
IIJlab seminar - Linux Kernel Library: Reusable monolithic kernel (in Japanese)
 
TensorFlow XLA : AOT編 チラ見版
TensorFlow XLA : AOT編 チラ見版TensorFlow XLA : AOT編 チラ見版
TensorFlow XLA : AOT編 チラ見版
 
Lagopus as open flow hybrid switch 実践編
Lagopus as open flow hybrid switch 実践編Lagopus as open flow hybrid switch 実践編
Lagopus as open flow hybrid switch 実践編
 
FPGAスタートアップ資料
FPGAスタートアップ資料FPGAスタートアップ資料
FPGAスタートアップ資料
 
pkgsrc とは何か? - よもやま話
pkgsrc とは何か? - よもやま話pkgsrc とは何か? - よもやま話
pkgsrc とは何か? - よもやま話
 
DSPでディープラーニング
DSPでディープラーニングDSPでディープラーニング
DSPでディープラーニング
 
FreeBSD jail+vnetと戯れた話
FreeBSD jail+vnetと戯れた話FreeBSD jail+vnetと戯れた話
FreeBSD jail+vnetと戯れた話
 
ZynqMP勉強会
ZynqMP勉強会ZynqMP勉強会
ZynqMP勉強会
 
第一回コンテナ情報交換会@関西
第一回コンテナ情報交換会@関西第一回コンテナ情報交換会@関西
第一回コンテナ情報交換会@関西
 
Lagopus, raw socket build
Lagopus, raw socket buildLagopus, raw socket build
Lagopus, raw socket build
 
ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)
ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)
ラプラシアンフィルタをZedBoardで実装(ソフトウェアからハードウェアにオフロード)
 
OpenContrailのソースコードを探検しよう!
OpenContrailのソースコードを探検しよう!OpenContrailのソースコードを探検しよう!
OpenContrailのソースコードを探検しよう!
 
High Performance Networking with DPDK & Multi/Many Core
High Performance Networking with DPDK & Multi/Many CoreHigh Performance Networking with DPDK & Multi/Many Core
High Performance Networking with DPDK & Multi/Many Core
 
Altera SDK for OpenCL解体新書 : ホストとデバイスの関係
Altera SDK for OpenCL解体新書 : ホストとデバイスの関係Altera SDK for OpenCL解体新書 : ホストとデバイスの関係
Altera SDK for OpenCL解体新書 : ホストとデバイスの関係
 
FPGA+SoC+Linux実践勉強会資料
FPGA+SoC+Linux実践勉強会資料FPGA+SoC+Linux実践勉強会資料
FPGA+SoC+Linux実践勉強会資料
 
Intel graphics
Intel graphicsIntel graphics
Intel graphics
 
Ietf97 ソウル報告
Ietf97 ソウル報告Ietf97 ソウル報告
Ietf97 ソウル報告
 
Lagopus 0.2.2
Lagopus 0.2.2Lagopus 0.2.2
Lagopus 0.2.2
 
Dockerと外部ルータを連携させる仕組みを作ってみた
Dockerと外部ルータを連携させる仕組みを作ってみたDockerと外部ルータを連携させる仕組みを作ってみた
Dockerと外部ルータを連携させる仕組みを作ってみた
 

Viewers also liked

Augmented Reality - Let’s Make Some Holgrams! (Developer Version)
Augmented Reality - Let’s Make Some Holgrams! (Developer Version)Augmented Reality - Let’s Make Some Holgrams! (Developer Version)
Augmented Reality - Let’s Make Some Holgrams! (Developer Version)
Cameron Vetter
 
Curriculum vitae diego
Curriculum vitae diegoCurriculum vitae diego
Curriculum vitae diego
melissa iparraguirre aliaga
 
Consumer first
Consumer firstConsumer first
Consumer first
Laure Duchateau
 
Logistic services marketing
Logistic services marketingLogistic services marketing
Logistic services marketing
Birmingham City University
 
12. silabus kesehatan
12. silabus kesehatan12. silabus kesehatan
12. silabus kesehatan
EKO SUPRIYADI
 
H61 m vg3
H61 m vg3H61 m vg3
H61 m vg3
Ulfa Amalia
 
Analysis of Anomalous Thrust Experiments from an Asymmetric Cavity
Analysis of Anomalous Thrust Experiments from an Asymmetric CavityAnalysis of Anomalous Thrust Experiments from an Asymmetric Cavity
Analysis of Anomalous Thrust Experiments from an Asymmetric Cavity
Brian Kraft
 
01_Maromizaha_Gerp_18 dec 15
01_Maromizaha_Gerp_18 dec 1501_Maromizaha_Gerp_18 dec 15
01_Maromizaha_Gerp_18 dec 15
FAPBM_Foundation
 
Shanna Laufer Portfolio
Shanna Laufer PortfolioShanna Laufer Portfolio
Shanna Laufer Portfolio
shanna laufer
 
Roles and functions of educational technology in 21st century baliber
Roles and functions of educational technology in 21st century   baliberRoles and functions of educational technology in 21st century   baliber
Roles and functions of educational technology in 21st century baliber
Milette Baliber
 
03 Itremo kmcc_ 18 dec 15
03 Itremo kmcc_ 18 dec 1503 Itremo kmcc_ 18 dec 15
03 Itremo kmcc_ 18 dec 15
FAPBM_Foundation
 
1. epicureismo
1. epicureismo1. epicureismo
1. epicureismo
emiliocarm1977
 
CV Orietta Donò nov15 ENG
CV Orietta Donò nov15 ENGCV Orietta Donò nov15 ENG
CV Orietta Donò nov15 ENG
orietta dono'
 
465 senior lab final report
465 senior lab final report465 senior lab final report
465 senior lab final report
Brian Kraft
 
Paul Carroll S-S '16
Paul Carroll S-S '16Paul Carroll S-S '16
Paul Carroll S-S '16
shanna laufer
 
Evaluation questions
Evaluation questionsEvaluation questions
Evaluation questions
lukegreen6
 
CV FACELLI 2016 ENG
CV FACELLI 2016 ENGCV FACELLI 2016 ENG
CV FACELLI 2016 ENG
Paolo Facelli
 
4 Amazingly Simple Ways to Reach Moms
4 Amazingly Simple Ways to Reach Moms4 Amazingly Simple Ways to Reach Moms
4 Amazingly Simple Ways to Reach Moms
huddleinc
 
теплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучению
теплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучениютеплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучению
теплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучению
maximstrong
 
Название
НазваниеНазвание
Название
Артемий Малков
 

Viewers also liked (20)

Augmented Reality - Let’s Make Some Holgrams! (Developer Version)
Augmented Reality - Let’s Make Some Holgrams! (Developer Version)Augmented Reality - Let’s Make Some Holgrams! (Developer Version)
Augmented Reality - Let’s Make Some Holgrams! (Developer Version)
 
Curriculum vitae diego
Curriculum vitae diegoCurriculum vitae diego
Curriculum vitae diego
 
Consumer first
Consumer firstConsumer first
Consumer first
 
Logistic services marketing
Logistic services marketingLogistic services marketing
Logistic services marketing
 
12. silabus kesehatan
12. silabus kesehatan12. silabus kesehatan
12. silabus kesehatan
 
H61 m vg3
H61 m vg3H61 m vg3
H61 m vg3
 
Analysis of Anomalous Thrust Experiments from an Asymmetric Cavity
Analysis of Anomalous Thrust Experiments from an Asymmetric CavityAnalysis of Anomalous Thrust Experiments from an Asymmetric Cavity
Analysis of Anomalous Thrust Experiments from an Asymmetric Cavity
 
01_Maromizaha_Gerp_18 dec 15
01_Maromizaha_Gerp_18 dec 1501_Maromizaha_Gerp_18 dec 15
01_Maromizaha_Gerp_18 dec 15
 
Shanna Laufer Portfolio
Shanna Laufer PortfolioShanna Laufer Portfolio
Shanna Laufer Portfolio
 
Roles and functions of educational technology in 21st century baliber
Roles and functions of educational technology in 21st century   baliberRoles and functions of educational technology in 21st century   baliber
Roles and functions of educational technology in 21st century baliber
 
03 Itremo kmcc_ 18 dec 15
03 Itremo kmcc_ 18 dec 1503 Itremo kmcc_ 18 dec 15
03 Itremo kmcc_ 18 dec 15
 
1. epicureismo
1. epicureismo1. epicureismo
1. epicureismo
 
CV Orietta Donò nov15 ENG
CV Orietta Donò nov15 ENGCV Orietta Donò nov15 ENG
CV Orietta Donò nov15 ENG
 
465 senior lab final report
465 senior lab final report465 senior lab final report
465 senior lab final report
 
Paul Carroll S-S '16
Paul Carroll S-S '16Paul Carroll S-S '16
Paul Carroll S-S '16
 
Evaluation questions
Evaluation questionsEvaluation questions
Evaluation questions
 
CV FACELLI 2016 ENG
CV FACELLI 2016 ENGCV FACELLI 2016 ENG
CV FACELLI 2016 ENG
 
4 Amazingly Simple Ways to Reach Moms
4 Amazingly Simple Ways to Reach Moms4 Amazingly Simple Ways to Reach Moms
4 Amazingly Simple Ways to Reach Moms
 
теплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучению
теплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучениютеплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучению
теплицкая а.г. школьный старт. новый взгляд на диагностику готовности к обучению
 
Название
НазваниеНазвание
Название
 

Similar to pkgsrc とは何か? - よもやま話

OpenCLに触れてみよう
OpenCLに触れてみようOpenCLに触れてみよう
OpenCLに触れてみよう
You&I
 
今だからこそ知りたい Docker Compose/Swarm 入門
今だからこそ知りたい Docker Compose/Swarm 入門今だからこそ知りたい Docker Compose/Swarm 入門
今だからこそ知りたい Docker Compose/Swarm 入門
Masahito Zembutsu
 
PEZY-SC programming overview
PEZY-SC programming overviewPEZY-SC programming overview
PEZY-SC programming overview
Ryo Sakamoto
 
2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境
2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境
2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境
智啓 出川
 
Building production server on docker
Building production server on dockerBuilding production server on docker
Building production server on docker
Hiroshi Miura
 
Building production server on docker
Building production server on dockerBuilding production server on docker
Building production server on docker
Hiroshi Miura
 
コンテナ情報交換会2
コンテナ情報交換会2コンテナ情報交換会2
コンテナ情報交換会2
Masahide Yamamoto
 
Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】
Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】
Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】
Masahito Zembutsu
 
Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...
Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...
Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...
NTT DATA Technology & Innovation
 
GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)
GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)
GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)
Ryuuta Tsunashima
 
OpenSolaris Printing Environment
OpenSolaris Printing EnvironmentOpenSolaris Printing Environment
OpenSolaris Printing Environment
Naruhiko Ogasawara
 
PyOpenCLによるGPGPU入門
PyOpenCLによるGPGPU入門PyOpenCLによるGPGPU入門
PyOpenCLによるGPGPU入門Yosuke Onoue
 
Docker ComposeでMastodonが必要なものを梱包する話
Docker ComposeでMastodonが必要なものを梱包する話Docker ComposeでMastodonが必要なものを梱包する話
Docker ComposeでMastodonが必要なものを梱包する話
Masahito Zembutsu
 
Dockerを支える技術
Dockerを支える技術Dockerを支える技術
Dockerを支える技術
Etsuji Nakai
 
Lagopus + DockerのDPDK接続
Lagopus + DockerのDPDK接続Lagopus + DockerのDPDK接続
Lagopus + DockerのDPDK接続
Tomoya Hibi
 
FPGAアクセラレータの作り方 (IBM POWER+CAPI編)
FPGAアクセラレータの作り方 (IBM POWER+CAPI編)FPGAアクセラレータの作り方 (IBM POWER+CAPI編)
FPGAアクセラレータの作り方 (IBM POWER+CAPI編)
Mr. Vengineer
 
GTC Japan 2017
GTC Japan 2017GTC Japan 2017
GTC Japan 2017
Hitoshi Sato
 
高速ネットワーク最新動向と具体例 (ENOG58 Meeting)
高速ネットワーク最新動向と具体例 (ENOG58 Meeting)高速ネットワーク最新動向と具体例 (ENOG58 Meeting)
高速ネットワーク最新動向と具体例 (ENOG58 Meeting)
Naoto MATSUMOTO
 
PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021
PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021
PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021
Preferred Networks
 

Similar to pkgsrc とは何か? - よもやま話 (20)

Pdp11 on-fpga
Pdp11 on-fpgaPdp11 on-fpga
Pdp11 on-fpga
 
OpenCLに触れてみよう
OpenCLに触れてみようOpenCLに触れてみよう
OpenCLに触れてみよう
 
今だからこそ知りたい Docker Compose/Swarm 入門
今だからこそ知りたい Docker Compose/Swarm 入門今だからこそ知りたい Docker Compose/Swarm 入門
今だからこそ知りたい Docker Compose/Swarm 入門
 
PEZY-SC programming overview
PEZY-SC programming overviewPEZY-SC programming overview
PEZY-SC programming overview
 
2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境
2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境
2015年度GPGPU実践プログラミング 第3回 GPGPUプログラミング環境
 
Building production server on docker
Building production server on dockerBuilding production server on docker
Building production server on docker
 
Building production server on docker
Building production server on dockerBuilding production server on docker
Building production server on docker
 
コンテナ情報交換会2
コンテナ情報交換会2コンテナ情報交換会2
コンテナ情報交換会2
 
Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】
Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】
Docker入門-基礎編 いまから始めるDocker管理【2nd Edition】
 
Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...
Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...
Apache BigtopによるHadoopエコシステムのパッケージング(Open Source Conference 2021 Online/Osaka...
 
GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)
GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)
GPU-FPGA 協調計算を記述するためのプログラミング環境に関する研究(HPC169 No.10)
 
OpenSolaris Printing Environment
OpenSolaris Printing EnvironmentOpenSolaris Printing Environment
OpenSolaris Printing Environment
 
PyOpenCLによるGPGPU入門
PyOpenCLによるGPGPU入門PyOpenCLによるGPGPU入門
PyOpenCLによるGPGPU入門
 
Docker ComposeでMastodonが必要なものを梱包する話
Docker ComposeでMastodonが必要なものを梱包する話Docker ComposeでMastodonが必要なものを梱包する話
Docker ComposeでMastodonが必要なものを梱包する話
 
Dockerを支える技術
Dockerを支える技術Dockerを支える技術
Dockerを支える技術
 
Lagopus + DockerのDPDK接続
Lagopus + DockerのDPDK接続Lagopus + DockerのDPDK接続
Lagopus + DockerのDPDK接続
 
FPGAアクセラレータの作り方 (IBM POWER+CAPI編)
FPGAアクセラレータの作り方 (IBM POWER+CAPI編)FPGAアクセラレータの作り方 (IBM POWER+CAPI編)
FPGAアクセラレータの作り方 (IBM POWER+CAPI編)
 
GTC Japan 2017
GTC Japan 2017GTC Japan 2017
GTC Japan 2017
 
高速ネットワーク最新動向と具体例 (ENOG58 Meeting)
高速ネットワーク最新動向と具体例 (ENOG58 Meeting)高速ネットワーク最新動向と具体例 (ENOG58 Meeting)
高速ネットワーク最新動向と具体例 (ENOG58 Meeting)
 
PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021
PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021
PFNのML/DL基盤を支えるKubernetesにおける自動化 / DevOpsDays Tokyo 2021
 

More from Akio OBATA

XXXsrc 2021 -the record of the past year-
XXXsrc 2021 -the record of the past year-XXXsrc 2021 -the record of the past year-
XXXsrc 2021 -the record of the past year-
Akio OBATA
 
XXXsrc 2020 -the record of the past year-
XXXsrc 2020 -the record of the past year-XXXsrc 2020 -the record of the past year-
XXXsrc 2020 -the record of the past year-
Akio OBATA
 
XXXsrc 2019 -the record of the past year-
XXXsrc 2019 -the record of the past year- XXXsrc 2019 -the record of the past year-
XXXsrc 2019 -the record of the past year-
Akio OBATA
 
XXXsrc 2018 -the record of the past year-
XXXsrc 2018 -the record of the past year- XXXsrc 2018 -the record of the past year-
XXXsrc 2018 -the record of the past year-
Akio OBATA
 
XXXsrc 2017 -the record of the past year-
XXXsrc 2017 -the record of the past year- XXXsrc 2017 -the record of the past year-
XXXsrc 2017 -the record of the past year-
Akio OBATA
 
XXXsrc 2016 -the record of the past year-
XXXsrc 2016 -the record of the past year-XXXsrc 2016 -the record of the past year-
XXXsrc 2016 -the record of the past year-
Akio OBATA
 
pkgsrc Internals - tools, wapper and buildlink
pkgsrc Internals - tools, wapper and buildlinkpkgsrc Internals - tools, wapper and buildlink
pkgsrc Internals - tools, wapper and buildlink
Akio OBATA
 
pkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past yearpkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past year
Akio OBATA
 
pkgsrc で gimp がアレだった件 - デマと放置と私
pkgsrc で gimp がアレだった件 - デマと放置と私pkgsrc で gimp がアレだった件 - デマと放置と私
pkgsrc で gimp がアレだった件 - デマと放置と私
Akio OBATA
 
pkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past yearpkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past year
Akio OBATA
 
pkgsrc 2013 - the record of the past year
pkgsrc 2013 - the record of the past yearpkgsrc 2013 - the record of the past year
pkgsrc 2013 - the record of the past year
Akio OBATA
 
pkgsrc 2012 - the record of the past year
pkgsrc 2012 - the record of the past yearpkgsrc 2012 - the record of the past year
pkgsrc 2012 - the record of the past year
Akio OBATA
 
The NetBSD package Collection - a.k.a pkgsrc
The NetBSD package Collection - a.k.a pkgsrcThe NetBSD package Collection - a.k.a pkgsrc
The NetBSD package Collection - a.k.a pkgsrc
Akio OBATA
 
pkgsrc 2011 - the record of the past year
pkgsrc 2011 - the record of the past yearpkgsrc 2011 - the record of the past year
pkgsrc 2011 - the record of the past year
Akio OBATA
 
pkgsrc 2010 - the record of the past year
pkgsrc 2010 - the record of the past yearpkgsrc 2010 - the record of the past year
pkgsrc 2010 - the record of the past year
Akio OBATA
 
pkgsrcに関する何か 2009 - 何と何で何とやら
pkgsrcに関する何か 2009 - 何と何で何とやらpkgsrcに関する何か 2009 - 何と何で何とやら
pkgsrcに関する何か 2009 - 何と何で何とやら
Akio OBATA
 
pkgsrcに関する何か 2008 - 何かは何かであって、何かでなし
pkgsrcに関する何か 2008 - 何かは何かであって、何かでなしpkgsrcに関する何か 2008 - 何かは何かであって、何かでなし
pkgsrcに関する何か 2008 - 何かは何かであって、何かでなし
Akio OBATA
 
pkgsrcに関する何か - 何かって何?
pkgsrcに関する何か - 何かって何?pkgsrcに関する何か - 何かって何?
pkgsrcに関する何か - 何かって何?
Akio OBATA
 

More from Akio OBATA (18)

XXXsrc 2021 -the record of the past year-
XXXsrc 2021 -the record of the past year-XXXsrc 2021 -the record of the past year-
XXXsrc 2021 -the record of the past year-
 
XXXsrc 2020 -the record of the past year-
XXXsrc 2020 -the record of the past year-XXXsrc 2020 -the record of the past year-
XXXsrc 2020 -the record of the past year-
 
XXXsrc 2019 -the record of the past year-
XXXsrc 2019 -the record of the past year- XXXsrc 2019 -the record of the past year-
XXXsrc 2019 -the record of the past year-
 
XXXsrc 2018 -the record of the past year-
XXXsrc 2018 -the record of the past year- XXXsrc 2018 -the record of the past year-
XXXsrc 2018 -the record of the past year-
 
XXXsrc 2017 -the record of the past year-
XXXsrc 2017 -the record of the past year- XXXsrc 2017 -the record of the past year-
XXXsrc 2017 -the record of the past year-
 
XXXsrc 2016 -the record of the past year-
XXXsrc 2016 -the record of the past year-XXXsrc 2016 -the record of the past year-
XXXsrc 2016 -the record of the past year-
 
pkgsrc Internals - tools, wapper and buildlink
pkgsrc Internals - tools, wapper and buildlinkpkgsrc Internals - tools, wapper and buildlink
pkgsrc Internals - tools, wapper and buildlink
 
pkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past yearpkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past year
 
pkgsrc で gimp がアレだった件 - デマと放置と私
pkgsrc で gimp がアレだった件 - デマと放置と私pkgsrc で gimp がアレだった件 - デマと放置と私
pkgsrc で gimp がアレだった件 - デマと放置と私
 
pkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past yearpkgsrc 2014 - the record of the past year
pkgsrc 2014 - the record of the past year
 
pkgsrc 2013 - the record of the past year
pkgsrc 2013 - the record of the past yearpkgsrc 2013 - the record of the past year
pkgsrc 2013 - the record of the past year
 
pkgsrc 2012 - the record of the past year
pkgsrc 2012 - the record of the past yearpkgsrc 2012 - the record of the past year
pkgsrc 2012 - the record of the past year
 
The NetBSD package Collection - a.k.a pkgsrc
The NetBSD package Collection - a.k.a pkgsrcThe NetBSD package Collection - a.k.a pkgsrc
The NetBSD package Collection - a.k.a pkgsrc
 
pkgsrc 2011 - the record of the past year
pkgsrc 2011 - the record of the past yearpkgsrc 2011 - the record of the past year
pkgsrc 2011 - the record of the past year
 
pkgsrc 2010 - the record of the past year
pkgsrc 2010 - the record of the past yearpkgsrc 2010 - the record of the past year
pkgsrc 2010 - the record of the past year
 
pkgsrcに関する何か 2009 - 何と何で何とやら
pkgsrcに関する何か 2009 - 何と何で何とやらpkgsrcに関する何か 2009 - 何と何で何とやら
pkgsrcに関する何か 2009 - 何と何で何とやら
 
pkgsrcに関する何か 2008 - 何かは何かであって、何かでなし
pkgsrcに関する何か 2008 - 何かは何かであって、何かでなしpkgsrcに関する何か 2008 - 何かは何かであって、何かでなし
pkgsrcに関する何か 2008 - 何かは何かであって、何かでなし
 
pkgsrcに関する何か - 何かって何?
pkgsrcに関する何か - 何かって何?pkgsrcに関する何か - 何かって何?
pkgsrcに関する何か - 何かって何?
 

pkgsrc とは何か? - よもやま話