SlideShare a Scribd company logo
1. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Basics Setup & OSPF
Going back to basics with Network Design, Route-Reflectors (iBGP), OSPF & Finally eBGP
J3 – Loop 10.0.0.3
J4 – Loop 10.0.0.4
R1 – Loop 10.0.0.10
R2 – Loop 10.0.0.11
R3 – Loop 10.0.0.12
R4 – Loop 10.0.0.13
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
1. Get OSPF Talking in Area 0
2. Get J03 – J04 Talking iBGP-RR
3. Add R1/R2 → iBGP – J03 (left)
4. Add R3/R4 → iBGP – J04 (right)
5. Add eBGP PEERS
6. Design Route-Maps OUT
7. Design some Resiliency
AS99
My IP ADDRESS Range
10.0.0.0/24 – Reserved for Loopbacks
20.0.0.0/30 – Private links betw J03-J04
30.0.0.0/24 – Reserved for ibgp (left)
40.0.0.0/24 – Reserved for ibgp (right)
left right
Have a closer look at our Network AS99. It really looks like two networks
separated only by the 20.0.0.0/30 portion (interface em1). In fact, we can
imagine that the “left” was the first network and later after expansion, a “right”
network as added together with a the new IP Range 40.0.0.0/24. - Later on we
will consider some “problems” with this design and how perhaps to overcome it.
Junos J03
kjteoh@Junos-3> show configuration interfaces lo0
unit 0 {
description Loop0;
family inet {
address 10.0.0.3/32;
}
kjteoh@Junos-3> show configuration interfaces em1
description Junos3-Junos4;
unit 0 {
family inet {
address 20.0.0.1/30;
}
kjteoh@Junos-3> show configuration routing-options router-id
router-id 10.0.0.3;
kjteoh@Junos-3> show configuration protocols ospf
area 0.0.0.0 {
interface all;
Cisco R1/R2
interface Loopback0
description loop
ip address 10.0.0.10 255.255.255.255
!
interface FastEthernet0/1
description R1-Junos3
ip address 30.0.0.2 255.255.255.0
!
router ospf 99
router-id 10.0.0.10
log-adjacency-changes
redistribute connected subnets
passive-interface default
no passive-interface FastEthernet0/1
network 0.0.0.0 255.255.255.255 area 0
Make sure everything works.
kjteoh@Junos-3> show ospf neighbor
Address Interface State ID
30.0.0.2 em0.0 Full 10.0.0.10
30.0.0.3 em0.0 Full 10.0.0.11
20.0.0.2 em1.0 Full 10.0.0.4
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Addres
10.0.0.3 128 FULL/DR 00:00:39 30.0.0.1
10.0.0.10 1 FULL/BDR 00:00:38 30.0.0.2
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
Why is this important?
Answer: the Cisco router are on the edge
and if it is connected to an external peer the
Cisco router will try and do OSPF with it and
send hello packets. Not good!
2. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Config RR
Making J03 and J04 participate as Route Reflector & iBGP neighbors
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
Really important to plan stuff out here especially with Junos. You have the options to
create bgp “groups” which is an advantage but can go haywire/
messy/unmanageableif you don't properly plan it in the configs.
J03 iBGP Configs & RR
kjteoh@Junos-3> show configuration protocols bgp group ibgp-RR-ONLY
type internal;
local-address 10.0.0.3;
advertise-peer-as;
family inet {
unicast;
}
export ibgp_export;
cluster 10.0.0.3;
local-as 99;
neighbor 10.0.0.4 {
description Junos4-RR;
}
Create a “group” and stick with it
IBGP ONLY
Define your Cluster
You're DONE!
Repeat the same on J04
cluster 10.0.0.4
Create Route-Map “out”
kjteoh@Junos-3> ...cy-options policy-statement ibgp_export
term 1 {
from protocol direct;
then accept;
}
term 3 {
from protocol static;
then accept;
}
term 2 {
from protocol ospf;
then accept;
Mostly self-explanatory but
this rule is interesting and it
had to be created to make a
40.0.0.0/24 network (right)
available to the 30.0.0.0/24
network on the left!
(In iBGP)
How do Route-Reflectors work?
First, this only applies to iBGP. R1 & R2 only need to do iBGP with J03. J03 in
turn learn iBGP routes from J04 and tell J03 about them. J04 will have his own set
of iBGP neighbors … in our case, R3 & R4. They will learn routes from the “left”
network via the exchange from J03 ↔ J04.
Of course it is also possible for the Cisco clients R1 & R2 to do ibgp with J04 and it
is a good idea too (dotted blue). J03 might fail. If this is the case, it is best to
ensure that the Left network can physically find its way to the Right network. This
can be achieved by trunking the switches above.
But we will also understand that OSPF adjacency will grow for ALL the routers as
they will become direct neighbors. Something to take note of.
BUT, there is a DOWNSIDE to having Route-Reflectors over FULL-MESH. Can
anybody tell me what it is?
IBGP-LEFT
Trunk
IBGP- RIGHT .. Maybe Later
kjteoh@Junos-3> show route receive-protocol bgp 10.0.0.4
inet.0:
Prefix Nexthop MED Lclpref AS path
10.0.0.4/32 10.0.0.4 100 I
10.0.0.12/32 40.0.0.2 2 100 I
10.0.0.13/32 40.0.0.3 2 100 I
20.0.0.0/30 10.0.0.4 100 I
40.0.0.0/24 10.0.0.4 100 I
Loops & interface IP
of R3 & R4 from
“right” network
“Right” network origination
the 40.0.0.0/24 block
kjteoh@Junos-3> show route table inet.0 40.0.0.0/24
40.0.0.0/24 *[OSPF/10] 01:14:33, metric 2
> to 20.0.0.2 via em1.0
[BGP/170] 01:13:43, localpref 100, from 10.0.0.4
AS path: I
> to 20.0.0.2 via em1.0
3. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Config RR – Adding iBGP Peers R1 & R2
Adding iBGP Peers to J03... R1 & R2 – Prepare J03 to accept clients
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
Configs J03
group ibgp {
type internal;
local-address 10.0.0.3;
advertise-peer-as;
family inet {
unicast;
}
export ibgp_export;
cluster 10.0.0.3;
local-as 99;
neighbor 10.0.0.10 {
description Cisco-R1;
}
neighbor 10.0.0.11 {
description Cisco-R2;
}
}
Specific group
created for Left
network
RR cluster
ID for J03 &
local AS99
Neighbor
IP
Configs
Route-Map
OUT
Configs R1/R2
router bgp 99
neighbor 10.0.0.3 remote-as 99
neighbor 10.0.0.3 update-source Loopback0
!
address-family ipv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 soft-reconfiguration inbound
!
Neighbor IP
Loop J03
IBGP
Is this Important? Does
R1 & R2 have multiple
exit points to J03?
What about Next hop-
self?
What is soft-recon ..
Is this mandatory?
Properly configured …
J03
kjteoh@Junos-3> show bgp summary
Groups: 3 Peers: 5 Down peers: 0
Peer AS InPkt OutPkt OutQ
10.0.0.4 99 87 88 0 0
10.0.0.10 99 82 97 0 0
10.0.0.11 99 81 96 0 0
Cisco R2
R2#show bgp sum
BGP router identifier 10.0.0.11, local AS number 99
Neighbor V AS MsgRcvd MsgSent Tbl
10.0.0.3 4 99 88 76 24
My IBGP AS
This is J04
configured
in slide 2
The Cisco
R1 & R2
neighbor
The J03 neighbor configured. I
will learn router R1 from this
iBGP neighbor (not ospf).
Does this mean that I (R2) will
INSTALL it?
R2#show ip bgp neighbors 10.0.0.3 routes
BGP table version is 24, local router ID is 10.0.0.11
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i10.0.0.0/24 10.0.0.3 100 0 i
r>i10.0.0.3/32 10.0.0.3 100 0 i
r>i10.0.0.4/32 20.0.0.2 1 100 0 i
r>i10.0.0.10/32 30.0.0.2 2 100 0 i
In terms of ROUTING,
which prefix will be
installed in Cisco R2?
10.0.0.0/24 or
10.0.0.10/32?
Compare: show ip route
10.0.0.10
Why is this
MANDATORY?
Cisco syntax
below
4. Back to Basics – OSPF / iBGP (Route Reflectors) - What R1/R2 is really learning from “Right” side
Refer slide 3 and perform the same between J04 ↔ Cisco R3 & R4. We will have the
following setup … One of the main Questions you should be asking yourself is … who and
which router is ORIGINATING routes for ..10.0.0.0/24, 30.0.0.0/24 & 40.0.0.0/24?
How are routes originated? Is this an automatic process? Is this OSPF or BGP?
Is there such a thing as originating routes in OSPF?
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
Left Network J03
Junos03 ibgp neighbors
R1 @ 10.0.0.10
R2 @ 10.0.0.11
Router J03
Right Network J04
Junos04 ibgp neighbors
R3 @ 10.0.0.12
R4 @ 10.0.0.13
Router J04
IBGP
20.0.0.0/30
Router R1
Router R2
IBGP
10.0.0.0/24
30.0.0.0/24
IBGP
10.0.0.0/24
40.0.0.0/24
Router R3
Router R4
Cluster RR
10.0.0.3 & .4
R2#show ip route
20.0.0.0/30 is subnetted, 1 subnets
O 20.0.0.0 [110/11] via 30.0.0.1, 01:54:57, FastEthernet0/1
40.0.0.0/24 is subnetted, 1 subnets
O 40.0.0.0 [110/12] via 30.0.0.1, 01:50:53, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.0.0.10/32 [110/11] via 30.0.0.2, 01:56:32, FastEthernet0/1
C 10.0.0.11/32 is directly connected, Loopback0
O 10.0.0.12/32 [110/13] via 30.0.0.1, 01:50:55, FastEthernet0/1
O 10.0.0.13/32 [110/13] via 30.0.0.1, 01:50:55, FastEthernet0/1
O 10.0.0.3/32 [110/10] via 30.0.0.1, 01:55:00, FastEthernet0/1
B 10.0.0.0/24 [200/0] via 10.0.0.3, 01:54:19
O 10.0.0.4/32 [110/11] via 30.0.0.1, 01:51:17, FastEthernet0/1
30.0.0.0/24 is subnetted, 1 subnets
C 30.0.0.0 is directly connected, FastEthernet0/
Relevant Codes:
B – BGP
C – connected
O – OSPF
This is a small network and we should really take
the time to go through every route and understand
how it is learned and where it is coming from.
We can “learn” routes from many Routers &
SOURCES (protocols), but we install only ONE
route and use it for routing.
It is possible to learn one route from one router and
from different source (protocols).
R2#show ip route 10.0.0.2
Routing entry for 10.0.0.0/24
Known via "bgp 99", distance 200, metric 0, type internal
Last update from 10.0.0.3 00:00:08 ago
Routing Descriptor Blocks:
* 10.0.0.3, from 10.0.0.3, 00:00:08 ago
Route metric is 0, traffic share count is 1
AS Hops 0
This becomes really
important when you
start doing EBGP with
other networks / ASNs
5. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Adding EBGP Peers / Neighbors / Route-Maps
Adding R5-AS100 with routes 200.0.0.0/24. Set up direct connection between
R5 – R1. You will do eBGP on this link – R5@fa0/0 ↔ R1@fa0/0
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
R5 - AS100
ebgp
FA0/0
FA0/0
Configs on R5 - AS100
interface Loopback200
description loopback200
ip address 200.0.0.1 255.255.255.0
!
interface FastEthernet0/0
description ebgp-R5-R1
ip address 100.0.0.1 255.255.255.252
!
router bgp 100
bgp log-neighbor-changes
neighbor 100.0.0.2 remote-as 99
!
address-family ipv4
neighbor 100.0.0.2 activate
neighbor 100.0.0.2 soft-reconfiguration inbound
no auto-summary
no synchronization
network 200.0.0.0
exit-address-family
!
!
!
ip forward-protocol nd
ip route 200.0.0.0 255.255.255.0 Null0 name BGP-PULL-UP
Originating Routes
E-BGP Peer
Note: On Junos
we write type
“internal or
external” &
peer-as
Create “routes” to
advertise. Remember, R5
is ONLY running BGP.
There isn't another
protocol to learn from and
inject into BGP
Configs on R1
router bgp 99
bgp log-neighbor-changes
neighbor 10.0.0.3 remote-as 99
neighbor 10.0.0.3 update-source Loopback0
neighbor 100.0.0.1 remote-as 100
!
address-family ipv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 soft-reconfiguration inbound
neighbor 100.0.0.1 activate
neighbor 100.0.0.1 soft-reconfiguration inboundR5#show ip bgp neighbors 100.0.0.2 routes
BGP table version is 48, local router ID is 200.0.0.1
Network Next Hop Metric LocPrf
*> 10.0.0.0/24 100.0.0.2 0 99 i
*> 10.0.0.3/32 100.0.0.2 0 99 i
*> 10.0.0.11/32 100.0.0.2 0 99 i
*> 20.0.0.0/30 100.0.0. 0 99 i
*> 30.0.0.0/24 100.0.0.2 0 99 i
*> 100.0.0.4/30 100.0.0.2 0 99 i
Problem here: R1 is sending even /32s! Not good.
R1 needs a route-map OUT. See AS-99-OUT on
Cisco R1
neighbor 100.0.0.1 route-map AS-99-OUT out
!
ip prefix-list 10 seq 5 permit 10.0.0.0/24
ip prefix-list 30 seq 5 permit 30.0.0.0/24
ip prefix-list 40 seq 5 permit 40.0.0.0/24
!
!
!
route-map AS-99-OUT permit 10
match ip address prefix-list 10 30 40
set metric 600
R5#show ip bgp neighbors 100.0.0.2 routes
BGP table version is 56,
local router ID is 200.0.0.1
Network Next Hop Metric LocPrf
*> 10.0.0.0/24 100.0.0.2 600 0 99 i
*> 30.0.0.0/24 100.0.0.2 600 0 99 i
*> 40.0.0.0/24 100.0.0.2 600 0 99 I
New and better looking results
AS99 needs to be neat & tidy and
advertise only /24s. While it is OK to
have small /32s internally, it is NOT
OK to advertise such small blocks to
eBGP peers.
Another important route-map that R1
should include is to reject 0.0.0.0/0
from eBGP Peers.
6. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – How does R3 (Right) learn about 200.0.0.0/24
What we know so far. R5 – ebgp – R1. R1 ONLY learns 200.0.0.0/24 from R5. OK
How does R5 tell the LEFT network about new 200.0.0.0/24?
How does R5 tell the RIGHT network about new 200.0.0.0/24? J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
R5 - AS100
ebgp
FA0/0
FA0/0
Lets look at R2 – LEFT
R2#show bgp sum
BGP router identifier 10.0.0.11, local AS number 99
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
10.0.0.3 4 99 13 6 19 0 0 00:01:01 10
R2#show ip bgp neighbors 10.0.0.3 routes
BGP table version is 19, local router ID is 10.0.0.11
Network Next Hop Metric LocPrf Weight Path
*>i10.0.0.0/24 10.0.0 100 0 i
...
*>i200.0.0.0 100.0.0.1 0 100 0 100
R2#show ip route 200.0.0.1
Routing entry for 200.0.0.0/24
Known via "bgp 99", distance 200, metric 0
Tag 100, type internal
Last update from 100.0.0.1 00:02:38 ago
Routing Descriptor Blocks:
* 100.0.0.1, from 10.0.0.3, 00:02:38 ago
Route metric is 0, traffic share count is 1
AS Hops 1
Route tag 100
One bgp neighbor only
Many routes ..
focus on
200.0.0.0/24
Installed ROUTES
BGP 99
Default distance (AD)
“tag” = AS100
Demonstrates how RR works. There is no direct ibgp r'ship
between R2 & R1 with each other; but BGP routes still shared.
Also interesting is how R3 learns the 200.0.0.0/24 route since its ibgp
neighbor is 10.0.0.4 (J04) and not J03. J03 ↔ exchange routes ↔
J04, and J04 made it available to R3.
Delete “cluster 10.0.0.x” on J03 or J04, restart BGP and see how the
200.0.0.0/24 network disappears from the RIGHT network!
What we ALSO understand is that BECAUSE we have used a
100.0.0.0/30 IP Address on R1@fa0/0 it has been injected into our
OSPF table as internally used. The same also applies to 20.0.0.0/30
between J03 ↔ J04!
Cisco R3
R3#show bgp sum
BGP router identifier 10.0.0.12, local AS number 99
Neighbor V AS MsgRcvd MsgSent TblVer InQ
10.0.0.4 4 99 66 51 23 0 0 00:24:20
R3#show ip bgp neighbors 10.0.0.4 routes
BGP table version is 23, local router ID is 10.0.0.12
Network Next Hop Metric LocPrf Weight Path
*>i10.0.0.0/24 10.0.0.3 100 0 i
...
*>i200.0.0.0 100.0.0.1 0 100 0 100 i
R3#show ip route 200.0.0.1
Routing entry for 200.0.0.0/24
Known via "bgp 99", distance 200, metric 0
Tag 100, type internal
Last update from 100.0.0.1 00:25:27 ago
Routing Descriptor Blocks:
* 100.0.0.1, from 10.0.0.4,
Route metric is 0, traffic share count is 1
AS Hops 1
Route tag 100
J04 - RR
200.0.0.0 –
target DST route
100.0.0.1 –
target next-hop
Learned
from J04
Find 100.0.0.1
and you will find
200.0.0.0/24
R3 will use
another CPU
cycle to find
100.0.0.1/OSPF
7. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Adding 2nd
EBGP Peers / Neighbors / Route-Maps
We are going to ADD another EBGP R6-AS200 to Cisco R2 and advertise 200.0.1.0/24
We will need to advertise the new AS200 to the LEFT & RIGHT
network as well as to AS100 which was established earlier. J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
R5 - AS100
ebgp
FA0/0
FA0/0
R6 - AS200
ebgp
FA0/0
FA0/0
Assuming that you have configured EBGP between AS99 (R2) ↔ AS200 (R6)
w/o any sort of route maps IN or OUT. You will expect to see that AS200
received many routes including AS100 prefix 200.0.0.0/24
R6 – AS200
R6#show ip route
B 200.0.0.0/24 [20/0] via 100.0.0.6, 00:02:38
20.0.0.0/30 is subnetted, 1 subnets
B 20.0.0.0 [20/0] via 100.0.0.6, 00:02:38
200.0.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 200.0.1.1/32 is directly connected, Loopback200
S 200.0.1.0/24 is directly connected, Null0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B 10.0.0.10/32 [20/0] via 100.0.0.6, 00:02:40
B 10.0.0.3/32 [20/0] via 100.0.0.6, 00:02:40
B 10.0.0.0/24 [20/0] via 100.0.0.6, 00:02:40
Confirm that
we can learn
AS100/prefix
R2 – AS99
R2#show ip bgp neighbors 100.0.0.5 routes
Network Next Hop Metric LocPrf Weight
*> 200.0.1.0 100.0.0.5 0 0 200 i
Confirm that
R02 is
receiving
routes from
AS200
The next QUESTION to ask. Is R5 (AS100) receiving
AS200/prefix (200.0.1.0/24)?
Quick answer is NO. This is 99% because we have a
ROUTE-MAP Out on R1(AS99) ↔ R5(AS100) and
there is an implicit DENY in the behavior.
Right now there are two remedial options:
a) modify ROUTE-MAP out on R1 ↔ R5 (AS100)
b) remove ROUTE-MAP out on R1 ↔ R5 (AS100)
Cisco R1 (AS99) → Cisco R5 (AS 100)
ip prefix-list 10 seq 5 permit 10.0.0.0/24
ip prefix-list 30 seq 5 permit 30.0.0.0/24
ip prefix-list 40 seq 5 permit 40.0.0.0/24
!
ip prefix-list AS200 seq 10 permit 200.0.1.0/24
!
route-map AS-99-OUT permit 10
match ip address prefix-list 10 30 40 AS200
set metric 600
* clear ip bgp 100 to reset bgp session
NEW
R5 – AS200 will now received AS200
R5#show ip route
100.0.0.0/30 is subnetted, 1 subnets
C 100.0.0.0 is directly connected, FastEthernet0/0
C 200.0.0.0/24 is directly connected, Loopback200
B 200.0.1.0/24 [20/600] via 100.0.0.2, 00:17:53
10.0.0.0/24 is subnetted, 1 subnets
B 10.0.0.0 [20/600] via 100.0.0.2, 00:17:53
30.0.0.0/24 is subnetted, 1 subnets
B 30.0.0.0 [20/600] via 100.0.0.2, 00:17:53
R5 receiving
AS200/prefix
NOTE:
The BIG problem here. What if we add AS300,
AS400, AS500 and so on? In order to ensure
that all routes are properly aggregated & all my
EBPG-Peers have visibility of each other, ALL
my ROUTE-MAP OUT will constantly require
modification/updates similar to R1..
How can this “inconvenience” be solved in a
more elegant way? Communities – Next Slide
Note: if J04 is set up properly, nothing extra
needs to be done for the RIGHT network to
learn AS100 & AS200
8. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Using BGP Communities
What are BGP Communities? These are a special set of instructions that can be created in BGP
and re-advertised in BGP throughout the network. All routers destined to received the
re-advertised routes/prefix/ASN will have an option to receive
the community and perform a certain configured action.
In our set up what we are going to do is the following:
1. EBGP is already set up with AS100 & AS200
2. The PROBLEM is, if I add another EBGP AS300, I will
have a lot of work to do. I will need to go to every
router and reconfigure a AS-99-OUT to recognize
the new AS300/prefix, accept it and advertise it to
the participating / neighbor ASN... I am lazy.
3. See Slide 7 (above) where I had to add “ip prefix-list AS200”
on Cisco R1 to advertise 200.0.1.0/24 to EBGP
neighbor AS100. A similar ip prefix-list ASXXX would be
required on Cisco R2 to advertise 200.0.0.0/24 to
EBGP neighbor AS200.
4. The situation will become MORE complex if R6-AS200 has another
downstream customer... say, AS210. How would YOU configure
AS210 → AS200 → AS99 → TRANSIT → AS100 AND vice-versa?
Our BGP Community Example
Out example is plain and NOT extensive. But it is hoped that it will provide
a small insight into what we can use BGP Communities for and how it
can help automate the set up. We will ONLY consider the current setup
where we R2 has to learn about routes from R5-AS100 (200.0.0.0/24)
and re-advertise it to R6-AS200.
Our plan is to get J03 to learn AS100/prefix AND tag it with community 99:355
and tell R2 about it. R2 will receive 99:355, “install it” and re-advertise it to AS200.
J03 will ALSO have to learn AS200/prefix, tag it 99:355, tell R1. R1 will then have to receive it, install it & re-advertise it to AS100.
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
R5 - AS100
ebgp
FA0/0
FA0/0
R6 - AS200
ebgp
FA0/0
FA0/0
E.G. AS300
The following MUST happen and we will use
BGP Communities to help us out.
1. J3 – Learns AS100/prefix (200.0.0.0/24)
2. J3 – Must tag it with 99:355
3. J3 – Must TELL Cisco R2
4. R2 - Must learn 99:355
5. R2 – Must ACCEPT it
6. R2 – Must TELL ebgp AS200
R6 – Will accept it anyway!
E.G. AS210
9. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Communities – Auto learn, tag & announce
BGP Communities
Learn iBGP prefix & tag it with 99:355
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
R5 - AS100
ebgp
FA0/0
FA0/0
R6 - AS200
ebgp
FA0/0
FA0/0
J03 – policy-option
policy-statement tag-355 {
term 1 {
from protocol bgp;
then {
community set ebgp-customers;
accept;
}
}
}
community ebgp-customers members 99:355;
Policy-Name
Learned from...
Add tags from community ...
We have created a policy-option named “tag-355”. It will learn
from protocol BGP and apply community name “ebgp-customers”:
99:355 as defined in community ebgp-customers a little lower
down the configs.
We need to APPLY this rule to the correct “protocols bgp group ...”
kjteoh@Junos-3> show conf.. proto.. bgp
group ibgp {
type internal;
local-address 10.0.0.3;
advertise-peer-as;
family inet {
unicast;
}
export [ ibgp_export tag-355 ];
cluster 10.0.0.3;
local-as 99;
neighbor 10.0.0.10 {
description Cisco-R1;
}
neighbor 10.0.0.11 {
description Cisco-R2;
}
Added – NEW
See Slide 3 for
a recap
After commit & clear
BGP neighbor .. test
your “new”
advertisements.
Now that this is done, what is J03 telling R2?
kjteoh@Junos-3> show route advertising-protocol bgp 10.0.0.11 200.0.0.0/24 detail
* 200.0.0.0/24 (1 entry, 1 announced)
BGP group ibgp type Internal
Nexthop: 100.0.0.1
MED: 0
Localpref: 100
AS path: [99] 100 I
Communities: 99:355
Cluster ID: 10.0.0.3
Originator ID: 10.0.0.10
J03 has learnt 200.0.0.0/24
and is tagging it with 99:355
AND is telling R2@10.0.0.11
R2 @10.0.0.11 needs to do now is create:
!
ip bgp-community new-format
ip community-list standard tag-355 permit 99:355
!
route-map AS-99-OUT permit 10
match ip address prefix-list 10 30 40 AS100
set metric 500
!
route-map AS-99-OUT permit 20
match community tag-355
set metric 355
Remove this.. see Slide 7
we don't want it anymore BUT
maintain prefix-list 10 30 & 40
Go to R6 and look at received
routes .. see metric 355
J3 learns
AS200
200.0.0.0
/24 untag
J3 tags
99:355
advertise it
R2 will learn
99:355 install
& advertise it
to AS200
Additional permit seq “20”
10. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco - Notes
Disadvantage of using RR? What does bgp multipath do for us? Add redundancy to both
networks by building iBGP adjacency. Eg. J03 ↔ R3 & R4.
What would the situation be if R1 has a new eBGP customer
R7 AS-300? … BIG Question here!
Kjteoh 11/3/2016
J03-RR-0.3 J04-RR-0.4
20.0.0.0/30
30.0.0.X/24 40.0.0.0/24
R1-0.10
R2-0.11
R3-0.12
R4-0.13
AS99
left right
em0 em0
FA0/1
FA0/1 FA0/1
FA0/1
em1
R5 - AS100
ebgp
FA0/0
FA0/0
R6 - AS200
ebgp
FA0/0
FA0/0
ebgp
R7 - AS300

More Related Content

What's hot

Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
Kishore Kumar
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
robertoxe
 
1
11
OSPF 3
OSPF 3OSPF 3
Cisco CCNA OSPF IPV6 Configuration
Cisco CCNA OSPF IPV6 ConfigurationCisco CCNA OSPF IPV6 Configuration
Cisco CCNA OSPF IPV6 Configuration
Hamed Moghaddam
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands Overview
Muhammed Niyas
 
Route Redistribution
Route RedistributionRoute Redistribution
Route Redistribution
Netwax Lab
 
Raspberry Pi I/O控制與感測器讀取
Raspberry Pi I/O控制與感測器讀取Raspberry Pi I/O控制與感測器讀取
Raspberry Pi I/O控制與感測器讀取
艾鍗科技
 
Day 12 enabling ospf
Day 12 enabling ospfDay 12 enabling ospf
Day 12 enabling ospf
CYBERINTELLIGENTS
 
Complete squid & firewall configuration. plus easy mac binding
Complete squid & firewall configuration. plus easy mac bindingComplete squid & firewall configuration. plus easy mac binding
Complete squid & firewall configuration. plus easy mac binding
Chanaka Lasantha
 
CDP Indicator
CDP IndicatorCDP Indicator
CDP Indicator
npsg
 
Linux router
Linux routerLinux router
Eigrp on a cisco asa firewall configuration
Eigrp on a cisco asa firewall configurationEigrp on a cisco asa firewall configuration
Eigrp on a cisco asa firewall configuration
3Anetwork com
 
Eincop Netwax Lab: Lab 1 static route
Eincop Netwax Lab: Lab 1 static routeEincop Netwax Lab: Lab 1 static route
Eincop Netwax Lab: Lab 1 static route
Netwax Lab
 
BGP Update Source
BGP Update Source BGP Update Source
BGP Update Source
NetProtocol Xpert
 
Cisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationCisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL Configuration
Hamed Moghaddam
 
EBGP MultiHop
EBGP MultiHopEBGP MultiHop
EBGP MultiHop
NetProtocol Xpert
 
FILES
FILESFILES
Per VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XRPer VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XR
Goerge Micheal Gerges
 
Ospf Cisco
Ospf CiscoOspf Cisco
Ospf Cisco
Alp isik
 

What's hot (20)

Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
1
11
1
 
OSPF 3
OSPF 3OSPF 3
OSPF 3
 
Cisco CCNA OSPF IPV6 Configuration
Cisco CCNA OSPF IPV6 ConfigurationCisco CCNA OSPF IPV6 Configuration
Cisco CCNA OSPF IPV6 Configuration
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands Overview
 
Route Redistribution
Route RedistributionRoute Redistribution
Route Redistribution
 
Raspberry Pi I/O控制與感測器讀取
Raspberry Pi I/O控制與感測器讀取Raspberry Pi I/O控制與感測器讀取
Raspberry Pi I/O控制與感測器讀取
 
Day 12 enabling ospf
Day 12 enabling ospfDay 12 enabling ospf
Day 12 enabling ospf
 
Complete squid & firewall configuration. plus easy mac binding
Complete squid & firewall configuration. plus easy mac bindingComplete squid & firewall configuration. plus easy mac binding
Complete squid & firewall configuration. plus easy mac binding
 
CDP Indicator
CDP IndicatorCDP Indicator
CDP Indicator
 
Linux router
Linux routerLinux router
Linux router
 
Eigrp on a cisco asa firewall configuration
Eigrp on a cisco asa firewall configurationEigrp on a cisco asa firewall configuration
Eigrp on a cisco asa firewall configuration
 
Eincop Netwax Lab: Lab 1 static route
Eincop Netwax Lab: Lab 1 static routeEincop Netwax Lab: Lab 1 static route
Eincop Netwax Lab: Lab 1 static route
 
BGP Update Source
BGP Update Source BGP Update Source
BGP Update Source
 
Cisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationCisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL Configuration
 
EBGP MultiHop
EBGP MultiHopEBGP MultiHop
EBGP MultiHop
 
FILES
FILESFILES
FILES
 
Per VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XRPer VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XR
 
Ospf Cisco
Ospf CiscoOspf Cisco
Ospf Cisco
 

Viewers also liked

Bgp
BgpBgp
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
Auguste Behe
 
mpls-04
mpls-04mpls-04
mpls-04
kj teoh
 
智能广域网及开源项目更新
智能广域网及开源项目更新智能广域网及开源项目更新
智能广域网及开源项目更新
Bertrand Duvivier
 
junos-firewall-filter
junos-firewall-filterjunos-firewall-filter
junos-firewall-filter
kj teoh
 
mpls-05
mpls-05mpls-05
mpls-05
kj teoh
 
Cisco crs1
Cisco crs1Cisco crs1
Cisco crs1
wjunjmt
 
BGP Graceful Shutdown - IOS XR
BGP Graceful Shutdown - IOS XR BGP Graceful Shutdown - IOS XR
BGP Graceful Shutdown - IOS XR
Bertrand Duvivier
 
Segment routing in ISO-XR 5.2.2
Segment routing in ISO-XR 5.2.2Segment routing in ISO-XR 5.2.2
Segment routing in ISO-XR 5.2.2
Bertrand Duvivier
 
BGP Route Aggregation Lab WorkBook
BGP Route Aggregation Lab WorkBookBGP Route Aggregation Lab WorkBook
BGP Route Aggregation Lab WorkBook
RHC Technologies
 
Segment Routing Lab
Segment Routing Lab Segment Routing Lab
Segment Routing Lab
Cisco Canada
 
BGP
BGPBGP
Traffic Engineering Using Segment Routing
Traffic Engineering Using Segment Routing Traffic Engineering Using Segment Routing
Traffic Engineering Using Segment Routing
Cisco Canada
 
Implementing Internet and MPLS BGP
Implementing Internet and MPLS BGPImplementing Internet and MPLS BGP
Implementing Internet and MPLS BGP
Private
 
Using BGP To Manage Dual Internet Connections
Using BGP To Manage Dual Internet ConnectionsUsing BGP To Manage Dual Internet Connections
Using BGP To Manage Dual Internet Connections
Rowell Dionicio
 
Bgp tutorial for ISP
Bgp tutorial for ISPBgp tutorial for ISP
Bgp tutorial for ISP
Wahyu Nasution
 
BGP Advance Technique by Steven & James
BGP Advance Technique by Steven & JamesBGP Advance Technique by Steven & James
BGP Advance Technique by Steven & James
Febrian ‎
 
Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010
Febrian ‎
 
BGP Traffic Engineering / Routing Optimisation
BGP Traffic Engineering / Routing OptimisationBGP Traffic Engineering / Routing Optimisation
BGP Traffic Engineering / Routing Optimisation
Andy Davidson
 
Border Gateway Protocol
Border Gateway ProtocolBorder Gateway Protocol
Border Gateway Protocol
Kashif Latif
 

Viewers also liked (20)

Bgp
BgpBgp
Bgp
 
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
 
mpls-04
mpls-04mpls-04
mpls-04
 
智能广域网及开源项目更新
智能广域网及开源项目更新智能广域网及开源项目更新
智能广域网及开源项目更新
 
junos-firewall-filter
junos-firewall-filterjunos-firewall-filter
junos-firewall-filter
 
mpls-05
mpls-05mpls-05
mpls-05
 
Cisco crs1
Cisco crs1Cisco crs1
Cisco crs1
 
BGP Graceful Shutdown - IOS XR
BGP Graceful Shutdown - IOS XR BGP Graceful Shutdown - IOS XR
BGP Graceful Shutdown - IOS XR
 
Segment routing in ISO-XR 5.2.2
Segment routing in ISO-XR 5.2.2Segment routing in ISO-XR 5.2.2
Segment routing in ISO-XR 5.2.2
 
BGP Route Aggregation Lab WorkBook
BGP Route Aggregation Lab WorkBookBGP Route Aggregation Lab WorkBook
BGP Route Aggregation Lab WorkBook
 
Segment Routing Lab
Segment Routing Lab Segment Routing Lab
Segment Routing Lab
 
BGP
BGPBGP
BGP
 
Traffic Engineering Using Segment Routing
Traffic Engineering Using Segment Routing Traffic Engineering Using Segment Routing
Traffic Engineering Using Segment Routing
 
Implementing Internet and MPLS BGP
Implementing Internet and MPLS BGPImplementing Internet and MPLS BGP
Implementing Internet and MPLS BGP
 
Using BGP To Manage Dual Internet Connections
Using BGP To Manage Dual Internet ConnectionsUsing BGP To Manage Dual Internet Connections
Using BGP To Manage Dual Internet Connections
 
Bgp tutorial for ISP
Bgp tutorial for ISPBgp tutorial for ISP
Bgp tutorial for ISP
 
BGP Advance Technique by Steven & James
BGP Advance Technique by Steven & JamesBGP Advance Technique by Steven & James
BGP Advance Technique by Steven & James
 
Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010Deploying IP/MPLS VPN - Cisco Networkers 2010
Deploying IP/MPLS VPN - Cisco Networkers 2010
 
BGP Traffic Engineering / Routing Optimisation
BGP Traffic Engineering / Routing OptimisationBGP Traffic Engineering / Routing Optimisation
BGP Traffic Engineering / Routing Optimisation
 
Border Gateway Protocol
Border Gateway ProtocolBorder Gateway Protocol
Border Gateway Protocol
 

Similar to bgp-01

mpls-06
mpls-06mpls-06
mpls-06
kj teoh
 
CCIE Lab - IGP Routing
CCIE Lab -  IGP Routing  CCIE Lab -  IGP Routing
CCIE Lab - IGP Routing
Kristof De Brouwer
 
Juniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route ConfigurationJuniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route Configuration
Hamed Moghaddam
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration
3Anetwork com
 
ospf ahmed tawfeek CCNA dump for Exam12
ospf  ahmed tawfeek CCNA dump for Exam12ospf  ahmed tawfeek CCNA dump for Exam12
ospf ahmed tawfeek CCNA dump for Exam12
ym7md88
 
OSPF_Exercises.pdf
OSPF_Exercises.pdfOSPF_Exercises.pdf
OSPF_Exercises.pdf
Denis Rasskazov
 
Juniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationJuniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route Configuration
Hamed Moghaddam
 
OSPF 3
OSPF 3OSPF 3
OSPF Internal Route Summarization
OSPF Internal Route SummarizationOSPF Internal Route Summarization
OSPF Internal Route Summarization
NetProtocol Xpert
 
Huawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatch
Huawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatchHuawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatch
Huawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatch
IPMAX s.r.l.
 
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
Josimar Caitano
 
Ospf Last Modified Eng
Ospf  Last Modified EngOspf  Last Modified Eng
Ospf Last Modified Eng
Alp isik
 
OSPF_multi.pdf
OSPF_multi.pdfOSPF_multi.pdf
OSPF_multi.pdf
Denis Rasskazov
 
IPv6_ROUTING_RIP
IPv6_ROUTING_RIPIPv6_ROUTING_RIP
Labs ospf
Labs ospfLabs ospf
Huawei ARG3 Router How To - Troubleshooting OSPF: Router ID Confusion
Huawei ARG3 Router How To - Troubleshooting OSPF: Router ID ConfusionHuawei ARG3 Router How To - Troubleshooting OSPF: Router ID Confusion
Huawei ARG3 Router How To - Troubleshooting OSPF: Router ID Confusion
IPMAX s.r.l.
 
MPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testingMPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testing
Stephane Litkowski
 
Ppt of routing protocols
Ppt of routing protocolsPpt of routing protocols
Ppt of routing protocols
Bhagyashri Dhoke
 
Bgp Basic Labs
Bgp Basic LabsBgp Basic Labs
Bgp Basic Labs
cisconetworker
 
Nxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarizationNxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarization
Netwax Lab
 

Similar to bgp-01 (20)

mpls-06
mpls-06mpls-06
mpls-06
 
CCIE Lab - IGP Routing
CCIE Lab -  IGP Routing  CCIE Lab -  IGP Routing
CCIE Lab - IGP Routing
 
Juniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route ConfigurationJuniper JNCIA – Juniper RIP and OSPF Route Configuration
Juniper JNCIA – Juniper RIP and OSPF Route Configuration
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration
 
ospf ahmed tawfeek CCNA dump for Exam12
ospf  ahmed tawfeek CCNA dump for Exam12ospf  ahmed tawfeek CCNA dump for Exam12
ospf ahmed tawfeek CCNA dump for Exam12
 
OSPF_Exercises.pdf
OSPF_Exercises.pdfOSPF_Exercises.pdf
OSPF_Exercises.pdf
 
Juniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationJuniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route Configuration
 
OSPF 3
OSPF 3OSPF 3
OSPF 3
 
OSPF Internal Route Summarization
OSPF Internal Route SummarizationOSPF Internal Route Summarization
OSPF Internal Route Summarization
 
Huawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatch
Huawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatchHuawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatch
Huawei ARG3 Router How To - Troubleshooting OSPF: Netmask mismatch
 
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
 
Ospf Last Modified Eng
Ospf  Last Modified EngOspf  Last Modified Eng
Ospf Last Modified Eng
 
OSPF_multi.pdf
OSPF_multi.pdfOSPF_multi.pdf
OSPF_multi.pdf
 
IPv6_ROUTING_RIP
IPv6_ROUTING_RIPIPv6_ROUTING_RIP
IPv6_ROUTING_RIP
 
Labs ospf
Labs ospfLabs ospf
Labs ospf
 
Huawei ARG3 Router How To - Troubleshooting OSPF: Router ID Confusion
Huawei ARG3 Router How To - Troubleshooting OSPF: Router ID ConfusionHuawei ARG3 Router How To - Troubleshooting OSPF: Router ID Confusion
Huawei ARG3 Router How To - Troubleshooting OSPF: Router ID Confusion
 
MPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testingMPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testing
 
Ppt of routing protocols
Ppt of routing protocolsPpt of routing protocols
Ppt of routing protocols
 
Bgp Basic Labs
Bgp Basic LabsBgp Basic Labs
Bgp Basic Labs
 
Nxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarizationNxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarization
 

bgp-01

  • 1. 1. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Basics Setup & OSPF Going back to basics with Network Design, Route-Reflectors (iBGP), OSPF & Finally eBGP J3 – Loop 10.0.0.3 J4 – Loop 10.0.0.4 R1 – Loop 10.0.0.10 R2 – Loop 10.0.0.11 R3 – Loop 10.0.0.12 R4 – Loop 10.0.0.13 J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 1. Get OSPF Talking in Area 0 2. Get J03 – J04 Talking iBGP-RR 3. Add R1/R2 → iBGP – J03 (left) 4. Add R3/R4 → iBGP – J04 (right) 5. Add eBGP PEERS 6. Design Route-Maps OUT 7. Design some Resiliency AS99 My IP ADDRESS Range 10.0.0.0/24 – Reserved for Loopbacks 20.0.0.0/30 – Private links betw J03-J04 30.0.0.0/24 – Reserved for ibgp (left) 40.0.0.0/24 – Reserved for ibgp (right) left right Have a closer look at our Network AS99. It really looks like two networks separated only by the 20.0.0.0/30 portion (interface em1). In fact, we can imagine that the “left” was the first network and later after expansion, a “right” network as added together with a the new IP Range 40.0.0.0/24. - Later on we will consider some “problems” with this design and how perhaps to overcome it. Junos J03 kjteoh@Junos-3> show configuration interfaces lo0 unit 0 { description Loop0; family inet { address 10.0.0.3/32; } kjteoh@Junos-3> show configuration interfaces em1 description Junos3-Junos4; unit 0 { family inet { address 20.0.0.1/30; } kjteoh@Junos-3> show configuration routing-options router-id router-id 10.0.0.3; kjteoh@Junos-3> show configuration protocols ospf area 0.0.0.0 { interface all; Cisco R1/R2 interface Loopback0 description loop ip address 10.0.0.10 255.255.255.255 ! interface FastEthernet0/1 description R1-Junos3 ip address 30.0.0.2 255.255.255.0 ! router ospf 99 router-id 10.0.0.10 log-adjacency-changes redistribute connected subnets passive-interface default no passive-interface FastEthernet0/1 network 0.0.0.0 255.255.255.255 area 0 Make sure everything works. kjteoh@Junos-3> show ospf neighbor Address Interface State ID 30.0.0.2 em0.0 Full 10.0.0.10 30.0.0.3 em0.0 Full 10.0.0.11 20.0.0.2 em1.0 Full 10.0.0.4 R2#show ip ospf neighbor Neighbor ID Pri State Dead Time Addres 10.0.0.3 128 FULL/DR 00:00:39 30.0.0.1 10.0.0.10 1 FULL/BDR 00:00:38 30.0.0.2 em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 Why is this important? Answer: the Cisco router are on the edge and if it is connected to an external peer the Cisco router will try and do OSPF with it and send hello packets. Not good!
  • 2. 2. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Config RR Making J03 and J04 participate as Route Reflector & iBGP neighbors J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 Really important to plan stuff out here especially with Junos. You have the options to create bgp “groups” which is an advantage but can go haywire/ messy/unmanageableif you don't properly plan it in the configs. J03 iBGP Configs & RR kjteoh@Junos-3> show configuration protocols bgp group ibgp-RR-ONLY type internal; local-address 10.0.0.3; advertise-peer-as; family inet { unicast; } export ibgp_export; cluster 10.0.0.3; local-as 99; neighbor 10.0.0.4 { description Junos4-RR; } Create a “group” and stick with it IBGP ONLY Define your Cluster You're DONE! Repeat the same on J04 cluster 10.0.0.4 Create Route-Map “out” kjteoh@Junos-3> ...cy-options policy-statement ibgp_export term 1 { from protocol direct; then accept; } term 3 { from protocol static; then accept; } term 2 { from protocol ospf; then accept; Mostly self-explanatory but this rule is interesting and it had to be created to make a 40.0.0.0/24 network (right) available to the 30.0.0.0/24 network on the left! (In iBGP) How do Route-Reflectors work? First, this only applies to iBGP. R1 & R2 only need to do iBGP with J03. J03 in turn learn iBGP routes from J04 and tell J03 about them. J04 will have his own set of iBGP neighbors … in our case, R3 & R4. They will learn routes from the “left” network via the exchange from J03 ↔ J04. Of course it is also possible for the Cisco clients R1 & R2 to do ibgp with J04 and it is a good idea too (dotted blue). J03 might fail. If this is the case, it is best to ensure that the Left network can physically find its way to the Right network. This can be achieved by trunking the switches above. But we will also understand that OSPF adjacency will grow for ALL the routers as they will become direct neighbors. Something to take note of. BUT, there is a DOWNSIDE to having Route-Reflectors over FULL-MESH. Can anybody tell me what it is? IBGP-LEFT Trunk IBGP- RIGHT .. Maybe Later kjteoh@Junos-3> show route receive-protocol bgp 10.0.0.4 inet.0: Prefix Nexthop MED Lclpref AS path 10.0.0.4/32 10.0.0.4 100 I 10.0.0.12/32 40.0.0.2 2 100 I 10.0.0.13/32 40.0.0.3 2 100 I 20.0.0.0/30 10.0.0.4 100 I 40.0.0.0/24 10.0.0.4 100 I Loops & interface IP of R3 & R4 from “right” network “Right” network origination the 40.0.0.0/24 block kjteoh@Junos-3> show route table inet.0 40.0.0.0/24 40.0.0.0/24 *[OSPF/10] 01:14:33, metric 2 > to 20.0.0.2 via em1.0 [BGP/170] 01:13:43, localpref 100, from 10.0.0.4 AS path: I > to 20.0.0.2 via em1.0
  • 3. 3. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Config RR – Adding iBGP Peers R1 & R2 Adding iBGP Peers to J03... R1 & R2 – Prepare J03 to accept clients J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 Configs J03 group ibgp { type internal; local-address 10.0.0.3; advertise-peer-as; family inet { unicast; } export ibgp_export; cluster 10.0.0.3; local-as 99; neighbor 10.0.0.10 { description Cisco-R1; } neighbor 10.0.0.11 { description Cisco-R2; } } Specific group created for Left network RR cluster ID for J03 & local AS99 Neighbor IP Configs Route-Map OUT Configs R1/R2 router bgp 99 neighbor 10.0.0.3 remote-as 99 neighbor 10.0.0.3 update-source Loopback0 ! address-family ipv4 neighbor 10.0.0.3 activate neighbor 10.0.0.3 soft-reconfiguration inbound ! Neighbor IP Loop J03 IBGP Is this Important? Does R1 & R2 have multiple exit points to J03? What about Next hop- self? What is soft-recon .. Is this mandatory? Properly configured … J03 kjteoh@Junos-3> show bgp summary Groups: 3 Peers: 5 Down peers: 0 Peer AS InPkt OutPkt OutQ 10.0.0.4 99 87 88 0 0 10.0.0.10 99 82 97 0 0 10.0.0.11 99 81 96 0 0 Cisco R2 R2#show bgp sum BGP router identifier 10.0.0.11, local AS number 99 Neighbor V AS MsgRcvd MsgSent Tbl 10.0.0.3 4 99 88 76 24 My IBGP AS This is J04 configured in slide 2 The Cisco R1 & R2 neighbor The J03 neighbor configured. I will learn router R1 from this iBGP neighbor (not ospf). Does this mean that I (R2) will INSTALL it? R2#show ip bgp neighbors 10.0.0.3 routes BGP table version is 24, local router ID is 10.0.0.11 Origin codes: i - IGP, e - EGP, ? - incomplete Network Next Hop Metric LocPrf Weight Path *>i10.0.0.0/24 10.0.0.3 100 0 i r>i10.0.0.3/32 10.0.0.3 100 0 i r>i10.0.0.4/32 20.0.0.2 1 100 0 i r>i10.0.0.10/32 30.0.0.2 2 100 0 i In terms of ROUTING, which prefix will be installed in Cisco R2? 10.0.0.0/24 or 10.0.0.10/32? Compare: show ip route 10.0.0.10 Why is this MANDATORY? Cisco syntax below
  • 4. 4. Back to Basics – OSPF / iBGP (Route Reflectors) - What R1/R2 is really learning from “Right” side Refer slide 3 and perform the same between J04 ↔ Cisco R3 & R4. We will have the following setup … One of the main Questions you should be asking yourself is … who and which router is ORIGINATING routes for ..10.0.0.0/24, 30.0.0.0/24 & 40.0.0.0/24? How are routes originated? Is this an automatic process? Is this OSPF or BGP? Is there such a thing as originating routes in OSPF? J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 Left Network J03 Junos03 ibgp neighbors R1 @ 10.0.0.10 R2 @ 10.0.0.11 Router J03 Right Network J04 Junos04 ibgp neighbors R3 @ 10.0.0.12 R4 @ 10.0.0.13 Router J04 IBGP 20.0.0.0/30 Router R1 Router R2 IBGP 10.0.0.0/24 30.0.0.0/24 IBGP 10.0.0.0/24 40.0.0.0/24 Router R3 Router R4 Cluster RR 10.0.0.3 & .4 R2#show ip route 20.0.0.0/30 is subnetted, 1 subnets O 20.0.0.0 [110/11] via 30.0.0.1, 01:54:57, FastEthernet0/1 40.0.0.0/24 is subnetted, 1 subnets O 40.0.0.0 [110/12] via 30.0.0.1, 01:50:53, FastEthernet0/1 10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks O 10.0.0.10/32 [110/11] via 30.0.0.2, 01:56:32, FastEthernet0/1 C 10.0.0.11/32 is directly connected, Loopback0 O 10.0.0.12/32 [110/13] via 30.0.0.1, 01:50:55, FastEthernet0/1 O 10.0.0.13/32 [110/13] via 30.0.0.1, 01:50:55, FastEthernet0/1 O 10.0.0.3/32 [110/10] via 30.0.0.1, 01:55:00, FastEthernet0/1 B 10.0.0.0/24 [200/0] via 10.0.0.3, 01:54:19 O 10.0.0.4/32 [110/11] via 30.0.0.1, 01:51:17, FastEthernet0/1 30.0.0.0/24 is subnetted, 1 subnets C 30.0.0.0 is directly connected, FastEthernet0/ Relevant Codes: B – BGP C – connected O – OSPF This is a small network and we should really take the time to go through every route and understand how it is learned and where it is coming from. We can “learn” routes from many Routers & SOURCES (protocols), but we install only ONE route and use it for routing. It is possible to learn one route from one router and from different source (protocols). R2#show ip route 10.0.0.2 Routing entry for 10.0.0.0/24 Known via "bgp 99", distance 200, metric 0, type internal Last update from 10.0.0.3 00:00:08 ago Routing Descriptor Blocks: * 10.0.0.3, from 10.0.0.3, 00:00:08 ago Route metric is 0, traffic share count is 1 AS Hops 0 This becomes really important when you start doing EBGP with other networks / ASNs
  • 5. 5. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Adding EBGP Peers / Neighbors / Route-Maps Adding R5-AS100 with routes 200.0.0.0/24. Set up direct connection between R5 – R1. You will do eBGP on this link – R5@fa0/0 ↔ R1@fa0/0 J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 R5 - AS100 ebgp FA0/0 FA0/0 Configs on R5 - AS100 interface Loopback200 description loopback200 ip address 200.0.0.1 255.255.255.0 ! interface FastEthernet0/0 description ebgp-R5-R1 ip address 100.0.0.1 255.255.255.252 ! router bgp 100 bgp log-neighbor-changes neighbor 100.0.0.2 remote-as 99 ! address-family ipv4 neighbor 100.0.0.2 activate neighbor 100.0.0.2 soft-reconfiguration inbound no auto-summary no synchronization network 200.0.0.0 exit-address-family ! ! ! ip forward-protocol nd ip route 200.0.0.0 255.255.255.0 Null0 name BGP-PULL-UP Originating Routes E-BGP Peer Note: On Junos we write type “internal or external” & peer-as Create “routes” to advertise. Remember, R5 is ONLY running BGP. There isn't another protocol to learn from and inject into BGP Configs on R1 router bgp 99 bgp log-neighbor-changes neighbor 10.0.0.3 remote-as 99 neighbor 10.0.0.3 update-source Loopback0 neighbor 100.0.0.1 remote-as 100 ! address-family ipv4 neighbor 10.0.0.3 activate neighbor 10.0.0.3 soft-reconfiguration inbound neighbor 100.0.0.1 activate neighbor 100.0.0.1 soft-reconfiguration inboundR5#show ip bgp neighbors 100.0.0.2 routes BGP table version is 48, local router ID is 200.0.0.1 Network Next Hop Metric LocPrf *> 10.0.0.0/24 100.0.0.2 0 99 i *> 10.0.0.3/32 100.0.0.2 0 99 i *> 10.0.0.11/32 100.0.0.2 0 99 i *> 20.0.0.0/30 100.0.0. 0 99 i *> 30.0.0.0/24 100.0.0.2 0 99 i *> 100.0.0.4/30 100.0.0.2 0 99 i Problem here: R1 is sending even /32s! Not good. R1 needs a route-map OUT. See AS-99-OUT on Cisco R1 neighbor 100.0.0.1 route-map AS-99-OUT out ! ip prefix-list 10 seq 5 permit 10.0.0.0/24 ip prefix-list 30 seq 5 permit 30.0.0.0/24 ip prefix-list 40 seq 5 permit 40.0.0.0/24 ! ! ! route-map AS-99-OUT permit 10 match ip address prefix-list 10 30 40 set metric 600 R5#show ip bgp neighbors 100.0.0.2 routes BGP table version is 56, local router ID is 200.0.0.1 Network Next Hop Metric LocPrf *> 10.0.0.0/24 100.0.0.2 600 0 99 i *> 30.0.0.0/24 100.0.0.2 600 0 99 i *> 40.0.0.0/24 100.0.0.2 600 0 99 I New and better looking results AS99 needs to be neat & tidy and advertise only /24s. While it is OK to have small /32s internally, it is NOT OK to advertise such small blocks to eBGP peers. Another important route-map that R1 should include is to reject 0.0.0.0/0 from eBGP Peers.
  • 6. 6. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – How does R3 (Right) learn about 200.0.0.0/24 What we know so far. R5 – ebgp – R1. R1 ONLY learns 200.0.0.0/24 from R5. OK How does R5 tell the LEFT network about new 200.0.0.0/24? How does R5 tell the RIGHT network about new 200.0.0.0/24? J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 R5 - AS100 ebgp FA0/0 FA0/0 Lets look at R2 – LEFT R2#show bgp sum BGP router identifier 10.0.0.11, local AS number 99 Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down 10.0.0.3 4 99 13 6 19 0 0 00:01:01 10 R2#show ip bgp neighbors 10.0.0.3 routes BGP table version is 19, local router ID is 10.0.0.11 Network Next Hop Metric LocPrf Weight Path *>i10.0.0.0/24 10.0.0 100 0 i ... *>i200.0.0.0 100.0.0.1 0 100 0 100 R2#show ip route 200.0.0.1 Routing entry for 200.0.0.0/24 Known via "bgp 99", distance 200, metric 0 Tag 100, type internal Last update from 100.0.0.1 00:02:38 ago Routing Descriptor Blocks: * 100.0.0.1, from 10.0.0.3, 00:02:38 ago Route metric is 0, traffic share count is 1 AS Hops 1 Route tag 100 One bgp neighbor only Many routes .. focus on 200.0.0.0/24 Installed ROUTES BGP 99 Default distance (AD) “tag” = AS100 Demonstrates how RR works. There is no direct ibgp r'ship between R2 & R1 with each other; but BGP routes still shared. Also interesting is how R3 learns the 200.0.0.0/24 route since its ibgp neighbor is 10.0.0.4 (J04) and not J03. J03 ↔ exchange routes ↔ J04, and J04 made it available to R3. Delete “cluster 10.0.0.x” on J03 or J04, restart BGP and see how the 200.0.0.0/24 network disappears from the RIGHT network! What we ALSO understand is that BECAUSE we have used a 100.0.0.0/30 IP Address on R1@fa0/0 it has been injected into our OSPF table as internally used. The same also applies to 20.0.0.0/30 between J03 ↔ J04! Cisco R3 R3#show bgp sum BGP router identifier 10.0.0.12, local AS number 99 Neighbor V AS MsgRcvd MsgSent TblVer InQ 10.0.0.4 4 99 66 51 23 0 0 00:24:20 R3#show ip bgp neighbors 10.0.0.4 routes BGP table version is 23, local router ID is 10.0.0.12 Network Next Hop Metric LocPrf Weight Path *>i10.0.0.0/24 10.0.0.3 100 0 i ... *>i200.0.0.0 100.0.0.1 0 100 0 100 i R3#show ip route 200.0.0.1 Routing entry for 200.0.0.0/24 Known via "bgp 99", distance 200, metric 0 Tag 100, type internal Last update from 100.0.0.1 00:25:27 ago Routing Descriptor Blocks: * 100.0.0.1, from 10.0.0.4, Route metric is 0, traffic share count is 1 AS Hops 1 Route tag 100 J04 - RR 200.0.0.0 – target DST route 100.0.0.1 – target next-hop Learned from J04 Find 100.0.0.1 and you will find 200.0.0.0/24 R3 will use another CPU cycle to find 100.0.0.1/OSPF
  • 7. 7. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Adding 2nd EBGP Peers / Neighbors / Route-Maps We are going to ADD another EBGP R6-AS200 to Cisco R2 and advertise 200.0.1.0/24 We will need to advertise the new AS200 to the LEFT & RIGHT network as well as to AS100 which was established earlier. J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 R5 - AS100 ebgp FA0/0 FA0/0 R6 - AS200 ebgp FA0/0 FA0/0 Assuming that you have configured EBGP between AS99 (R2) ↔ AS200 (R6) w/o any sort of route maps IN or OUT. You will expect to see that AS200 received many routes including AS100 prefix 200.0.0.0/24 R6 – AS200 R6#show ip route B 200.0.0.0/24 [20/0] via 100.0.0.6, 00:02:38 20.0.0.0/30 is subnetted, 1 subnets B 20.0.0.0 [20/0] via 100.0.0.6, 00:02:38 200.0.1.0/24 is variably subnetted, 2 subnets, 2 masks C 200.0.1.1/32 is directly connected, Loopback200 S 200.0.1.0/24 is directly connected, Null0 10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks B 10.0.0.10/32 [20/0] via 100.0.0.6, 00:02:40 B 10.0.0.3/32 [20/0] via 100.0.0.6, 00:02:40 B 10.0.0.0/24 [20/0] via 100.0.0.6, 00:02:40 Confirm that we can learn AS100/prefix R2 – AS99 R2#show ip bgp neighbors 100.0.0.5 routes Network Next Hop Metric LocPrf Weight *> 200.0.1.0 100.0.0.5 0 0 200 i Confirm that R02 is receiving routes from AS200 The next QUESTION to ask. Is R5 (AS100) receiving AS200/prefix (200.0.1.0/24)? Quick answer is NO. This is 99% because we have a ROUTE-MAP Out on R1(AS99) ↔ R5(AS100) and there is an implicit DENY in the behavior. Right now there are two remedial options: a) modify ROUTE-MAP out on R1 ↔ R5 (AS100) b) remove ROUTE-MAP out on R1 ↔ R5 (AS100) Cisco R1 (AS99) → Cisco R5 (AS 100) ip prefix-list 10 seq 5 permit 10.0.0.0/24 ip prefix-list 30 seq 5 permit 30.0.0.0/24 ip prefix-list 40 seq 5 permit 40.0.0.0/24 ! ip prefix-list AS200 seq 10 permit 200.0.1.0/24 ! route-map AS-99-OUT permit 10 match ip address prefix-list 10 30 40 AS200 set metric 600 * clear ip bgp 100 to reset bgp session NEW R5 – AS200 will now received AS200 R5#show ip route 100.0.0.0/30 is subnetted, 1 subnets C 100.0.0.0 is directly connected, FastEthernet0/0 C 200.0.0.0/24 is directly connected, Loopback200 B 200.0.1.0/24 [20/600] via 100.0.0.2, 00:17:53 10.0.0.0/24 is subnetted, 1 subnets B 10.0.0.0 [20/600] via 100.0.0.2, 00:17:53 30.0.0.0/24 is subnetted, 1 subnets B 30.0.0.0 [20/600] via 100.0.0.2, 00:17:53 R5 receiving AS200/prefix NOTE: The BIG problem here. What if we add AS300, AS400, AS500 and so on? In order to ensure that all routes are properly aggregated & all my EBPG-Peers have visibility of each other, ALL my ROUTE-MAP OUT will constantly require modification/updates similar to R1.. How can this “inconvenience” be solved in a more elegant way? Communities – Next Slide Note: if J04 is set up properly, nothing extra needs to be done for the RIGHT network to learn AS100 & AS200
  • 8. 8. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Using BGP Communities What are BGP Communities? These are a special set of instructions that can be created in BGP and re-advertised in BGP throughout the network. All routers destined to received the re-advertised routes/prefix/ASN will have an option to receive the community and perform a certain configured action. In our set up what we are going to do is the following: 1. EBGP is already set up with AS100 & AS200 2. The PROBLEM is, if I add another EBGP AS300, I will have a lot of work to do. I will need to go to every router and reconfigure a AS-99-OUT to recognize the new AS300/prefix, accept it and advertise it to the participating / neighbor ASN... I am lazy. 3. See Slide 7 (above) where I had to add “ip prefix-list AS200” on Cisco R1 to advertise 200.0.1.0/24 to EBGP neighbor AS100. A similar ip prefix-list ASXXX would be required on Cisco R2 to advertise 200.0.0.0/24 to EBGP neighbor AS200. 4. The situation will become MORE complex if R6-AS200 has another downstream customer... say, AS210. How would YOU configure AS210 → AS200 → AS99 → TRANSIT → AS100 AND vice-versa? Our BGP Community Example Out example is plain and NOT extensive. But it is hoped that it will provide a small insight into what we can use BGP Communities for and how it can help automate the set up. We will ONLY consider the current setup where we R2 has to learn about routes from R5-AS100 (200.0.0.0/24) and re-advertise it to R6-AS200. Our plan is to get J03 to learn AS100/prefix AND tag it with community 99:355 and tell R2 about it. R2 will receive 99:355, “install it” and re-advertise it to AS200. J03 will ALSO have to learn AS200/prefix, tag it 99:355, tell R1. R1 will then have to receive it, install it & re-advertise it to AS100. J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 R5 - AS100 ebgp FA0/0 FA0/0 R6 - AS200 ebgp FA0/0 FA0/0 E.G. AS300 The following MUST happen and we will use BGP Communities to help us out. 1. J3 – Learns AS100/prefix (200.0.0.0/24) 2. J3 – Must tag it with 99:355 3. J3 – Must TELL Cisco R2 4. R2 - Must learn 99:355 5. R2 – Must ACCEPT it 6. R2 – Must TELL ebgp AS200 R6 – Will accept it anyway! E.G. AS210
  • 9. 9. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco – Communities – Auto learn, tag & announce BGP Communities Learn iBGP prefix & tag it with 99:355 J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 R5 - AS100 ebgp FA0/0 FA0/0 R6 - AS200 ebgp FA0/0 FA0/0 J03 – policy-option policy-statement tag-355 { term 1 { from protocol bgp; then { community set ebgp-customers; accept; } } } community ebgp-customers members 99:355; Policy-Name Learned from... Add tags from community ... We have created a policy-option named “tag-355”. It will learn from protocol BGP and apply community name “ebgp-customers”: 99:355 as defined in community ebgp-customers a little lower down the configs. We need to APPLY this rule to the correct “protocols bgp group ...” kjteoh@Junos-3> show conf.. proto.. bgp group ibgp { type internal; local-address 10.0.0.3; advertise-peer-as; family inet { unicast; } export [ ibgp_export tag-355 ]; cluster 10.0.0.3; local-as 99; neighbor 10.0.0.10 { description Cisco-R1; } neighbor 10.0.0.11 { description Cisco-R2; } Added – NEW See Slide 3 for a recap After commit & clear BGP neighbor .. test your “new” advertisements. Now that this is done, what is J03 telling R2? kjteoh@Junos-3> show route advertising-protocol bgp 10.0.0.11 200.0.0.0/24 detail * 200.0.0.0/24 (1 entry, 1 announced) BGP group ibgp type Internal Nexthop: 100.0.0.1 MED: 0 Localpref: 100 AS path: [99] 100 I Communities: 99:355 Cluster ID: 10.0.0.3 Originator ID: 10.0.0.10 J03 has learnt 200.0.0.0/24 and is tagging it with 99:355 AND is telling R2@10.0.0.11 R2 @10.0.0.11 needs to do now is create: ! ip bgp-community new-format ip community-list standard tag-355 permit 99:355 ! route-map AS-99-OUT permit 10 match ip address prefix-list 10 30 40 AS100 set metric 500 ! route-map AS-99-OUT permit 20 match community tag-355 set metric 355 Remove this.. see Slide 7 we don't want it anymore BUT maintain prefix-list 10 30 & 40 Go to R6 and look at received routes .. see metric 355 J3 learns AS200 200.0.0.0 /24 untag J3 tags 99:355 advertise it R2 will learn 99:355 install & advertise it to AS200 Additional permit seq “20”
  • 10. 10. Back to Basics – OSPF / iBGP (Route Reflectors) / eBGP Junos – Cisco - Notes Disadvantage of using RR? What does bgp multipath do for us? Add redundancy to both networks by building iBGP adjacency. Eg. J03 ↔ R3 & R4. What would the situation be if R1 has a new eBGP customer R7 AS-300? … BIG Question here! Kjteoh 11/3/2016 J03-RR-0.3 J04-RR-0.4 20.0.0.0/30 30.0.0.X/24 40.0.0.0/24 R1-0.10 R2-0.11 R3-0.12 R4-0.13 AS99 left right em0 em0 FA0/1 FA0/1 FA0/1 FA0/1 em1 R5 - AS100 ebgp FA0/0 FA0/0 R6 - AS200 ebgp FA0/0 FA0/0 ebgp R7 - AS300