SlideShare a Scribd company logo
Basic Cisco 800 Router Configuration for
Internet Access
The Cisco 800 series routers are part of the “Branch Office” category, used mainly
for SOHO purposes or for connecting remote branch offices to a central location.
They are “fixed hardware configuration” devices, meaning that they don’t have
any plug-in hardware slots for inserting additional interfaces to the device (all the
interfaces are fixed).
All the 800 series models come with a 4-port 10/100 managed switch used for
connecting the internal LAN computers, and with an IOS software that supports
security features including the Firewall set. The main difference of each model is
the WAN interface. All models that end with “1” in the model number (i.e 851,
861, 871, 881, 891) have a 10/100 Fast Ethernet interface as a WAN port. The
other models have an xDSL type WAN port (i.e ADSL, G.SHDL, VDSL2). Also,
all models have the option of a WiFi Radio interface (the model number ends with
a “W”, e.g 851W, 857W, 861W etc).
In this post I will describe a basic configuration scenario for connecting a Cisco
800 router for Internet access. I will use a model with an Ethernet WAN interface
(such as 851, 861, 871, etc) since those models are the most popular.
Something to have in mind for all 800 series routers, the four LAN interfaces (FE0
up to FE3) are Layer2 switch interfaces that are assigned by default to Vlan1. This
means that you can not assign an IP address directly to the LAN interfaces. The IP
address for the LAN-facing side of the router is assigned under “interface Vlan1”.
On the other hand, the WAN interface (FE4) is a normal Layer3 router port, which
means you can assign an IP address directly on the interface (“interface
FastEthernet4”).
I will describe three basic scenarios which are frequently encountered in real
networks.
1. Scenario 1: WAN IP address of router is assigned dynamically by the ISP.
LAN IP addresses assigned dynamically from the router to the internal PCs.
2. Scenario 2: WAN IP address of router is static. LAN IP addresses assigned
dynamically from the router.
3. Scenario 3: WAN IP address of router is static. An internal LAN Web
Server exists. The router performs a static Port NAT (port redirection) to
forward traffic from Internet towards the internal Web Server.
Scenario 1:
Configuration:
The following is the basic configuration needed for the simple scenario above.
configure terminal
enable secret somesecretpassword
! Configure the DHCP pool to assign addresses to internal hosts
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 100.100.100.36
! Do not assign addresses 1 to 30
ip dhcp excluded-address 192.168.1.1 192.168.1.30
! This is the LAN facing interface of the 800 router. Used as gateway for PCs
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shut
! Interfaces FE0 to FE3 are Layer 2 interfaces
interface FastEthernet0
no shut
interface FastEthernet1
no shut
interface FastEthernet2
no shut
interface FastEthernet3
no shut
! This is the WAN interface getting address via DHCP from the ISP
interface FastEthernet 4
no shut
ip address dhcp
ip nat outside
! Configure NAT. All internal hosts will be nated on the WAN interface
ip nat inside source list 1 interface fastethernet4 overload
access-list 1 permit 192.168.1.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 fastethernet4
line vty 0 4
password somestrongpassword
Scenario 2:
Configuration:
This is the same configuration as scenario 1 except that the WAN IP address is
static and also the default gateway of our ISP is known.
The only difference from the configuration above is on the WAN interface and on
default route:
! This is the WAN interface with static IP
interface FastEthernet 4
no shut
ip address 100.100.100.1 255.255.255.0
ip nat outside
ip route 0.0.0.0 0.0.0.0 100.100.100.2
Scenario 3:
Configuration:
Here the WAN address is static and we have also an internal Web Server for which
we need to allow HTTP access from Internet. To do this we must configure a static
NAT with port redirection. Traffic that comes towards our WAN public address
100.100.100.1 on port 80 will be redirected by the router to the internal Web
Server at address 192.168.1.10 on port 80.
configure terminal
enable secret somesecretpassword
! Configure the DHCP pool to assign addresses to internal hosts
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 100.100.100.36
! Do not assign addresses 1 to 30
ip dhcp excluded-address 192.168.1.1 192.168.1.30
! This is the LAN facing interface of the 800 router. Used as gateway for PCs
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shut
! Interfaces FE0 to FE3 are Layer 2 interfaces
interface FastEthernet0
no shut
interface FastEthernet1
no shut
interface FastEthernet2
no shut
interface FastEthernet3
no shut
! This is the WAN interface with static IP
interface FastEthernet 4
no shut
ip address 100.100.100.1 255.255.255.0
ip nat outside
! Configure NAT. All internal hosts will be nated on the WAN interface
ip nat inside source list 1 interface fastethernet4 overload
access-list 1 permit 192.168.1.0 0.0.0.255
! Configure static NAT for port redirection
ip nat inside source static tcp 192.168.1.10 80 100.100.100.1 80 extendable
ip route 0.0.0.0 0.0.0.0 100.100.100.2
line vty 0 4
password somestrongpassword
About the Author
Harris Andrea is a Cisco Certified Professional with more than 18 years of experience
working with Cisco network technologies. He is the author of two Cisco Books
(“Cisco ASA Firewall Fundamentals” and “Cisco VPN Configuration Guide”) which
have been embraced by thousands of Cisco professionals all over the world. You can
find more Cisco configuration guides and tutorials on his blog here
http://www.networkstraining.com

More Related Content

What's hot

CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdfCCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
poojaswami31
 
CCNP Route - OSPF
CCNP Route - OSPFCCNP Route - OSPF
CCNP Route - OSPF
mdyabi
 
Cours VTP
Cours VTPCours VTP
Configuring GRE Tunnel Through a Cisco ASA Firewall
Configuring GRE Tunnel Through a Cisco ASA FirewallConfiguring GRE Tunnel Through a Cisco ASA Firewall
Configuring GRE Tunnel Through a Cisco ASA Firewall
Harris Andrea
 
Cours Vlan
Cours VlanCours Vlan
Cours Vlan
EL AMRI El Hassan
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
Kishore Kumar
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic Configuration
Prof. Erwin Globio
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
Eng. Emad Al-Atoum
 
A comparison of segment routing data-plane encodings
A comparison of segment routing data-plane encodingsA comparison of segment routing data-plane encodings
A comparison of segment routing data-plane encodings
Gunter Van de Velde
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
3Anetwork com
 
Cisco Catalyst 6500 Technical Deep Dive.pdf
Cisco Catalyst 6500 Technical Deep Dive.pdfCisco Catalyst 6500 Technical Deep Dive.pdf
Cisco Catalyst 6500 Technical Deep Dive.pdf
juergenJaeckel
 
Basics of firewall, ebtables, arptables and iptables
Basics of firewall, ebtables, arptables and iptablesBasics of firewall, ebtables, arptables and iptables
Basics of firewall, ebtables, arptables and iptables
Przemysław Piotrowski
 
IGMP
IGMPIGMP
MikroTik & RouterOS
MikroTik & RouterOSMikroTik & RouterOS
MikroTik & RouterOS
Faelix Ltd
 
VLAN Trunking Protocol
VLAN Trunking ProtocolVLAN Trunking Protocol
VLAN Trunking Protocol
Netwax Lab
 
The IPv6-Only Network
The IPv6-Only NetworkThe IPv6-Only Network
The IPv6-Only Network
APNIC
 
IPv6
IPv6IPv6
IPv6
medalaa
 
Howto createOpenFlow Switchusing FPGA (at FPGAX#6)
Howto createOpenFlow Switchusing FPGA (at FPGAX#6)Howto createOpenFlow Switchusing FPGA (at FPGAX#6)
Howto createOpenFlow Switchusing FPGA (at FPGAX#6)
Kentaro Ebisawa
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
Thomas Moegli
 
Virtual Local Area Network (VLAN)
Virtual Local Area Network (VLAN)Virtual Local Area Network (VLAN)
Virtual Local Area Network (VLAN)
Mohammad Javad Abdolmaleki
 

What's hot (20)

CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdfCCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
CCNA-LAB-GUIDE-V3_LAST-ADDITION (4).pdf
 
CCNP Route - OSPF
CCNP Route - OSPFCCNP Route - OSPF
CCNP Route - OSPF
 
Cours VTP
Cours VTPCours VTP
Cours VTP
 
Configuring GRE Tunnel Through a Cisco ASA Firewall
Configuring GRE Tunnel Through a Cisco ASA FirewallConfiguring GRE Tunnel Through a Cisco ASA Firewall
Configuring GRE Tunnel Through a Cisco ASA Firewall
 
Cours Vlan
Cours VlanCours Vlan
Cours Vlan
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic Configuration
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
A comparison of segment routing data-plane encodings
A comparison of segment routing data-plane encodingsA comparison of segment routing data-plane encodings
A comparison of segment routing data-plane encodings
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
Cisco Catalyst 6500 Technical Deep Dive.pdf
Cisco Catalyst 6500 Technical Deep Dive.pdfCisco Catalyst 6500 Technical Deep Dive.pdf
Cisco Catalyst 6500 Technical Deep Dive.pdf
 
Basics of firewall, ebtables, arptables and iptables
Basics of firewall, ebtables, arptables and iptablesBasics of firewall, ebtables, arptables and iptables
Basics of firewall, ebtables, arptables and iptables
 
IGMP
IGMPIGMP
IGMP
 
MikroTik & RouterOS
MikroTik & RouterOSMikroTik & RouterOS
MikroTik & RouterOS
 
VLAN Trunking Protocol
VLAN Trunking ProtocolVLAN Trunking Protocol
VLAN Trunking Protocol
 
The IPv6-Only Network
The IPv6-Only NetworkThe IPv6-Only Network
The IPv6-Only Network
 
IPv6
IPv6IPv6
IPv6
 
Howto createOpenFlow Switchusing FPGA (at FPGAX#6)
Howto createOpenFlow Switchusing FPGA (at FPGAX#6)Howto createOpenFlow Switchusing FPGA (at FPGAX#6)
Howto createOpenFlow Switchusing FPGA (at FPGAX#6)
 
Protocole OSPF
Protocole OSPFProtocole OSPF
Protocole OSPF
 
Virtual Local Area Network (VLAN)
Virtual Local Area Network (VLAN)Virtual Local Area Network (VLAN)
Virtual Local Area Network (VLAN)
 

Viewers also liked

Route Redistribution
Route RedistributionRoute Redistribution
Route Redistribution
Netwax Lab
 
Overview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCPOverview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCP
give2asia
 
Editioning use in ebs
Editioning use in  ebsEditioning use in  ebs
Editioning use in ebs
pasalapudi123
 
Img056
Img056Img056
How To Promote Your Business On Pinterest
How To Promote Your Business On PinterestHow To Promote Your Business On Pinterest
How To Promote Your Business On Pinterest
Team Mango Media Private Limited
 
Asat book0-fresh blood
Asat book0-fresh bloodAsat book0-fresh blood
Asat book0-fresh blood
Ashraf Ali
 
Tao tai khoan google play
Tao tai khoan google playTao tai khoan google play
Tao tai khoan google play
Minh Hương Nguyễn
 
An incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chainAn incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chain
Ali Elkhateb
 
JCLIC
JCLICJCLIC
JCLIC
laurittarp
 
Case study: #GoogleMoLang
Case study: #GoogleMoLangCase study: #GoogleMoLang
Case study: #GoogleMoLang
noreensayoc
 
Jdj Foss Java Tools
Jdj Foss Java ToolsJdj Foss Java Tools
Jdj Foss Java Tools
Ganesh Samarthyam
 
Q3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 octoberQ3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 october
ASSA ABLOY
 
Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014hastapurnama
 
Cob 20081113 1
Cob 20081113 1Cob 20081113 1
Cob 20081113 1
macavity_d_katt
 
فرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأولفرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأولA-Ile Self-hallucination
 
Email & Social Media Training
Email & Social Media TrainingEmail & Social Media Training
Email & Social Media Training
William Mann
 

Viewers also liked (17)

Route Redistribution
Route RedistributionRoute Redistribution
Route Redistribution
 
Kewirausahaan
KewirausahaanKewirausahaan
Kewirausahaan
 
Overview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCPOverview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCP
 
Editioning use in ebs
Editioning use in  ebsEditioning use in  ebs
Editioning use in ebs
 
Img056
Img056Img056
Img056
 
How To Promote Your Business On Pinterest
How To Promote Your Business On PinterestHow To Promote Your Business On Pinterest
How To Promote Your Business On Pinterest
 
Asat book0-fresh blood
Asat book0-fresh bloodAsat book0-fresh blood
Asat book0-fresh blood
 
Tao tai khoan google play
Tao tai khoan google playTao tai khoan google play
Tao tai khoan google play
 
An incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chainAn incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chain
 
JCLIC
JCLICJCLIC
JCLIC
 
Case study: #GoogleMoLang
Case study: #GoogleMoLangCase study: #GoogleMoLang
Case study: #GoogleMoLang
 
Jdj Foss Java Tools
Jdj Foss Java ToolsJdj Foss Java Tools
Jdj Foss Java Tools
 
Q3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 octoberQ3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 october
 
Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014
 
Cob 20081113 1
Cob 20081113 1Cob 20081113 1
Cob 20081113 1
 
فرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأولفرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأول
 
Email & Social Media Training
Email & Social Media TrainingEmail & Social Media Training
Email & Social Media Training
 

Similar to Basic Cisco 800 Router Configuration for Internet Access

Nat 03
Nat 03Nat 03
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
3Anetwork com
 
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAMCMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
HamesKellor
 
Nat 07
Nat 07Nat 07
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
robertoxe
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
ernestlithur
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
Arz Sy
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
Netwax Lab
 
Configure basic firewall and vpn
Configure basic firewall and vpnConfigure basic firewall and vpn
Configure basic firewall and vpn
Kumar
 
ACIT Mumbai - CCNA Training - Router Introduction
ACIT Mumbai - CCNA Training -  Router Introduction ACIT Mumbai - CCNA Training -  Router Introduction
ACIT Mumbai - CCNA Training - Router Introduction
Sleek International
 
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdfcisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
AsgarAlam6
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Abhilash Kuniyil
 
69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone
Rayan Darine
 
portfolio2
portfolio2portfolio2
portfolio2
Joseph Alcantara
 
Nat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with exampleNat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with example
unixhowto
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routers
IT Tech
 
3 2
3 23 2
119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut
nicolelemmimg
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
Đồng Quốc Vương
 
CCNA 1 Final v5.0 2014
CCNA 1 Final  v5.0 2014CCNA 1 Final  v5.0 2014
CCNA 1 Final v5.0 2014
Đồng Quốc Vương
 

Similar to Basic Cisco 800 Router Configuration for Internet Access (20)

Nat 03
Nat 03Nat 03
Nat 03
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAMCMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
 
Nat 07
Nat 07Nat 07
Nat 07
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
 
Configure basic firewall and vpn
Configure basic firewall and vpnConfigure basic firewall and vpn
Configure basic firewall and vpn
 
ACIT Mumbai - CCNA Training - Router Introduction
ACIT Mumbai - CCNA Training -  Router Introduction ACIT Mumbai - CCNA Training -  Router Introduction
ACIT Mumbai - CCNA Training - Router Introduction
 
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdfcisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
 
69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone
 
portfolio2
portfolio2portfolio2
portfolio2
 
Nat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with exampleNat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with example
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routers
 
3 2
3 23 2
3 2
 
119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
CCNA 1 Final v5.0 2014
CCNA 1 Final  v5.0 2014CCNA 1 Final  v5.0 2014
CCNA 1 Final v5.0 2014
 

Recently uploaded

dbms calicut university B. sc Cs 4th sem.pdf
dbms  calicut university B. sc Cs 4th sem.pdfdbms  calicut university B. sc Cs 4th sem.pdf
dbms calicut university B. sc Cs 4th sem.pdf
Shinana2
 
Recommendation System using RAG Architecture
Recommendation System using RAG ArchitectureRecommendation System using RAG Architecture
Recommendation System using RAG Architecture
fredae14
 
UI5 Controls simplified - UI5con2024 presentation
UI5 Controls simplified - UI5con2024 presentationUI5 Controls simplified - UI5con2024 presentation
UI5 Controls simplified - UI5con2024 presentation
Wouter Lemaire
 
Best 20 SEO Techniques To Improve Website Visibility In SERP
Best 20 SEO Techniques To Improve Website Visibility In SERPBest 20 SEO Techniques To Improve Website Visibility In SERP
Best 20 SEO Techniques To Improve Website Visibility In SERP
Pixlogix Infotech
 
Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...
Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...
Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...
Jeffrey Haguewood
 
Introduction of Cybersecurity with OSS at Code Europe 2024
Introduction of Cybersecurity with OSS  at Code Europe 2024Introduction of Cybersecurity with OSS  at Code Europe 2024
Introduction of Cybersecurity with OSS at Code Europe 2024
Hiroshi SHIBATA
 
Deep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStr
Deep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStrDeep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStr
Deep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStr
saastr
 
GenAI Pilot Implementation in the organizations
GenAI Pilot Implementation in the organizationsGenAI Pilot Implementation in the organizations
GenAI Pilot Implementation in the organizations
kumardaparthi1024
 
HCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAU
HCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAUHCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAU
HCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAU
panagenda
 
Operating System Used by Users in day-to-day life.pptx
Operating System Used by Users in day-to-day life.pptxOperating System Used by Users in day-to-day life.pptx
Operating System Used by Users in day-to-day life.pptx
Pravash Chandra Das
 
June Patch Tuesday
June Patch TuesdayJune Patch Tuesday
June Patch Tuesday
Ivanti
 
Choosing The Best AWS Service For Your Website + API.pptx
Choosing The Best AWS Service For Your Website + API.pptxChoosing The Best AWS Service For Your Website + API.pptx
Choosing The Best AWS Service For Your Website + API.pptx
Brandon Minnick, MBA
 
TrustArc Webinar - 2024 Global Privacy Survey
TrustArc Webinar - 2024 Global Privacy SurveyTrustArc Webinar - 2024 Global Privacy Survey
TrustArc Webinar - 2024 Global Privacy Survey
TrustArc
 
Letter and Document Automation for Bonterra Impact Management (fka Social Sol...
Letter and Document Automation for Bonterra Impact Management (fka Social Sol...Letter and Document Automation for Bonterra Impact Management (fka Social Sol...
Letter and Document Automation for Bonterra Impact Management (fka Social Sol...
Jeffrey Haguewood
 
Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...
Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...
Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...
saastr
 
Artificial Intelligence for XMLDevelopment
Artificial Intelligence for XMLDevelopmentArtificial Intelligence for XMLDevelopment
Artificial Intelligence for XMLDevelopment
Octavian Nadolu
 
A Comprehensive Guide to DeFi Development Services in 2024
A Comprehensive Guide to DeFi Development Services in 2024A Comprehensive Guide to DeFi Development Services in 2024
A Comprehensive Guide to DeFi Development Services in 2024
Intelisync
 
HCL Notes and Domino License Cost Reduction in the World of DLAU
HCL Notes and Domino License Cost Reduction in the World of DLAUHCL Notes and Domino License Cost Reduction in the World of DLAU
HCL Notes and Domino License Cost Reduction in the World of DLAU
panagenda
 
Your One-Stop Shop for Python Success: Top 10 US Python Development Providers
Your One-Stop Shop for Python Success: Top 10 US Python Development ProvidersYour One-Stop Shop for Python Success: Top 10 US Python Development Providers
Your One-Stop Shop for Python Success: Top 10 US Python Development Providers
akankshawande
 
WeTestAthens: Postman's AI & Automation Techniques
WeTestAthens: Postman's AI & Automation TechniquesWeTestAthens: Postman's AI & Automation Techniques
WeTestAthens: Postman's AI & Automation Techniques
Postman
 

Recently uploaded (20)

dbms calicut university B. sc Cs 4th sem.pdf
dbms  calicut university B. sc Cs 4th sem.pdfdbms  calicut university B. sc Cs 4th sem.pdf
dbms calicut university B. sc Cs 4th sem.pdf
 
Recommendation System using RAG Architecture
Recommendation System using RAG ArchitectureRecommendation System using RAG Architecture
Recommendation System using RAG Architecture
 
UI5 Controls simplified - UI5con2024 presentation
UI5 Controls simplified - UI5con2024 presentationUI5 Controls simplified - UI5con2024 presentation
UI5 Controls simplified - UI5con2024 presentation
 
Best 20 SEO Techniques To Improve Website Visibility In SERP
Best 20 SEO Techniques To Improve Website Visibility In SERPBest 20 SEO Techniques To Improve Website Visibility In SERP
Best 20 SEO Techniques To Improve Website Visibility In SERP
 
Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...
Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...
Salesforce Integration for Bonterra Impact Management (fka Social Solutions A...
 
Introduction of Cybersecurity with OSS at Code Europe 2024
Introduction of Cybersecurity with OSS  at Code Europe 2024Introduction of Cybersecurity with OSS  at Code Europe 2024
Introduction of Cybersecurity with OSS at Code Europe 2024
 
Deep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStr
Deep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStrDeep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStr
Deep Dive: Getting Funded with Jason Jason Lemkin Founder & CEO @ SaaStr
 
GenAI Pilot Implementation in the organizations
GenAI Pilot Implementation in the organizationsGenAI Pilot Implementation in the organizations
GenAI Pilot Implementation in the organizations
 
HCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAU
HCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAUHCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAU
HCL Notes und Domino Lizenzkostenreduzierung in der Welt von DLAU
 
Operating System Used by Users in day-to-day life.pptx
Operating System Used by Users in day-to-day life.pptxOperating System Used by Users in day-to-day life.pptx
Operating System Used by Users in day-to-day life.pptx
 
June Patch Tuesday
June Patch TuesdayJune Patch Tuesday
June Patch Tuesday
 
Choosing The Best AWS Service For Your Website + API.pptx
Choosing The Best AWS Service For Your Website + API.pptxChoosing The Best AWS Service For Your Website + API.pptx
Choosing The Best AWS Service For Your Website + API.pptx
 
TrustArc Webinar - 2024 Global Privacy Survey
TrustArc Webinar - 2024 Global Privacy SurveyTrustArc Webinar - 2024 Global Privacy Survey
TrustArc Webinar - 2024 Global Privacy Survey
 
Letter and Document Automation for Bonterra Impact Management (fka Social Sol...
Letter and Document Automation for Bonterra Impact Management (fka Social Sol...Letter and Document Automation for Bonterra Impact Management (fka Social Sol...
Letter and Document Automation for Bonterra Impact Management (fka Social Sol...
 
Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...
Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...
Overcoming the PLG Trap: Lessons from Canva's Head of Sales & Head of EMEA Da...
 
Artificial Intelligence for XMLDevelopment
Artificial Intelligence for XMLDevelopmentArtificial Intelligence for XMLDevelopment
Artificial Intelligence for XMLDevelopment
 
A Comprehensive Guide to DeFi Development Services in 2024
A Comprehensive Guide to DeFi Development Services in 2024A Comprehensive Guide to DeFi Development Services in 2024
A Comprehensive Guide to DeFi Development Services in 2024
 
HCL Notes and Domino License Cost Reduction in the World of DLAU
HCL Notes and Domino License Cost Reduction in the World of DLAUHCL Notes and Domino License Cost Reduction in the World of DLAU
HCL Notes and Domino License Cost Reduction in the World of DLAU
 
Your One-Stop Shop for Python Success: Top 10 US Python Development Providers
Your One-Stop Shop for Python Success: Top 10 US Python Development ProvidersYour One-Stop Shop for Python Success: Top 10 US Python Development Providers
Your One-Stop Shop for Python Success: Top 10 US Python Development Providers
 
WeTestAthens: Postman's AI & Automation Techniques
WeTestAthens: Postman's AI & Automation TechniquesWeTestAthens: Postman's AI & Automation Techniques
WeTestAthens: Postman's AI & Automation Techniques
 

Basic Cisco 800 Router Configuration for Internet Access

  • 1. Basic Cisco 800 Router Configuration for Internet Access The Cisco 800 series routers are part of the “Branch Office” category, used mainly for SOHO purposes or for connecting remote branch offices to a central location. They are “fixed hardware configuration” devices, meaning that they don’t have any plug-in hardware slots for inserting additional interfaces to the device (all the interfaces are fixed). All the 800 series models come with a 4-port 10/100 managed switch used for connecting the internal LAN computers, and with an IOS software that supports security features including the Firewall set. The main difference of each model is the WAN interface. All models that end with “1” in the model number (i.e 851, 861, 871, 881, 891) have a 10/100 Fast Ethernet interface as a WAN port. The other models have an xDSL type WAN port (i.e ADSL, G.SHDL, VDSL2). Also, all models have the option of a WiFi Radio interface (the model number ends with a “W”, e.g 851W, 857W, 861W etc).
  • 2. In this post I will describe a basic configuration scenario for connecting a Cisco 800 router for Internet access. I will use a model with an Ethernet WAN interface (such as 851, 861, 871, etc) since those models are the most popular. Something to have in mind for all 800 series routers, the four LAN interfaces (FE0 up to FE3) are Layer2 switch interfaces that are assigned by default to Vlan1. This means that you can not assign an IP address directly to the LAN interfaces. The IP address for the LAN-facing side of the router is assigned under “interface Vlan1”. On the other hand, the WAN interface (FE4) is a normal Layer3 router port, which means you can assign an IP address directly on the interface (“interface FastEthernet4”). I will describe three basic scenarios which are frequently encountered in real networks. 1. Scenario 1: WAN IP address of router is assigned dynamically by the ISP. LAN IP addresses assigned dynamically from the router to the internal PCs. 2. Scenario 2: WAN IP address of router is static. LAN IP addresses assigned dynamically from the router. 3. Scenario 3: WAN IP address of router is static. An internal LAN Web Server exists. The router performs a static Port NAT (port redirection) to forward traffic from Internet towards the internal Web Server.
  • 3. Scenario 1: Configuration: The following is the basic configuration needed for the simple scenario above. configure terminal enable secret somesecretpassword ! Configure the DHCP pool to assign addresses to internal hosts ip dhcp pool vlan1pool network 192.168.1.0 255.255.255.0 default-router 192.168.1.1 dns-server 100.100.100.36 ! Do not assign addresses 1 to 30 ip dhcp excluded-address 192.168.1.1 192.168.1.30
  • 4. ! This is the LAN facing interface of the 800 router. Used as gateway for PCs interface vlan 1 ip address 192.168.1.1 255.255.255.0 ip nat inside no shut ! Interfaces FE0 to FE3 are Layer 2 interfaces interface FastEthernet0 no shut interface FastEthernet1 no shut interface FastEthernet2 no shut interface FastEthernet3 no shut ! This is the WAN interface getting address via DHCP from the ISP interface FastEthernet 4 no shut ip address dhcp ip nat outside ! Configure NAT. All internal hosts will be nated on the WAN interface ip nat inside source list 1 interface fastethernet4 overload access-list 1 permit 192.168.1.0 0.0.0.255 ip route 0.0.0.0 0.0.0.0 fastethernet4 line vty 0 4 password somestrongpassword
  • 5. Scenario 2: Configuration: This is the same configuration as scenario 1 except that the WAN IP address is static and also the default gateway of our ISP is known. The only difference from the configuration above is on the WAN interface and on default route: ! This is the WAN interface with static IP interface FastEthernet 4 no shut ip address 100.100.100.1 255.255.255.0 ip nat outside ip route 0.0.0.0 0.0.0.0 100.100.100.2
  • 6. Scenario 3: Configuration: Here the WAN address is static and we have also an internal Web Server for which we need to allow HTTP access from Internet. To do this we must configure a static NAT with port redirection. Traffic that comes towards our WAN public address 100.100.100.1 on port 80 will be redirected by the router to the internal Web Server at address 192.168.1.10 on port 80. configure terminal enable secret somesecretpassword
  • 7. ! Configure the DHCP pool to assign addresses to internal hosts ip dhcp pool vlan1pool network 192.168.1.0 255.255.255.0 default-router 192.168.1.1 dns-server 100.100.100.36 ! Do not assign addresses 1 to 30 ip dhcp excluded-address 192.168.1.1 192.168.1.30 ! This is the LAN facing interface of the 800 router. Used as gateway for PCs interface vlan 1 ip address 192.168.1.1 255.255.255.0 ip nat inside no shut ! Interfaces FE0 to FE3 are Layer 2 interfaces interface FastEthernet0 no shut interface FastEthernet1 no shut interface FastEthernet2 no shut interface FastEthernet3 no shut ! This is the WAN interface with static IP interface FastEthernet 4 no shut ip address 100.100.100.1 255.255.255.0 ip nat outside ! Configure NAT. All internal hosts will be nated on the WAN interface ip nat inside source list 1 interface fastethernet4 overload access-list 1 permit 192.168.1.0 0.0.0.255
  • 8. ! Configure static NAT for port redirection ip nat inside source static tcp 192.168.1.10 80 100.100.100.1 80 extendable ip route 0.0.0.0 0.0.0.0 100.100.100.2 line vty 0 4 password somestrongpassword About the Author Harris Andrea is a Cisco Certified Professional with more than 18 years of experience working with Cisco network technologies. He is the author of two Cisco Books (“Cisco ASA Firewall Fundamentals” and “Cisco VPN Configuration Guide”) which have been embraced by thousands of Cisco professionals all over the world. You can find more Cisco configuration guides and tutorials on his blog here http://www.networkstraining.com