SlideShare a Scribd company logo
1 of 7
Configuring a Cisco Router as a PPPoE Client for DSL connectivity
PPPoE: Point-to-Point Protocol over Ethernet. The PPP over Ethernet Client feature
provides PPP over Ethernet (PPPoE) Client support on routers on customer premises.
Configuring a Cisco routers as a PPPoE client for DSL connectivity, there are two cases,
one for the Ethernet interfaces, and another for the ATM interfaces
A. PPPoE on Ethernet interfaces—PPPoE functionality is configured on a CPE
router with two Ethernet interfaces. One Ethernet interface is subscriber-facing,
the other provider facing.
B. PPPoE on ATM interfaces—PPPoE functionality is configured on a CPE router
with one Ethernet interface and one ATM interface. The Ethernet interface is
subscriber-facing whereas the ATM interface is provider-facing.
Note: I noticed that on some books no one mentioned the configuration of IP domain
lookup command and ISP DNS options in DHCP server configuration. Without these
DSL connection will not work. Also pay attention if DSL connection did not work, to check
the state of all interfaces by using show ip interface brief and make sure to issue no
shutdown command on all of them.
A. PPPoE on Ethernet interfaces
DSL configuration brief steps:
1. Internal Ethernet interface configuration
2. External Ethernet interface configuration
3. Dialer interface configuration
4. Configuring Access List
5. NAT/PAT configuration
6. Configuring IP domain Lookup
7. DHCP server services configuration
8. Static default route configuration
DSL configuration detailed steps:
1. Internal Ethernet interface configuration
interface FastEthernet 0/1
description internal interface
ip address 172.16.1.1 255.255.255.0
1
ip nat inside
no shut
OR (incase you are using Cisco 877 router)
interface Vlan1
description internal interface
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
2. External Ethernet interface configuration
Interface FastEthernet 0/0
Description DSL interface
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shut
3. Dialer interface configuration
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username USERNAME password P@ssw0rd (this is the password that
ISP gave it to you
ppp chap hostname HOSTNAME (This is the username that ISP gave it to you)
ppp chap password P@ssw0rd
no shut
4. Configuring Access List
ip access-list extended DSL_ACCESSLIST
100 permit ip 10.10.10.0 0.0.0.255 any
5. Configuring NAT/PAT
ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload
2
6. Configuring IP domain Lookup
ip domain lookup
ip name-server Primary DNS IP address (obtained from your ISP)
ip name-server Secondary DNS IP address (obtained from your ISP)
7. DHCP server services configuration
ip dhcp pool DSL_DHCP
network 10.10.10.0 /29
dns-server Primary DNS IP address Secondary DNS IP address (obtained from your
ISP)
default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address)
import all
8. Static default route configuration
Finally, configure a static default route. It should point to the dialer interface rather
than an IP address as in the below example.
ip route 0.0.0.0 0.0.0.0 dialer 1
B. PPPoE on ATM interfaces
DSL configuration brief steps:
1. Internal Ethernet interface configuration
2. External ATM interface configuration (in case you are using Cisco 877 Router)
3. Dialer interface configuration
4. Configuring Access List
5. NAT/PAT configuration
6. Configuring IP domain Lookup
7. DHCP server services configuration
8. Static default route configuration
DSL configuration detailed steps:
1. Internal VLAN interface configuration (using Cisco 877 Router)
interface Vlan1
description internal interface
3
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
OR (if you are using configurable internal Ethernet interface)
interface FastEthernet 0/1
description internal interface
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
2. External ATM interface configuration
interface ATM 0
description DSL interface
ip directed-broadcast
ip mask-reply
ip route-cache flow
no ip address
dsl operating-mode auto
pvc 8/35
no shutdown
pppoe-client dial-pool-number 1
3. Dialer interface configuration
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username USERNAME password P@ssw0rd (this is the password that
ISP gave it to you
ppp chap hostname HOSTNAME (This is the username that ISP gave it to you)
ppp chap password P@ssw0rd
no shut
4. Configuring Access List
ip access-list extended DSL_ACCESSLIST
4
100 permit ip 10.10.10.0 0.0.0.255 any
5. Configuring NAT/PAT
ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload
6. Configuring IP domain Lookup
ip domain lookup
ip name-server Primary DNS IP address (obtained from your ISP)
ip name-server Secondary DNS IP address (obtained from your ISP)
7. DHCP server services configuration
ip dhcp pool DSL_DHCP
network 10.10.10.0 /29
dns-server Primary DNS IP address Secondary DNS IP address (obtained from your
ISP)
default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address)
import all
8. Static default route configuration
Finally, configure a static default route. It should point to the dialer interface rather
than an IP address as in the below example.
ip route 0.0.0.0 0.0.0.0 dialer 1
More related:
Cisco Router 1941 Commands
How to recover Cisco 1921 router default password?
Cisco 2911 SNMP not working
How To Recover Cisco Router Password
The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900
More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog
3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale
original new Cisco networking equipments, including Cisco Catalyst switches, Cisco
5
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
6
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
6

More Related Content

What's hot

Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet3Anetwork com
 
pfSense Firewall ve Router Eğitimi
pfSense Firewall ve Router EğitimipfSense Firewall ve Router Eğitimi
pfSense Firewall ve Router EğitimiBGA Cyber Security
 
Routing Information Protocol (RIP)
Routing Information Protocol (RIP)Routing Information Protocol (RIP)
Routing Information Protocol (RIP)Tharindu Sankalpa
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRPKishore Kumar
 
CCNA 2 Routing and Switching v5.0 Chapter 2
CCNA 2 Routing and Switching v5.0 Chapter 2CCNA 2 Routing and Switching v5.0 Chapter 2
CCNA 2 Routing and Switching v5.0 Chapter 2Nil Menon
 
How to connect to cisco asa
How to connect to cisco asaHow to connect to cisco asa
How to connect to cisco asaIT Tech
 
CCNA ppt Day 1
CCNA ppt Day 1CCNA ppt Day 1
CCNA ppt Day 1VISHNU N
 
Router Full Concept pdf
Router Full Concept pdf Router Full Concept pdf
Router Full Concept pdf Vignesh kumar
 
CCNAv5 - S1: Chapter 10 Application Layer
CCNAv5 - S1: Chapter 10 Application LayerCCNAv5 - S1: Chapter 10 Application Layer
CCNAv5 - S1: Chapter 10 Application LayerVuz Dở Hơi
 
Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...
Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...
Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...David Adi Nugroho
 
CCNA Exploration 2 - Chapter 1
CCNA Exploration 2 - Chapter 1CCNA Exploration 2 - Chapter 1
CCNA Exploration 2 - Chapter 1Irsandi Hasan
 
Junos vs ios Troubleshooting comands
Junos vs ios Troubleshooting comands Junos vs ios Troubleshooting comands
Junos vs ios Troubleshooting comands sandeep kumar
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And AnswersCCNAResources
 
Basic command to configure mikrotik
Basic command to configure mikrotikBasic command to configure mikrotik
Basic command to configure mikrotikTola LENG
 

What's hot (20)

Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
pfSense Firewall ve Router Eğitimi
pfSense Firewall ve Router EğitimipfSense Firewall ve Router Eğitimi
pfSense Firewall ve Router Eğitimi
 
Routing Information Protocol (RIP)
Routing Information Protocol (RIP)Routing Information Protocol (RIP)
Routing Information Protocol (RIP)
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
CCNA 2 Routing and Switching v5.0 Chapter 2
CCNA 2 Routing and Switching v5.0 Chapter 2CCNA 2 Routing and Switching v5.0 Chapter 2
CCNA 2 Routing and Switching v5.0 Chapter 2
 
Nat pat
Nat patNat pat
Nat pat
 
How to connect to cisco asa
How to connect to cisco asaHow to connect to cisco asa
How to connect to cisco asa
 
CCNA ppt Day 1
CCNA ppt Day 1CCNA ppt Day 1
CCNA ppt Day 1
 
Router Full Concept pdf
Router Full Concept pdf Router Full Concept pdf
Router Full Concept pdf
 
CCNAv5 - S1: Chapter 10 Application Layer
CCNAv5 - S1: Chapter 10 Application LayerCCNAv5 - S1: Chapter 10 Application Layer
CCNAv5 - S1: Chapter 10 Application Layer
 
Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...
Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...
Ngelab Packet Tracer - Subnet, IP, DHCP, Server, DNS, Email, NTP, FTP, RIP, E...
 
Building converged plantwide ethernet architectures
Building converged plantwide ethernet architecturesBuilding converged plantwide ethernet architectures
Building converged plantwide ethernet architectures
 
CCNA Exploration 2 - Chapter 1
CCNA Exploration 2 - Chapter 1CCNA Exploration 2 - Chapter 1
CCNA Exploration 2 - Chapter 1
 
HSRP ccna
HSRP ccna HSRP ccna
HSRP ccna
 
Junos vs ios Troubleshooting comands
Junos vs ios Troubleshooting comands Junos vs ios Troubleshooting comands
Junos vs ios Troubleshooting comands
 
Ip security
Ip security Ip security
Ip security
 
VPN presentation - moeshesh
VPN presentation - moesheshVPN presentation - moeshesh
VPN presentation - moeshesh
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And Answers
 
Basic command to configure mikrotik
Basic command to configure mikrotikBasic command to configure mikrotik
Basic command to configure mikrotik
 

Viewers also liked

CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06   configuração básica de roteadores ciscoCCNA 4.1 - Capítulo 06   configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06 configuração básica de roteadores ciscoSergio Maia
 
Subnetting and routing
Subnetting and routingSubnetting and routing
Subnetting and routingGaurav Juneja
 
Network switches, functions & role in networks
Network switches, functions & role in networksNetwork switches, functions & role in networks
Network switches, functions & role in networksIT Tech
 
Internet control message protocol
Internet control message protocolInternet control message protocol
Internet control message protocolasimnawaz54
 

Viewers also liked (7)

Pppoe,pppoa
Pppoe,pppoaPppoe,pppoa
Pppoe,pppoa
 
CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06   configuração básica de roteadores ciscoCCNA 4.1 - Capítulo 06   configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
 
Subnetting and routing
Subnetting and routingSubnetting and routing
Subnetting and routing
 
Network switches, functions & role in networks
Network switches, functions & role in networksNetwork switches, functions & role in networks
Network switches, functions & role in networks
 
Http Vs Https .
Http Vs Https . Http Vs Https .
Http Vs Https .
 
Dhcp ppt
Dhcp pptDhcp ppt
Dhcp ppt
 
Internet control message protocol
Internet control message protocolInternet control message protocol
Internet control message protocol
 

Similar to Configure Cisco Router as PPPoE Client for DSL

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccnarobertoxe
 
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxCCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxketurahhazelhurst
 
Chapter 15 : routing concepts
Chapter 15 : routing conceptsChapter 15 : routing concepts
Chapter 15 : routing conceptsteknetir
 
CCNA Network Services
CCNA Network ServicesCCNA Network Services
CCNA Network ServicesDsunte Wilson
 
CCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing ConceptsCCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing ConceptsVuz Dở Hơi
 
KPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalKPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalFisal Anwari
 
Chapter 04 - Routing Concepts
Chapter 04 - Routing ConceptsChapter 04 - Routing Concepts
Chapter 04 - Routing ConceptsYaser Rahmati
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routersIT Tech
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)Netwax Lab
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configurationsamreenghauri786
 
CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4Nil Menon
 

Similar to Configure Cisco Router as PPPoE Client for DSL (20)

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
scg basic
scg basicscg basic
scg basic
 
Nat 03
Nat 03Nat 03
Nat 03
 
Nat 07
Nat 07Nat 07
Nat 07
 
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxCCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
 
Day 17.1 nat pat
Day 17.1 nat pat Day 17.1 nat pat
Day 17.1 nat pat
 
Chapter 15 : routing concepts
Chapter 15 : routing conceptsChapter 15 : routing concepts
Chapter 15 : routing concepts
 
CCNA Network Services
CCNA Network ServicesCCNA Network Services
CCNA Network Services
 
CCNA Icnd110 s05l04
CCNA Icnd110 s05l04CCNA Icnd110 s05l04
CCNA Icnd110 s05l04
 
CCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing ConceptsCCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing Concepts
 
KPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalKPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_final
 
Chapter 04 - Routing Concepts
Chapter 04 - Routing ConceptsChapter 04 - Routing Concepts
Chapter 04 - Routing Concepts
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routers
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4
 
N at
N atN at
N at
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
520scg basic
520scg basic520scg basic
520scg basic
 

More from 3Anetwork com

Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers3Anetwork com
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series3Anetwork com
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches3Anetwork com
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business3Anetwork com
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router3Anetwork com
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs3Anetwork com
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program3Anetwork com
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration3Anetwork com
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet3Anetwork com
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview3Anetwork com
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick3Anetwork com
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet3Anetwork com
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x3Anetwork com
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers3Anetwork com
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules3Anetwork com
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example3Anetwork com
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality3Anetwork com
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)3Anetwork com
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview3Anetwork com
 

More from 3Anetwork com (20)

Cisco sfp modules
Cisco sfp modulesCisco sfp modules
Cisco sfp modules
 
Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview
 

Recently uploaded

On Starlink, presented by Geoff Huston at NZNOG 2024
On Starlink, presented by Geoff Huston at NZNOG 2024On Starlink, presented by Geoff Huston at NZNOG 2024
On Starlink, presented by Geoff Huston at NZNOG 2024APNIC
 
VIP Kolkata Call Girl Dum Dum 👉 8250192130 Available With Room
VIP Kolkata Call Girl Dum Dum 👉 8250192130  Available With RoomVIP Kolkata Call Girl Dum Dum 👉 8250192130  Available With Room
VIP Kolkata Call Girl Dum Dum 👉 8250192130 Available With Roomdivyansh0kumar0
 
Challengers I Told Ya ShirtChallengers I Told Ya Shirt
Challengers I Told Ya ShirtChallengers I Told Ya ShirtChallengers I Told Ya ShirtChallengers I Told Ya Shirt
Challengers I Told Ya ShirtChallengers I Told Ya Shirtrahman018755
 
Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝
Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝
Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝soniya singh
 
Russian Call girls in Dubai +971563133746 Dubai Call girls
Russian  Call girls in Dubai +971563133746 Dubai  Call girlsRussian  Call girls in Dubai +971563133746 Dubai  Call girls
Russian Call girls in Dubai +971563133746 Dubai Call girlsstephieert
 
10.pdfMature Call girls in Dubai +971563133746 Dubai Call girls
10.pdfMature Call girls in Dubai +971563133746 Dubai Call girls10.pdfMature Call girls in Dubai +971563133746 Dubai Call girls
10.pdfMature Call girls in Dubai +971563133746 Dubai Call girlsstephieert
 
VIP Kolkata Call Girl Kestopur 👉 8250192130 Available With Room
VIP Kolkata Call Girl Kestopur 👉 8250192130  Available With RoomVIP Kolkata Call Girl Kestopur 👉 8250192130  Available With Room
VIP Kolkata Call Girl Kestopur 👉 8250192130 Available With Roomdivyansh0kumar0
 
AlbaniaDreamin24 - How to easily use an API with Flows
AlbaniaDreamin24 - How to easily use an API with FlowsAlbaniaDreamin24 - How to easily use an API with Flows
AlbaniaDreamin24 - How to easily use an API with FlowsThierry TROUIN ☁
 
Russian Call Girls in Kolkata Ishita 🤌 8250192130 🚀 Vip Call Girls Kolkata
Russian Call Girls in Kolkata Ishita 🤌  8250192130 🚀 Vip Call Girls KolkataRussian Call Girls in Kolkata Ishita 🤌  8250192130 🚀 Vip Call Girls Kolkata
Russian Call Girls in Kolkata Ishita 🤌 8250192130 🚀 Vip Call Girls Kolkataanamikaraghav4
 
Best VIP Call Girls Noida Sector 75 Call Me: 8448380779
Best VIP Call Girls Noida Sector 75 Call Me: 8448380779Best VIP Call Girls Noida Sector 75 Call Me: 8448380779
Best VIP Call Girls Noida Sector 75 Call Me: 8448380779Delhi Call girls
 
Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$
Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$
Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$kojalkojal131
 
VIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call Girl
VIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call GirlVIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call Girl
VIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call Girladitipandeya
 
VIP Call Girls Pune Madhuri 8617697112 Independent Escort Service Pune
VIP Call Girls Pune Madhuri 8617697112 Independent Escort Service PuneVIP Call Girls Pune Madhuri 8617697112 Independent Escort Service Pune
VIP Call Girls Pune Madhuri 8617697112 Independent Escort Service PuneCall girls in Ahmedabad High profile
 
₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...
₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...
₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...Diya Sharma
 
AWS Community DAY Albertini-Ellan Cloud Security (1).pptx
AWS Community DAY Albertini-Ellan Cloud Security (1).pptxAWS Community DAY Albertini-Ellan Cloud Security (1).pptx
AWS Community DAY Albertini-Ellan Cloud Security (1).pptxellan12
 
Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...
Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...
Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...Sheetaleventcompany
 

Recently uploaded (20)

Call Girls In South Ex 📱 9999965857 🤩 Delhi 🫦 HOT AND SEXY VVIP 🍎 SERVICE
Call Girls In South Ex 📱  9999965857  🤩 Delhi 🫦 HOT AND SEXY VVIP 🍎 SERVICECall Girls In South Ex 📱  9999965857  🤩 Delhi 🫦 HOT AND SEXY VVIP 🍎 SERVICE
Call Girls In South Ex 📱 9999965857 🤩 Delhi 🫦 HOT AND SEXY VVIP 🍎 SERVICE
 
On Starlink, presented by Geoff Huston at NZNOG 2024
On Starlink, presented by Geoff Huston at NZNOG 2024On Starlink, presented by Geoff Huston at NZNOG 2024
On Starlink, presented by Geoff Huston at NZNOG 2024
 
VIP Kolkata Call Girl Dum Dum 👉 8250192130 Available With Room
VIP Kolkata Call Girl Dum Dum 👉 8250192130  Available With RoomVIP Kolkata Call Girl Dum Dum 👉 8250192130  Available With Room
VIP Kolkata Call Girl Dum Dum 👉 8250192130 Available With Room
 
Challengers I Told Ya ShirtChallengers I Told Ya Shirt
Challengers I Told Ya ShirtChallengers I Told Ya ShirtChallengers I Told Ya ShirtChallengers I Told Ya Shirt
Challengers I Told Ya ShirtChallengers I Told Ya Shirt
 
Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝
Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝
Call Girls in Uttam Nagar Delhi 💯Call Us 🔝8264348440🔝
 
Russian Call girls in Dubai +971563133746 Dubai Call girls
Russian  Call girls in Dubai +971563133746 Dubai  Call girlsRussian  Call girls in Dubai +971563133746 Dubai  Call girls
Russian Call girls in Dubai +971563133746 Dubai Call girls
 
10.pdfMature Call girls in Dubai +971563133746 Dubai Call girls
10.pdfMature Call girls in Dubai +971563133746 Dubai Call girls10.pdfMature Call girls in Dubai +971563133746 Dubai Call girls
10.pdfMature Call girls in Dubai +971563133746 Dubai Call girls
 
VIP Kolkata Call Girl Kestopur 👉 8250192130 Available With Room
VIP Kolkata Call Girl Kestopur 👉 8250192130  Available With RoomVIP Kolkata Call Girl Kestopur 👉 8250192130  Available With Room
VIP Kolkata Call Girl Kestopur 👉 8250192130 Available With Room
 
AlbaniaDreamin24 - How to easily use an API with Flows
AlbaniaDreamin24 - How to easily use an API with FlowsAlbaniaDreamin24 - How to easily use an API with Flows
AlbaniaDreamin24 - How to easily use an API with Flows
 
Russian Call Girls in Kolkata Ishita 🤌 8250192130 🚀 Vip Call Girls Kolkata
Russian Call Girls in Kolkata Ishita 🤌  8250192130 🚀 Vip Call Girls KolkataRussian Call Girls in Kolkata Ishita 🤌  8250192130 🚀 Vip Call Girls Kolkata
Russian Call Girls in Kolkata Ishita 🤌 8250192130 🚀 Vip Call Girls Kolkata
 
Best VIP Call Girls Noida Sector 75 Call Me: 8448380779
Best VIP Call Girls Noida Sector 75 Call Me: 8448380779Best VIP Call Girls Noida Sector 75 Call Me: 8448380779
Best VIP Call Girls Noida Sector 75 Call Me: 8448380779
 
Rohini Sector 6 Call Girls Delhi 9999965857 @Sabina Saikh No Advance
Rohini Sector 6 Call Girls Delhi 9999965857 @Sabina Saikh No AdvanceRohini Sector 6 Call Girls Delhi 9999965857 @Sabina Saikh No Advance
Rohini Sector 6 Call Girls Delhi 9999965857 @Sabina Saikh No Advance
 
Model Call Girl in Jamuna Vihar Delhi reach out to us at 🔝9953056974🔝
Model Call Girl in  Jamuna Vihar Delhi reach out to us at 🔝9953056974🔝Model Call Girl in  Jamuna Vihar Delhi reach out to us at 🔝9953056974🔝
Model Call Girl in Jamuna Vihar Delhi reach out to us at 🔝9953056974🔝
 
Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$
Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$
Call Girls Dubai Prolapsed O525547819 Call Girls In Dubai Princes$
 
VIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call Girl
VIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call GirlVIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call Girl
VIP 7001035870 Find & Meet Hyderabad Call Girls LB Nagar high-profile Call Girl
 
VIP Call Girls Pune Madhuri 8617697112 Independent Escort Service Pune
VIP Call Girls Pune Madhuri 8617697112 Independent Escort Service PuneVIP Call Girls Pune Madhuri 8617697112 Independent Escort Service Pune
VIP Call Girls Pune Madhuri 8617697112 Independent Escort Service Pune
 
₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...
₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...
₹5.5k {Cash Payment}New Friends Colony Call Girls In [Delhi NIHARIKA] 🔝|97111...
 
AWS Community DAY Albertini-Ellan Cloud Security (1).pptx
AWS Community DAY Albertini-Ellan Cloud Security (1).pptxAWS Community DAY Albertini-Ellan Cloud Security (1).pptx
AWS Community DAY Albertini-Ellan Cloud Security (1).pptx
 
Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...
Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...
Call Girls Service Chandigarh Lucky ❤️ 7710465962 Independent Call Girls In C...
 
Rohini Sector 26 Call Girls Delhi 9999965857 @Sabina Saikh No Advance
Rohini Sector 26 Call Girls Delhi 9999965857 @Sabina Saikh No AdvanceRohini Sector 26 Call Girls Delhi 9999965857 @Sabina Saikh No Advance
Rohini Sector 26 Call Girls Delhi 9999965857 @Sabina Saikh No Advance
 

Configure Cisco Router as PPPoE Client for DSL

  • 1. Configuring a Cisco Router as a PPPoE Client for DSL connectivity PPPoE: Point-to-Point Protocol over Ethernet. The PPP over Ethernet Client feature provides PPP over Ethernet (PPPoE) Client support on routers on customer premises. Configuring a Cisco routers as a PPPoE client for DSL connectivity, there are two cases, one for the Ethernet interfaces, and another for the ATM interfaces A. PPPoE on Ethernet interfaces—PPPoE functionality is configured on a CPE router with two Ethernet interfaces. One Ethernet interface is subscriber-facing, the other provider facing. B. PPPoE on ATM interfaces—PPPoE functionality is configured on a CPE router with one Ethernet interface and one ATM interface. The Ethernet interface is subscriber-facing whereas the ATM interface is provider-facing. Note: I noticed that on some books no one mentioned the configuration of IP domain lookup command and ISP DNS options in DHCP server configuration. Without these DSL connection will not work. Also pay attention if DSL connection did not work, to check the state of all interfaces by using show ip interface brief and make sure to issue no shutdown command on all of them. A. PPPoE on Ethernet interfaces DSL configuration brief steps: 1. Internal Ethernet interface configuration 2. External Ethernet interface configuration 3. Dialer interface configuration 4. Configuring Access List 5. NAT/PAT configuration 6. Configuring IP domain Lookup 7. DHCP server services configuration 8. Static default route configuration DSL configuration detailed steps: 1. Internal Ethernet interface configuration interface FastEthernet 0/1 description internal interface ip address 172.16.1.1 255.255.255.0 1
  • 2. ip nat inside no shut OR (incase you are using Cisco 877 router) interface Vlan1 description internal interface ip address 172.16.1.1 255.255.255.0 ip nat inside no shut 2. External Ethernet interface configuration Interface FastEthernet 0/0 Description DSL interface no ip address pppoe enable pppoe-client dial-pool-number 1 no shut 3. Dialer interface configuration interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 ppp authentication chap pap callin ppp pap sent-username USERNAME password P@ssw0rd (this is the password that ISP gave it to you ppp chap hostname HOSTNAME (This is the username that ISP gave it to you) ppp chap password P@ssw0rd no shut 4. Configuring Access List ip access-list extended DSL_ACCESSLIST 100 permit ip 10.10.10.0 0.0.0.255 any 5. Configuring NAT/PAT ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload 2
  • 3. 6. Configuring IP domain Lookup ip domain lookup ip name-server Primary DNS IP address (obtained from your ISP) ip name-server Secondary DNS IP address (obtained from your ISP) 7. DHCP server services configuration ip dhcp pool DSL_DHCP network 10.10.10.0 /29 dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP) default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address) import all 8. Static default route configuration Finally, configure a static default route. It should point to the dialer interface rather than an IP address as in the below example. ip route 0.0.0.0 0.0.0.0 dialer 1 B. PPPoE on ATM interfaces DSL configuration brief steps: 1. Internal Ethernet interface configuration 2. External ATM interface configuration (in case you are using Cisco 877 Router) 3. Dialer interface configuration 4. Configuring Access List 5. NAT/PAT configuration 6. Configuring IP domain Lookup 7. DHCP server services configuration 8. Static default route configuration DSL configuration detailed steps: 1. Internal VLAN interface configuration (using Cisco 877 Router) interface Vlan1 description internal interface 3
  • 4. ip address 172.16.1.1 255.255.255.0 ip nat inside no shut OR (if you are using configurable internal Ethernet interface) interface FastEthernet 0/1 description internal interface ip address 172.16.1.1 255.255.255.0 ip nat inside no shut 2. External ATM interface configuration interface ATM 0 description DSL interface ip directed-broadcast ip mask-reply ip route-cache flow no ip address dsl operating-mode auto pvc 8/35 no shutdown pppoe-client dial-pool-number 1 3. Dialer interface configuration interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 ppp authentication chap pap callin ppp pap sent-username USERNAME password P@ssw0rd (this is the password that ISP gave it to you ppp chap hostname HOSTNAME (This is the username that ISP gave it to you) ppp chap password P@ssw0rd no shut 4. Configuring Access List ip access-list extended DSL_ACCESSLIST 4
  • 5. 100 permit ip 10.10.10.0 0.0.0.255 any 5. Configuring NAT/PAT ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload 6. Configuring IP domain Lookup ip domain lookup ip name-server Primary DNS IP address (obtained from your ISP) ip name-server Secondary DNS IP address (obtained from your ISP) 7. DHCP server services configuration ip dhcp pool DSL_DHCP network 10.10.10.0 /29 dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP) default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address) import all 8. Static default route configuration Finally, configure a static default route. It should point to the dialer interface rather than an IP address as in the below example. ip route 0.0.0.0 0.0.0.0 dialer 1 More related: Cisco Router 1941 Commands How to recover Cisco 1921 router default password? Cisco 2911 SNMP not working How To Recover Cisco Router Password The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900 More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog 3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale original new Cisco networking equipments, including Cisco Catalyst switches, Cisco 5
  • 6. routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 6
  • 7. routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 6