SlideShare a Scribd company logo
1 of 24
SSH (Secure Shell) and Telnet
 used for remote access to network devices
 Telnet: Telnet is an unencrypted protocol used for
remote terminal access to network devices.
 It allows a user to establish a text-based session with
a remote device and execute commands remotely.
 SSH: SSH is a secure replacement for Telnet.
 It provides encrypted communication between the
client and the server, ensuring confidentiality and
integrity of the data transmitted.
Configuring ssh password
Configure ssh for router and switch to control
form computers
Configuring ssh password…
Steps to configure ssh password
 Change the host name
 Assign the Ip address for all devices
 Assign the domain-name
 generate the rsa key for the encryption purpose
 Create user name and password for user and enable
 Apply ssh configuration
Configuring ssh password…
Switch(config)#hostname S1
S1(config)#interface vlan 1
S1(config-if)#ip address 192.168.10.20
255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#exit
Router(config)#hostname R1
R1(config)#interface G0/0/0
R1(config-if)#ip address 192.168.10.1
255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
Configuring ssh password…
R1(config)#ip domain-name lab.com
R1(config)#crypto key generate rsa
How many bits in the modulus [512]: 1024
R1(config)#enable password 12345
R1(config)#username admin password cisco
R1(config)#ip ssh version 2
R1(config)#line vty 0 15
R1(config-line)#transport input ssh
R1(config-line)#login local
R1(config-line)#exit
Configuring ssh password…
Access from pc’s CMD: ssh –L
example ssh –l admin 192.168.10.1
Access remotely from pc to configure both pc.
LAN Switching
Part II
VLAN- Virtual Local Area Network
Virtual Local Area Networks (VLANs) separate
an existing physical network into multiple
logical networks. Thus, each VLAN creates its
own broadcast domain.
Communication between two VLANs can only
occur through a router that is connected to both.
VLAN- Types
 In short, there are 2 types of VLANs:
 Port-based VLANs (untagged)
 With port-based VLANs, a single physical switch is simply divided into
multiple logical switches. The following example divides an eight-port
physical switch (Switch A) into two logical switches.
 Tagged VLANs
 With tagged VLANs, multiple VLANs can be used through a single switch
port. Tags containing the respective VLAN identifiers indicating the VLAN
to which the frame belongs are attached to the individual Ethernet frames as
they exit the port. If both switches understand the operation of tagged
VLANs, the reciprocal connection can be accomplished using one single
cable connecting from a “trunk” port.
VLAN- Types
 VLAN-1 (Default VLAN)
 Data VLAN: is a VLAN dedicated to carrying user data traffic. It is used
to segregate and isolate different types of network traffic, such as user devices,
servers, or specific applications.
 Management VLAN: is a VLAN specifically designated for
managing network devices, such as switches, routers, or wireless access points.
 Native VLAN: The native VLAN is a VLAN that is assigned to an
802.1Q trunk port without tagging the frames with a VLAN ID.
VLAN- Virtual Local Area Network
VLAN- Virtual Local Area Network
VLAN Configuration (SW-0)
Switch(config)#VLAN 10
Switch(config)#name Staff
Switch(config)#VLAN 99
Switch(config)#name mgt
VLAN- Virtual Local Area Network
Assigning Ports to VLAN (SW-0)
SWA(config)#interface fastethernet0/2
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 10
SWA(config-if-range)#exit
SWA(config)#interface fastethernet0/24
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 99
SWA(config-if-range)#exit
VLAN- Virtual Local Area Network
VLAN Configuration (SW-1)
Switch(config)#VLAN 10
Switch(config)#name Staff
VLAN- Virtual Local Area Network
Assigning Ports to VLAN (SW-1)
SWA(config)#interface fastethernet0/2
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 10
SWA(config-if-range)#exit
VLAN- Virtual Local Area Network
Assigning trunk Ports to VLAN (SW-0)
SWA(config)#interface fastethernet0/10
SWA(config-if-range)#switchport mode trunk
SWA(config-if-range)#switchport trunk allowed vlan 1,10,99
SWA(config-if-range)#exit
VLAN- Virtual Local Area Network
Assigning trunk Ports to VLAN (SW-1)
SWA(config)#interface fastethernet0/10
SWA(config-if-range)#switchport mode trunk
SWA(config-if-range)#switchport trunk allowed vlan 1,10,99
SWA(config-if-range)#exit
Management VLAN
Create vlan mngt
Assign the ip address for all device
Sw# vlan 99
Sw#name mnget
Sw#interface fa0/2-52
Sw#sw mode acess
Sw#sw acc valn99
___________________________________
Step 2
Assign the ip address to switch
Sw#interface vlan 99
Sw#ip address 192.168.50.1 255.255.255.0
Sw# no shut
Step 3
Create the vty password and enable password.
Step 4
Sw#ping the device of vlan mngt otr vlan99
step 5
Access the switch from the device
…. Telenet switch address
….. telnet 192.168.50.1
User pass
Enable pass
VLAN- Virtual Local Area Network
Management VLAN (SW-0)
SWA(config)#interface fastethernet0/24
SWA(config-if)#switchport mode access
SWA(config-if)#switchport access vlan 99
SWA(config-if)#exit
SWA(config-if)#interface vlan 99
SWA(config-if)#ip address 192.168.99.100 255.255.255.0
SWA(config-if)#no shutdown
VLAN- Virtual Local Area Network
 Management VLAN (SW-0)- Remote Login
SWA(config)#enable secret vty
SWA(config)#line vty 0 15
SWA(config- line)#password 123
SWA(config-if)#login
SWA(config-if)#exit
SWA(config)# enable password cisco
VLAN- Virtual Local Area Network
 Native VLAN
 The VLAN services developed with backward compatibility to support old
devices that does not support VLANs is called native VLAN. It is associated
with Trunk port.
SWA(config)#vlan 100
SWA(config)#name Native
SWA(config)#exit
SWA(config)#interface f0/10 (trunk port)
SWA(config)#switchport trunk native vlan 100
SWA(config)#show int f0/10 switchport
SWA(config)# show int trunk

More Related Content

Similar to lab 2 (1)bbbbhbbbvvvvvvccccbbvvvccc.pptx

VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANS
anilinvns
 
06 vlan configuration commands
06 vlan configuration commands06 vlan configuration commands
06 vlan configuration commands
Andri Martian
 

Similar to lab 2 (1)bbbbhbbbvvvvvvccccbbvvvccc.pptx (20)

Lab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routingLab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routing
 
Day 5 VIRTUAL LANS
Day 5 VIRTUAL LANSDay 5 VIRTUAL LANS
Day 5 VIRTUAL LANS
 
VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANS
 
Ccna 9
Ccna  9Ccna  9
Ccna 9
 
Vlan
Vlan Vlan
Vlan
 
Vlan
VlanVlan
Vlan
 
VLANs_Module_3.pptx
VLANs_Module_3.pptxVLANs_Module_3.pptx
VLANs_Module_3.pptx
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
CCNA R&S 2 3 4 All Commands
CCNA R&S 2 3 4 All Commands CCNA R&S 2 3 4 All Commands
CCNA R&S 2 3 4 All Commands
 
CCNA- Router on stick, VLAN and Trunking
CCNA- Router on stick, VLAN and TrunkingCCNA- Router on stick, VLAN and Trunking
CCNA- Router on stick, VLAN and Trunking
 
VLAN
VLANVLAN
VLAN
 
CCNA- part 9 vlan
CCNA- part 9 vlanCCNA- part 9 vlan
CCNA- part 9 vlan
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchi
 
06 vlan configuration commands
06 vlan configuration commands06 vlan configuration commands
06 vlan configuration commands
 
06 vlan configuration commands
06 vlan configuration commands06 vlan configuration commands
06 vlan configuration commands
 
Inter VLAN Routing
Inter VLAN RoutingInter VLAN Routing
Inter VLAN Routing
 
VLAN Virtual Area Network ,Switch,Ethernet ,VIkram Snehi
VLAN Virtual Area Network ,Switch,Ethernet ,VIkram SnehiVLAN Virtual Area Network ,Switch,Ethernet ,VIkram Snehi
VLAN Virtual Area Network ,Switch,Ethernet ,VIkram Snehi
 
Vlan.pdf
Vlan.pdfVlan.pdf
Vlan.pdf
 
Vlan
VlanVlan
Vlan
 
Switching
SwitchingSwitching
Switching
 

More from BinyamBekeleMoges (9)

Introduction to Distributed Systems (1).pdf
Introduction to Distributed Systems (1).pdfIntroduction to Distributed Systems (1).pdf
Introduction to Distributed Systems (1).pdf
 
MC Lecture 8 67875667767777775677887.pptx
MC Lecture 8 67875667767777775677887.pptxMC Lecture 8 67875667767777775677887.pptx
MC Lecture 8 67875667767777775677887.pptx
 
MC Lecture 9234455566667777777777777.pptx
MC Lecture 9234455566667777777777777.pptxMC Lecture 9234455566667777777777777.pptx
MC Lecture 9234455566667777777777777.pptx
 
The 4 Key Issues about Communication.pptx
The 4 Key Issues about Communication.pptxThe 4 Key Issues about Communication.pptx
The 4 Key Issues about Communication.pptx
 
2 Dev t Comm Paradigms and Practices.pptx
2 Dev t Comm Paradigms and Practices.pptx2 Dev t Comm Paradigms and Practices.pptx
2 Dev t Comm Paradigms and Practices.pptx
 
research methedology ppt.pptx
research methedology ppt.pptxresearch methedology ppt.pptx
research methedology ppt.pptx
 
Chapter one.pptx
Chapter one.pptxChapter one.pptx
Chapter one.pptx
 
babo corora grade 9 ICT-ppt.pptx
babo corora grade 9 ICT-ppt.pptxbabo corora grade 9 ICT-ppt.pptx
babo corora grade 9 ICT-ppt.pptx
 
Chapter Five.pptx
Chapter Five.pptxChapter Five.pptx
Chapter Five.pptx
 

Recently uploaded

SURVEY I created for uni project research
SURVEY I created for uni project researchSURVEY I created for uni project research
SURVEY I created for uni project research
CaitlinCummins3
 
Financial Accounting IFRS, 3rd Edition-dikompresi.pdf
Financial Accounting IFRS, 3rd Edition-dikompresi.pdfFinancial Accounting IFRS, 3rd Edition-dikompresi.pdf
Financial Accounting IFRS, 3rd Edition-dikompresi.pdf
MinawBelay
 
The basics of sentences session 4pptx.pptx
The basics of sentences session 4pptx.pptxThe basics of sentences session 4pptx.pptx
The basics of sentences session 4pptx.pptx
heathfieldcps1
 

Recently uploaded (20)

TỔNG HỢP HƠN 100 ĐỀ THI THỬ TỐT NGHIỆP THPT VẬT LÝ 2024 - TỪ CÁC TRƯỜNG, TRƯ...
TỔNG HỢP HƠN 100 ĐỀ THI THỬ TỐT NGHIỆP THPT VẬT LÝ 2024 - TỪ CÁC TRƯỜNG, TRƯ...TỔNG HỢP HƠN 100 ĐỀ THI THỬ TỐT NGHIỆP THPT VẬT LÝ 2024 - TỪ CÁC TRƯỜNG, TRƯ...
TỔNG HỢP HƠN 100 ĐỀ THI THỬ TỐT NGHIỆP THPT VẬT LÝ 2024 - TỪ CÁC TRƯỜNG, TRƯ...
 
Graduate Outcomes Presentation Slides - English (v3).pptx
Graduate Outcomes Presentation Slides - English (v3).pptxGraduate Outcomes Presentation Slides - English (v3).pptx
Graduate Outcomes Presentation Slides - English (v3).pptx
 
UChicago CMSC 23320 - The Best Commit Messages of 2024
UChicago CMSC 23320 - The Best Commit Messages of 2024UChicago CMSC 23320 - The Best Commit Messages of 2024
UChicago CMSC 23320 - The Best Commit Messages of 2024
 
Exploring Gemini AI and Integration with MuleSoft | MuleSoft Mysore Meetup #45
Exploring Gemini AI and Integration with MuleSoft | MuleSoft Mysore Meetup #45Exploring Gemini AI and Integration with MuleSoft | MuleSoft Mysore Meetup #45
Exploring Gemini AI and Integration with MuleSoft | MuleSoft Mysore Meetup #45
 
HVAC System | Audit of HVAC System | Audit and regulatory Comploance.pptx
HVAC System | Audit of HVAC System | Audit and regulatory Comploance.pptxHVAC System | Audit of HVAC System | Audit and regulatory Comploance.pptx
HVAC System | Audit of HVAC System | Audit and regulatory Comploance.pptx
 
Operations Management - Book1.p - Dr. Abdulfatah A. Salem
Operations Management - Book1.p  - Dr. Abdulfatah A. SalemOperations Management - Book1.p  - Dr. Abdulfatah A. Salem
Operations Management - Book1.p - Dr. Abdulfatah A. Salem
 
Capitol Tech Univ Doctoral Presentation -May 2024
Capitol Tech Univ Doctoral Presentation -May 2024Capitol Tech Univ Doctoral Presentation -May 2024
Capitol Tech Univ Doctoral Presentation -May 2024
 
PSYPACT- Practicing Over State Lines May 2024.pptx
PSYPACT- Practicing Over State Lines May 2024.pptxPSYPACT- Practicing Over State Lines May 2024.pptx
PSYPACT- Practicing Over State Lines May 2024.pptx
 
Pragya Champions Chalice 2024 Prelims & Finals Q/A set, General Quiz
Pragya Champions Chalice 2024 Prelims & Finals Q/A set, General QuizPragya Champions Chalice 2024 Prelims & Finals Q/A set, General Quiz
Pragya Champions Chalice 2024 Prelims & Finals Q/A set, General Quiz
 
SURVEY I created for uni project research
SURVEY I created for uni project researchSURVEY I created for uni project research
SURVEY I created for uni project research
 
Incoming and Outgoing Shipments in 2 STEPS Using Odoo 17
Incoming and Outgoing Shipments in 2 STEPS Using Odoo 17Incoming and Outgoing Shipments in 2 STEPS Using Odoo 17
Incoming and Outgoing Shipments in 2 STEPS Using Odoo 17
 
Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17
Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17
Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17
 
The Last Leaf, a short story by O. Henry
The Last Leaf, a short story by O. HenryThe Last Leaf, a short story by O. Henry
The Last Leaf, a short story by O. Henry
 
Envelope of Discrepancy in Orthodontics: Enhancing Precision in Treatment
 Envelope of Discrepancy in Orthodontics: Enhancing Precision in Treatment Envelope of Discrepancy in Orthodontics: Enhancing Precision in Treatment
Envelope of Discrepancy in Orthodontics: Enhancing Precision in Treatment
 
An overview of the various scriptures in Hinduism
An overview of the various scriptures in HinduismAn overview of the various scriptures in Hinduism
An overview of the various scriptures in Hinduism
 
Financial Accounting IFRS, 3rd Edition-dikompresi.pdf
Financial Accounting IFRS, 3rd Edition-dikompresi.pdfFinancial Accounting IFRS, 3rd Edition-dikompresi.pdf
Financial Accounting IFRS, 3rd Edition-dikompresi.pdf
 
ANTI PARKISON DRUGS.pptx
ANTI         PARKISON          DRUGS.pptxANTI         PARKISON          DRUGS.pptx
ANTI PARKISON DRUGS.pptx
 
The basics of sentences session 4pptx.pptx
The basics of sentences session 4pptx.pptxThe basics of sentences session 4pptx.pptx
The basics of sentences session 4pptx.pptx
 
Mattingly "AI and Prompt Design: LLMs with Text Classification and Open Source"
Mattingly "AI and Prompt Design: LLMs with Text Classification and Open Source"Mattingly "AI and Prompt Design: LLMs with Text Classification and Open Source"
Mattingly "AI and Prompt Design: LLMs with Text Classification and Open Source"
 
How to Manage Closest Location in Odoo 17 Inventory
How to Manage Closest Location in Odoo 17 InventoryHow to Manage Closest Location in Odoo 17 Inventory
How to Manage Closest Location in Odoo 17 Inventory
 

lab 2 (1)bbbbhbbbvvvvvvccccbbvvvccc.pptx

  • 1.
  • 2. SSH (Secure Shell) and Telnet  used for remote access to network devices  Telnet: Telnet is an unencrypted protocol used for remote terminal access to network devices.  It allows a user to establish a text-based session with a remote device and execute commands remotely.  SSH: SSH is a secure replacement for Telnet.  It provides encrypted communication between the client and the server, ensuring confidentiality and integrity of the data transmitted.
  • 3. Configuring ssh password Configure ssh for router and switch to control form computers
  • 4. Configuring ssh password… Steps to configure ssh password  Change the host name  Assign the Ip address for all devices  Assign the domain-name  generate the rsa key for the encryption purpose  Create user name and password for user and enable  Apply ssh configuration
  • 5. Configuring ssh password… Switch(config)#hostname S1 S1(config)#interface vlan 1 S1(config-if)#ip address 192.168.10.20 255.255.255.0 S1(config-if)#no shutdown S1(config-if)#exit
  • 6. Router(config)#hostname R1 R1(config)#interface G0/0/0 R1(config-if)#ip address 192.168.10.1 255.255.255.0 R1(config-if)#no shutdown R1(config-if)#exit
  • 7. Configuring ssh password… R1(config)#ip domain-name lab.com R1(config)#crypto key generate rsa How many bits in the modulus [512]: 1024 R1(config)#enable password 12345 R1(config)#username admin password cisco R1(config)#ip ssh version 2 R1(config)#line vty 0 15 R1(config-line)#transport input ssh R1(config-line)#login local R1(config-line)#exit
  • 8. Configuring ssh password… Access from pc’s CMD: ssh –L example ssh –l admin 192.168.10.1 Access remotely from pc to configure both pc.
  • 10. VLAN- Virtual Local Area Network Virtual Local Area Networks (VLANs) separate an existing physical network into multiple logical networks. Thus, each VLAN creates its own broadcast domain. Communication between two VLANs can only occur through a router that is connected to both.
  • 11. VLAN- Types  In short, there are 2 types of VLANs:  Port-based VLANs (untagged)  With port-based VLANs, a single physical switch is simply divided into multiple logical switches. The following example divides an eight-port physical switch (Switch A) into two logical switches.  Tagged VLANs  With tagged VLANs, multiple VLANs can be used through a single switch port. Tags containing the respective VLAN identifiers indicating the VLAN to which the frame belongs are attached to the individual Ethernet frames as they exit the port. If both switches understand the operation of tagged VLANs, the reciprocal connection can be accomplished using one single cable connecting from a “trunk” port.
  • 12. VLAN- Types  VLAN-1 (Default VLAN)  Data VLAN: is a VLAN dedicated to carrying user data traffic. It is used to segregate and isolate different types of network traffic, such as user devices, servers, or specific applications.  Management VLAN: is a VLAN specifically designated for managing network devices, such as switches, routers, or wireless access points.  Native VLAN: The native VLAN is a VLAN that is assigned to an 802.1Q trunk port without tagging the frames with a VLAN ID.
  • 13. VLAN- Virtual Local Area Network
  • 14. VLAN- Virtual Local Area Network VLAN Configuration (SW-0) Switch(config)#VLAN 10 Switch(config)#name Staff Switch(config)#VLAN 99 Switch(config)#name mgt
  • 15. VLAN- Virtual Local Area Network Assigning Ports to VLAN (SW-0) SWA(config)#interface fastethernet0/2 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 10 SWA(config-if-range)#exit SWA(config)#interface fastethernet0/24 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 99 SWA(config-if-range)#exit
  • 16. VLAN- Virtual Local Area Network VLAN Configuration (SW-1) Switch(config)#VLAN 10 Switch(config)#name Staff
  • 17. VLAN- Virtual Local Area Network Assigning Ports to VLAN (SW-1) SWA(config)#interface fastethernet0/2 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 10 SWA(config-if-range)#exit
  • 18. VLAN- Virtual Local Area Network Assigning trunk Ports to VLAN (SW-0) SWA(config)#interface fastethernet0/10 SWA(config-if-range)#switchport mode trunk SWA(config-if-range)#switchport trunk allowed vlan 1,10,99 SWA(config-if-range)#exit
  • 19. VLAN- Virtual Local Area Network Assigning trunk Ports to VLAN (SW-1) SWA(config)#interface fastethernet0/10 SWA(config-if-range)#switchport mode trunk SWA(config-if-range)#switchport trunk allowed vlan 1,10,99 SWA(config-if-range)#exit
  • 20. Management VLAN Create vlan mngt Assign the ip address for all device Sw# vlan 99 Sw#name mnget Sw#interface fa0/2-52 Sw#sw mode acess Sw#sw acc valn99 ___________________________________ Step 2 Assign the ip address to switch Sw#interface vlan 99 Sw#ip address 192.168.50.1 255.255.255.0 Sw# no shut
  • 21. Step 3 Create the vty password and enable password. Step 4 Sw#ping the device of vlan mngt otr vlan99 step 5 Access the switch from the device …. Telenet switch address ….. telnet 192.168.50.1 User pass Enable pass
  • 22. VLAN- Virtual Local Area Network Management VLAN (SW-0) SWA(config)#interface fastethernet0/24 SWA(config-if)#switchport mode access SWA(config-if)#switchport access vlan 99 SWA(config-if)#exit SWA(config-if)#interface vlan 99 SWA(config-if)#ip address 192.168.99.100 255.255.255.0 SWA(config-if)#no shutdown
  • 23. VLAN- Virtual Local Area Network  Management VLAN (SW-0)- Remote Login SWA(config)#enable secret vty SWA(config)#line vty 0 15 SWA(config- line)#password 123 SWA(config-if)#login SWA(config-if)#exit SWA(config)# enable password cisco
  • 24. VLAN- Virtual Local Area Network  Native VLAN  The VLAN services developed with backward compatibility to support old devices that does not support VLANs is called native VLAN. It is associated with Trunk port. SWA(config)#vlan 100 SWA(config)#name Native SWA(config)#exit SWA(config)#interface f0/10 (trunk port) SWA(config)#switchport trunk native vlan 100 SWA(config)#show int f0/10 switchport SWA(config)# show int trunk