SlideShare a Scribd company logo
1 of 74
Network Fundamentals
Basic Device Configuration
Part I
Basic Device Configuration(Lab 1)
IOS (Internetwork Operating System)
basics
Networking device basics
Security basics
Remote Access
Basic Device Configuration(Lab 1)
CLIConfigurationModes
 The basic CLI modes that we will be referring below are as following:
 Router> <– User EXEC Mode(?)
Router# <– Privileged EXEC mode
Router(config)# <– Global Configuration Mode
Router(config-if)# <– Interface Configuration Mode
Router(config-line)# <– Line Configuration Mode
Basic Device Configuration(Lab 1)
Naming Hostname
Creating Console password
Creating enable Password and Enable
secret
Creating vty password
Encrypting service password
Creating switch/ router interface
management
Exercise
Draw the following topology and do basic configuration.
How to change Hostname
 Pres Enter to start and type enable to get to the privilege mode.
 Switch>enable
 Type configure terminal to enter the global configuration mode.
 Switch# configure terminal
 Change the hostname by typing hostname switch-name.
 switch(config)# hostname SW
 sw (config)#exit
 sw#show running-config
Console and vty password
 The console password is used for authentication
when accessing the device's Command Line Interface
(CLI) through the console port.
 The console password is used to secure physical
access to the device.
 Its restrict unauthorized users from accessing and
configuring the device through the console port.
Console and vty password
 is used for authentication when accessing the device's
CLI remotely through a virtual terminal connection.
 VTY connections are established over the network
using protocols such as Telnet or SSH.
 The VTY password is used to authenticate remote
users who are trying to access the device's CLI.
Configuring Console Password
Enter to global configuration mode
S1(config)# line console 0
S1(config-line)# password cisco
S1(config-line)#login
 S1(config-line)#exit
S1(config)#exit
S1#show running-config
Configuring the Enable Password
Enter into the global configuration mod
S1(config)#Enable password cisco1
Or
S1(config)#Enable secret cisco1
S1(config)#exit
S1#show running-config
Configuring VTY password
Remote Access cont.…
 Enter into global configuration mode
 S1(config)#Line vty 0 15
 S1(config-line)#password cisco
 S1(config-line)#login
 S1(config-line)#exit
 S1(config)#exit
 S1# show runn
 Access from pc’s CMD: ping 10.10.10.1
Configuring Enable Password
Enter into global configuration mode
S1(config)#service password-encryption
S1(config)#show run
Then you will see all passwords are encrypted
SSH (Secure Shell) and Telnet
 used for remote access to network devices
 Telnet: Telnet is an unencrypted protocol used for
remote terminal access to network devices.
 It allows a user to establish a text-based session with
a remote device and execute commands remotely.
 SSH: SSH is a secure replacement for Telnet.
 It provides encrypted communication between the
client and the server, ensuring confidentiality and
integrity of the data transmitted.
Configuring ssh password
Configure ssh for router and switch to control
form computers
Configuring ssh password…
Steps to configure ssh password
 Change the host name
 Assign the Ip address for all devices
 Assign the domain-name
 generate the rsa key for the encryption purpose
 Create user name and password for user and enable
 Apply ssh configuration
Configuring ssh password…
Switch(config)#hostname S1
S1(config)#interface vlan 1
S1(config-if)#ip address 192.168.10.20 S1(config-
if)#no shutdown
S1(config-if)#exit
Router(config)#hostname R1
R1(config)#interface G0/0/0
R1(config-if)#ip address 192.168.10.1
255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
Configuring ssh password…
R1(config)#ip domain-name lab.com
R1(config)#crypto key generate rsa
How many bits in the modulus [512]: 1024
R1(config)#enable password 12345
R1(config)#username admin password cisco
R1(config)#ip ssh version 2
R1(config)#line vty 0 15
R1(config-line)#transport input ssh
R1(config-line)#login local
R1(config-line)#exit
Configuring ssh password…
Access from pc’s CMD: ssh –L
example ssh –l admin 192.168.10.1
Access remotely from pc to configure both pc.
LAN Switching
Part II
VLAN- Virtual Local Area Network
Virtual Local Area Networks (VLANs) separate
an existing physical network into multiple
logical networks. Thus, each VLAN creates its
own broadcast domain.
Communication between two VLANs can only
occur through a router that is connected to both.
VLAN- Types
 In short, there are 2 types of VLANs:
 Port-based VLANs (untagged)
 With port-based VLANs, a single physical switch is simply divided into
multiple logical switches. The following example divides an eight-port
physical switch (Switch A) into two logical switches.
 Tagged VLANs
 With tagged VLANs, multiple VLANs can be used through a single switch
port. Tags containing the respective VLAN identifiers indicating the VLAN
to which the frame belongs are attached to the individual Ethernet frames as
they exit the port. If both switches understand the operation of tagged
VLANs, the reciprocal connection can be accomplished using one single
cable connecting from a “trunk” port.
VLAN- Types
 VLAN-1 (Default VLAN)
 Data VLAN: is a VLAN dedicated to carrying user data traffic. It is used
to segregate and isolate different types of network traffic, such as user devices,
servers, or specific applications.
 Management VLAN: is a VLAN specifically designated for
managing network devices, such as switches, routers, or wireless access points.
 Native VLAN: The native VLAN is a VLAN that is assigned to an
802.1Q trunk port without tagging the frames with a VLAN ID.
VLAN- Virtual Local Area Network
VLAN- Virtual Local Area Network
VLAN Configuration (SW-0)
Switch(config)#VLAN 10
Switch(config)#name Staff
Switch(config)#VLAN 99
Switch(config)#name mgt
VLAN- Virtual Local Area Network
Assigning Ports to VLAN (SW-0)
SWA(config)#interface fastethernet0/2
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 10
SWA(config-if-range)#exit
SWA(config)#interface fastethernet0/24
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 99
SWA(config-if-range)#exit
VLAN- Virtual Local Area Network
VLAN Configuration (SW-1)
Switch(config)#VLAN 10
Switch(config)#name Staff
VLAN- Virtual Local Area Network
Assigning Ports to VLAN (SW-1)
SWA(config)#interface fastethernet0/2
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 10
SWA(config-if-range)#exit
VLAN- Virtual Local Area Network
Assigning trunk Ports to VLAN (SW-0)
SWA(config)#interface fastethernet0/10
SWA(config-if-range)#switchport mode trunk
SWA(config-if-range)#switchport trunk allowed vlan 1,10,99
SWA(config-if-range)#exit
VLAN- Virtual Local Area Network
Assigning trunk Ports to VLAN (SW-1)
SWA(config)#interface fastethernet0/10
SWA(config-if-range)#switchport mode trunk
SWA(config-if-range)#switchport trunk allowed vlan 1,10,99
SWA(config-if-range)#exit
Management VLAN
Create vlan mngt
Assign the ip address for all device
Sw# vlan 99
Sw#name mnget
Sw#interface fa0/2-52
Sw#sw mode acess
Sw#sw acc valn99
___________________________________
Step 2
Assign the ip address to switch
Sw#interface vlan 99
Sw#ip address 192.168.50.1 255.255.255.0
Sw# no shut
Step 3
Create the vty password and enable password.
Step 4
Sw#ping the device of vlan mngt otr vlan99
step 5
Access the switch from the device
…. Telenet switch address
….. telnet 192.168.50.1
User pass
Enable pass
VLAN- Virtual Local Area Network
Management VLAN (SW-0)
SWA(config)#interface fastethernet0/24
SWA(config-if)#switchport mode access
SWA(config-if)#switchport access vlan 99
SWA(config-if)#exit
SWA(config-if)#interface vlan 99
SWA(config-if)#ip address 192.168.99.100 255.255.255.0
SWA(config-if)#no shutdown
VLAN- Virtual Local Area Network
 Management VLAN (SW-0)- Remote Login
SWA(config)#enable secret vty
SWA(config)#line vty 0 15
SWA(config- line)#password 123
SWA(config-if)#login
SWA(config-if)#exit
SWA(config)# enable password cisco
VLAN- Virtual Local Area Network
 Native VLAN
 The VLAN services developed with backward compatibility to support old
devices that does not support VLANs is called native VLAN. It is associated
with Trunk port.
SWA(config)#vlan 100
SWA(config)#name Native
SWA(config)#exit
SWA(config)#interface f0/10 (trunk port)
SWA(config)#switchport trunk native vlan 100
SWA(config)#show int f0/10 switchport
SWA(config)# show int trunk
Inter-VLAN Routing
 Inter-VLAN routing can be defined as a way to forward traffic
between different VLAN by implementing a router in the
network.
 As we learnt previously, VLANs logically segment the switch
into different subnets, when a router is connected to the
switch, an administrator can configure the router to forward
the traffic between the various VLANs configured on the
switch.
 There are two ways in which inter-VLAN routing can be
accomplished.
 Traditional inter-VLAN routing
 Router-on-a-stick
 Multilayer switching
Traditional inter-VLAN routing
In this type of inter-VLAN routing, a router is usually
connected to the switch using multiple interfaces.
One for each VLAN.
The interfaces on the router are configured as the
default gateways for the VLANs configured on the
switch.
The ports that connect to the router from the switch
are configured in access mode in their corresponding
VLANs.
Traditional inter-VLAN routing
Laboratory exercises
Ex.1. Testing
connectivity using the
ping command between
PC A and PC B.
Traditional inter-VLAN routing
The ip addressing in use is shownbelow.
Traditional inter-VLAN routing
VLAN Configuration
Switch(config)#VLAN 20
Switch(config)#name RED
Switch(config)#VLAN 30
Switch(config)#name BLUE
Traditional inter-VLAN routing
m
Traditional inter-VLAN routing

m
Inter-VLAN routing using router-on-a-stick
 In the second type of inter-VLAN routing which is Router-
on-a-stick, the router is connected to the switch using a
single interface.
 The switchport connecting to the router is configured as a
trunk link.
 The single interface on the router is then configured
with multiple IP addresses that correspond to the VLANs
on the switch. On the router, the physical interface is
divided into smaller interfaces called sub-interfaces
 Configure link between Routerand Switchas trunk.
 Create sub-interfaces and configure IP
.
 Configure sub-interfaces with encapsulation802.1q
Inter-VLAN routing using router-on-a-stick
Laboratory exercises
Inter-VLAN routing using router-on-a-stick
Ip address
Inter-VLAN routing using router-on-a-stick
VLAN Configuration
SWA -->VLAN 10 name Gray
SWA -->VLAN 20 name Red
SWA -->VLAN 30 name Blue
SWA -->VLAN 40 name Green
Inter-VLAN routing using router-on-a-stick
Assigning Ports to VLAN
SWA(config)#interface fastethernet0/2
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 10
SWA(config)#interface fastethernet0/3
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 20
SWA(config)#interface fastethernet0/4
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 30
SWA(config)#interface fastethernet0/5
SWA(config-if-range)#switchport mode access
SWA(config-if-range)#switchport access vlan 40
43
Inter-VLAN routing using router-on-a-stick
Trunk Configuration
SWA(config)#interface fastethernet0/1
SWA(config-if)#switchport mode trunk
trunk allowed VLAN
SWA(config-if)#switchport
10,20,30,40
SWA(config-if)#exit
44
Inter-VLAN routing using router-on-a-stick
 Creating sub-interfaces and IP address in router.
Router(config)#interface fastethernet0/0
Router(config-if)#no shutdown
Router(config)#interface fastethernet0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config)#interface fastethernet0/0.20
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config)#interface fastethernet0/0.30
Router(config-subif)#encapsulation dot1q 300
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config)#interface fastethernet0/0.40
Router(config-subif)#encapsulation dot1q 40
Router(config-subif)#ip address 192.168.40.1 255.255.255.0
45
Inter-VLAN Routing using Multilayer switching
46
 Normally, Routers are used to divide broadcast
domain and switches (at layer 2) Operates in a single
broadcast domain but Switches can also divide
broadcast domain by using the concept of VLAN (Virtual
LAN).
 Vlan is logical grouping of devices in same or different
broadcast domain. By default, all the switch ports are in
Vlan 1.
 As the single broadcast domain is divided into multiple
broadcast domains, Routers or layer 3 switches are used
for intercommunication between the different Vlans.
Inter-VLAN Routing using Multilayer switching
Switch Virtual Interface (SVI)
 Multilayer switches support Switch Virtual Interfaces (SVIs),
logical interfaces that can perform routing.
 SVI is a logical interface on a multilayer switch which
provides layer 3 processing for packets to all switch ports
associated with that VLAN.A single SVI can be created for a
Vlan.
 SVI for layer 3 switch provides both management and
routing services while SVI on layer 2 switch provides only
management services like creating vlans or telnet/SSH
services.
47
Inter-VLAN Routing using Multilayer switching
Switch Virtual Interface (SVI)
 They behave like a physical interface of a router: they have an
IP address, and they insert a connected route into the
routing table. However, they are completely virtual.
 In Router on a stick method, both switch and router
are needed but while using layer 3 switch, a single switch
will perform inter-vlan routing as well as the layer 2
functions (Vlan), therefore this method is cost effective
and also less configuration is needed.
48
Inter-VLAN Routing using Multilayer switching
49
Inter-VLAN Routing using Multilayer switching
Creating VLAN and assigning ports
Switch1(config)# vlan 10
Switch1(config)# vlan 20
Switch1(config)#int f0/1
Switch1(config)#switchport mode access
Switch1(config)#switchport access vlan 10
Switch1(config)#int f0/2
Switch1(config)#switchport mode access
Switch1(config)#switchport access vlan 20
50
Inter-VLAN Routing using Multilayer switching
Creating SVI interface and configuring it
 IP Routing is the set of protocols that determine the path that data foll
order to travel across multiple networks from its source to its destination
Switch# show ip route
Switch# int vlan 10 //configure SVI interface
Switch# ip address 192.168.1.1 255.255.255.0
Switch# int vlan 20
Switch# ip address 192.168.2.1 255.255.255.0
Switch# ip routing
Switch# show ip route
 Verify the end to end connectivity
51
Port Security
Switch security feature that allows us to limit
the number of MAC addresses learned on a per
port basis.
Can be configured to limit a port to
specificMAC addresses.
Port Security
Can be configured to limit a port to a set number of
dynamically learned MAC address.
Useful to protect against end users plugging in rogue
equipment (PCs, hubs, switches)
57
Port Security
Secure MACs have two techniques
 Static: manually configure a specific MAC address on a
port. Switchport port-security mac-address hh.hh.hh
 Sticky: switch automatically learns secure addresses on a
port. Address added to the secure address table and
running-configuration.
Command : -
Switchport port-securitymac- address sticky
58
Port Security
While secure MAC addresses have been learned on a port
and another unsecured MAC attempts to communicate on
the port, Violation is triggered.
There are 3 types. Switchport port-security Violation
Protect: least severe. Frame from unsecured MACs not
forwarded.
Restrict: medium severity. Frame from unsecured MACs
not forwarded -----
Shutdown: most severe. Port moved to err-disabled state
59
Port Security
Exercise
60
Steps to configure port security
Steps
1. Enable port security on ports
2. Set maximum (how many device)is access
ports
3. Secure port mac- address of device is
dynamically learn.
4. Set violation
5. Disable all remaining usable ports.
Port Security
Configuration
S1(config)#int f0/1
S1(config)#switchport mode access
S1(config)#switchport port-security
 S1(config)#switchport port-security maximum 1
 S1(config)#switchport port-security mac-address sticky
 S1(config)#switchport port-security violation shutdown
S1(config)#int range f0/5-24,g0/1-2
S1(config)#shutdown
62
Verify port security
1. Ping pc to server
2. Do show running to show the status
3. Attach the rouge pc to unused ports.
4. Enable port of rouge pc and ping pc1 and server. Then
disable the port
Command interface fa 0/3
No shut down
Then disable port of rouge pc
4. Disconnect port from pc1 and connect to rouge pc and
check unping with server.
5. Disconnect rouge pc and reconnect to pc1 and ping with
server.
6. Why pc1 ping server and not with rouge pc?
Port Security
Check
S1(config)# show run
S1(config)# show mac-address-tale
S1(config)# show port-security
S1(config)# show port-security interface f0/1
 Check connectivity between pc0 and server
 Check connectivity between pc1 and server on the same port
 Server reply
 S1(config)# show run
 S1(config)# show mac-address-table
61
Port Security
Check
 S1(config)# show run
 S1(config)# show mac-address-table
 S1(config)# show port-security
 S1(config)# show port-security interface f0/1
 Check connectivity between pc0 and server
 Check connectivity between pc1 and server on the same port
 Server doesn’t reply to pc1, this is because of port
security
63
How to re-enable ports?
Commands
Interface fa 0/1
S1(config)# Shutdown
S1(config)# No shutdown
ACL
132
Access Control Lists “ACLs” are network traffic
filters that can control incoming or outgoing traffic.
 Powerful tool for network control
 Filter packets flow in or out of router interfaces
 Restrict network use by certain users or devices
 Deny or permit traffic
ACLs work on a set of rules that define how to
forward or block a packet at the router’s interface.
There are two types,
 Standard Access List
 Extended Access List
ACL
133
Standard Access List
 A Standard ACL can use only the source IP address in an IP
packet to filter the network traffic. Standard access lists are
typically used to permit or deny an entire host or network.
They cannot be used to filter individual protocol or services
such as FTP and Telnet. In the technical explanation, the
standard ACL supports only source address.
 standard access lists – allow you to evaluate only the
source IP address of a packet. Standard ACLs are not as
powerful as extended access lists, but they are less CPU
intensive for the device.
 By using numbers 1-99 or 1300-1999, router will understand it as
a standard ACL and the specified address as source IPaddress.
ACL
134
Configuring ACL
R1(config)# access-list ACL_NUMBER permit|denyhost
IP_ADDRESS WILDCARD_MASK
Once the access list is created, it needs to be applied to an interface
on the device where you want the traffic filtered. You must also
specify which direction of traffic you want the access list applied to.
Two directions are available:
 inbound – ACL is applied to the traffic coming into theinterface.
 outbound – the ACL is applied to the traffic leaving theinterface.
R1(config)# ip access-group ACL_NUMBER in|out
ACL
135
Exercise: Configuring ACL
ACL
136
Assigning Ip Address
 Router(config)#int g0/0/0
 Router(config-if)#ip address 192.168.10.1 255.255.255.0
 Router(config-if)#no shut
 Router(config-if)#int g0/0/1
 Router(config-if)#ip add 192.168.20.1 255.255.255.0
 Router(config-if)#no shut
ACL
137
Configuring ACL
Router(config)#access-list 1 deny host 192.168.20.3
Router(config)#access-list 1 permit host 192.168.20.2
Router(config)#int g0/0/1
Router(config-if)#ip access-group 1 in
Exercise
Allow pc2 to access web server and deny other.
Extended ACL
 Router(config)#access-list 130 permit ip
10.10.10.10 255.0.0.0 192.168.10.50
255.255.255.0
 Router(config)#access-list 130 deny ip any any
 Router(config)#interface GigabitEthernet0/0/1
 Router(config-if)#ip access-group 130 out

More Related Content

Similar to labffbhhhhjjjjjjjjj bnbbnv material.pptx

CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glance
Vikas Raut
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
alan moreno
 
Ccna lab manual 640 802
Ccna lab manual 640 802Ccna lab manual 640 802
Ccna lab manual 640 802
manikkan
 

Similar to labffbhhhhjjjjjjjjj bnbbnv material.pptx (20)

Nat report2
Nat report2Nat report2
Nat report2
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
CCNA at a glance
CCNA at a glanceCCNA at a glance
CCNA at a glance
 
How to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideHow to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guide
 
Cisco Router Basic Configuraiton
Cisco Router Basic ConfiguraitonCisco Router Basic Configuraiton
Cisco Router Basic Configuraiton
 
Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)
 
Labmannual
LabmannualLabmannual
Labmannual
 
Vlan lab
Vlan labVlan lab
Vlan lab
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
 
Vlan
VlanVlan
Vlan
 
Ccna lab manual 640 802
Ccna lab manual 640 802Ccna lab manual 640 802
Ccna lab manual 640 802
 
Lab6.4.1
Lab6.4.1Lab6.4.1
Lab6.4.1
 
managing your network environment
managing your network environmentmanaging your network environment
managing your network environment
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchi
 
Cisco CCNA-Router on Stick
Cisco CCNA-Router on StickCisco CCNA-Router on Stick
Cisco CCNA-Router on Stick
 

More from BinyamBekeleMoges (9)

Introduction to Distributed Systems (1).pdf
Introduction to Distributed Systems (1).pdfIntroduction to Distributed Systems (1).pdf
Introduction to Distributed Systems (1).pdf
 
MC Lecture 8 67875667767777775677887.pptx
MC Lecture 8 67875667767777775677887.pptxMC Lecture 8 67875667767777775677887.pptx
MC Lecture 8 67875667767777775677887.pptx
 
MC Lecture 9234455566667777777777777.pptx
MC Lecture 9234455566667777777777777.pptxMC Lecture 9234455566667777777777777.pptx
MC Lecture 9234455566667777777777777.pptx
 
The 4 Key Issues about Communication.pptx
The 4 Key Issues about Communication.pptxThe 4 Key Issues about Communication.pptx
The 4 Key Issues about Communication.pptx
 
2 Dev t Comm Paradigms and Practices.pptx
2 Dev t Comm Paradigms and Practices.pptx2 Dev t Comm Paradigms and Practices.pptx
2 Dev t Comm Paradigms and Practices.pptx
 
research methedology ppt.pptx
research methedology ppt.pptxresearch methedology ppt.pptx
research methedology ppt.pptx
 
Chapter one.pptx
Chapter one.pptxChapter one.pptx
Chapter one.pptx
 
babo corora grade 9 ICT-ppt.pptx
babo corora grade 9 ICT-ppt.pptxbabo corora grade 9 ICT-ppt.pptx
babo corora grade 9 ICT-ppt.pptx
 
Chapter Five.pptx
Chapter Five.pptxChapter Five.pptx
Chapter Five.pptx
 

Recently uploaded

Activity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdfActivity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdf
ciinovamais
 
1029-Danh muc Sach Giao Khoa khoi 6.pdf
1029-Danh muc Sach Giao Khoa khoi  6.pdf1029-Danh muc Sach Giao Khoa khoi  6.pdf
1029-Danh muc Sach Giao Khoa khoi 6.pdf
QucHHunhnh
 

Recently uploaded (20)

How to Give a Domain for a Field in Odoo 17
How to Give a Domain for a Field in Odoo 17How to Give a Domain for a Field in Odoo 17
How to Give a Domain for a Field in Odoo 17
 
Measures of Central Tendency: Mean, Median and Mode
Measures of Central Tendency: Mean, Median and ModeMeasures of Central Tendency: Mean, Median and Mode
Measures of Central Tendency: Mean, Median and Mode
 
Ecological Succession. ( ECOSYSTEM, B. Pharmacy, 1st Year, Sem-II, Environmen...
Ecological Succession. ( ECOSYSTEM, B. Pharmacy, 1st Year, Sem-II, Environmen...Ecological Succession. ( ECOSYSTEM, B. Pharmacy, 1st Year, Sem-II, Environmen...
Ecological Succession. ( ECOSYSTEM, B. Pharmacy, 1st Year, Sem-II, Environmen...
 
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
Presentation by Andreas Schleicher Tackling the School Absenteeism Crisis 30 ...
 
ComPTIA Overview | Comptia Security+ Book SY0-701
ComPTIA Overview | Comptia Security+ Book SY0-701ComPTIA Overview | Comptia Security+ Book SY0-701
ComPTIA Overview | Comptia Security+ Book SY0-701
 
Measures of Dispersion and Variability: Range, QD, AD and SD
Measures of Dispersion and Variability: Range, QD, AD and SDMeasures of Dispersion and Variability: Range, QD, AD and SD
Measures of Dispersion and Variability: Range, QD, AD and SD
 
Unit-IV- Pharma. Marketing Channels.pptx
Unit-IV- Pharma. Marketing Channels.pptxUnit-IV- Pharma. Marketing Channels.pptx
Unit-IV- Pharma. Marketing Channels.pptx
 
INDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptx
INDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptxINDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptx
INDIA QUIZ 2024 RLAC DELHI UNIVERSITY.pptx
 
microwave assisted reaction. General introduction
microwave assisted reaction. General introductionmicrowave assisted reaction. General introduction
microwave assisted reaction. General introduction
 
Mixin Classes in Odoo 17 How to Extend Models Using Mixin Classes
Mixin Classes in Odoo 17  How to Extend Models Using Mixin ClassesMixin Classes in Odoo 17  How to Extend Models Using Mixin Classes
Mixin Classes in Odoo 17 How to Extend Models Using Mixin Classes
 
psychiatric nursing HISTORY COLLECTION .docx
psychiatric  nursing HISTORY  COLLECTION  .docxpsychiatric  nursing HISTORY  COLLECTION  .docx
psychiatric nursing HISTORY COLLECTION .docx
 
Basic Civil Engineering first year Notes- Chapter 4 Building.pptx
Basic Civil Engineering first year Notes- Chapter 4 Building.pptxBasic Civil Engineering first year Notes- Chapter 4 Building.pptx
Basic Civil Engineering first year Notes- Chapter 4 Building.pptx
 
Micro-Scholarship, What it is, How can it help me.pdf
Micro-Scholarship, What it is, How can it help me.pdfMicro-Scholarship, What it is, How can it help me.pdf
Micro-Scholarship, What it is, How can it help me.pdf
 
ICT Role in 21st Century Education & its Challenges.pptx
ICT Role in 21st Century Education & its Challenges.pptxICT Role in 21st Century Education & its Challenges.pptx
ICT Role in 21st Century Education & its Challenges.pptx
 
Sociology 101 Demonstration of Learning Exhibit
Sociology 101 Demonstration of Learning ExhibitSociology 101 Demonstration of Learning Exhibit
Sociology 101 Demonstration of Learning Exhibit
 
Activity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdfActivity 01 - Artificial Culture (1).pdf
Activity 01 - Artificial Culture (1).pdf
 
1029-Danh muc Sach Giao Khoa khoi 6.pdf
1029-Danh muc Sach Giao Khoa khoi  6.pdf1029-Danh muc Sach Giao Khoa khoi  6.pdf
1029-Danh muc Sach Giao Khoa khoi 6.pdf
 
Introduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The BasicsIntroduction to Nonprofit Accounting: The Basics
Introduction to Nonprofit Accounting: The Basics
 
TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...
TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...
TỔNG ÔN TẬP THI VÀO LỚP 10 MÔN TIẾNG ANH NĂM HỌC 2023 - 2024 CÓ ĐÁP ÁN (NGỮ Â...
 
Z Score,T Score, Percential Rank and Box Plot Graph
Z Score,T Score, Percential Rank and Box Plot GraphZ Score,T Score, Percential Rank and Box Plot Graph
Z Score,T Score, Percential Rank and Box Plot Graph
 

labffbhhhhjjjjjjjjj bnbbnv material.pptx

  • 1. Network Fundamentals Basic Device Configuration Part I
  • 2. Basic Device Configuration(Lab 1) IOS (Internetwork Operating System) basics Networking device basics Security basics Remote Access
  • 3. Basic Device Configuration(Lab 1) CLIConfigurationModes  The basic CLI modes that we will be referring below are as following:  Router> <– User EXEC Mode(?) Router# <– Privileged EXEC mode Router(config)# <– Global Configuration Mode Router(config-if)# <– Interface Configuration Mode Router(config-line)# <– Line Configuration Mode
  • 4. Basic Device Configuration(Lab 1) Naming Hostname Creating Console password Creating enable Password and Enable secret Creating vty password Encrypting service password Creating switch/ router interface management
  • 5. Exercise Draw the following topology and do basic configuration.
  • 6. How to change Hostname  Pres Enter to start and type enable to get to the privilege mode.  Switch>enable  Type configure terminal to enter the global configuration mode.  Switch# configure terminal  Change the hostname by typing hostname switch-name.  switch(config)# hostname SW  sw (config)#exit  sw#show running-config
  • 7. Console and vty password  The console password is used for authentication when accessing the device's Command Line Interface (CLI) through the console port.  The console password is used to secure physical access to the device.  Its restrict unauthorized users from accessing and configuring the device through the console port.
  • 8. Console and vty password  is used for authentication when accessing the device's CLI remotely through a virtual terminal connection.  VTY connections are established over the network using protocols such as Telnet or SSH.  The VTY password is used to authenticate remote users who are trying to access the device's CLI.
  • 9. Configuring Console Password Enter to global configuration mode S1(config)# line console 0 S1(config-line)# password cisco S1(config-line)#login  S1(config-line)#exit S1(config)#exit S1#show running-config
  • 10. Configuring the Enable Password Enter into the global configuration mod S1(config)#Enable password cisco1 Or S1(config)#Enable secret cisco1 S1(config)#exit S1#show running-config
  • 11. Configuring VTY password Remote Access cont.…  Enter into global configuration mode  S1(config)#Line vty 0 15  S1(config-line)#password cisco  S1(config-line)#login  S1(config-line)#exit  S1(config)#exit  S1# show runn  Access from pc’s CMD: ping 10.10.10.1
  • 12. Configuring Enable Password Enter into global configuration mode S1(config)#service password-encryption S1(config)#show run Then you will see all passwords are encrypted
  • 13. SSH (Secure Shell) and Telnet  used for remote access to network devices  Telnet: Telnet is an unencrypted protocol used for remote terminal access to network devices.  It allows a user to establish a text-based session with a remote device and execute commands remotely.  SSH: SSH is a secure replacement for Telnet.  It provides encrypted communication between the client and the server, ensuring confidentiality and integrity of the data transmitted.
  • 14. Configuring ssh password Configure ssh for router and switch to control form computers
  • 15. Configuring ssh password… Steps to configure ssh password  Change the host name  Assign the Ip address for all devices  Assign the domain-name  generate the rsa key for the encryption purpose  Create user name and password for user and enable  Apply ssh configuration
  • 16. Configuring ssh password… Switch(config)#hostname S1 S1(config)#interface vlan 1 S1(config-if)#ip address 192.168.10.20 S1(config- if)#no shutdown S1(config-if)#exit
  • 17. Router(config)#hostname R1 R1(config)#interface G0/0/0 R1(config-if)#ip address 192.168.10.1 255.255.255.0 R1(config-if)#no shutdown R1(config-if)#exit
  • 18. Configuring ssh password… R1(config)#ip domain-name lab.com R1(config)#crypto key generate rsa How many bits in the modulus [512]: 1024 R1(config)#enable password 12345 R1(config)#username admin password cisco R1(config)#ip ssh version 2 R1(config)#line vty 0 15 R1(config-line)#transport input ssh R1(config-line)#login local R1(config-line)#exit
  • 19. Configuring ssh password… Access from pc’s CMD: ssh –L example ssh –l admin 192.168.10.1 Access remotely from pc to configure both pc.
  • 21. VLAN- Virtual Local Area Network Virtual Local Area Networks (VLANs) separate an existing physical network into multiple logical networks. Thus, each VLAN creates its own broadcast domain. Communication between two VLANs can only occur through a router that is connected to both.
  • 22. VLAN- Types  In short, there are 2 types of VLANs:  Port-based VLANs (untagged)  With port-based VLANs, a single physical switch is simply divided into multiple logical switches. The following example divides an eight-port physical switch (Switch A) into two logical switches.  Tagged VLANs  With tagged VLANs, multiple VLANs can be used through a single switch port. Tags containing the respective VLAN identifiers indicating the VLAN to which the frame belongs are attached to the individual Ethernet frames as they exit the port. If both switches understand the operation of tagged VLANs, the reciprocal connection can be accomplished using one single cable connecting from a “trunk” port.
  • 23. VLAN- Types  VLAN-1 (Default VLAN)  Data VLAN: is a VLAN dedicated to carrying user data traffic. It is used to segregate and isolate different types of network traffic, such as user devices, servers, or specific applications.  Management VLAN: is a VLAN specifically designated for managing network devices, such as switches, routers, or wireless access points.  Native VLAN: The native VLAN is a VLAN that is assigned to an 802.1Q trunk port without tagging the frames with a VLAN ID.
  • 24. VLAN- Virtual Local Area Network
  • 25. VLAN- Virtual Local Area Network VLAN Configuration (SW-0) Switch(config)#VLAN 10 Switch(config)#name Staff Switch(config)#VLAN 99 Switch(config)#name mgt
  • 26. VLAN- Virtual Local Area Network Assigning Ports to VLAN (SW-0) SWA(config)#interface fastethernet0/2 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 10 SWA(config-if-range)#exit SWA(config)#interface fastethernet0/24 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 99 SWA(config-if-range)#exit
  • 27. VLAN- Virtual Local Area Network VLAN Configuration (SW-1) Switch(config)#VLAN 10 Switch(config)#name Staff
  • 28. VLAN- Virtual Local Area Network Assigning Ports to VLAN (SW-1) SWA(config)#interface fastethernet0/2 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 10 SWA(config-if-range)#exit
  • 29. VLAN- Virtual Local Area Network Assigning trunk Ports to VLAN (SW-0) SWA(config)#interface fastethernet0/10 SWA(config-if-range)#switchport mode trunk SWA(config-if-range)#switchport trunk allowed vlan 1,10,99 SWA(config-if-range)#exit
  • 30. VLAN- Virtual Local Area Network Assigning trunk Ports to VLAN (SW-1) SWA(config)#interface fastethernet0/10 SWA(config-if-range)#switchport mode trunk SWA(config-if-range)#switchport trunk allowed vlan 1,10,99 SWA(config-if-range)#exit
  • 31. Management VLAN Create vlan mngt Assign the ip address for all device Sw# vlan 99 Sw#name mnget Sw#interface fa0/2-52 Sw#sw mode acess Sw#sw acc valn99 ___________________________________ Step 2 Assign the ip address to switch Sw#interface vlan 99 Sw#ip address 192.168.50.1 255.255.255.0 Sw# no shut
  • 32. Step 3 Create the vty password and enable password. Step 4 Sw#ping the device of vlan mngt otr vlan99 step 5 Access the switch from the device …. Telenet switch address ….. telnet 192.168.50.1 User pass Enable pass
  • 33. VLAN- Virtual Local Area Network Management VLAN (SW-0) SWA(config)#interface fastethernet0/24 SWA(config-if)#switchport mode access SWA(config-if)#switchport access vlan 99 SWA(config-if)#exit SWA(config-if)#interface vlan 99 SWA(config-if)#ip address 192.168.99.100 255.255.255.0 SWA(config-if)#no shutdown
  • 34. VLAN- Virtual Local Area Network  Management VLAN (SW-0)- Remote Login SWA(config)#enable secret vty SWA(config)#line vty 0 15 SWA(config- line)#password 123 SWA(config-if)#login SWA(config-if)#exit SWA(config)# enable password cisco
  • 35. VLAN- Virtual Local Area Network  Native VLAN  The VLAN services developed with backward compatibility to support old devices that does not support VLANs is called native VLAN. It is associated with Trunk port. SWA(config)#vlan 100 SWA(config)#name Native SWA(config)#exit SWA(config)#interface f0/10 (trunk port) SWA(config)#switchport trunk native vlan 100 SWA(config)#show int f0/10 switchport SWA(config)# show int trunk
  • 36. Inter-VLAN Routing  Inter-VLAN routing can be defined as a way to forward traffic between different VLAN by implementing a router in the network.  As we learnt previously, VLANs logically segment the switch into different subnets, when a router is connected to the switch, an administrator can configure the router to forward the traffic between the various VLANs configured on the switch.  There are two ways in which inter-VLAN routing can be accomplished.  Traditional inter-VLAN routing  Router-on-a-stick  Multilayer switching
  • 37. Traditional inter-VLAN routing In this type of inter-VLAN routing, a router is usually connected to the switch using multiple interfaces. One for each VLAN. The interfaces on the router are configured as the default gateways for the VLANs configured on the switch. The ports that connect to the router from the switch are configured in access mode in their corresponding VLANs.
  • 38. Traditional inter-VLAN routing Laboratory exercises Ex.1. Testing connectivity using the ping command between PC A and PC B.
  • 39. Traditional inter-VLAN routing The ip addressing in use is shownbelow.
  • 40. Traditional inter-VLAN routing VLAN Configuration Switch(config)#VLAN 20 Switch(config)#name RED Switch(config)#VLAN 30 Switch(config)#name BLUE
  • 43. Inter-VLAN routing using router-on-a-stick  In the second type of inter-VLAN routing which is Router- on-a-stick, the router is connected to the switch using a single interface.  The switchport connecting to the router is configured as a trunk link.  The single interface on the router is then configured with multiple IP addresses that correspond to the VLANs on the switch. On the router, the physical interface is divided into smaller interfaces called sub-interfaces  Configure link between Routerand Switchas trunk.  Create sub-interfaces and configure IP .  Configure sub-interfaces with encapsulation802.1q
  • 44. Inter-VLAN routing using router-on-a-stick Laboratory exercises
  • 45. Inter-VLAN routing using router-on-a-stick Ip address
  • 46. Inter-VLAN routing using router-on-a-stick VLAN Configuration SWA -->VLAN 10 name Gray SWA -->VLAN 20 name Red SWA -->VLAN 30 name Blue SWA -->VLAN 40 name Green
  • 47. Inter-VLAN routing using router-on-a-stick Assigning Ports to VLAN SWA(config)#interface fastethernet0/2 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 10 SWA(config)#interface fastethernet0/3 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 20 SWA(config)#interface fastethernet0/4 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 30 SWA(config)#interface fastethernet0/5 SWA(config-if-range)#switchport mode access SWA(config-if-range)#switchport access vlan 40 43
  • 48. Inter-VLAN routing using router-on-a-stick Trunk Configuration SWA(config)#interface fastethernet0/1 SWA(config-if)#switchport mode trunk trunk allowed VLAN SWA(config-if)#switchport 10,20,30,40 SWA(config-if)#exit 44
  • 49. Inter-VLAN routing using router-on-a-stick  Creating sub-interfaces and IP address in router. Router(config)#interface fastethernet0/0 Router(config-if)#no shutdown Router(config)#interface fastethernet0/0.10 Router(config-subif)#encapsulation dot1q 10 Router(config-subif)#ip address 192.168.10.1 255.255.255.0 Router(config)#interface fastethernet0/0.20 Router(config-subif)#encapsulation dot1q 20 Router(config-subif)#ip address 192.168.20.1 255.255.255.0 Router(config)#interface fastethernet0/0.30 Router(config-subif)#encapsulation dot1q 300 Router(config-subif)#ip address 192.168.30.1 255.255.255.0 Router(config)#interface fastethernet0/0.40 Router(config-subif)#encapsulation dot1q 40 Router(config-subif)#ip address 192.168.40.1 255.255.255.0 45
  • 50. Inter-VLAN Routing using Multilayer switching 46  Normally, Routers are used to divide broadcast domain and switches (at layer 2) Operates in a single broadcast domain but Switches can also divide broadcast domain by using the concept of VLAN (Virtual LAN).  Vlan is logical grouping of devices in same or different broadcast domain. By default, all the switch ports are in Vlan 1.  As the single broadcast domain is divided into multiple broadcast domains, Routers or layer 3 switches are used for intercommunication between the different Vlans.
  • 51. Inter-VLAN Routing using Multilayer switching Switch Virtual Interface (SVI)  Multilayer switches support Switch Virtual Interfaces (SVIs), logical interfaces that can perform routing.  SVI is a logical interface on a multilayer switch which provides layer 3 processing for packets to all switch ports associated with that VLAN.A single SVI can be created for a Vlan.  SVI for layer 3 switch provides both management and routing services while SVI on layer 2 switch provides only management services like creating vlans or telnet/SSH services. 47
  • 52. Inter-VLAN Routing using Multilayer switching Switch Virtual Interface (SVI)  They behave like a physical interface of a router: they have an IP address, and they insert a connected route into the routing table. However, they are completely virtual.  In Router on a stick method, both switch and router are needed but while using layer 3 switch, a single switch will perform inter-vlan routing as well as the layer 2 functions (Vlan), therefore this method is cost effective and also less configuration is needed. 48
  • 53. Inter-VLAN Routing using Multilayer switching 49
  • 54. Inter-VLAN Routing using Multilayer switching Creating VLAN and assigning ports Switch1(config)# vlan 10 Switch1(config)# vlan 20 Switch1(config)#int f0/1 Switch1(config)#switchport mode access Switch1(config)#switchport access vlan 10 Switch1(config)#int f0/2 Switch1(config)#switchport mode access Switch1(config)#switchport access vlan 20 50
  • 55. Inter-VLAN Routing using Multilayer switching Creating SVI interface and configuring it  IP Routing is the set of protocols that determine the path that data foll order to travel across multiple networks from its source to its destination Switch# show ip route Switch# int vlan 10 //configure SVI interface Switch# ip address 192.168.1.1 255.255.255.0 Switch# int vlan 20 Switch# ip address 192.168.2.1 255.255.255.0 Switch# ip routing Switch# show ip route  Verify the end to end connectivity 51
  • 56. Port Security Switch security feature that allows us to limit the number of MAC addresses learned on a per port basis. Can be configured to limit a port to specificMAC addresses.
  • 57. Port Security Can be configured to limit a port to a set number of dynamically learned MAC address. Useful to protect against end users plugging in rogue equipment (PCs, hubs, switches) 57
  • 58. Port Security Secure MACs have two techniques  Static: manually configure a specific MAC address on a port. Switchport port-security mac-address hh.hh.hh  Sticky: switch automatically learns secure addresses on a port. Address added to the secure address table and running-configuration. Command : - Switchport port-securitymac- address sticky 58
  • 59. Port Security While secure MAC addresses have been learned on a port and another unsecured MAC attempts to communicate on the port, Violation is triggered. There are 3 types. Switchport port-security Violation Protect: least severe. Frame from unsecured MACs not forwarded. Restrict: medium severity. Frame from unsecured MACs not forwarded ----- Shutdown: most severe. Port moved to err-disabled state 59
  • 61. Steps to configure port security Steps 1. Enable port security on ports 2. Set maximum (how many device)is access ports 3. Secure port mac- address of device is dynamically learn. 4. Set violation 5. Disable all remaining usable ports.
  • 62. Port Security Configuration S1(config)#int f0/1 S1(config)#switchport mode access S1(config)#switchport port-security  S1(config)#switchport port-security maximum 1  S1(config)#switchport port-security mac-address sticky  S1(config)#switchport port-security violation shutdown S1(config)#int range f0/5-24,g0/1-2 S1(config)#shutdown 62
  • 63. Verify port security 1. Ping pc to server 2. Do show running to show the status 3. Attach the rouge pc to unused ports. 4. Enable port of rouge pc and ping pc1 and server. Then disable the port Command interface fa 0/3 No shut down Then disable port of rouge pc 4. Disconnect port from pc1 and connect to rouge pc and check unping with server. 5. Disconnect rouge pc and reconnect to pc1 and ping with server. 6. Why pc1 ping server and not with rouge pc?
  • 64. Port Security Check S1(config)# show run S1(config)# show mac-address-tale S1(config)# show port-security S1(config)# show port-security interface f0/1  Check connectivity between pc0 and server  Check connectivity between pc1 and server on the same port  Server reply  S1(config)# show run  S1(config)# show mac-address-table 61
  • 65. Port Security Check  S1(config)# show run  S1(config)# show mac-address-table  S1(config)# show port-security  S1(config)# show port-security interface f0/1  Check connectivity between pc0 and server  Check connectivity between pc1 and server on the same port  Server doesn’t reply to pc1, this is because of port security 63
  • 66. How to re-enable ports? Commands Interface fa 0/1 S1(config)# Shutdown S1(config)# No shutdown
  • 67. ACL 132 Access Control Lists “ACLs” are network traffic filters that can control incoming or outgoing traffic.  Powerful tool for network control  Filter packets flow in or out of router interfaces  Restrict network use by certain users or devices  Deny or permit traffic ACLs work on a set of rules that define how to forward or block a packet at the router’s interface. There are two types,  Standard Access List  Extended Access List
  • 68. ACL 133 Standard Access List  A Standard ACL can use only the source IP address in an IP packet to filter the network traffic. Standard access lists are typically used to permit or deny an entire host or network. They cannot be used to filter individual protocol or services such as FTP and Telnet. In the technical explanation, the standard ACL supports only source address.  standard access lists – allow you to evaluate only the source IP address of a packet. Standard ACLs are not as powerful as extended access lists, but they are less CPU intensive for the device.  By using numbers 1-99 or 1300-1999, router will understand it as a standard ACL and the specified address as source IPaddress.
  • 69. ACL 134 Configuring ACL R1(config)# access-list ACL_NUMBER permit|denyhost IP_ADDRESS WILDCARD_MASK Once the access list is created, it needs to be applied to an interface on the device where you want the traffic filtered. You must also specify which direction of traffic you want the access list applied to. Two directions are available:  inbound – ACL is applied to the traffic coming into theinterface.  outbound – the ACL is applied to the traffic leaving theinterface. R1(config)# ip access-group ACL_NUMBER in|out
  • 71. ACL 136 Assigning Ip Address  Router(config)#int g0/0/0  Router(config-if)#ip address 192.168.10.1 255.255.255.0  Router(config-if)#no shut  Router(config-if)#int g0/0/1  Router(config-if)#ip add 192.168.20.1 255.255.255.0  Router(config-if)#no shut
  • 72. ACL 137 Configuring ACL Router(config)#access-list 1 deny host 192.168.20.3 Router(config)#access-list 1 permit host 192.168.20.2 Router(config)#int g0/0/1 Router(config-if)#ip access-group 1 in
  • 73. Exercise Allow pc2 to access web server and deny other.
  • 74. Extended ACL  Router(config)#access-list 130 permit ip 10.10.10.10 255.0.0.0 192.168.10.50 255.255.255.0  Router(config)#access-list 130 deny ip any any  Router(config)#interface GigabitEthernet0/0/1  Router(config-if)#ip access-group 130 out