SlideShare a Scribd company logo
RIP (Routing Information Protocol). Document Version 1.1.
Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330
Updated material may be found at http://www.deepuverma.in
LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw
Today we are covered about RIP Version 2 in real time configuration.
Last time we covered about RIP Basic and RIP Version 1 in details configuration on Cisco Router. Here I
am attached some basic again about RIP and RIP Version 2.
Routing Information Protocol (RIP) is a standardized
Distance Vector protocol (First true Distance Vector), and used on smaller networks. RIP uses the
“Bellman-Ford” Distance Vector algorithm to determine the best “path” to a particular destination. The
maximum number of hops allowed for RIP is 15. This hop limit, however, also limits the size of networks
that RIP can support. A hop count of 16 is considered an infinite distance or poison route, in other
words the route is considered unreachable.
Some Specification of RIP Protocol:
1. AD (Administrator Distance) is 120.
2. RIP sends out periodic routing updates after every 30 seconds with full routing table.
3. RIP uses a form of distance (Hopcount) as it’s metric, maximum hopcount are 15 hops.
4. RIP uses the “Bellman-Ford Distance Vector algorithm”.
5. RIP Utilize UDP Port 520.
6. RIP Support IP and IPX Routing.
7. RIP has two Versions (RIP Version 1 and RIP Version 2). (For IPv6 is RIPng, it’s not a Version of
RIP)
RIP will load balance between those paths (default, up to 4) only if the metric (hopcount) is equal. RIP
uses a round-robin system of load-balancing between equal metric routes, which can lead to pinhole
congestion.
Timers
RIP uses the following timers as part of its operation:
1. Update Timer – Default 30 Seconds.
2. Invalid Timer - Default 180 Seconds, After expires Invalid timer the hop count of the routing
entry will be set to 16, marking the destination as unreachable.
3. Flush Timer – Default 240 Seconds.
RIP (Routing Information Protocol). Document Version 1.1.
Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330
Updated material may be found at http://www.deepuverma.in
LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw
4. Holddown Timer - Default is 180 Seconds (This is Cisco's implementation and can word on only
Cisco Routers)
Limitations
The hop count cannot exceed 15, otherwise it will be considered invalid. Most RIP networks are flat.
There is no concept of areas or boundaries in RIP networks. Variable Length Subnet Masks are not
supported by RIP version 1. RIP has slow convergence and count to infinity problems.
RIP Versions
RIP has two versions, RIPv1 and RIPv2.
RIP Version 1 (RIPv1):
1. RIPv1 is classful, and therefore does not include the subnet mask with its routing table updates.
2. RIPv1 does not support Variable Length Subnet Masks (VLSMs).
3. RIPv1 sends updates as broadcasts to address 255.255.255.255.
4. RIPv1 has maximum hopcount is 15 hops.
5. RIPv1 does not support authentication.
6. RIPv1 routers will send only Version 1 packets.
7. RIPv1 routers will receive both Version 1 and 2 updates.
8. Cisco Routers by default support RIPv1.
RIP Version 2 (RIPv2):
1. RIPv2 is classless, and therefore does include the subnet mask with its routing table updates.
2. RIPv2 fully supports VLSMs.
3. Routing updates are sent via multicast, using address 224.0.0.9
4. Encrypted authentication can be configured between RIPv2 routers
5. Route tagging is supported.
6. RIPv2 routers will both send and receive only Version 2 updates
7. We can control the version of RIP a particular interface will “send” or “receive.”
8. RIPv2 is manually specified on, a Cisco will default to RIPv1 when configuring RIP.
9. User below mention command for change version on Cisco Routers
Router(config)#router rip
Router(config-router)#version 2
RIP (Routing Information Protocol). Document Version 1.1.
Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330
Updated material may be found at http://www.deepuverma.in
LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw
Configuration of RIPv2
As per image, take a network Diagram for testing RIPv1 Configuration.
Let’s Check Router Configuration on R0:-
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
RIP (Routing Information Protocol). Document Version 1.1.
Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330
Updated material may be found at http://www.deepuverma.in
LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.2.1 255.255.255.252
!
interface Serial0/0/1
ip address 192.168.3.6 255.255.255.252
!
!
router rip
version 2
network 192.168.2.0
network 192.168.3.0
network 192.168.10.0
no auto-summary
!
Let’s Check Router Configuration on R1:-
interface FastEthernet0/0
ip address 192.168.30.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.2.2 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 192.168.3.5 255.255.255.252
clock rate 2000000
RIP (Routing Information Protocol). Document Version 1.1.
Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330
Updated material may be found at http://www.deepuverma.in
LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw
!
router rip
version 2
network 192.168.2.0
network 192.168.3.0
network 192.168.20.0
network 192.168.30.0
no auto-summary
!
Let’s Check Router Configuration on R2:-
interface FastEthernet0/0
ip address 192.168.30.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.40.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
!
router rip
version 2
network 192.168.30.0
network 192.168.40.0
no auto-summary
RIP (Routing Information Protocol). Document Version 1.1.
Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330
Updated material may be found at http://www.deepuverma.in
LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw
Project Success:-
1. Project Ping test pass
2. Project Ready to work on Live Network
3. Load Balancing is tested.
Let’s Testing load Balancing: - (Tracert command from Laptop2 to Laptop0)
PC>tracert 192.168.10.2
Tracing route to 192.168.10.2 over a maximum of 30 hops:
1 1 ms 0 ms 1 ms 192.168.40.1
2 1 ms 0 ms 0 ms 192.168.30.1
3 0 ms 2 ms 2 ms 192.168.3.6
4 20 ms 0 ms 1 ms 192.168.10.2
Trace complete.
(Tracert command from Laptop1 to Laptop0)
PC>tracert 192.168.10.2
Tracing route to 192.168.10.2 over a maximum of 30 hops:
1 0 ms 0 ms 1 ms 192.168.20.1
2 1 ms 0 ms 0 ms 192.168.2.1
3 31 ms 0 ms 0 ms 192.168.10.2
Trace complete.
Test RIP Database on Routers
R2#sho ip rip database
192.168.2.0/30 auto-summary
192.168.2.0/30
[1] via 192.168.30.1, 00:00:23, FastEthernet0/0
192.168.3.4/30 auto-summary
192.168.3.4/30
RIP (Routing Information Protocol). Document Version 1.1.
Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330
Updated material may be found at http://www.deepuverma.in
LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw
[1] via 192.168.30.1, 00:00:23, FastEthernet0/0
192.168.10.0/24 auto-summary
192.168.10.0/24
[2] via 192.168.30.1, 00:00:23, FastEthernet0/0
192.168.20.0/24 auto-summary
192.168.20.0/24
[1] via 192.168.30.1, 00:00:23, FastEthernet0/0
192.168.30.0/24 auto-summary
192.168.30.0/24 directly connected, FastEthernet0/0
192.168.40.0/24 auto-summary
192.168.40.0/24 directly connected, FastEthernet0/1
R2#
R1#sho ip rip database
192.168.2.0/30 auto-summary
192.168.2.0/30 directly connected, Serial0/0/0
192.168.3.4/30 auto-summary
192.168.3.4/30 directly connected, Serial0/0/1
192.168.10.0/24 auto-summary
192.168.10.0/24
[1] via 192.168.2.1, 00:00:22, Serial0/0/0 [1] via 192.168.3.6, 00:00:22, Serial0/0/1
192.168.20.0/24 auto-summary
192.168.20.0/24 directly connected, FastEthernet0/1
192.168.30.0/24 auto-summary
192.168.30.0/24 directly connected, FastEthernet0/0
192.168.40.0/24 auto-summary
192.168.40.0/24
[1] via 192.168.30.2, 00:00:18, FastEthernet0/0
No auto-summary command forces the advertisement of two different subnets from different interfaces
within the same network.
-----------------------------End RIP Document Version 1.1 by Deepak Kumar -----------------------------------
Note: - RIP Troubleshooting Document will soon. Drop an email to get document in your inbox.

More Related Content

What's hot

IP Source Guard
IP Source Guard IP Source Guard
IP Source Guard
NetProtocol Xpert
 
How deep is your buffer – Demystifying buffers and application performance
How deep is your buffer – Demystifying buffers and application performanceHow deep is your buffer – Demystifying buffers and application performance
How deep is your buffer – Demystifying buffers and application performance
Cumulus Networks
 
RPM Junos-service
RPM Junos-serviceRPM Junos-service
RPM Junos-service
KHNOG
 
Precision Time Protocol
Precision Time ProtocolPrecision Time Protocol
Precision Time Protocol
Steven Kreuzer
 
DHCP Snooping
DHCP SnoopingDHCP Snooping
DHCP Snooping
NetProtocol Xpert
 
Remote VPN
Remote VPNRemote VPN
Remote VPN
Netwax Lab
 
OTV Configuration
OTV ConfigurationOTV Configuration
OTV Configuration
NetProtocol Xpert
 
introduction of iptables in linux
introduction of iptables in linuxintroduction of iptables in linux
introduction of iptables in linux
Nouman Baloch
 
TCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and SwitchesTCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and Switches
NetProtocol Xpert
 
PSKmail presentation @ Garec 2013 conference
PSKmail presentation @ Garec 2013 conferencePSKmail presentation @ Garec 2013 conference
PSKmail presentation @ Garec 2013 conference
Rein Couperus
 
BSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control Networks
BSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control NetworksBSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control Networks
BSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control Networks
BSidesROC
 
RAZORPOINT TCP/UDP PORTS LIST
RAZORPOINT TCP/UDP PORTS LISTRAZORPOINT TCP/UDP PORTS LIST
RAZORPOINT TCP/UDP PORTS LIST
Razorpoint Security
 
Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)
Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)
Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)
Netwax Lab
 
UDP Hunter
UDP HunterUDP Hunter
UDP Hunter
OWASP Delhi
 
2900 3500-5400-6200-8200-i pv6-jan08-2-intro
2900 3500-5400-6200-8200-i pv6-jan08-2-intro2900 3500-5400-6200-8200-i pv6-jan08-2-intro
2900 3500-5400-6200-8200-i pv6-jan08-2-intro
Stoyan Stoyanov
 
Cisco discovery drs ent module 3 - v.4 in english.
Cisco discovery   drs ent module 3 - v.4 in english.Cisco discovery   drs ent module 3 - v.4 in english.
Cisco discovery drs ent module 3 - v.4 in english.
igede tirtanata
 
Iptables presentation
Iptables presentationIptables presentation
Iptables presentation
Emin Abdul Azeez
 

What's hot (17)

IP Source Guard
IP Source Guard IP Source Guard
IP Source Guard
 
How deep is your buffer – Demystifying buffers and application performance
How deep is your buffer – Demystifying buffers and application performanceHow deep is your buffer – Demystifying buffers and application performance
How deep is your buffer – Demystifying buffers and application performance
 
RPM Junos-service
RPM Junos-serviceRPM Junos-service
RPM Junos-service
 
Precision Time Protocol
Precision Time ProtocolPrecision Time Protocol
Precision Time Protocol
 
DHCP Snooping
DHCP SnoopingDHCP Snooping
DHCP Snooping
 
Remote VPN
Remote VPNRemote VPN
Remote VPN
 
OTV Configuration
OTV ConfigurationOTV Configuration
OTV Configuration
 
introduction of iptables in linux
introduction of iptables in linuxintroduction of iptables in linux
introduction of iptables in linux
 
TCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and SwitchesTCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and Switches
 
PSKmail presentation @ Garec 2013 conference
PSKmail presentation @ Garec 2013 conferencePSKmail presentation @ Garec 2013 conference
PSKmail presentation @ Garec 2013 conference
 
BSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control Networks
BSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control NetworksBSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control Networks
BSidesROC 2016 - Nick Piazza - Fault Tolerant Command and Control Networks
 
RAZORPOINT TCP/UDP PORTS LIST
RAZORPOINT TCP/UDP PORTS LISTRAZORPOINT TCP/UDP PORTS LIST
RAZORPOINT TCP/UDP PORTS LIST
 
Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)
Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)
Eincop Netwax Lab: HSRP (Hot Standby Router Protocol)
 
UDP Hunter
UDP HunterUDP Hunter
UDP Hunter
 
2900 3500-5400-6200-8200-i pv6-jan08-2-intro
2900 3500-5400-6200-8200-i pv6-jan08-2-intro2900 3500-5400-6200-8200-i pv6-jan08-2-intro
2900 3500-5400-6200-8200-i pv6-jan08-2-intro
 
Cisco discovery drs ent module 3 - v.4 in english.
Cisco discovery   drs ent module 3 - v.4 in english.Cisco discovery   drs ent module 3 - v.4 in english.
Cisco discovery drs ent module 3 - v.4 in english.
 
Iptables presentation
Iptables presentationIptables presentation
Iptables presentation
 

Similar to Rip 2 docoments version 1.1 by deepak kumar

In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network security
Thanawan Tuamyim
 
project on OSPF
project on OSPFproject on OSPF
project on OSPF
Om Prakash
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
Salachudin Emir
 
Ripe71 FastNetMon open source DoS / DDoS mitigation
Ripe71 FastNetMon open source DoS / DDoS mitigationRipe71 FastNetMon open source DoS / DDoS mitigation
Ripe71 FastNetMon open source DoS / DDoS mitigation
Pavel Odintsov
 
Aceleracion TCP Mikrotik.pdf
Aceleracion TCP Mikrotik.pdfAceleracion TCP Mikrotik.pdf
Aceleracion TCP Mikrotik.pdf
WifiCren
 
Picobgp - A simple deamon for routing advertising
Picobgp - A simple deamon for routing advertisingPicobgp - A simple deamon for routing advertising
Picobgp - A simple deamon for routing advertising
Claudio Mignanti
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)
Netwax Lab
 
ccna networking ppt
ccna networking pptccna networking ppt
ccna networking ppt
Er. Anmol Bhagat
 
RIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme NetworksRIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme Networks
Dani Royman Simanjuntak
 
RIP Overview
RIP OverviewRIP Overview
RIP Overview
NetProtocol Xpert
 
Telnet configuration
Telnet configurationTelnet configuration
Telnet configuration
MdAlAmin187
 
Rfc1723
Rfc1723Rfc1723
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
arjuntrk
 
Quick Guide Ip Routing
Quick Guide   Ip RoutingQuick Guide   Ip Routing
Quick Guide Ip Routing
CCNAResources
 
Ducat
DucatDucat
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
Lakshan Perera
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
Lakshan Perera
 
Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013
Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013
Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013
Đồng Quốc Vương
 
Chapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdfChapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdf
Buntha Chhay
 
2.5.1.2 packet tracer configure cisco routers for syslog, ntp, and ssh oper...
2.5.1.2 packet tracer   configure cisco routers for syslog, ntp, and ssh oper...2.5.1.2 packet tracer   configure cisco routers for syslog, ntp, and ssh oper...
2.5.1.2 packet tracer configure cisco routers for syslog, ntp, and ssh oper...
Salem Trabelsi
 

Similar to Rip 2 docoments version 1.1 by deepak kumar (20)

In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network security
 
project on OSPF
project on OSPFproject on OSPF
project on OSPF
 
CCNA Lab Guide
CCNA Lab GuideCCNA Lab Guide
CCNA Lab Guide
 
Ripe71 FastNetMon open source DoS / DDoS mitigation
Ripe71 FastNetMon open source DoS / DDoS mitigationRipe71 FastNetMon open source DoS / DDoS mitigation
Ripe71 FastNetMon open source DoS / DDoS mitigation
 
Aceleracion TCP Mikrotik.pdf
Aceleracion TCP Mikrotik.pdfAceleracion TCP Mikrotik.pdf
Aceleracion TCP Mikrotik.pdf
 
Picobgp - A simple deamon for routing advertising
Picobgp - A simple deamon for routing advertisingPicobgp - A simple deamon for routing advertising
Picobgp - A simple deamon for routing advertising
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)
 
ccna networking ppt
ccna networking pptccna networking ppt
ccna networking ppt
 
RIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme NetworksRIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme Networks
 
RIP Overview
RIP OverviewRIP Overview
RIP Overview
 
Telnet configuration
Telnet configurationTelnet configuration
Telnet configuration
 
Rfc1723
Rfc1723Rfc1723
Rfc1723
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
Quick Guide Ip Routing
Quick Guide   Ip RoutingQuick Guide   Ip Routing
Quick Guide Ip Routing
 
Ducat
DucatDucat
Ducat
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013
Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013
Www ccnav5 net_ccna_3_v5_0_scaling_networks_final_exam_2013
 
Chapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdfChapter 2-IP Routing.pdf
Chapter 2-IP Routing.pdf
 
2.5.1.2 packet tracer configure cisco routers for syslog, ntp, and ssh oper...
2.5.1.2 packet tracer   configure cisco routers for syslog, ntp, and ssh oper...2.5.1.2 packet tracer   configure cisco routers for syslog, ntp, and ssh oper...
2.5.1.2 packet tracer configure cisco routers for syslog, ntp, and ssh oper...
 

Recently uploaded

Cosa hanno in comune un mattoncino Lego e la backdoor XZ?
Cosa hanno in comune un mattoncino Lego e la backdoor XZ?Cosa hanno in comune un mattoncino Lego e la backdoor XZ?
Cosa hanno in comune un mattoncino Lego e la backdoor XZ?
Speck&Tech
 
20240609 QFM020 Irresponsible AI Reading List May 2024
20240609 QFM020 Irresponsible AI Reading List May 202420240609 QFM020 Irresponsible AI Reading List May 2024
20240609 QFM020 Irresponsible AI Reading List May 2024
Matthew Sinclair
 
Securing your Kubernetes cluster_ a step-by-step guide to success !
Securing your Kubernetes cluster_ a step-by-step guide to success !Securing your Kubernetes cluster_ a step-by-step guide to success !
Securing your Kubernetes cluster_ a step-by-step guide to success !
KatiaHIMEUR1
 
Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...
Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...
Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...
James Anderson
 
Large Language Model (LLM) and it’s Geospatial Applications
Large Language Model (LLM) and it’s Geospatial ApplicationsLarge Language Model (LLM) and it’s Geospatial Applications
Large Language Model (LLM) and it’s Geospatial Applications
Rohit Gautam
 
GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...
GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...
GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...
Neo4j
 
PCI PIN Basics Webinar from the Controlcase Team
PCI PIN Basics Webinar from the Controlcase TeamPCI PIN Basics Webinar from the Controlcase Team
PCI PIN Basics Webinar from the Controlcase Team
ControlCase
 
A tale of scale & speed: How the US Navy is enabling software delivery from l...
A tale of scale & speed: How the US Navy is enabling software delivery from l...A tale of scale & speed: How the US Navy is enabling software delivery from l...
A tale of scale & speed: How the US Navy is enabling software delivery from l...
sonjaschweigert1
 
“I’m still / I’m still / Chaining from the Block”
“I’m still / I’m still / Chaining from the Block”“I’m still / I’m still / Chaining from the Block”
“I’m still / I’m still / Chaining from the Block”
Claudio Di Ciccio
 
How to use Firebase Data Connect For Flutter
How to use Firebase Data Connect For FlutterHow to use Firebase Data Connect For Flutter
How to use Firebase Data Connect For Flutter
Daiki Mogmet Ito
 
Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!
Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!
Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!
SOFTTECHHUB
 
Climate Impact of Software Testing at Nordic Testing Days
Climate Impact of Software Testing at Nordic Testing DaysClimate Impact of Software Testing at Nordic Testing Days
Climate Impact of Software Testing at Nordic Testing Days
Kari Kakkonen
 
20240605 QFM017 Machine Intelligence Reading List May 2024
20240605 QFM017 Machine Intelligence Reading List May 202420240605 QFM017 Machine Intelligence Reading List May 2024
20240605 QFM017 Machine Intelligence Reading List May 2024
Matthew Sinclair
 
Generative AI Deep Dive: Advancing from Proof of Concept to Production
Generative AI Deep Dive: Advancing from Proof of Concept to ProductionGenerative AI Deep Dive: Advancing from Proof of Concept to Production
Generative AI Deep Dive: Advancing from Proof of Concept to Production
Aggregage
 
Data structures and Algorithms in Python.pdf
Data structures and Algorithms in Python.pdfData structures and Algorithms in Python.pdf
Data structures and Algorithms in Python.pdf
TIPNGVN2
 
みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...
みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...
みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...
名前 です男
 
How to Get CNIC Information System with Paksim Ga.pptx
How to Get CNIC Information System with Paksim Ga.pptxHow to Get CNIC Information System with Paksim Ga.pptx
How to Get CNIC Information System with Paksim Ga.pptx
danishmna97
 
Uni Systems Copilot event_05062024_C.Vlachos.pdf
Uni Systems Copilot event_05062024_C.Vlachos.pdfUni Systems Copilot event_05062024_C.Vlachos.pdf
Uni Systems Copilot event_05062024_C.Vlachos.pdf
Uni Systems S.M.S.A.
 
Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...
Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...
Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...
SOFTTECHHUB
 
Communications Mining Series - Zero to Hero - Session 1
Communications Mining Series - Zero to Hero - Session 1Communications Mining Series - Zero to Hero - Session 1
Communications Mining Series - Zero to Hero - Session 1
DianaGray10
 

Recently uploaded (20)

Cosa hanno in comune un mattoncino Lego e la backdoor XZ?
Cosa hanno in comune un mattoncino Lego e la backdoor XZ?Cosa hanno in comune un mattoncino Lego e la backdoor XZ?
Cosa hanno in comune un mattoncino Lego e la backdoor XZ?
 
20240609 QFM020 Irresponsible AI Reading List May 2024
20240609 QFM020 Irresponsible AI Reading List May 202420240609 QFM020 Irresponsible AI Reading List May 2024
20240609 QFM020 Irresponsible AI Reading List May 2024
 
Securing your Kubernetes cluster_ a step-by-step guide to success !
Securing your Kubernetes cluster_ a step-by-step guide to success !Securing your Kubernetes cluster_ a step-by-step guide to success !
Securing your Kubernetes cluster_ a step-by-step guide to success !
 
Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...
Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...
Alt. GDG Cloud Southlake #33: Boule & Rebala: Effective AppSec in SDLC using ...
 
Large Language Model (LLM) and it’s Geospatial Applications
Large Language Model (LLM) and it’s Geospatial ApplicationsLarge Language Model (LLM) and it’s Geospatial Applications
Large Language Model (LLM) and it’s Geospatial Applications
 
GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...
GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...
GraphSummit Singapore | Graphing Success: Revolutionising Organisational Stru...
 
PCI PIN Basics Webinar from the Controlcase Team
PCI PIN Basics Webinar from the Controlcase TeamPCI PIN Basics Webinar from the Controlcase Team
PCI PIN Basics Webinar from the Controlcase Team
 
A tale of scale & speed: How the US Navy is enabling software delivery from l...
A tale of scale & speed: How the US Navy is enabling software delivery from l...A tale of scale & speed: How the US Navy is enabling software delivery from l...
A tale of scale & speed: How the US Navy is enabling software delivery from l...
 
“I’m still / I’m still / Chaining from the Block”
“I’m still / I’m still / Chaining from the Block”“I’m still / I’m still / Chaining from the Block”
“I’m still / I’m still / Chaining from the Block”
 
How to use Firebase Data Connect For Flutter
How to use Firebase Data Connect For FlutterHow to use Firebase Data Connect For Flutter
How to use Firebase Data Connect For Flutter
 
Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!
Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!
Goodbye Windows 11: Make Way for Nitrux Linux 3.5.0!
 
Climate Impact of Software Testing at Nordic Testing Days
Climate Impact of Software Testing at Nordic Testing DaysClimate Impact of Software Testing at Nordic Testing Days
Climate Impact of Software Testing at Nordic Testing Days
 
20240605 QFM017 Machine Intelligence Reading List May 2024
20240605 QFM017 Machine Intelligence Reading List May 202420240605 QFM017 Machine Intelligence Reading List May 2024
20240605 QFM017 Machine Intelligence Reading List May 2024
 
Generative AI Deep Dive: Advancing from Proof of Concept to Production
Generative AI Deep Dive: Advancing from Proof of Concept to ProductionGenerative AI Deep Dive: Advancing from Proof of Concept to Production
Generative AI Deep Dive: Advancing from Proof of Concept to Production
 
Data structures and Algorithms in Python.pdf
Data structures and Algorithms in Python.pdfData structures and Algorithms in Python.pdf
Data structures and Algorithms in Python.pdf
 
みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...
みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...
みなさんこんにちはこれ何文字まで入るの?40文字以下不可とか本当に意味わからないけどこれ限界文字数書いてないからマジでやばい文字数いけるんじゃないの?えこ...
 
How to Get CNIC Information System with Paksim Ga.pptx
How to Get CNIC Information System with Paksim Ga.pptxHow to Get CNIC Information System with Paksim Ga.pptx
How to Get CNIC Information System with Paksim Ga.pptx
 
Uni Systems Copilot event_05062024_C.Vlachos.pdf
Uni Systems Copilot event_05062024_C.Vlachos.pdfUni Systems Copilot event_05062024_C.Vlachos.pdf
Uni Systems Copilot event_05062024_C.Vlachos.pdf
 
Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...
Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...
Why You Should Replace Windows 11 with Nitrux Linux 3.5.0 for enhanced perfor...
 
Communications Mining Series - Zero to Hero - Session 1
Communications Mining Series - Zero to Hero - Session 1Communications Mining Series - Zero to Hero - Session 1
Communications Mining Series - Zero to Hero - Session 1
 

Rip 2 docoments version 1.1 by deepak kumar

  • 1. RIP (Routing Information Protocol). Document Version 1.1. Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330 Updated material may be found at http://www.deepuverma.in LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw Today we are covered about RIP Version 2 in real time configuration. Last time we covered about RIP Basic and RIP Version 1 in details configuration on Cisco Router. Here I am attached some basic again about RIP and RIP Version 2. Routing Information Protocol (RIP) is a standardized Distance Vector protocol (First true Distance Vector), and used on smaller networks. RIP uses the “Bellman-Ford” Distance Vector algorithm to determine the best “path” to a particular destination. The maximum number of hops allowed for RIP is 15. This hop limit, however, also limits the size of networks that RIP can support. A hop count of 16 is considered an infinite distance or poison route, in other words the route is considered unreachable. Some Specification of RIP Protocol: 1. AD (Administrator Distance) is 120. 2. RIP sends out periodic routing updates after every 30 seconds with full routing table. 3. RIP uses a form of distance (Hopcount) as it’s metric, maximum hopcount are 15 hops. 4. RIP uses the “Bellman-Ford Distance Vector algorithm”. 5. RIP Utilize UDP Port 520. 6. RIP Support IP and IPX Routing. 7. RIP has two Versions (RIP Version 1 and RIP Version 2). (For IPv6 is RIPng, it’s not a Version of RIP) RIP will load balance between those paths (default, up to 4) only if the metric (hopcount) is equal. RIP uses a round-robin system of load-balancing between equal metric routes, which can lead to pinhole congestion. Timers RIP uses the following timers as part of its operation: 1. Update Timer – Default 30 Seconds. 2. Invalid Timer - Default 180 Seconds, After expires Invalid timer the hop count of the routing entry will be set to 16, marking the destination as unreachable. 3. Flush Timer – Default 240 Seconds.
  • 2. RIP (Routing Information Protocol). Document Version 1.1. Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330 Updated material may be found at http://www.deepuverma.in LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw 4. Holddown Timer - Default is 180 Seconds (This is Cisco's implementation and can word on only Cisco Routers) Limitations The hop count cannot exceed 15, otherwise it will be considered invalid. Most RIP networks are flat. There is no concept of areas or boundaries in RIP networks. Variable Length Subnet Masks are not supported by RIP version 1. RIP has slow convergence and count to infinity problems. RIP Versions RIP has two versions, RIPv1 and RIPv2. RIP Version 1 (RIPv1): 1. RIPv1 is classful, and therefore does not include the subnet mask with its routing table updates. 2. RIPv1 does not support Variable Length Subnet Masks (VLSMs). 3. RIPv1 sends updates as broadcasts to address 255.255.255.255. 4. RIPv1 has maximum hopcount is 15 hops. 5. RIPv1 does not support authentication. 6. RIPv1 routers will send only Version 1 packets. 7. RIPv1 routers will receive both Version 1 and 2 updates. 8. Cisco Routers by default support RIPv1. RIP Version 2 (RIPv2): 1. RIPv2 is classless, and therefore does include the subnet mask with its routing table updates. 2. RIPv2 fully supports VLSMs. 3. Routing updates are sent via multicast, using address 224.0.0.9 4. Encrypted authentication can be configured between RIPv2 routers 5. Route tagging is supported. 6. RIPv2 routers will both send and receive only Version 2 updates 7. We can control the version of RIP a particular interface will “send” or “receive.” 8. RIPv2 is manually specified on, a Cisco will default to RIPv1 when configuring RIP. 9. User below mention command for change version on Cisco Routers Router(config)#router rip Router(config-router)#version 2
  • 3. RIP (Routing Information Protocol). Document Version 1.1. Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330 Updated material may be found at http://www.deepuverma.in LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw Configuration of RIPv2 As per image, take a network Diagram for testing RIPv1 Configuration. Let’s Check Router Configuration on R0:- interface FastEthernet0/0 ip address 192.168.10.1 255.255.255.0 duplex auto speed auto ! interface FastEthernet0/1 no ip address duplex auto
  • 4. RIP (Routing Information Protocol). Document Version 1.1. Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330 Updated material may be found at http://www.deepuverma.in LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw speed auto shutdown ! interface Serial0/0/0 ip address 192.168.2.1 255.255.255.252 ! interface Serial0/0/1 ip address 192.168.3.6 255.255.255.252 ! ! router rip version 2 network 192.168.2.0 network 192.168.3.0 network 192.168.10.0 no auto-summary ! Let’s Check Router Configuration on R1:- interface FastEthernet0/0 ip address 192.168.30.1 255.255.255.0 duplex auto speed auto ! interface FastEthernet0/1 ip address 192.168.20.1 255.255.255.0 duplex auto speed auto ! interface Serial0/0/0 ip address 192.168.2.2 255.255.255.252 clock rate 2000000 ! interface Serial0/0/1 ip address 192.168.3.5 255.255.255.252 clock rate 2000000
  • 5. RIP (Routing Information Protocol). Document Version 1.1. Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330 Updated material may be found at http://www.deepuverma.in LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw ! router rip version 2 network 192.168.2.0 network 192.168.3.0 network 192.168.20.0 network 192.168.30.0 no auto-summary ! Let’s Check Router Configuration on R2:- interface FastEthernet0/0 ip address 192.168.30.2 255.255.255.0 duplex auto speed auto ! interface FastEthernet0/1 ip address 192.168.40.1 255.255.255.0 duplex auto speed auto ! interface Serial0/0/0 no ip address clock rate 2000000 shutdown ! interface Serial0/0/1 no ip address clock rate 2000000 shutdown ! ! router rip version 2 network 192.168.30.0 network 192.168.40.0 no auto-summary
  • 6. RIP (Routing Information Protocol). Document Version 1.1. Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330 Updated material may be found at http://www.deepuverma.in LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw Project Success:- 1. Project Ping test pass 2. Project Ready to work on Live Network 3. Load Balancing is tested. Let’s Testing load Balancing: - (Tracert command from Laptop2 to Laptop0) PC>tracert 192.168.10.2 Tracing route to 192.168.10.2 over a maximum of 30 hops: 1 1 ms 0 ms 1 ms 192.168.40.1 2 1 ms 0 ms 0 ms 192.168.30.1 3 0 ms 2 ms 2 ms 192.168.3.6 4 20 ms 0 ms 1 ms 192.168.10.2 Trace complete. (Tracert command from Laptop1 to Laptop0) PC>tracert 192.168.10.2 Tracing route to 192.168.10.2 over a maximum of 30 hops: 1 0 ms 0 ms 1 ms 192.168.20.1 2 1 ms 0 ms 0 ms 192.168.2.1 3 31 ms 0 ms 0 ms 192.168.10.2 Trace complete. Test RIP Database on Routers R2#sho ip rip database 192.168.2.0/30 auto-summary 192.168.2.0/30 [1] via 192.168.30.1, 00:00:23, FastEthernet0/0 192.168.3.4/30 auto-summary 192.168.3.4/30
  • 7. RIP (Routing Information Protocol). Document Version 1.1. Deepak Kumar (deepuverma@outlook.com), Call: - +91 - 8875332931 / 9214012330 Updated material may be found at http://www.deepuverma.in LinkedIn: - https://in.linkedin.com/in/engdeepak Twitter: - https://twitter.com/Deepakkhw [1] via 192.168.30.1, 00:00:23, FastEthernet0/0 192.168.10.0/24 auto-summary 192.168.10.0/24 [2] via 192.168.30.1, 00:00:23, FastEthernet0/0 192.168.20.0/24 auto-summary 192.168.20.0/24 [1] via 192.168.30.1, 00:00:23, FastEthernet0/0 192.168.30.0/24 auto-summary 192.168.30.0/24 directly connected, FastEthernet0/0 192.168.40.0/24 auto-summary 192.168.40.0/24 directly connected, FastEthernet0/1 R2# R1#sho ip rip database 192.168.2.0/30 auto-summary 192.168.2.0/30 directly connected, Serial0/0/0 192.168.3.4/30 auto-summary 192.168.3.4/30 directly connected, Serial0/0/1 192.168.10.0/24 auto-summary 192.168.10.0/24 [1] via 192.168.2.1, 00:00:22, Serial0/0/0 [1] via 192.168.3.6, 00:00:22, Serial0/0/1 192.168.20.0/24 auto-summary 192.168.20.0/24 directly connected, FastEthernet0/1 192.168.30.0/24 auto-summary 192.168.30.0/24 directly connected, FastEthernet0/0 192.168.40.0/24 auto-summary 192.168.40.0/24 [1] via 192.168.30.2, 00:00:18, FastEthernet0/0 No auto-summary command forces the advertisement of two different subnets from different interfaces within the same network. -----------------------------End RIP Document Version 1.1 by Deepak Kumar ----------------------------------- Note: - RIP Troubleshooting Document will soon. Drop an email to get document in your inbox.