SlideShare a Scribd company logo
Networking
Submitted by-
Tarun Jaiswal
048
CSE (2K14)
Network
A network is a set of devices (often referred to as nodes)
connected by communication links. A node can be a
computer, printer, or any other device capable of sending
and/or receiving data generated by other nodes on the
network.
Types of Network
Local Area Network
 connects network devices over a
relatively short distance.
 Such as office building, school, or home.
Campus Area Network
 Collection of multiple LANs but smaller
than a MAN.
 Such as a university or local business
campus.
Types of Network Continued…
 used for data transmission amongst devices such
as computers, telephones, tablets and personal digital
assistants.
 can be used for communication amongst the personal
devices themselves (interpersonal communication).
Wide Area Network
 a geographically-dispersed collection
of LANs.
 The Internet is the largest WAN.
Personal Area Network
Types of Network Continued…
 A network spanning a physical
area larger than a LAN but smaller
than a WAN, such as a city.
 A MAN is typically owned and
operated by a single entity such
as a government body or large
corporation.
Metropolitan Area Network
Network Devices
an electronic device that amplifies the
signal it receives.
Hub
 Used to connect multiple network hosts.
 It sends data to all of its ports connected.
 Not so secure and safe.
 Slower and most congested.
Repeater
Network Devices Continued…
Bridge
 A bridge connects two subnetworks as
a part of the same network.
 Eg:- two different labs or two different
floors connected by a bridge
Switch
 Used to connect multiple network hosts.
 Intelligent than Hub.
 It filters data packets and then forwards it
to the valid destination port.
Network Devices Continued…
Router
 A router is a network device which is responsible for
routing traffic from one to another network.
 These two networks could be a private company
network to a public network.
Router Interfaces
Serial port
 This interface is used to connect with another router.
Ethernet port
 This interface is used to connect with switch or Hub.
Auxiliary port
 This interface is used to connect with modem or dongle.
Router Interfaces Continued…
Loopback Interface
 It is a logical and virtual.
 It is not a physical interface like Fast Ethernet interface
or Gigabit Ethernet interface.
 This interface is always up.
CISCO IOS
IOS (Internetwork Operating System) is a multitasking
operating system used on most Cisco routers and
switches. IOS has a command-line interface with the
predetermined number of multiple-word commands.
This operating system is used to configure routing,
switching, internetworking and other features supported
by a Cisco device.
IOS Command Modes
User EXEC mode commands
Privileged EXEC mode commands
Global configuration mode commands
Initially, a user logs into the User Exec mode. This is the mode with the
least number of commands like ping, enable, disable, etc.
This IOS mode is also called enable mode because We must enter
the enable command from a user EXEC mode, if We want to access this
mode. We can save a device configuration or reload a device in this
mode.
Global configuration mode commands are used to configure a device.
We can set a hostname, configure authentication, set an IP address for
an interface, etc.
Network Tools
Ping
 used for troubleshooting a network.
 invoked using a ping command.
 uses ICMP (Internet Control Message Protocol).
 works by sending an ICMP echo request message to the specified IP
address.
 If the computer with the destination IP address is reachable, it responds
with an ICMP echo reply message.
 usually outputs some other information about a network performance, e.g.
a round-trip time, a time to send an ICMP request packet and receive an
ICMP reply packet.
Dynamic Host Configuration Protocol ( DHCP )
 DHCP is a client/server protocol that automatically provides an IP address
and other related configuration information such as the subnet mask and
default gateway.
 The DHCP server maintains a pool of IP addresses because the IP
addresses are dynamic (leased) rather than static (permanently
assigned), addresses no longer in use are automatically returned to the
pool for reallocation.
 DHCP provide static and dynamic address allocation that can be manual
or automatic.
 In network, a DHCP server manages a pool of IP address as well as default
gateway.
Configuring Static Routing
Assigning IP to PC1
PC1> ip 10.10.10.1/24
10.10.10.3
PC1> save ip
exit
Assigning IP to Router R1’s Interface
R1#conf t
R1(config)#interface f0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address 20.20.20.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
Configuring RIP to Static Routing to R1
R1#conf t
R1(config)#ip route 20.20.20.0
255.255.255.0 10.10.10.3
R1(config)#exit
R1#write memory
20.20.20.0
Routing Information Protocol ( RIP )
one of the oldest distance vector routing protocols.
usually used in small networks.
simple to configure and maintain.
Two versions of the protocol exist: version 1 and version 2.
RIP version 2 is capable of advertising subnet masks and
uses multicast to send routing updates.
version 1 doesn’t advertises subnet masks and uses
broadcast for updates.
Configuring RIP
Assigning IP to PC1
PC1> ip 10.10.10.1/24
10.10.10.3
PC1> save ip
exit
Assigning IP to Router R1’s Interface
R1#conf t
R1(config)#interface f0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address 20.20.20.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
Configuring RIP to Router R1
R1#conf t
R1(config)#router rip
R1(config-router)#ver 2
R1(config-router)#network 10.10.10.0
R1(config-router)#network 20.20.20.0
R1(config)#exit
R1#write memory
Configuring EIGRPAssigning IP to Router R1’s Interface
R1#conf t
R1(config)#interface s5/0
R1(config-if)#ip address 10.10.10.1
255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface s5/1
R1(config-if)#ip address 20.20.20.1
255.255.255.0
R1(config-if)#no shut
R1(config-if)#exi
R1(config)#interface s5/2
R1(config-if)#ip address 20.20.20.1
255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface s5/3
R1(config-if)#ip address 40.40.40.1
255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
Configuring EIGRP to Router R1
R1#conf t
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 10.10.10.0
R1(config-router)#network 20.20.20.0
R1(config-router)#network 30.30.30.0
R1(config-router)#network 40.40.40.0
R1(config)#exit
R1#write memory
Configuring OSPF
Configuring OSPF to Router R1
R1#conf t
R1(config)#router ospf 1
R1(config-router)#network 10.10.10.0 area 0
R1(config-router)#network 20.20.20.0 area 1
R1(config-router)#network 40.40.40.0 area 1
R1(config)#exit
R1#write memory
Assigning IP to PC1
PC1> ip 10.10.10.1/24
10.10.10.3
PC1> save ip
exit
Assigning IP to Router R1’s
Interface
R1#conf t
R1(config)#interface f0/0
R1(config-if)#ip address
10.10.10.2 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#ip address
20.20.20.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface f1/
R1(config-if)#ip address
40.40.40.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
Configuring BGP
Assigning IP to PC1
PC1> ip 10.10.10.1/24
10.10.10.3
PC1> save ip
exit
Assigning IP to Router R1’s Interface
R1#conf t
R1(config)#interface f0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface f2/0
R1(config-if)#ip address 20.20.20.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
Configuring BGP Continued…
Configuring BGP to Router R1
R1#conf t
R1(config)#router bgp 1
R1(config-router)#neighbor
20.20.20.2 remote-as 2
R1(config-router)#network
10.10.10.0 mask
255.255.255.0
R1(config)#exit
R1#write memory
Configuring BGP to Router R2
R2#conf t
R2(config)#router bgp 2
R2(config-router)#neighbor
20.20.20.1 remote-as 1
R2(config-router)#network
30.30.30.0 mask
255.255.255.0
R2(config-router)#network
50.50.50.0 mask
255.255.255.0
R2(config)#exit
R2#write memory
Some Basic Commands
 show ip route
 show ip eigrp neighbors
 show ip ospf neighbors
 show ip
 show ip route ospf
Thank You…

More Related Content

What's hot

CCNA ppt
CCNA pptCCNA ppt
CCNA ppt
Sumant Garg
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructure
Prince Gautam
 
BASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLS
BASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLSBASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLS
BASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLS
amiteshg
 
Routing Protocols and Concepts - Chapter 1
Routing Protocols and Concepts - Chapter 1Routing Protocols and Concepts - Chapter 1
Routing Protocols and Concepts - Chapter 1CAVC
 
CCNA ALL IN ONE
CCNA ALL IN ONE CCNA ALL IN ONE
CCNA ALL IN ONE
Sripati Mahapatra
 
Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...
Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...
Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...
Vishal Sharma, Ph.D.
 
Advance hardware devices
Advance hardware devicesAdvance hardware devices
Advance hardware devices
Varinder Singh Walia
 
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
thesakshi12
 
versa router teletronics
versa router teletronicsversa router teletronics
versa router teletronics
guestd33e17a
 
summer training report on Computer network and Cisco packet tracer
summer training report on Computer network and Cisco packet tracer summer training report on Computer network and Cisco packet tracer
summer training report on Computer network and Cisco packet tracer
Dheeraj Giri
 
Router configuration
Router configurationRouter configuration
Router configuration
ChoyonBonik
 
Lecture 3 -_internet_infrastructure_updated_2011
Lecture 3 -_internet_infrastructure_updated_2011Lecture 3 -_internet_infrastructure_updated_2011
Lecture 3 -_internet_infrastructure_updated_2011
Serious_SamSoul
 
Ccna interview questions
Ccna interview questionsCcna interview questions
Ccna interview questionsSanjay Thakare
 
Chandan singh seminar report pdf.......router
Chandan singh seminar report pdf.......routerChandan singh seminar report pdf.......router
Chandan singh seminar report pdf.......router
Chandan Singh
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0
Saurav Pandey
 
Uccn1003 -may10_-_lect03b_-_intro_to_cisco_router
Uccn1003  -may10_-_lect03b_-_intro_to_cisco_routerUccn1003  -may10_-_lect03b_-_intro_to_cisco_router
Uccn1003 -may10_-_lect03b_-_intro_to_cisco_routerShu Shin
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
AIRTEL
 
Presentation on ccna
Presentation on ccnaPresentation on ccna
Presentation on ccna
HoneyKumar34
 
CCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTCCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPT
Nishant Goel
 

What's hot (20)

CCNA ppt
CCNA pptCCNA ppt
CCNA ppt
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructure
 
BASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLS
BASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLSBASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLS
BASIC OF ROUTERS,ROUTER IOS AND ROUTING PROTOCOLS
 
Routing Protocols and Concepts - Chapter 1
Routing Protocols and Concepts - Chapter 1Routing Protocols and Concepts - Chapter 1
Routing Protocols and Concepts - Chapter 1
 
CCNA ALL IN ONE
CCNA ALL IN ONE CCNA ALL IN ONE
CCNA ALL IN ONE
 
Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...
Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...
Internet Routing Protocols: Fundamental Concepts of Distance-Vector and Link-...
 
Advance hardware devices
Advance hardware devicesAdvance hardware devices
Advance hardware devices
 
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
6 weeks/months project training from CMC Faridabad - Ppt of ccna project from...
 
versa router teletronics
versa router teletronicsversa router teletronics
versa router teletronics
 
summer training report on Computer network and Cisco packet tracer
summer training report on Computer network and Cisco packet tracer summer training report on Computer network and Cisco packet tracer
summer training report on Computer network and Cisco packet tracer
 
Router configuration
Router configurationRouter configuration
Router configuration
 
Lecture 3 -_internet_infrastructure_updated_2011
Lecture 3 -_internet_infrastructure_updated_2011Lecture 3 -_internet_infrastructure_updated_2011
Lecture 3 -_internet_infrastructure_updated_2011
 
Ccna interview questions
Ccna interview questionsCcna interview questions
Ccna interview questions
 
Chandan singh seminar report pdf.......router
Chandan singh seminar report pdf.......routerChandan singh seminar report pdf.......router
Chandan singh seminar report pdf.......router
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0
 
Uccn1003 -may10_-_lect03b_-_intro_to_cisco_router
Uccn1003  -may10_-_lect03b_-_intro_to_cisco_routerUccn1003  -may10_-_lect03b_-_intro_to_cisco_router
Uccn1003 -may10_-_lect03b_-_intro_to_cisco_router
 
Chapter 6 - Networking
Chapter 6 - NetworkingChapter 6 - Networking
Chapter 6 - Networking
 
CCNA PPT
CCNA PPTCCNA PPT
CCNA PPT
 
Presentation on ccna
Presentation on ccnaPresentation on ccna
Presentation on ccna
 
CCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPTCCNA SUMMER TRAINNING PPT
CCNA SUMMER TRAINNING PPT
 

Similar to Networking

BASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALSBASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALS
Varinder Singh Walia
 
Basic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notesBasic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notesVamsi Krishna Kalavala
 
Computer networks - CBSE New Syllabus (083) Class - XII
Computer networks - CBSE  New Syllabus (083) Class - XIIComputer networks - CBSE  New Syllabus (083) Class - XII
Computer networks - CBSE New Syllabus (083) Class - XII
Deepak Singh
 
Understanding_Network_Devices.pptx
Understanding_Network_Devices.pptxUnderstanding_Network_Devices.pptx
Understanding_Network_Devices.pptx
meynard samson
 
Training Day Slides
Training Day SlidesTraining Day Slides
Training Day Slides
adam_merritt
 
Iap final
Iap finalIap final
Iap final
GLIM Digital
 
Mcse question
Mcse questionMcse question
Final isp
Final ispFinal isp
Final isp
honey32sharma
 
Ccnafile
CcnafileCcnafile
Ccnafile
Shefali Garg
 
PRE-FINAL.pdf
PRE-FINAL.pdfPRE-FINAL.pdf
PRE-FINAL.pdf
NoralieNicol
 
Network And Network Address Translation
Network And Network Address TranslationNetwork And Network Address Translation
Network And Network Address Translation
Erin Moore
 
CCNA
CCNACCNA
Networking
NetworkingNetworking
NetworkingRashmi
 
07 - TCP_IP and the DoD Model.ppt
07 - TCP_IP and the DoD Model.ppt07 - TCP_IP and the DoD Model.ppt
07 - TCP_IP and the DoD Model.ppt
ssuserf7cd2b
 
Network and security concepts
Network and security conceptsNetwork and security concepts
Network and security concepts
sonuagain
 
Basic Introduction to Technology (networking).pdf
Basic Introduction to Technology (networking).pdfBasic Introduction to Technology (networking).pdf
Basic Introduction to Technology (networking).pdf
tthind
 

Similar to Networking (20)

BASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALSBASIC TO ADVANCED NETWORKING TUTORIALS
BASIC TO ADVANCED NETWORKING TUTORIALS
 
Basic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notesBasic ccna interview questions and answers ~ sysnet notes
Basic ccna interview questions and answers ~ sysnet notes
 
Computer networks - CBSE New Syllabus (083) Class - XII
Computer networks - CBSE  New Syllabus (083) Class - XIIComputer networks - CBSE  New Syllabus (083) Class - XII
Computer networks - CBSE New Syllabus (083) Class - XII
 
class12_Networking2
class12_Networking2class12_Networking2
class12_Networking2
 
Understanding_Network_Devices.pptx
Understanding_Network_Devices.pptxUnderstanding_Network_Devices.pptx
Understanding_Network_Devices.pptx
 
Training Day Slides
Training Day SlidesTraining Day Slides
Training Day Slides
 
Iap final
Iap finalIap final
Iap final
 
Mcse question
Mcse questionMcse question
Mcse question
 
Final isp
Final ispFinal isp
Final isp
 
Ccnafile
CcnafileCcnafile
Ccnafile
 
Tcpip Intro
Tcpip IntroTcpip Intro
Tcpip Intro
 
PRE-FINAL.pdf
PRE-FINAL.pdfPRE-FINAL.pdf
PRE-FINAL.pdf
 
Network And Network Address Translation
Network And Network Address TranslationNetwork And Network Address Translation
Network And Network Address Translation
 
CCNA
CCNACCNA
CCNA
 
Networking
NetworkingNetworking
Networking
 
class30.ppt
class30.pptclass30.ppt
class30.ppt
 
07 - TCP_IP and the DoD Model.ppt
07 - TCP_IP and the DoD Model.ppt07 - TCP_IP and the DoD Model.ppt
07 - TCP_IP and the DoD Model.ppt
 
class28.ppt
class28.pptclass28.ppt
class28.ppt
 
Network and security concepts
Network and security conceptsNetwork and security concepts
Network and security concepts
 
Basic Introduction to Technology (networking).pdf
Basic Introduction to Technology (networking).pdfBasic Introduction to Technology (networking).pdf
Basic Introduction to Technology (networking).pdf
 

Recently uploaded

Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...
Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...
Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...
Jeffrey Haguewood
 
ODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User GroupODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User Group
CatarinaPereira64715
 
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Ramesh Iyer
 
DevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA ConnectDevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA Connect
Kari Kakkonen
 
How world-class product teams are winning in the AI era by CEO and Founder, P...
How world-class product teams are winning in the AI era by CEO and Founder, P...How world-class product teams are winning in the AI era by CEO and Founder, P...
How world-class product teams are winning in the AI era by CEO and Founder, P...
Product School
 
Epistemic Interaction - tuning interfaces to provide information for AI support
Epistemic Interaction - tuning interfaces to provide information for AI supportEpistemic Interaction - tuning interfaces to provide information for AI support
Epistemic Interaction - tuning interfaces to provide information for AI support
Alan Dix
 
When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...
Elena Simperl
 
Key Trends Shaping the Future of Infrastructure.pdf
Key Trends Shaping the Future of Infrastructure.pdfKey Trends Shaping the Future of Infrastructure.pdf
Key Trends Shaping the Future of Infrastructure.pdf
Cheryl Hung
 
Leading Change strategies and insights for effective change management pdf 1.pdf
Leading Change strategies and insights for effective change management pdf 1.pdfLeading Change strategies and insights for effective change management pdf 1.pdf
Leading Change strategies and insights for effective change management pdf 1.pdf
OnBoard
 
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Thierry Lestable
 
Neuro-symbolic is not enough, we need neuro-*semantic*
Neuro-symbolic is not enough, we need neuro-*semantic*Neuro-symbolic is not enough, we need neuro-*semantic*
Neuro-symbolic is not enough, we need neuro-*semantic*
Frank van Harmelen
 
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
DanBrown980551
 
PHP Frameworks: I want to break free (IPC Berlin 2024)
PHP Frameworks: I want to break free (IPC Berlin 2024)PHP Frameworks: I want to break free (IPC Berlin 2024)
PHP Frameworks: I want to break free (IPC Berlin 2024)
Ralf Eggert
 
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
UiPathCommunity
 
FIDO Alliance Osaka Seminar: Passkeys at Amazon.pdf
FIDO Alliance Osaka Seminar: Passkeys at Amazon.pdfFIDO Alliance Osaka Seminar: Passkeys at Amazon.pdf
FIDO Alliance Osaka Seminar: Passkeys at Amazon.pdf
FIDO Alliance
 
Knowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and backKnowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and back
Elena Simperl
 
Mission to Decommission: Importance of Decommissioning Products to Increase E...
Mission to Decommission: Importance of Decommissioning Products to Increase E...Mission to Decommission: Importance of Decommissioning Products to Increase E...
Mission to Decommission: Importance of Decommissioning Products to Increase E...
Product School
 
Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024
Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024
Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024
Tobias Schneck
 
The Future of Platform Engineering
The Future of Platform EngineeringThe Future of Platform Engineering
The Future of Platform Engineering
Jemma Hussein Allen
 
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMsTo Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
Paul Groth
 

Recently uploaded (20)

Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...
Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...
Slack (or Teams) Automation for Bonterra Impact Management (fka Social Soluti...
 
ODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User GroupODC, Data Fabric and Architecture User Group
ODC, Data Fabric and Architecture User Group
 
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
Builder.ai Founder Sachin Dev Duggal's Strategic Approach to Create an Innova...
 
DevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA ConnectDevOps and Testing slides at DASA Connect
DevOps and Testing slides at DASA Connect
 
How world-class product teams are winning in the AI era by CEO and Founder, P...
How world-class product teams are winning in the AI era by CEO and Founder, P...How world-class product teams are winning in the AI era by CEO and Founder, P...
How world-class product teams are winning in the AI era by CEO and Founder, P...
 
Epistemic Interaction - tuning interfaces to provide information for AI support
Epistemic Interaction - tuning interfaces to provide information for AI supportEpistemic Interaction - tuning interfaces to provide information for AI support
Epistemic Interaction - tuning interfaces to provide information for AI support
 
When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...When stars align: studies in data quality, knowledge graphs, and machine lear...
When stars align: studies in data quality, knowledge graphs, and machine lear...
 
Key Trends Shaping the Future of Infrastructure.pdf
Key Trends Shaping the Future of Infrastructure.pdfKey Trends Shaping the Future of Infrastructure.pdf
Key Trends Shaping the Future of Infrastructure.pdf
 
Leading Change strategies and insights for effective change management pdf 1.pdf
Leading Change strategies and insights for effective change management pdf 1.pdfLeading Change strategies and insights for effective change management pdf 1.pdf
Leading Change strategies and insights for effective change management pdf 1.pdf
 
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
Empowering NextGen Mobility via Large Action Model Infrastructure (LAMI): pav...
 
Neuro-symbolic is not enough, we need neuro-*semantic*
Neuro-symbolic is not enough, we need neuro-*semantic*Neuro-symbolic is not enough, we need neuro-*semantic*
Neuro-symbolic is not enough, we need neuro-*semantic*
 
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
LF Energy Webinar: Electrical Grid Modelling and Simulation Through PowSyBl -...
 
PHP Frameworks: I want to break free (IPC Berlin 2024)
PHP Frameworks: I want to break free (IPC Berlin 2024)PHP Frameworks: I want to break free (IPC Berlin 2024)
PHP Frameworks: I want to break free (IPC Berlin 2024)
 
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
Dev Dives: Train smarter, not harder – active learning and UiPath LLMs for do...
 
FIDO Alliance Osaka Seminar: Passkeys at Amazon.pdf
FIDO Alliance Osaka Seminar: Passkeys at Amazon.pdfFIDO Alliance Osaka Seminar: Passkeys at Amazon.pdf
FIDO Alliance Osaka Seminar: Passkeys at Amazon.pdf
 
Knowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and backKnowledge engineering: from people to machines and back
Knowledge engineering: from people to machines and back
 
Mission to Decommission: Importance of Decommissioning Products to Increase E...
Mission to Decommission: Importance of Decommissioning Products to Increase E...Mission to Decommission: Importance of Decommissioning Products to Increase E...
Mission to Decommission: Importance of Decommissioning Products to Increase E...
 
Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024
Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024
Kubernetes & AI - Beauty and the Beast !?! @KCD Istanbul 2024
 
The Future of Platform Engineering
The Future of Platform EngineeringThe Future of Platform Engineering
The Future of Platform Engineering
 
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMsTo Graph or Not to Graph Knowledge Graph Architectures and LLMs
To Graph or Not to Graph Knowledge Graph Architectures and LLMs
 

Networking

  • 2. Network A network is a set of devices (often referred to as nodes) connected by communication links. A node can be a computer, printer, or any other device capable of sending and/or receiving data generated by other nodes on the network.
  • 3. Types of Network Local Area Network  connects network devices over a relatively short distance.  Such as office building, school, or home. Campus Area Network  Collection of multiple LANs but smaller than a MAN.  Such as a university or local business campus.
  • 4. Types of Network Continued…  used for data transmission amongst devices such as computers, telephones, tablets and personal digital assistants.  can be used for communication amongst the personal devices themselves (interpersonal communication). Wide Area Network  a geographically-dispersed collection of LANs.  The Internet is the largest WAN. Personal Area Network
  • 5. Types of Network Continued…  A network spanning a physical area larger than a LAN but smaller than a WAN, such as a city.  A MAN is typically owned and operated by a single entity such as a government body or large corporation. Metropolitan Area Network
  • 6. Network Devices an electronic device that amplifies the signal it receives. Hub  Used to connect multiple network hosts.  It sends data to all of its ports connected.  Not so secure and safe.  Slower and most congested. Repeater
  • 7. Network Devices Continued… Bridge  A bridge connects two subnetworks as a part of the same network.  Eg:- two different labs or two different floors connected by a bridge Switch  Used to connect multiple network hosts.  Intelligent than Hub.  It filters data packets and then forwards it to the valid destination port.
  • 8. Network Devices Continued… Router  A router is a network device which is responsible for routing traffic from one to another network.  These two networks could be a private company network to a public network.
  • 9. Router Interfaces Serial port  This interface is used to connect with another router. Ethernet port  This interface is used to connect with switch or Hub. Auxiliary port  This interface is used to connect with modem or dongle.
  • 10. Router Interfaces Continued… Loopback Interface  It is a logical and virtual.  It is not a physical interface like Fast Ethernet interface or Gigabit Ethernet interface.  This interface is always up.
  • 11. CISCO IOS IOS (Internetwork Operating System) is a multitasking operating system used on most Cisco routers and switches. IOS has a command-line interface with the predetermined number of multiple-word commands. This operating system is used to configure routing, switching, internetworking and other features supported by a Cisco device.
  • 12. IOS Command Modes User EXEC mode commands Privileged EXEC mode commands Global configuration mode commands Initially, a user logs into the User Exec mode. This is the mode with the least number of commands like ping, enable, disable, etc. This IOS mode is also called enable mode because We must enter the enable command from a user EXEC mode, if We want to access this mode. We can save a device configuration or reload a device in this mode. Global configuration mode commands are used to configure a device. We can set a hostname, configure authentication, set an IP address for an interface, etc.
  • 13. Network Tools Ping  used for troubleshooting a network.  invoked using a ping command.  uses ICMP (Internet Control Message Protocol).  works by sending an ICMP echo request message to the specified IP address.  If the computer with the destination IP address is reachable, it responds with an ICMP echo reply message.  usually outputs some other information about a network performance, e.g. a round-trip time, a time to send an ICMP request packet and receive an ICMP reply packet.
  • 14. Dynamic Host Configuration Protocol ( DHCP )  DHCP is a client/server protocol that automatically provides an IP address and other related configuration information such as the subnet mask and default gateway.  The DHCP server maintains a pool of IP addresses because the IP addresses are dynamic (leased) rather than static (permanently assigned), addresses no longer in use are automatically returned to the pool for reallocation.  DHCP provide static and dynamic address allocation that can be manual or automatic.  In network, a DHCP server manages a pool of IP address as well as default gateway.
  • 15. Configuring Static Routing Assigning IP to PC1 PC1> ip 10.10.10.1/24 10.10.10.3 PC1> save ip exit Assigning IP to Router R1’s Interface R1#conf t R1(config)#interface f0/0 R1(config-if)#ip address 10.10.10.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface f0/1 R1(config-if)#ip address 20.20.20.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit Configuring RIP to Static Routing to R1 R1#conf t R1(config)#ip route 20.20.20.0 255.255.255.0 10.10.10.3 R1(config)#exit R1#write memory 20.20.20.0
  • 16. Routing Information Protocol ( RIP ) one of the oldest distance vector routing protocols. usually used in small networks. simple to configure and maintain. Two versions of the protocol exist: version 1 and version 2. RIP version 2 is capable of advertising subnet masks and uses multicast to send routing updates. version 1 doesn’t advertises subnet masks and uses broadcast for updates.
  • 17. Configuring RIP Assigning IP to PC1 PC1> ip 10.10.10.1/24 10.10.10.3 PC1> save ip exit Assigning IP to Router R1’s Interface R1#conf t R1(config)#interface f0/0 R1(config-if)#ip address 10.10.10.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface f0/1 R1(config-if)#ip address 20.20.20.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit Configuring RIP to Router R1 R1#conf t R1(config)#router rip R1(config-router)#ver 2 R1(config-router)#network 10.10.10.0 R1(config-router)#network 20.20.20.0 R1(config)#exit R1#write memory
  • 18. Configuring EIGRPAssigning IP to Router R1’s Interface R1#conf t R1(config)#interface s5/0 R1(config-if)#ip address 10.10.10.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface s5/1 R1(config-if)#ip address 20.20.20.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exi R1(config)#interface s5/2 R1(config-if)#ip address 20.20.20.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface s5/3 R1(config-if)#ip address 40.40.40.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit Configuring EIGRP to Router R1 R1#conf t R1(config)#router eigrp 1 R1(config-router)#no auto-summary R1(config-router)#network 10.10.10.0 R1(config-router)#network 20.20.20.0 R1(config-router)#network 30.30.30.0 R1(config-router)#network 40.40.40.0 R1(config)#exit R1#write memory
  • 19. Configuring OSPF Configuring OSPF to Router R1 R1#conf t R1(config)#router ospf 1 R1(config-router)#network 10.10.10.0 area 0 R1(config-router)#network 20.20.20.0 area 1 R1(config-router)#network 40.40.40.0 area 1 R1(config)#exit R1#write memory Assigning IP to PC1 PC1> ip 10.10.10.1/24 10.10.10.3 PC1> save ip exit Assigning IP to Router R1’s Interface R1#conf t R1(config)#interface f0/0 R1(config-if)#ip address 10.10.10.2 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface f0/1 R1(config-if)#ip address 20.20.20.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface f1/ R1(config-if)#ip address 40.40.40.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit
  • 20. Configuring BGP Assigning IP to PC1 PC1> ip 10.10.10.1/24 10.10.10.3 PC1> save ip exit Assigning IP to Router R1’s Interface R1#conf t R1(config)#interface f0/0 R1(config-if)#ip address 10.10.10.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit R1(config)#interface f2/0 R1(config-if)#ip address 20.20.20.1 255.255.255.0 R1(config-if)#no shut R1(config-if)#exit
  • 21. Configuring BGP Continued… Configuring BGP to Router R1 R1#conf t R1(config)#router bgp 1 R1(config-router)#neighbor 20.20.20.2 remote-as 2 R1(config-router)#network 10.10.10.0 mask 255.255.255.0 R1(config)#exit R1#write memory Configuring BGP to Router R2 R2#conf t R2(config)#router bgp 2 R2(config-router)#neighbor 20.20.20.1 remote-as 1 R2(config-router)#network 30.30.30.0 mask 255.255.255.0 R2(config-router)#network 50.50.50.0 mask 255.255.255.0 R2(config)#exit R2#write memory
  • 22. Some Basic Commands  show ip route  show ip eigrp neighbors  show ip ospf neighbors  show ip  show ip route ospf