SlideShare a Scribd company logo
1 of 10
LAB 4: Marking
Sơ đồ
Hình 1
Mô tả:
Bài thực hành này hướng dẫn Classification và Marking.
Đầu tiên Traffic sẽ được phân loại trên R1 và được đánh dấu (Marking) với những giá trị
DSCP tương ứng, sau đó tại R2 sẽ được phân loại trên những giá trị DSCP được Marking
trước đó.
Thực hiện:
Cấu hình ban đầu
Cấu hình R1:
R1#sh run
Building configuration...
Current configuration : 1509 bytes
!
version 12.2
!
hostname R1
!
ip subnet-zero
!
ip cef
!
interface Ethernet0/0
ip address 192.168.0.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.0
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.2
!
voice-port 1/1/0
!
voice-port 1/1/1
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 1 pots
destination-pattern 101
port 1/1/0
!
dial-peer voice 2 voip
destination-pattern 201
session target ipv4:192.168.2.2
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
!
end
Cấu hình R2:
R2#show run
Building configuration...
Current configuration : 1534 bytes
!
version 12.2
!
hostname R2
!
!
ip subnet-zero
!
ip host R3 192.168.2.2
ip host R1 192.168.1.1
!
!
interface Ethernet0/0
ip address 172.16.1.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 192.168.1.2 255.255.255.0
clockrate 2000000
no fair-queue
!
!
interface Serial0/1
ip address 192.168.2.1 255.255.255.0
!
no ip http server
ip classless
ip route 100.1.1.0 255.255.255.0 192.168.2.2
ip route 192.168.0.0 255.255.255.0 192.168.1.1
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
!
!
End
Cấu hình R3:
R3#show run
Building configuration...
Current configuration : 932 bytes
!
version 12.2
!
hostname R3
!
ip subnet-zero
!
!
interface Loopback0
ip address 100.1.1.1 255.255.255.0
!
!
interface Serial0/0
ip address 192.168.2.2 255.255.255.0
clockrate 2000000
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
destination-pattern 201
port 1/0/0
!
dial-peer voice 2 voip
destination-pattern 101
session target ipv4:192.168.1.1
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
!
!
end
Thực hiện
Trên R1:
Tạo ACL chọn lưu lượng:
access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo
access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo-reply
access-list 101 permit tcp any any eq telnet
access-list 102 permit tcp any any eq www
Tạo class-map:
class-map match-all TELNET
match access-group 101
class-map match-all PING
match access-group 100
class-map match-all HTTP
match access-group 102
class-map match-all VoIP
match ip rtp 16384 16383
Tạo policy-map:
policy-map TRAFFIC
class PING
set dscp af11 << đánh dấu lưu lượng tương ứng giá trị af11
class TELNET
set dscp af21 << đánh dấu lưu lượng tương ứng giá trị af21
class HTTP
set dscp af31 << đánh dấu lưu lượng tương ứng giá trị af31
class VoIP
set dscp ef << đánh dấu lưu lượng tương ứng giá trị ef
Áp dụng lên cổng:
interface Serial0/0
ip address 192.168.1.1 255.255.255.0
service-policy output TRAFFIC
Trên R2
Tạo ACL chọn lưu lượng
access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo
access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo-reply
access-list 101 permit tcp any any eq telnet
access-list 102 permit tcp any any eq www
Tạo class-map dùng ACL
class-map match-all TELNET
match dscp af21
class-map match-all PING
match dscp af11
class-map match-all HTTP
match dscp af31
class-map match-all VoIP
match dscp ef
Tạo Policy-map
policy-map TRAFFIC
class PING
class TELNET
class HTTP
class VoIP
Áp dụng lên cổng
interface Serial0/0
ip address 192.168.1.2 255.255.255.0
service-policy input TRAFFIC
clockrate 2000000
no fair-queue
Kiểm tra:
R1#sh policy-map
Policy Map TRAFFIC
Class PING
set dscp af11
Class TELNET
set dscp af21
Class HTTP
set dscp af31
Class VoIP
set dscp ef
R1#sh class-map
Class Map match-all TELNET (id 1)
Match access-group 101
Class Map match-all PING (id 2)
Match access-group 100
Class Map match-all HTTP (id 3)
Match access-group 102
Class Map match-all VoIP (id 4)
Match ip rtp 16384 16383
Class Map match-any class-default (id 0)
Match any
Tại thời điểm này chưa có Traffic liên quan được tạo ra nên số lượng gói so khớp và
được Marking là bằng 0
R1#sh policy-map interface s0/0
Serial0/0
Service-policy output: TRAFFIC
Class-map: PING (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 100
QoS Set
dscp af11
Packets marked 0
Class-map: TELNET (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 101
QoS Set
dscp af21
Packets marked 0
Class-map: HTTP (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 102
QoS Set
dscp af31
Packets marked 0
Class-map: VoIP (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip rtp 16384 16383
QoS Set
dscp ef
Packets marked 0
Class-map: class-default (match-any)
143 packets, 10947 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any
Tạo ra những Traffic liên quan, quan sát trong lênh Show ở đây nhận thấy số lượng gói
so khớp với mỗi lớp và gói được Marking.
R1#sh policy-map interface s0/0
Serial0/0
Service-policy output: TRAFFIC
Class-map: PING (match-all)
10 packets, 640 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 100
QoS Set
dscp af11
Packets marked 10
Class-map: TELNET (match-all)
25 packets, 1151 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 101
QoS Set
dscp af21
Packets marked 25
Class-map: HTTP (match-all)
61 packets, 4684 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: access-group 102
QoS Set
dscp af31
Packets marked 61
Class-map: VoIP (match-all)
370 packets, 23622 bytes
5 minute offered rate 2000 bps, drop rate 0 bps
Match: ip rtp 16384 16383
QoS Set
dscp ef
Packets marked 372
Class-map: class-default (match-any)
390 packets, 52662 bytes
5 minute offered rate 2000 bps, drop rate 0 bps
Match: any
R1#
Tại R2 thực hiện Classification với những giá trị được Marking trên R1
R2#sh class-map
Class Map match-all TELNET (id 2)
Match dscp af21
Class Map match-all PING (id 1)
Match dscp af11
Class Map match-all HTTP (id 3)
Match dscp af31
Class Map match-all VoIP (id 4)
Match dscp ef
Class Map match-any class-default (id 0)
Match any
R2#sh policy-map interface s0/0
Serial0/0
Service-policy input: TRAFFIC
Class-map: PING (match-all)
10 packets, 640 bytes
5 minute offered rate 0 bps
Match: dscp af11
Class-map: TELNET (match-all)
25 packets, 1151 bytes
5 minute offered rate 0 bps
Match: dscp af21
Class-map: HTTP (match-all)
86 packets, 7508 bytes
5 minute offered rate 0 bps
Match: dscp af31
Class-map: VoIP (match-all)
494 packets, 31529 bytes
5 minute offered rate 0 bps
Match: dscp ef
Class-map: class-default (match-any)
204 packets, 37027 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any

More Related Content

What's hot

Hacking With Nmap - Scanning Techniques
Hacking With Nmap - Scanning TechniquesHacking With Nmap - Scanning Techniques
Hacking With Nmap - Scanning Techniques
amiable_indian
 
The Next Linux Superpower: eBPF Primer
The Next Linux Superpower: eBPF PrimerThe Next Linux Superpower: eBPF Primer
The Next Linux Superpower: eBPF Primer
Sasha Goldshtein
 
Introduction to tcpdump
Introduction to tcpdumpIntroduction to tcpdump
Introduction to tcpdump
Lev Walkin
 
10 step-to-configure-cisco-call-manager-express
10 step-to-configure-cisco-call-manager-express10 step-to-configure-cisco-call-manager-express
10 step-to-configure-cisco-call-manager-express
Nguyen Thanh
 

What's hot (20)

Nxll10 v lan and trunking
Nxll10 v lan and trunkingNxll10 v lan and trunking
Nxll10 v lan and trunking
 
Network Mapper (NMAP)
Network Mapper (NMAP)Network Mapper (NMAP)
Network Mapper (NMAP)
 
Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...
Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...
Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...
 
Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...
Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...
Как HeadHunter удалось безопасно нарушить RFC 793 (TCP) и обойти сетевые лову...
 
Nmap5.cheatsheet.eng.v1
Nmap5.cheatsheet.eng.v1Nmap5.cheatsheet.eng.v1
Nmap5.cheatsheet.eng.v1
 
Nxll17 dynamic routing with asa
Nxll17 dynamic routing with asaNxll17 dynamic routing with asa
Nxll17 dynamic routing with asa
 
How to Leverage Go for Your Networking Needs
How to Leverage Go for Your Networking NeedsHow to Leverage Go for Your Networking Needs
How to Leverage Go for Your Networking Needs
 
Nmap scripting engine
Nmap scripting engineNmap scripting engine
Nmap scripting engine
 
Cho
ChoCho
Cho
 
Taller practico emu8086_galarraga
Taller practico emu8086_galarragaTaller practico emu8086_galarraga
Taller practico emu8086_galarraga
 
Nxll23 i pv6
Nxll23 i pv6Nxll23 i pv6
Nxll23 i pv6
 
Nxll19 vrrp (virtual router redundancy protocol)
Nxll19 vrrp (virtual router redundancy protocol)Nxll19 vrrp (virtual router redundancy protocol)
Nxll19 vrrp (virtual router redundancy protocol)
 
Hacking With Nmap - Scanning Techniques
Hacking With Nmap - Scanning TechniquesHacking With Nmap - Scanning Techniques
Hacking With Nmap - Scanning Techniques
 
Faster packet processing in Linux: XDP
Faster packet processing in Linux: XDPFaster packet processing in Linux: XDP
Faster packet processing in Linux: XDP
 
The Next Linux Superpower: eBPF Primer
The Next Linux Superpower: eBPF PrimerThe Next Linux Superpower: eBPF Primer
The Next Linux Superpower: eBPF Primer
 
Introduction to tcpdump
Introduction to tcpdumpIntroduction to tcpdump
Introduction to tcpdump
 
10 step-to-configure-cisco-call-manager-express
10 step-to-configure-cisco-call-manager-express10 step-to-configure-cisco-call-manager-express
10 step-to-configure-cisco-call-manager-express
 
Nmap tutorial
Nmap tutorialNmap tutorial
Nmap tutorial
 
Tcpdump
TcpdumpTcpdump
Tcpdump
 
04 18-2018--nmap port-80_blue_after_netcat
04 18-2018--nmap port-80_blue_after_netcat04 18-2018--nmap port-80_blue_after_netcat
04 18-2018--nmap port-80_blue_after_netcat
 

Viewers also liked (17)

ceh-lab_book_tieng_viet_phan1
ceh-lab_book_tieng_viet_phan1ceh-lab_book_tieng_viet_phan1
ceh-lab_book_tieng_viet_phan1
 
Chuong 1 tongquan
Chuong 1 tongquanChuong 1 tongquan
Chuong 1 tongquan
 
Gateway local
Gateway localGateway local
Gateway local
 
Chuyen mach trong wan2
Chuyen mach trong wan2Chuyen mach trong wan2
Chuyen mach trong wan2
 
Cấu hình rip cơ bản
Cấu hình rip cơ bảnCấu hình rip cơ bản
Cấu hình rip cơ bản
 
Chapter2
Chapter2Chapter2
Chapter2
 
Chapter3(CAC BIEN PHAP BAO DAM CHAT LUONG DICH VU
Chapter3(CAC BIEN PHAP BAO DAM CHAT LUONG DICH VUChapter3(CAC BIEN PHAP BAO DAM CHAT LUONG DICH VU
Chapter3(CAC BIEN PHAP BAO DAM CHAT LUONG DICH VU
 
Thực hiện cuộc gọi vo ip đơn giản
Thực hiện cuộc gọi vo ip đơn giảnThực hiện cuộc gọi vo ip đơn giản
Thực hiện cuộc gọi vo ip đơn giản
 
Tổng quan về vpn
Tổng quan về vpnTổng quan về vpn
Tổng quan về vpn
 
Ccip tổng quan mpls
Ccip tổng quan mplsCcip tổng quan mpls
Ccip tổng quan mpls
 
Lab 1 nbar – khám phá những lưu lượng chạy qua router
Lab 1  nbar – khám phá những lưu lượng chạy qua routerLab 1  nbar – khám phá những lưu lượng chạy qua router
Lab 1 nbar – khám phá những lưu lượng chạy qua router
 
Rtp
RtpRtp
Rtp
 
Gatekeeper
GatekeeperGatekeeper
Gatekeeper
 
Sự đóng gói cho quá trình vận chuyện gói thoạI
Sự đóng gói cho quá trình vận chuyện gói thoạISự đóng gói cho quá trình vận chuyện gói thoạI
Sự đóng gói cho quá trình vận chuyện gói thoạI
 
VPN
VPNVPN
VPN
 
Adsl lab
Adsl labAdsl lab
Adsl lab
 
Ipv6
Ipv6Ipv6
Ipv6
 

Similar to Lab 4 marking

Ccna voice study summary 460
Ccna voice study summary 460Ccna voice study summary 460
Ccna voice study summary 460
B Mach
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router
97148881557
 
Cisco data center support
Cisco data center supportCisco data center support
Cisco data center support
Krunal Shah
 

Similar to Lab 4 marking (20)

Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
Taking Security Groups to Ludicrous Speed with OVS (OpenStack Summit 2015)
 
הגדרת נתבי סיסקו 1.0
הגדרת נתבי סיסקו 1.0הגדרת נתבי סיסקו 1.0
הגדרת נתבי סיסקו 1.0
 
Lab 4 marking
Lab 4 markingLab 4 marking
Lab 4 marking
 
QoS In The Enterprise
QoS In The EnterpriseQoS In The Enterprise
QoS In The Enterprise
 
QoS marking on cisco IOS Router
QoS marking on cisco IOS RouterQoS marking on cisco IOS Router
QoS marking on cisco IOS Router
 
[오픈소스컨설팅] Linux Network Troubleshooting
[오픈소스컨설팅] Linux Network Troubleshooting[오픈소스컨설팅] Linux Network Troubleshooting
[오픈소스컨설팅] Linux Network Troubleshooting
 
Ccna voice study summary 460
Ccna voice study summary 460Ccna voice study summary 460
Ccna voice study summary 460
 
Linux Networking Explained
Linux Networking ExplainedLinux Networking Explained
Linux Networking Explained
 
Npppd: easy vpn with OpenBSD
Npppd: easy vpn with OpenBSDNpppd: easy vpn with OpenBSD
Npppd: easy vpn with OpenBSD
 
Topic 5 nx os management-ver 0.2
Topic 5 nx os management-ver 0.2Topic 5 nx os management-ver 0.2
Topic 5 nx os management-ver 0.2
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router
 
QoS Classification on Cisco IOS Router
QoS Classification on Cisco IOS RouterQoS Classification on Cisco IOS Router
QoS Classification on Cisco IOS Router
 
Mpls Qos Jayk
Mpls Qos JaykMpls Qos Jayk
Mpls Qos Jayk
 
How to convert your Linux box into Security Gateway - Part 1
How to convert your Linux box into Security Gateway - Part 1How to convert your Linux box into Security Gateway - Part 1
How to convert your Linux box into Security Gateway - Part 1
 
Cisco data center support
Cisco data center supportCisco data center support
Cisco data center support
 
TCP IP
TCP IP TCP IP
TCP IP
 
BACIK CISCO SKILLS
BACIK CISCO SKILLSBACIK CISCO SKILLS
BACIK CISCO SKILLS
 
Course on TCP Dynamic Performance
Course on TCP Dynamic PerformanceCourse on TCP Dynamic Performance
Course on TCP Dynamic Performance
 
Nxll18 vpn (s2 s gre & dmvpn)
Nxll18 vpn (s2 s gre & dmvpn)Nxll18 vpn (s2 s gre & dmvpn)
Nxll18 vpn (s2 s gre & dmvpn)
 
Linux Networking Commands
Linux Networking CommandsLinux Networking Commands
Linux Networking Commands
 

More from VNG

Chinh registry de vao win nhanh hon
Chinh registry de vao win nhanh honChinh registry de vao win nhanh hon
Chinh registry de vao win nhanh hon
VNG
 

More from VNG (20)

Configuring i pv6
Configuring i pv6Configuring i pv6
Configuring i pv6
 
Ipv6 trien khai
Ipv6 trien khaiIpv6 trien khai
Ipv6 trien khai
 
Cong nghe frame relay - chuong 4
Cong nghe frame relay - chuong 4Cong nghe frame relay - chuong 4
Cong nghe frame relay - chuong 4
 
Cong nghe frame relay - chuong 3
Cong nghe frame relay - chuong 3Cong nghe frame relay - chuong 3
Cong nghe frame relay - chuong 3
 
Cong nghe frame relay - chuong 2
Cong nghe frame relay - chuong 2Cong nghe frame relay - chuong 2
Cong nghe frame relay - chuong 2
 
Thiết lập i pv6 trên pc
Thiết lập i pv6 trên pcThiết lập i pv6 trên pc
Thiết lập i pv6 trên pc
 
Hoạt động chuyển giao i pv6 trên toàn cầu
Hoạt động chuyển giao i pv6 trên toàn cầuHoạt động chuyển giao i pv6 trên toàn cầu
Hoạt động chuyển giao i pv6 trên toàn cầu
 
Cấu hình osp fv3 cơ bản
Cấu hình osp fv3 cơ bảnCấu hình osp fv3 cơ bản
Cấu hình osp fv3 cơ bản
 
Cấu trúc mở rộng của internet
Cấu trúc mở rộng của internetCấu trúc mở rộng của internet
Cấu trúc mở rộng của internet
 
QOs
QOsQOs
QOs
 
Chapter4
Chapter4Chapter4
Chapter4
 
Chapter1(TONG QUAN VE VOIP)
Chapter1(TONG QUAN VE VOIP)Chapter1(TONG QUAN VE VOIP)
Chapter1(TONG QUAN VE VOIP)
 
Mega wan
Mega wanMega wan
Mega wan
 
Ccip tổng quan mpls
Ccip tổng quan mplsCcip tổng quan mpls
Ccip tổng quan mpls
 
Chinh registry de vao win nhanh hon
Chinh registry de vao win nhanh honChinh registry de vao win nhanh hon
Chinh registry de vao win nhanh hon
 
Disable usb
Disable usbDisable usb
Disable usb
 
Vo hieu hoa usb
Vo hieu hoa usbVo hieu hoa usb
Vo hieu hoa usb
 
Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...
Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...
Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...
 
Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...
Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...
Lab 7 cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 gatekeeper (...
 
Lab 3 phân loại dùng nbar
Lab 3 phân loại dùng nbarLab 3 phân loại dùng nbar
Lab 3 phân loại dùng nbar
 

Recently uploaded

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
ssuser89054b
 
AKTU Computer Networks notes --- Unit 3.pdf
AKTU Computer Networks notes ---  Unit 3.pdfAKTU Computer Networks notes ---  Unit 3.pdf
AKTU Computer Networks notes --- Unit 3.pdf
ankushspencer015
 

Recently uploaded (20)

ONLINE FOOD ORDER SYSTEM PROJECT REPORT.pdf
ONLINE FOOD ORDER SYSTEM PROJECT REPORT.pdfONLINE FOOD ORDER SYSTEM PROJECT REPORT.pdf
ONLINE FOOD ORDER SYSTEM PROJECT REPORT.pdf
 
UNIT - IV - Air Compressors and its Performance
UNIT - IV - Air Compressors and its PerformanceUNIT - IV - Air Compressors and its Performance
UNIT - IV - Air Compressors and its Performance
 
Navigating Complexity: The Role of Trusted Partners and VIAS3D in Dassault Sy...
Navigating Complexity: The Role of Trusted Partners and VIAS3D in Dassault Sy...Navigating Complexity: The Role of Trusted Partners and VIAS3D in Dassault Sy...
Navigating Complexity: The Role of Trusted Partners and VIAS3D in Dassault Sy...
 
University management System project report..pdf
University management System project report..pdfUniversity management System project report..pdf
University management System project report..pdf
 
Thermal Engineering Unit - I & II . ppt
Thermal Engineering  Unit - I & II . pptThermal Engineering  Unit - I & II . ppt
Thermal Engineering Unit - I & II . ppt
 
(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7
(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7
(INDIRA) Call Girl Aurangabad Call Now 8617697112 Aurangabad Escorts 24x7
 
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 
(INDIRA) Call Girl Meerut Call Now 8617697112 Meerut Escorts 24x7
(INDIRA) Call Girl Meerut Call Now 8617697112 Meerut Escorts 24x7(INDIRA) Call Girl Meerut Call Now 8617697112 Meerut Escorts 24x7
(INDIRA) Call Girl Meerut Call Now 8617697112 Meerut Escorts 24x7
 
chapter 5.pptx: drainage and irrigation engineering
chapter 5.pptx: drainage and irrigation engineeringchapter 5.pptx: drainage and irrigation engineering
chapter 5.pptx: drainage and irrigation engineering
 
Unit 2- Effective stress & Permeability.pdf
Unit 2- Effective stress & Permeability.pdfUnit 2- Effective stress & Permeability.pdf
Unit 2- Effective stress & Permeability.pdf
 
VIP Model Call Girls Kothrud ( Pune ) Call ON 8005736733 Starting From 5K to ...
VIP Model Call Girls Kothrud ( Pune ) Call ON 8005736733 Starting From 5K to ...VIP Model Call Girls Kothrud ( Pune ) Call ON 8005736733 Starting From 5K to ...
VIP Model Call Girls Kothrud ( Pune ) Call ON 8005736733 Starting From 5K to ...
 
CCS335 _ Neural Networks and Deep Learning Laboratory_Lab Complete Record
CCS335 _ Neural Networks and Deep Learning Laboratory_Lab Complete RecordCCS335 _ Neural Networks and Deep Learning Laboratory_Lab Complete Record
CCS335 _ Neural Networks and Deep Learning Laboratory_Lab Complete Record
 
Online banking management system project.pdf
Online banking management system project.pdfOnline banking management system project.pdf
Online banking management system project.pdf
 
AKTU Computer Networks notes --- Unit 3.pdf
AKTU Computer Networks notes ---  Unit 3.pdfAKTU Computer Networks notes ---  Unit 3.pdf
AKTU Computer Networks notes --- Unit 3.pdf
 
FEA Based Level 3 Assessment of Deformed Tanks with Fluid Induced Loads
FEA Based Level 3 Assessment of Deformed Tanks with Fluid Induced LoadsFEA Based Level 3 Assessment of Deformed Tanks with Fluid Induced Loads
FEA Based Level 3 Assessment of Deformed Tanks with Fluid Induced Loads
 
Call Girls Pimpri Chinchwad Call Me 7737669865 Budget Friendly No Advance Boo...
Call Girls Pimpri Chinchwad Call Me 7737669865 Budget Friendly No Advance Boo...Call Girls Pimpri Chinchwad Call Me 7737669865 Budget Friendly No Advance Boo...
Call Girls Pimpri Chinchwad Call Me 7737669865 Budget Friendly No Advance Boo...
 
Water Industry Process Automation & Control Monthly - April 2024
Water Industry Process Automation & Control Monthly - April 2024Water Industry Process Automation & Control Monthly - April 2024
Water Industry Process Automation & Control Monthly - April 2024
 
Generative AI or GenAI technology based PPT
Generative AI or GenAI technology based PPTGenerative AI or GenAI technology based PPT
Generative AI or GenAI technology based PPT
 
data_management_and _data_science_cheat_sheet.pdf
data_management_and _data_science_cheat_sheet.pdfdata_management_and _data_science_cheat_sheet.pdf
data_management_and _data_science_cheat_sheet.pdf
 
Call Girls Wakad Call Me 7737669865 Budget Friendly No Advance Booking
Call Girls Wakad Call Me 7737669865 Budget Friendly No Advance BookingCall Girls Wakad Call Me 7737669865 Budget Friendly No Advance Booking
Call Girls Wakad Call Me 7737669865 Budget Friendly No Advance Booking
 

Lab 4 marking

  • 1. LAB 4: Marking Sơ đồ Hình 1 Mô tả: Bài thực hành này hướng dẫn Classification và Marking. Đầu tiên Traffic sẽ được phân loại trên R1 và được đánh dấu (Marking) với những giá trị DSCP tương ứng, sau đó tại R2 sẽ được phân loại trên những giá trị DSCP được Marking trước đó. Thực hiện: Cấu hình ban đầu Cấu hình R1: R1#sh run Building configuration... Current configuration : 1509 bytes ! version 12.2 ! hostname R1 ! ip subnet-zero ! ip cef ! interface Ethernet0/0
  • 2. ip address 192.168.0.1 255.255.255.0 half-duplex ! interface Serial0/0 ip address 192.168.1.1 255.255.255.0 ! no ip http server ip classless ip route 0.0.0.0 0.0.0.0 192.168.1.2 ! voice-port 1/1/0 ! voice-port 1/1/1 ! mgcp profile default ! dial-peer cor custom ! dial-peer voice 1 pots destination-pattern 101 port 1/1/0 ! dial-peer voice 2 voip destination-pattern 201 session target ipv4:192.168.2.2 ! line con 0 line aux 0 line vty 0 4 privilege level 15 no login ! end Cấu hình R2: R2#show run Building configuration... Current configuration : 1534 bytes ! version 12.2 ! hostname R2 ! ! ip subnet-zero ! ip host R3 192.168.2.2 ip host R1 192.168.1.1 ! !
  • 3. interface Ethernet0/0 ip address 172.16.1.1 255.255.255.0 half-duplex ! interface Serial0/0 ip address 192.168.1.2 255.255.255.0 clockrate 2000000 no fair-queue ! ! interface Serial0/1 ip address 192.168.2.1 255.255.255.0 ! no ip http server ip classless ip route 100.1.1.0 255.255.255.0 192.168.2.2 ip route 192.168.0.0 255.255.255.0 192.168.1.1 ! ! line con 0 line aux 0 line vty 0 4 privilege level 15 no login ! ! End Cấu hình R3: R3#show run Building configuration... Current configuration : 932 bytes ! version 12.2 ! hostname R3 ! ip subnet-zero ! ! interface Loopback0 ip address 100.1.1.1 255.255.255.0 ! ! interface Serial0/0 ip address 192.168.2.2 255.255.255.0 clockrate 2000000 ! ip http server ip classless
  • 4. ip route 0.0.0.0 0.0.0.0 192.168.2.1 ! ! ! voice-port 1/0/0 ! voice-port 1/0/1 ! dial-peer voice 1 pots destination-pattern 201 port 1/0/0 ! dial-peer voice 2 voip destination-pattern 101 session target ipv4:192.168.1.1 ! line con 0 line aux 0 line vty 0 4 privilege level 15 no login ! ! end
  • 5. Thực hiện Trên R1: Tạo ACL chọn lưu lượng: access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo-reply access-list 101 permit tcp any any eq telnet access-list 102 permit tcp any any eq www Tạo class-map: class-map match-all TELNET match access-group 101 class-map match-all PING match access-group 100 class-map match-all HTTP match access-group 102 class-map match-all VoIP match ip rtp 16384 16383 Tạo policy-map: policy-map TRAFFIC class PING set dscp af11 << đánh dấu lưu lượng tương ứng giá trị af11 class TELNET set dscp af21 << đánh dấu lưu lượng tương ứng giá trị af21 class HTTP set dscp af31 << đánh dấu lưu lượng tương ứng giá trị af31 class VoIP set dscp ef << đánh dấu lưu lượng tương ứng giá trị ef Áp dụng lên cổng: interface Serial0/0 ip address 192.168.1.1 255.255.255.0 service-policy output TRAFFIC Trên R2 Tạo ACL chọn lưu lượng
  • 6. access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo access-list 100 permit icmp host 192.168.0.2 host 100.1.1.1 echo-reply access-list 101 permit tcp any any eq telnet access-list 102 permit tcp any any eq www Tạo class-map dùng ACL class-map match-all TELNET match dscp af21 class-map match-all PING match dscp af11 class-map match-all HTTP match dscp af31 class-map match-all VoIP match dscp ef Tạo Policy-map policy-map TRAFFIC class PING class TELNET class HTTP class VoIP Áp dụng lên cổng interface Serial0/0 ip address 192.168.1.2 255.255.255.0 service-policy input TRAFFIC clockrate 2000000 no fair-queue
  • 7. Kiểm tra: R1#sh policy-map Policy Map TRAFFIC Class PING set dscp af11 Class TELNET set dscp af21 Class HTTP set dscp af31 Class VoIP set dscp ef R1#sh class-map Class Map match-all TELNET (id 1) Match access-group 101 Class Map match-all PING (id 2) Match access-group 100 Class Map match-all HTTP (id 3) Match access-group 102 Class Map match-all VoIP (id 4) Match ip rtp 16384 16383 Class Map match-any class-default (id 0) Match any Tại thời điểm này chưa có Traffic liên quan được tạo ra nên số lượng gói so khớp và được Marking là bằng 0 R1#sh policy-map interface s0/0 Serial0/0 Service-policy output: TRAFFIC Class-map: PING (match-all) 0 packets, 0 bytes 5 minute offered rate 0 bps, drop rate 0 bps Match: access-group 100 QoS Set dscp af11 Packets marked 0 Class-map: TELNET (match-all) 0 packets, 0 bytes 5 minute offered rate 0 bps, drop rate 0 bps
  • 8. Match: access-group 101 QoS Set dscp af21 Packets marked 0 Class-map: HTTP (match-all) 0 packets, 0 bytes 5 minute offered rate 0 bps, drop rate 0 bps Match: access-group 102 QoS Set dscp af31 Packets marked 0 Class-map: VoIP (match-all) 0 packets, 0 bytes 5 minute offered rate 0 bps, drop rate 0 bps Match: ip rtp 16384 16383 QoS Set dscp ef Packets marked 0 Class-map: class-default (match-any) 143 packets, 10947 bytes 5 minute offered rate 1000 bps, drop rate 0 bps Match: any Tạo ra những Traffic liên quan, quan sát trong lênh Show ở đây nhận thấy số lượng gói so khớp với mỗi lớp và gói được Marking. R1#sh policy-map interface s0/0 Serial0/0 Service-policy output: TRAFFIC Class-map: PING (match-all) 10 packets, 640 bytes 5 minute offered rate 0 bps, drop rate 0 bps Match: access-group 100 QoS Set dscp af11 Packets marked 10 Class-map: TELNET (match-all) 25 packets, 1151 bytes 5 minute offered rate 0 bps, drop rate 0 bps Match: access-group 101 QoS Set dscp af21 Packets marked 25 Class-map: HTTP (match-all)
  • 9. 61 packets, 4684 bytes 5 minute offered rate 1000 bps, drop rate 0 bps Match: access-group 102 QoS Set dscp af31 Packets marked 61 Class-map: VoIP (match-all) 370 packets, 23622 bytes 5 minute offered rate 2000 bps, drop rate 0 bps Match: ip rtp 16384 16383 QoS Set dscp ef Packets marked 372 Class-map: class-default (match-any) 390 packets, 52662 bytes 5 minute offered rate 2000 bps, drop rate 0 bps Match: any R1# Tại R2 thực hiện Classification với những giá trị được Marking trên R1 R2#sh class-map Class Map match-all TELNET (id 2) Match dscp af21 Class Map match-all PING (id 1) Match dscp af11 Class Map match-all HTTP (id 3) Match dscp af31 Class Map match-all VoIP (id 4) Match dscp ef Class Map match-any class-default (id 0) Match any R2#sh policy-map interface s0/0 Serial0/0 Service-policy input: TRAFFIC Class-map: PING (match-all) 10 packets, 640 bytes 5 minute offered rate 0 bps Match: dscp af11 Class-map: TELNET (match-all) 25 packets, 1151 bytes
  • 10. 5 minute offered rate 0 bps Match: dscp af21 Class-map: HTTP (match-all) 86 packets, 7508 bytes 5 minute offered rate 0 bps Match: dscp af31 Class-map: VoIP (match-all) 494 packets, 31529 bytes 5 minute offered rate 0 bps Match: dscp ef Class-map: class-default (match-any) 204 packets, 37027 bytes 5 minute offered rate 1000 bps, drop rate 0 bps Match: any