SlideShare a Scribd company logo
packetlife.net
by Jeremy Stretch v2.1-r1
BGP · PART 1
Type
About BGP
eBGP AD
iBGP AD
Path Vector
20
200
Standard
Protocols
Transport
Authentication
RFC 4271
IP
TCP/179
MD5
Path Selection
Attribute
Weight Administrative preference
Description
1
Preference
Highest
Local Preference
Communicated between peers
within an AS
2 Highest
Self-originated Prefer paths originated locally3 True
AS Path Minimize AS hops4 Shortest
Origin
Prefer IGP-learned routes over
EGP, and EGP over unknown
5 IGP
MED Used externally to enter an AS6 Lowest
External Prefer eBGP routes over iBGP7 eBGP
IGP Cost Consider IGP metric8 Lowest
eBGP Peering Favor more stable routes9 Oldest
Router ID Tie breaker10 Lowest
Influencing Path Selection
Weight neighbor 172.16.0.1 weight 200
MED default-metric 400
Local Preference bgp default local-preference 100
Route Map neighbor 172.16.0.1 route-map Foo
Terminology
Autonomous System (AS)
A logical domain under the control of a
single entity
External BGP (eBGP)
BGP adjacencies which span autonomous
system boundaries
Internal BGP (iBGP)
BGP adjacencies formed within a single AS
Synchronization Requirement
A route must be known by an IGP before
it may be advertised to BGP peers
Packet Types
Open Update
Keepalive Notification
Neighbor States
Idle · Neighbor is not responding
Connect · TCP session established
Open Sent · Open message sent
Open Confirm · Response received
Established · Adjacency established
Troubleshooting
show ip bgp [summary]
show ip bgp neighbors
show ip route [bgp]
clear ip bgp * [soft]
debug ip bgp […]
Active · Attempting to connect
Well-known Mandatory · Must be supported and propagated
Well-known Discretionary · Must be supported; propagation optional
Optional Transitive · Marked as partial if unsupported by neighbor
Optional Nontransitive · Deleted if unsupported by neighbor
Attributes
Aggregator7 ID and AS of summarizing router
List of autonomous systems which the
advertisement has traversed
AS Path2
Atomic Aggregate6
Includes ASes which have been dropped
due to route aggregation
Originating cluster13 Cluster ID
Route tag8 Community
Metric for internal neighbors to reach
external destinations (default 100)
Local Preference5
Multiple Exit
Discriminator (MED)
4
Metric for external neighbors to reach the
local AS (default 0)
External peer in neighboring AS3 Next Hop
Origin type (IGP, EGP, or unknown)1 Origin
The originator of a reflected route9 Originator ID
Weight--
Cisco proprietary, not communicated to
peers (default 0)
Name Description
List of cluster IDs10 Cluster List
Ignore
AS Path
bgp bestpath as-path ignore
Ignore Cost
Communities
bgp bestpath cost-community ignore
packetlife.net
by Jeremy Stretch v2.1-r1
BGP · PART 2
Configuration Example
interface Serial1/0
description Backbone to B
ip address 172.16.0.1 255.255.255.252
!
interface Serial1/1
description Backbone to C
ip address 172.16.0.5 255.255.255.252
!
interface FastEthernet2/0
description LAN
ip address 192.168.1.1 255.255.255.0
!
router bgp 65100
no synchronization
network 172.16.0.0 mask 255.255.255.252
network 172.16.0.4 mask 255.255.255.252
network 192.168.1.0
neighbor South peer-group
neighbor South remote-as 65200
neighbor 172.16.0.2 peer-group South
neighbor 172.16.0.6 peer-group South
no auto-summary
10.0.0.0/30
172.16.0.0/30
172.16.0.4/30
AS 65100
AS 65200
F0/0 F0/0
A
B C
OSPF
F2/0 F2/0
S1/0S1/0
S1/0 S1/1
F2/0
interface FastEthernet0/0
description Backbone to B
ip address 10.0.0.2 255.255.255.252
!
interface Serial1/0
description Backbone to A
ip address 172.16.0.6 255.255.255.252
!
interface FastEthernet2/0
description LAN
ip address 192.168.3.1 255.255.255.0
!
router ospf 100
network 10.0.0.2 0.0.0.0 area 0
network 192.168.3.1 0.0.0.0 area 2
!
router bgp 65200
no synchronization
redistribute ospf 100 route-map LAN_Subnets
neighbor 10.0.0.1 remote-as 65200
neighbor 172.16.0.5 remote-as 65100
no auto-summary
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map LAN_Subnets permit 10
match ip address 10
set metric 100
interface FastEthernet0/0
description Backbone to C
ip address 10.0.0.1 255.255.255.252
!
interface Serial1/0
description Backbone to A
ip address 172.16.0.2 255.255.255.252
!
interface FastEthernet2/0
description LAN
ip address 192.168.2.1 255.255.255.0
!
router ospf 100
network 10.0.0.1 0.0.0.0 area 0
network 192.168.2.1 0.0.0.0 area 1
!
router bgp 65200
no synchronization
redistribute ospf 100 route-map LAN_Subnets
neighbor 10.0.0.2 remote-as 65200
neighbor 172.16.0.1 remote-as 65100
no auto-summary
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map LAN_Subnets permit 10
match ip address 10
set metric 100
Router A Routing Table Router B Routing Table
172.16.0.0/30 is subnetted, 2 subnets
C 172.16.0.4 is directly connected, S1/1
C 172.16.0.0 is directly connected, S1/0
C 192.168.1.0/24 is directly connected, F2/0
B 192.168.2.0/24 [20/100] via 172.16.0.2
B 192.168.3.0/24 [20/100] via 172.16.0.2
172.16.0.0/30 is subnetted, 2 subnets
B 172.16.0.4 [20/0] via 172.16.0.1
C 172.16.0.0 is directly connected, S1/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, F0/0
B 192.168.1.0/24 [20/0] via 172.16.0.1
C 192.168.2.0/24 is directly connected, F2/0
O IA 192.168.3.0/24 [110/2] via 10.0.0.2, F0/0
Router A
Router CRouter B

More Related Content

What's hot

L3 Vpn Diagnosing Common Problems
L3 Vpn Diagnosing Common ProblemsL3 Vpn Diagnosing Common Problems
L3 Vpn Diagnosing Common Problems
Amir Malik
 
Day 12 enabling ospf
Day 12 enabling ospfDay 12 enabling ospf
Day 12 enabling ospf
CYBERINTELLIGENTS
 
Per VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XRPer VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XR
Goerge Micheal Gerges
 
Bgp For Presentation
Bgp For PresentationBgp For Presentation
Bgp For Presentation
Alp isik
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGP
APNIC
 
07.bgp
07.bgp07.bgp
VRF Configuration
VRF ConfigurationVRF Configuration
VRF Configuration
Netwax Lab
 
IPV6 IPv6 Routing Lab By Rob Hamm
IPV6 IPv6 Routing Lab  By Rob HammIPV6 IPv6 Routing Lab  By Rob Hamm
IPV6 IPv6 Routing Lab By Rob Hamm
Information and Communications Technology Council
 
Bgp Toc
Bgp TocBgp Toc
Bgp Toc
bigb0206
 
Implementing Internet and MPLS BGP
Implementing Internet and MPLS BGPImplementing Internet and MPLS BGP
Implementing Internet and MPLS BGP
Private
 
Migrating from OSPF to IS-IS by Philip Smith
Migrating from OSPF to IS-IS by Philip SmithMigrating from OSPF to IS-IS by Philip Smith
Migrating from OSPF to IS-IS by Philip Smith
MyNOG
 
Cisco vs juniper
Cisco vs juniperCisco vs juniper
Cisco vs juniper
Elshaday Gelaye
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
robertoxe
 
Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011
Dân Chơi
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration
3Anetwork com
 
BGP Update Source
BGP Update Source BGP Update Source
BGP Update Source
NetProtocol Xpert
 
Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
Kishore Kumar
 
B G P Part2
B G P  Part2B G P  Part2
B G P Part2
cisconetworker
 

What's hot (18)

L3 Vpn Diagnosing Common Problems
L3 Vpn Diagnosing Common ProblemsL3 Vpn Diagnosing Common Problems
L3 Vpn Diagnosing Common Problems
 
Day 12 enabling ospf
Day 12 enabling ospfDay 12 enabling ospf
Day 12 enabling ospf
 
Per VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XRPer VRF tunnel Seclection IOS-XR
Per VRF tunnel Seclection IOS-XR
 
Bgp For Presentation
Bgp For PresentationBgp For Presentation
Bgp For Presentation
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGP
 
07.bgp
07.bgp07.bgp
07.bgp
 
VRF Configuration
VRF ConfigurationVRF Configuration
VRF Configuration
 
IPV6 IPv6 Routing Lab By Rob Hamm
IPV6 IPv6 Routing Lab  By Rob HammIPV6 IPv6 Routing Lab  By Rob Hamm
IPV6 IPv6 Routing Lab By Rob Hamm
 
Bgp Toc
Bgp TocBgp Toc
Bgp Toc
 
Implementing Internet and MPLS BGP
Implementing Internet and MPLS BGPImplementing Internet and MPLS BGP
Implementing Internet and MPLS BGP
 
Migrating from OSPF to IS-IS by Philip Smith
Migrating from OSPF to IS-IS by Philip SmithMigrating from OSPF to IS-IS by Philip Smith
Migrating from OSPF to IS-IS by Philip Smith
 
Cisco vs juniper
Cisco vs juniperCisco vs juniper
Cisco vs juniper
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration
 
BGP Update Source
BGP Update Source BGP Update Source
BGP Update Source
 
Dynamic routing OSPF 1
Dynamic routing OSPF 1Dynamic routing OSPF 1
Dynamic routing OSPF 1
 
B G P Part2
B G P  Part2B G P  Part2
B G P Part2
 

Similar to Bgp

Bgp
BgpBgp
Bgp
BgpBgp
Bgp
BgpBgp
Bgp
BgpBgp
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
ernestlithur
 
Bgp
BgpBgp
bgp.ppt
bgp.pptbgp.ppt
bgp.ppt
aozcan1
 
Ospf infografia
Ospf infografiaOspf infografia
Ospf infografia
w78ww
 
Bgp (1)
Bgp (1)Bgp (1)
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
Auguste Behe
 
T4 Handout3
T4 Handout3T4 Handout3
T4 Handout3
gobed
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
ernestlithur
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
robertoxe
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
Alejandro Marin
 
Eigrp
EigrpEigrp
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PROIDEA
 
B G P Part2
B G P  Part2B G P  Part2
B G P Part2
cisconetworker
 
BGP Overview
BGP OverviewBGP Overview
BGP Overview
Matt Bynum
 
Dynamische Routingprotokolle Aufzucht und Pflege - BGP
Dynamische Routingprotokolle Aufzucht und Pflege - BGPDynamische Routingprotokolle Aufzucht und Pflege - BGP
Dynamische Routingprotokolle Aufzucht und Pflege - BGP
Maximilan Wilhelm
 
Lec7
Lec7Lec7

Similar to Bgp (20)

Bgp
BgpBgp
Bgp
 
Bgp
BgpBgp
Bgp
 
Bgp
BgpBgp
Bgp
 
Bgp
BgpBgp
Bgp
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Bgp
BgpBgp
Bgp
 
bgp.ppt
bgp.pptbgp.ppt
bgp.ppt
 
Ospf infografia
Ospf infografiaOspf infografia
Ospf infografia
 
Bgp (1)
Bgp (1)Bgp (1)
Bgp (1)
 
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
 
T4 Handout3
T4 Handout3T4 Handout3
T4 Handout3
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
Chapter6ccna
Chapter6ccnaChapter6ccna
Chapter6ccna
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
 
Eigrp
EigrpEigrp
Eigrp
 
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
 
B G P Part2
B G P  Part2B G P  Part2
B G P Part2
 
BGP Overview
BGP OverviewBGP Overview
BGP Overview
 
Dynamische Routingprotokolle Aufzucht und Pflege - BGP
Dynamische Routingprotokolle Aufzucht und Pflege - BGPDynamische Routingprotokolle Aufzucht und Pflege - BGP
Dynamische Routingprotokolle Aufzucht und Pflege - BGP
 
Lec7
Lec7Lec7
Lec7
 

Recently uploaded

KubeCon & CloudNative Con 2024 Artificial Intelligent
KubeCon & CloudNative Con 2024 Artificial IntelligentKubeCon & CloudNative Con 2024 Artificial Intelligent
KubeCon & CloudNative Con 2024 Artificial Intelligent
Emre Gündoğdu
 
Bengaluru Dreamin' 24 - Personal Branding
Bengaluru Dreamin' 24 - Personal BrandingBengaluru Dreamin' 24 - Personal Branding
Bengaluru Dreamin' 24 - Personal Branding
Tarandeep Singh
 
cyber crime.pptx..........................
cyber crime.pptx..........................cyber crime.pptx..........................
cyber crime.pptx..........................
GNAMBIKARAO
 
HijackLoader Evolution: Interactive Process Hollowing
HijackLoader Evolution: Interactive Process HollowingHijackLoader Evolution: Interactive Process Hollowing
HijackLoader Evolution: Interactive Process Hollowing
Donato Onofri
 
一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理
一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理
一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理
dtagbe
 
Securing BGP: Operational Strategies and Best Practices for Network Defenders...
Securing BGP: Operational Strategies and Best Practices for Network Defenders...Securing BGP: Operational Strategies and Best Practices for Network Defenders...
Securing BGP: Operational Strategies and Best Practices for Network Defenders...
APNIC
 
How to make a complaint to the police for Social Media Fraud.pdf
How to make a complaint to the police for Social Media Fraud.pdfHow to make a complaint to the police for Social Media Fraud.pdf
How to make a complaint to the police for Social Media Fraud.pdf
Infosec train
 
快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样
快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样
快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样
3a0sd7z3
 
一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理
一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理
一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理
thezot
 
怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样
怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样
怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样
rtunex8r
 
快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样
快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样
快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样
3a0sd7z3
 
Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...
Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...
Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...
APNIC
 

Recently uploaded (12)

KubeCon & CloudNative Con 2024 Artificial Intelligent
KubeCon & CloudNative Con 2024 Artificial IntelligentKubeCon & CloudNative Con 2024 Artificial Intelligent
KubeCon & CloudNative Con 2024 Artificial Intelligent
 
Bengaluru Dreamin' 24 - Personal Branding
Bengaluru Dreamin' 24 - Personal BrandingBengaluru Dreamin' 24 - Personal Branding
Bengaluru Dreamin' 24 - Personal Branding
 
cyber crime.pptx..........................
cyber crime.pptx..........................cyber crime.pptx..........................
cyber crime.pptx..........................
 
HijackLoader Evolution: Interactive Process Hollowing
HijackLoader Evolution: Interactive Process HollowingHijackLoader Evolution: Interactive Process Hollowing
HijackLoader Evolution: Interactive Process Hollowing
 
一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理
一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理
一比一原版(uc毕业证书)加拿大卡尔加里大学毕业证如何办理
 
Securing BGP: Operational Strategies and Best Practices for Network Defenders...
Securing BGP: Operational Strategies and Best Practices for Network Defenders...Securing BGP: Operational Strategies and Best Practices for Network Defenders...
Securing BGP: Operational Strategies and Best Practices for Network Defenders...
 
How to make a complaint to the police for Social Media Fraud.pdf
How to make a complaint to the police for Social Media Fraud.pdfHow to make a complaint to the police for Social Media Fraud.pdf
How to make a complaint to the police for Social Media Fraud.pdf
 
快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样
快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样
快速办理(新加坡SMU毕业证书)新加坡管理大学毕业证文凭证书一模一样
 
一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理
一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理
一比一原版新西兰林肯大学毕业证(Lincoln毕业证书)学历如何办理
 
怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样
怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样
怎么办理(umiami毕业证书)美国迈阿密大学毕业证文凭证书实拍图原版一模一样
 
快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样
快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样
快速办理(Vic毕业证书)惠灵顿维多利亚大学毕业证完成信一模一样
 
Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...
Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...
Honeypots Unveiled: Proactive Defense Tactics for Cyber Security, Phoenix Sum...
 

Bgp

  • 1. packetlife.net by Jeremy Stretch v2.1-r1 BGP · PART 1 Type About BGP eBGP AD iBGP AD Path Vector 20 200 Standard Protocols Transport Authentication RFC 4271 IP TCP/179 MD5 Path Selection Attribute Weight Administrative preference Description 1 Preference Highest Local Preference Communicated between peers within an AS 2 Highest Self-originated Prefer paths originated locally3 True AS Path Minimize AS hops4 Shortest Origin Prefer IGP-learned routes over EGP, and EGP over unknown 5 IGP MED Used externally to enter an AS6 Lowest External Prefer eBGP routes over iBGP7 eBGP IGP Cost Consider IGP metric8 Lowest eBGP Peering Favor more stable routes9 Oldest Router ID Tie breaker10 Lowest Influencing Path Selection Weight neighbor 172.16.0.1 weight 200 MED default-metric 400 Local Preference bgp default local-preference 100 Route Map neighbor 172.16.0.1 route-map Foo Terminology Autonomous System (AS) A logical domain under the control of a single entity External BGP (eBGP) BGP adjacencies which span autonomous system boundaries Internal BGP (iBGP) BGP adjacencies formed within a single AS Synchronization Requirement A route must be known by an IGP before it may be advertised to BGP peers Packet Types Open Update Keepalive Notification Neighbor States Idle · Neighbor is not responding Connect · TCP session established Open Sent · Open message sent Open Confirm · Response received Established · Adjacency established Troubleshooting show ip bgp [summary] show ip bgp neighbors show ip route [bgp] clear ip bgp * [soft] debug ip bgp […] Active · Attempting to connect Well-known Mandatory · Must be supported and propagated Well-known Discretionary · Must be supported; propagation optional Optional Transitive · Marked as partial if unsupported by neighbor Optional Nontransitive · Deleted if unsupported by neighbor Attributes Aggregator7 ID and AS of summarizing router List of autonomous systems which the advertisement has traversed AS Path2 Atomic Aggregate6 Includes ASes which have been dropped due to route aggregation Originating cluster13 Cluster ID Route tag8 Community Metric for internal neighbors to reach external destinations (default 100) Local Preference5 Multiple Exit Discriminator (MED) 4 Metric for external neighbors to reach the local AS (default 0) External peer in neighboring AS3 Next Hop Origin type (IGP, EGP, or unknown)1 Origin The originator of a reflected route9 Originator ID Weight-- Cisco proprietary, not communicated to peers (default 0) Name Description List of cluster IDs10 Cluster List Ignore AS Path bgp bestpath as-path ignore Ignore Cost Communities bgp bestpath cost-community ignore
  • 2. packetlife.net by Jeremy Stretch v2.1-r1 BGP · PART 2 Configuration Example interface Serial1/0 description Backbone to B ip address 172.16.0.1 255.255.255.252 ! interface Serial1/1 description Backbone to C ip address 172.16.0.5 255.255.255.252 ! interface FastEthernet2/0 description LAN ip address 192.168.1.1 255.255.255.0 ! router bgp 65100 no synchronization network 172.16.0.0 mask 255.255.255.252 network 172.16.0.4 mask 255.255.255.252 network 192.168.1.0 neighbor South peer-group neighbor South remote-as 65200 neighbor 172.16.0.2 peer-group South neighbor 172.16.0.6 peer-group South no auto-summary 10.0.0.0/30 172.16.0.0/30 172.16.0.4/30 AS 65100 AS 65200 F0/0 F0/0 A B C OSPF F2/0 F2/0 S1/0S1/0 S1/0 S1/1 F2/0 interface FastEthernet0/0 description Backbone to B ip address 10.0.0.2 255.255.255.252 ! interface Serial1/0 description Backbone to A ip address 172.16.0.6 255.255.255.252 ! interface FastEthernet2/0 description LAN ip address 192.168.3.1 255.255.255.0 ! router ospf 100 network 10.0.0.2 0.0.0.0 area 0 network 192.168.3.1 0.0.0.0 area 2 ! router bgp 65200 no synchronization redistribute ospf 100 route-map LAN_Subnets neighbor 10.0.0.1 remote-as 65200 neighbor 172.16.0.5 remote-as 65100 no auto-summary ! access-list 10 permit 192.168.0.0 0.0.255.255 ! route-map LAN_Subnets permit 10 match ip address 10 set metric 100 interface FastEthernet0/0 description Backbone to C ip address 10.0.0.1 255.255.255.252 ! interface Serial1/0 description Backbone to A ip address 172.16.0.2 255.255.255.252 ! interface FastEthernet2/0 description LAN ip address 192.168.2.1 255.255.255.0 ! router ospf 100 network 10.0.0.1 0.0.0.0 area 0 network 192.168.2.1 0.0.0.0 area 1 ! router bgp 65200 no synchronization redistribute ospf 100 route-map LAN_Subnets neighbor 10.0.0.2 remote-as 65200 neighbor 172.16.0.1 remote-as 65100 no auto-summary ! access-list 10 permit 192.168.0.0 0.0.255.255 ! route-map LAN_Subnets permit 10 match ip address 10 set metric 100 Router A Routing Table Router B Routing Table 172.16.0.0/30 is subnetted, 2 subnets C 172.16.0.4 is directly connected, S1/1 C 172.16.0.0 is directly connected, S1/0 C 192.168.1.0/24 is directly connected, F2/0 B 192.168.2.0/24 [20/100] via 172.16.0.2 B 192.168.3.0/24 [20/100] via 172.16.0.2 172.16.0.0/30 is subnetted, 2 subnets B 172.16.0.4 [20/0] via 172.16.0.1 C 172.16.0.0 is directly connected, S1/0 10.0.0.0/30 is subnetted, 1 subnets C 10.0.0.0 is directly connected, F0/0 B 192.168.1.0/24 [20/0] via 172.16.0.1 C 192.168.2.0/24 is directly connected, F2/0 O IA 192.168.3.0/24 [110/2] via 10.0.0.2, F0/0 Router A Router CRouter B