SlideShare a Scribd company logo
1 of 2
BGP · PART 1                                                                                     packetlife.net
                              Attributes                                                 About BGP
       Name                   Description                                               Type Path Vector
Well-known Mandatory · Must be supported and propagated                            eBGP AD 20
  1 Origin                    Origin type (IGP, EGP, or unknown)                    iBGP AD 200
                              List of autonomous systems which the                 Standard RFC 4271
  2 AS Path
                              advertisement has traversed
                                                                                   Protocols IP
  3 Next Hop                  External peer in neighboring AS
                                                                                  Transport TCP/179
Well-known Discretionary · Must be supported; propagation optional
                                                                            Authentication MD5
                              Metric for internal neighbors to reach
  5 Local Preference
                              external destinations (default 100)                       Terminology
                              Includes ASes which have been dropped        Autonomous System (AS)
  6 Atomic Aggregate
                              due to route aggregation                     A logical domain under the control of a
Optional Transitive · Marked as partial if unsupported by neighbor         single entity

  7 Aggregator                ID and AS of summarizing router              External BGP (eBGP)
                                                                           BGP adjacencies which span autonomous
  8 Community                 Route tag                                    system boundaries
Optional Nontransitive · Deleted if unsupported by neighbor                Internal BGP (iBGP)
                                                                           BGP adjacencies formed within a single AS
       Multiple Exit       Metric for external neighbors to reach the
  4
       Discriminator (MED) local AS (default 0)                            Synchronization Requirement
                                                                           A route must be known by an IGP before
  9 Originator ID             The originator of a reflected route          it may be advertised to BGP peers
 10 Cluster List              List of cluster IDs
                                                                                        Packet Types
 13 Cluster ID                Originating cluster
                                                                                 Open                 Update
                              Cisco proprietary, not communicated to
  -- Weight
                              peers (default 0)                                Keepalive            Notification

                           Path Selection                                             Neighbor States
      Attribute         Description                           Preference   Idle · Neighbor is not responding
 1 Weight               Administrative preference             Highest      Active · Attempting to connect
                        Communicated between peers                         Connect · TCP session established
 2 Local Preference                                           Highest
                        within an AS
                                                                           Open Sent · Open message sent
 3 Self-originated      Prefer paths originated locally       True
                                                                           Open Confirm · Response received
 4 AS Path              Minimize AS hops                      Shortest
                                                                           Established · Adjacency established
                        Prefer IGP-learned routes over
 5 Origin                                                     IGP
                        EGP, and EGP over unknown                                     Troubleshooting
 6 MED                  Used externally to enter an AS        Lowest       show ip bgp [summary]
 7 External             Prefer eBGP routes over iBGP          eBGP         show ip bgp neighbors
 8 IGP Cost             Consider IGP metric                   Lowest       show ip route [bgp]
 9 eBGP Peering         Favor more stable routes              Oldest       clear ip bgp * [soft]
10 Router ID            Tie breaker                           Lowest       debug ip bgp […]

                                            Influencing Path Selection
 Weight neighbor 172.16.0.1 weight 200              Local Preference bgp default local-preference 100
      MED default-metric 400                                Route Map neighbor 172.16.0.1 route-map Foo
  Ignore                                                   Ignore Cost
         bgp bestpath as-path ignore                                   bgp bestpath cost-community ignore
 AS Path                                                  Communities

by Jeremy Stretch                                                                                            v2.1-r1
BGP · PART 2                                                                                            packetlife.net
                                                         Configuration Example

                                                                    interface Serial1/0                          Router A
                          AS 65100                                   description Backbone to B
                                                                     ip address 172.16.0.1 255.255.255.252
                                         F2/0                       !
                                A                                   interface Serial1/1
                        S1/0          S1/1                           description Backbone to C
                                                                     ip address 172.16.0.5 255.255.255.252
                                                                    !
                  172.16.0.0/30                                     interface FastEthernet2/0
                                    172.16.0.4/30                    description LAN
                                                                     ip address 192.168.1.1 255.255.255.0
                          AS 65200                                  !
          S1/0                                       S1/0           router bgp 65100
                        F0/0           F0/0                          no synchronization
                                                                     network 172.16.0.0 mask 255.255.255.252
                           10.0.0.0/30                               network 172.16.0.4 mask 255.255.255.252
            B                                        C
                                                                     network 192.168.1.0
                 F2/0                         F2/0                   neighbor South peer-group
                                                                     neighbor South remote-as 65200
                                                                     neighbor 172.16.0.2 peer-group South
                               OSPF                                  neighbor 172.16.0.6 peer-group South
                                                                     no auto-summary

interface FastEthernet0/0                    Router B               interface FastEthernet0/0                   Router C
 description Backbone to C                                           description Backbone to B
 ip address 10.0.0.1 255.255.255.252                                 ip address 10.0.0.2 255.255.255.252
!                                                                   !
interface Serial1/0                                                 interface Serial1/0
 description Backbone to A                                           description Backbone to A
 ip address 172.16.0.2 255.255.255.252                               ip address 172.16.0.6 255.255.255.252
!                                                                   !
interface FastEthernet2/0                                           interface FastEthernet2/0
 description LAN                                                     description LAN
 ip address 192.168.2.1 255.255.255.0                                ip address 192.168.3.1 255.255.255.0
!                                                                   !
router ospf 100                                                     router ospf 100
 network 10.0.0.1 0.0.0.0 area 0                                     network 10.0.0.2 0.0.0.0 area 0
 network 192.168.2.1 0.0.0.0 area 1                                  network 192.168.3.1 0.0.0.0 area 2
!                                                                   !
router bgp 65200                                                    router bgp 65200
 no synchronization                                                  no synchronization
 redistribute ospf 100 route-map LAN_Subnets                         redistribute ospf 100 route-map LAN_Subnets
 neighbor 10.0.0.2 remote-as 65200                                   neighbor 10.0.0.1 remote-as 65200
 neighbor 172.16.0.1 remote-as 65100                                 neighbor 172.16.0.5 remote-as 65100
 no auto-summary                                                     no auto-summary
!                                                                   !
access-list 10 permit 192.168.0.0 0.0.255.255                       access-list 10 permit 192.168.0.0 0.0.255.255
!                                                                   !
route-map LAN_Subnets permit 10                                     route-map LAN_Subnets permit 10
 match ip address 10                                                 match ip address 10
 set metric 100                                                      set metric 100

                Router A Routing Table                                             Router B Routing Table

     172.16.0.0/30 is subnetted, 2 subnets                                 172.16.0.0/30 is subnetted, 2 subnets
C       172.16.0.4 is directly connected, S1/1                      B         172.16.0.4 [20/0] via 172.16.0.1
C       172.16.0.0 is directly connected, S1/0                      C         172.16.0.0 is directly connected, S1/0
C    192.168.1.0/24 is directly connected, F2/0                            10.0.0.0/30 is subnetted, 1 subnets
B    192.168.2.0/24 [20/100] via 172.16.0.2                         C         10.0.0.0 is directly connected, F0/0
B    192.168.3.0/24 [20/100] via 172.16.0.2                         B      192.168.1.0/24 [20/0] via 172.16.0.1
                                                                    C      192.168.2.0/24 is directly connected, F2/0
                                                                    O   IA 192.168.3.0/24 [110/2] via 10.0.0.2, F0/0

by Jeremy Stretch                                                                                                v2.1-r1

More Related Content

What's hot

An Overview of Border Gateway Protocol (BGP)
An Overview of Border Gateway Protocol (BGP)An Overview of Border Gateway Protocol (BGP)
An Overview of Border Gateway Protocol (BGP)Jasim Alam
 
Mpls Presentation Ine
Mpls Presentation IneMpls Presentation Ine
Mpls Presentation IneAlp isik
 
IETF80 - IDR/GROW BGP Error Handling Requirements
IETF80 - IDR/GROW BGP Error Handling RequirementsIETF80 - IDR/GROW BGP Error Handling Requirements
IETF80 - IDR/GROW BGP Error Handling RequirementsRob Shakir
 
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 2611 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26legasu zemene
 
BGP (border gateway routing protocol)
BGP (border gateway routing protocol)BGP (border gateway routing protocol)
BGP (border gateway routing protocol)Netwax Lab
 
Bgp multihoming
Bgp multihomingBgp multihoming
Bgp multihomingee38sp
 
Drd700
Drd700Drd700
Drd700ciperi
 
08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24
08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 2408 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24
08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24legasu zemene
 
BGP Techniques for Network Operators
BGP Techniques for Network OperatorsBGP Techniques for Network Operators
BGP Techniques for Network OperatorsAPNIC
 

What's hot (17)

An Overview of Border Gateway Protocol (BGP)
An Overview of Border Gateway Protocol (BGP)An Overview of Border Gateway Protocol (BGP)
An Overview of Border Gateway Protocol (BGP)
 
1reigrp
1reigrp1reigrp
1reigrp
 
Mpls Presentation Ine
Mpls Presentation IneMpls Presentation Ine
Mpls Presentation Ine
 
Juniper Bgp
Juniper BgpJuniper Bgp
Juniper Bgp
 
Bgp (1)
Bgp (1)Bgp (1)
Bgp (1)
 
Inter as vpn option c
Inter as vpn option c Inter as vpn option c
Inter as vpn option c
 
IETF80 - IDR/GROW BGP Error Handling Requirements
IETF80 - IDR/GROW BGP Error Handling RequirementsIETF80 - IDR/GROW BGP Error Handling Requirements
IETF80 - IDR/GROW BGP Error Handling Requirements
 
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 2611 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
11 zxr10 b-en-bgp-mpls-vpn configuration-2-ppt-201105 26
 
BGP (border gateway routing protocol)
BGP (border gateway routing protocol)BGP (border gateway routing protocol)
BGP (border gateway routing protocol)
 
Bgp multihoming
Bgp multihomingBgp multihoming
Bgp multihoming
 
Inter-AS MPLS VPN Deployment
Inter-AS MPLS VPN DeploymentInter-AS MPLS VPN Deployment
Inter-AS MPLS VPN Deployment
 
Bgp
BgpBgp
Bgp
 
I pv6 autoconfig20c
I pv6 autoconfig20cI pv6 autoconfig20c
I pv6 autoconfig20c
 
Bgp
BgpBgp
Bgp
 
Drd700
Drd700Drd700
Drd700
 
08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24
08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 2408 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24
08 ip oc304 2_e1_1 zxr10 m6000 bgp configuration 24
 
BGP Techniques for Network Operators
BGP Techniques for Network OperatorsBGP Techniques for Network Operators
BGP Techniques for Network Operators
 

Similar to Bgp

Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issuesAuguste Behe
 
Bgp 1232073634451868-3
Bgp 1232073634451868-3Bgp 1232073634451868-3
Bgp 1232073634451868-3afzel
 
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...PROIDEA
 
Surviving The Stump The Chump Interview Questions
Surviving The Stump The Chump Interview QuestionsSurviving The Stump The Chump Interview Questions
Surviving The Stump The Chump Interview QuestionsDuane Bodle
 
bgp features presentation routing protocle
bgp features presentation routing protoclebgp features presentation routing protocle
bgp features presentation routing protocleBadr Belhajja
 
routing Protocols and Virtual private network
routing Protocols and Virtual private networkrouting Protocols and Virtual private network
routing Protocols and Virtual private networkhayenas
 
ISP Border Definition
ISP Border DefinitionISP Border Definition
ISP Border DefinitionQrator Labs
 
Cisco BGP Exam 642-661 Review Notes
Cisco BGP Exam 642-661 Review NotesCisco BGP Exam 642-661 Review Notes
Cisco BGP Exam 642-661 Review NotesDuane Bodle
 
Border Gateway Protocol (BGP)
Border Gateway Protocol (BGP)Border Gateway Protocol (BGP)
Border Gateway Protocol (BGP)Nutan Singh
 

Similar to Bgp (20)

Bgp
BgpBgp
Bgp
 
Bgp
BgpBgp
Bgp
 
Bgp
BgpBgp
Bgp
 
Ospf
OspfOspf
Ospf
 
Ospf
OspfOspf
Ospf
 
Bgp Toc
Bgp TocBgp Toc
Bgp Toc
 
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
 
07.bgp
07.bgp07.bgp
07.bgp
 
Eigrp
EigrpEigrp
Eigrp
 
Eigrp
EigrpEigrp
Eigrp
 
Bgp 1232073634451868-3
Bgp 1232073634451868-3Bgp 1232073634451868-3
Bgp 1232073634451868-3
 
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
PLNOG 6: Rafał Szarecki - Routing w Sieci - Praktyczne aspekty implementacji ...
 
Surviving The Stump The Chump Interview Questions
Surviving The Stump The Chump Interview QuestionsSurviving The Stump The Chump Interview Questions
Surviving The Stump The Chump Interview Questions
 
bgp features presentation routing protocle
bgp features presentation routing protoclebgp features presentation routing protocle
bgp features presentation routing protocle
 
routing Protocols and Virtual private network
routing Protocols and Virtual private networkrouting Protocols and Virtual private network
routing Protocols and Virtual private network
 
Bgp attribute-case study
Bgp attribute-case studyBgp attribute-case study
Bgp attribute-case study
 
ISP Border Definition
ISP Border DefinitionISP Border Definition
ISP Border Definition
 
BGP Overview
BGP OverviewBGP Overview
BGP Overview
 
Cisco BGP Exam 642-661 Review Notes
Cisco BGP Exam 642-661 Review NotesCisco BGP Exam 642-661 Review Notes
Cisco BGP Exam 642-661 Review Notes
 
Border Gateway Protocol (BGP)
Border Gateway Protocol (BGP)Border Gateway Protocol (BGP)
Border Gateway Protocol (BGP)
 

More from Mohamed Gamel (20)

Vyatta subnet range_cheat_sheet
Vyatta subnet range_cheat_sheetVyatta subnet range_cheat_sheet
Vyatta subnet range_cheat_sheet
 
Voip basics
Voip basicsVoip basics
Voip basics
 
Vla ns
Vla nsVla ns
Vla ns
 
Tcpdump
TcpdumpTcpdump
Tcpdump
 
Spanning tree
Spanning treeSpanning tree
Spanning tree
 
Scapy
ScapyScapy
Scapy
 
Rip
RipRip
Rip
 
Qo s
Qo sQo s
Qo s
 
Ppp
PppPpp
Ppp
 
Physical terminations
Physical terminationsPhysical terminations
Physical terminations
 
Nat
NatNat
Nat
 
Media wiki
Media wikiMedia wiki
Media wiki
 
Markdown
MarkdownMarkdown
Markdown
 
Is is
Is isIs is
Is is
 
I pv6
I pv6I pv6
I pv6
 
I pv4 subnetting
I pv4 subnettingI pv4 subnetting
I pv4 subnetting
 
I pv4 multicast
I pv4 multicastI pv4 multicast
I pv4 multicast
 
I psec
I psecI psec
I psec
 
Ios zone based-firewall
Ios zone based-firewallIos zone based-firewall
Ios zone based-firewall
 
Ios i pv4_access_lists
Ios i pv4_access_listsIos i pv4_access_lists
Ios i pv4_access_lists
 

Bgp

  • 1. BGP · PART 1 packetlife.net Attributes About BGP Name Description Type Path Vector Well-known Mandatory · Must be supported and propagated eBGP AD 20 1 Origin Origin type (IGP, EGP, or unknown) iBGP AD 200 List of autonomous systems which the Standard RFC 4271 2 AS Path advertisement has traversed Protocols IP 3 Next Hop External peer in neighboring AS Transport TCP/179 Well-known Discretionary · Must be supported; propagation optional Authentication MD5 Metric for internal neighbors to reach 5 Local Preference external destinations (default 100) Terminology Includes ASes which have been dropped Autonomous System (AS) 6 Atomic Aggregate due to route aggregation A logical domain under the control of a Optional Transitive · Marked as partial if unsupported by neighbor single entity 7 Aggregator ID and AS of summarizing router External BGP (eBGP) BGP adjacencies which span autonomous 8 Community Route tag system boundaries Optional Nontransitive · Deleted if unsupported by neighbor Internal BGP (iBGP) BGP adjacencies formed within a single AS Multiple Exit Metric for external neighbors to reach the 4 Discriminator (MED) local AS (default 0) Synchronization Requirement A route must be known by an IGP before 9 Originator ID The originator of a reflected route it may be advertised to BGP peers 10 Cluster List List of cluster IDs Packet Types 13 Cluster ID Originating cluster Open Update Cisco proprietary, not communicated to -- Weight peers (default 0) Keepalive Notification Path Selection Neighbor States Attribute Description Preference Idle · Neighbor is not responding 1 Weight Administrative preference Highest Active · Attempting to connect Communicated between peers Connect · TCP session established 2 Local Preference Highest within an AS Open Sent · Open message sent 3 Self-originated Prefer paths originated locally True Open Confirm · Response received 4 AS Path Minimize AS hops Shortest Established · Adjacency established Prefer IGP-learned routes over 5 Origin IGP EGP, and EGP over unknown Troubleshooting 6 MED Used externally to enter an AS Lowest show ip bgp [summary] 7 External Prefer eBGP routes over iBGP eBGP show ip bgp neighbors 8 IGP Cost Consider IGP metric Lowest show ip route [bgp] 9 eBGP Peering Favor more stable routes Oldest clear ip bgp * [soft] 10 Router ID Tie breaker Lowest debug ip bgp […] Influencing Path Selection Weight neighbor 172.16.0.1 weight 200 Local Preference bgp default local-preference 100 MED default-metric 400 Route Map neighbor 172.16.0.1 route-map Foo Ignore Ignore Cost bgp bestpath as-path ignore bgp bestpath cost-community ignore AS Path Communities by Jeremy Stretch v2.1-r1
  • 2. BGP · PART 2 packetlife.net Configuration Example interface Serial1/0 Router A AS 65100 description Backbone to B ip address 172.16.0.1 255.255.255.252 F2/0 ! A interface Serial1/1 S1/0 S1/1 description Backbone to C ip address 172.16.0.5 255.255.255.252 ! 172.16.0.0/30 interface FastEthernet2/0 172.16.0.4/30 description LAN ip address 192.168.1.1 255.255.255.0 AS 65200 ! S1/0 S1/0 router bgp 65100 F0/0 F0/0 no synchronization network 172.16.0.0 mask 255.255.255.252 10.0.0.0/30 network 172.16.0.4 mask 255.255.255.252 B C network 192.168.1.0 F2/0 F2/0 neighbor South peer-group neighbor South remote-as 65200 neighbor 172.16.0.2 peer-group South OSPF neighbor 172.16.0.6 peer-group South no auto-summary interface FastEthernet0/0 Router B interface FastEthernet0/0 Router C description Backbone to C description Backbone to B ip address 10.0.0.1 255.255.255.252 ip address 10.0.0.2 255.255.255.252 ! ! interface Serial1/0 interface Serial1/0 description Backbone to A description Backbone to A ip address 172.16.0.2 255.255.255.252 ip address 172.16.0.6 255.255.255.252 ! ! interface FastEthernet2/0 interface FastEthernet2/0 description LAN description LAN ip address 192.168.2.1 255.255.255.0 ip address 192.168.3.1 255.255.255.0 ! ! router ospf 100 router ospf 100 network 10.0.0.1 0.0.0.0 area 0 network 10.0.0.2 0.0.0.0 area 0 network 192.168.2.1 0.0.0.0 area 1 network 192.168.3.1 0.0.0.0 area 2 ! ! router bgp 65200 router bgp 65200 no synchronization no synchronization redistribute ospf 100 route-map LAN_Subnets redistribute ospf 100 route-map LAN_Subnets neighbor 10.0.0.2 remote-as 65200 neighbor 10.0.0.1 remote-as 65200 neighbor 172.16.0.1 remote-as 65100 neighbor 172.16.0.5 remote-as 65100 no auto-summary no auto-summary ! ! access-list 10 permit 192.168.0.0 0.0.255.255 access-list 10 permit 192.168.0.0 0.0.255.255 ! ! route-map LAN_Subnets permit 10 route-map LAN_Subnets permit 10 match ip address 10 match ip address 10 set metric 100 set metric 100 Router A Routing Table Router B Routing Table 172.16.0.0/30 is subnetted, 2 subnets 172.16.0.0/30 is subnetted, 2 subnets C 172.16.0.4 is directly connected, S1/1 B 172.16.0.4 [20/0] via 172.16.0.1 C 172.16.0.0 is directly connected, S1/0 C 172.16.0.0 is directly connected, S1/0 C 192.168.1.0/24 is directly connected, F2/0 10.0.0.0/30 is subnetted, 1 subnets B 192.168.2.0/24 [20/100] via 172.16.0.2 C 10.0.0.0 is directly connected, F0/0 B 192.168.3.0/24 [20/100] via 172.16.0.2 B 192.168.1.0/24 [20/0] via 172.16.0.1 C 192.168.2.0/24 is directly connected, F2/0 O IA 192.168.3.0/24 [110/2] via 10.0.0.2, F0/0 by Jeremy Stretch v2.1-r1