SlideShare a Scribd company logo
1 of 13
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
Full Bandwidth Management Parent Queue Tree
Thisis the combination,continuedandcompletionof bandwidthmanagement methodspreviouslyusing
parentqueue tree abouttohandle all sortsof purposesinaninternetnetworkthatismore complex.
Perhapsif youdo not wantto thinktoohard, yousimplyapplythe simple queue tolimitbandwidththat
so powerful andassertivetolimitbandwidthperclientonyourinternetnetwork.The problemisif we
share the bandwidthwithasimple queue isstiffness,andit'shardfor me to divide intomanyclients
normally.Itwouldbe appropriate tobe appliedtothe kindof dedicateinternet connection.
For example If Ihave a totallythe bandwidthinternetconnectionisupto2M, afteri have testedby
speedtest,the bandwidthaverageis512 kbps.Itmeansthat if I have 6 clients,be 512/6 = 86
kbps/clientsnormally,the idealnumberisverysmall inappropriate forourclient.If the bandwidthof up
to 2 M calculatedwith2000/6 to be around334 kbps/clients,itcanmakesbrowsingandonline game
stuck if justonlyone clientthere whodownloadandplaystreamingvideo,because the clientspend
almostall the average speed(512kbps) otherclientswill be especiallyproblematicjustforbrowsingor
online game.Inthiscase we needthe prioritytothe fourthpackets.
Full BandwidthManagementwiththe parentqueue tree complete the lackof packetsconnectionper
client,especiallytohandle the internetnetworkwithmanyclients.The principle isequallydividethe
bandwidthtoall the clientswithbandwidthgreaterthanthatshouldbe givenasthe limitbandwidthon
each clients,in whichwe setOnlineGames,Browsing,Download,VideoStreamingpackets,connection
packets.Well,fornowI will make the Full BandwidthManagementusingthe parent queue tree.For
more easilytomake the complex rule,Iwill workwiththe scriptsformore quickly.
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
Situation and Conditions:
Total Bandwidth=Up to2 M
8 ClientsthatIhave :
Billing: 192.168.1.11
Client1 : 192.168.1.17
Client2 : 192.168.1.16
Client3 : 192.168.1.15
Client4 : 192.168.1.14
Client5 : 192.168.1.20
Client6 : 192.168.1.21
Master : 192.168.1.8
In-Interface =ether1
Out-Interface =wlan1
/ipfirewall address-list
add address=192.168.1.0/24 disabled=nolist=MikroTikcomment=""
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
1. Marking all the connectionoutandin of the interface Mikrotikrouter,andcreate the
connection
/ipfirewall mangle
add action=mark-connectionchain=preroutingdst-address=!MikroTikin-interface=ether1new-
connection-mark=All-Inconndisabled=nopassthrough=yescomment="CONNECTION-IN"
add action=mark-packetchain=preroutingconnection-mark=All-Inconndisabled=nonew-packet-
mark=All-inpktpassthrough=yescomment="UPSTEAMPACKETS"
add action=mark-connectionchain=forwardin-interface=wlan1new-connection-mark=All-Outconn
disabled=nopassthrough=yescomment="CONNECTION-OUT"
add action=mark-packetchain=forwardconnection-mark=All-Outconnnew-packet-mark=All-
Outpktdisabled=nopassthrough=yescomment="DOWNSTEAM-PACKETS"
/queue tree
add name=All-Bandwidthparent=global-outpacket-mark=All-Outpktqueue=defaultpriority=1max-
limit=2M
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
The connectionthatwe will use is All-Outconnasthe above scriptswiththe connection
chain=forward out-interface=wlan1,whichwe subsequentlydifferentiate intodifferentconnections
to produce differentconnectionpackets.
2. Take the connectionsof All-Outconnthendivideitintothe connectionstoeveryclient,andmake
connectionpacketseveryclientthatwill capturedbythe queue tree perclient.
Here are the followingscripts:
/ip firewall mangle
add action=mark-connection chain=forward comment="Billing" disabled=no dst-
address=192.168.1.11 new-connection-mark=Billing-conn passthrough=yes
connection-mark=All-Outconn
add action=mark-connection chain=forward comment="Client1" disabled=no dst-
address=192.168.1.17 new-connection-mark=Client1-conn passthrough=yes
connection-mark=All-Outconn
add action=mark-connection chain=forward comment="Client2" disabled=no dst-
address=192.168.1.16 new-connection-mark=Client2-conn passthrough=yes
connection-mark=All-Outconn
add action=mark-connection chain=forward comment="Client3" disabled=no dst-
address=192.168.1.15 new-connection-mark=Client3-conn passthrough=yes
connection-mark=All-Outconn
add action=mark-connection chain=forward comment="Client4" disabled=no dst-
address=192.168.1.14 new-connection-mark=Client4-conn passthrough=yes
connection-mark=All-Outconn
add action=mark-connection chain=forward comment="Client5" disabled=no dst-
address=192.168.1.20 new-connection-mark=Client5-conn passthrough=yes
connection-mark=All-Outconn
add action=mark-connection chain=forward comment="Client6" disabled=no dst-
address=192.168.1.21 new-connection-mark=Client6-conn passthrough=yes
connection-mark=All-Outconn
add action=mark-connection chain=forward comment="Master" disabled=no dst-
address=192.168.1.8 new-connection-mark=Master-conn passthrough=yes
connection-mark=All-Outconn
/ip firewall mangle
add action=mark-packet chain=forward new-packet-mark=Billing-pkt
passthrough=yes connection-mark=Billing-conn comment="BILLING DOWNSTEAM"
add action=mark-packet chain=forward new-packet-mark=Client1-pkt
passthrough=yes connection-mark=Client1-conn comment="CLIENT1 DOWNSTEAM"
add action=mark-packet chain=forward new-packet-mark=Client2-pkt
passthrough=yes connection-mark=Client2-conn comment="CLIENT2 DOWNSTEAM"
add action=mark-packet chain=forward new-packet-mark=Client3-pkt
passthrough=yes connection-mark=Client3-conn comment="CLIENT3 DOWNSTEAM"
add action=mark-packet chain=forward new-packet-mark=Client4-pkt
passthrough=yes connection-mark=Client4-conn comment="CLIENT4 DOWNSTEAM"
add action=mark-packet chain=forward new-packet-mark=Client5-pkt
passthrough=yes connection-mark=Client5-conn comment="CLIENT5 DOWNSTEAM"
add action=mark-packet chain=forward new-packet-mark=Client6-pkt
passthrough=yes connection-mark=Client6-conn comment="CLIENT6 DOWNSTEAM"
add action=mark-packet chain=forward new-packet-mark=Master-pkt
passthrough=yes connection-mark=Master-conn comment="MASTER DOWNSTEAM"
/queue tree
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
add name=Billing parent=All-Bandwidth packet-mark=Billing-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
add name=Client1 parent=All-Bandwidth packet-mark=Client1-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
add name=Client2 parent=All-Bandwidth packet-mark=Client2-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
add name=Client3 parent=All-Bandwidth packet-mark=Client3-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
add name=Client4 parent=All-Bandwidth packet-mark=Client4-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
add name=Client5 parent=All-Bandwidth packet-mark=Client5-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
add name=Client6 parent=All-Bandwidth packet-mark=Client6-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
add name=Master parent=All-Bandwidth packet-mark=Master-pkt queue=default
priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
The scripts above consists with mangle and queue tree rule. From here we are already making
the connections per ip address of clients, such as
 Connections Per Client : Billing-conn, Client1-conn, Client2-conn, Client3-conn,
Client4-conn, Client5-conn, Client6-conn, Master-conn
 Connection Packets Per Client : Billing-pkt, Client1-pkt, Client1-pkt, Client2-pkt,
Client3-pkt, Client4-pkt, Client5-pkt, Client6-pkt, Master-pkt
3. The Connections per client that we have divided will separated into four packets
connection such as browsing, online games, download, streaming video per client. Here are
the forth part of four different packets connection. If there are any packets that have not been
defined I asked for suggestions from those of you that had experience.
Part I : Making the packets per client for download and the queue tree with priority as you
wish, here the following scripts:
/ip firewall layer7-protocol
add comment="" name=download
regexp="^.*get.+.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat
|mov).*$"
/ip firewall mangle
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=billing-dpkt passthrough=no packet-mark=Billing-pkt comment=Billing-Down
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=client1-dpkt passthrough=no packet-mark=Client1-pkt comment=Client1-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=client2-dpkt passthrough=no packet-mark=Client2-pkt comment=Client2-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=client3-dpkt passthrough=no packet-mark=Client3-pkt comment=Client3-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=client4-dpkt passthrough=no packet-mark=Client4-pkt comment=Client4-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=client5-dpkt passthrough=no packet-mark=Client5-pkt comment=Client5-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=client6-dpkt passthrough=no packet-mark=Client6-pkt comment=Client6-Down
add chain=forward layer7-protocol=download action=mark-packet new-packet-
mark=master-dpkt passthrough=no packet-mark=Master-pkt comment=Master-Down
/queue tree
add name=Billing-Down parent=Billing packet-mark=billing-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
add name=Client1-Down parent=Client1 packet-mark=client1-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
add name=Client2-Down parent=Client2 packet-mark=client2-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
add name=Client3-Down parent=Client3 packet-mark=client3-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
add name=Client4-Down parent=Client4 packet-mark=client4-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
add name=Client5-Down parent=Client5 packet-mark=client5-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
add name=Client6-Down parent=Client6 packet-mark=client6-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
add name=Master-Down parent=Master packet-mark=master-dpkt queue=default
priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k
burst-time=2s
Here we take anduse the connectionsperclientanddifferentiate intoconnectionpacketsof
downloadedbythe extensionfiles,soif there are anythe extensionfilesthatyouthinkisimportant,
justadd the the extensionfilesthatyouwantto the layer7 protocolsfromthe above scripts.
Part II. Makingthe videopacketconnectionperclientcomplete withthe queue tree andpriorityas
youplease.Here the followingscripts
add comment=""name=streaming
regexp="^.*get.+.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*$"
If the above scriptdoesn'tworks,trythe secondregexponthe script below!
/ipfirewall layer7-protocol
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
add comment=""name=streamingregexp="videoplayback|video"
/ip firewall mangle
add comment=Billing-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=billing-spkt passthrough=no packet-
mark=Billing-pkt
add comment=Client1-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=client1-spkt passthrough=no packet-
mark=Client1-pkt
add comment=Client2-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=client2-spkt passthrough=no packet-
mark=Client2-pkt
add comment=Client3-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=client3-spkt passthrough=no packet-
mark=Client3-pkt
add comment=Client4-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=client4-spkt passthrough=no packet-
mark=Client4-pkt
add comment=Client5-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=client5-spkt passthrough=no packet-
mark=Client5-pkt
add comment=Client6-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=client6-spkt passthrough=no packet-
mark=Client6-pkt
add comment=Master-Streams chain=forward layer7-protocol=streaming
action=mark-packet new-packet-mark=master-spkt passthrough=no packet-
mark=Master-pkt
/queue tree
add name=Billing-Streams parent=Billing packet-mark=billing-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client1-Streams parent=Client1 packet-mark=client1-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client2-Streams parent=Client2 packet-mark=client2-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client3-Streams parent=Client3 packet-mark=client3-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client4-Streams parent=Client4 packet-mark=client4-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client5-Streams parent=Client5 packet-mark=client5-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client6-Streams parent=Client6 packet-mark=client6-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Master-Streams parent=Master packet-mark=master-spkt queue=default
priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
Thisis the similarmethodinmakingthe connectionpacketslike downloadpacketsisbyusingalayer
7 protocols,the contentof streamingvideoothersitesthathave notbeendefined,pleaseyouadd
on the layer7 protocolsif youthinkthatis important,andadjustthe priorityandlimitspeedonthe
queue tree asyouplease.
c. MembuatpacketsOnline game perclientlengkapdenganqueuetreenya,berikutini adalah
scriptsnya:
Part III : Making the Online gamespacketconnectionperclientcomplete withthe queue tree and
priority,here the followingscripts:
/ip firewall mangle
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001-
10011,14009-14030,18901-18909 comment="Online Game Portal"
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=tcp dst-
port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=tcp dst-
port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=tcp dst-
port=47611,16666,20000,5105,29000,18901-18909,9015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=udp dst-port=27005,27015
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=udp dst-port=27005-27020,13055,7800-
7900,12060-12070
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=udp dst-port=8005-
8010,9068,1293,1479,9401,9600,30000
add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet-
mark=gpkt passthrough=yes protocol=udp dst-port=14009-14030,42051-
42052,40000-40050,13000-13080
/ip firewall mangle
add action=mark-packet chain=forward new-packet-mark=billing-gpkt
passthrough=no dst-address=192.168.1.11 packet-mark=gpkt comment=Billing-Game
add action=mark-packet chain=forward new-packet-mark=client1-gpkt
passthrough=no dst-address=192.168.1.17 packet-mark=gpkt comment=Client1-Game
add action=mark-packet chain=forward new-packet-mark=client2-gpkt
passthrough=no dst-address=192.168.1.16 packet-mark=gpkt comment=Client2-Game
add action=mark-packet chain=forward new-packet-mark=client3-gpkt
passthrough=no dst-address=192.168.1.15 packet-mark=gpkt comment=Client3-Game
add action=mark-packet chain=forward new-packet-mark=client4-gpkt
passthrough=no dst-address=192.168.1.14 packet-mark=gpkt comment=Client4-Game
add action=mark-packet chain=forward new-packet-mark=client5-gpkt
passthrough=no dst-address=192.168.1.20 packet-mark=gpkt comment=Client5-Game
add action=mark-packet chain=forward new-packet-mark=client6-gpkt
passthrough=no dst-address=192.168.1.21 packet-mark=gpkt comment=Client6-Game
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
add action=mark-packet chain=forward new-packet-mark=master-gpkt
passthrough=no dst-address=192.168.1.8 packet-mark=gpkt comment=Master-Game
/queue tree
add name=Billing-Game parent=Billing packet-mark=billing-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client1-Game parent=Client1 packet-mark=client1-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client2-Game parent=Client2 packet-mark=client2-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client3-Game parent=Client3 packet-mark=client3-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client4-Game parent=Client4 packet-mark=client4-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client5-Game parent=Client5 packet-mark=client5-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Client6-Game parent=Client6 packet-mark=client6-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
add name=Master-Game parent=Master packet-mark=master-gpkt queue=default
priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k
burst-time=2s
In thiscase we make the online-gamesconnectionatfirst,basedonout-interface=wlan1andtcp
and udpof manyports that usedbythe online games.Thenmake the onlinegamesconnection
packetsperip addressclientfromthat,finallywe capture the packetsonline gamesonqueue tree
and the priorityasyou wish.
Part IV.Make browsingconnectionpacketsperclientcompletewithtree queue andgive the
priority,here the followingscript:
/ip firewall mangle
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Billing-pkt new-packet-mark=billing-
bpkt protocol=tcp comment="BILLING BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Client1-pkt new-packet-mark=client1-
bpkt protocol=tcp comment="CLIENT1 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Client2-pkt new-packet-mark=client2-
bpkt protocol=tcp comment="CLIENT2 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Client3-pkt new-packet-mark=client3-
bpkt protocol=tcp comment="CLIENT3 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Client4-pkt new-packet-mark=client4-
bpkt protocol=tcp comment="CLIENT4 BROWSING"
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Client5-pkt new-packet-mark=client5-
bpkt protocol=tcp comment="CLIENT5 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Client6-pkt new-packet-mark=client6-
bpkt protocol=tcp comment="CLIENT6 BROWSING"
add action=mark-packet chain=forward connection-bytes=0-1000000 src-
port=80,443 passthrough=no packet-mark=Master-pkt new-packet-mark=master-bpkt
protocol=tcp comment="MASTER BROWSING"
/queue tree
add name="Billing-Browsing" parent=Billing packet-mark=billing-bpkt
queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-
threshold=192k burst-time=2s
add name="Client1-Browsing" parent=Client1 packet-mark=client1-bpkt
queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-
threshold=192k burst-time=2s
add name="Client2-Browsing" parent=Client2 packet-mark=client2-bpkt
queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-
threshold=192k burst-time=2s
add name="Client3-Browsing" parent=Client3 packet-mark=client3-bpkt
queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-
threshold=192k burst-time=2s
add name="Client4-Browsing" parent=Client4 packet-mark=client4-bpkt
queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-
threshold=192k burst-time=2s
add name="Client5-Browsing" parent=Client5 packet-mark=client5-bpkt
queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-
threshold=192k burst-time=2s
add name="Client6-Browsing" parent=Client6 packet-mark=client6-bpkt
queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-
threshold=192k burst-time=2s
add name="Master-Browsing" parent=Master packet-mark=master-bpkt queue=default
priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k
burst-time=2s
Take and use the connectionperclientthenwe make the new browsingconnectionbycapturing
basedon port 80 and 443 (HTTP and HTTPS ports) andaddingsmall bytes connection-bytes=0-
1000000, port that commonlyusedinbrowsingthe url site,small bytesof datamay alsobe included
here fromthe otherthree connectionpacketselse,butsmall enough
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah
Semoga Bermanfaat
Visit Blog sayawww.gerbang-komputer.com
Salam suksesRahmat Hidayatullah

More Related Content

Recently uploaded

ppt your views.ppt your views of your college in your eyes
ppt your views.ppt your views of your college in your eyesppt your views.ppt your views of your college in your eyes
ppt your views.ppt your views of your college in your eyes
ashishpaul799
 
會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文
會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文
會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文
中 央社
 
Liberal & Redical Feminism presentation.pptx
Liberal & Redical Feminism presentation.pptxLiberal & Redical Feminism presentation.pptx
Liberal & Redical Feminism presentation.pptx
Rizwan Abbas
 
會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽
會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽
會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽
中 央社
 
IATP How-to Foreign Travel May 2024.pdff
IATP How-to Foreign Travel May 2024.pdffIATP How-to Foreign Travel May 2024.pdff
IATP How-to Foreign Travel May 2024.pdff
17thcssbs2
 

Recently uploaded (20)

The Last Leaf, a short story by O. Henry
The Last Leaf, a short story by O. HenryThe Last Leaf, a short story by O. Henry
The Last Leaf, a short story by O. Henry
 
ppt your views.ppt your views of your college in your eyes
ppt your views.ppt your views of your college in your eyesppt your views.ppt your views of your college in your eyes
ppt your views.ppt your views of your college in your eyes
 
slides CapTechTalks Webinar May 2024 Alexander Perry.pptx
slides CapTechTalks Webinar May 2024 Alexander Perry.pptxslides CapTechTalks Webinar May 2024 Alexander Perry.pptx
slides CapTechTalks Webinar May 2024 Alexander Perry.pptx
 
Danh sách HSG Bộ môn cấp trường - Cấp THPT.pdf
Danh sách HSG Bộ môn cấp trường - Cấp THPT.pdfDanh sách HSG Bộ môn cấp trường - Cấp THPT.pdf
Danh sách HSG Bộ môn cấp trường - Cấp THPT.pdf
 
MichaelStarkes_UncutGemsProjectSummary.pdf
MichaelStarkes_UncutGemsProjectSummary.pdfMichaelStarkes_UncutGemsProjectSummary.pdf
MichaelStarkes_UncutGemsProjectSummary.pdf
 
會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文
會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文
會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文會考英文
 
Championnat de France de Tennis de table/
Championnat de France de Tennis de table/Championnat de France de Tennis de table/
Championnat de France de Tennis de table/
 
Mbaye_Astou.Education Civica_Human Rights.pptx
Mbaye_Astou.Education Civica_Human Rights.pptxMbaye_Astou.Education Civica_Human Rights.pptx
Mbaye_Astou.Education Civica_Human Rights.pptx
 
Post Exam Fun(da) Intra UEM General Quiz 2024 - Prelims q&a.pdf
Post Exam Fun(da) Intra UEM General Quiz 2024 - Prelims q&a.pdfPost Exam Fun(da) Intra UEM General Quiz 2024 - Prelims q&a.pdf
Post Exam Fun(da) Intra UEM General Quiz 2024 - Prelims q&a.pdf
 
Word Stress rules esl .pptx
Word Stress rules esl               .pptxWord Stress rules esl               .pptx
Word Stress rules esl .pptx
 
Liberal & Redical Feminism presentation.pptx
Liberal & Redical Feminism presentation.pptxLiberal & Redical Feminism presentation.pptx
Liberal & Redical Feminism presentation.pptx
 
Pragya Champions Chalice 2024 Prelims & Finals Q/A set, General Quiz
Pragya Champions Chalice 2024 Prelims & Finals Q/A set, General QuizPragya Champions Chalice 2024 Prelims & Finals Q/A set, General Quiz
Pragya Champions Chalice 2024 Prelims & Finals Q/A set, General Quiz
 
會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽
會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽
會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽會考英聽
 
B.ed spl. HI pdusu exam paper-2023-24.pdf
B.ed spl. HI pdusu exam paper-2023-24.pdfB.ed spl. HI pdusu exam paper-2023-24.pdf
B.ed spl. HI pdusu exam paper-2023-24.pdf
 
IATP How-to Foreign Travel May 2024.pdff
IATP How-to Foreign Travel May 2024.pdffIATP How-to Foreign Travel May 2024.pdff
IATP How-to Foreign Travel May 2024.pdff
 
2024_Student Session 2_ Set Plan Preparation.pptx
2024_Student Session 2_ Set Plan Preparation.pptx2024_Student Session 2_ Set Plan Preparation.pptx
2024_Student Session 2_ Set Plan Preparation.pptx
 
Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17
Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17
Removal Strategy _ FEFO _ Working with Perishable Products in Odoo 17
 
Features of Video Calls in the Discuss Module in Odoo 17
Features of Video Calls in the Discuss Module in Odoo 17Features of Video Calls in the Discuss Module in Odoo 17
Features of Video Calls in the Discuss Module in Odoo 17
 
Gyanartha SciBizTech Quiz slideshare.pptx
Gyanartha SciBizTech Quiz slideshare.pptxGyanartha SciBizTech Quiz slideshare.pptx
Gyanartha SciBizTech Quiz slideshare.pptx
 
Application of Matrices in real life. Presentation on application of matrices
Application of Matrices in real life. Presentation on application of matricesApplication of Matrices in real life. Presentation on application of matrices
Application of Matrices in real life. Presentation on application of matrices
 

Featured

Social Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsSocial Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie Insights
Kurio // The Social Media Age(ncy)
 

Featured (20)

Skeleton Culture Code
Skeleton Culture CodeSkeleton Culture Code
Skeleton Culture Code
 
PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024
 
Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)
 
How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024
 
Social Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsSocial Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie Insights
 
Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024
 
5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary
 
ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd
 
Getting into the tech field. what next
Getting into the tech field. what next Getting into the tech field. what next
Getting into the tech field. what next
 
Google's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search IntentGoogle's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search Intent
 
How to have difficult conversations
How to have difficult conversations How to have difficult conversations
How to have difficult conversations
 
Introduction to Data Science
Introduction to Data ScienceIntroduction to Data Science
Introduction to Data Science
 
Time Management & Productivity - Best Practices
Time Management & Productivity -  Best PracticesTime Management & Productivity -  Best Practices
Time Management & Productivity - Best Practices
 
The six step guide to practical project management
The six step guide to practical project managementThe six step guide to practical project management
The six step guide to practical project management
 
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
 
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
 
12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work
 
ChatGPT webinar slides
ChatGPT webinar slidesChatGPT webinar slides
ChatGPT webinar slides
 
More than Just Lines on a Map: Best Practices for U.S Bike Routes
More than Just Lines on a Map: Best Practices for U.S Bike RoutesMore than Just Lines on a Map: Best Practices for U.S Bike Routes
More than Just Lines on a Map: Best Practices for U.S Bike Routes
 
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
 

Full bandwidth management with parent queue tree

  • 1. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah Full Bandwidth Management Parent Queue Tree Thisis the combination,continuedandcompletionof bandwidthmanagement methodspreviouslyusing parentqueue tree abouttohandle all sortsof purposesinaninternetnetworkthatismore complex. Perhapsif youdo not wantto thinktoohard, yousimplyapplythe simple queue tolimitbandwidththat so powerful andassertivetolimitbandwidthperclientonyourinternetnetwork.The problemisif we share the bandwidthwithasimple queue isstiffness,andit'shardfor me to divide intomanyclients normally.Itwouldbe appropriate tobe appliedtothe kindof dedicateinternet connection. For example If Ihave a totallythe bandwidthinternetconnectionisupto2M, afteri have testedby speedtest,the bandwidthaverageis512 kbps.Itmeansthat if I have 6 clients,be 512/6 = 86 kbps/clientsnormally,the idealnumberisverysmall inappropriate forourclient.If the bandwidthof up to 2 M calculatedwith2000/6 to be around334 kbps/clients,itcanmakesbrowsingandonline game stuck if justonlyone clientthere whodownloadandplaystreamingvideo,because the clientspend almostall the average speed(512kbps) otherclientswill be especiallyproblematicjustforbrowsingor online game.Inthiscase we needthe prioritytothe fourthpackets. Full BandwidthManagementwiththe parentqueue tree complete the lackof packetsconnectionper client,especiallytohandle the internetnetworkwithmanyclients.The principle isequallydividethe bandwidthtoall the clientswithbandwidthgreaterthanthatshouldbe givenasthe limitbandwidthon each clients,in whichwe setOnlineGames,Browsing,Download,VideoStreamingpackets,connection packets.Well,fornowI will make the Full BandwidthManagementusingthe parent queue tree.For more easilytomake the complex rule,Iwill workwiththe scriptsformore quickly.
  • 2. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah Situation and Conditions: Total Bandwidth=Up to2 M 8 ClientsthatIhave : Billing: 192.168.1.11 Client1 : 192.168.1.17 Client2 : 192.168.1.16 Client3 : 192.168.1.15 Client4 : 192.168.1.14 Client5 : 192.168.1.20 Client6 : 192.168.1.21 Master : 192.168.1.8 In-Interface =ether1 Out-Interface =wlan1 /ipfirewall address-list add address=192.168.1.0/24 disabled=nolist=MikroTikcomment=""
  • 3. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah 1. Marking all the connectionoutandin of the interface Mikrotikrouter,andcreate the connection /ipfirewall mangle add action=mark-connectionchain=preroutingdst-address=!MikroTikin-interface=ether1new- connection-mark=All-Inconndisabled=nopassthrough=yescomment="CONNECTION-IN" add action=mark-packetchain=preroutingconnection-mark=All-Inconndisabled=nonew-packet- mark=All-inpktpassthrough=yescomment="UPSTEAMPACKETS" add action=mark-connectionchain=forwardin-interface=wlan1new-connection-mark=All-Outconn disabled=nopassthrough=yescomment="CONNECTION-OUT" add action=mark-packetchain=forwardconnection-mark=All-Outconnnew-packet-mark=All- Outpktdisabled=nopassthrough=yescomment="DOWNSTEAM-PACKETS" /queue tree add name=All-Bandwidthparent=global-outpacket-mark=All-Outpktqueue=defaultpriority=1max- limit=2M
  • 4. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah The connectionthatwe will use is All-Outconnasthe above scriptswiththe connection chain=forward out-interface=wlan1,whichwe subsequentlydifferentiate intodifferentconnections to produce differentconnectionpackets. 2. Take the connectionsof All-Outconnthendivideitintothe connectionstoeveryclient,andmake connectionpacketseveryclientthatwill capturedbythe queue tree perclient. Here are the followingscripts: /ip firewall mangle add action=mark-connection chain=forward comment="Billing" disabled=no dst- address=192.168.1.11 new-connection-mark=Billing-conn passthrough=yes connection-mark=All-Outconn add action=mark-connection chain=forward comment="Client1" disabled=no dst- address=192.168.1.17 new-connection-mark=Client1-conn passthrough=yes connection-mark=All-Outconn add action=mark-connection chain=forward comment="Client2" disabled=no dst- address=192.168.1.16 new-connection-mark=Client2-conn passthrough=yes connection-mark=All-Outconn add action=mark-connection chain=forward comment="Client3" disabled=no dst- address=192.168.1.15 new-connection-mark=Client3-conn passthrough=yes connection-mark=All-Outconn add action=mark-connection chain=forward comment="Client4" disabled=no dst- address=192.168.1.14 new-connection-mark=Client4-conn passthrough=yes connection-mark=All-Outconn add action=mark-connection chain=forward comment="Client5" disabled=no dst- address=192.168.1.20 new-connection-mark=Client5-conn passthrough=yes connection-mark=All-Outconn add action=mark-connection chain=forward comment="Client6" disabled=no dst- address=192.168.1.21 new-connection-mark=Client6-conn passthrough=yes connection-mark=All-Outconn add action=mark-connection chain=forward comment="Master" disabled=no dst- address=192.168.1.8 new-connection-mark=Master-conn passthrough=yes connection-mark=All-Outconn /ip firewall mangle add action=mark-packet chain=forward new-packet-mark=Billing-pkt passthrough=yes connection-mark=Billing-conn comment="BILLING DOWNSTEAM" add action=mark-packet chain=forward new-packet-mark=Client1-pkt passthrough=yes connection-mark=Client1-conn comment="CLIENT1 DOWNSTEAM" add action=mark-packet chain=forward new-packet-mark=Client2-pkt passthrough=yes connection-mark=Client2-conn comment="CLIENT2 DOWNSTEAM" add action=mark-packet chain=forward new-packet-mark=Client3-pkt passthrough=yes connection-mark=Client3-conn comment="CLIENT3 DOWNSTEAM" add action=mark-packet chain=forward new-packet-mark=Client4-pkt passthrough=yes connection-mark=Client4-conn comment="CLIENT4 DOWNSTEAM" add action=mark-packet chain=forward new-packet-mark=Client5-pkt passthrough=yes connection-mark=Client5-conn comment="CLIENT5 DOWNSTEAM" add action=mark-packet chain=forward new-packet-mark=Client6-pkt passthrough=yes connection-mark=Client6-conn comment="CLIENT6 DOWNSTEAM" add action=mark-packet chain=forward new-packet-mark=Master-pkt passthrough=yes connection-mark=Master-conn comment="MASTER DOWNSTEAM" /queue tree
  • 5. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah add name=Billing parent=All-Bandwidth packet-mark=Billing-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client1 parent=All-Bandwidth packet-mark=Client1-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client2 parent=All-Bandwidth packet-mark=Client2-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client3 parent=All-Bandwidth packet-mark=Client3-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client4 parent=All-Bandwidth packet-mark=Client4-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client5 parent=All-Bandwidth packet-mark=Client5-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Client6 parent=All-Bandwidth packet-mark=Client6-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s add name=Master parent=All-Bandwidth packet-mark=Master-pkt queue=default priority=8 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s The scripts above consists with mangle and queue tree rule. From here we are already making the connections per ip address of clients, such as  Connections Per Client : Billing-conn, Client1-conn, Client2-conn, Client3-conn, Client4-conn, Client5-conn, Client6-conn, Master-conn  Connection Packets Per Client : Billing-pkt, Client1-pkt, Client1-pkt, Client2-pkt, Client3-pkt, Client4-pkt, Client5-pkt, Client6-pkt, Master-pkt 3. The Connections per client that we have divided will separated into four packets connection such as browsing, online games, download, streaming video per client. Here are the forth part of four different packets connection. If there are any packets that have not been defined I asked for suggestions from those of you that had experience. Part I : Making the packets per client for download and the queue tree with priority as you wish, here the following scripts: /ip firewall layer7-protocol add comment="" name=download regexp="^.*get.+.(exe|rar|iso|zip|7zip|flv|mkv|avi|mp4|3gp|rmvb|mp3|img|dat |mov).*$" /ip firewall mangle add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=billing-dpkt passthrough=no packet-mark=Billing-pkt comment=Billing-Down
  • 6. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=client1-dpkt passthrough=no packet-mark=Client1-pkt comment=Client1-Down add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=client2-dpkt passthrough=no packet-mark=Client2-pkt comment=Client2-Down add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=client3-dpkt passthrough=no packet-mark=Client3-pkt comment=Client3-Down add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=client4-dpkt passthrough=no packet-mark=Client4-pkt comment=Client4-Down add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=client5-dpkt passthrough=no packet-mark=Client5-pkt comment=Client5-Down add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=client6-dpkt passthrough=no packet-mark=Client6-pkt comment=Client6-Down add chain=forward layer7-protocol=download action=mark-packet new-packet- mark=master-dpkt passthrough=no packet-mark=Master-pkt comment=Master-Down /queue tree add name=Billing-Down parent=Billing packet-mark=billing-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client1-Down parent=Client1 packet-mark=client1-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client2-Down parent=Client2 packet-mark=client2-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client3-Down parent=Client3 packet-mark=client3-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client4-Down parent=Client4 packet-mark=client4-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client5-Down parent=Client5 packet-mark=client5-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Client6-Down parent=Client6 packet-mark=client6-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s add name=Master-Down parent=Master packet-mark=master-dpkt queue=default priority=6 limit-at=180k max-limit=180k burst-limit=256k burst-threshold=135k burst-time=2s Here we take anduse the connectionsperclientanddifferentiate intoconnectionpacketsof downloadedbythe extensionfiles,soif there are anythe extensionfilesthatyouthinkisimportant, justadd the the extensionfilesthatyouwantto the layer7 protocolsfromthe above scripts. Part II. Makingthe videopacketconnectionperclientcomplete withthe queue tree andpriorityas youplease.Here the followingscripts add comment=""name=streaming regexp="^.*get.+.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*$" If the above scriptdoesn'tworks,trythe secondregexponthe script below! /ipfirewall layer7-protocol
  • 7. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah add comment=""name=streamingregexp="videoplayback|video" /ip firewall mangle add comment=Billing-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=billing-spkt passthrough=no packet- mark=Billing-pkt add comment=Client1-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client1-spkt passthrough=no packet- mark=Client1-pkt add comment=Client2-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client2-spkt passthrough=no packet- mark=Client2-pkt add comment=Client3-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client3-spkt passthrough=no packet- mark=Client3-pkt add comment=Client4-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client4-spkt passthrough=no packet- mark=Client4-pkt add comment=Client5-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client5-spkt passthrough=no packet- mark=Client5-pkt add comment=Client6-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=client6-spkt passthrough=no packet- mark=Client6-pkt add comment=Master-Streams chain=forward layer7-protocol=streaming action=mark-packet new-packet-mark=master-spkt passthrough=no packet- mark=Master-pkt /queue tree add name=Billing-Streams parent=Billing packet-mark=billing-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client1-Streams parent=Client1 packet-mark=client1-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client2-Streams parent=Client2 packet-mark=client2-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client3-Streams parent=Client3 packet-mark=client3-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client4-Streams parent=Client4 packet-mark=client4-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client5-Streams parent=Client5 packet-mark=client5-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client6-Streams parent=Client6 packet-mark=client6-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Master-Streams parent=Master packet-mark=master-spkt queue=default priority=8 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s
  • 8. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah Thisis the similarmethodinmakingthe connectionpacketslike downloadpacketsisbyusingalayer 7 protocols,the contentof streamingvideoothersitesthathave notbeendefined,pleaseyouadd on the layer7 protocolsif youthinkthatis important,andadjustthe priorityandlimitspeedonthe queue tree asyouplease. c. MembuatpacketsOnline game perclientlengkapdenganqueuetreenya,berikutini adalah scriptsnya: Part III : Making the Online gamespacketconnectionperclientcomplete withthe queue tree and priority,here the followingscripts: /ip firewall mangle add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=tcp dst-port=5340-5352,6000-6152,10001- 10011,14009-14030,18901-18909 comment="Online Game Portal" add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=tcp dst- port=39190,27780,29000,22100,10009,4300,15001,15002,7341,7451 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=tcp dst- port=40000,9300,9400,9700,7342,8005-8010,37466,36567,8822 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=tcp dst- port=47611,16666,20000,5105,29000,18901-18909,9015 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=udp dst-port=27005,27015 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=udp dst-port=27005-27020,13055,7800- 7900,12060-12070 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=udp dst-port=8005- 8010,9068,1293,1479,9401,9600,30000 add action=mark-packet chain=forward packet-mark=All-Outpkt new-packet- mark=gpkt passthrough=yes protocol=udp dst-port=14009-14030,42051- 42052,40000-40050,13000-13080 /ip firewall mangle add action=mark-packet chain=forward new-packet-mark=billing-gpkt passthrough=no dst-address=192.168.1.11 packet-mark=gpkt comment=Billing-Game add action=mark-packet chain=forward new-packet-mark=client1-gpkt passthrough=no dst-address=192.168.1.17 packet-mark=gpkt comment=Client1-Game add action=mark-packet chain=forward new-packet-mark=client2-gpkt passthrough=no dst-address=192.168.1.16 packet-mark=gpkt comment=Client2-Game add action=mark-packet chain=forward new-packet-mark=client3-gpkt passthrough=no dst-address=192.168.1.15 packet-mark=gpkt comment=Client3-Game add action=mark-packet chain=forward new-packet-mark=client4-gpkt passthrough=no dst-address=192.168.1.14 packet-mark=gpkt comment=Client4-Game add action=mark-packet chain=forward new-packet-mark=client5-gpkt passthrough=no dst-address=192.168.1.20 packet-mark=gpkt comment=Client5-Game add action=mark-packet chain=forward new-packet-mark=client6-gpkt passthrough=no dst-address=192.168.1.21 packet-mark=gpkt comment=Client6-Game
  • 9. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah add action=mark-packet chain=forward new-packet-mark=master-gpkt passthrough=no dst-address=192.168.1.8 packet-mark=gpkt comment=Master-Game /queue tree add name=Billing-Game parent=Billing packet-mark=billing-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client1-Game parent=Client1 packet-mark=client1-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client2-Game parent=Client2 packet-mark=client2-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client3-Game parent=Client3 packet-mark=client3-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client4-Game parent=Client4 packet-mark=client4-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client5-Game parent=Client5 packet-mark=client5-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Client6-Game parent=Client6 packet-mark=client6-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s add name=Master-Game parent=Master packet-mark=master-gpkt queue=default priority=1 limit-at=220k max-limit=220k burst-limit=256k burst-threshold=165k burst-time=2s In thiscase we make the online-gamesconnectionatfirst,basedonout-interface=wlan1andtcp and udpof manyports that usedbythe online games.Thenmake the onlinegamesconnection packetsperip addressclientfromthat,finallywe capture the packetsonline gamesonqueue tree and the priorityasyou wish. Part IV.Make browsingconnectionpacketsperclientcompletewithtree queue andgive the priority,here the followingscript: /ip firewall mangle add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Billing-pkt new-packet-mark=billing- bpkt protocol=tcp comment="BILLING BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Client1-pkt new-packet-mark=client1- bpkt protocol=tcp comment="CLIENT1 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Client2-pkt new-packet-mark=client2- bpkt protocol=tcp comment="CLIENT2 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Client3-pkt new-packet-mark=client3- bpkt protocol=tcp comment="CLIENT3 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Client4-pkt new-packet-mark=client4- bpkt protocol=tcp comment="CLIENT4 BROWSING"
  • 10. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Client5-pkt new-packet-mark=client5- bpkt protocol=tcp comment="CLIENT5 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Client6-pkt new-packet-mark=client6- bpkt protocol=tcp comment="CLIENT6 BROWSING" add action=mark-packet chain=forward connection-bytes=0-1000000 src- port=80,443 passthrough=no packet-mark=Master-pkt new-packet-mark=master-bpkt protocol=tcp comment="MASTER BROWSING" /queue tree add name="Billing-Browsing" parent=Billing packet-mark=billing-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst- threshold=192k burst-time=2s add name="Client1-Browsing" parent=Client1 packet-mark=client1-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst- threshold=192k burst-time=2s add name="Client2-Browsing" parent=Client2 packet-mark=client2-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst- threshold=192k burst-time=2s add name="Client3-Browsing" parent=Client3 packet-mark=client3-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst- threshold=192k burst-time=2s add name="Client4-Browsing" parent=Client4 packet-mark=client4-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst- threshold=192k burst-time=2s add name="Client5-Browsing" parent=Client5 packet-mark=client5-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst- threshold=192k burst-time=2s add name="Client6-Browsing" parent=Client6 packet-mark=client6-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst- threshold=192k burst-time=2s add name="Master-Browsing" parent=Master packet-mark=master-bpkt queue=default priority=2 limit-at=256k max-limit=256k burst-limit=720k burst-threshold=192k burst-time=2s Take and use the connectionperclientthenwe make the new browsingconnectionbycapturing basedon port 80 and 443 (HTTP and HTTPS ports) andaddingsmall bytes connection-bytes=0- 1000000, port that commonlyusedinbrowsingthe url site,small bytesof datamay alsobe included here fromthe otherthree connectionpacketselse,butsmall enough
  • 11. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah
  • 12. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah
  • 13. Semoga Bermanfaat Visit Blog sayawww.gerbang-komputer.com Salam suksesRahmat Hidayatullah