SlideShare a Scribd company logo
1 of 2
OSPF                PART 1                                                                             packetlife.net
                            Protocol Header                                                   Attributes
                    8               16                   24              32                  Type Link-State
        Version            Type                     Length                             Algorithm Dijkstra
                                  Router ID                                                Metric Cost (Bandwidth)
                                   Area ID                                                      AD 110
               Checksum                    Instance ID        Reserved                  Standard RFC 2328, 2740
                                    Data                                               Protocols IP
                                                                                       Transport IP/89
                        Link State Advertisements
                                                                                Authentication Plaintext, MD5
Router Link (Type 1)
Lists neighboring routers and the cost to each; flooded within an area          AllSPF Address 224.0.0.5

Network Link (Type 2)                                                            AllDR Address 224.0.0.6
Generated by a DR; lists all routers on an adjacent segment; flooded
                                                                                           Metric Formula
within an area
Network Summary (Type 3)                                                                        100,000 Kbps*
                                                                                       cost =
Generated by an ABR and advertised among areas                                                    link speed
ASBR Summary (Type 4)
                                                                                                           * modifiable with
Injected by an ABR into the backbone to advertise the presence of an                   ospf auto-cost reference-bandwidth
ASBR within an area
External Link (Type 5)                                                                    Adjacency States
Generated by an ASBR and flooded throughout the AS to advertise a
                                                                              1 Down                 5 Exstart
route external to OSPF
NSSA External Link (Type 7)                                                   2 Attempt              6 Exchange
Generated by an ASBR in a not-so-stubby area; converted into a                3 Init                 7 Loading
type 5 LSA by the ABR when leaving the area
                                                                              4 2-Way                8 Full
         Router Types                               Area Types
                                                                                          DR/BDR Election
Internal Router                          Standard Area
All interfaces reside within the         Default OSPF area type                The DR serves as a common point for
same area                                                                     all adjacencies on a multiaccess
                                         Stub Area                            segment
Backbone Router                          External link (type 5) LSAs are
A router with an interface in            replaced with a default route         The BDR also maintains adjacencies
area 0 (the backbone)                                                         with all routers in case the DR fails
                                         Totally Stubby Area
Area Border Router (ABR)                 Type 3, 4, and 5 LSAs are             Election does not occur on point-to-
Connects two or more areas               replaced with a default route        point or multipoint links
AS Boundary Router (ASBR)                Not So Stubby Area (NSSA)
                                                                               Default priority (0-255) is 1; highest
Connects to additional routing           A stub area containing an ASBR;
                                                                              priority wins; 0 cannot be elected
domains; typically located in            type 5 LSAs are converted to type
the backbone                             7 within the area                      DR preemption will not occur unless
                                                                              the current DR is reset
                          External Route Types
E1   Cost to the advertising ASBR plus the external cost of the route                        Virtual Links

E2 (Default)      Cost of the route as seen by the ASBR                        Tunnel formed to join two areas
                                                                              across an intermediate
                            Troubleshooting
                                                                               Both end routers must share a
show ip [route | protocols]               show ip ospf border-routers         common area
show ip ospf interface                    show ip ospf virtual-links           At least one end must reside in area 0
show ip ospf neighbor                     debug ip ospf […]                    Cannot traverse stub areas

by Jeremy Stretch                                                                                                      v2.1
OSPF                   PART 2                                                                           packetlife.net
                                                           Network Types
                               Nonbroadcast        Multipoint          Multipoint
                               (NBMA)              Broadcast           Nonbroadcast     Broadcast        Point-to-Point

      DR/BDR Elected Yes                           No                  No               Yes              No
  Neighbor Discovery No                            Yes                 No               Yes              Yes
  Hello/Dead Timers 30/120                         30/120              30/120           10/40            10/40
                 Defined By RFC 2328               RFC 2328            Cisco            Cisco            Cisco
 Supported Topology Full Mesh                      Any                 Any              Full Mesh        Point-to-Point

                                                       Configuration Example

                                                                       interface Serial0/0                       Router A
    WAN                 Area 0                         Area 9           description WAN Link
 172.16.0.0/18          Backbone               Totally Stubby Area      ip address 172.16.34.2 255.255.255.252
                                                                       !
                                                                       interface FastEthernet0/0
                                                                        description Area 0
                                                                        ip address 192.168.0.1 255.255.255.0
                 A                                                     !
                                                                       interface Loopback0
                                                                       ! Used as router ID
                                                                        ip address 10.0.34.1 255.255.255.0
                                                   C                   !
                           B
                                                                       router ospf 100
                                                                        ! Advertising the WAN cloud to OSPF
                                                                        redistribute static subnets
                                                                        network 192.168.0.0 0.0.0.255 area 0
                                                                       !
           Area 1                    Area 2                            ! Static route to the WAN cloud
           Stub Area               Standard Area                       ip route 172.16.0.0 255.255.192.0 172.16.34.1

                                                            Router B                                              Router C
interface Ethernet0/0                                                  interface Ethernet0/0
 description Area 0                                                     description Area 9
 ip address 192.168.0.2 255.255.255.0                                   ip address 192.168.9.1 255.255.255.0
 ip ospf 100 area 0                                                     ip ospf 100 area 9
!                                                                      !
interface Ethernet0/1                                                  interface Ethernet0/1
 description Area 2                                                     description Area 2
 ip address 192.168.2.1 255.255.255.0                                   ip address 192.168.2.2 255.255.255.0
 ip ospf 100 area 2                                                     ip ospf 100 area 2
 ! Optional MD5 authentication configured                               ! Optional MD5 authentication configured
 ip ospf authentication message-digest                                  ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 FooBar                                ip ospf message-digest-key 1 md5 FooBar
 ! Give B priority in DR election                                       ! Give C second priority (BDR) in election
 ip ospf priority 100                                                   ip ospf priority 50
!                                                                      !
interface Ethernet0/2                                                  !
 description Area 1                                                    !
 ip address 192.168.1.1 255.255.255.0                                  !
 ip ospf 100 area 1                                                    !
!                                                                      !
interface Loopback0                                                    interface Loopback0
 ip address 10.0.34.2 255.255.255.0                                     ip address 10.0.34.3 255.255.255.0
!                                                                      !
router ospf 100                                                        router ospf 100
 ! Define area 1 as a stub area                                         ! Define area 9 as a totally stubby area
 area 1 stub                                                            area 9 stub no-summary
 ! Virtual link from area 0 to area 9                                   ! Virtual link from area 9 to area 0
 area 2 virtual-link 10.0.34.3                                          area 2 virtual-link 10.0.34.2


by Jeremy Stretch                                                                                                     v2.1

More Related Content

What's hot

CCNA Routing and Switching Lesson 05 - WANs - Eric Vanderburg
CCNA Routing and Switching Lesson 05 - WANs - Eric VanderburgCCNA Routing and Switching Lesson 05 - WANs - Eric Vanderburg
CCNA Routing and Switching Lesson 05 - WANs - Eric VanderburgEric Vanderburg
 
Open Shortest Path First
Open Shortest Path FirstOpen Shortest Path First
Open Shortest Path FirstKashif Latif
 
Drd700
Drd700Drd700
Drd700ciperi
 
IP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless AccessIP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless AccessDhiman Chowdhury
 
Understanding ISP Wiring
Understanding ISP WiringUnderstanding ISP Wiring
Understanding ISP Wiringrns-usa
 
Dynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPFDynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPFAtakan ATAK
 
第15讲 Stp
第15讲 Stp第15讲 Stp
第15讲 StpF.l. Yu
 
MPLS Concepts and Fundamentals
MPLS Concepts and FundamentalsMPLS Concepts and Fundamentals
MPLS Concepts and FundamentalsShawn Zandi
 
Routing and OSPF
Routing and OSPFRouting and OSPF
Routing and OSPFarpit
 

What's hot (19)

Introduction to MPLS - NANOG 61
Introduction to MPLS - NANOG 61Introduction to MPLS - NANOG 61
Introduction to MPLS - NANOG 61
 
Mpls co s
Mpls co sMpls co s
Mpls co s
 
Ospf
OspfOspf
Ospf
 
Multicast for ipv6
Multicast for ipv6Multicast for ipv6
Multicast for ipv6
 
CCNA Routing and Switching Lesson 05 - WANs - Eric Vanderburg
CCNA Routing and Switching Lesson 05 - WANs - Eric VanderburgCCNA Routing and Switching Lesson 05 - WANs - Eric Vanderburg
CCNA Routing and Switching Lesson 05 - WANs - Eric Vanderburg
 
Cisco ospf
Cisco ospf Cisco ospf
Cisco ospf
 
Open Shortest Path First
Open Shortest Path FirstOpen Shortest Path First
Open Shortest Path First
 
Drd700
Drd700Drd700
Drd700
 
IP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless AccessIP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless Access
 
Understanding ISP Wiring
Understanding ISP WiringUnderstanding ISP Wiring
Understanding ISP Wiring
 
Cisco ospf
Cisco ospf Cisco ospf
Cisco ospf
 
Dynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPFDynamic Routing Protocol OSPF
Dynamic Routing Protocol OSPF
 
Remote offices survival
Remote offices survivalRemote offices survival
Remote offices survival
 
Voip basics
Voip basicsVoip basics
Voip basics
 
第15讲 Stp
第15讲 Stp第15讲 Stp
第15讲 Stp
 
Bluetooth
Bluetooth Bluetooth
Bluetooth
 
OSPF Configuration
OSPF ConfigurationOSPF Configuration
OSPF Configuration
 
MPLS Concepts and Fundamentals
MPLS Concepts and FundamentalsMPLS Concepts and Fundamentals
MPLS Concepts and Fundamentals
 
Routing and OSPF
Routing and OSPFRouting and OSPF
Routing and OSPF
 

Viewers also liked

Still Digital Studios 3 Page Website Design
Still Digital Studios 3 Page Website DesignStill Digital Studios 3 Page Website Design
Still Digital Studios 3 Page Website Designbobstill
 
Bigg Boss All Season Winners List
Bigg Boss All Season Winners ListBigg Boss All Season Winners List
Bigg Boss All Season Winners ListKapil Kumar
 
APAC Social Media Map
APAC Social Media MapAPAC Social Media Map
APAC Social Media MapEdelman
 
Presentation Studie Deutsch
Presentation Studie DeutschPresentation Studie Deutsch
Presentation Studie DeutschWebguard
 
Dincolo de orice parser XML: XMLFS
Dincolo de orice parser XML: XMLFSDincolo de orice parser XML: XMLFS
Dincolo de orice parser XML: XMLFSAsociatia ProLinux
 
Letters and the animals they spell
Letters and the animals they spellLetters and the animals they spell
Letters and the animals they spellBrian Kelley
 
Reussir en e-Commerce - Conference Altics
Reussir en e-Commerce - Conference AlticsReussir en e-Commerce - Conference Altics
Reussir en e-Commerce - Conference AlticsALTICS
 
Slide
SlideSlide
SlideClay
 
Baking Analytics Into Your Digital Projects
Baking Analytics Into Your Digital ProjectsBaking Analytics Into Your Digital Projects
Baking Analytics Into Your Digital ProjectsCharles Meaden
 
Application of Microcontroller in Transmitter Section of Wireless System
Application of Microcontroller in Transmitter Section of Wireless SystemApplication of Microcontroller in Transmitter Section of Wireless System
Application of Microcontroller in Transmitter Section of Wireless Systemijceronline
 
246885077 cele-sapte-legi-spirituale-ale-succesului
246885077 cele-sapte-legi-spirituale-ale-succesului246885077 cele-sapte-legi-spirituale-ale-succesului
246885077 cele-sapte-legi-spirituale-ale-succesuluiNastase Ecaterina
 
Next Level Local Tactics (for MozCon 2013)
Next Level Local Tactics (for MozCon 2013)Next Level Local Tactics (for MozCon 2013)
Next Level Local Tactics (for MozCon 2013)Dana DiTomaso
 
How To Make Your Marketing Match Your Reality (#mozcon 2015)
How To Make Your Marketing Match Your Reality (#mozcon 2015)How To Make Your Marketing Match Your Reality (#mozcon 2015)
How To Make Your Marketing Match Your Reality (#mozcon 2015)Dana DiTomaso
 

Viewers also liked (17)

Still Digital Studios 3 Page Website Design
Still Digital Studios 3 Page Website DesignStill Digital Studios 3 Page Website Design
Still Digital Studios 3 Page Website Design
 
Bigg Boss All Season Winners List
Bigg Boss All Season Winners ListBigg Boss All Season Winners List
Bigg Boss All Season Winners List
 
West Point
West  PointWest  Point
West Point
 
APAC Social Media Map
APAC Social Media MapAPAC Social Media Map
APAC Social Media Map
 
ACTION PLAN
ACTION PLANACTION PLAN
ACTION PLAN
 
Guia de apredizaj 2
Guia de apredizaj 2Guia de apredizaj 2
Guia de apredizaj 2
 
Zoo Kacper B
Zoo Kacper BZoo Kacper B
Zoo Kacper B
 
Presentation Studie Deutsch
Presentation Studie DeutschPresentation Studie Deutsch
Presentation Studie Deutsch
 
Dincolo de orice parser XML: XMLFS
Dincolo de orice parser XML: XMLFSDincolo de orice parser XML: XMLFS
Dincolo de orice parser XML: XMLFS
 
Letters and the animals they spell
Letters and the animals they spellLetters and the animals they spell
Letters and the animals they spell
 
Reussir en e-Commerce - Conference Altics
Reussir en e-Commerce - Conference AlticsReussir en e-Commerce - Conference Altics
Reussir en e-Commerce - Conference Altics
 
Slide
SlideSlide
Slide
 
Baking Analytics Into Your Digital Projects
Baking Analytics Into Your Digital ProjectsBaking Analytics Into Your Digital Projects
Baking Analytics Into Your Digital Projects
 
Application of Microcontroller in Transmitter Section of Wireless System
Application of Microcontroller in Transmitter Section of Wireless SystemApplication of Microcontroller in Transmitter Section of Wireless System
Application of Microcontroller in Transmitter Section of Wireless System
 
246885077 cele-sapte-legi-spirituale-ale-succesului
246885077 cele-sapte-legi-spirituale-ale-succesului246885077 cele-sapte-legi-spirituale-ale-succesului
246885077 cele-sapte-legi-spirituale-ale-succesului
 
Next Level Local Tactics (for MozCon 2013)
Next Level Local Tactics (for MozCon 2013)Next Level Local Tactics (for MozCon 2013)
Next Level Local Tactics (for MozCon 2013)
 
How To Make Your Marketing Match Your Reality (#mozcon 2015)
How To Make Your Marketing Match Your Reality (#mozcon 2015)How To Make Your Marketing Match Your Reality (#mozcon 2015)
How To Make Your Marketing Match Your Reality (#mozcon 2015)
 

Similar to Ospf

Ospf infografia
Ospf infografiaOspf infografia
Ospf infografiaw78ww
 
Networking Basics OSPF
Networking Basics OSPFNetworking Basics OSPF
Networking Basics OSPFHassan Tariq
 
Ospf and eigrp concepts and configuration
Ospf and eigrp concepts and configurationOspf and eigrp concepts and configuration
Ospf and eigrp concepts and configurationIT Tech
 
Ospf Cisco
Ospf CiscoOspf Cisco
Ospf CiscoAlp isik
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccnarobertoxe
 
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.pptMenggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.pptRochmadGSaputra
 
OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)NetProtocol Xpert
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsAlejandro Marin
 
Designated & Backup Designated Router
Designated & Backup Designated RouterDesignated & Backup Designated Router
Designated & Backup Designated RouterNetProtocol Xpert
 
CCNA pptCCNA ppt Day 6
CCNA pptCCNA ppt Day 6CCNA pptCCNA ppt Day 6
CCNA pptCCNA ppt Day 6VISHNU N
 
OSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdfOSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdfDenis Rasskazov
 
OPEN SHORTEST PATH FIRST (OSPF)
OPEN SHORTEST PATH FIRST (OSPF)OPEN SHORTEST PATH FIRST (OSPF)
OPEN SHORTEST PATH FIRST (OSPF)Ann Joseph
 

Similar to Ospf (20)

Ospf infografia
Ospf infografiaOspf infografia
Ospf infografia
 
Networking Basics OSPF
Networking Basics OSPFNetworking Basics OSPF
Networking Basics OSPF
 
Ospf and eigrp concepts and configuration
Ospf and eigrp concepts and configurationOspf and eigrp concepts and configuration
Ospf and eigrp concepts and configuration
 
Ospf Cisco
Ospf CiscoOspf Cisco
Ospf Cisco
 
Ospf routing protocol
Ospf routing protocolOspf routing protocol
Ospf routing protocol
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.pptMenggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
Menggali Lebih Dalam tentang OSPF: Protokol Routing Dinamis yang Efisien.ppt
 
ospf.ppt
ospf.pptospf.ppt
ospf.ppt
 
OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)OSPF Network LSA (Type 2 LSA)
OSPF Network LSA (Type 2 LSA)
 
IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
 
Designated & Backup Designated Router
Designated & Backup Designated RouterDesignated & Backup Designated Router
Designated & Backup Designated Router
 
Day 12.2 enablingospf
Day 12.2 enablingospfDay 12.2 enablingospf
Day 12.2 enablingospf
 
OSPF - Copie.pptx
OSPF - Copie.pptxOSPF - Copie.pptx
OSPF - Copie.pptx
 
Multi-Area OSPF on IOS XR
Multi-Area OSPF on IOS XRMulti-Area OSPF on IOS XR
Multi-Area OSPF on IOS XR
 
CCNA pptCCNA ppt Day 6
CCNA pptCCNA ppt Day 6CCNA pptCCNA ppt Day 6
CCNA pptCCNA ppt Day 6
 
OSPF v3
OSPF v3OSPF v3
OSPF v3
 
OSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdfOSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdf
 
Network Layer Protocol.pptx
Network Layer Protocol.pptxNetwork Layer Protocol.pptx
Network Layer Protocol.pptx
 
OPEN SHORTEST PATH FIRST (OSPF)
OPEN SHORTEST PATH FIRST (OSPF)OPEN SHORTEST PATH FIRST (OSPF)
OPEN SHORTEST PATH FIRST (OSPF)
 

More from Mohamed Gamel (20)

Vyatta subnet range_cheat_sheet
Vyatta subnet range_cheat_sheetVyatta subnet range_cheat_sheet
Vyatta subnet range_cheat_sheet
 
Vla ns
Vla nsVla ns
Vla ns
 
Tcpdump
TcpdumpTcpdump
Tcpdump
 
Spanning tree
Spanning treeSpanning tree
Spanning tree
 
Scapy
ScapyScapy
Scapy
 
Rip
RipRip
Rip
 
Qo s
Qo sQo s
Qo s
 
Ppp
PppPpp
Ppp
 
Physical terminations
Physical terminationsPhysical terminations
Physical terminations
 
Nat
NatNat
Nat
 
Media wiki
Media wikiMedia wiki
Media wiki
 
Markdown
MarkdownMarkdown
Markdown
 
Is is
Is isIs is
Is is
 
I pv6
I pv6I pv6
I pv6
 
I pv4 subnetting
I pv4 subnettingI pv4 subnetting
I pv4 subnetting
 
I pv4 multicast
I pv4 multicastI pv4 multicast
I pv4 multicast
 
I psec
I psecI psec
I psec
 
Ios zone based-firewall
Ios zone based-firewallIos zone based-firewall
Ios zone based-firewall
 
Ios i pv4_access_lists
Ios i pv4_access_listsIos i pv4_access_lists
Ios i pv4_access_lists
 
Ios interior routing_protocols
Ios interior routing_protocolsIos interior routing_protocols
Ios interior routing_protocols
 

Ospf

  • 1. OSPF PART 1 packetlife.net Protocol Header Attributes 8 16 24 32 Type Link-State Version Type Length Algorithm Dijkstra Router ID Metric Cost (Bandwidth) Area ID AD 110 Checksum Instance ID Reserved Standard RFC 2328, 2740 Data Protocols IP Transport IP/89 Link State Advertisements Authentication Plaintext, MD5 Router Link (Type 1) Lists neighboring routers and the cost to each; flooded within an area AllSPF Address 224.0.0.5 Network Link (Type 2) AllDR Address 224.0.0.6 Generated by a DR; lists all routers on an adjacent segment; flooded Metric Formula within an area Network Summary (Type 3) 100,000 Kbps* cost = Generated by an ABR and advertised among areas link speed ASBR Summary (Type 4) * modifiable with Injected by an ABR into the backbone to advertise the presence of an ospf auto-cost reference-bandwidth ASBR within an area External Link (Type 5) Adjacency States Generated by an ASBR and flooded throughout the AS to advertise a 1 Down 5 Exstart route external to OSPF NSSA External Link (Type 7) 2 Attempt 6 Exchange Generated by an ASBR in a not-so-stubby area; converted into a 3 Init 7 Loading type 5 LSA by the ABR when leaving the area 4 2-Way 8 Full Router Types Area Types DR/BDR Election Internal Router Standard Area All interfaces reside within the Default OSPF area type The DR serves as a common point for same area all adjacencies on a multiaccess Stub Area segment Backbone Router External link (type 5) LSAs are A router with an interface in replaced with a default route The BDR also maintains adjacencies area 0 (the backbone) with all routers in case the DR fails Totally Stubby Area Area Border Router (ABR) Type 3, 4, and 5 LSAs are Election does not occur on point-to- Connects two or more areas replaced with a default route point or multipoint links AS Boundary Router (ASBR) Not So Stubby Area (NSSA) Default priority (0-255) is 1; highest Connects to additional routing A stub area containing an ASBR; priority wins; 0 cannot be elected domains; typically located in type 5 LSAs are converted to type the backbone 7 within the area DR preemption will not occur unless the current DR is reset External Route Types E1 Cost to the advertising ASBR plus the external cost of the route Virtual Links E2 (Default) Cost of the route as seen by the ASBR Tunnel formed to join two areas across an intermediate Troubleshooting Both end routers must share a show ip [route | protocols] show ip ospf border-routers common area show ip ospf interface show ip ospf virtual-links At least one end must reside in area 0 show ip ospf neighbor debug ip ospf […] Cannot traverse stub areas by Jeremy Stretch v2.1
  • 2. OSPF PART 2 packetlife.net Network Types Nonbroadcast Multipoint Multipoint (NBMA) Broadcast Nonbroadcast Broadcast Point-to-Point DR/BDR Elected Yes No No Yes No Neighbor Discovery No Yes No Yes Yes Hello/Dead Timers 30/120 30/120 30/120 10/40 10/40 Defined By RFC 2328 RFC 2328 Cisco Cisco Cisco Supported Topology Full Mesh Any Any Full Mesh Point-to-Point Configuration Example interface Serial0/0 Router A WAN Area 0 Area 9 description WAN Link 172.16.0.0/18 Backbone Totally Stubby Area ip address 172.16.34.2 255.255.255.252 ! interface FastEthernet0/0 description Area 0 ip address 192.168.0.1 255.255.255.0 A ! interface Loopback0 ! Used as router ID ip address 10.0.34.1 255.255.255.0 C ! B router ospf 100 ! Advertising the WAN cloud to OSPF redistribute static subnets network 192.168.0.0 0.0.0.255 area 0 ! Area 1 Area 2 ! Static route to the WAN cloud Stub Area Standard Area ip route 172.16.0.0 255.255.192.0 172.16.34.1 Router B Router C interface Ethernet0/0 interface Ethernet0/0 description Area 0 description Area 9 ip address 192.168.0.2 255.255.255.0 ip address 192.168.9.1 255.255.255.0 ip ospf 100 area 0 ip ospf 100 area 9 ! ! interface Ethernet0/1 interface Ethernet0/1 description Area 2 description Area 2 ip address 192.168.2.1 255.255.255.0 ip address 192.168.2.2 255.255.255.0 ip ospf 100 area 2 ip ospf 100 area 2 ! Optional MD5 authentication configured ! Optional MD5 authentication configured ip ospf authentication message-digest ip ospf authentication message-digest ip ospf message-digest-key 1 md5 FooBar ip ospf message-digest-key 1 md5 FooBar ! Give B priority in DR election ! Give C second priority (BDR) in election ip ospf priority 100 ip ospf priority 50 ! ! interface Ethernet0/2 ! description Area 1 ! ip address 192.168.1.1 255.255.255.0 ! ip ospf 100 area 1 ! ! ! interface Loopback0 interface Loopback0 ip address 10.0.34.2 255.255.255.0 ip address 10.0.34.3 255.255.255.0 ! ! router ospf 100 router ospf 100 ! Define area 1 as a stub area ! Define area 9 as a totally stubby area area 1 stub area 9 stub no-summary ! Virtual link from area 0 to area 9 ! Virtual link from area 9 to area 0 area 2 virtual-link 10.0.34.3 area 2 virtual-link 10.0.34.2 by Jeremy Stretch v2.1