SlideShare a Scribd company logo
Backup and Restore router configuration file using TFTP server with Packet
Tracer -Cisco CCNA
==================================================
Home › Networking › Backup and Restore router configuration file using TFTP
server with Packet Tracer -Cisco CCNA ›
==================================================
Here you can clearly see the router and TFTP Server in below diagram. I will
show you how to take backup of below router configuration file whose ip address
is 1.0.0.1 using TFTP Server whose ip address is 1.0.0.2.
==================================================
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#line vty 0
R1(config-line)#password redhat
R1(config-line)#login
R1(config-line)#exit
R1(config)#line console 0
R1(config-line)#password redhat123
R1(config-line)#login
R1(config-line)#exit
R1(config)#int fa0/0
R1(config-if)#ip address 1.0.0.1 255.0.0.0
R1(config-if)#no shut
==================================================
Now took a look at the running configuration using "show run" command.This is
the configuration active at the moment.
R1#show run
Building configuration...
Current configuration : 552 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 1.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
line con 0
password redhat123
login
!
line aux 0
!
line vty 0
password redhat
login
line vty 1 4
login
!
end
=========================================================
Now using show version or show flash command we can see the router ios file.
R1#show version
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1,
RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 04:52 by pt_team
ROM: System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)
System returned to ROM by power-on
System image file is "flash:c1841-advipservicesk9-mz.124-15.T1.bin"
Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory.
Processor board ID FTX0947Z18E
M860 processor: part number 0, mask 49
2 FastEthernet/IEEE 802.3 interface(s)
191K bytes of NVRAM.
63488K bytes of ATA CompactFlash (Read/Write)
Configuration register is 0x2102
=========================================================
R1#show flash
System flash directory:
File Length Name/status
3 33591768 c1841-advipservicesk9-mz.124-15.T1.bin
2 28282 sigdef-category.xml
1 227537 sigdef-default.xml
[33847587 bytes used, 30168797 available, 64016384 total]
63488K bytes of processor board System flash (Read/Write)
=======================================================
Now we are going to take backup of router IOS on tftp Server using below
mentioned command.
R1#copy flash tftp
Source filename []? c1841-advipservicesk9-mz.124-15.T1.bin
Address or name of remote host []? 1.0.0.2
Destination filename [c1841-advipservicesk9-mz.124-15.T1.bin]?
Writing c1841-advipservicesk9-mz.124-
15.T1.bin....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 33591768 bytes]
33591768 bytes copied in 5.796 secs (5795000 bytes/sec)
R1#
Now copy running-config to startup-config.
R1#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Then copy the startup-config file to tftp server machine so that we can get it
back from there whenever we need.
R1#copy startup-config tftp
Address or name of remote host []? 1.0.0.2
Destination filename [R1-confg]? R1-config
Writing startup-config...!!
[OK - 552 bytes]
552 bytes copied in 0.001 secs (552000 bytes/sec)
Now Go To TFTP Server and Verify:
in the above image you can clearly see we have successfully taken backup of
Router IOS to tftp Server and router configuration also to tftp server.
Now after Backup it's time to test recovery or restore.
i.e we will test how to restore router configuration.
Here in this tutorial we will discuss about how to restore back router
configuration from tftp server.
To test restore configuration of router first we need to first erase the
configuration on routers.
========================================================
R1#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue?
[confirm]
[OK]
Erase of nvram: complete
%SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
After erasing check whether you have successfully erased or not.
========================================================
R1#show startup-config
startup-config is not present
R1#
Now you can clearly see there is no output,means no configuration remains now.It
means everything has been erased.
Note:After reload i have a brand new router.Means all previous configuration
lost.
========================================================
R1#reload
Proceed with reload? [confirm]
System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1)
Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory.
Self decompressing the image :
########################################################################## [OK]
Restricted Rights Legend
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>
Now check your configuration after reload.
Router>enable
Router#show run
Building configuration...
Current configuration : 489 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
Now you can clearly see no ip, no hostaname, everything have been removed from
router previous configuration. so now we have to assign ip address again to have
a fresh start to connect with tftp so that we recover our configuration file
back as it was previous.
========================================================
So we are going to get back our IOS configuration file from tftp server to
router using below command.
=========================================================
Router#copy tftp running-config
Address or name of remote host []? 1.0.0.2
Source filename []? R1-config
Destination filename [running-config]?
Accessing tftp://1.0.0.2/R1-config........
%Error opening tftp://1.0.0.2/R1-config (Timed out)
Router#
You can clearly see that copy from tftp server failed because router interface
is down,we have to manualy up router interface
=========================================================
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut
Now our router interface have an ip address again and port is also up now we can
start restore process.
Router#copy tftp running-config
Address or name of remote host []? 1.0.0.2
Source filename []? R1-config
Destination filename [running-config]?
Accessing tftp://1.0.0.2/R1-config....
Loading R1-config from 1.0.0.2: !
[OK - 552 bytes]
552 bytes copied in 3.003 secs (183 bytes/sec)
R1#
%SYS-5-CONFIG_I: Configured from console by console
Now check whether we have successfully able to restore our IOS configuration
file or not.
R1#show run
Building configuration...
Current configuration : 552 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/0
ip address 1.0.0.1 255.0.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
line con 0
password redhat123
login
!
line aux 0
!
line vty 0
password redhat
login
line vty 1 4
login
!
end
--More--
You can clearly see that now our router is as it was in start.Everything come
back as it is.same password for console port,as it is configuration for telnet.
everything as it is.
Hence we have successfully restore our router configuration..
========================================================
this is configuration with
troubleshooting
for to see how
the TFTP server
running Thank you..!!!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
line con 0
password redhat123
login
!
line aux 0
!
line vty 0
password redhat
login
line vty 1 4
login
!
end
--More--
You can clearly see that now our router is as it was in start.Everything come
back as it is.same password for console port,as it is configuration for telnet.
everything as it is.
Hence we have successfully restore our router configuration..
========================================================
this is configuration with
troubleshooting
for to see how
the TFTP server
running Thank you..!!!

More Related Content

What's hot

Modul dhcp server menggunakan mikrotik os
Modul dhcp server menggunakan mikrotik osModul dhcp server menggunakan mikrotik os
Modul dhcp server menggunakan mikrotik os
Een Pahlefi
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands Overview
Muhammed Niyas
 
Tuned
TunedTuned
12c for Developers - Feb 2014
12c for Developers - Feb 201412c for Developers - Feb 2014
12c for Developers - Feb 2014
Connor McDonald
 
How to Save, backup and restore IOS on Cisco router
How to Save, backup and restore IOS on Cisco routerHow to Save, backup and restore IOS on Cisco router
How to Save, backup and restore IOS on Cisco router
tcpipguru
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
Guntaka Reddy
 
Powervc upgrade from_1.3.0.2_to_1.3.2.0
Powervc upgrade from_1.3.0.2_to_1.3.2.0Powervc upgrade from_1.3.0.2_to_1.3.2.0
Powervc upgrade from_1.3.0.2_to_1.3.2.0
Gobinath Panchavarnam
 
Complex stories about Sqooping PostgreSQL data
Complex stories about Sqooping PostgreSQL dataComplex stories about Sqooping PostgreSQL data
Complex stories about Sqooping PostgreSQL data
NTT DATA OSS Professional Services
 
Thomas+Niewel+ +Oracletuning
Thomas+Niewel+ +OracletuningThomas+Niewel+ +Oracletuning
Thomas+Niewel+ +Oracletuning
afa reg
 
Armboot process zeelogic
Armboot process zeelogicArmboot process zeelogic
Armboot process zeelogic
Aleem Shariff
 
Shak larry-jeder-perf-and-tuning-summit14-part1-final
Shak larry-jeder-perf-and-tuning-summit14-part1-finalShak larry-jeder-perf-and-tuning-summit14-part1-final
Shak larry-jeder-perf-and-tuning-summit14-part1-final
Tommy Lee
 
How to shutdown and power up of the netapp cluster mode storage system
How to shutdown and power up of the netapp cluster mode storage systemHow to shutdown and power up of the netapp cluster mode storage system
How to shutdown and power up of the netapp cluster mode storage system
Saroj Sahu
 
How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...
How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...
How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...
Saroj Sahu
 
OakTable World Sep14 clonedb
OakTable World Sep14 clonedb OakTable World Sep14 clonedb
OakTable World Sep14 clonedb
Connor McDonald
 
DNS windows server(2008R2) & linux(SLES 11)
DNS windows server(2008R2) & linux(SLES 11)DNS windows server(2008R2) & linux(SLES 11)
DNS windows server(2008R2) & linux(SLES 11)
Tola LENG
 
Ultimate Unix Meetup Presentation
Ultimate Unix Meetup PresentationUltimate Unix Meetup Presentation
Ultimate Unix Meetup Presentation
JacobMenke1
 
Install tomcat 5.5 in debian os and deploy war file
Install tomcat 5.5 in debian os and deploy war fileInstall tomcat 5.5 in debian os and deploy war file
Install tomcat 5.5 in debian os and deploy war file
Nguyen Cao Hung
 
MySQLinsanity
MySQLinsanityMySQLinsanity
MySQLinsanity
Stanley Huang
 
Basic security & info
Basic security & infoBasic security & info
Basic security & info
Tola LENG
 

What's hot (19)

Modul dhcp server menggunakan mikrotik os
Modul dhcp server menggunakan mikrotik osModul dhcp server menggunakan mikrotik os
Modul dhcp server menggunakan mikrotik os
 
Router Commands Overview
Router Commands OverviewRouter Commands Overview
Router Commands Overview
 
Tuned
TunedTuned
Tuned
 
12c for Developers - Feb 2014
12c for Developers - Feb 201412c for Developers - Feb 2014
12c for Developers - Feb 2014
 
How to Save, backup and restore IOS on Cisco router
How to Save, backup and restore IOS on Cisco routerHow to Save, backup and restore IOS on Cisco router
How to Save, backup and restore IOS on Cisco router
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
Powervc upgrade from_1.3.0.2_to_1.3.2.0
Powervc upgrade from_1.3.0.2_to_1.3.2.0Powervc upgrade from_1.3.0.2_to_1.3.2.0
Powervc upgrade from_1.3.0.2_to_1.3.2.0
 
Complex stories about Sqooping PostgreSQL data
Complex stories about Sqooping PostgreSQL dataComplex stories about Sqooping PostgreSQL data
Complex stories about Sqooping PostgreSQL data
 
Thomas+Niewel+ +Oracletuning
Thomas+Niewel+ +OracletuningThomas+Niewel+ +Oracletuning
Thomas+Niewel+ +Oracletuning
 
Armboot process zeelogic
Armboot process zeelogicArmboot process zeelogic
Armboot process zeelogic
 
Shak larry-jeder-perf-and-tuning-summit14-part1-final
Shak larry-jeder-perf-and-tuning-summit14-part1-finalShak larry-jeder-perf-and-tuning-summit14-part1-final
Shak larry-jeder-perf-and-tuning-summit14-part1-final
 
How to shutdown and power up of the netapp cluster mode storage system
How to shutdown and power up of the netapp cluster mode storage systemHow to shutdown and power up of the netapp cluster mode storage system
How to shutdown and power up of the netapp cluster mode storage system
 
How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...
How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...
How to Shutdown Netapp Cluster Mode Storage System with Multi-Node Cluster (6...
 
OakTable World Sep14 clonedb
OakTable World Sep14 clonedb OakTable World Sep14 clonedb
OakTable World Sep14 clonedb
 
DNS windows server(2008R2) & linux(SLES 11)
DNS windows server(2008R2) & linux(SLES 11)DNS windows server(2008R2) & linux(SLES 11)
DNS windows server(2008R2) & linux(SLES 11)
 
Ultimate Unix Meetup Presentation
Ultimate Unix Meetup PresentationUltimate Unix Meetup Presentation
Ultimate Unix Meetup Presentation
 
Install tomcat 5.5 in debian os and deploy war file
Install tomcat 5.5 in debian os and deploy war fileInstall tomcat 5.5 in debian os and deploy war file
Install tomcat 5.5 in debian os and deploy war file
 
MySQLinsanity
MySQLinsanityMySQLinsanity
MySQLinsanity
 
Basic security & info
Basic security & infoBasic security & info
Basic security & info
 

Similar to Backup and restore router configuration

managing your network environment
managing your network environmentmanaging your network environment
managing your network environment
scooby_doo
 
05 module managing your network enviornment
05  module managing your network enviornment05  module managing your network enviornment
05 module managing your network enviornment
Asif
 
CCNA_LAB_MANUAL_part1.pptx
CCNA_LAB_MANUAL_part1.pptxCCNA_LAB_MANUAL_part1.pptx
CCNA_LAB_MANUAL_part1.pptx
SanathKumarV3
 
Setting packet tracer
Setting packet tracerSetting packet tracer
Setting packet tracer
Badori San
 
Chapter5ccna
Chapter5ccnaChapter5ccna
Chapter5ccna
ernestlithur
 
Chapter5ccna
Chapter5ccnaChapter5ccna
Chapter5ccna
robertoxe
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
EZREIG OMAR
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
Fredrick Hall
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
Guntaka Reddy
 
CCNA CheatSheet
CCNA CheatSheetCCNA CheatSheet
CCNA CheatSheet
Eng. Emad Al-Atoum
 
VESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.pptVESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.ppt
zmulani8
 
VESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.pptVESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.ppt
zmulani8
 
VESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.pptVESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.ppt
zmulani8
 
StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce
StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce
StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce
StackIQ
 
Stacki - The1600+ Server Journey
Stacki - The1600+ Server JourneyStacki - The1600+ Server Journey
Stacki - The1600+ Server Journey
Salesforce Engineering
 
In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network security
Thanawan Tuamyim
 
CCNA ALL IN ONE
CCNA ALL IN ONE CCNA ALL IN ONE
CCNA ALL IN ONE
Sripati Mahapatra
 
Chapter5ccna
Chapter5ccnaChapter5ccna
Chapter5ccna
Lakshan Perera
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
Ajaigururaj R
 
Manage CISCO IOS
Manage CISCO IOSManage CISCO IOS
Manage CISCO IOS
anilinvns
 

Similar to Backup and restore router configuration (20)

managing your network environment
managing your network environmentmanaging your network environment
managing your network environment
 
05 module managing your network enviornment
05  module managing your network enviornment05  module managing your network enviornment
05 module managing your network enviornment
 
CCNA_LAB_MANUAL_part1.pptx
CCNA_LAB_MANUAL_part1.pptxCCNA_LAB_MANUAL_part1.pptx
CCNA_LAB_MANUAL_part1.pptx
 
Setting packet tracer
Setting packet tracerSetting packet tracer
Setting packet tracer
 
Chapter5ccna
Chapter5ccnaChapter5ccna
Chapter5ccna
 
Chapter5ccna
Chapter5ccnaChapter5ccna
Chapter5ccna
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
CCNA CheatSheet
CCNA CheatSheetCCNA CheatSheet
CCNA CheatSheet
 
VESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.pptVESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.ppt
 
VESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.pptVESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.ppt
 
VESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.pptVESIT WORKSHOP SIMULATIONS.ppt
VESIT WORKSHOP SIMULATIONS.ppt
 
StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce
StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce
StackiFest16: Stacki 1600+ Server Journey - Dave Peterson, Salesforce
 
Stacki - The1600+ Server Journey
Stacki - The1600+ Server JourneyStacki - The1600+ Server Journey
Stacki - The1600+ Server Journey
 
In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network security
 
CCNA ALL IN ONE
CCNA ALL IN ONE CCNA ALL IN ONE
CCNA ALL IN ONE
 
Chapter5ccna
Chapter5ccnaChapter5ccna
Chapter5ccna
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
Manage CISCO IOS
Manage CISCO IOSManage CISCO IOS
Manage CISCO IOS
 

Recently uploaded

Standardized tool for Intelligence test.
Standardized tool for Intelligence test.Standardized tool for Intelligence test.
Standardized tool for Intelligence test.
deepaannamalai16
 
Electric Fetus - Record Store Scavenger Hunt
Electric Fetus - Record Store Scavenger HuntElectric Fetus - Record Store Scavenger Hunt
Electric Fetus - Record Store Scavenger Hunt
RamseyBerglund
 
BIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptx
BIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptxBIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptx
BIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptx
RidwanHassanYusuf
 
LAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UP
LAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UPLAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UP
LAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UP
RAHUL
 
Présentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptx
Présentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptxPrésentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptx
Présentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptx
siemaillard
 
A Independência da América Espanhola LAPBOOK.pdf
A Independência da América Espanhola LAPBOOK.pdfA Independência da América Espanhola LAPBOOK.pdf
A Independência da América Espanhola LAPBOOK.pdf
Jean Carlos Nunes Paixão
 
BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...
BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...
BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...
Nguyen Thanh Tu Collection
 
Nutrition Inc FY 2024, 4 - Hour Training
Nutrition Inc FY 2024, 4 - Hour TrainingNutrition Inc FY 2024, 4 - Hour Training
Nutrition Inc FY 2024, 4 - Hour Training
melliereed
 
RHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem students
RHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem studentsRHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem students
RHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem students
Himanshu Rai
 
How to Setup Warehouse & Location in Odoo 17 Inventory
How to Setup Warehouse & Location in Odoo 17 InventoryHow to Setup Warehouse & Location in Odoo 17 Inventory
How to Setup Warehouse & Location in Odoo 17 Inventory
Celine George
 
Pharmaceutics Pharmaceuticals best of brub
Pharmaceutics Pharmaceuticals best of brubPharmaceutics Pharmaceuticals best of brub
Pharmaceutics Pharmaceuticals best of brub
danielkiash986
 
Philippine Edukasyong Pantahanan at Pangkabuhayan (EPP) Curriculum
Philippine Edukasyong Pantahanan at Pangkabuhayan (EPP) CurriculumPhilippine Edukasyong Pantahanan at Pangkabuhayan (EPP) Curriculum
Philippine Edukasyong Pantahanan at Pangkabuhayan (EPP) Curriculum
MJDuyan
 
A Visual Guide to 1 Samuel | A Tale of Two Hearts
A Visual Guide to 1 Samuel | A Tale of Two HeartsA Visual Guide to 1 Samuel | A Tale of Two Hearts
A Visual Guide to 1 Samuel | A Tale of Two Hearts
Steve Thomason
 
مصحف القراءات العشر أعد أحرف الخلاف سمير بسيوني.pdf
مصحف القراءات العشر   أعد أحرف الخلاف سمير بسيوني.pdfمصحف القراءات العشر   أعد أحرف الخلاف سمير بسيوني.pdf
مصحف القراءات العشر أعد أحرف الخلاف سمير بسيوني.pdf
سمير بسيوني
 
RESULTS OF THE EVALUATION QUESTIONNAIRE.pptx
RESULTS OF THE EVALUATION QUESTIONNAIRE.pptxRESULTS OF THE EVALUATION QUESTIONNAIRE.pptx
RESULTS OF THE EVALUATION QUESTIONNAIRE.pptx
zuzanka
 
B. Ed Syllabus for babasaheb ambedkar education university.pdf
B. Ed Syllabus for babasaheb ambedkar education university.pdfB. Ed Syllabus for babasaheb ambedkar education university.pdf
B. Ed Syllabus for babasaheb ambedkar education university.pdf
BoudhayanBhattachari
 
What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...
What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...
What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...
GeorgeMilliken2
 
How to Make a Field Mandatory in Odoo 17
How to Make a Field Mandatory in Odoo 17How to Make a Field Mandatory in Odoo 17
How to Make a Field Mandatory in Odoo 17
Celine George
 
Beyond Degrees - Empowering the Workforce in the Context of Skills-First.pptx
Beyond Degrees - Empowering the Workforce in the Context of Skills-First.pptxBeyond Degrees - Empowering the Workforce in the Context of Skills-First.pptx
Beyond Degrees - Empowering the Workforce in the Context of Skills-First.pptx
EduSkills OECD
 
Walmart Business+ and Spark Good for Nonprofits.pdf
Walmart Business+ and Spark Good for Nonprofits.pdfWalmart Business+ and Spark Good for Nonprofits.pdf
Walmart Business+ and Spark Good for Nonprofits.pdf
TechSoup
 

Recently uploaded (20)

Standardized tool for Intelligence test.
Standardized tool for Intelligence test.Standardized tool for Intelligence test.
Standardized tool for Intelligence test.
 
Electric Fetus - Record Store Scavenger Hunt
Electric Fetus - Record Store Scavenger HuntElectric Fetus - Record Store Scavenger Hunt
Electric Fetus - Record Store Scavenger Hunt
 
BIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptx
BIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptxBIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptx
BIOLOGY NATIONAL EXAMINATION COUNCIL (NECO) 2024 PRACTICAL MANUAL.pptx
 
LAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UP
LAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UPLAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UP
LAND USE LAND COVER AND NDVI OF MIRZAPUR DISTRICT, UP
 
Présentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptx
Présentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptxPrésentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptx
Présentationvvvvvvvvvvvvvvvvvvvvvvvvvvvv2.pptx
 
A Independência da América Espanhola LAPBOOK.pdf
A Independência da América Espanhola LAPBOOK.pdfA Independência da América Espanhola LAPBOOK.pdf
A Independência da América Espanhola LAPBOOK.pdf
 
BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...
BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...
BÀI TẬP BỔ TRỢ TIẾNG ANH LỚP 9 CẢ NĂM - GLOBAL SUCCESS - NĂM HỌC 2024-2025 - ...
 
Nutrition Inc FY 2024, 4 - Hour Training
Nutrition Inc FY 2024, 4 - Hour TrainingNutrition Inc FY 2024, 4 - Hour Training
Nutrition Inc FY 2024, 4 - Hour Training
 
RHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem students
RHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem studentsRHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem students
RHEOLOGY Physical pharmaceutics-II notes for B.pharm 4th sem students
 
How to Setup Warehouse & Location in Odoo 17 Inventory
How to Setup Warehouse & Location in Odoo 17 InventoryHow to Setup Warehouse & Location in Odoo 17 Inventory
How to Setup Warehouse & Location in Odoo 17 Inventory
 
Pharmaceutics Pharmaceuticals best of brub
Pharmaceutics Pharmaceuticals best of brubPharmaceutics Pharmaceuticals best of brub
Pharmaceutics Pharmaceuticals best of brub
 
Philippine Edukasyong Pantahanan at Pangkabuhayan (EPP) Curriculum
Philippine Edukasyong Pantahanan at Pangkabuhayan (EPP) CurriculumPhilippine Edukasyong Pantahanan at Pangkabuhayan (EPP) Curriculum
Philippine Edukasyong Pantahanan at Pangkabuhayan (EPP) Curriculum
 
A Visual Guide to 1 Samuel | A Tale of Two Hearts
A Visual Guide to 1 Samuel | A Tale of Two HeartsA Visual Guide to 1 Samuel | A Tale of Two Hearts
A Visual Guide to 1 Samuel | A Tale of Two Hearts
 
مصحف القراءات العشر أعد أحرف الخلاف سمير بسيوني.pdf
مصحف القراءات العشر   أعد أحرف الخلاف سمير بسيوني.pdfمصحف القراءات العشر   أعد أحرف الخلاف سمير بسيوني.pdf
مصحف القراءات العشر أعد أحرف الخلاف سمير بسيوني.pdf
 
RESULTS OF THE EVALUATION QUESTIONNAIRE.pptx
RESULTS OF THE EVALUATION QUESTIONNAIRE.pptxRESULTS OF THE EVALUATION QUESTIONNAIRE.pptx
RESULTS OF THE EVALUATION QUESTIONNAIRE.pptx
 
B. Ed Syllabus for babasaheb ambedkar education university.pdf
B. Ed Syllabus for babasaheb ambedkar education university.pdfB. Ed Syllabus for babasaheb ambedkar education university.pdf
B. Ed Syllabus for babasaheb ambedkar education university.pdf
 
What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...
What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...
What is Digital Literacy? A guest blog from Andy McLaughlin, University of Ab...
 
How to Make a Field Mandatory in Odoo 17
How to Make a Field Mandatory in Odoo 17How to Make a Field Mandatory in Odoo 17
How to Make a Field Mandatory in Odoo 17
 
Beyond Degrees - Empowering the Workforce in the Context of Skills-First.pptx
Beyond Degrees - Empowering the Workforce in the Context of Skills-First.pptxBeyond Degrees - Empowering the Workforce in the Context of Skills-First.pptx
Beyond Degrees - Empowering the Workforce in the Context of Skills-First.pptx
 
Walmart Business+ and Spark Good for Nonprofits.pdf
Walmart Business+ and Spark Good for Nonprofits.pdfWalmart Business+ and Spark Good for Nonprofits.pdf
Walmart Business+ and Spark Good for Nonprofits.pdf
 

Backup and restore router configuration

  • 1. Backup and Restore router configuration file using TFTP server with Packet Tracer -Cisco CCNA ================================================== Home › Networking › Backup and Restore router configuration file using TFTP server with Packet Tracer -Cisco CCNA › ================================================== Here you can clearly see the router and TFTP Server in below diagram. I will show you how to take backup of below router configuration file whose ip address is 1.0.0.1 using TFTP Server whose ip address is 1.0.0.2. ================================================== Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname R1 R1(config)#line vty 0 R1(config-line)#password redhat R1(config-line)#login R1(config-line)#exit R1(config)#line console 0 R1(config-line)#password redhat123 R1(config-line)#login R1(config-line)#exit R1(config)#int fa0/0 R1(config-if)#ip address 1.0.0.1 255.0.0.0 R1(config-if)#no shut ================================================== Now took a look at the running configuration using "show run" command.This is the configuration active at the moment. R1#show run Building configuration... Current configuration : 552 bytes ! version 12.4 no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption ! hostname R1 ! spanning-tree mode pvst ! interface FastEthernet0/0 ip address 1.0.0.1 255.0.0.0 duplex auto speed auto ! interface FastEthernet0/1 no ip address duplex auto speed auto shutdown ! interface Vlan1 no ip address shutdown ! ip classless ! line con 0 password redhat123 login
  • 2. ! line aux 0 ! line vty 0 password redhat login line vty 1 4 login ! end ========================================================= Now using show version or show flash command we can see the router ios file. R1#show version Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2007 by Cisco Systems, Inc. Compiled Wed 18-Jul-07 04:52 by pt_team ROM: System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1) System returned to ROM by power-on System image file is "flash:c1841-advipservicesk9-mz.124-15.T1.bin" Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory. Processor board ID FTX0947Z18E M860 processor: part number 0, mask 49 2 FastEthernet/IEEE 802.3 interface(s) 191K bytes of NVRAM. 63488K bytes of ATA CompactFlash (Read/Write) Configuration register is 0x2102 ========================================================= R1#show flash System flash directory: File Length Name/status 3 33591768 c1841-advipservicesk9-mz.124-15.T1.bin 2 28282 sigdef-category.xml 1 227537 sigdef-default.xml [33847587 bytes used, 30168797 available, 64016384 total] 63488K bytes of processor board System flash (Read/Write) ======================================================= Now we are going to take backup of router IOS on tftp Server using below mentioned command. R1#copy flash tftp Source filename []? c1841-advipservicesk9-mz.124-15.T1.bin Address or name of remote host []? 1.0.0.2 Destination filename [c1841-advipservicesk9-mz.124-15.T1.bin]? Writing c1841-advipservicesk9-mz.124- 15.T1.bin....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  • 3. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! [OK - 33591768 bytes] 33591768 bytes copied in 5.796 secs (5795000 bytes/sec) R1# Now copy running-config to startup-config. R1#copy run start Destination filename [startup-config]? Building configuration... [OK] Then copy the startup-config file to tftp server machine so that we can get it back from there whenever we need. R1#copy startup-config tftp Address or name of remote host []? 1.0.0.2 Destination filename [R1-confg]? R1-config Writing startup-config...!! [OK - 552 bytes] 552 bytes copied in 0.001 secs (552000 bytes/sec) Now Go To TFTP Server and Verify: in the above image you can clearly see we have successfully taken backup of Router IOS to tftp Server and router configuration also to tftp server. Now after Backup it's time to test recovery or restore. i.e we will test how to restore router configuration. Here in this tutorial we will discuss about how to restore back router configuration from tftp server. To test restore configuration of router first we need to first erase the configuration on routers. ======================================================== R1#erase startup-config Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] [OK] Erase of nvram: complete %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram After erasing check whether you have successfully erased or not. ======================================================== R1#show startup-config startup-config is not present R1# Now you can clearly see there is no output,means no configuration remains now.It means everything has been erased.
  • 4. Note:After reload i have a brand new router.Means all previous configuration lost. ======================================================== R1#reload Proceed with reload? [confirm] System Bootstrap, Version 12.3(8r)T8, RELEASE SOFTWARE (fc1) Cisco 1841 (revision 5.0) with 114688K/16384K bytes of memory. Self decompressing the image : ########################################################################## [OK] Restricted Rights Legend --- System Configuration Dialog --- Continue with configuration dialog? [yes/no]: no Press RETURN to get started! Router> Now check your configuration after reload. Router>enable Router#show run Building configuration... Current configuration : 489 bytes ! version 12.4 no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption ! hostname Router ! ! ! spanning-tree mode pvst ! interface FastEthernet0/0 no ip address duplex auto speed auto shutdown ! interface FastEthernet0/1 no ip address duplex auto speed auto shutdown ! interface Vlan1 no ip address shutdown ! ip classless Now you can clearly see no ip, no hostaname, everything have been removed from router previous configuration. so now we have to assign ip address again to have a fresh start to connect with tftp so that we recover our configuration file back as it was previous. ======================================================== So we are going to get back our IOS configuration file from tftp server to router using below command. =========================================================
  • 5. Router#copy tftp running-config Address or name of remote host []? 1.0.0.2 Source filename []? R1-config Destination filename [running-config]? Accessing tftp://1.0.0.2/R1-config........ %Error opening tftp://1.0.0.2/R1-config (Timed out) Router# You can clearly see that copy from tftp server failed because router interface is down,we have to manualy up router interface ========================================================= Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#int fa0/0 Router(config-if)#ip address 1.0.0.1 255.0.0.0 Router(config-if)#no shut Now our router interface have an ip address again and port is also up now we can start restore process. Router#copy tftp running-config Address or name of remote host []? 1.0.0.2 Source filename []? R1-config Destination filename [running-config]? Accessing tftp://1.0.0.2/R1-config.... Loading R1-config from 1.0.0.2: ! [OK - 552 bytes] 552 bytes copied in 3.003 secs (183 bytes/sec) R1# %SYS-5-CONFIG_I: Configured from console by console Now check whether we have successfully able to restore our IOS configuration file or not. R1#show run Building configuration... Current configuration : 552 bytes ! version 12.4 no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption ! hostname R1 ! ! spanning-tree mode pvst ! interface FastEthernet0/0 ip address 1.0.0.1 255.0.0.0 duplex auto speed auto ! interface FastEthernet0/1 no ip address duplex auto speed auto shutdown !
  • 6. interface Vlan1 no ip address shutdown ! ip classless ! ! line con 0 password redhat123 login ! line aux 0 ! line vty 0 password redhat login line vty 1 4 login ! end --More-- You can clearly see that now our router is as it was in start.Everything come back as it is.same password for console port,as it is configuration for telnet. everything as it is. Hence we have successfully restore our router configuration.. ======================================================== this is configuration with troubleshooting for to see how the TFTP server running Thank you..!!!
  • 7. interface Vlan1 no ip address shutdown ! ip classless ! ! line con 0 password redhat123 login ! line aux 0 ! line vty 0 password redhat login line vty 1 4 login ! end --More-- You can clearly see that now our router is as it was in start.Everything come back as it is.same password for console port,as it is configuration for telnet. everything as it is. Hence we have successfully restore our router configuration.. ======================================================== this is configuration with troubleshooting for to see how the TFTP server running Thank you..!!!