SlideShare a Scribd company logo
1 of 28
Download to read offline
A Dell EMC Deployment and Configuration Guide
Dell Networking Switch CLI Examples
A deployment guide for Dell Networking switches
2 Dell Networking Switch CLI Examples
Revisions
Date Description Authors
2014 Initial release John Wroblewski
Enterprise Technologist - Networking
Copyright © 2014-2017 Dell Inc. or its subsidiaries. All Rights Reserved.
Except as stated below, no part of this document may be reproduced, distributed or transmitted in any form or
by any means, without express permission of Dell.
You may distribute this document within your company or organization only, without alteration of its contents.
THIS DOCUMENT IS PROVIDED “AS-IS”, AND WITHOUT ANY WARRANTY, EXPRESS OR IMPLIED.
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
SPECIFICALLY DISCLAIMED. PRODUCT WARRANTIES APPLICABLE TO THE DELL PRODUCTS
DESCRIBED IN THIS DOCUMENT MAY BE FOUND AT: http://www.dell.com/learn/us/en/vn/terms-of-sale-
commercial-and-public-sector-warranties
Performance of network reference architectures discussed in this document may vary with differing
deployment conditions, network loads, and the like. Third party products may be included in reference
architectures for the convenience of the reader. Inclusion of such third party products does not necessarily
constitute Dell’s recommendation of those products. Please consult your Dell representative for additional
information.
Trademarks used in this text: Dell™, the Dell logo, Dell Boomi™, PowerEdge™, PowerVault™,
PowerConnect™, OpenManage™, EqualLogic™, Compellent™, KACE™, FlexAddress™, Force10™ and
Vostro™ are trademarks of Dell Inc. EMC VNX®, and EMC Unisphere® are registered trademarks of Dell.
Other Dell trademarks may be used in this document. Cisco Nexus®, Cisco MDS®, Cisco NX-0S®, and other
Cisco Catalyst® are registered trademarks of Cisco System Inc. Intel®, Pentium®, Xeon®, Core® and
Celeron® are registered trademarks of Intel Corporation in the U.S. and other countries. AMD® is a
registered trademark and AMD Opteron™, AMD Phenom™ and AMD Sempron™ are trademarks of
Advanced Micro Devices, Inc. Microsoft®, Windows®, Windows Server®, Internet Explorer®, MS-DOS®,
Windows Vista® and Active Directory® are either trademarks or registered trademarks of Microsoft
Corporation in the United States and/or other countries. Red Hat® and Red Hat® Enterprise Linux® are
registered trademarks of Red Hat, Inc. in the United States and/or other countries. Novell® and SUSE® are
registered trademarks of Novell Inc. in the United States and other countries. Oracle® is a registered
trademark of Oracle Corporation and/or its affiliates. VMware®, Virtual SMP®, vMotion®, vCenter® and
vSphere® are registered trademarks or trademarks of VMware, Inc. in the United States or other countries.
IBM® is a registered trademark of International Business Machines Corporation. Broadcom® and
NetXtreme® are registered trademarks of QLogic is a registered trademark of QLogic Corporation. Other
trademarks and trade names may be used in this document to refer to either the entities claiming the marks
and/or names or their products and are the property of their respective owners. Dell disclaims proprietary
interest in the marks and names of others.
3 Dell Networking Switch CLI Examples
Table of contents
Revisions.............................................................................................................................................................................2
Introduction .........................................................................................................................................................................4
1 N-Series Default Configuration.....................................................................................................................................6
2 N-Series Configuration with a Port Channel to connect to another Switch supporting a VoIP Solution......................7
3 N-Series Configuration with MLAG (Virtual Port Channel) ..........................................................................................9
4 S-Series Configuration for Access with Port Channel................................................................................................12
5 S-Series Configuration for TOR or Core – Virtual Link Trunk ....................................................................................18
6 Conclusion..................................................................................................................................................................28
4 Dell Networking Switch CLI Examples
Introduction
The Dell Networking Switches provide the feature sets required to construct redundant, reliable, Active /
Active Fabrics for today’s Data Center and Campus Networks. While the Dell Networking N-Series Campus
Switches can be configured (after initially setting a management IP) using a Web-Based GUI, Customers may
prefer to configure the switches using a console connection and the Command Line Interface. The Dell
Networking Data Center Switches are always configured using a Command Line Interface. The dominate
command line interface in Networking was originally developed and marketed by Cisco. Customers familiar
with the Cisco CLI typically inquire about the Dell Networking Command Line Interface and the similarity to
the Cisco CLI. Dell Networking Switches support a Command Line Interface that is very similar to the Cisco
CLI. We use the term, Industry Standard Command Line Interface. This makes the transition from Customer
familiar with Cisco to Dell Networking potentially seamless without the requirement for additional training. The
‘look and feel’ of the Dell Networking CLI is very familiar to most Network Engineers but it is not exactly the
same and there are some feature set and protocol differences due to the proprietary nature of some of the
Cisco Feature set. Dell Networking provides standards based features and protocols, therefore in our
examples we will use interoperable standards.
This document will not attempt to cover all feature sets and protocols but will function as a way to begin a
Dell Networking configuration to produce an operating switch. The document will also not cover the protocol
differences between a Cisco deployed switch that might make use of proprietary protocols versus a Dell
Networking Standards based switch. We will briefly cover some of the protocols that maybe deployed in a
Cisco Network and the Dell equivalent Standards based protocols.
Protocols
These are some of the protocols that can be deployed in Networks. Since this is a starter document, we will
not cover more extensive and complex protocols. There are capabilities, terms, and protocols that are
standard and should not be confusing to experienced networking professionals. Let’s explore some of the
common terms and protocols.
Layer 2 Switching – A capability that forwards packets based on the destination MAC address where
both end-stations communicating are in the same broadcast domain.
Layer 3 Switching – A capability that forwards packets based on the higher layer protocol destination
address (Layer 3 in the OSI Model). This is across different Broadcast Domains
or Subnets.
Virtual LANs (VLAN) - A Broadcast Domain created at Layer 2. A virtualization of a Switch or switching
infrastructure. Inter-VLAN communication is through Layer 3 Switching or
Routing.
Link Aggregation - Binding one or more separate Ethernet links together to form a larger bandwidth
path that can be istributed for redundancy. Etherchannel, port-channel and LAG
are synonymous terms.
LACP - Link Aggregation Control Protocol, a protocol that dynamically configures Link
Aggregation.
5 Dell Networking Switch CLI Examples
Interface - A mode that specifies a port on a switch for applying configuration statements.
Switchport - An interface configuration term that places the port (configured interface) into
Layer 2 mode so that VLAN information can be configured.
Spanning-Tree - A protocol that provides protection to the switch and switching infrastructure from
network Loops while allowing redundant connections.
OSPF / EIGRP - Dynamic Routing Protocols that build information tables for switches to make
Layer 3 Switching or Routing decisions. OSPF is Standards based. EIGRP is
Cisco proprietary.
6 Dell Networking Switch CLI Examples
1 N-Series Default Configuration
This is an N-series Switch defaulted configuration. The defaulted configuration doesn’t show a lot of detail
and defaulted configuration parameters are not displayed. As the configuration changes (protocols are
changed from defaults or statements added), the CLI configuration will show more information.
In this initial configuration two additional configuration statements. An IP address was added to VLAN 1 to
allow the Web interface to be displayed and a new User was added with a Password and a Privilege of 15,
the highest.
!Current Configuration:
!System Description "Dell Networking N3024, 6.1.2.4, Linux 3.6.5-601418a5"
!System Software Version 6.1.2.4
!
configure
slot 1/0 1 ! Dell Networking N3024
stack
member 1 1 ! N3024
exit
interface vlan 1
ip address 10.5.5.1 255.255.255.0
exit
username "john" password 1c065ad7087eb8ce058b02e38654a2c4 privilege 15 encrypted
snmp-server engineid local 800002a203f8b1562b9ab2
exit
BEST PRACTICES
It is not recommended to use VLAN 1 for Data or Voice configurations. VLAN 1 can represent a security risk.
In the N-Series, VLAN is the default (by default the ‘native’ VLAN). Ports that are unassigned to other VLANs
are configured to VLAN1.
Tech Note: Voice over IP (VoIP) applications usually uses either LLDP or Cisco Discovery Protocol (CDP)
for the discovery of VoIP Devices. In the Dell Networking N-Series, LLDP and a CDP-like Protocol, ISDP
are enabled by default. ISDP is interoperable with Cisco CDP.
7 Dell Networking Switch CLI Examples
2 N-Series Configuration with a Port Channel to connect to
another Switch supporting a VoIP Solution.
This is a configuration that can be used for connecting to an aggregation switch and be used for supporting a
VoIP Solution. We use the term ‘Switchport general’ on the configured interfaces to support more than one
VLAN for VoIP and data traffic. In this configuration example, the Layer Two Class of Service was modified to
provide strict queuing for VoIP. The N-Series Voice VLAN feature is used to setup the switch for Voice and
QOS for Voice. This feature is globally enabled. The N-Series 2000 Switches are stacked in this example and
have a Port Channel (port channel 1) to an Aggregation Switch.
N-Series 2000P Configuration Example
!Current Configuration:
!System Description "Dell Networking N2048P, 6.0.1.3, Linux 3.6.5-320b2282"
!System Software Version 6.0.1.3
!
configure
vlan 152,160,194,401,421
exit
slot 1/0 9 ! Dell Networking N2048P
slot 2/0 8 ! Dell Networking N2024P
sntp unicast client enable
sntp server 10.100.200.1
clock timezone -5 minutes 0
stack
member 1 9 ! N2048P
member 2 7 ! N2024P
exit
no logging console
ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.100.200.1
interface vlan 1
ip address 10.100.200.201 255.255.254.0
exit
username "admin" password dec68e4501ce09a74284cb1bd03164a2 privilege 15
encrypted
voice vlan
ip ssh server
classofservice dot1p-mapping 5 5
cos-queue min-bandwidth 0 0 5 5 10 30 40
cos-queue strict 5
!
interface Gi1/0/1
switchport mode general
switchport general pvid 160
switchport general allowed vlan add 160
8 Dell Networking Switch CLI Examples
switchport general allowed vlan add 152 tagged
voice vlan 152
voice vlan auth disable
exit
!
interface Gi1/0/2
switchport mode general
switchport general pvid 160
switchport general allowed vlan add 160
switchport general allowed vlan add 152 tagged
voice vlan 152
voice vlan auth disable
exit
!
interface Te1/0/1
channel-group 1 mode active
switchport mode trunk
switchport trunk allowed vlan 1,152,160,194,401,421
exit
!
interface Gi2/0/1
switchport mode general
switchport general pvid 160
switchport general allowed vlan add 160
switchport general allowed vlan add 152 tagged
voice vlan 152
voice vlan auth disable
exit
!
interface Te2/0/1
channel-group 1 mode active
exit
!
interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan 1,152,160,194,401,421
exit
snmp-server engineid local 800002a203001ec9ded907
enable password dec68e4501ce09a74284cb1bd03164a2 encrypted
exit
9 Dell Networking Switch CLI Examples
3 N-Series Configuration with MLAG (Virtual Port Channel)
The Dell Networking N-Series can provide a Layer Two Active/ Active construct that provides redundancy,
resiliency and performance to attached switches and devices without Spanning-Tree blocking ports. This
capability is becoming a required feature for Campus Networks as the importance of the Campus
infrastructure grows. In the VPC Configuration for MLAG, Spanning-Tree is disabled. The S-Series 60 switch
configuration that follows was attached to the MLAG configuration represented here via S-60 ports 0/46-47 in
Port Channel 1. This S-60 Port Channel was connected to Port Channel 100 in this N-3000 Series
Configuration.
This is an example of a MLAG N-Series 3000 Switch. This is the proposed topology.
MLAG –N3000 series swtich
!Current Configuration:
!System Description "Dell Networking N3024P, 6.1.2.4, Linux 3.6.5-601418a5"
!System Software Version 6.1.2.4
!
configure
vlan 5,7,100
exit
hostname "John3024P_Dot1"
slot 1/0 6 ! Dell Networking N3024P
stack
member 1 3 ! N3024P
exit
interface out-of-band
ip address 10.168.1.1 255.255.255.0 0.0.0.0
exit
interface vlan 1
ip address dhcp
10 Dell Networking Switch CLI Examples
exit
interface vlan 5
ip address 10.5.5.2 255.255.255.0
exit
interface vlan 7
ip address 10.7.7.2 255.255.255.0
exit
interface vlan 100
ip address 10.100.100.1 255.255.255.0
exit
username "john" password 9c91519328647000f9be49ebe9f7c939 privilege 15 encrypted
exit
udld enable
!
interface Gi1/0/1
switchport access vlan 5
exit
!
interface Gi1/0/2
switchport access vlan 5
exit
!
interface Gi1/0/3
switchport access vlan 5
exit
!
interface Gi1/0/4
switchport access vlan 5
exit
!
interface Gi1/0/5
switchport access vlan 100
exit
!
interface Gi1/0/9
switchport access vlan 100
exit
!
interface Gi1/0/10
switchport mode trunk
switchport trunk allowed vlan 5,7,100
exit
!
interface Gi1/0/22
channel-group 1 mode active
spanning-tree disable
exit
11 Dell Networking Switch CLI Examples
!
interface Gi1/0/23
channel-group 100 mode active
spanning-tree disable
exit
!
interface Gi1/0/24
channel-group 100 mode active
spanning-tree disable
exit
!
interface port-channel 1
spanning-tree disable
switchport mode trunk
switchport trunk native vlan 5
switchport trunk allowed vlan 5,7
vpc 1
exit
!
interface port-channel 100
spanning-tree disable
switchport mode trunk
switchport trunk allowed vlan 5,7
vpc peer-link
exit
interface vlan 5
exit
interface vlan 7
exit
snmp-server engineid local 800002a203f8b15633f60a
feature vpc
vpc domain 1
role priority 1
peer-keepalive enable
peer-keepalive destination 10.100.100.254 source 10.100.100.1
peer detection enable
exit
12 Dell Networking Switch CLI Examples
4 S-Series Configuration for Access with Port Channel
The S-Series 1Gb switches are excellent platforms for the access layer in the data center capable of
supporting 1Gb attached servers at line rate with 10Gb uplink capability for attached to Dell Networking Active
Fabric Cores or Top-of-Rack Solutions. S-Series switches based on Dell Networking FTOS are configured
slightly differently than the N-Series DNOS 6 Switches. The major difference is that in Dell Networking FTOS,
the interfaces are assigned into the VLANs (a configuration section ‘interface vlan’) versus VLANs being
assigned to ‘interface port’ sections of the configuration. One other difference, Dell Networking FTOS uses
the configuration term ‘Hybrid’ to place a port into a mode where multiple VLANs can be attached for VoIP
applications. We will not cover that in this configuration example. This configuration was used to attach to a
N-Series 3000 MLAG Aggregation using Port Channel 1.
Tech Note: In Dell Networking FTOS, Spanning–Tree is not enabled by default. When configuring a Dell
Networking FTOS Switch, select a Spanning-Tree Protocol (RSTP, PVST+, MST) and enable it on the
Switch.
Current Configuration ...
! Version 8.3.3.7
! Last configuration change at Wed Jan 14 20:04:24 2015 by default
! Startup-config last updated at Wed Jan 14 20:04:01 2015 by default
!
boot system stack-unit 0 primary tftp://192.168.128.1/FTOS-SC-8.3.3.4.bin
boot system stack-unit 0 secondary system: A:
boot system stack-unit 0 default system: A:
boot system gateway 192.168.128.1
!
redundancy auto-synchronize full
hardware watchdog
hostname Force10
protocol spanning-tree pvst
no disable
stack-unit 0 provision S60
interface GigabitEthernet 0/0
no ip address
switchport
no shutdown
interface GigabitEthernet 0/1
no ip address
switchport
no shutdown
interface GigabitEthernet 0/2
no ip address
switchport
no shutdown
interface GigabitEthernet 0/3
no ip address
13 Dell Networking Switch CLI Examples
switchport
no shutdown
interface GigabitEthernet 0/4
no ip address
shutdown
interface GigabitEthernet 0/5
no ip address
shutdown
interface GigabitEthernet 0/6
no ip address
shutdown
interface GigabitEthernet 0/7
no ip address
shutdown
interface GigabitEthernet 0/8
no ip address
shutdown
interface GigabitEthernet 0/9
no ip address
shutdown
interface GigabitEthernet 0/10
no ip address
shutdown
interface GigabitEthernet 0/11
no ip address
shutdown
interface GigabitEthernet 0/12
no ip address
shutdown
interface GigabitEthernet 0/13
no ip address
shutdown
interface GigabitEthernet 0/14
no ip address
shutdown
interface GigabitEthernet 0/15
no ip address
shutdown
interface GigabitEthernet 0/16
no ip address
shutdown
interface GigabitEthernet 0/17
no ip address
shutdown
interface GigabitEthernet 0/18
no ip address
shutdown
14 Dell Networking Switch CLI Examples
interface GigabitEthernet 0/19
no ip address
shutdown
interface GigabitEthernet 0/20
no ip address
shutdown
interface GigabitEthernet 0/21
no ip address
shutdown
interface GigabitEthernet 0/22
no ip address
shutdown
interface GigabitEthernet 0/23
no ip address
shutdown
interface GigabitEthernet 0/24
no ip address
shutdown
interface GigabitEthernet 0/25
no ip address
shutdown
interface GigabitEthernet 0/26
no ip address
shutdown
interface GigabitEthernet 0/27
no ip address
shutdown
interface GigabitEthernet 0/28
no ip address
shutdown
interface GigabitEthernet 0/29
no ip address
shutdown
interface GigabitEthernet 0/30
no ip address
shutdown
interface GigabitEthernet 0/31
no ip address
shutdown
interface GigabitEthernet 0/32
no ip address
shutdown
interface GigabitEthernet 0/33
no ip address
shutdown
interface GigabitEthernet 0/34
no ip address
15 Dell Networking Switch CLI Examples
shutdown
interface GigabitEthernet 0/35
no ip address
shutdown
interface GigabitEthernet 0/36
no ip address
shutdown
interface GigabitEthernet 0/37
no ip address
shutdown
interface GigabitEthernet 0/38
no ip address
shutdown
interface GigabitEthernet 0/39
no ip address
shutdown
interface GigabitEthernet 0/40
no ip address
shutdown
interface GigabitEthernet 0/41
no ip address
shutdown
interface GigabitEthernet 0/42
no ip address
shutdown
interface GigabitEthernet 0/43
no ip address
shutdown
interface GigabitEthernet 0/44
no ip address
shutdown
interface GigabitEthernet 0/45
no ip address
shutdown
interface GigabitEthernet 0/46
no ip address
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
interface GigabitEthernet 0/47
no ip address
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
interface ManagementEthernet 0/0
ip address 10.168.1.10/24
no shutdown
16 Dell Networking Switch CLI Examples
!
interface ManagementEthernet 1/0
no shutdown
interface ManagementEthernet 2/0
no shutdown
interface ManagementEthernet 3/0
no shutdown
interface ManagementEthernet 4/0
no shutdown
interface ManagementEthernet 5/0
no shutdown
interface ManagementEthernet 6/0
no shutdown
interface ManagementEthernet 7/0
no shutdown
interface ManagementEthernet 8/0
no shutdown
interface ManagementEthernet 9/0
no shutdown
interface ManagementEthernet 10/0
no shutdown
interface ManagementEthernet 11/0
no shutdown
interface Port-channel 1
no ip address
portmode hybrid
switchport
no shutdown
!
interface Vlan 1
!
interface Vlan 5
ip address 10.5.5.10/24
untagged GigabitEthernet 0/0-3
untagged Port-channel 1
no shutdown
!
interface Vlan 7
ip address 10.7.7.10/24
tagged Port-channel 1
no shutdown
!
line console 0
line vty 0
line vty 1
line vty 2
line vty 3
17 Dell Networking Switch CLI Examples
line vty 4
line vty 5
line vty 6
line vty 7
line vty 8
18 Dell Networking Switch CLI Examples
5 S-Series Configuration for TOR or Core – Virtual Link Trunk
The Dell Networking S-Series of 10Gb / 40Gb switches using Dell Networking Operating System 9 (DNOS 9)
offer the ability to provide a redundant, resilient, Active Fabric construct to connected switches, appliances,
systems. An Active Fabric based on VLT allows a pair of S-Series 10Gb / 40gb Switches to be viewed from
the connected devices as a single switch for Link Aggregation. This allows the connected links to operate in
an Active / Active manner without a Spanning-Tree block. In VLT, Spanning-Tree is still configured to prevent
downstream devices from impacting the Fabric due to a misconfiguration that results in a loop. VLT is a
flexible topology offering Layer 2 VLT Domains and Layer 3 constructs.
Tech Notes :
In Dell Networking FTOS, Spanning–Tree is not enabled by default. When configuring a Dell Networking
FTOS Switch, select a Spanning-Tree Protocol (RSTP, PVST+, MST) and enable it on the Switch.
In the VLT Domain Configuration a System-MAC address is configured to improve fail-over speed. This is a
Virtual MAC shared by both switches in the VLT Domain and is made up.
The VLT interconnect (VLTi) is a special port channel connecting the switches in a VLT Domain. Dell
Networking recommends a static port channel (without LACP) for the VLTi. This will reduces the time-to-
converge and allow the VLTi to become operational prior to the VLT Peer LAGs (LACP) connecting the
devices attached to the VLT Domain.
This is an example VLT Topology.
VLT topology
19 Dell Networking Switch CLI Examples
This is an example VLT Domain configuration.
Last configuration change at Sun Sep 29 21:04:22 2013 by admin
!
Startup-config last updated at Wed Nov 13 14:13:38 2013 by admin
!
boot system stack-unit 0
primary system: A:
boot system stack-unit 0
secondary system: B:
boot system stack-unit 0
default system: A:
boot
system gateway 0.0.0.0
redundancy auto-synchronize full
hardware watchdog
hostname S4810-2
!
username admin
password 7 89afe0892189bd96 privilege 15
enable restricted 7 387a7f2df5969da4
!
protocol spanning-tree 0
protocol spanning-tree rstp
no disable
max-age 6
forward-delay 6
bridge-priority 36864
!
ip multicast-routing
vlan-stack protocol-type 8100
mac-address-table aging-time 0
!
vlt domain 1
peer-link port-channel 100
back-up destination 192.168.109.103
primary-priority 8192
system-mac mac-address 00:22:22:22:22:22
unit-id 1
!
stack-unit 0 provision S4810
!
interface TenGigabitEthernet 0/0
no ip address
20 Dell Networking Switch CLI Examples
flowcontrol rx on tx off
port-channel-protocol LACP
port-channel 1 mode active
no shutdown
!
Interface TenGigabitEthernet 0/1
no ip address
flowcontrol rx on tx off
port-channel-protocol LACP
port-channel 2 mode active
no shutdown
interface TenGigabitEthernet 0/2
no ip address
flowcontrol rx on tx off
no shutdown
interface TenGigabitEthernet 0/3
no ip address
flowcontrol rx on tx off
no shutdown
interface TenGigabitEthernet 0/4
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/5
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/6
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/7
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/8
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/9
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/10
no ip address
flowcontrol rx on tx off
shutdown
21 Dell Networking Switch CLI Examples
interface TenGigabitEthernet 0/11
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/12
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/13
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/14
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/15
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/16
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/17
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/18
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/19
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/20
no ip address
switchport
flowcontrol rx on tx off
vlan-stack trunk
no shutdown
interface TenGigabitEthernet 0/21
no ip address
switchport
flowcontrol rx on tx off
vlan-stack trunk
22 Dell Networking Switch CLI Examples
no shutdown
interface TenGigabitEthernet 0/22
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/23
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/24
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/25
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/26
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/27
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/28
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/29
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/30
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/31
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/32
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/33
no ip address
23 Dell Networking Switch CLI Examples
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/34
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/35
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/36
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/37
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/38
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/39
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/40
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/41
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/42
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/43
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/44
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/45
24 Dell Networking Switch CLI Examples
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/46
no ip address
flowcontrol rx on tx off
shutdown
interface TenGigabitEthernet 0/47
no ip address
flowcontrol rx on tx off
shutdown
interface fortyGigE 0/48
no ip address
flowcontrol rx on tx off
no shutdown
interface fortyGigE 0/52
no ip address
flowcontrol rx on tx off
no shutdown
interface fortyGigE 0/56
ip address 192.168.0.3/31
flowcontrol rx on tx off
no shutdown
interface fortyGigE 0/60
ip address 192.168.0.7/31
flowcontrol rx on tx off
no shutdown
interface ManagementEthernet 0/0
ip address 192.168.109.104/24
no shutdown
interface ManagementEthernet 1/0
no shutdown
interface ManagementEthernet 2/0
no shutdown
interface ManagementEthernet 3/0
no shutdown
interface ManagementEthernet 4/0
no shutdown
interface ManagementEthernet 5/0
no shutdown
interface ManagementEthernet 6/0
no shutdown
interface ManagementEthernet 7/0
no shutdown
interface ManagementEthernet 8/0
no shutdown
25 Dell Networking Switch CLI Examples
interface ManagementEthernet 9/0
no shutdown
interface ManagementEthernet 10/0
no shutdown
interface ManagementEthernet 11/0
no shutdown
interface Loopback 0
ip address 10.0.0.4/32
no shutdown
interface Port-channel 1
no ip address
switchport
spanning-tree rstp edge-port
rate-interval 10
vlt-peer-lag port-channel 1
no shutdown
interface Port-channel 2
no ip address
switchport
spanning-tree rstp edge-port
rate-interval 10
vlt-peer-lag port-channel 2
no shutdown
interface Port-channel 100
no ip address
channel-member fortyGigE 0/48,52
no shutdown
interface Vlan 1
!untagged Port-channel 100
interface Vlan 100
ip address 100.0.0.253/24
tagged Port-channel 1-2
ip igmp immediate-leave
ip igmp query-interval 2
ip igmp snooping fast-leave
ip igmp snooping querier
!
vrrp-group 1
no preempt
priority 110
virtual-address 100.0.0.254
no shutdown
interface Vlan 101
ip address 101.0.0.253/24
tagged Port-channel 1-2
ip igmp immediate-leave
26 Dell Networking Switch CLI Examples
ip igmp query-interval 2
ip igmp snooping fast-leave
ip igmp snooping querier
vrrp-group 1
no preempt
priority 110
virtual-address 101.0.0.254
ip helper-address 100.0.0.101
no shutdown
!
interface Vlan 192
ip address 192.168.1.252/24
tagged Port-channel 1-2
ip igmp query-interval 2
ip igmp snooping querier
no shutdown
!
interface Vlan 300
no ip address
tagged
TenGigabitEthernet 0/20-21
shutdown
!
interface Vlan 400
description IPTV-source
ip address 104.0.0.253/24
tagged Port-channel 1-2
ip igmp immediate-leave
ip igmp query-interval 2
ip igmp snooping fast-leave
ip igmp snooping querier
!
vrrp-group 1
no preempt
priority 110
virtual-address 104.0.0.254
no shutdown
!
interface Vlan 901
ip address 192.168.10.12/24
tagged Port-channel 1
no shutdown
!
logging 192.168.109.46
!
snmp-server community private rw
snmp-server community public ro
27 Dell Networking Switch CLI Examples
snmp-server enable traps
snmp authentication coldstart linkdown linkup
snmp-server enable traps
lacp
snmp-server enable traps
stp
snmp-server enable traps
vlt
snmp-server enable traps
xstp
snmp-server enable traps
envmon cam-utilization
fan supply temperature
snmp-server host 192.168.109.41
traps version 2c public udp-port 162
ntp server 192.168.109.46
ntp update-calendar 1440
clock timezone Singapore 8
ip ssh server enable
ip igmp snooping enable
!protocol lldp
advertise management-tlv system-capabilities
system-description system-name
advertise interface-port-desc
line console 0
exec-timeout 35751 0
line vty 0
line vty 1
line vty 2
line vty 3
line vty 4
line vty 5
line vty 6
line vty 7
line vty 8
line vty 9
!reload-type normal-reload
end
28 Dell Networking Switch CLI Examples
6 Conclusion
Dell Networking N-Series and S-Series Switches use an Industry Standard Command Line (CLI) interface for
configuration. The Dell Networking CLI features standard terms for configuration (interface gigabitethernet,
switchport) and the Dell Networking Operating System (DNOS) contains the required features to successfully
provide LAN services for Campus deployments and Data Center Services for successful Data Center
Networks.
We have provided some examples of basic switch configurations and more complex Active Fabric
Topologies for both the Campus N-Series Switches and the more Data Center Centric S-Series Switches. By
the examples, Network Engineers and Administrators should be able to successfully configure Dell
Networking Switches for most deployments.

More Related Content

What's hot

OpenShift 4, the smarter Kubernetes platform
OpenShift 4, the smarter Kubernetes platformOpenShift 4, the smarter Kubernetes platform
OpenShift 4, the smarter Kubernetes platformKangaroot
 
Chassis Cluster Configuration
Chassis Cluster ConfigurationChassis Cluster Configuration
Chassis Cluster ConfigurationKashif Latif
 
Architectures for open and scalable clouds
Architectures for open and scalable cloudsArchitectures for open and scalable clouds
Architectures for open and scalable cloudsRandy Bias
 
GKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps Online
GKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps OnlineGKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps Online
GKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps OnlineGoogle Cloud Platform - Japan
 
Junos routing overview from Juniper
Junos routing overview from JuniperJunos routing overview from Juniper
Junos routing overview from JuniperNam Nguyen
 
Pushing Packets - How do the ML2 Mechanism Drivers Stack Up
Pushing Packets - How do the ML2 Mechanism Drivers Stack UpPushing Packets - How do the ML2 Mechanism Drivers Stack Up
Pushing Packets - How do the ML2 Mechanism Drivers Stack UpJames Denton
 
Hopper アーキテクチャで、変わること、変わらないこと
Hopper アーキテクチャで、変わること、変わらないことHopper アーキテクチャで、変わること、変わらないこと
Hopper アーキテクチャで、変わること、変わらないことNVIDIA Japan
 
Supermicro’s Universal GPU: Modular, Standards Based and Built for the Future
Supermicro’s Universal GPU: Modular, Standards Based and Built for the FutureSupermicro’s Universal GPU: Modular, Standards Based and Built for the Future
Supermicro’s Universal GPU: Modular, Standards Based and Built for the FutureRebekah Rodriguez
 
KVM tools and enterprise usage
KVM tools and enterprise usageKVM tools and enterprise usage
KVM tools and enterprise usagevincentvdk
 
MHA for MySQLとDeNAのオープンソースの話
MHA for MySQLとDeNAのオープンソースの話MHA for MySQLとDeNAのオープンソースの話
MHA for MySQLとDeNAのオープンソースの話Yoshinori Matsunobu
 
[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKit
[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKit[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKit
[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKitAkihiro Suda
 
Kubernetes Networking 101
Kubernetes Networking 101Kubernetes Networking 101
Kubernetes Networking 101Weaveworks
 
オトナのDocker入門
オトナのDocker入門オトナのDocker入門
オトナのDocker入門Tsukasa Kato
 
[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육
[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육
[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육Ji-Woong Choi
 
Getting started with Ansible
Getting started with AnsibleGetting started with Ansible
Getting started with AnsibleIvan Serdyuk
 
FD.io VPP事始め
FD.io VPP事始めFD.io VPP事始め
FD.io VPP事始めtetsusat
 
Kubernetes device plugins
Kubernetes device pluginsKubernetes device plugins
Kubernetes device pluginsssuser75c76a2
 
Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)
Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)
Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)Cisco DevNet
 

What's hot (20)

OpenShift 4, the smarter Kubernetes platform
OpenShift 4, the smarter Kubernetes platformOpenShift 4, the smarter Kubernetes platform
OpenShift 4, the smarter Kubernetes platform
 
Chassis Cluster Configuration
Chassis Cluster ConfigurationChassis Cluster Configuration
Chassis Cluster Configuration
 
Architectures for open and scalable clouds
Architectures for open and scalable cloudsArchitectures for open and scalable clouds
Architectures for open and scalable clouds
 
5分で分かるBig Switch Networks
5分で分かるBig Switch Networks5分で分かるBig Switch Networks
5分で分かるBig Switch Networks
 
Juniper
JuniperJuniper
Juniper
 
GKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps Online
GKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps OnlineGKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps Online
GKE に飛んでくるトラフィックを 自由自在に操る力 | 第 10 回 Google Cloud INSIDE Games & Apps Online
 
Junos routing overview from Juniper
Junos routing overview from JuniperJunos routing overview from Juniper
Junos routing overview from Juniper
 
Pushing Packets - How do the ML2 Mechanism Drivers Stack Up
Pushing Packets - How do the ML2 Mechanism Drivers Stack UpPushing Packets - How do the ML2 Mechanism Drivers Stack Up
Pushing Packets - How do the ML2 Mechanism Drivers Stack Up
 
Hopper アーキテクチャで、変わること、変わらないこと
Hopper アーキテクチャで、変わること、変わらないことHopper アーキテクチャで、変わること、変わらないこと
Hopper アーキテクチャで、変わること、変わらないこと
 
Supermicro’s Universal GPU: Modular, Standards Based and Built for the Future
Supermicro’s Universal GPU: Modular, Standards Based and Built for the FutureSupermicro’s Universal GPU: Modular, Standards Based and Built for the Future
Supermicro’s Universal GPU: Modular, Standards Based and Built for the Future
 
KVM tools and enterprise usage
KVM tools and enterprise usageKVM tools and enterprise usage
KVM tools and enterprise usage
 
MHA for MySQLとDeNAのオープンソースの話
MHA for MySQLとDeNAのオープンソースの話MHA for MySQLとDeNAのオープンソースの話
MHA for MySQLとDeNAのオープンソースの話
 
[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKit
[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKit[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKit
[KubeConEU] Building images efficiently and securely on Kubernetes with BuildKit
 
Kubernetes Networking 101
Kubernetes Networking 101Kubernetes Networking 101
Kubernetes Networking 101
 
オトナのDocker入門
オトナのDocker入門オトナのDocker入門
オトナのDocker入門
 
[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육
[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육
[오픈소스컨설팅] Ansible을 활용한 운영 자동화 교육
 
Getting started with Ansible
Getting started with AnsibleGetting started with Ansible
Getting started with Ansible
 
FD.io VPP事始め
FD.io VPP事始めFD.io VPP事始め
FD.io VPP事始め
 
Kubernetes device plugins
Kubernetes device pluginsKubernetes device plugins
Kubernetes device plugins
 
Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)
Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)
Open Device Programmability: Hands-on Intro to RESTCONF (and a bit of NETCONF)
 

Similar to Dell Networking Switch Configuration Examples

Dell Networking Wired, Wireless and Security Solutions Lab
Dell Networking Wired, Wireless and Security Solutions LabDell Networking Wired, Wireless and Security Solutions Lab
Dell Networking Wired, Wireless and Security Solutions LabDell World
 
Intel® Select Solutions for the Network
Intel® Select Solutions for the NetworkIntel® Select Solutions for the Network
Intel® Select Solutions for the NetworkLiz Warner
 
Eyeball AnyConnect™ Gateway Administration Guide
Eyeball AnyConnect™ Gateway Administration GuideEyeball AnyConnect™ Gateway Administration Guide
Eyeball AnyConnect™ Gateway Administration GuideEyeball Networks
 
sf-os10-virtual-link-trunking-ra.pdf
sf-os10-virtual-link-trunking-ra.pdfsf-os10-virtual-link-trunking-ra.pdf
sf-os10-virtual-link-trunking-ra.pdfssuserecfcc8
 
Dell OS10 VLT Architecture Guide.pdf
Dell OS10  VLT Architecture Guide.pdfDell OS10  VLT Architecture Guide.pdf
Dell OS10 VLT Architecture Guide.pdfdjameleddine2015
 
Deploying Applications in Today’s Network Infrastructure
Deploying Applications in Today’s Network InfrastructureDeploying Applications in Today’s Network Infrastructure
Deploying Applications in Today’s Network InfrastructureCisco Canada
 
Dell VLT reference architecture v2 0
Dell VLT reference architecture v2 0Dell VLT reference architecture v2 0
Dell VLT reference architecture v2 0David Pasek
 
End-to-End Data Center Virtualization
End-to-End Data Center VirtualizationEnd-to-End Data Center Virtualization
End-to-End Data Center VirtualizationCisco Canada
 
Innovation in SDN Tools and Platforms
Innovation in SDN Tools and PlatformsInnovation in SDN Tools and Platforms
Innovation in SDN Tools and PlatformsUmesh Krishnaswamy
 
Sdn dell lab report v2
Sdn dell lab report v2Sdn dell lab report v2
Sdn dell lab report v2Oded Rotter
 
CCNA3 Verson6 Chapter1
CCNA3 Verson6 Chapter1CCNA3 Verson6 Chapter1
CCNA3 Verson6 Chapter1Chaing Ravuth
 
SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014
SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014
SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014SAMeh Zaghloul
 
A Deep Dive in the World of IT Networking (Part 2)
A Deep Dive in the World of IT Networking (Part 2)A Deep Dive in the World of IT Networking (Part 2)
A Deep Dive in the World of IT Networking (Part 2)Tuan Yang
 
Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...
Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...
Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...University of Technology - Iraq
 
Ccnp™ advanced cisco® router
Ccnp™ advanced cisco® routerCcnp™ advanced cisco® router
Ccnp™ advanced cisco® routerchiliconcarne
 
I drac7 virtual_media_improved_networking_performance_6
I drac7 virtual_media_improved_networking_performance_6I drac7 virtual_media_improved_networking_performance_6
I drac7 virtual_media_improved_networking_performance_6olive4277
 
NFF-GO (YANFF) - Yet Another Network Function Framework
NFF-GO (YANFF) - Yet Another Network Function FrameworkNFF-GO (YANFF) - Yet Another Network Function Framework
NFF-GO (YANFF) - Yet Another Network Function FrameworkMichelle Holley
 
DAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI Convergence
DAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI ConvergenceDAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI Convergence
DAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI Convergenceinside-BigData.com
 
Introduction to the WSO2 Identity Server &Contributing to an OS Project
Introduction to the WSO2 Identity Server &Contributing to an OS ProjectIntroduction to the WSO2 Identity Server &Contributing to an OS Project
Introduction to the WSO2 Identity Server &Contributing to an OS ProjectMichael J Geiser
 

Similar to Dell Networking Switch Configuration Examples (20)

Dell Networking Wired, Wireless and Security Solutions Lab
Dell Networking Wired, Wireless and Security Solutions LabDell Networking Wired, Wireless and Security Solutions Lab
Dell Networking Wired, Wireless and Security Solutions Lab
 
Intel® Select Solutions for the Network
Intel® Select Solutions for the NetworkIntel® Select Solutions for the Network
Intel® Select Solutions for the Network
 
Eyeball AnyConnect™ Gateway Administration Guide
Eyeball AnyConnect™ Gateway Administration GuideEyeball AnyConnect™ Gateway Administration Guide
Eyeball AnyConnect™ Gateway Administration Guide
 
sf-os10-virtual-link-trunking-ra.pdf
sf-os10-virtual-link-trunking-ra.pdfsf-os10-virtual-link-trunking-ra.pdf
sf-os10-virtual-link-trunking-ra.pdf
 
Dell OS10 VLT Architecture Guide.pdf
Dell OS10  VLT Architecture Guide.pdfDell OS10  VLT Architecture Guide.pdf
Dell OS10 VLT Architecture Guide.pdf
 
Deploying Applications in Today’s Network Infrastructure
Deploying Applications in Today’s Network InfrastructureDeploying Applications in Today’s Network Infrastructure
Deploying Applications in Today’s Network Infrastructure
 
Dell VLT reference architecture v2 0
Dell VLT reference architecture v2 0Dell VLT reference architecture v2 0
Dell VLT reference architecture v2 0
 
End-to-End Data Center Virtualization
End-to-End Data Center VirtualizationEnd-to-End Data Center Virtualization
End-to-End Data Center Virtualization
 
Innovation in SDN Tools and Platforms
Innovation in SDN Tools and PlatformsInnovation in SDN Tools and Platforms
Innovation in SDN Tools and Platforms
 
Sdn dell lab report v2
Sdn dell lab report v2Sdn dell lab report v2
Sdn dell lab report v2
 
CCNA3 Verson6 Chapter1
CCNA3 Verson6 Chapter1CCNA3 Verson6 Chapter1
CCNA3 Verson6 Chapter1
 
SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014
SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014
SDN 101: Software Defined Networking Course - Sameh Zaghloul/IBM - 2014
 
A Deep Dive in the World of IT Networking (Part 2)
A Deep Dive in the World of IT Networking (Part 2)A Deep Dive in the World of IT Networking (Part 2)
A Deep Dive in the World of IT Networking (Part 2)
 
Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...
Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...
Performance Evaluation for Software Defined Networking (SDN) Based on Adaptiv...
 
Cis sem sdn
Cis sem sdnCis sem sdn
Cis sem sdn
 
Ccnp™ advanced cisco® router
Ccnp™ advanced cisco® routerCcnp™ advanced cisco® router
Ccnp™ advanced cisco® router
 
I drac7 virtual_media_improved_networking_performance_6
I drac7 virtual_media_improved_networking_performance_6I drac7 virtual_media_improved_networking_performance_6
I drac7 virtual_media_improved_networking_performance_6
 
NFF-GO (YANFF) - Yet Another Network Function Framework
NFF-GO (YANFF) - Yet Another Network Function FrameworkNFF-GO (YANFF) - Yet Another Network Function Framework
NFF-GO (YANFF) - Yet Another Network Function Framework
 
DAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI Convergence
DAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI ConvergenceDAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI Convergence
DAOS - Scale-Out Software-Defined Storage for HPC/Big Data/AI Convergence
 
Introduction to the WSO2 Identity Server &Contributing to an OS Project
Introduction to the WSO2 Identity Server &Contributing to an OS ProjectIntroduction to the WSO2 Identity Server &Contributing to an OS Project
Introduction to the WSO2 Identity Server &Contributing to an OS Project
 

Recently uploaded

Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Mark Simos
 
"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr BaganFwdays
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii SoldatenkoFwdays
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLScyllaDB
 
Scanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL CertsScanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL CertsRizwan Syed
 
My INSURER PTE LTD - Insurtech Innovation Award 2024
My INSURER PTE LTD - Insurtech Innovation Award 2024My INSURER PTE LTD - Insurtech Innovation Award 2024
My INSURER PTE LTD - Insurtech Innovation Award 2024The Digital Insurer
 
Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024Enterprise Knowledge
 
SAP Build Work Zone - Overview L2-L3.pptx
SAP Build Work Zone - Overview L2-L3.pptxSAP Build Work Zone - Overview L2-L3.pptx
SAP Build Work Zone - Overview L2-L3.pptxNavinnSomaal
 
costume and set research powerpoint presentation
costume and set research powerpoint presentationcostume and set research powerpoint presentation
costume and set research powerpoint presentationphoebematthew05
 
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...shyamraj55
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfAlex Barbosa Coqueiro
 
AI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsAI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsMemoori
 
Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Commit University
 
Dev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebDev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebUiPathCommunity
 
Streamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupStreamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupFlorian Wilhelm
 
Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 365Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 3652toLead Limited
 
Artificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxArtificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxhariprasad279825
 
Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfAddepto
 
Unleash Your Potential - Namagunga Girls Coding Club
Unleash Your Potential - Namagunga Girls Coding ClubUnleash Your Potential - Namagunga Girls Coding Club
Unleash Your Potential - Namagunga Girls Coding ClubKalema Edgar
 

Recently uploaded (20)

Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
 
"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQL
 
DMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special EditionDMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special Edition
 
Scanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL CertsScanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL Certs
 
My INSURER PTE LTD - Insurtech Innovation Award 2024
My INSURER PTE LTD - Insurtech Innovation Award 2024My INSURER PTE LTD - Insurtech Innovation Award 2024
My INSURER PTE LTD - Insurtech Innovation Award 2024
 
Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024Designing IA for AI - Information Architecture Conference 2024
Designing IA for AI - Information Architecture Conference 2024
 
SAP Build Work Zone - Overview L2-L3.pptx
SAP Build Work Zone - Overview L2-L3.pptxSAP Build Work Zone - Overview L2-L3.pptx
SAP Build Work Zone - Overview L2-L3.pptx
 
costume and set research powerpoint presentation
costume and set research powerpoint presentationcostume and set research powerpoint presentation
costume and set research powerpoint presentation
 
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdf
 
AI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsAI as an Interface for Commercial Buildings
AI as an Interface for Commercial Buildings
 
Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!
 
Dev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebDev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio Web
 
Streamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupStreamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project Setup
 
Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 365Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 365
 
Artificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxArtificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptx
 
Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdf
 
Unleash Your Potential - Namagunga Girls Coding Club
Unleash Your Potential - Namagunga Girls Coding ClubUnleash Your Potential - Namagunga Girls Coding Club
Unleash Your Potential - Namagunga Girls Coding Club
 

Dell Networking Switch Configuration Examples

  • 1. A Dell EMC Deployment and Configuration Guide Dell Networking Switch CLI Examples A deployment guide for Dell Networking switches
  • 2. 2 Dell Networking Switch CLI Examples Revisions Date Description Authors 2014 Initial release John Wroblewski Enterprise Technologist - Networking Copyright © 2014-2017 Dell Inc. or its subsidiaries. All Rights Reserved. Except as stated below, no part of this document may be reproduced, distributed or transmitted in any form or by any means, without express permission of Dell. You may distribute this document within your company or organization only, without alteration of its contents. THIS DOCUMENT IS PROVIDED “AS-IS”, AND WITHOUT ANY WARRANTY, EXPRESS OR IMPLIED. IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE SPECIFICALLY DISCLAIMED. PRODUCT WARRANTIES APPLICABLE TO THE DELL PRODUCTS DESCRIBED IN THIS DOCUMENT MAY BE FOUND AT: http://www.dell.com/learn/us/en/vn/terms-of-sale- commercial-and-public-sector-warranties Performance of network reference architectures discussed in this document may vary with differing deployment conditions, network loads, and the like. Third party products may be included in reference architectures for the convenience of the reader. Inclusion of such third party products does not necessarily constitute Dell’s recommendation of those products. Please consult your Dell representative for additional information. Trademarks used in this text: Dell™, the Dell logo, Dell Boomi™, PowerEdge™, PowerVault™, PowerConnect™, OpenManage™, EqualLogic™, Compellent™, KACE™, FlexAddress™, Force10™ and Vostro™ are trademarks of Dell Inc. EMC VNX®, and EMC Unisphere® are registered trademarks of Dell. Other Dell trademarks may be used in this document. Cisco Nexus®, Cisco MDS®, Cisco NX-0S®, and other Cisco Catalyst® are registered trademarks of Cisco System Inc. Intel®, Pentium®, Xeon®, Core® and Celeron® are registered trademarks of Intel Corporation in the U.S. and other countries. AMD® is a registered trademark and AMD Opteron™, AMD Phenom™ and AMD Sempron™ are trademarks of Advanced Micro Devices, Inc. Microsoft®, Windows®, Windows Server®, Internet Explorer®, MS-DOS®, Windows Vista® and Active Directory® are either trademarks or registered trademarks of Microsoft Corporation in the United States and/or other countries. Red Hat® and Red Hat® Enterprise Linux® are registered trademarks of Red Hat, Inc. in the United States and/or other countries. Novell® and SUSE® are registered trademarks of Novell Inc. in the United States and other countries. Oracle® is a registered trademark of Oracle Corporation and/or its affiliates. VMware®, Virtual SMP®, vMotion®, vCenter® and vSphere® are registered trademarks or trademarks of VMware, Inc. in the United States or other countries. IBM® is a registered trademark of International Business Machines Corporation. Broadcom® and NetXtreme® are registered trademarks of QLogic is a registered trademark of QLogic Corporation. Other trademarks and trade names may be used in this document to refer to either the entities claiming the marks and/or names or their products and are the property of their respective owners. Dell disclaims proprietary interest in the marks and names of others.
  • 3. 3 Dell Networking Switch CLI Examples Table of contents Revisions.............................................................................................................................................................................2 Introduction .........................................................................................................................................................................4 1 N-Series Default Configuration.....................................................................................................................................6 2 N-Series Configuration with a Port Channel to connect to another Switch supporting a VoIP Solution......................7 3 N-Series Configuration with MLAG (Virtual Port Channel) ..........................................................................................9 4 S-Series Configuration for Access with Port Channel................................................................................................12 5 S-Series Configuration for TOR or Core – Virtual Link Trunk ....................................................................................18 6 Conclusion..................................................................................................................................................................28
  • 4. 4 Dell Networking Switch CLI Examples Introduction The Dell Networking Switches provide the feature sets required to construct redundant, reliable, Active / Active Fabrics for today’s Data Center and Campus Networks. While the Dell Networking N-Series Campus Switches can be configured (after initially setting a management IP) using a Web-Based GUI, Customers may prefer to configure the switches using a console connection and the Command Line Interface. The Dell Networking Data Center Switches are always configured using a Command Line Interface. The dominate command line interface in Networking was originally developed and marketed by Cisco. Customers familiar with the Cisco CLI typically inquire about the Dell Networking Command Line Interface and the similarity to the Cisco CLI. Dell Networking Switches support a Command Line Interface that is very similar to the Cisco CLI. We use the term, Industry Standard Command Line Interface. This makes the transition from Customer familiar with Cisco to Dell Networking potentially seamless without the requirement for additional training. The ‘look and feel’ of the Dell Networking CLI is very familiar to most Network Engineers but it is not exactly the same and there are some feature set and protocol differences due to the proprietary nature of some of the Cisco Feature set. Dell Networking provides standards based features and protocols, therefore in our examples we will use interoperable standards. This document will not attempt to cover all feature sets and protocols but will function as a way to begin a Dell Networking configuration to produce an operating switch. The document will also not cover the protocol differences between a Cisco deployed switch that might make use of proprietary protocols versus a Dell Networking Standards based switch. We will briefly cover some of the protocols that maybe deployed in a Cisco Network and the Dell equivalent Standards based protocols. Protocols These are some of the protocols that can be deployed in Networks. Since this is a starter document, we will not cover more extensive and complex protocols. There are capabilities, terms, and protocols that are standard and should not be confusing to experienced networking professionals. Let’s explore some of the common terms and protocols. Layer 2 Switching – A capability that forwards packets based on the destination MAC address where both end-stations communicating are in the same broadcast domain. Layer 3 Switching – A capability that forwards packets based on the higher layer protocol destination address (Layer 3 in the OSI Model). This is across different Broadcast Domains or Subnets. Virtual LANs (VLAN) - A Broadcast Domain created at Layer 2. A virtualization of a Switch or switching infrastructure. Inter-VLAN communication is through Layer 3 Switching or Routing. Link Aggregation - Binding one or more separate Ethernet links together to form a larger bandwidth path that can be istributed for redundancy. Etherchannel, port-channel and LAG are synonymous terms. LACP - Link Aggregation Control Protocol, a protocol that dynamically configures Link Aggregation.
  • 5. 5 Dell Networking Switch CLI Examples Interface - A mode that specifies a port on a switch for applying configuration statements. Switchport - An interface configuration term that places the port (configured interface) into Layer 2 mode so that VLAN information can be configured. Spanning-Tree - A protocol that provides protection to the switch and switching infrastructure from network Loops while allowing redundant connections. OSPF / EIGRP - Dynamic Routing Protocols that build information tables for switches to make Layer 3 Switching or Routing decisions. OSPF is Standards based. EIGRP is Cisco proprietary.
  • 6. 6 Dell Networking Switch CLI Examples 1 N-Series Default Configuration This is an N-series Switch defaulted configuration. The defaulted configuration doesn’t show a lot of detail and defaulted configuration parameters are not displayed. As the configuration changes (protocols are changed from defaults or statements added), the CLI configuration will show more information. In this initial configuration two additional configuration statements. An IP address was added to VLAN 1 to allow the Web interface to be displayed and a new User was added with a Password and a Privilege of 15, the highest. !Current Configuration: !System Description "Dell Networking N3024, 6.1.2.4, Linux 3.6.5-601418a5" !System Software Version 6.1.2.4 ! configure slot 1/0 1 ! Dell Networking N3024 stack member 1 1 ! N3024 exit interface vlan 1 ip address 10.5.5.1 255.255.255.0 exit username "john" password 1c065ad7087eb8ce058b02e38654a2c4 privilege 15 encrypted snmp-server engineid local 800002a203f8b1562b9ab2 exit BEST PRACTICES It is not recommended to use VLAN 1 for Data or Voice configurations. VLAN 1 can represent a security risk. In the N-Series, VLAN is the default (by default the ‘native’ VLAN). Ports that are unassigned to other VLANs are configured to VLAN1. Tech Note: Voice over IP (VoIP) applications usually uses either LLDP or Cisco Discovery Protocol (CDP) for the discovery of VoIP Devices. In the Dell Networking N-Series, LLDP and a CDP-like Protocol, ISDP are enabled by default. ISDP is interoperable with Cisco CDP.
  • 7. 7 Dell Networking Switch CLI Examples 2 N-Series Configuration with a Port Channel to connect to another Switch supporting a VoIP Solution. This is a configuration that can be used for connecting to an aggregation switch and be used for supporting a VoIP Solution. We use the term ‘Switchport general’ on the configured interfaces to support more than one VLAN for VoIP and data traffic. In this configuration example, the Layer Two Class of Service was modified to provide strict queuing for VoIP. The N-Series Voice VLAN feature is used to setup the switch for Voice and QOS for Voice. This feature is globally enabled. The N-Series 2000 Switches are stacked in this example and have a Port Channel (port channel 1) to an Aggregation Switch. N-Series 2000P Configuration Example !Current Configuration: !System Description "Dell Networking N2048P, 6.0.1.3, Linux 3.6.5-320b2282" !System Software Version 6.0.1.3 ! configure vlan 152,160,194,401,421 exit slot 1/0 9 ! Dell Networking N2048P slot 2/0 8 ! Dell Networking N2024P sntp unicast client enable sntp server 10.100.200.1 clock timezone -5 minutes 0 stack member 1 9 ! N2048P member 2 7 ! N2024P exit no logging console ip http secure-server ip route 0.0.0.0 0.0.0.0 10.100.200.1 interface vlan 1 ip address 10.100.200.201 255.255.254.0 exit username "admin" password dec68e4501ce09a74284cb1bd03164a2 privilege 15 encrypted voice vlan ip ssh server classofservice dot1p-mapping 5 5 cos-queue min-bandwidth 0 0 5 5 10 30 40 cos-queue strict 5 ! interface Gi1/0/1 switchport mode general switchport general pvid 160 switchport general allowed vlan add 160
  • 8. 8 Dell Networking Switch CLI Examples switchport general allowed vlan add 152 tagged voice vlan 152 voice vlan auth disable exit ! interface Gi1/0/2 switchport mode general switchport general pvid 160 switchport general allowed vlan add 160 switchport general allowed vlan add 152 tagged voice vlan 152 voice vlan auth disable exit ! interface Te1/0/1 channel-group 1 mode active switchport mode trunk switchport trunk allowed vlan 1,152,160,194,401,421 exit ! interface Gi2/0/1 switchport mode general switchport general pvid 160 switchport general allowed vlan add 160 switchport general allowed vlan add 152 tagged voice vlan 152 voice vlan auth disable exit ! interface Te2/0/1 channel-group 1 mode active exit ! interface port-channel 1 switchport mode trunk switchport trunk allowed vlan 1,152,160,194,401,421 exit snmp-server engineid local 800002a203001ec9ded907 enable password dec68e4501ce09a74284cb1bd03164a2 encrypted exit
  • 9. 9 Dell Networking Switch CLI Examples 3 N-Series Configuration with MLAG (Virtual Port Channel) The Dell Networking N-Series can provide a Layer Two Active/ Active construct that provides redundancy, resiliency and performance to attached switches and devices without Spanning-Tree blocking ports. This capability is becoming a required feature for Campus Networks as the importance of the Campus infrastructure grows. In the VPC Configuration for MLAG, Spanning-Tree is disabled. The S-Series 60 switch configuration that follows was attached to the MLAG configuration represented here via S-60 ports 0/46-47 in Port Channel 1. This S-60 Port Channel was connected to Port Channel 100 in this N-3000 Series Configuration. This is an example of a MLAG N-Series 3000 Switch. This is the proposed topology. MLAG –N3000 series swtich !Current Configuration: !System Description "Dell Networking N3024P, 6.1.2.4, Linux 3.6.5-601418a5" !System Software Version 6.1.2.4 ! configure vlan 5,7,100 exit hostname "John3024P_Dot1" slot 1/0 6 ! Dell Networking N3024P stack member 1 3 ! N3024P exit interface out-of-band ip address 10.168.1.1 255.255.255.0 0.0.0.0 exit interface vlan 1 ip address dhcp
  • 10. 10 Dell Networking Switch CLI Examples exit interface vlan 5 ip address 10.5.5.2 255.255.255.0 exit interface vlan 7 ip address 10.7.7.2 255.255.255.0 exit interface vlan 100 ip address 10.100.100.1 255.255.255.0 exit username "john" password 9c91519328647000f9be49ebe9f7c939 privilege 15 encrypted exit udld enable ! interface Gi1/0/1 switchport access vlan 5 exit ! interface Gi1/0/2 switchport access vlan 5 exit ! interface Gi1/0/3 switchport access vlan 5 exit ! interface Gi1/0/4 switchport access vlan 5 exit ! interface Gi1/0/5 switchport access vlan 100 exit ! interface Gi1/0/9 switchport access vlan 100 exit ! interface Gi1/0/10 switchport mode trunk switchport trunk allowed vlan 5,7,100 exit ! interface Gi1/0/22 channel-group 1 mode active spanning-tree disable exit
  • 11. 11 Dell Networking Switch CLI Examples ! interface Gi1/0/23 channel-group 100 mode active spanning-tree disable exit ! interface Gi1/0/24 channel-group 100 mode active spanning-tree disable exit ! interface port-channel 1 spanning-tree disable switchport mode trunk switchport trunk native vlan 5 switchport trunk allowed vlan 5,7 vpc 1 exit ! interface port-channel 100 spanning-tree disable switchport mode trunk switchport trunk allowed vlan 5,7 vpc peer-link exit interface vlan 5 exit interface vlan 7 exit snmp-server engineid local 800002a203f8b15633f60a feature vpc vpc domain 1 role priority 1 peer-keepalive enable peer-keepalive destination 10.100.100.254 source 10.100.100.1 peer detection enable exit
  • 12. 12 Dell Networking Switch CLI Examples 4 S-Series Configuration for Access with Port Channel The S-Series 1Gb switches are excellent platforms for the access layer in the data center capable of supporting 1Gb attached servers at line rate with 10Gb uplink capability for attached to Dell Networking Active Fabric Cores or Top-of-Rack Solutions. S-Series switches based on Dell Networking FTOS are configured slightly differently than the N-Series DNOS 6 Switches. The major difference is that in Dell Networking FTOS, the interfaces are assigned into the VLANs (a configuration section ‘interface vlan’) versus VLANs being assigned to ‘interface port’ sections of the configuration. One other difference, Dell Networking FTOS uses the configuration term ‘Hybrid’ to place a port into a mode where multiple VLANs can be attached for VoIP applications. We will not cover that in this configuration example. This configuration was used to attach to a N-Series 3000 MLAG Aggregation using Port Channel 1. Tech Note: In Dell Networking FTOS, Spanning–Tree is not enabled by default. When configuring a Dell Networking FTOS Switch, select a Spanning-Tree Protocol (RSTP, PVST+, MST) and enable it on the Switch. Current Configuration ... ! Version 8.3.3.7 ! Last configuration change at Wed Jan 14 20:04:24 2015 by default ! Startup-config last updated at Wed Jan 14 20:04:01 2015 by default ! boot system stack-unit 0 primary tftp://192.168.128.1/FTOS-SC-8.3.3.4.bin boot system stack-unit 0 secondary system: A: boot system stack-unit 0 default system: A: boot system gateway 192.168.128.1 ! redundancy auto-synchronize full hardware watchdog hostname Force10 protocol spanning-tree pvst no disable stack-unit 0 provision S60 interface GigabitEthernet 0/0 no ip address switchport no shutdown interface GigabitEthernet 0/1 no ip address switchport no shutdown interface GigabitEthernet 0/2 no ip address switchport no shutdown interface GigabitEthernet 0/3 no ip address
  • 13. 13 Dell Networking Switch CLI Examples switchport no shutdown interface GigabitEthernet 0/4 no ip address shutdown interface GigabitEthernet 0/5 no ip address shutdown interface GigabitEthernet 0/6 no ip address shutdown interface GigabitEthernet 0/7 no ip address shutdown interface GigabitEthernet 0/8 no ip address shutdown interface GigabitEthernet 0/9 no ip address shutdown interface GigabitEthernet 0/10 no ip address shutdown interface GigabitEthernet 0/11 no ip address shutdown interface GigabitEthernet 0/12 no ip address shutdown interface GigabitEthernet 0/13 no ip address shutdown interface GigabitEthernet 0/14 no ip address shutdown interface GigabitEthernet 0/15 no ip address shutdown interface GigabitEthernet 0/16 no ip address shutdown interface GigabitEthernet 0/17 no ip address shutdown interface GigabitEthernet 0/18 no ip address shutdown
  • 14. 14 Dell Networking Switch CLI Examples interface GigabitEthernet 0/19 no ip address shutdown interface GigabitEthernet 0/20 no ip address shutdown interface GigabitEthernet 0/21 no ip address shutdown interface GigabitEthernet 0/22 no ip address shutdown interface GigabitEthernet 0/23 no ip address shutdown interface GigabitEthernet 0/24 no ip address shutdown interface GigabitEthernet 0/25 no ip address shutdown interface GigabitEthernet 0/26 no ip address shutdown interface GigabitEthernet 0/27 no ip address shutdown interface GigabitEthernet 0/28 no ip address shutdown interface GigabitEthernet 0/29 no ip address shutdown interface GigabitEthernet 0/30 no ip address shutdown interface GigabitEthernet 0/31 no ip address shutdown interface GigabitEthernet 0/32 no ip address shutdown interface GigabitEthernet 0/33 no ip address shutdown interface GigabitEthernet 0/34 no ip address
  • 15. 15 Dell Networking Switch CLI Examples shutdown interface GigabitEthernet 0/35 no ip address shutdown interface GigabitEthernet 0/36 no ip address shutdown interface GigabitEthernet 0/37 no ip address shutdown interface GigabitEthernet 0/38 no ip address shutdown interface GigabitEthernet 0/39 no ip address shutdown interface GigabitEthernet 0/40 no ip address shutdown interface GigabitEthernet 0/41 no ip address shutdown interface GigabitEthernet 0/42 no ip address shutdown interface GigabitEthernet 0/43 no ip address shutdown interface GigabitEthernet 0/44 no ip address shutdown interface GigabitEthernet 0/45 no ip address shutdown interface GigabitEthernet 0/46 no ip address port-channel-protocol LACP port-channel 1 mode active no shutdown interface GigabitEthernet 0/47 no ip address port-channel-protocol LACP port-channel 1 mode active no shutdown interface ManagementEthernet 0/0 ip address 10.168.1.10/24 no shutdown
  • 16. 16 Dell Networking Switch CLI Examples ! interface ManagementEthernet 1/0 no shutdown interface ManagementEthernet 2/0 no shutdown interface ManagementEthernet 3/0 no shutdown interface ManagementEthernet 4/0 no shutdown interface ManagementEthernet 5/0 no shutdown interface ManagementEthernet 6/0 no shutdown interface ManagementEthernet 7/0 no shutdown interface ManagementEthernet 8/0 no shutdown interface ManagementEthernet 9/0 no shutdown interface ManagementEthernet 10/0 no shutdown interface ManagementEthernet 11/0 no shutdown interface Port-channel 1 no ip address portmode hybrid switchport no shutdown ! interface Vlan 1 ! interface Vlan 5 ip address 10.5.5.10/24 untagged GigabitEthernet 0/0-3 untagged Port-channel 1 no shutdown ! interface Vlan 7 ip address 10.7.7.10/24 tagged Port-channel 1 no shutdown ! line console 0 line vty 0 line vty 1 line vty 2 line vty 3
  • 17. 17 Dell Networking Switch CLI Examples line vty 4 line vty 5 line vty 6 line vty 7 line vty 8
  • 18. 18 Dell Networking Switch CLI Examples 5 S-Series Configuration for TOR or Core – Virtual Link Trunk The Dell Networking S-Series of 10Gb / 40Gb switches using Dell Networking Operating System 9 (DNOS 9) offer the ability to provide a redundant, resilient, Active Fabric construct to connected switches, appliances, systems. An Active Fabric based on VLT allows a pair of S-Series 10Gb / 40gb Switches to be viewed from the connected devices as a single switch for Link Aggregation. This allows the connected links to operate in an Active / Active manner without a Spanning-Tree block. In VLT, Spanning-Tree is still configured to prevent downstream devices from impacting the Fabric due to a misconfiguration that results in a loop. VLT is a flexible topology offering Layer 2 VLT Domains and Layer 3 constructs. Tech Notes : In Dell Networking FTOS, Spanning–Tree is not enabled by default. When configuring a Dell Networking FTOS Switch, select a Spanning-Tree Protocol (RSTP, PVST+, MST) and enable it on the Switch. In the VLT Domain Configuration a System-MAC address is configured to improve fail-over speed. This is a Virtual MAC shared by both switches in the VLT Domain and is made up. The VLT interconnect (VLTi) is a special port channel connecting the switches in a VLT Domain. Dell Networking recommends a static port channel (without LACP) for the VLTi. This will reduces the time-to- converge and allow the VLTi to become operational prior to the VLT Peer LAGs (LACP) connecting the devices attached to the VLT Domain. This is an example VLT Topology. VLT topology
  • 19. 19 Dell Networking Switch CLI Examples This is an example VLT Domain configuration. Last configuration change at Sun Sep 29 21:04:22 2013 by admin ! Startup-config last updated at Wed Nov 13 14:13:38 2013 by admin ! boot system stack-unit 0 primary system: A: boot system stack-unit 0 secondary system: B: boot system stack-unit 0 default system: A: boot system gateway 0.0.0.0 redundancy auto-synchronize full hardware watchdog hostname S4810-2 ! username admin password 7 89afe0892189bd96 privilege 15 enable restricted 7 387a7f2df5969da4 ! protocol spanning-tree 0 protocol spanning-tree rstp no disable max-age 6 forward-delay 6 bridge-priority 36864 ! ip multicast-routing vlan-stack protocol-type 8100 mac-address-table aging-time 0 ! vlt domain 1 peer-link port-channel 100 back-up destination 192.168.109.103 primary-priority 8192 system-mac mac-address 00:22:22:22:22:22 unit-id 1 ! stack-unit 0 provision S4810 ! interface TenGigabitEthernet 0/0 no ip address
  • 20. 20 Dell Networking Switch CLI Examples flowcontrol rx on tx off port-channel-protocol LACP port-channel 1 mode active no shutdown ! Interface TenGigabitEthernet 0/1 no ip address flowcontrol rx on tx off port-channel-protocol LACP port-channel 2 mode active no shutdown interface TenGigabitEthernet 0/2 no ip address flowcontrol rx on tx off no shutdown interface TenGigabitEthernet 0/3 no ip address flowcontrol rx on tx off no shutdown interface TenGigabitEthernet 0/4 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/5 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/6 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/7 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/8 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/9 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/10 no ip address flowcontrol rx on tx off shutdown
  • 21. 21 Dell Networking Switch CLI Examples interface TenGigabitEthernet 0/11 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/12 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/13 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/14 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/15 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/16 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/17 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/18 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/19 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/20 no ip address switchport flowcontrol rx on tx off vlan-stack trunk no shutdown interface TenGigabitEthernet 0/21 no ip address switchport flowcontrol rx on tx off vlan-stack trunk
  • 22. 22 Dell Networking Switch CLI Examples no shutdown interface TenGigabitEthernet 0/22 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/23 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/24 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/25 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/26 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/27 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/28 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/29 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/30 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/31 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/32 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/33 no ip address
  • 23. 23 Dell Networking Switch CLI Examples flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/34 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/35 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/36 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/37 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/38 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/39 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/40 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/41 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/42 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/43 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/44 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/45
  • 24. 24 Dell Networking Switch CLI Examples no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/46 no ip address flowcontrol rx on tx off shutdown interface TenGigabitEthernet 0/47 no ip address flowcontrol rx on tx off shutdown interface fortyGigE 0/48 no ip address flowcontrol rx on tx off no shutdown interface fortyGigE 0/52 no ip address flowcontrol rx on tx off no shutdown interface fortyGigE 0/56 ip address 192.168.0.3/31 flowcontrol rx on tx off no shutdown interface fortyGigE 0/60 ip address 192.168.0.7/31 flowcontrol rx on tx off no shutdown interface ManagementEthernet 0/0 ip address 192.168.109.104/24 no shutdown interface ManagementEthernet 1/0 no shutdown interface ManagementEthernet 2/0 no shutdown interface ManagementEthernet 3/0 no shutdown interface ManagementEthernet 4/0 no shutdown interface ManagementEthernet 5/0 no shutdown interface ManagementEthernet 6/0 no shutdown interface ManagementEthernet 7/0 no shutdown interface ManagementEthernet 8/0 no shutdown
  • 25. 25 Dell Networking Switch CLI Examples interface ManagementEthernet 9/0 no shutdown interface ManagementEthernet 10/0 no shutdown interface ManagementEthernet 11/0 no shutdown interface Loopback 0 ip address 10.0.0.4/32 no shutdown interface Port-channel 1 no ip address switchport spanning-tree rstp edge-port rate-interval 10 vlt-peer-lag port-channel 1 no shutdown interface Port-channel 2 no ip address switchport spanning-tree rstp edge-port rate-interval 10 vlt-peer-lag port-channel 2 no shutdown interface Port-channel 100 no ip address channel-member fortyGigE 0/48,52 no shutdown interface Vlan 1 !untagged Port-channel 100 interface Vlan 100 ip address 100.0.0.253/24 tagged Port-channel 1-2 ip igmp immediate-leave ip igmp query-interval 2 ip igmp snooping fast-leave ip igmp snooping querier ! vrrp-group 1 no preempt priority 110 virtual-address 100.0.0.254 no shutdown interface Vlan 101 ip address 101.0.0.253/24 tagged Port-channel 1-2 ip igmp immediate-leave
  • 26. 26 Dell Networking Switch CLI Examples ip igmp query-interval 2 ip igmp snooping fast-leave ip igmp snooping querier vrrp-group 1 no preempt priority 110 virtual-address 101.0.0.254 ip helper-address 100.0.0.101 no shutdown ! interface Vlan 192 ip address 192.168.1.252/24 tagged Port-channel 1-2 ip igmp query-interval 2 ip igmp snooping querier no shutdown ! interface Vlan 300 no ip address tagged TenGigabitEthernet 0/20-21 shutdown ! interface Vlan 400 description IPTV-source ip address 104.0.0.253/24 tagged Port-channel 1-2 ip igmp immediate-leave ip igmp query-interval 2 ip igmp snooping fast-leave ip igmp snooping querier ! vrrp-group 1 no preempt priority 110 virtual-address 104.0.0.254 no shutdown ! interface Vlan 901 ip address 192.168.10.12/24 tagged Port-channel 1 no shutdown ! logging 192.168.109.46 ! snmp-server community private rw snmp-server community public ro
  • 27. 27 Dell Networking Switch CLI Examples snmp-server enable traps snmp authentication coldstart linkdown linkup snmp-server enable traps lacp snmp-server enable traps stp snmp-server enable traps vlt snmp-server enable traps xstp snmp-server enable traps envmon cam-utilization fan supply temperature snmp-server host 192.168.109.41 traps version 2c public udp-port 162 ntp server 192.168.109.46 ntp update-calendar 1440 clock timezone Singapore 8 ip ssh server enable ip igmp snooping enable !protocol lldp advertise management-tlv system-capabilities system-description system-name advertise interface-port-desc line console 0 exec-timeout 35751 0 line vty 0 line vty 1 line vty 2 line vty 3 line vty 4 line vty 5 line vty 6 line vty 7 line vty 8 line vty 9 !reload-type normal-reload end
  • 28. 28 Dell Networking Switch CLI Examples 6 Conclusion Dell Networking N-Series and S-Series Switches use an Industry Standard Command Line (CLI) interface for configuration. The Dell Networking CLI features standard terms for configuration (interface gigabitethernet, switchport) and the Dell Networking Operating System (DNOS) contains the required features to successfully provide LAN services for Campus deployments and Data Center Services for successful Data Center Networks. We have provided some examples of basic switch configurations and more complex Active Fabric Topologies for both the Campus N-Series Switches and the more Data Center Centric S-Series Switches. By the examples, Network Engineers and Administrators should be able to successfully configure Dell Networking Switches for most deployments.