SlideShare a Scribd company logo
1 of 8
Download to read offline
  1	
  
OSPF	
  Exercises	
  
All participants will work within a group as a team. Each group has three
routers and four switches to work with.
These exercises are divided into several components:
1. Basic Router Configuration
2. Static Routing
3. Dynamic routing with OSPF
There is a certain dependency between the labs as the exercises progress. Make
sure to maintain your configuration unless otherwise instructed. All exercises
will use a common IP addressing scheme and network topology.
As you go through the exercises all the examples are given from the point of
view of R11, the border router in group 1. Make sure that you take the
examples and adapt them to your own router, network topology and addressing
scheme.
Address Space Allocation
	
  
Group 1: 10.10.0.0/16 FEC0:10::/32 ASN: 10
Group 2: 10.20.0.0/16 FEC0:20::/32 ASN: 20
Group 3: 10.30.0.0/16 FEC0:30::/32 ASN: 30
Group 4: 10.40.0.0/16 FEC0:40::/32 ASN: 40
Group 5: 10.50.0.0/16 FEC0:50::/32 ASN: 50
Each group will then further partition their space:
10.X0.1.0/24 FEC0:X0:1:1::/64 - Core Network
10.X0.64.0/24 FEC0:X0:2:64::/64 - Data Subnet (VLAN 64)
10.X0.65.0/24 FEC0:X0:2:65::/64 - VOIP Subnet (VLAN 65)
10.X0.254.0/24 FEC0:X0:0:FE::/64 - Router Loopback Subnet
10.X0.255.0/24 FEC0:X0:0:FF::/64 - Switch MGMT Subnet (VLAN 255)
With X being your group number (1,2,3,4,5)
  2	
  
  3	
  
Basic Router Configuration	
  
1. Name the router.
enable
config terminal
hostname R11
2. Configure authentication
aaa new-model
aaa authentication login default local
aaa authentication enable default enable
username nsrc secret nsrc
enable secret nsrc
service password-encryption
line vty 0 4
transport preferred none
line console 0
transport preferred none
3. Configure logging
no logging console
logging buffered 8192 debugging
4. Deactivate domain name resolution.
no ip domain-lookup
5. Make sure the router understands CIDR. This is the default setting in
recent IOS versions, but just in case.
ip subnet-zero
ip classless
6. Disable source routing.
	
  
no ip source-route
7. Activate IPv6 routing.
ipv6 unicast-routing
8. Save the configuration.
write memory
9. Configure all your interfaces.
  4	
  
R11:	
  
interface GigabitEthernet0/1
ip address 10.10.1.1 255.255.255.0
description Link to Core
ipv6 enable
ipv6 address FEC0:10:1:1::1/64
no ip redirects
no ip directed-broadcast
no ip proxy-arp
no shutdown
Do the same for the core interfaces of R12 (10.10.1.2) and R13
(10.10.1.3)
On the access side, where you will use VLANs:
R12:	
  
interface GigabitEthernet0/1
no ip address
no shutdown
interface GigabitEthernet0/1.64
encapsulation dot1Q 64
ip address 10.10.64.2 255.255.255.0
description Link VLAN 64
ipv6 enable
ipv6 address FEC0:10:2:64::2/64
no ip redirects
no ip directed-broadcast
no ip proxy-arp
no shutdown
R13:	
  
interface GigabitEthernet0/1
no ip address
no shutdown
interface GigabitEthernet0/1.64
encapsulation dot1Q 64
ip address 10.10.64.3 255.255.255.0
description Link VLAN 64
ipv6 enable
ipv6 address FEC0:10:2:64::3/64
no ip redirects
no ip directed-broadcast
no ip proxy-arp
no shutdown
Do the same for VLANs 65 and 255.
10. Do some ping tests.
  5	
  
R11# ping 10.10.1.2
R11# ping 10.10.1.3
R11# ping FEC0:10:1:1::2
R11# ping FEC0:10:1:1::3
and then verify the output of the following commands
show arp : Shows ARP cache
show interface <int> : Shows interface state and configuration
show ip interface : Shows interface IP state and config
	
  
show ipv6 neighbors : Shows IPv6 neighbors
show ipv6 interface <int> : Shows interface state and configuration
show ipv6 interface : Shows interface state and configuration
11. Create loopback interface.
R11:	
  
interface loopback 0
ip address 10.10.254.1 255.255.255.255
ipv6 address FEC0:10:0:FE::1/128
12. Verify and save the configuration.
R11# show running-config
R11# write memory
Static Routing
1. Try pinging the addresses within your AS.
R11# ping 10.10.1.2
R11# ping 10.10.1.3
R11# ping 10.10.254.2
R11# ping 10.10.254.3
R11# ping 10.10.64.2
R11# ping 10.10.64.3
R11# ping 10.10.65.2
R11# ping 10.10.65.3
R11# ping 10.10.255.2
R11# ping 10.10.255.3
R11# ping ipv6 FEC0:10:1:1::2
R11# ping ipv6 FEC0:10:1:1::3
R11# ping ipv6 FEC0:10:0:FE::2
R11# ping ipv6 FEC0:10:0:FE::3
R11# ping ipv6 FEC0:10:2:64::2
R11# ping ipv6 FEC0:10:2:64::3
R11# ping ipv6 FEC0:10:2:65::2
R11# ping ipv6 FEC0:10:2:65::3
R11# ping ipv6 FEC0:10:0:FF::2
R11# ping ipv6 FEC0:10:0:FF::3
  6	
  
What is happening? Why can’t we ping some of the addresses?
2. Create static routes.
R11:	
  
ip route 10.10.254.2 255.255.255.255 10.10.1.2
ip route 10.10.254.3 255.255.255.255 10.10.1.3
ip route 10.10.64.0 255.255.255.0 10.10.1.2
ip route 10.10.64.0 255.255.255.0 10.10.1.3
ip route 10.10.65.0 255.255.255.0 10.10.1.2
ip route 10.10.65.0 255.255.255.0 10.10.1.3
ipv6 route FEC0:10:0:FE::2/128 FEC0:10:1:1::2
ipv6 route FEC0:10:0:FE::3/128 FEC0:10:1:1::3
ipv6 route FEC0:10:2:64::/64 FEC0:10:1:1::2
ipv6 route FEC0:10:2:64::/64 FEC0:10:1:1::3
ipv6 route FEC0:10:2:65::/64 FEC0:10:1:1::2
ipv6 route FEC0:10:2:65::/64 FEC0:10:1:1::3
ipv6 route FEC0:10:0:FF::/64 FEC0:10:1:1::2
ipv6 route FEC0:10:0:FF::/64 FEC0:10:1:1::3
Repeat the ping tests now. What happens when a new network is added?
3. Save the configuration.
R11# write memory
R11# show running-config
R11# show startup-config
Dynamic Routing with OSPF
1. Configure a new OSPF routing process and configure OSPF on the
interfaces where adjacencies need to be established, and also on any
interface that needs to have its subnets advertised by OSPF.
In	
  the	
  case	
  of	
  R12	
  and	
  R13,	
  this	
  includes	
  the	
  sub-­‐interfaces	
  for	
  VLANs	
  64,	
  65	
  and	
  255.	
  
Notice	
  that	
  we	
  are	
  configuring	
  authentication	
  for	
  the	
  OSPF	
  adjacencies.	
  This	
  is	
  important.	
  
	
  
R11:	
  
router ospf 100
log-adjacency-changes
passive-interface default
no passive-interface GigabitEthernet0/1
  7	
  
!
ipv6 router ospf 100
log-adjacency-changes
passive-interface default
no passive-interface GigabitEthernet0/1
!
interface Loopback0
ip ospf 100 area 0
ipv6 ospf 100 area 0
!
interface GigabitEthernet0/1
ip ospf 100 area 0
ip ospf authentication message-digest
ip ospf authentication-key N$RC
ipv6 ospf 100 area 0
ipv6 ospf authentication ipsec spi 500 md5
1234567890abcdef1234567890abcdef
2. STOP -- Checkpoint.
show ip ospf neighbor : show adjacencies
show ip route : show routes in routing table
show ip ospf : shows general OSPF information
show ip ospf interface : shows the status of OSPF in an interface
show ipv6 ospf neighbor
show ipv6 route
show ipv6 ospf
show ipv6 ospf interface
Which routes are preferred?
3. Remove the old static route entries.
no ip route 10.10.254.2 255.255.255.255 10.10.1.2
4. STOP -- Checkpoint.
show ip route : show routes in routing table
show ipv6 route
How many routes do you have for each access network? Which route is
preferred?
5. Load balance the traffic for the different networks by using OSPF link
costs.
a. Check each interface’s cost
R12#show ip ospf interface GigabitEthernet 0/1.64
  8	
  
b. If you did the Layer 2 exercises and used MSTP to load balance
traffic for the different VLANs, make sure that you assign OSPF link
costs accordingly to avoid unnecessary hops.
R12:	
  
interface GigabitEthernet 0/1.255
ip ospf cost 5
ipv6 ospf cost 5
Notes:
• Old	
  OSPF	
  syntax	
  for	
  adding	
  IPv4	
  networks	
  (before	
  IOS	
  12.3):	
  
router ospf 100
network 10.10.1.0 0.0.0.255 area 0
network 10.10.254.1 0.0.0.0 area 0
network 10.10.255.1 0.0.0.0 area 0

More Related Content

Similar to OSPF_Exercises.pdf

IPV6 Hands on Lab
IPV6 Hands on Lab IPV6 Hands on Lab
IPV6 Hands on Lab Cisco Canada
 
Hands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching ServicesHands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching ServicesCisco Canada
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesCisco Canada
 
Nxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarizationNxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarizationNetwax Lab
 
MPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testingMPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testingStephane Litkowski
 
Cisco CCNA IP SLA with tracking configuration
Cisco CCNA IP SLA  with tracking  configurationCisco CCNA IP SLA  with tracking  configuration
Cisco CCNA IP SLA with tracking configurationHamed Moghaddam
 
WAN SDN meet Segment Routing
WAN SDN meet Segment RoutingWAN SDN meet Segment Routing
WAN SDN meet Segment RoutingAPNIC
 
ACI MultiPod Config Guide
ACI MultiPod Config GuideACI MultiPod Config Guide
ACI MultiPod Config GuideWoo Hyung Choi
 
CCNA3 Verson6 Chapter10
CCNA3 Verson6 Chapter10CCNA3 Verson6 Chapter10
CCNA3 Verson6 Chapter10Chaing Ravuth
 
Eincop Netwax Lab: Redistribution
Eincop Netwax Lab: RedistributionEincop Netwax Lab: Redistribution
Eincop Netwax Lab: RedistributionNetwax Lab
 
Transitioning IPv4 to IPv6
Transitioning IPv4 to IPv6Transitioning IPv4 to IPv6
Transitioning IPv4 to IPv6Jhoni Guerrero
 
VXLAN, BGP EVPN without myths and packet capture
VXLAN, BGP EVPN without myths and packet captureVXLAN, BGP EVPN without myths and packet capture
VXLAN, BGP EVPN without myths and packet captureseyfitopuz1
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesCisco Canada
 
Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching Cisco Canada
 
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentCcn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentAngel Clavel
 
Lab 9 instructions
Lab 9 instructionsLab 9 instructions
Lab 9 instructionstrayyoo
 
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docxJosimar Caitano
 

Similar to OSPF_Exercises.pdf (20)

IPV6 Hands on Lab
IPV6 Hands on Lab IPV6 Hands on Lab
IPV6 Hands on Lab
 
IPV6 IPv6 Routing Lab By Rob Hamm
IPV6 IPv6 Routing Lab  By Rob HammIPV6 IPv6 Routing Lab  By Rob Hamm
IPV6 IPv6 Routing Lab By Rob Hamm
 
Hands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching ServicesHands on Experience with IPv6 Routing and Switching Services
Hands on Experience with IPv6 Routing and Switching Services
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and Services
 
ACI MultiPod 구성
ACI MultiPod 구성ACI MultiPod 구성
ACI MultiPod 구성
 
Nxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarizationNxll21 ospf filtering & summarization
Nxll21 ospf filtering & summarization
 
MPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testingMPLS SDN 2015 - SPRING interoperability testing
MPLS SDN 2015 - SPRING interoperability testing
 
Cisco CCNA IP SLA with tracking configuration
Cisco CCNA IP SLA  with tracking  configurationCisco CCNA IP SLA  with tracking  configuration
Cisco CCNA IP SLA with tracking configuration
 
WAN SDN meet Segment Routing
WAN SDN meet Segment RoutingWAN SDN meet Segment Routing
WAN SDN meet Segment Routing
 
ACI MultiPod Config Guide
ACI MultiPod Config GuideACI MultiPod Config Guide
ACI MultiPod Config Guide
 
CCNA3 Verson6 Chapter10
CCNA3 Verson6 Chapter10CCNA3 Verson6 Chapter10
CCNA3 Verson6 Chapter10
 
Eincop Netwax Lab: Redistribution
Eincop Netwax Lab: RedistributionEincop Netwax Lab: Redistribution
Eincop Netwax Lab: Redistribution
 
Transitioning IPv4 to IPv6
Transitioning IPv4 to IPv6Transitioning IPv4 to IPv6
Transitioning IPv4 to IPv6
 
VXLAN, BGP EVPN without myths and packet capture
VXLAN, BGP EVPN without myths and packet captureVXLAN, BGP EVPN without myths and packet capture
VXLAN, BGP EVPN without myths and packet capture
 
Hands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and ServicesHands-on Experience with IPv6 Routing and Services
Hands-on Experience with IPv6 Routing and Services
 
Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching Hands-on Experience with IPv6 Routing and Switching
Hands-on Experience with IPv6 Routing and Switching
 
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_studentCcn pv7 route_lab2-1_eigrp-load-balancing_student
Ccn pv7 route_lab2-1_eigrp-load-balancing_student
 
Ipv6 Alp
Ipv6 AlpIpv6 Alp
Ipv6 Alp
 
Lab 9 instructions
Lab 9 instructionsLab 9 instructions
Lab 9 instructions
 
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
 

More from Denis Rasskazov

ospf-filtering-issue - Partial Topology.pdf
ospf-filtering-issue - Partial Topology.pdfospf-filtering-issue - Partial Topology.pdf
ospf-filtering-issue - Partial Topology.pdfDenis Rasskazov
 
OSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdfOSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdfDenis Rasskazov
 
Ермаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDF
Ермаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDFЕрмаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDF
Ермаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDFDenis Rasskazov
 

More from Denis Rasskazov (10)

OSPF commands
OSPF commands OSPF commands
OSPF commands
 
ospfv3.pdf
ospfv3.pdfospfv3.pdf
ospfv3.pdf
 
OSPF-Design-Guide_.pdf
OSPF-Design-Guide_.pdfOSPF-Design-Guide_.pdf
OSPF-Design-Guide_.pdf
 
ospf-filtering-issue - Partial Topology.pdf
ospf-filtering-issue - Partial Topology.pdfospf-filtering-issue - Partial Topology.pdf
ospf-filtering-issue - Partial Topology.pdf
 
OSPF Section Topology
OSPF Section TopologyOSPF Section Topology
OSPF Section Topology
 
OSPF-Design-Guide.pdf
OSPF-Design-Guide.pdfOSPF-Design-Guide.pdf
OSPF-Design-Guide.pdf
 
OSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdfOSPFv3_Technology_White_Paper.pdf
OSPFv3_Technology_White_Paper.pdf
 
ospf-config.pdf
ospf-config.pdfospf-config.pdf
ospf-config.pdf
 
OSPF_multi.pdf
OSPF_multi.pdfOSPF_multi.pdf
OSPF_multi.pdf
 
Ермаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDF
Ермаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDFЕрмаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDF
Ермаков А.Е. - Основы конфигурирования корпоративных сетей Cisco - 2013.PDF
 

Recently uploaded

IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024Mark Billinghurst
 
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptxDecoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptxJoão Esperancinha
 
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).pptssuser5c9d4b1
 
SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )Tsuyoshi Horigome
 
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICSHARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICSRajkumarAkumalla
 
Microscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptxMicroscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptxpurnimasatapathy1234
 
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130Suhani Kapoor
 
High Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur EscortsHigh Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur EscortsCall Girls in Nagpur High Profile
 
Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024hassan khalil
 
Analog to Digital and Digital to Analog Converter
Analog to Digital and Digital to Analog ConverterAnalog to Digital and Digital to Analog Converter
Analog to Digital and Digital to Analog ConverterAbhinavSharma374939
 
What are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptxWhat are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptxwendy cai
 
Call Girls Delhi {Jodhpur} 9711199012 high profile service
Call Girls Delhi {Jodhpur} 9711199012 high profile serviceCall Girls Delhi {Jodhpur} 9711199012 high profile service
Call Girls Delhi {Jodhpur} 9711199012 high profile servicerehmti665
 
(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Service
(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Service(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Service
(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Serviceranjana rawat
 
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝soniya singh
 
High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...
High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...
High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...Call Girls in Nagpur High Profile
 
Porous Ceramics seminar and technical writing
Porous Ceramics seminar and technical writingPorous Ceramics seminar and technical writing
Porous Ceramics seminar and technical writingrakeshbaidya232001
 
High Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur EscortsHigh Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur Escortsranjana rawat
 

Recently uploaded (20)

IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024
 
★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR
★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR
★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR
 
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptxDecoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
 
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
 
SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )
 
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICSHARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
 
Microscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptxMicroscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptx
 
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
 
High Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur EscortsHigh Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Meera Call 7001035870 Meet With Nagpur Escorts
 
Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024
 
Analog to Digital and Digital to Analog Converter
Analog to Digital and Digital to Analog ConverterAnalog to Digital and Digital to Analog Converter
Analog to Digital and Digital to Analog Converter
 
What are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptxWhat are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptx
 
Call Girls Delhi {Jodhpur} 9711199012 high profile service
Call Girls Delhi {Jodhpur} 9711199012 high profile serviceCall Girls Delhi {Jodhpur} 9711199012 high profile service
Call Girls Delhi {Jodhpur} 9711199012 high profile service
 
(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Service
(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Service(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Service
(RIA) Call Girls Bhosari ( 7001035870 ) HI-Fi Pune Escorts Service
 
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
 
Call Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCR
Call Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCRCall Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCR
Call Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCR
 
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
 
High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...
High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...
High Profile Call Girls Nashik Megha 7001305949 Independent Escort Service Na...
 
Porous Ceramics seminar and technical writing
Porous Ceramics seminar and technical writingPorous Ceramics seminar and technical writing
Porous Ceramics seminar and technical writing
 
High Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur EscortsHigh Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur Escorts
High Profile Call Girls Nagpur Isha Call 7001035870 Meet With Nagpur Escorts
 

OSPF_Exercises.pdf

  • 1.   1   OSPF  Exercises   All participants will work within a group as a team. Each group has three routers and four switches to work with. These exercises are divided into several components: 1. Basic Router Configuration 2. Static Routing 3. Dynamic routing with OSPF There is a certain dependency between the labs as the exercises progress. Make sure to maintain your configuration unless otherwise instructed. All exercises will use a common IP addressing scheme and network topology. As you go through the exercises all the examples are given from the point of view of R11, the border router in group 1. Make sure that you take the examples and adapt them to your own router, network topology and addressing scheme. Address Space Allocation   Group 1: 10.10.0.0/16 FEC0:10::/32 ASN: 10 Group 2: 10.20.0.0/16 FEC0:20::/32 ASN: 20 Group 3: 10.30.0.0/16 FEC0:30::/32 ASN: 30 Group 4: 10.40.0.0/16 FEC0:40::/32 ASN: 40 Group 5: 10.50.0.0/16 FEC0:50::/32 ASN: 50 Each group will then further partition their space: 10.X0.1.0/24 FEC0:X0:1:1::/64 - Core Network 10.X0.64.0/24 FEC0:X0:2:64::/64 - Data Subnet (VLAN 64) 10.X0.65.0/24 FEC0:X0:2:65::/64 - VOIP Subnet (VLAN 65) 10.X0.254.0/24 FEC0:X0:0:FE::/64 - Router Loopback Subnet 10.X0.255.0/24 FEC0:X0:0:FF::/64 - Switch MGMT Subnet (VLAN 255) With X being your group number (1,2,3,4,5)
  • 3.   3   Basic Router Configuration   1. Name the router. enable config terminal hostname R11 2. Configure authentication aaa new-model aaa authentication login default local aaa authentication enable default enable username nsrc secret nsrc enable secret nsrc service password-encryption line vty 0 4 transport preferred none line console 0 transport preferred none 3. Configure logging no logging console logging buffered 8192 debugging 4. Deactivate domain name resolution. no ip domain-lookup 5. Make sure the router understands CIDR. This is the default setting in recent IOS versions, but just in case. ip subnet-zero ip classless 6. Disable source routing.   no ip source-route 7. Activate IPv6 routing. ipv6 unicast-routing 8. Save the configuration. write memory 9. Configure all your interfaces.
  • 4.   4   R11:   interface GigabitEthernet0/1 ip address 10.10.1.1 255.255.255.0 description Link to Core ipv6 enable ipv6 address FEC0:10:1:1::1/64 no ip redirects no ip directed-broadcast no ip proxy-arp no shutdown Do the same for the core interfaces of R12 (10.10.1.2) and R13 (10.10.1.3) On the access side, where you will use VLANs: R12:   interface GigabitEthernet0/1 no ip address no shutdown interface GigabitEthernet0/1.64 encapsulation dot1Q 64 ip address 10.10.64.2 255.255.255.0 description Link VLAN 64 ipv6 enable ipv6 address FEC0:10:2:64::2/64 no ip redirects no ip directed-broadcast no ip proxy-arp no shutdown R13:   interface GigabitEthernet0/1 no ip address no shutdown interface GigabitEthernet0/1.64 encapsulation dot1Q 64 ip address 10.10.64.3 255.255.255.0 description Link VLAN 64 ipv6 enable ipv6 address FEC0:10:2:64::3/64 no ip redirects no ip directed-broadcast no ip proxy-arp no shutdown Do the same for VLANs 65 and 255. 10. Do some ping tests.
  • 5.   5   R11# ping 10.10.1.2 R11# ping 10.10.1.3 R11# ping FEC0:10:1:1::2 R11# ping FEC0:10:1:1::3 and then verify the output of the following commands show arp : Shows ARP cache show interface <int> : Shows interface state and configuration show ip interface : Shows interface IP state and config   show ipv6 neighbors : Shows IPv6 neighbors show ipv6 interface <int> : Shows interface state and configuration show ipv6 interface : Shows interface state and configuration 11. Create loopback interface. R11:   interface loopback 0 ip address 10.10.254.1 255.255.255.255 ipv6 address FEC0:10:0:FE::1/128 12. Verify and save the configuration. R11# show running-config R11# write memory Static Routing 1. Try pinging the addresses within your AS. R11# ping 10.10.1.2 R11# ping 10.10.1.3 R11# ping 10.10.254.2 R11# ping 10.10.254.3 R11# ping 10.10.64.2 R11# ping 10.10.64.3 R11# ping 10.10.65.2 R11# ping 10.10.65.3 R11# ping 10.10.255.2 R11# ping 10.10.255.3 R11# ping ipv6 FEC0:10:1:1::2 R11# ping ipv6 FEC0:10:1:1::3 R11# ping ipv6 FEC0:10:0:FE::2 R11# ping ipv6 FEC0:10:0:FE::3 R11# ping ipv6 FEC0:10:2:64::2 R11# ping ipv6 FEC0:10:2:64::3 R11# ping ipv6 FEC0:10:2:65::2 R11# ping ipv6 FEC0:10:2:65::3 R11# ping ipv6 FEC0:10:0:FF::2 R11# ping ipv6 FEC0:10:0:FF::3
  • 6.   6   What is happening? Why can’t we ping some of the addresses? 2. Create static routes. R11:   ip route 10.10.254.2 255.255.255.255 10.10.1.2 ip route 10.10.254.3 255.255.255.255 10.10.1.3 ip route 10.10.64.0 255.255.255.0 10.10.1.2 ip route 10.10.64.0 255.255.255.0 10.10.1.3 ip route 10.10.65.0 255.255.255.0 10.10.1.2 ip route 10.10.65.0 255.255.255.0 10.10.1.3 ipv6 route FEC0:10:0:FE::2/128 FEC0:10:1:1::2 ipv6 route FEC0:10:0:FE::3/128 FEC0:10:1:1::3 ipv6 route FEC0:10:2:64::/64 FEC0:10:1:1::2 ipv6 route FEC0:10:2:64::/64 FEC0:10:1:1::3 ipv6 route FEC0:10:2:65::/64 FEC0:10:1:1::2 ipv6 route FEC0:10:2:65::/64 FEC0:10:1:1::3 ipv6 route FEC0:10:0:FF::/64 FEC0:10:1:1::2 ipv6 route FEC0:10:0:FF::/64 FEC0:10:1:1::3 Repeat the ping tests now. What happens when a new network is added? 3. Save the configuration. R11# write memory R11# show running-config R11# show startup-config Dynamic Routing with OSPF 1. Configure a new OSPF routing process and configure OSPF on the interfaces where adjacencies need to be established, and also on any interface that needs to have its subnets advertised by OSPF. In  the  case  of  R12  and  R13,  this  includes  the  sub-­‐interfaces  for  VLANs  64,  65  and  255.   Notice  that  we  are  configuring  authentication  for  the  OSPF  adjacencies.  This  is  important.     R11:   router ospf 100 log-adjacency-changes passive-interface default no passive-interface GigabitEthernet0/1
  • 7.   7   ! ipv6 router ospf 100 log-adjacency-changes passive-interface default no passive-interface GigabitEthernet0/1 ! interface Loopback0 ip ospf 100 area 0 ipv6 ospf 100 area 0 ! interface GigabitEthernet0/1 ip ospf 100 area 0 ip ospf authentication message-digest ip ospf authentication-key N$RC ipv6 ospf 100 area 0 ipv6 ospf authentication ipsec spi 500 md5 1234567890abcdef1234567890abcdef 2. STOP -- Checkpoint. show ip ospf neighbor : show adjacencies show ip route : show routes in routing table show ip ospf : shows general OSPF information show ip ospf interface : shows the status of OSPF in an interface show ipv6 ospf neighbor show ipv6 route show ipv6 ospf show ipv6 ospf interface Which routes are preferred? 3. Remove the old static route entries. no ip route 10.10.254.2 255.255.255.255 10.10.1.2 4. STOP -- Checkpoint. show ip route : show routes in routing table show ipv6 route How many routes do you have for each access network? Which route is preferred? 5. Load balance the traffic for the different networks by using OSPF link costs. a. Check each interface’s cost R12#show ip ospf interface GigabitEthernet 0/1.64
  • 8.   8   b. If you did the Layer 2 exercises and used MSTP to load balance traffic for the different VLANs, make sure that you assign OSPF link costs accordingly to avoid unnecessary hops. R12:   interface GigabitEthernet 0/1.255 ip ospf cost 5 ipv6 ospf cost 5 Notes: • Old  OSPF  syntax  for  adding  IPv4  networks  (before  IOS  12.3):   router ospf 100 network 10.10.1.0 0.0.0.255 area 0 network 10.10.254.1 0.0.0.0 area 0 network 10.10.255.1 0.0.0.0 area 0