SlideShare a Scribd company logo
1 of 36
Download to read offline
v
Cumulus Linux Conversion Guides
Cumulus Networks
May 24, 2016
Evolution of the CLI
§Where did things move?
cumulusnetworks.com 2
interfaces {
ge-0/1/1 {
unit 0 {
family bridge {
interface-mode access;
vlan-id 100;
}
}
}
ge-0/1/2 {
unit 0 {
family bridge {
interface-mode access;
vlan-id 200;
}
}
}
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports swp1 swp2
bridge-vids 100 200
auto swp1
iface swp1
bridge-access 100
auto swp2
iface swp2
bridge-access 200
▪ Cisco ▪ Juniper ▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode access
switchport access vlan 100
interface ethernet 1/2
switchport mode access
switchport access vlan 200
Defining a Switch Port
cumulusnetworks.com 3
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
auto bridge
iface bridge
bridge-ports swp1
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport
Adding an IP Address
cumulusnetworks.com 4
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
address [ipv4-address/subnet-mask]
address [ipv6-address/subnet-mask]
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# no switchport
switch(config-if)# ip address [ipv4-address/subnet-mask]
switch(config-if)# ipv6 address [ipv6-address/subnet-mask]
Setting Speed, Duplex, MTU, and Auto-negotiation for an Interface
cumulusnetworks.com 5
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
link-speed [speed]
link-duplex [full|half]
mtu [1500 - 9216]
link-autoneg [on|off]
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# speed [speed]
switch(config-if)# duplex [full|half]
switch(config-if)# mtu [1500 - 9216]
switch(config-if)# [no] negotiate auto
Configuring Trunks
cumulusnetworks.com 6
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode trunk
interface ethernet 1/2
switchport mode trunk
Cisco
Pruning a Trunk
cumulusnetworks.com 7
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
auto swp1
iface swp1
bridge-vids 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode trunk
switchport trunk allowed vlan 200
interface ethernet 1/2
switchport mode trunk
Cisco
Configuring Access Ports
cumulusnetworks.com 8
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
auto swp1
iface swp1
bridge-access 100
auto swp2
iface swp2
bridge-access 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode access
switchport access vlan 100
interface ethernet 1/2
switchport mode access
switchport access vlan 200
Cisco
Changing the Native (Untagged) VLAN for a Single Trunk
cumulusnetworks.com 9
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 1-200
auto swp1
iface swp1
bridge-pvid 100
auto swp2
iface swp2
bridge-pvid 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 1-200
interface ethernet 1/1-2
switchport mode trunk
switchport trunk allowed vlan 1-200
interface ethernet 1/1
switchport trunk native vlan 100
interface ethernet 1/2
switchport trunk native vlan 200
Cisco
EtherChannels/Bonds
cumulusnetworks.com 10
vlan 10
!
interface GigabitEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan10
ip address 10.10.10.10 255.255.255.0
Cisco WS-C3560X-24 12.2(55)SE5
auto bond1
iface bond1
bond-slaves glob swp19-20
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan10
iface vlan10
bridge-ports bond1.10
address 10.10.10.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Cisco
EtherChannels/Bonds
cumulusnetworks.com 11
interface Ethernet37
switchport mode trunk
channel-group 2 mode active
interface Ethernet38
switchport mode trunk
channel-group 2 mode active
interface Port-Channel2
switchport trunk allowed vlan 12
switchport mode trunk
interface Vlan12
ip address 12.12.12.12/24
Arista DCS-7148S-R 4.13.5F
auto bond2
iface bond2
bond-slaves glob swp37-38
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan12
iface vlan12
bridge-ports bond2.12
address 12.12.12.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Arista
EtherChannels/Bonds
cumulusnetworks.com 12
feature interface-vlan
feature lacp
vlan 14
interface Ethernet1/39
switchport mode trunk
channel-group 3 mode active
interface Ethernet1/40
switchport mode trunk
channel-group 3 mode active
interface port-channel3
switchport mode trunk
interface Vlan14
no shutdown
ip address 14.14.14.14/24
Cisco Nexus3064 5.0(3)U2(2c)
auto bond3
iface bond3
bond-slaves glob swp39-40
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan14
iface vlan14
bridge-ports bond3.14
address 14.14.14.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Cisco
Spanning Tree Configuration
cumulusnetworks.com 13
auto swp1
iface swp1
mstpctl-portadminedge yes
interface Gigabit0/0
spanning-tree portfast
Immediately bring an interface configured as an access or trunk port to the forwarding state.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 14
auto swp1
iface swp1
mstpctl-bpduguard yes
!
spanning-tree portfast bpduguard default
!
interface Gigabit0/0
spanning-tree portfast
Enabling/disabling the BPDU guard configuration.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 15
auto swp1
iface swp1
mstpctl-portbpdufilter yes
!
spanning-tree portfast bpdufilter default
!
interface Gigabit0/0
spanning-tree portfast
Enables BPDU filter on a switch port, which filters BPDUs in both directions.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 16
auto swp1
iface swp1
mstpctl-treeportprio 128
interface Gigabit0/0
spanning-tree port-priority 128
Configure the port priority for an interface. The default for both operating systems is 128.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 17
auto vlan1
iface vlan1
mstpctl-treeprio 32768
bridge-ports swp1
spanning-tree vlan 1 priority 32768
Configure the switch's priority for a bridge/VLAN. The default for both operating systems is 32768.
▪ Cumulus Linux Cisco
More Spanning Tree Info (Conversion Guide)
cumulusnetworks.com 18
https://support.cumulusnetworks.com/hc/en-us/articles/206908397
Spanning Tree
Industry-standard Loop Prevention for L2
Access Lists
cumulusnetworks.com 19
iptables -A {FORWARD | INPUT | OUTPUT} -j {ACCEPT | DROP | POLICE | SPAN | ERSPAN} | -p <protocol>
-s <source> --sport [<ports>] -d destination> --dport [<ports>] [<options>]
iptables -A FORWARD -j ACCEPT -p tcp -s 10.10.10.0/24 -d 3.3.3.3/24 --dport 80
iptables/netfilter (including Cumulus Linux)
access-list <number> {permit | deny} <protocol> <source> [<ports>] <destination> [<ports>] [<options>]
IOS Standard Syntax
ip access-list extended {<number> | <name>}
[<sequence>] {permit | deny} <protocol> <source> [<ports>]<destination> [<ports>] [<options>]
IOS Extended Syntax (including NX-OS)
ip access-list extended allow_http
10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www
access-list 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www
(Example permit http port 80 traffic to 10.10.10.0/24 subnet)
Block ICMP Echo Requests on the Specified Switch Port
cumulusnetworks.com 20
iptables -A FORWARD -j DROP -i swp1 -p icmp --icmp-type echo-request
ip access-list extended block_icmp
deny icmp any any echo
interface g0/0
ip access-group block_icmp in
Cumulus Linux
Cisco
Block SSH Trafficfrom the Specified Subnet (5.5.5.0/24)
cumulusnetworks.com 21
iptables -A INPUT -j DROP -p tcp -s 5.5.5.0/24 --dport 22
ip access-list extended block_ssh
deny tcp 5.5.5.0 0.0.0.255 192.50.50.0 0.0.0.255 eq 22
interface g0/0
ip access-group block_ssh in
Cumulus Linux
Cisco
Allow NTP Traffic to Transitthe Switch (UDP Port 123)
cumulusnetworks.com 22
iptables -A FORWARD -j ACCEPT -p udp -s 192.168.1.0/24 --dport 123
ip access-list extended allow_ntp
permit udp 192.168.1.0 0.0.0.255 any eq ntp
interface g0/0
ip access-group allow_ntp in
Cumulus Linux
Cisco
Policing a Physical Interface
cumulusnetworks.com 23
-A FORWARD --in-interface swp1 -j POLICE --set-mode KB --set-rate 125000 --set-burst 2000
Cumulus Linux
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp1
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp1 any anywhere anywhere POLICE mode:KB rate:125000 burst:2000
Output
policy-map sean
class class-default
police cir 1000000000 interface
TenGigabitEthernet1/13
service-policy input sean
Cisco
Policing DSCP Values
cumulusnetworks.com 24
-A FORWARD --in-interface swp2 -m dscp --dscp 10 -j POLICE --set-mode KB --set-rate 31250 --set-burst 2000
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp2
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp2 any anywhere anywhere DSCP match 0x0a POLICE mode:KB rate:31250 burst:2000
Cumulus Linux
Output
class-map match-all dscp10
match dscp af11
!
policy-map sean2
class dscp10
police cir 250000000
!
interface TenGigabitEthernet1/14
service-policy input sean2
Cisco
Policing by Source Traffic
cumulusnetworks.com 25
-A FORWARD --in-interface swp3 -j POLICE --set-mode KB --set-rate 12500 --set-burst 2000 -s 3.3.3.0/24
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp3
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp3 any 3.3.3.0/24 anywhere POLICE mode:KB rate:12500 burst:2000
Cumulus Linux
access-list 100 permit ip 3.3.3.0 0.0.0.255 any
!
class-map match-all heller
match access-group 100
!
policy-map heller
class heller
police cir 100000000
!
interface TenGigabitEthernet1/15
service-policy input heller
Cisco
Output
Time Zone Configuration
cumulusnetworks.com 26
switch# configure terminal
switch(config)# clock timezone PST -8 0
switch(config)# exit
switch# show clock
switch# copy running-config startup-config
Cumulus Linux
Cisco
cumulus@switch:~$ sudo tzconfg
cumulus@switch:~$ sudo hwclock
NTP
cumulusnetworks.com 27
switch# clock protocol ntp vdc 1
Cumulus Linux
Cisco
Set NTP (e.g. to VDC 1)
cumulus@switch:~$ sudo vi /etc/ntp.conf
cumulus@switch:~$ ntpd –q
Show Management Interface Current Configuration
cumulusnetworks.com 28
switch# show interface mgmt 0
Cumulus Linux
Cisco
cumulus@switch:~$ ifquery eth0
DHCP Relay
cumulusnetworks.com 29
cumulus@switch:~$ sudo vi /etc/default/isc-dhcp-relay
SERVERS="192.168.123.4"
INTERFACES="bridge swp4 swp5"
cumulus@switch:~$ sudo /etc/init.d/isc-dhcp-relay restart
Cumulus Linux
Cisco
switch# configure terminal switch(config)# ip dhcp relay
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# ip dhcp relay address 192.168.123.4
CLI Basics
cumulusnetworks.com 30
Show command history
cumulus@switch:~$ history switch# show cli history
Cumulus Linux Cisco
Send message to all logged on users
cumulus@switch:~$ echo message | sudo wall switch# send message
Send message to specific user
cumulus@switch:~$ sudo write user-id switch# show users
switch# send session line message
CLI Basics
cumulusnetworks.com 31
Show SPROM information
cumulus@switch:~$ decode-syseeprom switch# show sprom
Cumulus Linux Cisco
Show hardware states (temperature, fan, power)
cumulus@switch:~$ sudo smonctl switch# show environment
Show memory allocation
cumulus@switch:~$ vmstat switch# show processes memory
Show real-time memory usage
cumulus@switch:~$ vmstat 1
Alternative command
cumulus@switch:~$ free
cumulus@switch:~$ sudo sensors
CLI Basics
cumulusnetworks.com 32
Show CPU processes and utilization
cumulus@switch:~$ ps aux switch# show processes
Cumulus Linux Cisco
Show hardware information
cumulus@switch:~$ dmidecode switch# show inventory
Show high level port state
cumulus@switch:~$ netshow interface switch# show ip int br
cumulus@switch:~$ top switch# show processes cpu
cumulus@switch:~$ netshow system
CLI Basics
cumulusnetworks.com 33
Show interface neighbors
cumulus@switch:~$ lldpctl switch# show lldp neigbhors
Cumulus Linux Cisco
Show interface connector information
cumulus@switch:~$ sudo ethtool –m swp1 switch# show interface ethernet 1/1 transceiver
Reboot switch
cumulus@switch:~$ sudo reboot switch# reload
cumulus@switch:~$ netshow lldp
Show ARP Table
cumulusnetworks.com 34
root@leaf01:~# arp –n
Address HWtype HWaddress Flags Mask Iface
10.2.0.254 ether 44:38:39:00:00:29 C eth0
169.254.1.2 ether 44:38:39:00:00:30 C peerlink.4094
169.254.0.1 ether 44:38:39:00:00:08 CM swp49
169.254.0.1 ether 44:38:39:00:00:14 CM swp50
Cumulus Linux
Cisco
switch# show ip arp
IP ARP Table for context default
Total number of entries: 1
Address Age MAC Address Interface
90.10.10.2 00:03:11 000d.ece7.df7c Vlan900
Configure SNMP (Net-SNMP)
cumulusnetworks.com 35
cumulus@switch:~$ sudo vi /etc/snmp/snmpd.conf
cumulus@switch:~$ sudo vi /etc/snmp/snmptrapd.conf
switch# configure terminal
switch(config)# snmp-server host ip-address traps version 2c public
Cumulus Linux
Cisco
https://docs.cumulusnetworks.com/display/DOCS/Monitoring+System+Hardware
Detailed Info
© 2016 Cumulus Networks. CUMULUS, the Cumulus Logo, CUMULUS NETWORKS, and the Rocket Turtle Logo (the “Marks”) are trademarks and service marks of
Cumulus Networks, Inc. in the U.S. and other countries. You are not permitted touse the Marks without theprior written consent of Cumulus Networks. The registered
trademark Linux® is used pursuant to a sublicense from LMI, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis. All other marks are used
under fair use or license from their respective owners.
§Thank You!
cumulusnetworks.com 36
Bringing the Linux Revolution to Networking

More Related Content

What's hot

Virtualization with KVM (Kernel-based Virtual Machine)
Virtualization with KVM (Kernel-based Virtual Machine)Virtualization with KVM (Kernel-based Virtual Machine)
Virtualization with KVM (Kernel-based Virtual Machine)Novell
 
Open vSwitch 패킷 처리 구조
Open vSwitch 패킷 처리 구조Open vSwitch 패킷 처리 구조
Open vSwitch 패킷 처리 구조Seung-Hoon Baek
 
VXLAN and FRRouting
VXLAN and FRRoutingVXLAN and FRRouting
VXLAN and FRRoutingFaisal Reza
 
오픈스택: 구석구석 파헤쳐보기
오픈스택: 구석구석 파헤쳐보기오픈스택: 구석구석 파헤쳐보기
오픈스택: 구석구석 파헤쳐보기Jaehwa Park
 
MP BGP-EVPN 실전기술-1편(개념잡기)
MP BGP-EVPN 실전기술-1편(개념잡기)MP BGP-EVPN 실전기술-1편(개념잡기)
MP BGP-EVPN 실전기술-1편(개념잡기)JuHwan Lee
 
Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...
Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...
Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...OpenStack
 
ACI Multicast 구성 가이드
ACI Multicast 구성 가이드ACI Multicast 구성 가이드
ACI Multicast 구성 가이드Woo Hyung Choi
 
Linux女子部 iptables復習編
Linux女子部 iptables復習編Linux女子部 iptables復習編
Linux女子部 iptables復習編Etsuji Nakai
 
単なるキャッシュじゃないよ!?infinispanの紹介
単なるキャッシュじゃないよ!?infinispanの紹介単なるキャッシュじゃないよ!?infinispanの紹介
単なるキャッシュじゃないよ!?infinispanの紹介AdvancedTechNight
 
Ceph Introduction 2017
Ceph Introduction 2017  Ceph Introduction 2017
Ceph Introduction 2017 Karan Singh
 
Cisco sddc solution 소개
Cisco sddc solution 소개Cisco sddc solution 소개
Cisco sddc solution 소개Woo Hyung Choi
 
VXLAN BGP EVPN: Technology Building Blocks
VXLAN BGP EVPN: Technology Building BlocksVXLAN BGP EVPN: Technology Building Blocks
VXLAN BGP EVPN: Technology Building BlocksAPNIC
 
Building DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPNBuilding DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPNCisco Canada
 
[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항
[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항
[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항Ji-Woong Choi
 

What's hot (20)

Virtualization with KVM (Kernel-based Virtual Machine)
Virtualization with KVM (Kernel-based Virtual Machine)Virtualization with KVM (Kernel-based Virtual Machine)
Virtualization with KVM (Kernel-based Virtual Machine)
 
Open vSwitch 패킷 처리 구조
Open vSwitch 패킷 처리 구조Open vSwitch 패킷 처리 구조
Open vSwitch 패킷 처리 구조
 
VXLAN and FRRouting
VXLAN and FRRoutingVXLAN and FRRouting
VXLAN and FRRouting
 
오픈스택: 구석구석 파헤쳐보기
오픈스택: 구석구석 파헤쳐보기오픈스택: 구석구석 파헤쳐보기
오픈스택: 구석구석 파헤쳐보기
 
MP BGP-EVPN 실전기술-1편(개념잡기)
MP BGP-EVPN 실전기술-1편(개념잡기)MP BGP-EVPN 실전기술-1편(개념잡기)
MP BGP-EVPN 실전기술-1편(개념잡기)
 
Lustre Best Practices
Lustre Best Practices Lustre Best Practices
Lustre Best Practices
 
Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...
Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...
Meshing OpenStack and Bare Metal Networks with EVPN - David Iles, Mellanox Te...
 
Vyatta 改造入門
Vyatta 改造入門Vyatta 改造入門
Vyatta 改造入門
 
Deploying IPv6 on OpenStack
Deploying IPv6 on OpenStackDeploying IPv6 on OpenStack
Deploying IPv6 on OpenStack
 
Meetup 23 - 02 - OVN - The future of networking in OpenStack
Meetup 23 - 02 - OVN - The future of networking in OpenStackMeetup 23 - 02 - OVN - The future of networking in OpenStack
Meetup 23 - 02 - OVN - The future of networking in OpenStack
 
YJTC18 A-1 データセンタネットワークの取り組み
YJTC18 A-1 データセンタネットワークの取り組みYJTC18 A-1 データセンタネットワークの取り組み
YJTC18 A-1 データセンタネットワークの取り組み
 
ACI Multicast 구성 가이드
ACI Multicast 구성 가이드ACI Multicast 구성 가이드
ACI Multicast 구성 가이드
 
Linux女子部 iptables復習編
Linux女子部 iptables復習編Linux女子部 iptables復習編
Linux女子部 iptables復習編
 
ゼロからはじめるKVM超入門
ゼロからはじめるKVM超入門ゼロからはじめるKVM超入門
ゼロからはじめるKVM超入門
 
単なるキャッシュじゃないよ!?infinispanの紹介
単なるキャッシュじゃないよ!?infinispanの紹介単なるキャッシュじゃないよ!?infinispanの紹介
単なるキャッシュじゃないよ!?infinispanの紹介
 
Ceph Introduction 2017
Ceph Introduction 2017  Ceph Introduction 2017
Ceph Introduction 2017
 
Cisco sddc solution 소개
Cisco sddc solution 소개Cisco sddc solution 소개
Cisco sddc solution 소개
 
VXLAN BGP EVPN: Technology Building Blocks
VXLAN BGP EVPN: Technology Building BlocksVXLAN BGP EVPN: Technology Building Blocks
VXLAN BGP EVPN: Technology Building Blocks
 
Building DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPNBuilding DataCenter networks with VXLAN BGP-EVPN
Building DataCenter networks with VXLAN BGP-EVPN
 
[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항
[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항
[오픈소스컨설팅]클라우드기반U2L마이그레이션 전략 및 고려사항
 

Viewers also liked

20ten final presentation-Cumulus
20ten final presentation-Cumulus20ten final presentation-Cumulus
20ten final presentation-Cumulusjulianasur
 
Cumulus Networks Overview
Cumulus Networks OverviewCumulus Networks Overview
Cumulus Networks OverviewAdam Lorts
 
Cumulus Linux 2.5 Overview
Cumulus Linux 2.5 OverviewCumulus Linux 2.5 Overview
Cumulus Linux 2.5 OverviewCumulus Networks
 
ONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks WebinarONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks WebinarCumulus Networks
 
Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015Cumulus Networks
 
Ansible & Cumulus Networks - Simplify Network Automation
Ansible & Cumulus Networks - Simplify Network AutomationAnsible & Cumulus Networks - Simplify Network Automation
Ansible & Cumulus Networks - Simplify Network AutomationCumulus Networks
 
VMware NSX + Cumulus Networks: Software Defined Networking
VMware NSX + Cumulus Networks: Software Defined NetworkingVMware NSX + Cumulus Networks: Software Defined Networking
VMware NSX + Cumulus Networks: Software Defined NetworkingCumulus Networks
 
現代 IT 人一定要知道的 Ansible 自動化組態技巧
現代 IT 人一定要知道的 Ansible 自動化組態技巧現代 IT 人一定要知道的 Ansible 自動化組態技巧
現代 IT 人一定要知道的 Ansible 自動化組態技巧Chu-Siang Lai
 

Viewers also liked (9)

20ten final presentation-Cumulus
20ten final presentation-Cumulus20ten final presentation-Cumulus
20ten final presentation-Cumulus
 
Cumulus Networks Overview
Cumulus Networks OverviewCumulus Networks Overview
Cumulus Networks Overview
 
Cumulus Linux 2.5 Overview
Cumulus Linux 2.5 OverviewCumulus Linux 2.5 Overview
Cumulus Linux 2.5 Overview
 
ONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks WebinarONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks Webinar
 
Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015
 
OCP Switch Overview
OCP Switch OverviewOCP Switch Overview
OCP Switch Overview
 
Ansible & Cumulus Networks - Simplify Network Automation
Ansible & Cumulus Networks - Simplify Network AutomationAnsible & Cumulus Networks - Simplify Network Automation
Ansible & Cumulus Networks - Simplify Network Automation
 
VMware NSX + Cumulus Networks: Software Defined Networking
VMware NSX + Cumulus Networks: Software Defined NetworkingVMware NSX + Cumulus Networks: Software Defined Networking
VMware NSX + Cumulus Networks: Software Defined Networking
 
現代 IT 人一定要知道的 Ansible 自動化組態技巧
現代 IT 人一定要知道的 Ansible 自動化組態技巧現代 IT 人一定要知道的 Ansible 自動化組態技巧
現代 IT 人一定要知道的 Ansible 自動化組態技巧
 

Similar to Cumulus networks conversion guide

Cisco data center support
Cisco data center supportCisco data center support
Cisco data center supportKrunal Shah
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2alan moreno
 
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleVoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleFaisal Khan
 
Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Hardware accelerated switching with Linux @ SWLUG Talks May 2014Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Hardware accelerated switching with Linux @ SWLUG Talks May 2014Nat Morris
 
Thebasicintroductionofopenvswitch
ThebasicintroductionofopenvswitchThebasicintroductionofopenvswitch
ThebasicintroductionofopenvswitchRamses Ramirez
 
Deploying Carrier Ethernet Features on Cisco ASR 9000
Deploying Carrier Ethernet Features on Cisco ASR 9000Deploying Carrier Ethernet Features on Cisco ASR 9000
Deploying Carrier Ethernet Features on Cisco ASR 9000Vinod Kumar Balasubramanyam
 
ACIT - CCNA Training Course Topic - Switch Stp ACIT
ACIT - CCNA Training Course Topic - Switch Stp ACITACIT - CCNA Training Course Topic - Switch Stp ACIT
ACIT - CCNA Training Course Topic - Switch Stp ACITSleek International
 
Openstack openswitch basics
Openstack openswitch basicsOpenstack openswitch basics
Openstack openswitch basicsnshah061
 
Free CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfNetworkershome
 

Similar to Cumulus networks conversion guide (20)

Day 14.2 configuringvla ns
Day 14.2 configuringvla nsDay 14.2 configuringvla ns
Day 14.2 configuringvla ns
 
Cisco data center support
Cisco data center supportCisco data center support
Cisco data center support
 
Day 13.1..1 catalyst switch
Day 13.1..1 catalyst switchDay 13.1..1 catalyst switch
Day 13.1..1 catalyst switch
 
Icnd210 s02l01
Icnd210 s02l01Icnd210 s02l01
Icnd210 s02l01
 
Configuracion EIGRP
Configuracion EIGRPConfiguracion EIGRP
Configuracion EIGRP
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
 
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleVoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
 
Ccnp3 lab 3_3_en
Ccnp3 lab 3_3_enCcnp3 lab 3_3_en
Ccnp3 lab 3_3_en
 
Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Hardware accelerated switching with Linux @ SWLUG Talks May 2014Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Hardware accelerated switching with Linux @ SWLUG Talks May 2014
 
Aruba mobility access switch useful commands v2
Aruba mobility access switch useful commands v2Aruba mobility access switch useful commands v2
Aruba mobility access switch useful commands v2
 
Thebasicintroductionofopenvswitch
ThebasicintroductionofopenvswitchThebasicintroductionofopenvswitch
Thebasicintroductionofopenvswitch
 
Deploying Carrier Ethernet Features on Cisco ASR 9000
Deploying Carrier Ethernet Features on Cisco ASR 9000Deploying Carrier Ethernet Features on Cisco ASR 9000
Deploying Carrier Ethernet Features on Cisco ASR 9000
 
Deploying Carrier Ethernet features on ASR 9000
Deploying Carrier Ethernet features on ASR 9000Deploying Carrier Ethernet features on ASR 9000
Deploying Carrier Ethernet features on ASR 9000
 
Ccnp3 lab 3_4_en
Ccnp3 lab 3_4_enCcnp3 lab 3_4_en
Ccnp3 lab 3_4_en
 
Ccnp3 lab 3_4_en
Ccnp3 lab 3_4_enCcnp3 lab 3_4_en
Ccnp3 lab 3_4_en
 
ACIT - CCNA Training Course Topic - Switch Stp ACIT
ACIT - CCNA Training Course Topic - Switch Stp ACITACIT - CCNA Training Course Topic - Switch Stp ACIT
ACIT - CCNA Training Course Topic - Switch Stp ACIT
 
Dc fabric path
Dc fabric pathDc fabric path
Dc fabric path
 
Openstack openswitch basics
Openstack openswitch basicsOpenstack openswitch basics
Openstack openswitch basics
 
PROYECTO VLANS
PROYECTO VLANSPROYECTO VLANS
PROYECTO VLANS
 
Free CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdf
 

Recently uploaded

Learn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdf
Learn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdfLearn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdf
Learn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdfkalichargn70th171
 
Unveiling the Tech Salsa of LAMs with Janus in Real-Time Applications
Unveiling the Tech Salsa of LAMs with Janus in Real-Time ApplicationsUnveiling the Tech Salsa of LAMs with Janus in Real-Time Applications
Unveiling the Tech Salsa of LAMs with Janus in Real-Time ApplicationsAlberto González Trastoy
 
What is Binary Language? Computer Number Systems
What is Binary Language?  Computer Number SystemsWhat is Binary Language?  Computer Number Systems
What is Binary Language? Computer Number SystemsJheuzeDellosa
 
Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...
Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...
Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...soniya singh
 
(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...
(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...
(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...gurkirankumar98700
 
DNT_Corporate presentation know about us
DNT_Corporate presentation know about usDNT_Corporate presentation know about us
DNT_Corporate presentation know about usDynamic Netsoft
 
BATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASE
BATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASEBATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASE
BATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASEOrtus Solutions, Corp
 
Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...
Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...
Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...MyIntelliSource, Inc.
 
Adobe Marketo Engage Deep Dives: Using Webhooks to Transfer Data
Adobe Marketo Engage Deep Dives: Using Webhooks to Transfer DataAdobe Marketo Engage Deep Dives: Using Webhooks to Transfer Data
Adobe Marketo Engage Deep Dives: Using Webhooks to Transfer DataBradBedford3
 
Optimizing AI for immediate response in Smart CCTV
Optimizing AI for immediate response in Smart CCTVOptimizing AI for immediate response in Smart CCTV
Optimizing AI for immediate response in Smart CCTVshikhaohhpro
 
Advancing Engineering with AI through the Next Generation of Strategic Projec...
Advancing Engineering with AI through the Next Generation of Strategic Projec...Advancing Engineering with AI through the Next Generation of Strategic Projec...
Advancing Engineering with AI through the Next Generation of Strategic Projec...OnePlan Solutions
 
XpertSolvers: Your Partner in Building Innovative Software Solutions
XpertSolvers: Your Partner in Building Innovative Software SolutionsXpertSolvers: Your Partner in Building Innovative Software Solutions
XpertSolvers: Your Partner in Building Innovative Software SolutionsMehedi Hasan Shohan
 
KnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptx
KnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptxKnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptx
KnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptxTier1 app
 
Asset Management Software - Infographic
Asset Management Software - InfographicAsset Management Software - Infographic
Asset Management Software - InfographicHr365.us smith
 
Project Based Learning (A.I).pptx detail explanation
Project Based Learning (A.I).pptx detail explanationProject Based Learning (A.I).pptx detail explanation
Project Based Learning (A.I).pptx detail explanationkaushalgiri8080
 
Engage Usergroup 2024 - The Good The Bad_The Ugly
Engage Usergroup 2024 - The Good The Bad_The UglyEngage Usergroup 2024 - The Good The Bad_The Ugly
Engage Usergroup 2024 - The Good The Bad_The UglyFrank van der Linden
 
chapter--4-software-project-planning.ppt
chapter--4-software-project-planning.pptchapter--4-software-project-planning.ppt
chapter--4-software-project-planning.pptkotipi9215
 
The Evolution of Karaoke From Analog to App.pdf
The Evolution of Karaoke From Analog to App.pdfThe Evolution of Karaoke From Analog to App.pdf
The Evolution of Karaoke From Analog to App.pdfPower Karaoke
 
Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...
Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...
Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...stazi3110
 
why an Opensea Clone Script might be your perfect match.pdf
why an Opensea Clone Script might be your perfect match.pdfwhy an Opensea Clone Script might be your perfect match.pdf
why an Opensea Clone Script might be your perfect match.pdfjoe51371421
 

Recently uploaded (20)

Learn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdf
Learn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdfLearn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdf
Learn the Fundamentals of XCUITest Framework_ A Beginner's Guide.pdf
 
Unveiling the Tech Salsa of LAMs with Janus in Real-Time Applications
Unveiling the Tech Salsa of LAMs with Janus in Real-Time ApplicationsUnveiling the Tech Salsa of LAMs with Janus in Real-Time Applications
Unveiling the Tech Salsa of LAMs with Janus in Real-Time Applications
 
What is Binary Language? Computer Number Systems
What is Binary Language?  Computer Number SystemsWhat is Binary Language?  Computer Number Systems
What is Binary Language? Computer Number Systems
 
Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...
Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...
Russian Call Girls in Karol Bagh Aasnvi ➡️ 8264348440 💋📞 Independent Escort S...
 
(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...
(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...
(Genuine) Escort Service Lucknow | Starting ₹,5K To @25k with A/C 🧑🏽‍❤️‍🧑🏻 89...
 
DNT_Corporate presentation know about us
DNT_Corporate presentation know about usDNT_Corporate presentation know about us
DNT_Corporate presentation know about us
 
BATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASE
BATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASEBATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASE
BATTLEFIELD ORM: TIPS, TACTICS AND STRATEGIES FOR CONQUERING YOUR DATABASE
 
Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...
Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...
Try MyIntelliAccount Cloud Accounting Software As A Service Solution Risk Fre...
 
Adobe Marketo Engage Deep Dives: Using Webhooks to Transfer Data
Adobe Marketo Engage Deep Dives: Using Webhooks to Transfer DataAdobe Marketo Engage Deep Dives: Using Webhooks to Transfer Data
Adobe Marketo Engage Deep Dives: Using Webhooks to Transfer Data
 
Optimizing AI for immediate response in Smart CCTV
Optimizing AI for immediate response in Smart CCTVOptimizing AI for immediate response in Smart CCTV
Optimizing AI for immediate response in Smart CCTV
 
Advancing Engineering with AI through the Next Generation of Strategic Projec...
Advancing Engineering with AI through the Next Generation of Strategic Projec...Advancing Engineering with AI through the Next Generation of Strategic Projec...
Advancing Engineering with AI through the Next Generation of Strategic Projec...
 
XpertSolvers: Your Partner in Building Innovative Software Solutions
XpertSolvers: Your Partner in Building Innovative Software SolutionsXpertSolvers: Your Partner in Building Innovative Software Solutions
XpertSolvers: Your Partner in Building Innovative Software Solutions
 
KnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptx
KnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptxKnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptx
KnowAPIs-UnknownPerf-jaxMainz-2024 (1).pptx
 
Asset Management Software - Infographic
Asset Management Software - InfographicAsset Management Software - Infographic
Asset Management Software - Infographic
 
Project Based Learning (A.I).pptx detail explanation
Project Based Learning (A.I).pptx detail explanationProject Based Learning (A.I).pptx detail explanation
Project Based Learning (A.I).pptx detail explanation
 
Engage Usergroup 2024 - The Good The Bad_The Ugly
Engage Usergroup 2024 - The Good The Bad_The UglyEngage Usergroup 2024 - The Good The Bad_The Ugly
Engage Usergroup 2024 - The Good The Bad_The Ugly
 
chapter--4-software-project-planning.ppt
chapter--4-software-project-planning.pptchapter--4-software-project-planning.ppt
chapter--4-software-project-planning.ppt
 
The Evolution of Karaoke From Analog to App.pdf
The Evolution of Karaoke From Analog to App.pdfThe Evolution of Karaoke From Analog to App.pdf
The Evolution of Karaoke From Analog to App.pdf
 
Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...
Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...
Building a General PDE Solving Framework with Symbolic-Numeric Scientific Mac...
 
why an Opensea Clone Script might be your perfect match.pdf
why an Opensea Clone Script might be your perfect match.pdfwhy an Opensea Clone Script might be your perfect match.pdf
why an Opensea Clone Script might be your perfect match.pdf
 

Cumulus networks conversion guide

  • 1. v Cumulus Linux Conversion Guides Cumulus Networks May 24, 2016
  • 2. Evolution of the CLI §Where did things move? cumulusnetworks.com 2 interfaces { ge-0/1/1 { unit 0 { family bridge { interface-mode access; vlan-id 100; } } } ge-0/1/2 { unit 0 { family bridge { interface-mode access; vlan-id 200; } } } auto bridge iface bridge bridge-vlan-aware yes bridge-ports swp1 swp2 bridge-vids 100 200 auto swp1 iface swp1 bridge-access 100 auto swp2 iface swp2 bridge-access 200 ▪ Cisco ▪ Juniper ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode access switchport access vlan 100 interface ethernet 1/2 switchport mode access switchport access vlan 200
  • 3. Defining a Switch Port cumulusnetworks.com 3 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 auto bridge iface bridge bridge-ports swp1 Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# switchport
  • 4. Adding an IP Address cumulusnetworks.com 4 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 address [ipv4-address/subnet-mask] address [ipv6-address/subnet-mask] Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# no switchport switch(config-if)# ip address [ipv4-address/subnet-mask] switch(config-if)# ipv6 address [ipv6-address/subnet-mask]
  • 5. Setting Speed, Duplex, MTU, and Auto-negotiation for an Interface cumulusnetworks.com 5 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 link-speed [speed] link-duplex [full|half] mtu [1500 - 9216] link-autoneg [on|off] Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# speed [speed] switch(config-if)# duplex [full|half] switch(config-if)# mtu [1500 - 9216] switch(config-if)# [no] negotiate auto
  • 6. Configuring Trunks cumulusnetworks.com 6 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode trunk interface ethernet 1/2 switchport mode trunk Cisco
  • 7. Pruning a Trunk cumulusnetworks.com 7 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 auto swp1 iface swp1 bridge-vids 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode trunk switchport trunk allowed vlan 200 interface ethernet 1/2 switchport mode trunk Cisco
  • 8. Configuring Access Ports cumulusnetworks.com 8 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 auto swp1 iface swp1 bridge-access 100 auto swp2 iface swp2 bridge-access 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode access switchport access vlan 100 interface ethernet 1/2 switchport mode access switchport access vlan 200 Cisco
  • 9. Changing the Native (Untagged) VLAN for a Single Trunk cumulusnetworks.com 9 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 1-200 auto swp1 iface swp1 bridge-pvid 100 auto swp2 iface swp2 bridge-pvid 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 1-200 interface ethernet 1/1-2 switchport mode trunk switchport trunk allowed vlan 1-200 interface ethernet 1/1 switchport trunk native vlan 100 interface ethernet 1/2 switchport trunk native vlan 200 Cisco
  • 10. EtherChannels/Bonds cumulusnetworks.com 10 vlan 10 ! interface GigabitEthernet0/19 switchport trunk encapsulation dot1q switchport mode trunk channel-group 1 mode active interface GigabitEthernet0/20 switchport trunk encapsulation dot1q switchport mode trunk channel-group 1 mode active interface Port-channel1 switchport trunk encapsulation dot1q switchport mode trunk interface Vlan10 ip address 10.10.10.10 255.255.255.0 Cisco WS-C3560X-24 12.2(55)SE5 auto bond1 iface bond1 bond-slaves glob swp19-20 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan10 iface vlan10 bridge-ports bond1.10 address 10.10.10.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Cisco
  • 11. EtherChannels/Bonds cumulusnetworks.com 11 interface Ethernet37 switchport mode trunk channel-group 2 mode active interface Ethernet38 switchport mode trunk channel-group 2 mode active interface Port-Channel2 switchport trunk allowed vlan 12 switchport mode trunk interface Vlan12 ip address 12.12.12.12/24 Arista DCS-7148S-R 4.13.5F auto bond2 iface bond2 bond-slaves glob swp37-38 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan12 iface vlan12 bridge-ports bond2.12 address 12.12.12.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Arista
  • 12. EtherChannels/Bonds cumulusnetworks.com 12 feature interface-vlan feature lacp vlan 14 interface Ethernet1/39 switchport mode trunk channel-group 3 mode active interface Ethernet1/40 switchport mode trunk channel-group 3 mode active interface port-channel3 switchport mode trunk interface Vlan14 no shutdown ip address 14.14.14.14/24 Cisco Nexus3064 5.0(3)U2(2c) auto bond3 iface bond3 bond-slaves glob swp39-40 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan14 iface vlan14 bridge-ports bond3.14 address 14.14.14.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Cisco
  • 13. Spanning Tree Configuration cumulusnetworks.com 13 auto swp1 iface swp1 mstpctl-portadminedge yes interface Gigabit0/0 spanning-tree portfast Immediately bring an interface configured as an access or trunk port to the forwarding state. ▪ Cumulus Linux Cisco
  • 14. Spanning Tree Configuration cumulusnetworks.com 14 auto swp1 iface swp1 mstpctl-bpduguard yes ! spanning-tree portfast bpduguard default ! interface Gigabit0/0 spanning-tree portfast Enabling/disabling the BPDU guard configuration. ▪ Cumulus Linux Cisco
  • 15. Spanning Tree Configuration cumulusnetworks.com 15 auto swp1 iface swp1 mstpctl-portbpdufilter yes ! spanning-tree portfast bpdufilter default ! interface Gigabit0/0 spanning-tree portfast Enables BPDU filter on a switch port, which filters BPDUs in both directions. ▪ Cumulus Linux Cisco
  • 16. Spanning Tree Configuration cumulusnetworks.com 16 auto swp1 iface swp1 mstpctl-treeportprio 128 interface Gigabit0/0 spanning-tree port-priority 128 Configure the port priority for an interface. The default for both operating systems is 128. ▪ Cumulus Linux Cisco
  • 17. Spanning Tree Configuration cumulusnetworks.com 17 auto vlan1 iface vlan1 mstpctl-treeprio 32768 bridge-ports swp1 spanning-tree vlan 1 priority 32768 Configure the switch's priority for a bridge/VLAN. The default for both operating systems is 32768. ▪ Cumulus Linux Cisco
  • 18. More Spanning Tree Info (Conversion Guide) cumulusnetworks.com 18 https://support.cumulusnetworks.com/hc/en-us/articles/206908397 Spanning Tree Industry-standard Loop Prevention for L2
  • 19. Access Lists cumulusnetworks.com 19 iptables -A {FORWARD | INPUT | OUTPUT} -j {ACCEPT | DROP | POLICE | SPAN | ERSPAN} | -p <protocol> -s <source> --sport [<ports>] -d destination> --dport [<ports>] [<options>] iptables -A FORWARD -j ACCEPT -p tcp -s 10.10.10.0/24 -d 3.3.3.3/24 --dport 80 iptables/netfilter (including Cumulus Linux) access-list <number> {permit | deny} <protocol> <source> [<ports>] <destination> [<ports>] [<options>] IOS Standard Syntax ip access-list extended {<number> | <name>} [<sequence>] {permit | deny} <protocol> <source> [<ports>]<destination> [<ports>] [<options>] IOS Extended Syntax (including NX-OS) ip access-list extended allow_http 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www access-list 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www (Example permit http port 80 traffic to 10.10.10.0/24 subnet)
  • 20. Block ICMP Echo Requests on the Specified Switch Port cumulusnetworks.com 20 iptables -A FORWARD -j DROP -i swp1 -p icmp --icmp-type echo-request ip access-list extended block_icmp deny icmp any any echo interface g0/0 ip access-group block_icmp in Cumulus Linux Cisco
  • 21. Block SSH Trafficfrom the Specified Subnet (5.5.5.0/24) cumulusnetworks.com 21 iptables -A INPUT -j DROP -p tcp -s 5.5.5.0/24 --dport 22 ip access-list extended block_ssh deny tcp 5.5.5.0 0.0.0.255 192.50.50.0 0.0.0.255 eq 22 interface g0/0 ip access-group block_ssh in Cumulus Linux Cisco
  • 22. Allow NTP Traffic to Transitthe Switch (UDP Port 123) cumulusnetworks.com 22 iptables -A FORWARD -j ACCEPT -p udp -s 192.168.1.0/24 --dport 123 ip access-list extended allow_ntp permit udp 192.168.1.0 0.0.0.255 any eq ntp interface g0/0 ip access-group allow_ntp in Cumulus Linux Cisco
  • 23. Policing a Physical Interface cumulusnetworks.com 23 -A FORWARD --in-interface swp1 -j POLICE --set-mode KB --set-rate 125000 --set-burst 2000 Cumulus Linux cumulus@leaf1$ sudo cl-acltool -L ip | grep swp1 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp1 any anywhere anywhere POLICE mode:KB rate:125000 burst:2000 Output policy-map sean class class-default police cir 1000000000 interface TenGigabitEthernet1/13 service-policy input sean Cisco
  • 24. Policing DSCP Values cumulusnetworks.com 24 -A FORWARD --in-interface swp2 -m dscp --dscp 10 -j POLICE --set-mode KB --set-rate 31250 --set-burst 2000 cumulus@leaf1$ sudo cl-acltool -L ip | grep swp2 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp2 any anywhere anywhere DSCP match 0x0a POLICE mode:KB rate:31250 burst:2000 Cumulus Linux Output class-map match-all dscp10 match dscp af11 ! policy-map sean2 class dscp10 police cir 250000000 ! interface TenGigabitEthernet1/14 service-policy input sean2 Cisco
  • 25. Policing by Source Traffic cumulusnetworks.com 25 -A FORWARD --in-interface swp3 -j POLICE --set-mode KB --set-rate 12500 --set-burst 2000 -s 3.3.3.0/24 cumulus@leaf1$ sudo cl-acltool -L ip | grep swp3 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp3 any 3.3.3.0/24 anywhere POLICE mode:KB rate:12500 burst:2000 Cumulus Linux access-list 100 permit ip 3.3.3.0 0.0.0.255 any ! class-map match-all heller match access-group 100 ! policy-map heller class heller police cir 100000000 ! interface TenGigabitEthernet1/15 service-policy input heller Cisco Output
  • 26. Time Zone Configuration cumulusnetworks.com 26 switch# configure terminal switch(config)# clock timezone PST -8 0 switch(config)# exit switch# show clock switch# copy running-config startup-config Cumulus Linux Cisco cumulus@switch:~$ sudo tzconfg cumulus@switch:~$ sudo hwclock
  • 27. NTP cumulusnetworks.com 27 switch# clock protocol ntp vdc 1 Cumulus Linux Cisco Set NTP (e.g. to VDC 1) cumulus@switch:~$ sudo vi /etc/ntp.conf cumulus@switch:~$ ntpd –q
  • 28. Show Management Interface Current Configuration cumulusnetworks.com 28 switch# show interface mgmt 0 Cumulus Linux Cisco cumulus@switch:~$ ifquery eth0
  • 29. DHCP Relay cumulusnetworks.com 29 cumulus@switch:~$ sudo vi /etc/default/isc-dhcp-relay SERVERS="192.168.123.4" INTERFACES="bridge swp4 swp5" cumulus@switch:~$ sudo /etc/init.d/isc-dhcp-relay restart Cumulus Linux Cisco switch# configure terminal switch(config)# ip dhcp relay switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# ip dhcp relay address 192.168.123.4
  • 30. CLI Basics cumulusnetworks.com 30 Show command history cumulus@switch:~$ history switch# show cli history Cumulus Linux Cisco Send message to all logged on users cumulus@switch:~$ echo message | sudo wall switch# send message Send message to specific user cumulus@switch:~$ sudo write user-id switch# show users switch# send session line message
  • 31. CLI Basics cumulusnetworks.com 31 Show SPROM information cumulus@switch:~$ decode-syseeprom switch# show sprom Cumulus Linux Cisco Show hardware states (temperature, fan, power) cumulus@switch:~$ sudo smonctl switch# show environment Show memory allocation cumulus@switch:~$ vmstat switch# show processes memory Show real-time memory usage cumulus@switch:~$ vmstat 1 Alternative command cumulus@switch:~$ free cumulus@switch:~$ sudo sensors
  • 32. CLI Basics cumulusnetworks.com 32 Show CPU processes and utilization cumulus@switch:~$ ps aux switch# show processes Cumulus Linux Cisco Show hardware information cumulus@switch:~$ dmidecode switch# show inventory Show high level port state cumulus@switch:~$ netshow interface switch# show ip int br cumulus@switch:~$ top switch# show processes cpu cumulus@switch:~$ netshow system
  • 33. CLI Basics cumulusnetworks.com 33 Show interface neighbors cumulus@switch:~$ lldpctl switch# show lldp neigbhors Cumulus Linux Cisco Show interface connector information cumulus@switch:~$ sudo ethtool –m swp1 switch# show interface ethernet 1/1 transceiver Reboot switch cumulus@switch:~$ sudo reboot switch# reload cumulus@switch:~$ netshow lldp
  • 34. Show ARP Table cumulusnetworks.com 34 root@leaf01:~# arp –n Address HWtype HWaddress Flags Mask Iface 10.2.0.254 ether 44:38:39:00:00:29 C eth0 169.254.1.2 ether 44:38:39:00:00:30 C peerlink.4094 169.254.0.1 ether 44:38:39:00:00:08 CM swp49 169.254.0.1 ether 44:38:39:00:00:14 CM swp50 Cumulus Linux Cisco switch# show ip arp IP ARP Table for context default Total number of entries: 1 Address Age MAC Address Interface 90.10.10.2 00:03:11 000d.ece7.df7c Vlan900
  • 35. Configure SNMP (Net-SNMP) cumulusnetworks.com 35 cumulus@switch:~$ sudo vi /etc/snmp/snmpd.conf cumulus@switch:~$ sudo vi /etc/snmp/snmptrapd.conf switch# configure terminal switch(config)# snmp-server host ip-address traps version 2c public Cumulus Linux Cisco https://docs.cumulusnetworks.com/display/DOCS/Monitoring+System+Hardware Detailed Info
  • 36. © 2016 Cumulus Networks. CUMULUS, the Cumulus Logo, CUMULUS NETWORKS, and the Rocket Turtle Logo (the “Marks”) are trademarks and service marks of Cumulus Networks, Inc. in the U.S. and other countries. You are not permitted touse the Marks without theprior written consent of Cumulus Networks. The registered trademark Linux® is used pursuant to a sublicense from LMI, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis. All other marks are used under fair use or license from their respective owners. §Thank You! cumulusnetworks.com 36 Bringing the Linux Revolution to Networking