SlideShare a Scribd company logo
1 of 11
Download to read offline
[CookBook] Ansible_4_Dell EMC Networking
This document is the purpose of education for Ansible on the DELL EMC OS10
Copyright <2019> Hoon_Jo@dell.com < Github : https://github.com/sysnet4admin >
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and
associated documentation files (the "Software"), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to whom the Software is furnished to
do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
0. Pre-Conditions
Predifined Group_Vars
ansible_user: ansible
ansible_ssh_pass: Ansible00
ansible_become_method: enable
ansible_become: yes
ansible_become_pass: admin
ansible_network_os: dellos10
ansible_connection: network_cli
Config Chagne
[vagrant@ansible-server ~]$ ansible-config dump --only-changed
HOST_KEY_CHECKING(/etc/ansible/ansible.cfg) = False
PERSISTENT_COMMAND_TIMEOUT(/etc/ansible/ansible.cfg) = 60
Inventory
[dellos10]
172.16.1.[1:4]
Topology
1. ad-hoc
1-1. Source Code
ansible dellos10 -m ping
ansible dellos10 -m dellos10_command -a "commands='show version'"
[Code 1-1] 1.ad-hoc
1.2. Run the Code
Note: ans = ansible (alias)
[vagrant@ansible-server ~]$ ans dellos10 -m ping
172.16.1.1 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"ping": "pong"
}
172.16.1.3 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"ping": "pong"
}
172.16.1.2 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"ping": "pong"
}
172.16.1.4 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"ping": "pong"
}
[vagrant@ansible-server ~]$ ans dellos10 -m dellos10_command -a 
"commands='show version'"
172.16.1.1 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"stdout": [
"Dell EMC Networking OS10-EnterprisenCopyright (c) 1999-2019 by Dell
Inc. All Rights Reserved.nOS Version: 10.4.3.1nBuild Version:
10.4.3.1.154nBuild Time: 2019-03-20T18:16:25-0700nSystem Type: S4048-
ONnArchitecture: x86_64nUp Time: 02:11:07"
],
"stdout_lines": [
[
"Dell EMC Networking OS10-Enterprise",
"Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.",
"OS Version: 10.4.3.1",
"Build Version: 10.4.3.1.154",
"Build Time: 2019-03-20T18:16:25-0700",
"System Type: S4048-ON",
"Architecture: x86_64",
"Up Time: 02:11:07"
]
]
}
172.16.1.3 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"stdout": [
"Dell EMC Networking OS10 EnterprisenCopyright (c) 1999-2019 by Dell
Inc. All Rights Reserved.nOS Version: 10.5.0.0nBuild Version:
10.5.0.0.326nBuild Time: 2019-08-07T00:12:30+0000nSystem Type: S4148U-
ONnArchitecture: x86_64nUp Time: 02:10:59"
],
"stdout_lines": [
[
"Dell EMC Networking OS10 Enterprise",
"Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.",
"OS Version: 10.5.0.0",
"Build Version: 10.5.0.0.326",
"Build Time: 2019-08-07T00:12:30+0000",
"System Type: S4148U-ON",
"Architecture: x86_64",
"Up Time: 02:10:59"
]
]
}
172.16.1.2 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"stdout": [
"Dell EMC Networking OS10-EnterprisenCopyright (c) 1999-2019 by Dell
Inc. All Rights Reserved.nOS Version: 10.4.3.1nBuild Version:
10.4.3.1.154nBuild Time: 2019-03-20T18:16:25-0700nSystem Type: S4048-
ONnArchitecture: x86_64nUp Time: 02:11:08"
],
"stdout_lines": [
[
"Dell EMC Networking OS10-Enterprise",
"Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.",
"OS Version: 10.4.3.1",
"Build Version: 10.4.3.1.154",
"Build Time: 2019-03-20T18:16:25-0700",
"System Type: S4048-ON",
"Architecture: x86_64",
"Up Time: 02:11:08"
]
]
}
172.16.1.4 | SUCCESS => {
"ansible_facts": {
"discovered_interpreter_python": "/usr/bin/python"
},
"changed": false,
"stdout": [
"Dell EMC Networking OS10 EnterprisenCopyright (c) 1999-2019 by Dell
Inc. All Rights Reserved.nOS Version: 10.5.0.0nBuild Version:
10.5.0.0.326nBuild Time: 2019-08-07T00:12:30+0000nSystem Type: S4112T-
ONnArchitecture: x86_64nUp Time: 02:11:03"
],
"stdout_lines": [
[
"Dell EMC Networking OS10 Enterprise",
"Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.",
"OS Version: 10.5.0.0",
"Build Version: 10.5.0.0.326",
"Build Time: 2019-08-07T00:12:30+0000",
"System Type: S4112T-ON",
"Architecture: x86_64",
"Up Time: 02:11:03"
]
]
}
2. Create new VLAN
2.1. Source Code
---
- name: Create vlan for LEFT spine
hosts: dellos10[0]
gather_facts: no
tasks:
- name: input config for int vlan 11
dellos10_config:
lines:
- interface vlan 11
- ip address 11.1.1.1/24
- no shutdown
- name: input config for po1
dellos10_config:
lines:
- interface port-channel 1
- switchport trunk allowed vlan 11
- name: Create vlan for RIGHT spine
hosts: dellos10[1]
gather_facts: no
tasks:
- name: input config for int vlan 11
dellos10_config:
lines:
- interface vlan 11
- ip address 11.1.1.2/24
- no shutdown
- name: input config for po1
dellos10_config:
lines:
- interface port-channel 1
- switchport trunk allowed vlan 11
- name: Create vlan for TOR
hosts: dellos10[2]
gather_facts: no
tasks:
- name: input config for int vlan 11
dellos10_config:
lines:
- interface vlan 11
- no shutdown
- name: input config for uplink
dellos10_config:
lines:
- interface port-channel 1
- switchport trunk allowed vlan 11
- name: input config for downlink
dellos10_config:
lines:
- interface ethernet 1/1/27
- switchport trunk allowed vlan 11
- name: Create vlan for Access
hosts: dellos10[3]
gather_facts: no
tasks:
- name: input config for int vlan 11
dellos10_config:
lines:
- interface vlan 11
- ip address 11.1.1.4/24
- no shutdown
- name: input config for uplink
dellos10_config:
lines:
- 'interface ethernet 1/1/13:1'
- switchport trunk allowed vlan 11
[Code 2-1] 2.cr_vlan.yml
2.2. Run the Code
Note: anp = ansible-playbook (alias)
[vagrant@ansible-server ~]$ anp cr_vlan.yml
PLAY [Create vlan for LEFT spine] *********************************************
TASK [input config for int vlan 11] *******************************************
changed: [172.16.1.1]
TASK [input config for po1] ***************************************************
changed: [172.16.1.1]
PLAY [Create vlan for RIGHT spine] ********************************************
TASK [input config for int vlan 11] *******************************************
changed: [172.16.1.2]
TASK [input config for po1] ***************************************************
changed: [172.16.1.2]
PLAY [Create vlan for TOR] ****************************************************
TASK [input config for int vlan 11] *******************************************
changed: [172.16.1.3]
TASK [input config for uplink] ************************************************
changed: [172.16.1.3]
TASK [input config for downlink] **********************************************
changed: [172.16.1.3]
PLAY [Create vlan for Access] *************************************************
TASK [input config for int vlan 11] *******************************************
changed: [172.16.1.4]
TASK [input config for uplink] ************************************************
changed: [172.16.1.4]
PLAY RECAP ********************************************************************
172.16.1.1 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
172.16.1.2 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
172.16.1.3 : ok=3 changed=3 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
172.16.1.4 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
2.3. Check Status
[ Access: ping to left Spine ]
S4112T# ping 11.1.1.1
PING 11.1.1.1 (11.1.1.1) 56(84) bytes of data.
64 bytes from 11.1.1.1: icmp_seq=1 ttl=64 time=1.02 ms
64 bytes from 11.1.1.1: icmp_seq=2 ttl=64 time=0.984 ms
64 bytes from 11.1.1.1: icmp_seq=3 ttl=64 time=0.983 ms
^C
--- 11.1.1.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 0.983/0.997/1.025/0.032 ms
[ Access: ping to right Spine ]
S4112T# ping 11.1.1.2
PING 11.1.1.2 (11.1.1.2) 56(84) bytes of data.
64 bytes from 11.1.1.2: icmp_seq=1 ttl=64 time=0.891 ms
64 bytes from 11.1.1.2: icmp_seq=2 ttl=64 time=0.835 ms
64 bytes from 11.1.1.2: icmp_seq=3 ttl=64 time=0.957 ms
^C
--- 11.1.1.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2009ms
rtt min/avg/max/mdev = 0.835/0.894/0.957/0.055 ms
3. Config BFD
3.1. Source Code
---
- name: Config BFD for LEFT spine
hosts: dellos10[0]
gather_facts: no
tasks:
- name: input config for loopback0
dellos10_config:
lines:
- interface loopback 0
- ip address 1.1.1.1/32
- no shutdown
- name: input config for routing
dellos10_config:
lines:
- ip route 4.4.4.4/32 11.1.1.4
- name: Config BFD for RIGHT spine
hosts: dellos10[1]
gather_facts: no
tasks:
- name: input config for loopback0
dellos10_config:
lines:
- interface loopback 0
- ip address 2.2.2.2/32
- no shutdown
- name: input config for routing
dellos10_config:
lines:
- ip route 4.4.4.4/32 11.1.1.4
- name: Config BFD for Access
hosts: dellos10[3]
gather_facts: no
tasks:
- name: input config for loopback0
dellos10_config:
lines:
- interface loopback 0
- ip address 4.4.4.4/32
- no shutdown
- name: input config for routing
dellos10_config:
lines:
- ip route 1.1.1.1/32 11.1.1.1
- ip route 2.2.2.2/32 11.1.1.2
[Code 3-1] 3.cfg_BFD.yml
3.2. Run the Code
Note: anp = ansible-playbook (alias)
[vagrant@ansible-server ~]$ anp 3.cfg_BFD.yml
PLAY [Config BFD for LEFT spine] **********************************************
TASK [input config for loopback0] *********************************************
changed: [172.16.1.1]
TASK [input config for routing] ***********************************************
changed: [172.16.1.1]
PLAY [Config BFD for RIGHT spine] *********************************************
TASK [input config for loopback0] *********************************************
changed: [172.16.1.2]
TASK [input config for routing] ***********************************************
changed: [172.16.1.2]
PLAY [Config BFD for Access] **************************************************
TASK [input config for loopback0] *********************************************
changed: [172.16.1.4]
TASK [input config for routing] ***********************************************
changed: [172.16.1.4]
PLAY RECAP ********************************************************************
172.16.1.1 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
172.16.1.2 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
172.16.1.4 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0
3.3. Check Status
[ Left Spine : show bfd neighbors ]
S4048-1# show bfd neighbors
* - Active session role
-----------------------------------------------------------------------------------------
LocalAddr RemoteAddr Interface State RxInt TxInt Mult VRF Clients
-----------------------------------------------------------------------------------------
* 10.1.1.1 10.1.1.4 vlan10 up 200 200 3 default rtmv4
* 11.1.1.1 11.1.1.4 vlan11 up 200 200 3 default rtmv4
[ Right Spine : show bfd neighbors ]
S4048-2# show bfd neighbors
* - Active session role
-----------------------------------------------------------------------------------------
LocalAddr RemoteAddr Interface State RxInt TxInt Mult VRF Clients
-----------------------------------------------------------------------------------------
* 10.1.1.2 10.1.1.4 vlan10 up 200 200 3 default rtmv4
* 11.1.1.2 11.1.1.4 vlan11 up 200 200 3 default rtmv4
[ Access: show bfd neighbors ]
S4112T# show bfd neighbors
* - Active session role
-----------------------------------------------------------------------------------------
LocalAddr RemoteAddr Interface State RxInt TxInt Mult VRF Clients
-----------------------------------------------------------------------------------------
* 10.1.1.4 10.1.1.1 vlan10 up 200 200 3 default rtmv4
* 10.1.1.4 10.1.1.2 vlan10 up 200 200 3 default rtmv4
* 11.1.1.4 11.1.1.1 vlan11 up 200 200 3 default rtmv4
* 11.1.1.4 11.1.1.2 vlan11 up 200 200 3 default rtmv4

More Related Content

What's hot

An Express Guide ~ Zabbix for IT Monitoring
An Express Guide ~ Zabbix for IT Monitoring An Express Guide ~ Zabbix for IT Monitoring
An Express Guide ~ Zabbix for IT Monitoring Abhishek Kumar
 
Open vpn server_linux
Open vpn server_linuxOpen vpn server_linux
Open vpn server_linuxTola LENG
 
Oracle forms and reports 11g installation on linux
Oracle forms and reports 11g installation on linuxOracle forms and reports 11g installation on linux
Oracle forms and reports 11g installation on linuxVenu Palakolanu
 
Dependency management with Composer
Dependency management with ComposerDependency management with Composer
Dependency management with ComposerJason Grimes
 
Composer the right way - SunshinePHP
Composer the right way - SunshinePHPComposer the right way - SunshinePHP
Composer the right way - SunshinePHPRafael Dohms
 
Configure Proxy and Firewall (Iptables)
Configure Proxy and Firewall (Iptables)Configure Proxy and Firewall (Iptables)
Configure Proxy and Firewall (Iptables)Tola LENG
 
Composer for Busy Developers - php|tek13
Composer for Busy Developers - php|tek13Composer for Busy Developers - php|tek13
Composer for Busy Developers - php|tek13Rafael Dohms
 
Presentation Linux Server setup Advance Networking
Presentation   Linux Server setup Advance NetworkingPresentation   Linux Server setup Advance Networking
Presentation Linux Server setup Advance NetworkingTariqul Islam Shohag
 
Ad, dns, dhcp, file server
Ad, dns, dhcp, file serverAd, dns, dhcp, file server
Ad, dns, dhcp, file serverTola LENG
 
Configure DHCP Server and DHCP-Relay
Configure DHCP Server and DHCP-RelayConfigure DHCP Server and DHCP-Relay
Configure DHCP Server and DHCP-RelayTola LENG
 
Learnings from Real eZ Publish 5 Projects
Learnings from Real eZ Publish 5 ProjectsLearnings from Real eZ Publish 5 Projects
Learnings from Real eZ Publish 5 ProjectsDonat Fritschy
 
Licão 08 system redirects
Licão 08 system redirectsLicão 08 system redirects
Licão 08 system redirectsAcácio Oliveira
 
Basic security &amp; info
Basic security &amp; infoBasic security &amp; info
Basic security &amp; infoTola LENG
 
Releasing Elixir/Phoenix Applications
Releasing Elixir/Phoenix ApplicationsReleasing Elixir/Phoenix Applications
Releasing Elixir/Phoenix ApplicationsWise Engineering
 
Yaroslav Martsynyuk - Deploying Elixir/Phoenix with Distillery
Yaroslav Martsynyuk - Deploying Elixir/Phoenix with DistilleryYaroslav Martsynyuk - Deploying Elixir/Phoenix with Distillery
Yaroslav Martsynyuk - Deploying Elixir/Phoenix with DistilleryElixir Club
 

What's hot (19)

An Express Guide ~ Zabbix for IT Monitoring
An Express Guide ~ Zabbix for IT Monitoring An Express Guide ~ Zabbix for IT Monitoring
An Express Guide ~ Zabbix for IT Monitoring
 
Open vpn server_linux
Open vpn server_linuxOpen vpn server_linux
Open vpn server_linux
 
Oracle forms and reports 11g installation on linux
Oracle forms and reports 11g installation on linuxOracle forms and reports 11g installation on linux
Oracle forms and reports 11g installation on linux
 
Dependency management with Composer
Dependency management with ComposerDependency management with Composer
Dependency management with Composer
 
Composer the right way - SunshinePHP
Composer the right way - SunshinePHPComposer the right way - SunshinePHP
Composer the right way - SunshinePHP
 
Configure Proxy and Firewall (Iptables)
Configure Proxy and Firewall (Iptables)Configure Proxy and Firewall (Iptables)
Configure Proxy and Firewall (Iptables)
 
Composer for Busy Developers - php|tek13
Composer for Busy Developers - php|tek13Composer for Busy Developers - php|tek13
Composer for Busy Developers - php|tek13
 
Presentation Linux Server setup Advance Networking
Presentation   Linux Server setup Advance NetworkingPresentation   Linux Server setup Advance Networking
Presentation Linux Server setup Advance Networking
 
ProdQMScripts.cmd
ProdQMScripts.cmdProdQMScripts.cmd
ProdQMScripts.cmd
 
Ad, dns, dhcp, file server
Ad, dns, dhcp, file serverAd, dns, dhcp, file server
Ad, dns, dhcp, file server
 
Configure DHCP Server and DHCP-Relay
Configure DHCP Server and DHCP-RelayConfigure DHCP Server and DHCP-Relay
Configure DHCP Server and DHCP-Relay
 
DNS SERVER
DNS SERVERDNS SERVER
DNS SERVER
 
Learnings from Real eZ Publish 5 Projects
Learnings from Real eZ Publish 5 ProjectsLearnings from Real eZ Publish 5 Projects
Learnings from Real eZ Publish 5 Projects
 
How to ride a whale
How to ride a whaleHow to ride a whale
How to ride a whale
 
Licão 08 system redirects
Licão 08 system redirectsLicão 08 system redirects
Licão 08 system redirects
 
Basic security &amp; info
Basic security &amp; infoBasic security &amp; info
Basic security &amp; info
 
Releasing Elixir/Phoenix Applications
Releasing Elixir/Phoenix ApplicationsReleasing Elixir/Phoenix Applications
Releasing Elixir/Phoenix Applications
 
Yaroslav Martsynyuk - Deploying Elixir/Phoenix with Distillery
Yaroslav Martsynyuk - Deploying Elixir/Phoenix with DistilleryYaroslav Martsynyuk - Deploying Elixir/Phoenix with Distillery
Yaroslav Martsynyuk - Deploying Elixir/Phoenix with Distillery
 
Rac
RacRac
Rac
 

Similar to [Cook book] ansible 4_dell emc networking

Alfresco Environment Validation and "Day Zero" Configuration
Alfresco Environment Validation and "Day Zero" ConfigurationAlfresco Environment Validation and "Day Zero" Configuration
Alfresco Environment Validation and "Day Zero" ConfigurationAlfresco Software
 
Docker &amp; rancher
Docker &amp; rancherDocker &amp; rancher
Docker &amp; rancherAlin Voinea
 
1.4.2-basic-configuration-with-mikrotik-cli.pdf
1.4.2-basic-configuration-with-mikrotik-cli.pdf1.4.2-basic-configuration-with-mikrotik-cli.pdf
1.4.2-basic-configuration-with-mikrotik-cli.pdfDeivysVargas
 
Vagrant, Ansible, and OpenStack on your laptop
Vagrant, Ansible, and OpenStack on your laptopVagrant, Ansible, and OpenStack on your laptop
Vagrant, Ansible, and OpenStack on your laptopLorin Hochstein
 
Percona Live 2012PPT:mysql-security-privileges-and-user-management
Percona Live 2012PPT:mysql-security-privileges-and-user-managementPercona Live 2012PPT:mysql-security-privileges-and-user-management
Percona Live 2012PPT:mysql-security-privileges-and-user-managementmysqlops
 
Automatisation in development and testing - within budget
Automatisation in development and testing - within budgetAutomatisation in development and testing - within budget
Automatisation in development and testing - within budgetDavid Lukac
 
Deployment Tactics
Deployment TacticsDeployment Tactics
Deployment TacticsIan Barber
 
Huawei AR 150 Series.pptx
Huawei AR 150 Series.pptxHuawei AR 150 Series.pptx
Huawei AR 150 Series.pptxssuser03d8b1
 
Composer for busy developers - DPC13
Composer for busy developers - DPC13Composer for busy developers - DPC13
Composer for busy developers - DPC13Rafael Dohms
 
ONOS SDN Controller - Clustering Tests & Experiments
ONOS SDN Controller - Clustering Tests & Experiments ONOS SDN Controller - Clustering Tests & Experiments
ONOS SDN Controller - Clustering Tests & Experiments Eueung Mulyana
 
Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...
Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...
Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...mCloud
 
The Enterprise Wor/d/thy/Press
The Enterprise Wor/d/thy/PressThe Enterprise Wor/d/thy/Press
The Enterprise Wor/d/thy/PressJeroen van Dijk
 
Oracle obiee-11-installation-guide 11.1.1.6.0
Oracle obiee-11-installation-guide 11.1.1.6.0Oracle obiee-11-installation-guide 11.1.1.6.0
Oracle obiee-11-installation-guide 11.1.1.6.0Aadiseshu Immadisetty
 
Módulo de docker compose para ensino e aprendizagem do yml para docker
Módulo de docker compose para ensino e aprendizagem do yml para dockerMódulo de docker compose para ensino e aprendizagem do yml para docker
Módulo de docker compose para ensino e aprendizagem do yml para dockerDiogo Soares Moreira
 
Buildout: How to maintain big app stacks without losing your mind
Buildout: How to maintain big app stacks without losing your mindBuildout: How to maintain big app stacks without losing your mind
Buildout: How to maintain big app stacks without losing your mindDylan Jay
 
Getting started with SIP Express Media Server SIP app server and SBC - workshop
Getting started with SIP Express Media Server SIP app server and SBC - workshopGetting started with SIP Express Media Server SIP app server and SBC - workshop
Getting started with SIP Express Media Server SIP app server and SBC - workshopstefansayer
 
OSMC 2021 | Icinga-Installer – the easy way to your Icinga
OSMC 2021 | Icinga-Installer – the easy way to your IcingaOSMC 2021 | Icinga-Installer – the easy way to your Icinga
OSMC 2021 | Icinga-Installer – the easy way to your IcingaNETWAYS
 

Similar to [Cook book] ansible 4_dell emc networking (20)

Commcon 2018
Commcon 2018Commcon 2018
Commcon 2018
 
Alfresco Environment Validation and "Day Zero" Configuration
Alfresco Environment Validation and "Day Zero" ConfigurationAlfresco Environment Validation and "Day Zero" Configuration
Alfresco Environment Validation and "Day Zero" Configuration
 
Docker &amp; rancher
Docker &amp; rancherDocker &amp; rancher
Docker &amp; rancher
 
1.4.2-basic-configuration-with-mikrotik-cli.pdf
1.4.2-basic-configuration-with-mikrotik-cli.pdf1.4.2-basic-configuration-with-mikrotik-cli.pdf
1.4.2-basic-configuration-with-mikrotik-cli.pdf
 
Vagrant, Ansible, and OpenStack on your laptop
Vagrant, Ansible, and OpenStack on your laptopVagrant, Ansible, and OpenStack on your laptop
Vagrant, Ansible, and OpenStack on your laptop
 
Percona Live 2012PPT:mysql-security-privileges-and-user-management
Percona Live 2012PPT:mysql-security-privileges-and-user-managementPercona Live 2012PPT:mysql-security-privileges-and-user-management
Percona Live 2012PPT:mysql-security-privileges-and-user-management
 
Automatisation in development and testing - within budget
Automatisation in development and testing - within budgetAutomatisation in development and testing - within budget
Automatisation in development and testing - within budget
 
Deployment Tactics
Deployment TacticsDeployment Tactics
Deployment Tactics
 
Huawei AR 150 Series.pptx
Huawei AR 150 Series.pptxHuawei AR 150 Series.pptx
Huawei AR 150 Series.pptx
 
Composer for busy developers - DPC13
Composer for busy developers - DPC13Composer for busy developers - DPC13
Composer for busy developers - DPC13
 
Mini CTF workshop dump
Mini CTF workshop dumpMini CTF workshop dump
Mini CTF workshop dump
 
ONOS SDN Controller - Clustering Tests & Experiments
ONOS SDN Controller - Clustering Tests & Experiments ONOS SDN Controller - Clustering Tests & Experiments
ONOS SDN Controller - Clustering Tests & Experiments
 
Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...
Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...
Developers’ mDay 2019. - Rastko Vasiljević, SuperAdmins – Infrastructure as c...
 
The Enterprise Wor/d/thy/Press
The Enterprise Wor/d/thy/PressThe Enterprise Wor/d/thy/Press
The Enterprise Wor/d/thy/Press
 
Oracle obiee-11-installation-guide 11.1.1.6.0
Oracle obiee-11-installation-guide 11.1.1.6.0Oracle obiee-11-installation-guide 11.1.1.6.0
Oracle obiee-11-installation-guide 11.1.1.6.0
 
Módulo de docker compose para ensino e aprendizagem do yml para docker
Módulo de docker compose para ensino e aprendizagem do yml para dockerMódulo de docker compose para ensino e aprendizagem do yml para docker
Módulo de docker compose para ensino e aprendizagem do yml para docker
 
Buildout: How to maintain big app stacks without losing your mind
Buildout: How to maintain big app stacks without losing your mindBuildout: How to maintain big app stacks without losing your mind
Buildout: How to maintain big app stacks without losing your mind
 
Getting started with SIP Express Media Server SIP app server and SBC - workshop
Getting started with SIP Express Media Server SIP app server and SBC - workshopGetting started with SIP Express Media Server SIP app server and SBC - workshop
Getting started with SIP Express Media Server SIP app server and SBC - workshop
 
OSMC 2021 | Icinga-Installer – the easy way to your Icinga
OSMC 2021 | Icinga-Installer – the easy way to your IcingaOSMC 2021 | Icinga-Installer – the easy way to your Icinga
OSMC 2021 | Icinga-Installer – the easy way to your Icinga
 
WP-CLI: Unleash the power
WP-CLI: Unleash the powerWP-CLI: Unleash the power
WP-CLI: Unleash the power
 

More from Jo Hoon

이스티오 (Istio) 자습서 v0.5.0
이스티오 (Istio) 자습서 v0.5.0이스티오 (Istio) 자습서 v0.5.0
이스티오 (Istio) 자습서 v0.5.0Jo Hoon
 
[GitOps] Argo CD on GKE (v0.9.2).pdf
[GitOps] Argo CD on GKE (v0.9.2).pdf[GitOps] Argo CD on GKE (v0.9.2).pdf
[GitOps] Argo CD on GKE (v0.9.2).pdfJo Hoon
 
Prometheus on EKS
Prometheus on EKSPrometheus on EKS
Prometheus on EKSJo Hoon
 
Prometheus on NKS
Prometheus on NKSPrometheus on NKS
Prometheus on NKSJo Hoon
 
[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdf
[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdf[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdf
[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdfJo Hoon
 
[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요
[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요
[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요Jo Hoon
 
왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요
왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요
왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요Jo Hoon
 
CDN on GKE with Ingress
CDN on GKE with IngressCDN on GKE with Ingress
CDN on GKE with IngressJo Hoon
 
The myths of deprecating docker in kubernetes
The myths of deprecating docker in kubernetesThe myths of deprecating docker in kubernetes
The myths of deprecating docker in kubernetesJo Hoon
 
온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)
온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)
온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)Jo Hoon
 
[네전따 27회] 네트워크 자동화 어렵지 않아요
[네전따 27회] 네트워크 자동화 어렵지 않아요[네전따 27회] 네트워크 자동화 어렵지 않아요
[네전따 27회] 네트워크 자동화 어렵지 않아요Jo Hoon
 
Wiki academy sysadmin 10_day
Wiki academy sysadmin 10_dayWiki academy sysadmin 10_day
Wiki academy sysadmin 10_dayJo Hoon
 
Wiki academy sysadmin 4_day
Wiki academy sysadmin 4_dayWiki academy sysadmin 4_day
Wiki academy sysadmin 4_dayJo Hoon
 
Wiki academy sysadmin 3_day
Wiki academy sysadmin 3_dayWiki academy sysadmin 3_day
Wiki academy sysadmin 3_dayJo Hoon
 
Wiki academy sysadmin 2_day
Wiki academy sysadmin 2_dayWiki academy sysadmin 2_day
Wiki academy sysadmin 2_dayJo Hoon
 
Wiki academy sysadmin 1_day
Wiki academy sysadmin 1_dayWiki academy sysadmin 1_day
Wiki academy sysadmin 1_dayJo Hoon
 
Wiki academy sysadmin 9_day
Wiki academy sysadmin 9_dayWiki academy sysadmin 9_day
Wiki academy sysadmin 9_dayJo Hoon
 
Wiki academy sysadmin 8_day
Wiki academy sysadmin 8_dayWiki academy sysadmin 8_day
Wiki academy sysadmin 8_dayJo Hoon
 
Wiki academy sysadmin 7_day
Wiki academy sysadmin 7_dayWiki academy sysadmin 7_day
Wiki academy sysadmin 7_dayJo Hoon
 
Wiki academy sysadmin 6_day
Wiki academy sysadmin 6_dayWiki academy sysadmin 6_day
Wiki academy sysadmin 6_dayJo Hoon
 

More from Jo Hoon (20)

이스티오 (Istio) 자습서 v0.5.0
이스티오 (Istio) 자습서 v0.5.0이스티오 (Istio) 자습서 v0.5.0
이스티오 (Istio) 자습서 v0.5.0
 
[GitOps] Argo CD on GKE (v0.9.2).pdf
[GitOps] Argo CD on GKE (v0.9.2).pdf[GitOps] Argo CD on GKE (v0.9.2).pdf
[GitOps] Argo CD on GKE (v0.9.2).pdf
 
Prometheus on EKS
Prometheus on EKSPrometheus on EKS
Prometheus on EKS
 
Prometheus on NKS
Prometheus on NKSPrometheus on NKS
Prometheus on NKS
 
[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdf
[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdf[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdf
[GuideDoc] Deploy EKS thru eksctl - v1.22_v0.105.0.pdf
 
[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요
[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요
[네전따] 네트워크 엔지니어에게 쿠버네티스는 어떤 의미일까요
 
왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요
왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요
왜 쿠버네티스는 systemd로 cgroup을 관리하려고 할까요
 
CDN on GKE with Ingress
CDN on GKE with IngressCDN on GKE with Ingress
CDN on GKE with Ingress
 
The myths of deprecating docker in kubernetes
The myths of deprecating docker in kubernetesThe myths of deprecating docker in kubernetes
The myths of deprecating docker in kubernetes
 
온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)
온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)
온프레미스 쿠버네티스에서도 로드밸런서를 (w MetalLB)
 
[네전따 27회] 네트워크 자동화 어렵지 않아요
[네전따 27회] 네트워크 자동화 어렵지 않아요[네전따 27회] 네트워크 자동화 어렵지 않아요
[네전따 27회] 네트워크 자동화 어렵지 않아요
 
Wiki academy sysadmin 10_day
Wiki academy sysadmin 10_dayWiki academy sysadmin 10_day
Wiki academy sysadmin 10_day
 
Wiki academy sysadmin 4_day
Wiki academy sysadmin 4_dayWiki academy sysadmin 4_day
Wiki academy sysadmin 4_day
 
Wiki academy sysadmin 3_day
Wiki academy sysadmin 3_dayWiki academy sysadmin 3_day
Wiki academy sysadmin 3_day
 
Wiki academy sysadmin 2_day
Wiki academy sysadmin 2_dayWiki academy sysadmin 2_day
Wiki academy sysadmin 2_day
 
Wiki academy sysadmin 1_day
Wiki academy sysadmin 1_dayWiki academy sysadmin 1_day
Wiki academy sysadmin 1_day
 
Wiki academy sysadmin 9_day
Wiki academy sysadmin 9_dayWiki academy sysadmin 9_day
Wiki academy sysadmin 9_day
 
Wiki academy sysadmin 8_day
Wiki academy sysadmin 8_dayWiki academy sysadmin 8_day
Wiki academy sysadmin 8_day
 
Wiki academy sysadmin 7_day
Wiki academy sysadmin 7_dayWiki academy sysadmin 7_day
Wiki academy sysadmin 7_day
 
Wiki academy sysadmin 6_day
Wiki academy sysadmin 6_dayWiki academy sysadmin 6_day
Wiki academy sysadmin 6_day
 

Recently uploaded

Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticsKotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticscarlostorres15106
 
A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)Gabriella Davis
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerThousandEyes
 
Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...Alan Dix
 
Factors to Consider When Choosing Accounts Payable Services Providers.pptx
Factors to Consider When Choosing Accounts Payable Services Providers.pptxFactors to Consider When Choosing Accounts Payable Services Providers.pptx
Factors to Consider When Choosing Accounts Payable Services Providers.pptxKatpro Technologies
 
Maximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptxMaximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptxOnBoard
 
Azure Monitor & Application Insight to monitor Infrastructure & Application
Azure Monitor & Application Insight to monitor Infrastructure & ApplicationAzure Monitor & Application Insight to monitor Infrastructure & Application
Azure Monitor & Application Insight to monitor Infrastructure & ApplicationAndikSusilo4
 
How to convert PDF to text with Nanonets
How to convert PDF to text with NanonetsHow to convert PDF to text with Nanonets
How to convert PDF to text with Nanonetsnaman860154
 
Enhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for PartnersEnhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for PartnersThousandEyes
 
From Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time AutomationFrom Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time AutomationSafe Software
 
Slack Application Development 101 Slides
Slack Application Development 101 SlidesSlack Application Development 101 Slides
Slack Application Development 101 Slidespraypatel2
 
Beyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry InnovationBeyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry InnovationSafe Software
 
My Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 PresentationMy Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 PresentationRidwan Fadjar
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsMaria Levchenko
 
Benefits Of Flutter Compared To Other Frameworks
Benefits Of Flutter Compared To Other FrameworksBenefits Of Flutter Compared To Other Frameworks
Benefits Of Flutter Compared To Other FrameworksSoftradix Technologies
 
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 3652toLead Limited
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking MenDelhi Call girls
 
Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Allon Mureinik
 
The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024Rafal Los
 
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptxHampshireHUG
 

Recently uploaded (20)

Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticsKotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
 
A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected Worker
 
Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...
 
Factors to Consider When Choosing Accounts Payable Services Providers.pptx
Factors to Consider When Choosing Accounts Payable Services Providers.pptxFactors to Consider When Choosing Accounts Payable Services Providers.pptx
Factors to Consider When Choosing Accounts Payable Services Providers.pptx
 
Maximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptxMaximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptx
 
Azure Monitor & Application Insight to monitor Infrastructure & Application
Azure Monitor & Application Insight to monitor Infrastructure & ApplicationAzure Monitor & Application Insight to monitor Infrastructure & Application
Azure Monitor & Application Insight to monitor Infrastructure & Application
 
How to convert PDF to text with Nanonets
How to convert PDF to text with NanonetsHow to convert PDF to text with Nanonets
How to convert PDF to text with Nanonets
 
Enhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for PartnersEnhancing Worker Digital Experience: A Hands-on Workshop for Partners
Enhancing Worker Digital Experience: A Hands-on Workshop for Partners
 
From Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time AutomationFrom Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time Automation
 
Slack Application Development 101 Slides
Slack Application Development 101 SlidesSlack Application Development 101 Slides
Slack Application Development 101 Slides
 
Beyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry InnovationBeyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
 
My Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 PresentationMy Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 Presentation
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed texts
 
Benefits Of Flutter Compared To Other Frameworks
Benefits Of Flutter Compared To Other FrameworksBenefits Of Flutter Compared To Other Frameworks
Benefits Of Flutter Compared To Other Frameworks
 
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men
 
Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)
 
The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024
 
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
 

[Cook book] ansible 4_dell emc networking

  • 1. [CookBook] Ansible_4_Dell EMC Networking This document is the purpose of education for Ansible on the DELL EMC OS10 Copyright <2019> Hoon_Jo@dell.com < Github : https://github.com/sysnet4admin > Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
  • 2. 0. Pre-Conditions Predifined Group_Vars ansible_user: ansible ansible_ssh_pass: Ansible00 ansible_become_method: enable ansible_become: yes ansible_become_pass: admin ansible_network_os: dellos10 ansible_connection: network_cli Config Chagne [vagrant@ansible-server ~]$ ansible-config dump --only-changed HOST_KEY_CHECKING(/etc/ansible/ansible.cfg) = False PERSISTENT_COMMAND_TIMEOUT(/etc/ansible/ansible.cfg) = 60 Inventory [dellos10] 172.16.1.[1:4] Topology
  • 3. 1. ad-hoc 1-1. Source Code ansible dellos10 -m ping ansible dellos10 -m dellos10_command -a "commands='show version'" [Code 1-1] 1.ad-hoc 1.2. Run the Code Note: ans = ansible (alias) [vagrant@ansible-server ~]$ ans dellos10 -m ping 172.16.1.1 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "ping": "pong" } 172.16.1.3 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "ping": "pong" } 172.16.1.2 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "ping": "pong" } 172.16.1.4 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "ping": "pong" } [vagrant@ansible-server ~]$ ans dellos10 -m dellos10_command -a "commands='show version'" 172.16.1.1 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "stdout": [ "Dell EMC Networking OS10-EnterprisenCopyright (c) 1999-2019 by Dell Inc. All Rights Reserved.nOS Version: 10.4.3.1nBuild Version: 10.4.3.1.154nBuild Time: 2019-03-20T18:16:25-0700nSystem Type: S4048- ONnArchitecture: x86_64nUp Time: 02:11:07"
  • 4. ], "stdout_lines": [ [ "Dell EMC Networking OS10-Enterprise", "Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.", "OS Version: 10.4.3.1", "Build Version: 10.4.3.1.154", "Build Time: 2019-03-20T18:16:25-0700", "System Type: S4048-ON", "Architecture: x86_64", "Up Time: 02:11:07" ] ] } 172.16.1.3 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "stdout": [ "Dell EMC Networking OS10 EnterprisenCopyright (c) 1999-2019 by Dell Inc. All Rights Reserved.nOS Version: 10.5.0.0nBuild Version: 10.5.0.0.326nBuild Time: 2019-08-07T00:12:30+0000nSystem Type: S4148U- ONnArchitecture: x86_64nUp Time: 02:10:59" ], "stdout_lines": [ [ "Dell EMC Networking OS10 Enterprise", "Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.", "OS Version: 10.5.0.0", "Build Version: 10.5.0.0.326", "Build Time: 2019-08-07T00:12:30+0000", "System Type: S4148U-ON", "Architecture: x86_64", "Up Time: 02:10:59" ] ] } 172.16.1.2 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "stdout": [ "Dell EMC Networking OS10-EnterprisenCopyright (c) 1999-2019 by Dell Inc. All Rights Reserved.nOS Version: 10.4.3.1nBuild Version: 10.4.3.1.154nBuild Time: 2019-03-20T18:16:25-0700nSystem Type: S4048- ONnArchitecture: x86_64nUp Time: 02:11:08" ], "stdout_lines": [ [ "Dell EMC Networking OS10-Enterprise", "Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.", "OS Version: 10.4.3.1", "Build Version: 10.4.3.1.154", "Build Time: 2019-03-20T18:16:25-0700", "System Type: S4048-ON", "Architecture: x86_64", "Up Time: 02:11:08"
  • 5. ] ] } 172.16.1.4 | SUCCESS => { "ansible_facts": { "discovered_interpreter_python": "/usr/bin/python" }, "changed": false, "stdout": [ "Dell EMC Networking OS10 EnterprisenCopyright (c) 1999-2019 by Dell Inc. All Rights Reserved.nOS Version: 10.5.0.0nBuild Version: 10.5.0.0.326nBuild Time: 2019-08-07T00:12:30+0000nSystem Type: S4112T- ONnArchitecture: x86_64nUp Time: 02:11:03" ], "stdout_lines": [ [ "Dell EMC Networking OS10 Enterprise", "Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.", "OS Version: 10.5.0.0", "Build Version: 10.5.0.0.326", "Build Time: 2019-08-07T00:12:30+0000", "System Type: S4112T-ON", "Architecture: x86_64", "Up Time: 02:11:03" ] ] }
  • 6. 2. Create new VLAN 2.1. Source Code --- - name: Create vlan for LEFT spine hosts: dellos10[0] gather_facts: no tasks: - name: input config for int vlan 11 dellos10_config: lines: - interface vlan 11 - ip address 11.1.1.1/24 - no shutdown - name: input config for po1 dellos10_config: lines: - interface port-channel 1 - switchport trunk allowed vlan 11 - name: Create vlan for RIGHT spine hosts: dellos10[1] gather_facts: no tasks: - name: input config for int vlan 11 dellos10_config: lines: - interface vlan 11 - ip address 11.1.1.2/24 - no shutdown - name: input config for po1 dellos10_config: lines: - interface port-channel 1 - switchport trunk allowed vlan 11 - name: Create vlan for TOR hosts: dellos10[2] gather_facts: no tasks: - name: input config for int vlan 11 dellos10_config: lines: - interface vlan 11 - no shutdown - name: input config for uplink dellos10_config: lines: - interface port-channel 1 - switchport trunk allowed vlan 11 - name: input config for downlink dellos10_config:
  • 7. lines: - interface ethernet 1/1/27 - switchport trunk allowed vlan 11 - name: Create vlan for Access hosts: dellos10[3] gather_facts: no tasks: - name: input config for int vlan 11 dellos10_config: lines: - interface vlan 11 - ip address 11.1.1.4/24 - no shutdown - name: input config for uplink dellos10_config: lines: - 'interface ethernet 1/1/13:1' - switchport trunk allowed vlan 11 [Code 2-1] 2.cr_vlan.yml 2.2. Run the Code Note: anp = ansible-playbook (alias) [vagrant@ansible-server ~]$ anp cr_vlan.yml PLAY [Create vlan for LEFT spine] ********************************************* TASK [input config for int vlan 11] ******************************************* changed: [172.16.1.1] TASK [input config for po1] *************************************************** changed: [172.16.1.1] PLAY [Create vlan for RIGHT spine] ******************************************** TASK [input config for int vlan 11] ******************************************* changed: [172.16.1.2] TASK [input config for po1] *************************************************** changed: [172.16.1.2] PLAY [Create vlan for TOR] **************************************************** TASK [input config for int vlan 11] ******************************************* changed: [172.16.1.3] TASK [input config for uplink] ************************************************ changed: [172.16.1.3] TASK [input config for downlink] ********************************************** changed: [172.16.1.3]
  • 8. PLAY [Create vlan for Access] ************************************************* TASK [input config for int vlan 11] ******************************************* changed: [172.16.1.4] TASK [input config for uplink] ************************************************ changed: [172.16.1.4] PLAY RECAP ******************************************************************** 172.16.1.1 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 172.16.1.2 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 172.16.1.3 : ok=3 changed=3 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 172.16.1.4 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 2.3. Check Status [ Access: ping to left Spine ] S4112T# ping 11.1.1.1 PING 11.1.1.1 (11.1.1.1) 56(84) bytes of data. 64 bytes from 11.1.1.1: icmp_seq=1 ttl=64 time=1.02 ms 64 bytes from 11.1.1.1: icmp_seq=2 ttl=64 time=0.984 ms 64 bytes from 11.1.1.1: icmp_seq=3 ttl=64 time=0.983 ms ^C --- 11.1.1.1 ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2002ms rtt min/avg/max/mdev = 0.983/0.997/1.025/0.032 ms [ Access: ping to right Spine ] S4112T# ping 11.1.1.2 PING 11.1.1.2 (11.1.1.2) 56(84) bytes of data. 64 bytes from 11.1.1.2: icmp_seq=1 ttl=64 time=0.891 ms 64 bytes from 11.1.1.2: icmp_seq=2 ttl=64 time=0.835 ms 64 bytes from 11.1.1.2: icmp_seq=3 ttl=64 time=0.957 ms ^C --- 11.1.1.2 ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2009ms rtt min/avg/max/mdev = 0.835/0.894/0.957/0.055 ms
  • 9. 3. Config BFD 3.1. Source Code --- - name: Config BFD for LEFT spine hosts: dellos10[0] gather_facts: no tasks: - name: input config for loopback0 dellos10_config: lines: - interface loopback 0 - ip address 1.1.1.1/32 - no shutdown - name: input config for routing dellos10_config: lines: - ip route 4.4.4.4/32 11.1.1.4 - name: Config BFD for RIGHT spine hosts: dellos10[1] gather_facts: no tasks: - name: input config for loopback0 dellos10_config: lines: - interface loopback 0 - ip address 2.2.2.2/32 - no shutdown - name: input config for routing dellos10_config: lines: - ip route 4.4.4.4/32 11.1.1.4 - name: Config BFD for Access hosts: dellos10[3] gather_facts: no tasks: - name: input config for loopback0 dellos10_config: lines: - interface loopback 0 - ip address 4.4.4.4/32 - no shutdown - name: input config for routing dellos10_config: lines: - ip route 1.1.1.1/32 11.1.1.1 - ip route 2.2.2.2/32 11.1.1.2 [Code 3-1] 3.cfg_BFD.yml
  • 10. 3.2. Run the Code Note: anp = ansible-playbook (alias) [vagrant@ansible-server ~]$ anp 3.cfg_BFD.yml PLAY [Config BFD for LEFT spine] ********************************************** TASK [input config for loopback0] ********************************************* changed: [172.16.1.1] TASK [input config for routing] *********************************************** changed: [172.16.1.1] PLAY [Config BFD for RIGHT spine] ********************************************* TASK [input config for loopback0] ********************************************* changed: [172.16.1.2] TASK [input config for routing] *********************************************** changed: [172.16.1.2] PLAY [Config BFD for Access] ************************************************** TASK [input config for loopback0] ********************************************* changed: [172.16.1.4] TASK [input config for routing] *********************************************** changed: [172.16.1.4] PLAY RECAP ******************************************************************** 172.16.1.1 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 172.16.1.2 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 172.16.1.4 : ok=2 changed=2 unreachable=0 failed=0 skipped=0 rescued=0 ignored=0 3.3. Check Status [ Left Spine : show bfd neighbors ] S4048-1# show bfd neighbors * - Active session role ----------------------------------------------------------------------------------------- LocalAddr RemoteAddr Interface State RxInt TxInt Mult VRF Clients ----------------------------------------------------------------------------------------- * 10.1.1.1 10.1.1.4 vlan10 up 200 200 3 default rtmv4 * 11.1.1.1 11.1.1.4 vlan11 up 200 200 3 default rtmv4 [ Right Spine : show bfd neighbors ] S4048-2# show bfd neighbors * - Active session role ----------------------------------------------------------------------------------------- LocalAddr RemoteAddr Interface State RxInt TxInt Mult VRF Clients ----------------------------------------------------------------------------------------- * 10.1.1.2 10.1.1.4 vlan10 up 200 200 3 default rtmv4 * 11.1.1.2 11.1.1.4 vlan11 up 200 200 3 default rtmv4
  • 11. [ Access: show bfd neighbors ] S4112T# show bfd neighbors * - Active session role ----------------------------------------------------------------------------------------- LocalAddr RemoteAddr Interface State RxInt TxInt Mult VRF Clients ----------------------------------------------------------------------------------------- * 10.1.1.4 10.1.1.1 vlan10 up 200 200 3 default rtmv4 * 10.1.1.4 10.1.1.2 vlan10 up 200 200 3 default rtmv4 * 11.1.1.4 11.1.1.1 vlan11 up 200 200 3 default rtmv4 * 11.1.1.4 11.1.1.2 vlan11 up 200 200 3 default rtmv4