SlideShare a Scribd company logo
1 of 37
Download to read offline
© 2015, Amazon Web Services, Inc. or its Affiliates. All rights reserved.
Matt Lehwess, AWS
October 2015
ARC402
Double Redundancy
With AWS Direct Connect
Agenda
• Building network foundations in AWS
• Connecting your onsite deployment to AWS
• Adding some redundancy into the mix
• Demo: Taking our environment live and
introducing some failures!
Foundations: Amazon VPC
Your own private, isolated section of the AWS cloud
VPC CIDR 10.1.0.0/16
Availability Zone A Availability Zone B
Public Subnet Public Subnet
Private Subnet Private Subnet
Instance A
10.1.1.11 /24
Instance B
10.1.2.22 /24
Instance C
10.1.3.33 /24
Instance D
10.1.4.44 /24
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
Only 1 IGW and 1 VGW per VPC
Foundations: Other Services
Lets add some AWS services outside of VPC
AWS Region - eg: US-WEST1
Our VPC from Earlier
AWS Region
AWS Region Level Services (plus many more)
AWS VPC Internal Services (e.g. Amazon EMR,
Elastic Load Balancing, Amazon RDS)
IGW, gateway between AWS region level
services and internal VPC services
Instance A
10.1.1.11 /24
Availability Zone A Availability Zone B
Public Subnet Public Subnet
Private Subnet Private Subnet
Instance B
10.1.2.22 /24
Instance C
10.1.3.33 /24
Instance D
10.1.4.44 /24
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
Amazon SNS
Amazon SQS
Amazon SWF
Amazon SES
Amazon S3
Amazon Glacier
Amazon DynamoDB
AWS Lambda
Connectivity: AWS to On-Premises
Using AWS Direct Connect
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
Customer DCColocation Facility - e.g. Equinix SV1
VPC CIDR 10.1.0.0/16
Customer Subnet
192.168.0.0/16
Direct Connect POP
Colocation Facility
Customer or Partner Device
AWS Direct Connect
Point of Presence
Customer Gateway
Cross Connect
Customer Data Center
Service Provider Backhaul
Anatomy of AWS Direct Connect
Private Virtual Interface
Configure Customer Gateway
VPC VGW
Standard Interface & BGP Configuration…
interface GigabitEthernet0/1
no ip address
interface GigabitEthernet0/1.807
description "Direct Connect to your Amazon VPC or AWS Cloud"
encapsulation dot1Q 807
ip address 172.16.7.5 255.255.255.252
router bgp 65001
neighbor 172.16.7.6 remote-as 7224
neighbor 172.16.7.6 password 7 $1$zVOvlUSp$UrqWP2awtiG8ZbXo9BwcB
network 0.0.0.0
exit
Physical Interface that fiber is plugged into
Sub-interface (Generally matches VLAN)
VLAN Association
/30 Private P2P address
BGP ASN
Route Advertisement to AWS
Just a description
BGP MD5 Password
Neighbor Peer Address
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
VPC CIDR 10.1.0.0/16
Customer DCColocation Facility - e.g. Equinix SV1
Customer Subnet
192.168.0.0/16
Configure Customer Gateway
Customer Gateway
BGP Comes up, prefixes are advertised.
%BGP-5-ADJCHANGE: neighbor 172.16.6.6 Up
AWS Direct Connect
Point of Presence
Anatomy of AWS Direct Connect continued...
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
VPC CIDR 10.1.0.0/16
Customer DCColocation Facility - e.g. Equinix SV1
Customer Subnet
172.160.0.0/16
Anatomy of AWS Direct Connect continued...
Customer Gateway
AWS Direct Connect
Point of Presence
My Private Virtual Interface is up, now what?
What about my S3 bucket or DynamoDB? – in comes Public Virtual Interfaces!
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
VPC CIDR 10.1.0.0/16
Amazon SNS
Amazon SQS
Amazon SWF
Amazon SES
Amazon S3 Amazon DynamoDB
AWS Region - eg: US-WEST1
AWS LambdaAmazon Glacier
Customer DCColocation Facility - e.g. Equinix SV1
Customer Subnet
172.160.0.0/16
Customer Gateway
AWS Regions much larger than just what’s inside a VPC
Create Public Virtual Interface
Configure Customer Gateway
BGP Comes up, prefixes are advertised (Public only!).
%BGP-5-ADJCHANGE: neighbor 203.50.24.5
Anatomy of AWS Direct Connect continued...
AWS Direct Connect
Point of Presence
Adding Redundancy
“Everything fails, all the time.” – Werner Vogels
Anatomy of a redundant AWS Direct Connect
Customer Subnet
172.160.0.0/16
Double connectivity
The standard connectivity we built earlierVPC VGW
Redundant DX POP LocationOther AWS Services
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
VPC CIDR 10.1.0.0/16
Amazon SNS
Amazon SQS
Amazon SWF
Amazon SES
Amazon S3 Amazon DynamoDB
AWS Region - eg: US-WEST1
AWS LambdaAmazon Glacier
Amazon SNS
Amazon SQS
Amazon SWF
Amazon SES
Amazon S3 Amazon DynamoDB
AWS Region - eg: US-WEST1
AWS LambdaAmazon Glacier
Anatomy of a redundant AWS Direct Connect
Customer Subnet
172.160.0.0/16
How do we configure redundant BGP?
And here too!
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
VPC CIDR 10.1.0.0/16
Standard Interface & BGP Configuration…
#Active Passive deployment:
router bgp 65001
neighbor 10.1.0.2 remote-as 65200
neighbor 10.1.0.2 description Backup
neighbor 10.1.0.2 route-map prepend out
route-map prepend permit 10
set as-path prepend 65001 65001 65001
Using one link as the primary, and the
other “Prepended” as the secondary
and less preferred route
Autonomous System (AS) Path Prepending?
Origin NetworkPrepended ASNPrepended ASNPrepended ASN
Verses.
Origin Network
Metric 4
Metric 1
Less Preferred
More Preferred
0%
100%
Standard Interface & BGP Configuration…
#Active Active deployment:
router bgp 1
maximum-paths 4 Usually reserved for a single customer router scenario,
can be configured at the service provider level as well.
Note: By default we “Multi-path” outbound from VGW over equal cost paths
unless you set a metric such as AS PATH on one route.
Autonomous System (AS) Equal Paths
Origin Network
Vs.
Origin Network
Metric 1
Metric 1
Both Preferred
Both Preferred
50%
50%
Did I hear Double Redundancy?
You can use VPN as your backup of backups
Amazon SNS
Amazon SQS
Amazon SWF
Amazon SES
Amazon S3 Amazon DynamoDB
AWS Region - eg: US-WEST1
AWS LambdaAmazon Glacier
10.1.1.0/16
10.1.2.0/16
10.1.3.0/16
VPC CIDR 10.1.0.0/16
Anatomy of a redundant AWS Direct Connect
Customer Subnet
172.160.0.0/16
Most MPLS Providers can “trunk”
you an internet circuitOur VGW’s are also used as VPN
connection points remember!
Dual VPN tunnels providing
connectivity and encryption.
VPN & BGP Redundancy Configuration…
#Direct Connect Interface:
interface GigabitEthernet0/0/0.259
description "Direct Connect to your Amazon VPC or AWS Cloud"
encapsulation dot1Q 259
ip address 169.254.254.2 255.255.255.252
bfd interval 300 min_rx 300 multiplier 3
!
Subinterface
VLAN ID
Local IP Address
BFD Configuration
VPN & BGP Redundancy Configuration…
#Inter Router Interface:
interface GigabitEthernet0/1
description ** Internal Interface - SW2 Gi2/0/1 **
ip address 192.168.51.253 255.255.255.0
ip virtual-reassembly in
standby 1 ip 192.168.51.254
standby 1 timers msec 300 msec 900
standby 1 priority 110
standby 1 preempt
duplex auto
speed auto
!
Local LAN IP
HSRP Configuration
HSRP sub second hello
This router is primary
Preempt primary if not active
VPN & BGP Redundancy Configuration…
BGP Configuration:
router bgp 65501
bgp log-neighbor-changes
neighbor 169.254.254.1 remote-as 9059
neighbor 169.254.254.1 password 7 124B36F51
neighbor 169.254.254.1 fall-over bfd
neighbor 192.168.51.252 remote-as 65501
!
Direct Connect neighbor
BFD Configuration
Inter router neighbor
VPN & BGP Redundancy Configuration…
Secondary router BGP and route-map assignment:
router bgp 65501
bgp log-neighbor-changes
neighbor 169.254.254.37 remote-as 9059
neighbor 169.254.254.37 route-map LOCAL-PREF in
neighbor 169.254.254.37 route-map AS-PREPEND out
Secondary Direct Connect
neighbor
Inbound route-map
Outbound route-map
VPN & BGP Redundancy Configuration…
Secondary router route-map:
ip prefix-list LOCAL-ROUTES seq 10 permit 192.168.0.0/16 le 32
route-map AS-PREPEND permit 10
match ip address prefix-list LOCAL-ROUTES
set as-path prepend 65501 65501
!
route-map LOCAL-PREF permit 10
set local-preference 90
!
Match local routes for AS prepending
Match above prefix list
Add ASN x 2 to AS Path
Set local preference to 90 (for secondary)
Now adding VPN….
VPN Tunnel interface (Straight forward):
interface Tunnel1
ip address 169.254.20.62 255.255.255.252
ip virtual-reassembly in
ip tcp adjust-mss 1387
tunnel source 62.216.229.132
tunnel mode ipsec ipv4
tunnel destination 52.17.141.73
tunnel protection ipsec profile ipsec-vpn-946e19df-0
!
Now adding VPN….
VPN Tunnel interface (Straight forward):
interface Tunnel2
ip address 169.254.20.162 255.255.255.252
ip virtual-reassembly in
ip tcp adjust-mss 1387
tunnel source 62.216.229.132
tunnel mode ipsec ipv4
tunnel destination 52.18.219.193
tunnel protection ipsec profile ipsec-vpn-946e19df-1
!
Plus your other VPN goodness like crypto-maps…
Now adding VPN….
VPN BGP Configuration (Still standard..)
Router BGP 65501
neighbor 169.254.20.61 remote-as 9059
neighbor 169.254.20.61 timers 10 30 30
!
Address-family ipv4
network 192.168.51.0
neighbor 169.254.20.61 activate
neighbor 169.254.20.61 route-map LOCAL-PREF-VPN in
neighbor 169.254.20.61 route-map AS-PREPEND-VPN out
!
Standard BGP Configuration
Where it gets interesting…
Now adding VPN….
#Where we add our metrics:
route-map AS-PREPEND-VPN permit 10
match ip address prefix-list LOCAL-ROUTES
set as-path prepend 65501 65501 65501
!
route-map LOCAL-PREF-VPN permit 10
set local-preference 80
!
An additional ASN beyond our backup direct connect link
Local Preference is 10 lower than our backup
Direct Connect link
Our real life environment
Demo
Let’s see how our use case was built on AWS
Our real life environment
In summary
• Built our network foundations in AWS
• Connected your onsite deployment to AWS
• Added some redundancy into the mix
• Demo: Took our environment live and
introduced some failures!
Related Sessions
NET406 - Deep Dive: AWS Direct Connect and VPNs
• Thursday, Oct 8, 2:45 PM - 3:45 PM – Palazzo C
ISM403 - How Amazon.com is Moving to Amazon WorkSpaces
• Thursday, Oct 8, 1:30 PM - 2:30 PM – Titian 2306
Thank you!
Remember to complete
your evaluations!

More Related Content

What's hot

금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017
금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017
금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017
Amazon Web Services Korea
 
10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)
10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)
10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)
Amazon Web Services Korea
 

What's hot (20)

いまさら、AWSのネットワーク設計
いまさら、AWSのネットワーク設計いまさら、AWSのネットワーク設計
いまさら、AWSのネットワーク設計
 
금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017
금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017
금융권을 위한 AWS Direct Connect 기반 하이브리드 구성 방법 - AWS Summit Seoul 2017
 
Advanced Architectures with AWS Transit Gateway
Advanced Architectures with AWS Transit GatewayAdvanced Architectures with AWS Transit Gateway
Advanced Architectures with AWS Transit Gateway
 
[AWS Builders] AWS상의 보안 위협 탐지 및 대응
[AWS Builders] AWS상의 보안 위협 탐지 및 대응[AWS Builders] AWS상의 보안 위협 탐지 및 대응
[AWS Builders] AWS상의 보안 위협 탐지 및 대응
 
Behind the Scenes: Exploring the AWS Global Network (NET305) - AWS re:Invent ...
Behind the Scenes: Exploring the AWS Global Network (NET305) - AWS re:Invent ...Behind the Scenes: Exploring the AWS Global Network (NET305) - AWS re:Invent ...
Behind the Scenes: Exploring the AWS Global Network (NET305) - AWS re:Invent ...
 
AWS Black Belt Techシリーズ AWS Direct Connect
AWS Black Belt Techシリーズ AWS Direct ConnectAWS Black Belt Techシリーズ AWS Direct Connect
AWS Black Belt Techシリーズ AWS Direct Connect
 
20210126 AWS Black Belt Online Seminar AWS CodeDeploy
20210126 AWS Black Belt Online Seminar AWS CodeDeploy20210126 AWS Black Belt Online Seminar AWS CodeDeploy
20210126 AWS Black Belt Online Seminar AWS CodeDeploy
 
AWS Summit Seoul 2023 | 다중 계정 및 하이브리드 환경에서 안전한 IAM 체계 만들기
AWS Summit Seoul 2023 | 다중 계정 및 하이브리드 환경에서 안전한 IAM 체계 만들기AWS Summit Seoul 2023 | 다중 계정 및 하이브리드 환경에서 안전한 IAM 체계 만들기
AWS Summit Seoul 2023 | 다중 계정 및 하이브리드 환경에서 안전한 IAM 체계 만들기
 
[오픈소스컨설팅] Open Stack Ceph, Neutron, HA, Multi-Region
[오픈소스컨설팅] Open Stack Ceph, Neutron, HA, Multi-Region[오픈소스컨설팅] Open Stack Ceph, Neutron, HA, Multi-Region
[오픈소스컨설팅] Open Stack Ceph, Neutron, HA, Multi-Region
 
20210119 AWS Black Belt Online Seminar AWS CloudTrail
20210119 AWS Black Belt Online Seminar AWS CloudTrail20210119 AWS Black Belt Online Seminar AWS CloudTrail
20210119 AWS Black Belt Online Seminar AWS CloudTrail
 
20190313 AWS Black Belt Online Seminar Amazon VPC Basic
20190313 AWS Black Belt Online Seminar Amazon VPC Basic20190313 AWS Black Belt Online Seminar Amazon VPC Basic
20190313 AWS Black Belt Online Seminar Amazon VPC Basic
 
SaaS テナント毎のコストを把握するための「AWS Application Cost Profiler」のご紹介
SaaS テナント毎のコストを把握するための「AWS Application Cost Profiler」のご紹介SaaS テナント毎のコストを把握するための「AWS Application Cost Profiler」のご紹介
SaaS テナント毎のコストを把握するための「AWS Application Cost Profiler」のご紹介
 
10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)
10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)
10월 웨비나 - AWS에서 Active Directory 구축 및 연동 옵션 살펴보기 (김용우 솔루션즈 아키텍트)
 
KINX와 함께 하는 AWS Direct Connect 도입 - 남시우 매니저, KINX :: AWS Summit Seoul 2019
KINX와 함께 하는 AWS Direct Connect 도입 - 남시우 매니저, KINX :: AWS Summit Seoul 2019KINX와 함께 하는 AWS Direct Connect 도입 - 남시우 매니저, KINX :: AWS Summit Seoul 2019
KINX와 함께 하는 AWS Direct Connect 도입 - 남시우 매니저, KINX :: AWS Summit Seoul 2019
 
AWS Black Belt Online Seminar 2017 AWS Storage Gateway
AWS Black Belt Online Seminar 2017 AWS Storage GatewayAWS Black Belt Online Seminar 2017 AWS Storage Gateway
AWS Black Belt Online Seminar 2017 AWS Storage Gateway
 
20200728 AWS Black Belt Online Seminar What's New in Serverless
20200728 AWS Black Belt Online Seminar What's New in Serverless20200728 AWS Black Belt Online Seminar What's New in Serverless
20200728 AWS Black Belt Online Seminar What's New in Serverless
 
(SPOT301) AWS Innovation at Scale | AWS re:Invent 2014
(SPOT301) AWS Innovation at Scale | AWS re:Invent 2014(SPOT301) AWS Innovation at Scale | AWS re:Invent 2014
(SPOT301) AWS Innovation at Scale | AWS re:Invent 2014
 
AWS Connectivity, VPC Design and Security Pro Tips
AWS Connectivity, VPC Design and Security Pro TipsAWS Connectivity, VPC Design and Security Pro Tips
AWS Connectivity, VPC Design and Security Pro Tips
 
[Games on AWS 2019] AWS 입문자를 위한 초단기 레벨업 트랙 | AWS 레벨업 하기! : 네트워크 - 권신중 AWS 솔루션...
[Games on AWS 2019] AWS 입문자를 위한 초단기 레벨업 트랙 | AWS 레벨업 하기! : 네트워크 - 권신중 AWS 솔루션...[Games on AWS 2019] AWS 입문자를 위한 초단기 레벨업 트랙 | AWS 레벨업 하기! : 네트워크 - 권신중 AWS 솔루션...
[Games on AWS 2019] AWS 입문자를 위한 초단기 레벨업 트랙 | AWS 레벨업 하기! : 네트워크 - 권신중 AWS 솔루션...
 
Modernizing applications with Amazon EKS - MAD304 - Santa Clara AWS Summit.pdf
Modernizing applications with Amazon EKS - MAD304 - Santa Clara AWS Summit.pdfModernizing applications with Amazon EKS - MAD304 - Santa Clara AWS Summit.pdf
Modernizing applications with Amazon EKS - MAD304 - Santa Clara AWS Summit.pdf
 

Viewers also liked

Viewers also liked (9)

Cloud Architectures with AWS Direct Connect (ARC304) | AWS re:Invent 2013
Cloud Architectures with AWS Direct Connect (ARC304) | AWS re:Invent 2013Cloud Architectures with AWS Direct Connect (ARC304) | AWS re:Invent 2013
Cloud Architectures with AWS Direct Connect (ARC304) | AWS re:Invent 2013
 
AWS re:Invent 2016: Scaling Up to Your First 10 Million Users (ARC201)
AWS re:Invent 2016: Scaling Up to Your First 10 Million Users (ARC201)AWS re:Invent 2016: Scaling Up to Your First 10 Million Users (ARC201)
AWS re:Invent 2016: Scaling Up to Your First 10 Million Users (ARC201)
 
AWS re:Invent 2016: Serverless Architectural Patterns and Best Practices (ARC...
AWS re:Invent 2016: Serverless Architectural Patterns and Best Practices (ARC...AWS re:Invent 2016: Serverless Architectural Patterns and Best Practices (ARC...
AWS re:Invent 2016: Serverless Architectural Patterns and Best Practices (ARC...
 
AWS re:Invent 2016: Deep Dive: AWS Direct Connect and VPNs (NET402)
AWS re:Invent 2016: Deep Dive: AWS Direct Connect and VPNs (NET402)AWS re:Invent 2016: Deep Dive: AWS Direct Connect and VPNs (NET402)
AWS re:Invent 2016: Deep Dive: AWS Direct Connect and VPNs (NET402)
 
(ARC403) From One To Many: Evolving VPC Design
(ARC403) From One To Many: Evolving VPC Design(ARC403) From One To Many: Evolving VPC Design
(ARC403) From One To Many: Evolving VPC Design
 
(SDD422) Amazon VPC Deep Dive | AWS re:Invent 2014
(SDD422) Amazon VPC Deep Dive | AWS re:Invent 2014(SDD422) Amazon VPC Deep Dive | AWS re:Invent 2014
(SDD422) Amazon VPC Deep Dive | AWS re:Invent 2014
 
Selecting the Best VPC Network Architecture (CPN208) | AWS re:Invent 2013
Selecting the Best VPC Network Architecture (CPN208) | AWS re:Invent 2013Selecting the Best VPC Network Architecture (CPN208) | AWS re:Invent 2013
Selecting the Best VPC Network Architecture (CPN208) | AWS re:Invent 2013
 
AWS re:Invent 2016: Extending Datacenters to the Cloud: Connectivity Options ...
AWS re:Invent 2016: Extending Datacenters to the Cloud: Connectivity Options ...AWS re:Invent 2016: Extending Datacenters to the Cloud: Connectivity Options ...
AWS re:Invent 2016: Extending Datacenters to the Cloud: Connectivity Options ...
 
AWS re:Invent 2016: From One to Many: Evolving VPC Design (ARC302)
AWS re:Invent 2016: From One to Many: Evolving VPC Design (ARC302)AWS re:Invent 2016: From One to Many: Evolving VPC Design (ARC302)
AWS re:Invent 2016: From One to Many: Evolving VPC Design (ARC302)
 

Similar to (ARC402) Double Redundancy With AWS Direct Connect

利用AWS建立企業全球化網路
利用AWS建立企業全球化網路利用AWS建立企業全球化網路
利用AWS建立企業全球化網路
Amazon Web Services
 

Similar to (ARC402) Double Redundancy With AWS Direct Connect (20)

Double Redundancy with AWS Direct Connect - Pop-up Loft Tel Aviv
Double Redundancy with AWS Direct Connect - Pop-up Loft Tel AvivDouble Redundancy with AWS Direct Connect - Pop-up Loft Tel Aviv
Double Redundancy with AWS Direct Connect - Pop-up Loft Tel Aviv
 
VPC and DX PoP @ HKG
VPC and DX PoP @ HKGVPC and DX PoP @ HKG
VPC and DX PoP @ HKG
 
利用AWS建立企業全球化網路
利用AWS建立企業全球化網路利用AWS建立企業全球化網路
利用AWS建立企業全球化網路
 
打破時空藩籬,輕鬆存取您的雲端工作負載
打破時空藩籬,輕鬆存取您的雲端工作負載打破時空藩籬,輕鬆存取您的雲端工作負載
打破時空藩籬,輕鬆存取您的雲端工作負載
 
打破時空藩籬-輕鬆存取您的雲端工作負載
打破時空藩籬-輕鬆存取您的雲端工作負載打破時空藩籬-輕鬆存取您的雲端工作負載
打破時空藩籬-輕鬆存取您的雲端工作負載
 
PLNOG 17 - Tomasz Stachlewski - Infrastruktura sieciowa w chmurze AWS
PLNOG 17 - Tomasz Stachlewski - Infrastruktura sieciowa w chmurze AWSPLNOG 17 - Tomasz Stachlewski - Infrastruktura sieciowa w chmurze AWS
PLNOG 17 - Tomasz Stachlewski - Infrastruktura sieciowa w chmurze AWS
 
Planning advanced AWS networking architectures - SVC304 - Chicago AWS Summit
Planning advanced AWS networking architectures - SVC304 - Chicago AWS SummitPlanning advanced AWS networking architectures - SVC304 - Chicago AWS Summit
Planning advanced AWS networking architectures - SVC304 - Chicago AWS Summit
 
A Day in the Life of a Billion Packets (CPN401) | AWS re:Invent 2013
A Day in the Life of a Billion Packets (CPN401) | AWS re:Invent 2013A Day in the Life of a Billion Packets (CPN401) | AWS re:Invent 2013
A Day in the Life of a Billion Packets (CPN401) | AWS re:Invent 2013
 
Amazon Virtual Private Cloud
Amazon Virtual Private CloudAmazon Virtual Private Cloud
Amazon Virtual Private Cloud
 
Edge to Instance - AWS Networking
Edge to Instance - AWS Networking Edge to Instance - AWS Networking
Edge to Instance - AWS Networking
 
AWS re:Invent 2016: How Harvard University Improves Scalable Cloud Network Se...
AWS re:Invent 2016: How Harvard University Improves Scalable Cloud Network Se...AWS re:Invent 2016: How Harvard University Improves Scalable Cloud Network Se...
AWS re:Invent 2016: How Harvard University Improves Scalable Cloud Network Se...
 
Another Day, Another Billion Packets
Another Day, Another Billion PacketsAnother Day, Another Billion Packets
Another Day, Another Billion Packets
 
AWS Summit Auckland - Fundamentals of Networking in AWS
AWS Summit Auckland - Fundamentals of Networking in AWSAWS Summit Auckland - Fundamentals of Networking in AWS
AWS Summit Auckland - Fundamentals of Networking in AWS
 
(NET405) Build a Remote Access VPN Solution on AWS
(NET405) Build a Remote Access VPN Solution on AWS(NET405) Build a Remote Access VPN Solution on AWS
(NET405) Build a Remote Access VPN Solution on AWS
 
Another day, another billion packets - Toronto
Another day, another billion packets - TorontoAnother day, another billion packets - Toronto
Another day, another billion packets - Toronto
 
The Fundamentals of Networking in AWS: VPC and Connectivity Options - Business
The Fundamentals of Networking in AWS: VPC and Connectivity Options - BusinessThe Fundamentals of Networking in AWS: VPC and Connectivity Options - Business
The Fundamentals of Networking in AWS: VPC and Connectivity Options - Business
 
another day, another billion packets
another day, another billion packetsanother day, another billion packets
another day, another billion packets
 
GPSTEC322-GPS Creating Your Virtual Data Center VPC Fundamentals Connectivity...
GPSTEC322-GPS Creating Your Virtual Data Center VPC Fundamentals Connectivity...GPSTEC322-GPS Creating Your Virtual Data Center VPC Fundamentals Connectivity...
GPSTEC322-GPS Creating Your Virtual Data Center VPC Fundamentals Connectivity...
 
Deep Dive: Amazon Virtual Private Cloud (March 2017)
Deep Dive: Amazon Virtual Private Cloud (March 2017)Deep Dive: Amazon Virtual Private Cloud (March 2017)
Deep Dive: Amazon Virtual Private Cloud (March 2017)
 
Deep Dive VPC - Pop-up Loft TLV 2017
Deep Dive VPC - Pop-up Loft TLV 2017Deep Dive VPC - Pop-up Loft TLV 2017
Deep Dive VPC - Pop-up Loft TLV 2017
 

More from Amazon Web Services

Tools for building your MVP on AWS
Tools for building your MVP on AWSTools for building your MVP on AWS
Tools for building your MVP on AWS
Amazon Web Services
 
How to Build a Winning Pitch Deck
How to Build a Winning Pitch DeckHow to Build a Winning Pitch Deck
How to Build a Winning Pitch Deck
Amazon Web Services
 
Building a web application without servers
Building a web application without serversBuilding a web application without servers
Building a web application without servers
Amazon Web Services
 
AWS_HK_StartupDay_Building Interactive websites while automating for efficien...
AWS_HK_StartupDay_Building Interactive websites while automating for efficien...AWS_HK_StartupDay_Building Interactive websites while automating for efficien...
AWS_HK_StartupDay_Building Interactive websites while automating for efficien...
Amazon Web Services
 

More from Amazon Web Services (20)

Come costruire servizi di Forecasting sfruttando algoritmi di ML e deep learn...
Come costruire servizi di Forecasting sfruttando algoritmi di ML e deep learn...Come costruire servizi di Forecasting sfruttando algoritmi di ML e deep learn...
Come costruire servizi di Forecasting sfruttando algoritmi di ML e deep learn...
 
Big Data per le Startup: come creare applicazioni Big Data in modalità Server...
Big Data per le Startup: come creare applicazioni Big Data in modalità Server...Big Data per le Startup: come creare applicazioni Big Data in modalità Server...
Big Data per le Startup: come creare applicazioni Big Data in modalità Server...
 
Esegui pod serverless con Amazon EKS e AWS Fargate
Esegui pod serverless con Amazon EKS e AWS FargateEsegui pod serverless con Amazon EKS e AWS Fargate
Esegui pod serverless con Amazon EKS e AWS Fargate
 
Costruire Applicazioni Moderne con AWS
Costruire Applicazioni Moderne con AWSCostruire Applicazioni Moderne con AWS
Costruire Applicazioni Moderne con AWS
 
Come spendere fino al 90% in meno con i container e le istanze spot
Come spendere fino al 90% in meno con i container e le istanze spot Come spendere fino al 90% in meno con i container e le istanze spot
Come spendere fino al 90% in meno con i container e le istanze spot
 
Open banking as a service
Open banking as a serviceOpen banking as a service
Open banking as a service
 
Rendi unica l’offerta della tua startup sul mercato con i servizi Machine Lea...
Rendi unica l’offerta della tua startup sul mercato con i servizi Machine Lea...Rendi unica l’offerta della tua startup sul mercato con i servizi Machine Lea...
Rendi unica l’offerta della tua startup sul mercato con i servizi Machine Lea...
 
OpsWorks Configuration Management: automatizza la gestione e i deployment del...
OpsWorks Configuration Management: automatizza la gestione e i deployment del...OpsWorks Configuration Management: automatizza la gestione e i deployment del...
OpsWorks Configuration Management: automatizza la gestione e i deployment del...
 
Microsoft Active Directory su AWS per supportare i tuoi Windows Workloads
Microsoft Active Directory su AWS per supportare i tuoi Windows WorkloadsMicrosoft Active Directory su AWS per supportare i tuoi Windows Workloads
Microsoft Active Directory su AWS per supportare i tuoi Windows Workloads
 
Computer Vision con AWS
Computer Vision con AWSComputer Vision con AWS
Computer Vision con AWS
 
Database Oracle e VMware Cloud on AWS i miti da sfatare
Database Oracle e VMware Cloud on AWS i miti da sfatareDatabase Oracle e VMware Cloud on AWS i miti da sfatare
Database Oracle e VMware Cloud on AWS i miti da sfatare
 
Crea la tua prima serverless ledger-based app con QLDB e NodeJS
Crea la tua prima serverless ledger-based app con QLDB e NodeJSCrea la tua prima serverless ledger-based app con QLDB e NodeJS
Crea la tua prima serverless ledger-based app con QLDB e NodeJS
 
API moderne real-time per applicazioni mobili e web
API moderne real-time per applicazioni mobili e webAPI moderne real-time per applicazioni mobili e web
API moderne real-time per applicazioni mobili e web
 
Database Oracle e VMware Cloud™ on AWS: i miti da sfatare
Database Oracle e VMware Cloud™ on AWS: i miti da sfatareDatabase Oracle e VMware Cloud™ on AWS: i miti da sfatare
Database Oracle e VMware Cloud™ on AWS: i miti da sfatare
 
Tools for building your MVP on AWS
Tools for building your MVP on AWSTools for building your MVP on AWS
Tools for building your MVP on AWS
 
How to Build a Winning Pitch Deck
How to Build a Winning Pitch DeckHow to Build a Winning Pitch Deck
How to Build a Winning Pitch Deck
 
Building a web application without servers
Building a web application without serversBuilding a web application without servers
Building a web application without servers
 
Fundraising Essentials
Fundraising EssentialsFundraising Essentials
Fundraising Essentials
 
AWS_HK_StartupDay_Building Interactive websites while automating for efficien...
AWS_HK_StartupDay_Building Interactive websites while automating for efficien...AWS_HK_StartupDay_Building Interactive websites while automating for efficien...
AWS_HK_StartupDay_Building Interactive websites while automating for efficien...
 
Introduzione a Amazon Elastic Container Service
Introduzione a Amazon Elastic Container ServiceIntroduzione a Amazon Elastic Container Service
Introduzione a Amazon Elastic Container Service
 

Recently uploaded

Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Safe Software
 
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Safe Software
 
Finding Java's Hidden Performance Traps @ DevoxxUK 2024
Finding Java's Hidden Performance Traps @ DevoxxUK 2024Finding Java's Hidden Performance Traps @ DevoxxUK 2024
Finding Java's Hidden Performance Traps @ DevoxxUK 2024
Victor Rentea
 
Why Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businessWhy Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire business
panagenda
 
TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...
TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...
TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...
TrustArc
 
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Victor Rentea
 

Recently uploaded (20)

Less Is More: Utilizing Ballerina to Architect a Cloud Data Platform
Less Is More: Utilizing Ballerina to Architect a Cloud Data PlatformLess Is More: Utilizing Ballerina to Architect a Cloud Data Platform
Less Is More: Utilizing Ballerina to Architect a Cloud Data Platform
 
Vector Search -An Introduction in Oracle Database 23ai.pptx
Vector Search -An Introduction in Oracle Database 23ai.pptxVector Search -An Introduction in Oracle Database 23ai.pptx
Vector Search -An Introduction in Oracle Database 23ai.pptx
 
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
 
JohnPollard-hybrid-app-RailsConf2024.pptx
JohnPollard-hybrid-app-RailsConf2024.pptxJohnPollard-hybrid-app-RailsConf2024.pptx
JohnPollard-hybrid-app-RailsConf2024.pptx
 
Decarbonising Commercial Real Estate: The Role of Operational Performance
Decarbonising Commercial Real Estate: The Role of Operational PerformanceDecarbonising Commercial Real Estate: The Role of Operational Performance
Decarbonising Commercial Real Estate: The Role of Operational Performance
 
CNIC Information System with Pakdata Cf In Pakistan
CNIC Information System with Pakdata Cf In PakistanCNIC Information System with Pakdata Cf In Pakistan
CNIC Information System with Pakdata Cf In Pakistan
 
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
 
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
 
Finding Java's Hidden Performance Traps @ DevoxxUK 2024
Finding Java's Hidden Performance Traps @ DevoxxUK 2024Finding Java's Hidden Performance Traps @ DevoxxUK 2024
Finding Java's Hidden Performance Traps @ DevoxxUK 2024
 
Elevate Developer Efficiency & build GenAI Application with Amazon Q​
Elevate Developer Efficiency & build GenAI Application with Amazon Q​Elevate Developer Efficiency & build GenAI Application with Amazon Q​
Elevate Developer Efficiency & build GenAI Application with Amazon Q​
 
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
 
Introduction to Multilingual Retrieval Augmented Generation (RAG)
Introduction to Multilingual Retrieval Augmented Generation (RAG)Introduction to Multilingual Retrieval Augmented Generation (RAG)
Introduction to Multilingual Retrieval Augmented Generation (RAG)
 
Navigating Identity and Access Management in the Modern Enterprise
Navigating Identity and Access Management in the Modern EnterpriseNavigating Identity and Access Management in the Modern Enterprise
Navigating Identity and Access Management in the Modern Enterprise
 
TEST BANK For Principles of Anatomy and Physiology, 16th Edition by Gerard J....
TEST BANK For Principles of Anatomy and Physiology, 16th Edition by Gerard J....TEST BANK For Principles of Anatomy and Physiology, 16th Edition by Gerard J....
TEST BANK For Principles of Anatomy and Physiology, 16th Edition by Gerard J....
 
Understanding the FAA Part 107 License ..
Understanding the FAA Part 107 License ..Understanding the FAA Part 107 License ..
Understanding the FAA Part 107 License ..
 
Why Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businessWhy Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire business
 
AI+A11Y 11MAY2024 HYDERBAD GAAD 2024 - HelloA11Y (11 May 2024)
AI+A11Y 11MAY2024 HYDERBAD GAAD 2024 - HelloA11Y (11 May 2024)AI+A11Y 11MAY2024 HYDERBAD GAAD 2024 - HelloA11Y (11 May 2024)
AI+A11Y 11MAY2024 HYDERBAD GAAD 2024 - HelloA11Y (11 May 2024)
 
TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...
TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...
TrustArc Webinar - Unified Trust Center for Privacy, Security, Compliance, an...
 
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
 
Repurposing LNG terminals for Hydrogen Ammonia: Feasibility and Cost Saving
Repurposing LNG terminals for Hydrogen Ammonia: Feasibility and Cost SavingRepurposing LNG terminals for Hydrogen Ammonia: Feasibility and Cost Saving
Repurposing LNG terminals for Hydrogen Ammonia: Feasibility and Cost Saving
 

(ARC402) Double Redundancy With AWS Direct Connect

  • 1. © 2015, Amazon Web Services, Inc. or its Affiliates. All rights reserved. Matt Lehwess, AWS October 2015 ARC402 Double Redundancy With AWS Direct Connect
  • 2. Agenda • Building network foundations in AWS • Connecting your onsite deployment to AWS • Adding some redundancy into the mix • Demo: Taking our environment live and introducing some failures!
  • 3. Foundations: Amazon VPC Your own private, isolated section of the AWS cloud
  • 4. VPC CIDR 10.1.0.0/16 Availability Zone A Availability Zone B Public Subnet Public Subnet Private Subnet Private Subnet Instance A 10.1.1.11 /24 Instance B 10.1.2.22 /24 Instance C 10.1.3.33 /24 Instance D 10.1.4.44 /24 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 Only 1 IGW and 1 VGW per VPC
  • 5. Foundations: Other Services Lets add some AWS services outside of VPC
  • 6. AWS Region - eg: US-WEST1 Our VPC from Earlier AWS Region AWS Region Level Services (plus many more) AWS VPC Internal Services (e.g. Amazon EMR, Elastic Load Balancing, Amazon RDS) IGW, gateway between AWS region level services and internal VPC services Instance A 10.1.1.11 /24 Availability Zone A Availability Zone B Public Subnet Public Subnet Private Subnet Private Subnet Instance B 10.1.2.22 /24 Instance C 10.1.3.33 /24 Instance D 10.1.4.44 /24 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 Amazon SNS Amazon SQS Amazon SWF Amazon SES Amazon S3 Amazon Glacier Amazon DynamoDB AWS Lambda
  • 7. Connectivity: AWS to On-Premises Using AWS Direct Connect
  • 8. 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 Customer DCColocation Facility - e.g. Equinix SV1 VPC CIDR 10.1.0.0/16 Customer Subnet 192.168.0.0/16 Direct Connect POP Colocation Facility Customer or Partner Device AWS Direct Connect Point of Presence Customer Gateway Cross Connect Customer Data Center Service Provider Backhaul Anatomy of AWS Direct Connect Private Virtual Interface Configure Customer Gateway VPC VGW
  • 9. Standard Interface & BGP Configuration… interface GigabitEthernet0/1 no ip address interface GigabitEthernet0/1.807 description "Direct Connect to your Amazon VPC or AWS Cloud" encapsulation dot1Q 807 ip address 172.16.7.5 255.255.255.252 router bgp 65001 neighbor 172.16.7.6 remote-as 7224 neighbor 172.16.7.6 password 7 $1$zVOvlUSp$UrqWP2awtiG8ZbXo9BwcB network 0.0.0.0 exit Physical Interface that fiber is plugged into Sub-interface (Generally matches VLAN) VLAN Association /30 Private P2P address BGP ASN Route Advertisement to AWS Just a description BGP MD5 Password Neighbor Peer Address
  • 10. 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 VPC CIDR 10.1.0.0/16 Customer DCColocation Facility - e.g. Equinix SV1 Customer Subnet 192.168.0.0/16 Configure Customer Gateway Customer Gateway BGP Comes up, prefixes are advertised. %BGP-5-ADJCHANGE: neighbor 172.16.6.6 Up AWS Direct Connect Point of Presence Anatomy of AWS Direct Connect continued...
  • 11. 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 VPC CIDR 10.1.0.0/16 Customer DCColocation Facility - e.g. Equinix SV1 Customer Subnet 172.160.0.0/16 Anatomy of AWS Direct Connect continued... Customer Gateway AWS Direct Connect Point of Presence My Private Virtual Interface is up, now what? What about my S3 bucket or DynamoDB? – in comes Public Virtual Interfaces!
  • 12. 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 VPC CIDR 10.1.0.0/16 Amazon SNS Amazon SQS Amazon SWF Amazon SES Amazon S3 Amazon DynamoDB AWS Region - eg: US-WEST1 AWS LambdaAmazon Glacier Customer DCColocation Facility - e.g. Equinix SV1 Customer Subnet 172.160.0.0/16 Customer Gateway AWS Regions much larger than just what’s inside a VPC Create Public Virtual Interface Configure Customer Gateway BGP Comes up, prefixes are advertised (Public only!). %BGP-5-ADJCHANGE: neighbor 203.50.24.5 Anatomy of AWS Direct Connect continued... AWS Direct Connect Point of Presence
  • 13. Adding Redundancy “Everything fails, all the time.” – Werner Vogels
  • 14. Anatomy of a redundant AWS Direct Connect Customer Subnet 172.160.0.0/16 Double connectivity The standard connectivity we built earlierVPC VGW Redundant DX POP LocationOther AWS Services 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 VPC CIDR 10.1.0.0/16 Amazon SNS Amazon SQS Amazon SWF Amazon SES Amazon S3 Amazon DynamoDB AWS Region - eg: US-WEST1 AWS LambdaAmazon Glacier
  • 15. Amazon SNS Amazon SQS Amazon SWF Amazon SES Amazon S3 Amazon DynamoDB AWS Region - eg: US-WEST1 AWS LambdaAmazon Glacier Anatomy of a redundant AWS Direct Connect Customer Subnet 172.160.0.0/16 How do we configure redundant BGP? And here too! 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 VPC CIDR 10.1.0.0/16
  • 16. Standard Interface & BGP Configuration… #Active Passive deployment: router bgp 65001 neighbor 10.1.0.2 remote-as 65200 neighbor 10.1.0.2 description Backup neighbor 10.1.0.2 route-map prepend out route-map prepend permit 10 set as-path prepend 65001 65001 65001 Using one link as the primary, and the other “Prepended” as the secondary and less preferred route
  • 17. Autonomous System (AS) Path Prepending? Origin NetworkPrepended ASNPrepended ASNPrepended ASN Verses. Origin Network Metric 4 Metric 1 Less Preferred More Preferred 0% 100%
  • 18. Standard Interface & BGP Configuration… #Active Active deployment: router bgp 1 maximum-paths 4 Usually reserved for a single customer router scenario, can be configured at the service provider level as well. Note: By default we “Multi-path” outbound from VGW over equal cost paths unless you set a metric such as AS PATH on one route.
  • 19. Autonomous System (AS) Equal Paths Origin Network Vs. Origin Network Metric 1 Metric 1 Both Preferred Both Preferred 50% 50%
  • 20. Did I hear Double Redundancy? You can use VPN as your backup of backups
  • 21. Amazon SNS Amazon SQS Amazon SWF Amazon SES Amazon S3 Amazon DynamoDB AWS Region - eg: US-WEST1 AWS LambdaAmazon Glacier 10.1.1.0/16 10.1.2.0/16 10.1.3.0/16 VPC CIDR 10.1.0.0/16 Anatomy of a redundant AWS Direct Connect Customer Subnet 172.160.0.0/16 Most MPLS Providers can “trunk” you an internet circuitOur VGW’s are also used as VPN connection points remember! Dual VPN tunnels providing connectivity and encryption.
  • 22. VPN & BGP Redundancy Configuration… #Direct Connect Interface: interface GigabitEthernet0/0/0.259 description "Direct Connect to your Amazon VPC or AWS Cloud" encapsulation dot1Q 259 ip address 169.254.254.2 255.255.255.252 bfd interval 300 min_rx 300 multiplier 3 ! Subinterface VLAN ID Local IP Address BFD Configuration
  • 23. VPN & BGP Redundancy Configuration… #Inter Router Interface: interface GigabitEthernet0/1 description ** Internal Interface - SW2 Gi2/0/1 ** ip address 192.168.51.253 255.255.255.0 ip virtual-reassembly in standby 1 ip 192.168.51.254 standby 1 timers msec 300 msec 900 standby 1 priority 110 standby 1 preempt duplex auto speed auto ! Local LAN IP HSRP Configuration HSRP sub second hello This router is primary Preempt primary if not active
  • 24. VPN & BGP Redundancy Configuration… BGP Configuration: router bgp 65501 bgp log-neighbor-changes neighbor 169.254.254.1 remote-as 9059 neighbor 169.254.254.1 password 7 124B36F51 neighbor 169.254.254.1 fall-over bfd neighbor 192.168.51.252 remote-as 65501 ! Direct Connect neighbor BFD Configuration Inter router neighbor
  • 25. VPN & BGP Redundancy Configuration… Secondary router BGP and route-map assignment: router bgp 65501 bgp log-neighbor-changes neighbor 169.254.254.37 remote-as 9059 neighbor 169.254.254.37 route-map LOCAL-PREF in neighbor 169.254.254.37 route-map AS-PREPEND out Secondary Direct Connect neighbor Inbound route-map Outbound route-map
  • 26. VPN & BGP Redundancy Configuration… Secondary router route-map: ip prefix-list LOCAL-ROUTES seq 10 permit 192.168.0.0/16 le 32 route-map AS-PREPEND permit 10 match ip address prefix-list LOCAL-ROUTES set as-path prepend 65501 65501 ! route-map LOCAL-PREF permit 10 set local-preference 90 ! Match local routes for AS prepending Match above prefix list Add ASN x 2 to AS Path Set local preference to 90 (for secondary)
  • 27. Now adding VPN…. VPN Tunnel interface (Straight forward): interface Tunnel1 ip address 169.254.20.62 255.255.255.252 ip virtual-reassembly in ip tcp adjust-mss 1387 tunnel source 62.216.229.132 tunnel mode ipsec ipv4 tunnel destination 52.17.141.73 tunnel protection ipsec profile ipsec-vpn-946e19df-0 !
  • 28. Now adding VPN…. VPN Tunnel interface (Straight forward): interface Tunnel2 ip address 169.254.20.162 255.255.255.252 ip virtual-reassembly in ip tcp adjust-mss 1387 tunnel source 62.216.229.132 tunnel mode ipsec ipv4 tunnel destination 52.18.219.193 tunnel protection ipsec profile ipsec-vpn-946e19df-1 ! Plus your other VPN goodness like crypto-maps…
  • 29. Now adding VPN…. VPN BGP Configuration (Still standard..) Router BGP 65501 neighbor 169.254.20.61 remote-as 9059 neighbor 169.254.20.61 timers 10 30 30 ! Address-family ipv4 network 192.168.51.0 neighbor 169.254.20.61 activate neighbor 169.254.20.61 route-map LOCAL-PREF-VPN in neighbor 169.254.20.61 route-map AS-PREPEND-VPN out ! Standard BGP Configuration Where it gets interesting…
  • 30. Now adding VPN…. #Where we add our metrics: route-map AS-PREPEND-VPN permit 10 match ip address prefix-list LOCAL-ROUTES set as-path prepend 65501 65501 65501 ! route-map LOCAL-PREF-VPN permit 10 set local-preference 80 ! An additional ASN beyond our backup direct connect link Local Preference is 10 lower than our backup Direct Connect link
  • 31. Our real life environment
  • 32. Demo Let’s see how our use case was built on AWS
  • 33. Our real life environment
  • 34. In summary • Built our network foundations in AWS • Connected your onsite deployment to AWS • Added some redundancy into the mix • Demo: Took our environment live and introduced some failures!
  • 35. Related Sessions NET406 - Deep Dive: AWS Direct Connect and VPNs • Thursday, Oct 8, 2:45 PM - 3:45 PM – Palazzo C ISM403 - How Amazon.com is Moving to Amazon WorkSpaces • Thursday, Oct 8, 1:30 PM - 2:30 PM – Titian 2306