SlideShare a Scribd company logo
1 of 13
Change the encapsulation
 Go in interface mode and select the Frame Relay
encapsulation on the interface. There are two types of
Frame Relay encapsulations: Cisco and IETF. Cisco is the
default. Syntax to set your encapsulation is
encapsulation frame-relay [ietf]
Configure LMI type
 The three LMI types are Cisco, Ansi, and Q933a. For IOS
11.2 and higher, the LMI type is automatically detected
frame-relay lmi-type [cisco | ansi | 933a]
Configure Frame Relay map
 configuring a static Frame Relay map, is optional unless you are
using subinterfaces. The Frame Relay map will map a Layer 3
address to a local DLCI. This step is optional because inverse-arp
will automatically perform this map for you. The syntax for a
Frame Relay map is as follows:
frame-relay map protocol address dlci [broadcast] [cisco |
ietf]
Configure subinterfaces
 If you are using a routing protocol in a hub-and-spoke topology,
you will probably want to use subinterfaces to avoid the split-
horizon problem. To configure a subinterface, remove the IP
address off the main interface and put it under the subinterface.
Configuring a subinterface involves assigning it a number and
specifying the type. The following command creates point-to-
point subinterface serial0/0.1
Router(config)#interface serial0/0.1 point-to-point
 To create a multipoint subinterface, enter multipoint instead:
Router(config)#interface serial0/0.1 multipoint
Assign IP address to subinterface
 After entering one of these commands you will be taken to the
subinterface configuration mode where you can enter your IP
address:
Router(config-subif)#ip address 10.0.0.2 255.0.0.0
 If you are using a multipoint subinterface, you will need to
configure frame-relay maps and you cannot rely on inverse-arp.
 If you are using a point-to-point subinterface, you will need to
assign a DLCI to the subinterface. This is only for point-to-point
subinterfaces; this is not needed on the main interface or on
multipoint subinterfaces. To assign a DLCI to a point-to-point
subinterface, enter the following command under the
subinterface:
frame-relay interface-dlci dlci
 Now first configure R1. Fast Ethernet port and hostname is
already configured. Double click on R1 and configure serial port
for frame relay encapsulation and further create sub interface
for connecting R2, R3, R4. Configure also static route for
connecting remaining network.
Configure R1
R1>enable
R1#configure terminal
R1(config)#interface serial 0/0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown
R1(config-if)#exit
 R1(config-subif)#interface serial 0/0/0.102 point-to-point
 R1(config-subif)#ip address 192.168.1.245 255.255.255.252
 R1(config-subif)#frame-relay interface-dlci 102
 R1(config-subif)#exit
 R1(config)#interface serial 0/0/0.103 point-to-point
 R1(config-subif)#ip address 192.168.1.249 255.255.255.252
 R1(config-subif)#frame-relay interface-dlci 103
 R1(config-subif)#exit
 R1(config)#interface serial 0/0/0.104 point-to-point
 R1(config-subif)#ip address 192.168.1.253 255.255.255.252
 R1(config-subif)#frame-relay interface-dlci 104
 R1(config-subif)#exit
 R1(config)#ip route 192.168.1.64 255.255.255.224 192.168.1.246
 R1(config)#ip route 192.168.1.96 255.255.255.224 192.168.1.250
 R1(config)#ip route 192.168.1.128 255.255.255.224 192.168.1.254
 R1(config)#exit
configure R2
R2>enable
R2#configure terminal
R2(config)#interface serial 0/0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/0/0.101 point-to-point
R2(config-subif)#ip address 192.168.1.246 255.255.255.252
R2(config-subif)#frame-relay interface-dlci 101
R2(config-subif)#exit
R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.245
configure R3
R3>enable
R3#configure terminal
R3(config)#interface serial 0/0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface serial 0/0/0.101 point-to-point
R3(config-subif)#ip address 192.168.1.250 255.255.255.252
R3(config-subif)#frame-relay interface-dlci 101
R3(config-subif)#exit
R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.249
R3(config)#
configure R4
R4>enable
R4#configure terminal
R4(config)#interface serial 0/0/0
R4(config-if)#encapsulation frame-relay
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface serial 0/0/0.101 point-to-point
R4(config-subif)#ip address 192.168.1.254 255.255.255.252
R4(config-subif)#frame-relay interface-dlci 101
R4(config-subif)#exit
R4(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.253
R4(config)#
Router(config)#interface serial 0/0/0 Enter in interface mode
Router(config-if)#encapsulation frame-relay
Turns on Frame Relay encapsulation with the default
encapsulation type of cisco
Router(config-if)#frame-relay lmitype {ansi | cisco |
q933a}
Depending on the option you select, this command sets
the LMI type to the ANSI standard, the Cisco standard,
or the ITU-T Q.933 Annex A standard.
Router(config-if)#frame-relay interface-dlci 110
Sets the DLCI number of 110 on the local interface and
enters Frame Relay DLCI configuration mode
Router(config-fr-dlci)#exit Returns to interface configuration mode
Router(config-if)#frame-relay map ip 192.168.100.1 110
broadcast
Maps the remote IP address (192.168.100.1) to the local
DLCI number (110). The optional broadcast keyword
specifies that broadcasts across IP should be forwarded
to this address. This is necessary when using dynamic
routing protocols.
Router(config-if)#no frame-relay inverse
arp
Turns off Inverse ARP.
Router#show frame-relay map Displays IP/DLCI map entries
Router#show frame-relay pvc Displays the status of all PVCs configured
Router#show frame-relay lmi Displays LMI statistics
Router#clear frame-relay counters Clears and resets all Frame Relay counters
Router#clear frame-relay inarp
Clears all Inverse ARP entries from the map
table
Router#debug frame-relay lmi
Used to help determine whether a router
and Frame Relay switch are exchanging LMI
packets properly

More Related Content

What's hot (20)

Frame Relay
Frame RelayFrame Relay
Frame Relay
 
Chapter3 frame relay
Chapter3   frame relayChapter3   frame relay
Chapter3 frame relay
 
Frame relay
Frame relay Frame relay
Frame relay
 
Frame Relay
Frame RelayFrame Relay
Frame Relay
 
Forouzan frame relay
Forouzan frame relayForouzan frame relay
Forouzan frame relay
 
Frame Relay
Frame RelayFrame Relay
Frame Relay
 
Frame relay
Frame relayFrame relay
Frame relay
 
Frame
FrameFrame
Frame
 
X.25 and frame relay
X.25 and frame relayX.25 and frame relay
X.25 and frame relay
 
Frame Relay
Frame RelayFrame Relay
Frame Relay
 
Frame relay
Frame relayFrame relay
Frame relay
 
Switching
SwitchingSwitching
Switching
 
Virtual lan
Virtual lanVirtual lan
Virtual lan
 
VIRTUAL CIRCUIT NETWORKS, atm , frame relay
VIRTUAL CIRCUIT NETWORKS, atm , frame relayVIRTUAL CIRCUIT NETWORKS, atm , frame relay
VIRTUAL CIRCUIT NETWORKS, atm , frame relay
 
Switching
SwitchingSwitching
Switching
 
Frame relay
Frame relayFrame relay
Frame relay
 
Vlan
Vlan Vlan
Vlan
 
Wide area networks
Wide area networksWide area networks
Wide area networks
 
Presentation
PresentationPresentation
Presentation
 
Frame Relay Chapter 04
Frame Relay Chapter 04Frame Relay Chapter 04
Frame Relay Chapter 04
 

Similar to How to configure frame realy

Similar to How to configure frame realy (20)

Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame Relay
 
Frame Relay (point to point)
Frame Relay (point to point)Frame Relay (point to point)
Frame Relay (point to point)
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
 
Ccna command
Ccna commandCcna command
Ccna command
 
Ccna 4 chapter 3 v4.0 answers 2011
Ccna 4 chapter 3 v4.0 answers 2011Ccna 4 chapter 3 v4.0 answers 2011
Ccna 4 chapter 3 v4.0 answers 2011
 
Aula04 - configuração da topologia ppp - resolvido
Aula04 -  configuração da topologia ppp - resolvidoAula04 -  configuração da topologia ppp - resolvido
Aula04 - configuração da topologia ppp - resolvido
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
Chapter14ccna
Chapter14ccnaChapter14ccna
Chapter14ccna
 
Chapter14ccna
Chapter14ccnaChapter14ccna
Chapter14ccna
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 Minutes
 
Samplab19
Samplab19Samplab19
Samplab19
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2
 
Ccna command
Ccna commandCcna command
Ccna command
 

More from NetProtocol Xpert

Basic Cisco ASA 5506-x Configuration (Firepower)
Basic Cisco ASA 5506-x Configuration (Firepower)Basic Cisco ASA 5506-x Configuration (Firepower)
Basic Cisco ASA 5506-x Configuration (Firepower)NetProtocol Xpert
 
Common Layer 2 Threats, Attacks & Mitigation
Common Layer 2 Threats, Attacks & MitigationCommon Layer 2 Threats, Attacks & Mitigation
Common Layer 2 Threats, Attacks & MitigationNetProtocol Xpert
 
Dynamic ARP Inspection (DAI)
Dynamic ARP Inspection (DAI)Dynamic ARP Inspection (DAI)
Dynamic ARP Inspection (DAI)NetProtocol Xpert
 
Securing management, control & data plane
Securing management, control & data planeSecuring management, control & data plane
Securing management, control & data planeNetProtocol Xpert
 
Point to-point protocol (ppp), PAP & CHAP
Point to-point protocol (ppp), PAP & CHAPPoint to-point protocol (ppp), PAP & CHAP
Point to-point protocol (ppp), PAP & CHAPNetProtocol Xpert
 
Avoid DNS lookup when mistyping a command
Avoid DNS lookup when mistyping a commandAvoid DNS lookup when mistyping a command
Avoid DNS lookup when mistyping a commandNetProtocol Xpert
 
TCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and SwitchesTCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and SwitchesNetProtocol Xpert
 
MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)NetProtocol Xpert
 
OTV(Overlay Transport Virtualization)
OTV(Overlay  Transport  Virtualization)OTV(Overlay  Transport  Virtualization)
OTV(Overlay Transport Virtualization)NetProtocol Xpert
 

More from NetProtocol Xpert (20)

Basic Cisco ASA 5506-x Configuration (Firepower)
Basic Cisco ASA 5506-x Configuration (Firepower)Basic Cisco ASA 5506-x Configuration (Firepower)
Basic Cisco ASA 5506-x Configuration (Firepower)
 
MPLS Layer 3 VPN
MPLS Layer 3 VPN MPLS Layer 3 VPN
MPLS Layer 3 VPN
 
Common Layer 2 Threats, Attacks & Mitigation
Common Layer 2 Threats, Attacks & MitigationCommon Layer 2 Threats, Attacks & Mitigation
Common Layer 2 Threats, Attacks & Mitigation
 
Storm-Control
Storm-ControlStorm-Control
Storm-Control
 
Dynamic ARP Inspection (DAI)
Dynamic ARP Inspection (DAI)Dynamic ARP Inspection (DAI)
Dynamic ARP Inspection (DAI)
 
IP Source Guard
IP Source Guard IP Source Guard
IP Source Guard
 
DHCP Snooping
DHCP SnoopingDHCP Snooping
DHCP Snooping
 
Password Recovery
Password RecoveryPassword Recovery
Password Recovery
 
Application & Data Center
Application & Data CenterApplication & Data Center
Application & Data Center
 
Cisco ISR 4351 Router
Cisco ISR 4351 RouterCisco ISR 4351 Router
Cisco ISR 4351 Router
 
Cisco ASR 1001-X Router
Cisco ASR 1001-X RouterCisco ASR 1001-X Router
Cisco ASR 1001-X Router
 
Securing management, control & data plane
Securing management, control & data planeSecuring management, control & data plane
Securing management, control & data plane
 
Point to-point protocol (ppp), PAP & CHAP
Point to-point protocol (ppp), PAP & CHAPPoint to-point protocol (ppp), PAP & CHAP
Point to-point protocol (ppp), PAP & CHAP
 
Avoid DNS lookup when mistyping a command
Avoid DNS lookup when mistyping a commandAvoid DNS lookup when mistyping a command
Avoid DNS lookup when mistyping a command
 
TCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and SwitchesTCLSH and Macro Ping Test on Cisco Routers and Switches
TCLSH and Macro Ping Test on Cisco Routers and Switches
 
Private VLANs
Private VLANsPrivate VLANs
Private VLANs
 
MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)MTU (maximum transmission unit) & MRU (maximum receive unit)
MTU (maximum transmission unit) & MRU (maximum receive unit)
 
OTV Configuration
OTV ConfigurationOTV Configuration
OTV Configuration
 
Cisco OTV 
Cisco OTV Cisco OTV 
Cisco OTV 
 
OTV(Overlay Transport Virtualization)
OTV(Overlay  Transport  Virtualization)OTV(Overlay  Transport  Virtualization)
OTV(Overlay Transport Virtualization)
 

Recently uploaded

(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...
(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...
(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...ranjana rawat
 
HARMONY IN THE NATURE AND EXISTENCE - Unit-IV
HARMONY IN THE NATURE AND EXISTENCE - Unit-IVHARMONY IN THE NATURE AND EXISTENCE - Unit-IV
HARMONY IN THE NATURE AND EXISTENCE - Unit-IVRajaP95
 
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).pptssuser5c9d4b1
 
Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...
Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...
Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...Christo Ananth
 
Booking open Available Pune Call Girls Koregaon Park 6297143586 Call Hot Ind...
Booking open Available Pune Call Girls Koregaon Park  6297143586 Call Hot Ind...Booking open Available Pune Call Girls Koregaon Park  6297143586 Call Hot Ind...
Booking open Available Pune Call Girls Koregaon Park 6297143586 Call Hot Ind...Call Girls in Nagpur High Profile
 
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICSHARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICSRajkumarAkumalla
 
MANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLS
MANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLSMANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLS
MANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLSSIVASHANKAR N
 
Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...
Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...
Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...Dr.Costas Sachpazis
 
High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...
High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...
High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...Call girls in Ahmedabad High profile
 
the ladakh protest in leh ladakh 2024 sonam wangchuk.pptx
the ladakh protest in leh ladakh 2024 sonam wangchuk.pptxthe ladakh protest in leh ladakh 2024 sonam wangchuk.pptx
the ladakh protest in leh ladakh 2024 sonam wangchuk.pptxhumanexperienceaaa
 
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130Suhani Kapoor
 
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝soniya singh
 
Software Development Life Cycle By Team Orange (Dept. of Pharmacy)
Software Development Life Cycle By  Team Orange (Dept. of Pharmacy)Software Development Life Cycle By  Team Orange (Dept. of Pharmacy)
Software Development Life Cycle By Team Orange (Dept. of Pharmacy)Suman Mia
 
Call Girls in Nagpur Suman Call 7001035870 Meet With Nagpur Escorts
Call Girls in Nagpur Suman Call 7001035870 Meet With Nagpur EscortsCall Girls in Nagpur Suman Call 7001035870 Meet With Nagpur Escorts
Call Girls in Nagpur Suman Call 7001035870 Meet With Nagpur EscortsCall Girls in Nagpur High Profile
 
UNIT-V FMM.HYDRAULIC TURBINE - Construction and working
UNIT-V FMM.HYDRAULIC TURBINE - Construction and workingUNIT-V FMM.HYDRAULIC TURBINE - Construction and working
UNIT-V FMM.HYDRAULIC TURBINE - Construction and workingrknatarajan
 
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptxDecoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptxJoão Esperancinha
 
SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )Tsuyoshi Horigome
 

Recently uploaded (20)

(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...
(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...
(ANVI) Koregaon Park Call Girls Just Call 7001035870 [ Cash on Delivery ] Pun...
 
HARMONY IN THE NATURE AND EXISTENCE - Unit-IV
HARMONY IN THE NATURE AND EXISTENCE - Unit-IVHARMONY IN THE NATURE AND EXISTENCE - Unit-IV
HARMONY IN THE NATURE AND EXISTENCE - Unit-IV
 
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
247267395-1-Symmetric-and-distributed-shared-memory-architectures-ppt (1).ppt
 
Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...
Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...
Call for Papers - African Journal of Biological Sciences, E-ISSN: 2663-2187, ...
 
Booking open Available Pune Call Girls Koregaon Park 6297143586 Call Hot Ind...
Booking open Available Pune Call Girls Koregaon Park  6297143586 Call Hot Ind...Booking open Available Pune Call Girls Koregaon Park  6297143586 Call Hot Ind...
Booking open Available Pune Call Girls Koregaon Park 6297143586 Call Hot Ind...
 
Call Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCR
Call Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCRCall Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCR
Call Us -/9953056974- Call Girls In Vikaspuri-/- Delhi NCR
 
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICSHARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
HARDNESS, FRACTURE TOUGHNESS AND STRENGTH OF CERAMICS
 
MANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLS
MANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLSMANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLS
MANUFACTURING PROCESS-II UNIT-5 NC MACHINE TOOLS
 
Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...
Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...
Structural Analysis and Design of Foundations: A Comprehensive Handbook for S...
 
High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...
High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...
High Profile Call Girls Dahisar Arpita 9907093804 Independent Escort Service ...
 
the ladakh protest in leh ladakh 2024 sonam wangchuk.pptx
the ladakh protest in leh ladakh 2024 sonam wangchuk.pptxthe ladakh protest in leh ladakh 2024 sonam wangchuk.pptx
the ladakh protest in leh ladakh 2024 sonam wangchuk.pptx
 
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
 
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
 
DJARUM4D - SLOT GACOR ONLINE | SLOT DEMO ONLINE
DJARUM4D - SLOT GACOR ONLINE | SLOT DEMO ONLINEDJARUM4D - SLOT GACOR ONLINE | SLOT DEMO ONLINE
DJARUM4D - SLOT GACOR ONLINE | SLOT DEMO ONLINE
 
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
Model Call Girl in Narela Delhi reach out to us at 🔝8264348440🔝
 
Software Development Life Cycle By Team Orange (Dept. of Pharmacy)
Software Development Life Cycle By  Team Orange (Dept. of Pharmacy)Software Development Life Cycle By  Team Orange (Dept. of Pharmacy)
Software Development Life Cycle By Team Orange (Dept. of Pharmacy)
 
Call Girls in Nagpur Suman Call 7001035870 Meet With Nagpur Escorts
Call Girls in Nagpur Suman Call 7001035870 Meet With Nagpur EscortsCall Girls in Nagpur Suman Call 7001035870 Meet With Nagpur Escorts
Call Girls in Nagpur Suman Call 7001035870 Meet With Nagpur Escorts
 
UNIT-V FMM.HYDRAULIC TURBINE - Construction and working
UNIT-V FMM.HYDRAULIC TURBINE - Construction and workingUNIT-V FMM.HYDRAULIC TURBINE - Construction and working
UNIT-V FMM.HYDRAULIC TURBINE - Construction and working
 
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptxDecoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
Decoding Kotlin - Your guide to solving the mysterious in Kotlin.pptx
 
SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )SPICE PARK APR2024 ( 6,793 SPICE Models )
SPICE PARK APR2024 ( 6,793 SPICE Models )
 

How to configure frame realy

  • 1.
  • 2. Change the encapsulation  Go in interface mode and select the Frame Relay encapsulation on the interface. There are two types of Frame Relay encapsulations: Cisco and IETF. Cisco is the default. Syntax to set your encapsulation is encapsulation frame-relay [ietf] Configure LMI type  The three LMI types are Cisco, Ansi, and Q933a. For IOS 11.2 and higher, the LMI type is automatically detected frame-relay lmi-type [cisco | ansi | 933a]
  • 3. Configure Frame Relay map  configuring a static Frame Relay map, is optional unless you are using subinterfaces. The Frame Relay map will map a Layer 3 address to a local DLCI. This step is optional because inverse-arp will automatically perform this map for you. The syntax for a Frame Relay map is as follows: frame-relay map protocol address dlci [broadcast] [cisco | ietf]
  • 4. Configure subinterfaces  If you are using a routing protocol in a hub-and-spoke topology, you will probably want to use subinterfaces to avoid the split- horizon problem. To configure a subinterface, remove the IP address off the main interface and put it under the subinterface. Configuring a subinterface involves assigning it a number and specifying the type. The following command creates point-to- point subinterface serial0/0.1 Router(config)#interface serial0/0.1 point-to-point  To create a multipoint subinterface, enter multipoint instead: Router(config)#interface serial0/0.1 multipoint
  • 5. Assign IP address to subinterface  After entering one of these commands you will be taken to the subinterface configuration mode where you can enter your IP address: Router(config-subif)#ip address 10.0.0.2 255.0.0.0  If you are using a multipoint subinterface, you will need to configure frame-relay maps and you cannot rely on inverse-arp.  If you are using a point-to-point subinterface, you will need to assign a DLCI to the subinterface. This is only for point-to-point subinterfaces; this is not needed on the main interface or on multipoint subinterfaces. To assign a DLCI to a point-to-point subinterface, enter the following command under the subinterface: frame-relay interface-dlci dlci
  • 6.
  • 7.  Now first configure R1. Fast Ethernet port and hostname is already configured. Double click on R1 and configure serial port for frame relay encapsulation and further create sub interface for connecting R2, R3, R4. Configure also static route for connecting remaining network. Configure R1 R1>enable R1#configure terminal R1(config)#interface serial 0/0/0 R1(config-if)#encapsulation frame-relay R1(config-if)#no shutdown R1(config-if)#exit
  • 8.  R1(config-subif)#interface serial 0/0/0.102 point-to-point  R1(config-subif)#ip address 192.168.1.245 255.255.255.252  R1(config-subif)#frame-relay interface-dlci 102  R1(config-subif)#exit  R1(config)#interface serial 0/0/0.103 point-to-point  R1(config-subif)#ip address 192.168.1.249 255.255.255.252  R1(config-subif)#frame-relay interface-dlci 103  R1(config-subif)#exit  R1(config)#interface serial 0/0/0.104 point-to-point  R1(config-subif)#ip address 192.168.1.253 255.255.255.252  R1(config-subif)#frame-relay interface-dlci 104  R1(config-subif)#exit  R1(config)#ip route 192.168.1.64 255.255.255.224 192.168.1.246  R1(config)#ip route 192.168.1.96 255.255.255.224 192.168.1.250  R1(config)#ip route 192.168.1.128 255.255.255.224 192.168.1.254  R1(config)#exit
  • 9. configure R2 R2>enable R2#configure terminal R2(config)#interface serial 0/0/0 R2(config-if)#encapsulation frame-relay R2(config-if)#no shutdown R2(config-if)#exit R2(config)#interface serial 0/0/0.101 point-to-point R2(config-subif)#ip address 192.168.1.246 255.255.255.252 R2(config-subif)#frame-relay interface-dlci 101 R2(config-subif)#exit R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.245
  • 10. configure R3 R3>enable R3#configure terminal R3(config)#interface serial 0/0/0 R3(config-if)#encapsulation frame-relay R3(config-if)#no shutdown R3(config-if)#exit R3(config)#interface serial 0/0/0.101 point-to-point R3(config-subif)#ip address 192.168.1.250 255.255.255.252 R3(config-subif)#frame-relay interface-dlci 101 R3(config-subif)#exit R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.249 R3(config)#
  • 11. configure R4 R4>enable R4#configure terminal R4(config)#interface serial 0/0/0 R4(config-if)#encapsulation frame-relay R4(config-if)#no shutdown R4(config-if)#exit R4(config)#interface serial 0/0/0.101 point-to-point R4(config-subif)#ip address 192.168.1.254 255.255.255.252 R4(config-subif)#frame-relay interface-dlci 101 R4(config-subif)#exit R4(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.253 R4(config)#
  • 12. Router(config)#interface serial 0/0/0 Enter in interface mode Router(config-if)#encapsulation frame-relay Turns on Frame Relay encapsulation with the default encapsulation type of cisco Router(config-if)#frame-relay lmitype {ansi | cisco | q933a} Depending on the option you select, this command sets the LMI type to the ANSI standard, the Cisco standard, or the ITU-T Q.933 Annex A standard. Router(config-if)#frame-relay interface-dlci 110 Sets the DLCI number of 110 on the local interface and enters Frame Relay DLCI configuration mode Router(config-fr-dlci)#exit Returns to interface configuration mode Router(config-if)#frame-relay map ip 192.168.100.1 110 broadcast Maps the remote IP address (192.168.100.1) to the local DLCI number (110). The optional broadcast keyword specifies that broadcasts across IP should be forwarded to this address. This is necessary when using dynamic routing protocols.
  • 13. Router(config-if)#no frame-relay inverse arp Turns off Inverse ARP. Router#show frame-relay map Displays IP/DLCI map entries Router#show frame-relay pvc Displays the status of all PVCs configured Router#show frame-relay lmi Displays LMI statistics Router#clear frame-relay counters Clears and resets all Frame Relay counters Router#clear frame-relay inarp Clears all Inverse ARP entries from the map table Router#debug frame-relay lmi Used to help determine whether a router and Frame Relay switch are exchanging LMI packets properly