SlideShare a Scribd company logo
1 of 1
Download to read offline
packetlife.net 
NETWORK ADDRESS TRANSLATION 
FastEthernet0 
10.0.0.1/16 
NAT Inside 
Example Topology 
NAT Boundary Configuration 
interface FastEthernet0 
ip address 10.0.0.1 255.255.0.0 
ip nat inside 
! 
interface FastEthernet1 
ip address 174.143.212.1 255.255.252.0 
ip nat outside 
FastEthernet1 
174.143.212.1/22 
NAT Outside 
Static Source Translation 
! One line per static translation 
ip nat inside source static 10.0.0.19 192.0.2.1 
ip nat inside source static 10.0.1.47 192.0.2.2 
ip nat outside source static 174.143.212.133 10.0.0.47 
ip nat outside source static 174.143.213.240 10.0.2.181 
Dynamic Source Translation 
! Create an access list to match inside local addresses 
access-list 10 permit 10.0.0.0 0.0.255.255 
! 
! Create NAT pool of inside global addresses 
ip nat pool MyPool 192.0.2.1 192.0.2.254 prefix-length 24 
! 
! Combine them with a translation rule 
ip nat inside source list 10 pool MyPool 
! 
! Dynamic translations can be combined with static entries 
ip nat inside source static 10.0.0.42 192.0.2.42 
Port Address Translation (PAT) 
Outside Global 
Outside Local 
Location 
! Static layer four port translations 
ip nat inside source static tcp 10.0.0.3 8080 192.0.2.1 80 
ip nat inside source static udp 10.0.0.14 53 192.0.2.2 53 
ip nat outside source static tcp 174.143.212.4 23 10.0.0.8 23 
! 
! Dynamic port translation with a pool 
ip nat inside source list 11 pool MyPool overload 
! 
! Dynamic translation with interface overloading 
ip nat inside source list 11 interface FastEthernet1 overload 
Inside Local 
Inside Global 
Inside 
Address Classification 
Outside 
Terminology 
NAT Pool 
A pool of IP addresses to be used as inside 
global or outside local addresses in translations 
Port Address Translation (PAT) 
An extension to NAT that translates information 
at layer four and above, such as TCP and UDP 
port numbers; dynamic PAT configurations 
include the overload keyword 
Extendable Translation 
The extendable keyword must be appended 
when multiple overlapping static translations are 
configured 
Special NAT Pool Types 
Rotary Used for load balancing 
Preserves the host portion of 
the address after translation 
Match- 
Host 
show ip nat translations [verbose] 
show ip nat statistics 
clear ip nat translations 
NAT Translations Tuning 
ip nat translation tcp-timeout <seconds> 
ip nat translation udp-timeout <seconds> 
ip nat translation max-entries <number> 
Inside Destination Translation 
An actual address assigned to 
an inside host 
An inside address seen from 
the outside 
An actual address assigned to 
an outside host 
An outside address seen from 
the inside 
Local Global 
Inside Local Inside Global 
Outside Local Outside Global 
Troubleshooting 
! Create a rotary NAT pool 
ip nat pool LoadBalServers 10.0.99.200 10.0.99.203 prefix-length 24 type rotary 
! 
! Enable load balancing across inside hosts for incoming traffic 
ip nat inside destination list 12 pool LoadBalServers 
Perspective 
by Jeremy Stretch v1.0

More Related Content

What's hot

The End of IPv4: What It Means for Incident Responders
The End of IPv4: What It Means for Incident RespondersThe End of IPv4: What It Means for Incident Responders
The End of IPv4: What It Means for Incident RespondersCarlos Martinez Cagnazzo
 
At640 datasheet-d20110704 en
At640 datasheet-d20110704 enAt640 datasheet-d20110704 en
At640 datasheet-d20110704 enTran Thanh
 
Ad-Hoc Networking in Linux with Avahi
Ad-Hoc Networking in Linux with AvahiAd-Hoc Networking in Linux with Avahi
Ad-Hoc Networking in Linux with Avahisinchume
 
NetFlow Monitoring for Cyber Threat Defense
NetFlow Monitoring for Cyber Threat DefenseNetFlow Monitoring for Cyber Threat Defense
NetFlow Monitoring for Cyber Threat DefenseCisco Canada
 
Dhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETF
Dhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETFDhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETF
Dhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETFzarigatongy
 
Samba and Vista with IPv6
Samba and Vista with IPv6Samba and Vista with IPv6
Samba and Vista with IPv6dinomasch
 
OARC 26: Scoring the Root Server System
OARC 26: Scoring the Root Server SystemOARC 26: Scoring the Root Server System
OARC 26: Scoring the Root Server SystemAPNIC
 
IPv6 How To Set Up a Linux IPv6 Lan
IPv6 How To Set Up  a Linux IPv6 LanIPv6 How To Set Up  a Linux IPv6 Lan
IPv6 How To Set Up a Linux IPv6 LanJumping Bean
 
Internet Protocol version 10 (IPv10).
Internet Protocol version 10 (IPv10).Internet Protocol version 10 (IPv10).
Internet Protocol version 10 (IPv10).Khaled Omar
 
IPv6 Best Practice
IPv6 Best PracticeIPv6 Best Practice
IPv6 Best Practiceflyingpotato
 
Ipv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentationIpv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentationIDEA4PRO
 
Razor: provision like a boss (Build-a-cloud edition)
Razor: provision like a  boss (Build-a-cloud edition)Razor: provision like a  boss (Build-a-cloud edition)
Razor: provision like a boss (Build-a-cloud edition)lutter
 
internet protocol version6
internet protocol version6internet protocol version6
internet protocol version6Akhil Kumar
 
Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017
Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017
Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017VOIP2DAY
 
Zero Configuration Networking
Zero Configuration NetworkingZero Configuration Networking
Zero Configuration NetworkingZafar Shahid, PhD
 
Getting started with IPv6
Getting started with IPv6Getting started with IPv6
Getting started with IPv6Private
 

What's hot (20)

The End of IPv4: What It Means for Incident Responders
The End of IPv4: What It Means for Incident RespondersThe End of IPv4: What It Means for Incident Responders
The End of IPv4: What It Means for Incident Responders
 
At640 datasheet-d20110704 en
At640 datasheet-d20110704 enAt640 datasheet-d20110704 en
At640 datasheet-d20110704 en
 
Ad-Hoc Networking in Linux with Avahi
Ad-Hoc Networking in Linux with AvahiAd-Hoc Networking in Linux with Avahi
Ad-Hoc Networking in Linux with Avahi
 
Kamailio - SIP Servers Everywhere
Kamailio - SIP Servers EverywhereKamailio - SIP Servers Everywhere
Kamailio - SIP Servers Everywhere
 
NetFlow Monitoring for Cyber Threat Defense
NetFlow Monitoring for Cyber Threat DefenseNetFlow Monitoring for Cyber Threat Defense
NetFlow Monitoring for Cyber Threat Defense
 
Dhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETF
Dhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETFDhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETF
Dhcpv6 Tutorial Overview, DHCP for Ipv6 ,RFC 3315 - IETF
 
Samba and Vista with IPv6
Samba and Vista with IPv6Samba and Vista with IPv6
Samba and Vista with IPv6
 
OARC 26: Scoring the Root Server System
OARC 26: Scoring the Root Server SystemOARC 26: Scoring the Root Server System
OARC 26: Scoring the Root Server System
 
IPv6 How To Set Up a Linux IPv6 Lan
IPv6 How To Set Up  a Linux IPv6 LanIPv6 How To Set Up  a Linux IPv6 Lan
IPv6 How To Set Up a Linux IPv6 Lan
 
Internet Protocol version 10 (IPv10).
Internet Protocol version 10 (IPv10).Internet Protocol version 10 (IPv10).
Internet Protocol version 10 (IPv10).
 
IPv6 Best Practice
IPv6 Best PracticeIPv6 Best Practice
IPv6 Best Practice
 
Ipv6
Ipv6Ipv6
Ipv6
 
Nat
NatNat
Nat
 
Ipv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentationIpv6 introduction - MUM 2011 presentation
Ipv6 introduction - MUM 2011 presentation
 
Razor: provision like a boss (Build-a-cloud edition)
Razor: provision like a  boss (Build-a-cloud edition)Razor: provision like a  boss (Build-a-cloud edition)
Razor: provision like a boss (Build-a-cloud edition)
 
internet protocol version6
internet protocol version6internet protocol version6
internet protocol version6
 
Keep calm-and-try-v6only
Keep calm-and-try-v6onlyKeep calm-and-try-v6only
Keep calm-and-try-v6only
 
Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017
Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017
Homer metrics | LORENZO MANGANI Y FEDERICO CABIDDU - VoIP2DAY 2017
 
Zero Configuration Networking
Zero Configuration NetworkingZero Configuration Networking
Zero Configuration Networking
 
Getting started with IPv6
Getting started with IPv6Getting started with IPv6
Getting started with IPv6
 

Similar to Nat

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccnarobertoxe
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routersIT Tech
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)Netwax Lab
 
Chapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfChapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfBuntha Chhay
 
NAT and PAT
NAT and PATNAT and PAT
NAT and PATMuuluu
 
Network address translations
Network address translations Network address translations
Network address translations Shahzad shareef
 
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9Waqas Ahmed Nawaz
 
Module (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxModule (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxGeorgeThoreJr
 
SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.
SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.
SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.Louis Göhl
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address TranslationEng. Emad Al-Atoum
 

Similar to Nat (20)

Nat
NatNat
Nat
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
NAT Ccna
NAT CcnaNAT Ccna
NAT Ccna
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routers
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
 
N at
N atN at
N at
 
Chapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdfChapter 5-Network Address Translation.pdf
Chapter 5-Network Address Translation.pdf
 
Day 17 nat and pat
Day 17 nat and patDay 17 nat and pat
Day 17 nat and pat
 
NAT and PAT
NAT and PATNAT and PAT
NAT and PAT
 
Nat 07
Nat 07Nat 07
Nat 07
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
Network address translations
Network address translations Network address translations
Network address translations
 
NAT_Final
NAT_FinalNAT_Final
NAT_Final
 
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
CCNA (R & S) Module 03 - Routing & Switching Essentials - Chapter 9
 
Module (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptxModule (10) NAT for IPV4.pptx
Module (10) NAT for IPV4.pptx
 
Nat 03
Nat 03Nat 03
Nat 03
 
NAT Examples.pptx
NAT Examples.pptxNAT Examples.pptx
NAT Examples.pptx
 
SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.
SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.
SVR402: DirectAccess Technical Drilldown, Part 2 of 2: Putting it all together.
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address Translation
 

More from saul calle espinoza (20)

Introducción a la economía IV
Introducción a la economía IVIntroducción a la economía IV
Introducción a la economía IV
 
Introducción a la economía III
Introducción a la economía IIIIntroducción a la economía III
Introducción a la economía III
 
Introducción a la economía II
Introducción a la economía IIIntroducción a la economía II
Introducción a la economía II
 
Introducción a la economía I
Introducción a la economía IIntroducción a la economía I
Introducción a la economía I
 
caratula Uno
caratula Unocaratula Uno
caratula Uno
 
caratula Unifranz
caratula Unifranzcaratula Unifranz
caratula Unifranz
 
caratula Ueb
caratula Uebcaratula Ueb
caratula Ueb
 
caratula Udabol
caratula Udabolcaratula Udabol
caratula Udabol
 
caratula UAGRM Trabajo social
caratula UAGRM Trabajo socialcaratula UAGRM Trabajo social
caratula UAGRM Trabajo social
 
caratula Tesis UAGRM
caratula Tesis UAGRMcaratula Tesis UAGRM
caratula Tesis UAGRM
 
caratula UAGRM Trabajo avendaño.
caratula UAGRM Trabajo avendaño.caratula UAGRM Trabajo avendaño.
caratula UAGRM Trabajo avendaño.
 
Tapa de cd UAGRM
Tapa de cd UAGRM Tapa de cd UAGRM
Tapa de cd UAGRM
 
caratula Sociologia uagrm
caratula Sociologia uagrm caratula Sociologia uagrm
caratula Sociologia uagrm
 
caratula Petrolera uagrm
caratula Petrolera uagrmcaratula Petrolera uagrm
caratula Petrolera uagrm
 
caratula Normal enrique finot
caratula Normal enrique finotcaratula Normal enrique finot
caratula Normal enrique finot
 
Ingenieria en cs. de la computacion uagrm
Ingenieria en cs. de la computacion uagrm Ingenieria en cs. de la computacion uagrm
Ingenieria en cs. de la computacion uagrm
 
caratula Humanidades uagrm
caratula Humanidades uagrmcaratula Humanidades uagrm
caratula Humanidades uagrm
 
caratula Financiera uagrm
caratula Financiera uagrmcaratula Financiera uagrm
caratula Financiera uagrm
 
caratula Enrrique finot
caratula Enrrique finotcaratula Enrrique finot
caratula Enrrique finot
 
caratula Electromecanica uagrm
caratula Electromecanica uagrmcaratula Electromecanica uagrm
caratula Electromecanica uagrm
 

Recently uploaded

Electronically Controlled suspensions system .pdf
Electronically Controlled suspensions system .pdfElectronically Controlled suspensions system .pdf
Electronically Controlled suspensions system .pdfme23b1001
 
Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024hassan khalil
 
Introduction-To-Agricultural-Surveillance-Rover.pptx
Introduction-To-Agricultural-Surveillance-Rover.pptxIntroduction-To-Agricultural-Surveillance-Rover.pptx
Introduction-To-Agricultural-Surveillance-Rover.pptxk795866
 
Sachpazis Costas: Geotechnical Engineering: A student's Perspective Introduction
Sachpazis Costas: Geotechnical Engineering: A student's Perspective IntroductionSachpazis Costas: Geotechnical Engineering: A student's Perspective Introduction
Sachpazis Costas: Geotechnical Engineering: A student's Perspective IntroductionDr.Costas Sachpazis
 
main PPT.pptx of girls hostel security using rfid
main PPT.pptx of girls hostel security using rfidmain PPT.pptx of girls hostel security using rfid
main PPT.pptx of girls hostel security using rfidNikhilNagaraju
 
chaitra-1.pptx fake news detection using machine learning
chaitra-1.pptx  fake news detection using machine learningchaitra-1.pptx  fake news detection using machine learning
chaitra-1.pptx fake news detection using machine learningmisbanausheenparvam
 
OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...
OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...
OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...Soham Mondal
 
Microscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptxMicroscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptxpurnimasatapathy1234
 
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130Suhani Kapoor
 
Application of Residue Theorem to evaluate real integrations.pptx
Application of Residue Theorem to evaluate real integrations.pptxApplication of Residue Theorem to evaluate real integrations.pptx
Application of Residue Theorem to evaluate real integrations.pptx959SahilShah
 
Biology for Computer Engineers Course Handout.pptx
Biology for Computer Engineers Course Handout.pptxBiology for Computer Engineers Course Handout.pptx
Biology for Computer Engineers Course Handout.pptxDeepakSakkari2
 
IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024Mark Billinghurst
 
VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...
VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...
VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...VICTOR MAESTRE RAMIREZ
 
Introduction to Microprocesso programming and interfacing.pptx
Introduction to Microprocesso programming and interfacing.pptxIntroduction to Microprocesso programming and interfacing.pptx
Introduction to Microprocesso programming and interfacing.pptxvipinkmenon1
 
What are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptxWhat are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptxwendy cai
 

Recently uploaded (20)

Electronically Controlled suspensions system .pdf
Electronically Controlled suspensions system .pdfElectronically Controlled suspensions system .pdf
Electronically Controlled suspensions system .pdf
 
Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024Architect Hassan Khalil Portfolio for 2024
Architect Hassan Khalil Portfolio for 2024
 
Exploring_Network_Security_with_JA3_by_Rakesh Seal.pptx
Exploring_Network_Security_with_JA3_by_Rakesh Seal.pptxExploring_Network_Security_with_JA3_by_Rakesh Seal.pptx
Exploring_Network_Security_with_JA3_by_Rakesh Seal.pptx
 
Introduction-To-Agricultural-Surveillance-Rover.pptx
Introduction-To-Agricultural-Surveillance-Rover.pptxIntroduction-To-Agricultural-Surveillance-Rover.pptx
Introduction-To-Agricultural-Surveillance-Rover.pptx
 
Sachpazis Costas: Geotechnical Engineering: A student's Perspective Introduction
Sachpazis Costas: Geotechnical Engineering: A student's Perspective IntroductionSachpazis Costas: Geotechnical Engineering: A student's Perspective Introduction
Sachpazis Costas: Geotechnical Engineering: A student's Perspective Introduction
 
main PPT.pptx of girls hostel security using rfid
main PPT.pptx of girls hostel security using rfidmain PPT.pptx of girls hostel security using rfid
main PPT.pptx of girls hostel security using rfid
 
chaitra-1.pptx fake news detection using machine learning
chaitra-1.pptx  fake news detection using machine learningchaitra-1.pptx  fake news detection using machine learning
chaitra-1.pptx fake news detection using machine learning
 
OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...
OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...
OSVC_Meta-Data based Simulation Automation to overcome Verification Challenge...
 
Microscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptxMicroscopic Analysis of Ceramic Materials.pptx
Microscopic Analysis of Ceramic Materials.pptx
 
POWER SYSTEMS-1 Complete notes examples
POWER SYSTEMS-1 Complete notes  examplesPOWER SYSTEMS-1 Complete notes  examples
POWER SYSTEMS-1 Complete notes examples
 
★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR
★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR
★ CALL US 9953330565 ( HOT Young Call Girls In Badarpur delhi NCR
 
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
VIP Call Girls Service Hitech City Hyderabad Call +91-8250192130
 
Application of Residue Theorem to evaluate real integrations.pptx
Application of Residue Theorem to evaluate real integrations.pptxApplication of Residue Theorem to evaluate real integrations.pptx
Application of Residue Theorem to evaluate real integrations.pptx
 
Biology for Computer Engineers Course Handout.pptx
Biology for Computer Engineers Course Handout.pptxBiology for Computer Engineers Course Handout.pptx
Biology for Computer Engineers Course Handout.pptx
 
IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024IVE Industry Focused Event - Defence Sector 2024
IVE Industry Focused Event - Defence Sector 2024
 
young call girls in Rajiv Chowk🔝 9953056974 🔝 Delhi escort Service
young call girls in Rajiv Chowk🔝 9953056974 🔝 Delhi escort Serviceyoung call girls in Rajiv Chowk🔝 9953056974 🔝 Delhi escort Service
young call girls in Rajiv Chowk🔝 9953056974 🔝 Delhi escort Service
 
VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...
VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...
VICTOR MAESTRE RAMIREZ - Planetary Defender on NASA's Double Asteroid Redirec...
 
Introduction to Microprocesso programming and interfacing.pptx
Introduction to Microprocesso programming and interfacing.pptxIntroduction to Microprocesso programming and interfacing.pptx
Introduction to Microprocesso programming and interfacing.pptx
 
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
9953056974 Call Girls In South Ex, Escorts (Delhi) NCR.pdf
 
What are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptxWhat are the advantages and disadvantages of membrane structures.pptx
What are the advantages and disadvantages of membrane structures.pptx
 

Nat

  • 1. packetlife.net NETWORK ADDRESS TRANSLATION FastEthernet0 10.0.0.1/16 NAT Inside Example Topology NAT Boundary Configuration interface FastEthernet0 ip address 10.0.0.1 255.255.0.0 ip nat inside ! interface FastEthernet1 ip address 174.143.212.1 255.255.252.0 ip nat outside FastEthernet1 174.143.212.1/22 NAT Outside Static Source Translation ! One line per static translation ip nat inside source static 10.0.0.19 192.0.2.1 ip nat inside source static 10.0.1.47 192.0.2.2 ip nat outside source static 174.143.212.133 10.0.0.47 ip nat outside source static 174.143.213.240 10.0.2.181 Dynamic Source Translation ! Create an access list to match inside local addresses access-list 10 permit 10.0.0.0 0.0.255.255 ! ! Create NAT pool of inside global addresses ip nat pool MyPool 192.0.2.1 192.0.2.254 prefix-length 24 ! ! Combine them with a translation rule ip nat inside source list 10 pool MyPool ! ! Dynamic translations can be combined with static entries ip nat inside source static 10.0.0.42 192.0.2.42 Port Address Translation (PAT) Outside Global Outside Local Location ! Static layer four port translations ip nat inside source static tcp 10.0.0.3 8080 192.0.2.1 80 ip nat inside source static udp 10.0.0.14 53 192.0.2.2 53 ip nat outside source static tcp 174.143.212.4 23 10.0.0.8 23 ! ! Dynamic port translation with a pool ip nat inside source list 11 pool MyPool overload ! ! Dynamic translation with interface overloading ip nat inside source list 11 interface FastEthernet1 overload Inside Local Inside Global Inside Address Classification Outside Terminology NAT Pool A pool of IP addresses to be used as inside global or outside local addresses in translations Port Address Translation (PAT) An extension to NAT that translates information at layer four and above, such as TCP and UDP port numbers; dynamic PAT configurations include the overload keyword Extendable Translation The extendable keyword must be appended when multiple overlapping static translations are configured Special NAT Pool Types Rotary Used for load balancing Preserves the host portion of the address after translation Match- Host show ip nat translations [verbose] show ip nat statistics clear ip nat translations NAT Translations Tuning ip nat translation tcp-timeout <seconds> ip nat translation udp-timeout <seconds> ip nat translation max-entries <number> Inside Destination Translation An actual address assigned to an inside host An inside address seen from the outside An actual address assigned to an outside host An outside address seen from the inside Local Global Inside Local Inside Global Outside Local Outside Global Troubleshooting ! Create a rotary NAT pool ip nat pool LoadBalServers 10.0.99.200 10.0.99.203 prefix-length 24 type rotary ! ! Enable load balancing across inside hosts for incoming traffic ip nat inside destination list 12 pool LoadBalServers Perspective by Jeremy Stretch v1.0