SlideShare a Scribd company logo
1 of 6
Download to read offline
Routing protocol commands list
CCNA Routing Protocol Commands
IP ROUTING
#sh ip route // To view IP routing tables created on a Cisco router.
Static Routing
Routers are manually configured for networks that are not directly connected, to be
able to route to all networks via the next-hop interface.
Syntax:
(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.2
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 //To remove a static
route
// Please note the ‘no’ which is the word used in routers to negate any command
Default Routing
Used on stub networks only to send packets with remote destination network not
in the routing table to the next hop router.
Syntax:
(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1
RIP (Routing Information Protocol)
A distance vector routing protocol that passes complete routing table contents to
neighbouring routers
Example– Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a
router interfaces and 192.168.30.0 be non-directly connected
Syntax 1:
(config)#router rip
(config-router)#192.168.10.0
(config-router)#192.168.20.0
(config-router)#exit
Verifying RIP
1.Sh ip route
2.debug ip
Syntax 2:
(config)#router rip
(config-router)#network 192.168.10.0
(config-router)#passive-interface serial 0/0 //In this case we have used the interface
address rather a IP address
EIGRP
Proprietary of CISCO
Uses classless routing which is subnet mask information sent with routing protocol
updates.
Example– Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a
router interfaces with autonomous system number of 20 and 192.168.30.0 be non-
directly connected
Syntax 1:
#router eigrp 20
(config-router)#network 192.168.10.0
(config-router)#network 192.168.20.0
(config-router)#^z
Syntax 2:
(config)#router eigrp 20
(config-router)#passive-interface serial 0/0
To enable EIGRP on discontiguos networks(two different subnetworks of classfull
network connected by another different classful subnetwork)
Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another
remote subnetwork of 192.168.10.0, then to enable EIGRP, we use
(config)#router eigrp 100
(config-router)#network 172.16.0.0
(config-router)#network 10.0.0.0
(config-router)#no auto-summary
HINT:
The no auto-summary command should be enabled in routers that encloses such
networks.
Verifying EIGRP
1. sh ip route //Shows entire routing table
2. sh ip route eigrp //Shows only EIGRP entries in the routing table
3. ip eigrp neighbours // Shows all EIGRP neighbours
4. ip eigrp topology // Shows entries in the EIGRP topology table
OSPF
A link-state routing protocol
Example– Let 10.0.0.0 be the network directly connected to the router upon which
OSPF is to be enabled; with ospf ID of 1 and area o
(config)#router ospf 1
(config-router)#network 10.0.0.0 0.255.255.255 area0
Loopback Interface– They are configured to be used as the routers RID to
advertise the routes and elect DR and BDR.
Example– Let the loopback iinterface be configured on interface with ip 172.16.10.1
(config)#int loopback 0
(config-if)#ip address 172.16.10.1 255.255.255.0
(config-if)#no shut
(config-if)#^z
Verifying OSPF Configuration
1. sh ip ospf // Used to display all OSPF information
2. sh ip ospf database // indicates the number of links and neighboring router ID
3. sh ip ospf interface //Displays all OSPF interface related info
4. sh ip ospf neighbour // Summarizes OSPF info about neighbours
5. sh ip protocols // Overview of all present running protocols
Verifying Loopback and RID
1. sh running-config // To verify loopback address
2. sh ip ospf database // Verifies the new RID of each router
3. sh ip ospf interface // Verifies the new RID of each router
IMPORTANT COMMANDS
Checking the Current Configuration Register Values
show version or show ver
Changing Configuration Register
(config)#config-register 0x101 (d default is 0x2102)
Recovering Passwords in Router
1. Interrupt the Router Boot Sequence
ctrl+Break key (windows wont perform break key, only 95/98)
2. Changing the configuration register
for 2600 series router
rammon>confreg 0x2142
for 2500
type 0 after a break and enter the command o/r 0x2142
3. Reloading the Router and Entering Privilged mode
for 2600-type reset
for 2500-type I
4. Viewing and changing the configuration
copy run start
5. Resetting the configuration Register and Reloading the Router
config t
config-register 0x2102
copy run start-to save
Backing up and restoring the Cisco ios
1. verifying flash memory-Ensuring flash memory has enough room
router#sh flash
2. Backing-up the ciso ios
first verify server connectivity by- Router#ping 192.168.0.120 then;
(config-router)#copy flash tftp
3. Restoring or upgrading the cisco router ios
router#copy tftp flash
Backing up and Restoring the Cisco configuration
1.Backing up the cisco router configuration
copy runing config tftp
2. verifying the current configuration
sh run
3. copying the current cofiguration to NVRAM
copy run start
4. copying the current configuration to a TFTP server
copy run TFTP
5. Restoring the Cisco Router Configuration
copy TFTP run
6. Erasing the configuration
erase startup-config
Getting CDP timers and Holdtime information
Router#config t
Router(config)#cdp timer 90
Router(config)#cdp holdtime 240
Router(config)#^z
To turn-off CDP Completely
Router(config)#no cdp run
Using DNS to resolve names
#config t
(config)#ip domain-lookup (usually turned on by default)
(config)#ip name-server 192.168.0.70 (ip of an assumed DNS set)
(config)#ip domain-name india-router.com (Appends the domain name to a host)
(config)#^z

More Related Content

What's hot

Acn Experiment No 5
Acn Experiment No 5Acn Experiment No 5
Acn Experiment No 5Garima Singh
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 MinutesCCNAResources
 
Acn Experiment No 4
Acn Experiment No 4Acn Experiment No 4
Acn Experiment No 4Garima Singh
 
INTRODUCTION TO IOS AND CISCO ROUTERS
INTRODUCTION TO IOS AND CISCO ROUTERSINTRODUCTION TO IOS AND CISCO ROUTERS
INTRODUCTION TO IOS AND CISCO ROUTERSanilinvns
 
Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Abdul Basit
 
How to Configure ip address for router interfaces
How to Configure ip address for router interfacesHow to Configure ip address for router interfaces
How to Configure ip address for router interfacestcpipguru
 
How to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchHow to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchIT Tech
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration3Anetwork com
 
Trik singkat STATIC ROUTING via cli Packet Tracer
Trik singkat STATIC ROUTING via cli Packet Tracer Trik singkat STATIC ROUTING via cli Packet Tracer
Trik singkat STATIC ROUTING via cli Packet Tracer Selamet Hariadi
 
Route Redistribution
Route RedistributionRoute Redistribution
Route RedistributionNetwax Lab
 
Лекц 15
Лекц 15Лекц 15
Лекц 15Muuluu
 
Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet3Anetwork com
 
Cisco router basic configuration commands
Cisco router basic configuration commandsCisco router basic configuration commands
Cisco router basic configuration commandsCCNAStudyGuide
 
Manage CISCO IOS
Manage CISCO IOSManage CISCO IOS
Manage CISCO IOSanilinvns
 
Juniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationJuniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationHamed Moghaddam
 

What's hot (19)

Acn Experiment No 5
Acn Experiment No 5Acn Experiment No 5
Acn Experiment No 5
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 Minutes
 
Acn Experiment No 4
Acn Experiment No 4Acn Experiment No 4
Acn Experiment No 4
 
INTRODUCTION TO IOS AND CISCO ROUTERS
INTRODUCTION TO IOS AND CISCO ROUTERSINTRODUCTION TO IOS AND CISCO ROUTERS
INTRODUCTION TO IOS AND CISCO ROUTERS
 
Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2
 
How to Configure ip address for router interfaces
How to Configure ip address for router interfacesHow to Configure ip address for router interfaces
How to Configure ip address for router interfaces
 
Configuración del dial peer
Configuración del dial peer Configuración del dial peer
Configuración del dial peer
 
How to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchHow to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switch
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
Ccna command
Ccna commandCcna command
Ccna command
 
Trik singkat STATIC ROUTING via cli Packet Tracer
Trik singkat STATIC ROUTING via cli Packet Tracer Trik singkat STATIC ROUTING via cli Packet Tracer
Trik singkat STATIC ROUTING via cli Packet Tracer
 
Route Redistribution
Route RedistributionRoute Redistribution
Route Redistribution
 
Лекц 15
Лекц 15Лекц 15
Лекц 15
 
Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet
 
Cisco ios-cont
Cisco ios-contCisco ios-cont
Cisco ios-cont
 
Cisco router basic configuration commands
Cisco router basic configuration commandsCisco router basic configuration commands
Cisco router basic configuration commands
 
Manage CISCO IOS
Manage CISCO IOSManage CISCO IOS
Manage CISCO IOS
 
1
11
1
 
Juniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route ConfigurationJuniper JNCIA – Juniper OSPF Route Configuration
Juniper JNCIA – Juniper OSPF Route Configuration
 

Viewers also liked

Interaksi manusia dan komputer
Interaksi manusia dan komputerInteraksi manusia dan komputer
Interaksi manusia dan komputerMiftahul Khair N
 
Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information ProtocolMiftahul Khair N
 
CCNA Based routing protocols
CCNA Based routing protocolsCCNA Based routing protocols
CCNA Based routing protocolsGaurav Rawat
 
Leaky bucket algorithm
Leaky bucket algorithmLeaky bucket algorithm
Leaky bucket algorithmUmesh Gupta
 
Routing protocol on wireless sensor network
Routing protocol on wireless sensor networkRouting protocol on wireless sensor network
Routing protocol on wireless sensor networkshashankcsnits
 
RIP - Routing Information Protocol
RIP - Routing Information ProtocolRIP - Routing Information Protocol
RIP - Routing Information Protocolselvakumar_b1985
 
Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information ProtocolKashif Latif
 
CCNA Advanced Routing Protocols
CCNA Advanced Routing ProtocolsCCNA Advanced Routing Protocols
CCNA Advanced Routing ProtocolsDsunte Wilson
 
Subnetting Basics Tutorial
Subnetting Basics TutorialSubnetting Basics Tutorial
Subnetting Basics Tutorialmikem801
 
Network Layer,Computer Networks
Network Layer,Computer NetworksNetwork Layer,Computer Networks
Network Layer,Computer Networksguesta81d4b
 
Leaky Bucket & Tocken Bucket - Traffic shaping
Leaky Bucket & Tocken Bucket - Traffic shapingLeaky Bucket & Tocken Bucket - Traffic shaping
Leaky Bucket & Tocken Bucket - Traffic shapingVimal Dewangan
 

Viewers also liked (14)

Day 5.5 subnetting
Day 5.5 subnettingDay 5.5 subnetting
Day 5.5 subnetting
 
Subnet calculation Tutorial
Subnet calculation TutorialSubnet calculation Tutorial
Subnet calculation Tutorial
 
Interaksi manusia dan komputer
Interaksi manusia dan komputerInteraksi manusia dan komputer
Interaksi manusia dan komputer
 
Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information Protocol
 
CCNA Based routing protocols
CCNA Based routing protocolsCCNA Based routing protocols
CCNA Based routing protocols
 
Leaky bucket algorithm
Leaky bucket algorithmLeaky bucket algorithm
Leaky bucket algorithm
 
Routing protocol on wireless sensor network
Routing protocol on wireless sensor networkRouting protocol on wireless sensor network
Routing protocol on wireless sensor network
 
RIP - Routing Information Protocol
RIP - Routing Information ProtocolRIP - Routing Information Protocol
RIP - Routing Information Protocol
 
Routing Information Protocol
Routing Information ProtocolRouting Information Protocol
Routing Information Protocol
 
CCNA Advanced Routing Protocols
CCNA Advanced Routing ProtocolsCCNA Advanced Routing Protocols
CCNA Advanced Routing Protocols
 
Subnetting Basics Tutorial
Subnetting Basics TutorialSubnetting Basics Tutorial
Subnetting Basics Tutorial
 
Network Layer,Computer Networks
Network Layer,Computer NetworksNetwork Layer,Computer Networks
Network Layer,Computer Networks
 
Leaky Bucket & Tocken Bucket - Traffic shaping
Leaky Bucket & Tocken Bucket - Traffic shapingLeaky Bucket & Tocken Bucket - Traffic shaping
Leaky Bucket & Tocken Bucket - Traffic shaping
 
Projeto gelo
Projeto geloProjeto gelo
Projeto gelo
 

Similar to Routing protocol commands list

Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration3Anetwork com
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)IT Tech
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)Netwax Lab
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config97148881557
 
How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)IT Tech
 
Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011Dân Chơi
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheetGuntaka Reddy
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheetEZREIG OMAR
 
Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Netwax Lab
 
Chapter 04 - Router Conf
Chapter 04 - Router ConfChapter 04 - Router Conf
Chapter 04 - Router Confphanleson
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Saurav Pandey
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospfmyciokas
 
ENSA_Module_2.pptx
ENSA_Module_2.pptxENSA_Module_2.pptx
ENSA_Module_2.pptxserieux1
 

Similar to Routing protocol commands list (20)

Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)
 
Intro to router_config
Intro to router_configIntro to router_config
Intro to router_config
 
How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)How to configure interior gateway routing protocol (igrp)
How to configure interior gateway routing protocol (igrp)
 
Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011Ccna 2 chapter 11 v4.0 answers 2011
Ccna 2 chapter 11 v4.0 answers 2011
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)Cisco Internetworking Operating System (ios)
Cisco Internetworking Operating System (ios)
 
CCNA presentation.
CCNA presentation.CCNA presentation.
CCNA presentation.
 
Chapter 04 - Router Conf
Chapter 04 - Router ConfChapter 04 - Router Conf
Chapter 04 - Router Conf
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospf
 
OSWAN.pptx
OSWAN.pptxOSWAN.pptx
OSWAN.pptx
 
ENSA_Module_2.pptx
ENSA_Module_2.pptxENSA_Module_2.pptx
ENSA_Module_2.pptx
 
ENSA_Module_2.pptx
ENSA_Module_2.pptxENSA_Module_2.pptx
ENSA_Module_2.pptx
 

Recently uploaded

Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?Mattias Andersson
 
Pigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food ManufacturingPigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food ManufacturingPigging Solutions
 
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticsKotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticscarlostorres15106
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLScyllaDB
 
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek SchlawackFwdays
 
Streamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupStreamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupFlorian Wilhelm
 
Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfAddepto
 
My Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 PresentationMy Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 PresentationRidwan Fadjar
 
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024BookNet Canada
 
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...Patryk Bandurski
 
Artificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxArtificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxhariprasad279825
 
CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):comworks
 
Beyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry InnovationBeyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry InnovationSafe Software
 
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...shyamraj55
 
Human Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR SystemsHuman Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR SystemsMark Billinghurst
 
SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024Lorenzo Miniero
 
Powerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time ClashPowerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time Clashcharlottematthew16
 
SQL Database Design For Developers at php[tek] 2024
SQL Database Design For Developers at php[tek] 2024SQL Database Design For Developers at php[tek] 2024
SQL Database Design For Developers at php[tek] 2024Scott Keck-Warren
 

Recently uploaded (20)

Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?
 
Pigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food ManufacturingPigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food Manufacturing
 
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticsKotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQL
 
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
 
Streamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupStreamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project Setup
 
Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdf
 
My Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 PresentationMy Hashitalk Indonesia April 2024 Presentation
My Hashitalk Indonesia April 2024 Presentation
 
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
 
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
Integration and Automation in Practice: CI/CD in Mule Integration and Automat...
 
Hot Sexy call girls in Panjabi Bagh 🔝 9953056974 🔝 Delhi escort Service
Hot Sexy call girls in Panjabi Bagh 🔝 9953056974 🔝 Delhi escort ServiceHot Sexy call girls in Panjabi Bagh 🔝 9953056974 🔝 Delhi escort Service
Hot Sexy call girls in Panjabi Bagh 🔝 9953056974 🔝 Delhi escort Service
 
Artificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxArtificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptx
 
CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):
 
Beyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry InnovationBeyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
Beyond Boundaries: Leveraging No-Code Solutions for Industry Innovation
 
DMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special EditionDMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special Edition
 
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
Automating Business Process via MuleSoft Composer | Bangalore MuleSoft Meetup...
 
Human Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR SystemsHuman Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR Systems
 
SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024
 
Powerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time ClashPowerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time Clash
 
SQL Database Design For Developers at php[tek] 2024
SQL Database Design For Developers at php[tek] 2024SQL Database Design For Developers at php[tek] 2024
SQL Database Design For Developers at php[tek] 2024
 

Routing protocol commands list

  • 1. Routing protocol commands list CCNA Routing Protocol Commands IP ROUTING #sh ip route // To view IP routing tables created on a Cisco router. Static Routing Routers are manually configured for networks that are not directly connected, to be able to route to all networks via the next-hop interface. Syntax: (config)#ip route 192.168.10.0 255.255.255.0 192.168.20.2 (config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 //To remove a static route // Please note the ‘no’ which is the word used in routers to negate any command Default Routing Used on stub networks only to send packets with remote destination network not in the routing table to the next hop router. Syntax: (config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1 RIP (Routing Information Protocol) A distance vector routing protocol that passes complete routing table contents to neighbouring routers Example– Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces and 192.168.30.0 be non-directly connected Syntax 1: (config)#router rip (config-router)#192.168.10.0
  • 2. (config-router)#192.168.20.0 (config-router)#exit Verifying RIP 1.Sh ip route 2.debug ip Syntax 2: (config)#router rip (config-router)#network 192.168.10.0 (config-router)#passive-interface serial 0/0 //In this case we have used the interface address rather a IP address EIGRP Proprietary of CISCO Uses classless routing which is subnet mask information sent with routing protocol updates. Example– Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces with autonomous system number of 20 and 192.168.30.0 be non- directly connected Syntax 1: #router eigrp 20 (config-router)#network 192.168.10.0 (config-router)#network 192.168.20.0 (config-router)#^z Syntax 2: (config)#router eigrp 20 (config-router)#passive-interface serial 0/0
  • 3. To enable EIGRP on discontiguos networks(two different subnetworks of classfull network connected by another different classful subnetwork) Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another remote subnetwork of 192.168.10.0, then to enable EIGRP, we use (config)#router eigrp 100 (config-router)#network 172.16.0.0 (config-router)#network 10.0.0.0 (config-router)#no auto-summary HINT: The no auto-summary command should be enabled in routers that encloses such networks. Verifying EIGRP 1. sh ip route //Shows entire routing table 2. sh ip route eigrp //Shows only EIGRP entries in the routing table 3. ip eigrp neighbours // Shows all EIGRP neighbours 4. ip eigrp topology // Shows entries in the EIGRP topology table OSPF A link-state routing protocol Example– Let 10.0.0.0 be the network directly connected to the router upon which OSPF is to be enabled; with ospf ID of 1 and area o (config)#router ospf 1 (config-router)#network 10.0.0.0 0.255.255.255 area0 Loopback Interface– They are configured to be used as the routers RID to advertise the routes and elect DR and BDR. Example– Let the loopback iinterface be configured on interface with ip 172.16.10.1 (config)#int loopback 0 (config-if)#ip address 172.16.10.1 255.255.255.0
  • 4. (config-if)#no shut (config-if)#^z Verifying OSPF Configuration 1. sh ip ospf // Used to display all OSPF information 2. sh ip ospf database // indicates the number of links and neighboring router ID 3. sh ip ospf interface //Displays all OSPF interface related info 4. sh ip ospf neighbour // Summarizes OSPF info about neighbours 5. sh ip protocols // Overview of all present running protocols Verifying Loopback and RID 1. sh running-config // To verify loopback address 2. sh ip ospf database // Verifies the new RID of each router 3. sh ip ospf interface // Verifies the new RID of each router IMPORTANT COMMANDS Checking the Current Configuration Register Values show version or show ver Changing Configuration Register (config)#config-register 0x101 (d default is 0x2102) Recovering Passwords in Router 1. Interrupt the Router Boot Sequence ctrl+Break key (windows wont perform break key, only 95/98) 2. Changing the configuration register for 2600 series router rammon>confreg 0x2142 for 2500 type 0 after a break and enter the command o/r 0x2142
  • 5. 3. Reloading the Router and Entering Privilged mode for 2600-type reset for 2500-type I 4. Viewing and changing the configuration copy run start 5. Resetting the configuration Register and Reloading the Router config t config-register 0x2102 copy run start-to save Backing up and restoring the Cisco ios 1. verifying flash memory-Ensuring flash memory has enough room router#sh flash 2. Backing-up the ciso ios first verify server connectivity by- Router#ping 192.168.0.120 then; (config-router)#copy flash tftp 3. Restoring or upgrading the cisco router ios router#copy tftp flash Backing up and Restoring the Cisco configuration 1.Backing up the cisco router configuration copy runing config tftp 2. verifying the current configuration sh run 3. copying the current cofiguration to NVRAM copy run start 4. copying the current configuration to a TFTP server copy run TFTP 5. Restoring the Cisco Router Configuration
  • 6. copy TFTP run 6. Erasing the configuration erase startup-config Getting CDP timers and Holdtime information Router#config t Router(config)#cdp timer 90 Router(config)#cdp holdtime 240 Router(config)#^z To turn-off CDP Completely Router(config)#no cdp run Using DNS to resolve names #config t (config)#ip domain-lookup (usually turned on by default) (config)#ip name-server 192.168.0.70 (ip of an assumed DNS set) (config)#ip domain-name india-router.com (Appends the domain name to a host) (config)#^z