SlideShare a Scribd company logo
1 of 15
Download to read offline
BGP Optimization
Proposal
Network Connectivity– High Level
CE R1
4500
Site -1
VLAN-1 10.1.1.0/24
VLAN-2 10.2.2.0/24
VLAN-3 10.3.3.0/24
AS 65200
Remote Site
ISP
CE R2
4500
Site -2
VLAN-1 20.1.1.0/24
VLAN-2 20.2.2.0/24
VLAN-3 20.3.3.0/24
AS 65201
CE R3
4500
Site -3
VLAN-1 30.1.1.0/24
VLAN-2 30.2.2.0/24
VLAN-3 30.3.3.0/24
AS 65208
AS 65000
EBGP
EIGRP
* All AS Numbers and IP Addresses are symbolic
Control Plane – Routing Protocols
• EIGRP – Interior Gateway Routing
– Handles Local Routing Advertisements and
Neighbourship with Regional Routers
– Fully Converged and has the routing updates from
the regional sites
• BGP – Exterior Gateway Routing
– Handles External Routing Advertisements &
Neighbourship with Service Provider
– Unique Private AS’s are configured for the sites.
– Hub and Spoke Design.
• Sites are isolated from External Network.
– Incase of failure on the Link towards Service
Provider.
Control Plane – Routing Concerns
Redistributing BGP learned routes to EIGRP.
!
router eigrp 1
redistribute bgp 65200 metric 10000 100 100 100 100
!
router bgp 65200
no synchronization
bgp log-neighbor-changes
Advertising Local VLAN’s to BGP
network 10.1.1.0 mask 255.255.255.0
network 10.2.2.0 mask 255.255.255.0
network 10.3.3.0 mask 255.255.255.0
neighbor 52.52.52.2 remote-as 65000
no auto-summary
!
Site 1 - CE
Redistributing BGP learned routes to EIGRP.
!
router eigrp 1
redistribute bgp 65201 metric 10000 100 100 100 100
!
router bgp 65201
no synchronization
bgp log-neighbor-changes
Advertising local VLAN’s to BGP
network 20.1.1.0 mask 255.255.255.0
network 20.2.2.0 mask 255.255.255.0
network 20.3.3.0 mask 255.255.255.0
neighbor 53.53.53.2 remote-as 65000
no auto-summary
!
Site 2 - CE
Redistributing BGP learned routes to EIGRP.
!
router eigrp 1
redistribute bgp 65208 metric 10000 100 100 100 100
!
router bgp 65208
no synchronization
bgp log-neighbor-changes
Advertising local VLAN’s to BGP
network 30.1.1.0 mask 255.255.255.0
network 30.2.2.0 mask 255.255.255.0
network 30.3.3.0 mask 255.255.255.0
neighbor 54.54.54.2 remote-as 65000
no auto-summary
!
Site 3 - CE
• Unique AS’s for all sites (Hub and Spoke Design).
• Only Local networks are advertised to BGP.
Current BGP Configurations
* All AS Numbers and IP Addresses are symbolic
Proposed Control Plane Changes - Routing
• EIGRP
– No changes required
• BGP
– Configure all the CE routers to advertise all the
regional Networks to BGP
– AS path Pre-pending
Proposed Control Plane Changes - BGP
• Results
– 2 back-up paths for all the networks.
– Control over advertising networks.
– Indian admin can influence the routing decision
of other AS.
– Optimal routing as possible.
Proposed BGP Configurations – AS paths prepend.
• AS paths prepend.
– The only global BGP metric available to influence
the best path selection is the autonomous system
path length. By varying the length of the
autonomous system path, a BGP speaker can
influence the best path selection by a peer further
away.
Proposed Control Plane Changes – Task List
• Ensure the Reachability of Regional Sites through
EIGRP.
• Configure all the CE routers to advertise all the
regional Networks to BGP.
• Pre-pend respective AS number to respective
network when advertised to the neighbor.
Proposed Control Plane Changes– BGP AS
path prepend list.
• Access list.
– 3 standard access list matching each local site
networks
• Route-map.
– Route map prepends AS number to BGP updates
for networks that are permitted by access list.
• Apply outgoing policy.
– apply the outgoing policy route map for the
application of attributes to specific routes in BGP
peering.
!
router bgp 65200
no synchronization
bgp log-neighbor-changes
!--- The next lines announce all the local sites
!--- networks to BGP peers.
network 10.1.1.0 mask 255.255.255.0
network 10.2.2.0 mask 255.255.255.0
network 10.3.3.0 mask 255.255.255.0
network 20.1.1.0 mask 255.255.255.0
network 20.2.2.0 mask 255.255.255.0
network 20.3.3.0 mask 255.255.255.0
network 30.1.1.0 mask 255.255.255.0
network 30.2.2.0 mask 255.255.255.0
network 30.3.3.0 mask 255.255.255.0
!--- The next line configures eBGP with ISP.
neighbor 52.52.52.2 remote-as 65000
!--- This is the outgoing policy route map for
!--- prepending AS attributes to specific routes.
neighbor 52.52.52.2 route-map INDIA_NETWORKS
out
no auto-summary
!
Site 1 - CE
!
router bgp 65201
no synchronization
bgp log-neighbor-changes
!--- The next lines announce all the local sites
!--- networks to BGP peers.
network 10.1.1.0 mask 255.255.255.0
network 10.2.2.0 mask 255.255.255.0
network 10.3.3.0 mask 255.255.255.0
network 20.1.1.0 mask 255.255.255.0
network 20.2.2.0 mask 255.255.255.0
network 20.3.3.0 mask 255.255.255.0
network 30.1.1.0 mask 255.255.255.0
network 30.2.2.0 mask 255.255.255.0
network 30.3.3.0 mask 255.255.255.0
!--- The next line configures eBGP with ISP.
neighbor 54.54.54.2 remote-as 65000
!--- This is the outgoing policy route map for
!--- prepending AS attributes to specific routes.
neighbor 54.54.54.2 route-map INDIA_NETWORKS
out
no auto-summary
!
Site 2 - CE
!
router bgp 65208
no synchronization
bgp log-neighbor-changes
!--- The next lines announce all the local sites
!--- networks to BGP peers.
network 10.1.1.0 mask 255.255.255.0
network 10.2.2.0 mask 255.255.255.0
network 10.3.3.0 mask 255.255.255.0
network 20.1.1.0 mask 255.255.255.0
network 20.2.2.0 mask 255.255.255.0
network 20.3.3.0 mask 255.255.255.0
network 30.1.1.0 mask 255.255.255.0
network 30.2.2.0 mask 255.255.255.0
network 30.3.3.0 mask 255.255.255.0
!--- The next line configures eBGP with ISP.
neighbor 53.53.53.2 remote-as 65000
!--- This is the outgoing policy route map for
!--- prepending AS attributes to specific routes.
neighbor 53.53.53.2 route-map INDIA_NETWORKS
out
no auto-summary
!
Site 3 - CE
Proposed BGP Configurations – Edge Routers
* All AS Numbers and IP Addresses are symbolic
!--- These set the access lists.
!--- These set the access list for local networks.
ip access-list standard LOCAL
permit 10.1.1.0 0.0.0.255
permit 10.2.2.0 0.0.0.255
permit 10.3.3.0 0.0.0.255
!--- These set the access list for Site 3 site networks.
ip access-list standard Site 3
permit 20.1.1.0 0.0.0.255
permit 20.2.2.0 0.0.0.255
permit 20.3.3.0 0.0.0.255
!--- These set the access list for Site 2 site networks.
ip access-list standard Site 2
permit 30.1.1.0 0.0.0.255
permit 30.2.2.0 0.0.0.255
permit 30.3.3.0 0.0.0.255
!
Site 1 - CE
!--- These set the access lists.
!--- These set the access list for local networks.
ip access-list standard LOCAL
permit 30.1.1.0 0.0.0.255
permit 30.2.2.0 0.0.0.255
permit 30.3.3.0 0.0.0.255
!--- These set the access list for Site 3 site networks.
ip access-list standard Site 3
permit 20.1.1.0 0.0.0.255
permit 20.2.2.0 0.0.0.255
permit 20.3.3.0 0.0.0.255
!--- These set the access list for Site 1 site networks.
ip access-list standard Site 1
permit 10.1.1.0 0.0.0.255
permit 10.2.2.0 0.0.0.255
permit 10.3.3.0 0.0.0.255
!
Site 2 - CE
!--- These set the access lists.
!--- These set the access list for local networks.
ip access-list standard LOCAL
permit 20.1.1.0 0.0.0.255
permit 20.2.2.0 0.0.0.255
permit 20.3.3.0 0.0.0.255
!--- These set the access list for Site 2 site networks.
ip access-list standard Site 2
permit 30.1.1.0 0.0.0.255
permit 30.2.2.0 0.0.0.255
permit 30.3.3.0 0.0.0.255
!--- These set the access list for Site 1 site networks.
ip access-list standard Site 1
permit 10.1.1.0 0.0.0.255
permit 10.2.2.0 0.0.0.255
permit 10.3.3.0 0.0.0.255
!
Site 3 - CE
Proposed BGP Configurations – Edge Routers
* All AS Numbers and IP Addresses are symbolic
!--- These set the route-map.
!--- Here, the route map not prepends AS to BGP
!--- updates for networks that are permitted by
!--- access list LOCAL.
!
route-map INDIA_NETWORKS permit 10
match ip address LOCAL
!
!--- Here, the route map prepends AS 65200 (local) &
!--- 65208 (Site 3 AS) to BGP updates for networks
!--- that are permitted by access list Site 3.
!
route-map INDIA_NETWORKS permit 20
match ip address Site 3
set as-path prepend 65200 65208 !–making least preference
!
!--- Here, the route map prepends AS 65200 (local) &
!--- 65201 (Site 2 AS) to BGP updates for networks
!--- that are permitted by access list Site 2.
!
route-map INDIA_NETWORKS permit 30
match ip address Site 2
set as-path prepend 65200 65201 !–making least preference
!
Site 1 - CE
!--- These set the route-map.
!--- Here, the route map not prepends AS to BGP
!--- updates for networks that are permitted by
!--- access list LOCAL.
!
route-map INDIA_NETWORKS permit 10
match ip address LOCAL
!
!--- Here, the route map prepends AS 65208 (Site 3
!--- AS) to BGP updates for networks that are
!--- permitted by access list Site 3.
!
route-map INDIA_NETWORKS permit 20
match ip address Site 3
set as-path prepend 65208
!
!--- Here, the route map prepends AS 65200 (Site 1 !--
- AS) to BGP updates for networks that are
!--- permitted by access list Site 1.
!
route-map INDIA_NETWORKS permit 30
match ip address Site 1
set as-path prepend 65200
!
Site 2 - CE
!--- These set the route-map.
!--- Here, the route map not prepends AS to BGP
!--- updates for networks that are permitted by
!--- access list LOCAL.
!
route-map INDIA_NETWORKS permit 10
match ip address LOCAL
!
!--- Here, the route map prepends AS 65201 (Site 2
!--- AS) to BGP updates for networks that are
!--- permitted by access list Site 2.
!
route-map INDIA_NETWORKS permit 20
match ip address Site 2
set as-path prepend 65201
!
!--- Here, the route map prepends AS 65208 (local) &
!--- 65200 (Site 1 AS) to BGP updates for networks
!--- that are permitted by access list Site 1.
!
route-map INDIA_NETWORKS permit 30
match ip address Site 1
set as-path prepend 65208 65200 !–making least preference
!
Site 3 - CE
Proposed BGP Configurations – Edge Routers
* All AS Numbers and IP Addresses are symbolic
Remote Site#sh ip bgp
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 0.0.0.0 0 32768 i
*> 10.1.1.0/24 51.51.51.2 0 65000 65200 i
*> 10.2.2.0/24 51.51.51.2 0 65000 65200 i
*> 10.3.3.0/24 51.51.51.2 0 65000 65200 i
*> 20.1.1.0/24 51.51.51.2 0 65000 65208 i
*> 20.2.2.0/24 51.51.51.2 0 65000 65208 i
*> 20.3.3.0/24 51.51.51.2 0 65000 65208 i
*> 30.1.1.0/24 51.51.51.2 0 65000 65201 i
*> 30.2.2.0/24 51.51.51.2 0 65000 65201 i
*> 30.3.3.0/24 51.51.51.2 0 65000 65201 i
Remote Site#
Remote Site#sh ip bgp
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 0.0.0.0 0 32768 i
*> 10.1.1.0/24 51.51.51.2 0 65000 65200 i
*> 10.2.2.0/24 51.51.51.2 0 65000 65200 i
*> 10.3.3.0/24 51.51.51.2 0 65000 65200 i
*> 20.1.1.0/24 51.51.51.2 0 65000 65208 i
*> 20.2.2.0/24 51.51.51.2 0 65000 65208 i
*> 20.3.3.0/24 51.51.51.2 0 65000 65208 i
*> 30.1.1.0/24 51.51.51.2 0 65000 65208 65201 i
*> 30.2.2.0/24 51.51.51.2 0 65000 65208 65201 i
*> 30.3.3.0/24 51.51.51.2 0 65000 65208 65201
Remote Site#
Remote Site#sh ip bgp
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 0.0.0.0 0 32768 i
*> 10.1.1.0/24 51.51.51.2 0 65000 65200 i
*> 10.2.2.0/24 51.51.51.2 0 65000 65200 i
*> 10.3.3.0/24 51.51.51.2 0 65000 65200 i
*> 20.1.1.0/24 51.51.51.2 0 65000 65200 65200 65208 i
*> 20.2.2.0/24 51.51.51.2 0 65000 65200 65200 65208 i
*> 20.3.3.0/24 51.51.51.2 0 65000 65200 65200 65208 i
*> 30.1.1.0/24 51.51.51.2 0 65000 65200 65200 65201 i
*> 30.2.2.0/24 51.51.51.2 0 65000 65200 65200 65201 i
*> 30.3.3.0/24 51.51.51.2 0 65000 65200 65200 65201
Remote Site#
All WAN Links Are UP
Site 2 WAN Link Is DOWN Site 2 & Site 3 WAN Links Are DOWN
Appropriate AS Numbers
Prepended AS Numbers
Prepended AS Numbers
Proposed BGP Configurations – Results
* All AS Numbers and IP Addresses are symbolic
Proposed BGP Configurations – Results
• Results
– 2 back-up paths for all the networks.
• 3 sites are advertising all the local networks to BGP
– Control over advertising networks.
• AS numbers are indicating the original sites and transiting
paths
– Indian admin can influence the routing decision of
other AS.
• Remote sites are depending on our advertising AS attribute
for selecting the best path.
– Optimal routing as possible.

More Related Content

What's hot

Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGPDuane Bodle
 
Chapter 17 : static routing
Chapter 17 : static routingChapter 17 : static routing
Chapter 17 : static routingteknetir
 
Pass4sure 300-101 CCNP Routing And Switching Protocol
Pass4sure 300-101 CCNP Routing And Switching ProtocolPass4sure 300-101 CCNP Routing And Switching Protocol
Pass4sure 300-101 CCNP Routing And Switching Protocolpheaboup
 
Routing Protocol EIGRP
Routing Protocol EIGRPRouting Protocol EIGRP
Routing Protocol EIGRPDmitry Figol
 
Stp. cli command reference, quiz
Stp. cli command reference, quizStp. cli command reference, quiz
Stp. cli command reference, quizSagarR24
 
Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)anilinvns
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bullsSwapnil Kapate
 
OSPF Internal Route Summarization
OSPF Internal Route SummarizationOSPF Internal Route Summarization
OSPF Internal Route SummarizationNetProtocol Xpert
 
ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)anilinvns
 
Configuring dynamic and static routing
Configuring dynamic and static routingConfiguring dynamic and static routing
Configuring dynamic and static routingAnand Dhouni
 
HUAWEI Switch HOW-TO - Configuring link aggregation in static LACP mode
HUAWEI Switch HOW-TO - Configuring link aggregation in static LACP modeHUAWEI Switch HOW-TO - Configuring link aggregation in static LACP mode
HUAWEI Switch HOW-TO - Configuring link aggregation in static LACP modeIPMAX s.r.l.
 

What's hot (20)

Dynamic routing
Dynamic routingDynamic routing
Dynamic routing
 
CCNA part 6 igrp,ospf,eigrp
CCNA part 6 igrp,ospf,eigrpCCNA part 6 igrp,ospf,eigrp
CCNA part 6 igrp,ospf,eigrp
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGP
 
Chapter 17 : static routing
Chapter 17 : static routingChapter 17 : static routing
Chapter 17 : static routing
 
Dynamic Routing RIP
Dynamic Routing RIPDynamic Routing RIP
Dynamic Routing RIP
 
Pass4sure 300-101 CCNP Routing And Switching Protocol
Pass4sure 300-101 CCNP Routing And Switching ProtocolPass4sure 300-101 CCNP Routing And Switching Protocol
Pass4sure 300-101 CCNP Routing And Switching Protocol
 
EIGRP Configuration
EIGRP ConfigurationEIGRP Configuration
EIGRP Configuration
 
Routing Protocol EIGRP
Routing Protocol EIGRPRouting Protocol EIGRP
Routing Protocol EIGRP
 
Static Routing
Static RoutingStatic Routing
Static Routing
 
Stp. cli command reference, quiz
Stp. cli command reference, quizStp. cli command reference, quiz
Stp. cli command reference, quiz
 
Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
Day 3 ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bulls
 
OSPF Internal Route Summarization
OSPF Internal Route SummarizationOSPF Internal Route Summarization
OSPF Internal Route Summarization
 
IP ROUTING
IP ROUTINGIP ROUTING
IP ROUTING
 
07.bgp
07.bgp07.bgp
07.bgp
 
Redistribution into OSPF
Redistribution into OSPFRedistribution into OSPF
Redistribution into OSPF
 
ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
ENHANCED IGRP (EIGRP) AND OPEN SHORTEST PATH FIRST (OSPF)
 
Configuring dynamic and static routing
Configuring dynamic and static routingConfiguring dynamic and static routing
Configuring dynamic and static routing
 
HUAWEI Switch HOW-TO - Configuring link aggregation in static LACP mode
HUAWEI Switch HOW-TO - Configuring link aggregation in static LACP modeHUAWEI Switch HOW-TO - Configuring link aggregation in static LACP mode
HUAWEI Switch HOW-TO - Configuring link aggregation in static LACP mode
 
13. eigrp and ospf
13. eigrp and ospf13. eigrp and ospf
13. eigrp and ospf
 

Similar to Bgp fine tuning

BGP Weight Manipulation with Route Map
BGP Weight Manipulation with Route MapBGP Weight Manipulation with Route Map
BGP Weight Manipulation with Route MapNetProtocol Xpert
 
Ospf Last Modified Eng
Ospf  Last Modified EngOspf  Last Modified Eng
Ospf Last Modified EngAlp isik
 
Ccna 2 chapter 2 v4.0 answers 2011
Ccna 2 chapter 2 v4.0 answers 2011Ccna 2 chapter 2 v4.0 answers 2011
Ccna 2 chapter 2 v4.0 answers 2011Dân Chơi
 
Practice exam #2
Practice exam #2Practice exam #2
Practice exam #2Kris Mofu
 
Implementing Internet and MPLS BGP
Implementing Internet and MPLS BGPImplementing Internet and MPLS BGP
Implementing Internet and MPLS BGPPrivate
 
Cloud Traffic Engineer – Google Espresso Project by Shaowen Ma
Cloud Traffic Engineer – Google Espresso Project  by Shaowen MaCloud Traffic Engineer – Google Espresso Project  by Shaowen Ma
Cloud Traffic Engineer – Google Espresso Project by Shaowen MaMyNOG
 
BÀI TẬP 01.docx
BÀI TẬP 01.docxBÀI TẬP 01.docx
BÀI TẬP 01.docxssuseraf0e77
 
BÀI TẬP 01.docx
BÀI TẬP 01.docxBÀI TẬP 01.docx
BÀI TẬP 01.docxssuseraf0e77
 
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issuesAuguste Behe
 
Ch5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docxCh5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docxcravennichole326
 
OSPF Summary LSA (Type 3 LSA)
OSPF Summary LSA (Type 3 LSA)OSPF Summary LSA (Type 3 LSA)
OSPF Summary LSA (Type 3 LSA)NetProtocol Xpert
 

Similar to Bgp fine tuning (20)

Bgp Basic Labs
Bgp Basic LabsBgp Basic Labs
Bgp Basic Labs
 
BGP Weight Manipulation with Route Map
BGP Weight Manipulation with Route MapBGP Weight Manipulation with Route Map
BGP Weight Manipulation with Route Map
 
Ospf Last Modified Eng
Ospf  Last Modified EngOspf  Last Modified Eng
Ospf Last Modified Eng
 
Ccna 2 chapter 2 v4.0 answers 2011
Ccna 2 chapter 2 v4.0 answers 2011Ccna 2 chapter 2 v4.0 answers 2011
Ccna 2 chapter 2 v4.0 answers 2011
 
bgp.ppt
bgp.pptbgp.ppt
bgp.ppt
 
Practice exam #2
Practice exam #2Practice exam #2
Practice exam #2
 
Implementing Internet and MPLS BGP
Implementing Internet and MPLS BGPImplementing Internet and MPLS BGP
Implementing Internet and MPLS BGP
 
Cloud Traffic Engineer – Google Espresso Project by Shaowen Ma
Cloud Traffic Engineer – Google Espresso Project  by Shaowen MaCloud Traffic Engineer – Google Espresso Project  by Shaowen Ma
Cloud Traffic Engineer – Google Espresso Project by Shaowen Ma
 
BÀI TẬP 01.docx
BÀI TẬP 01.docxBÀI TẬP 01.docx
BÀI TẬP 01.docx
 
BÀI TẬP 01.docx
BÀI TẬP 01.docxBÀI TẬP 01.docx
BÀI TẬP 01.docx
 
Bgp 6 advanced transit as issues
Bgp 6   advanced transit as issuesBgp 6   advanced transit as issues
Bgp 6 advanced transit as issues
 
Bgp (1)
Bgp (1)Bgp (1)
Bgp (1)
 
Class 7
Class 7Class 7
Class 7
 
OSPF v3
OSPF v3OSPF v3
OSPF v3
 
Routing
RoutingRouting
Routing
 
Ch5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docxCh5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docx
 
BGP Loop Prevention
BGP Loop Prevention BGP Loop Prevention
BGP Loop Prevention
 
OSPF 3
OSPF 3OSPF 3
OSPF 3
 
OSPF 3
OSPF 3OSPF 3
OSPF 3
 
OSPF Summary LSA (Type 3 LSA)
OSPF Summary LSA (Type 3 LSA)OSPF Summary LSA (Type 3 LSA)
OSPF Summary LSA (Type 3 LSA)
 

Recently uploaded

AI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsAI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsMemoori
 
08448380779 Call Girls In Diplomatic Enclave Women Seeking Men
08448380779 Call Girls In Diplomatic Enclave Women Seeking Men08448380779 Call Girls In Diplomatic Enclave Women Seeking Men
08448380779 Call Girls In Diplomatic Enclave Women Seeking MenDelhi Call girls
 
Maximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptxMaximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptxOnBoard
 
Slack Application Development 101 Slides
Slack Application Development 101 SlidesSlack Application Development 101 Slides
Slack Application Development 101 Slidespraypatel2
 
GenCyber Cyber Security Day Presentation
GenCyber Cyber Security Day PresentationGenCyber Cyber Security Day Presentation
GenCyber Cyber Security Day PresentationMichael W. Hawkins
 
The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024Rafal Los
 
Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Allon Mureinik
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking MenDelhi Call girls
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsMaria Levchenko
 
How to Remove Document Management Hurdles with X-Docs?
How to Remove Document Management Hurdles with X-Docs?How to Remove Document Management Hurdles with X-Docs?
How to Remove Document Management Hurdles with X-Docs?XfilesPro
 
08448380779 Call Girls In Civil Lines Women Seeking Men
08448380779 Call Girls In Civil Lines Women Seeking Men08448380779 Call Girls In Civil Lines Women Seeking Men
08448380779 Call Girls In Civil Lines Women Seeking MenDelhi Call girls
 
Install Stable Diffusion in windows machine
Install Stable Diffusion in windows machineInstall Stable Diffusion in windows machine
Install Stable Diffusion in windows machinePadma Pradeep
 
[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdf[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdfhans926745
 
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticsKotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticscarlostorres15106
 
Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...
Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...
Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...HostedbyConfluent
 
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 3652toLead Limited
 
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024BookNet Canada
 
Salesforce Community Group Quito, Salesforce 101
Salesforce Community Group Quito, Salesforce 101Salesforce Community Group Quito, Salesforce 101
Salesforce Community Group Quito, Salesforce 101Paola De la Torre
 
Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...Alan Dix
 
Pigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food ManufacturingPigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food ManufacturingPigging Solutions
 

Recently uploaded (20)

AI as an Interface for Commercial Buildings
AI as an Interface for Commercial BuildingsAI as an Interface for Commercial Buildings
AI as an Interface for Commercial Buildings
 
08448380779 Call Girls In Diplomatic Enclave Women Seeking Men
08448380779 Call Girls In Diplomatic Enclave Women Seeking Men08448380779 Call Girls In Diplomatic Enclave Women Seeking Men
08448380779 Call Girls In Diplomatic Enclave Women Seeking Men
 
Maximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptxMaximizing Board Effectiveness 2024 Webinar.pptx
Maximizing Board Effectiveness 2024 Webinar.pptx
 
Slack Application Development 101 Slides
Slack Application Development 101 SlidesSlack Application Development 101 Slides
Slack Application Development 101 Slides
 
GenCyber Cyber Security Day Presentation
GenCyber Cyber Security Day PresentationGenCyber Cyber Security Day Presentation
GenCyber Cyber Security Day Presentation
 
The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024The 7 Things I Know About Cyber Security After 25 Years | April 2024
The 7 Things I Know About Cyber Security After 25 Years | April 2024
 
Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)Injustice - Developers Among Us (SciFiDevCon 2024)
Injustice - Developers Among Us (SciFiDevCon 2024)
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed texts
 
How to Remove Document Management Hurdles with X-Docs?
How to Remove Document Management Hurdles with X-Docs?How to Remove Document Management Hurdles with X-Docs?
How to Remove Document Management Hurdles with X-Docs?
 
08448380779 Call Girls In Civil Lines Women Seeking Men
08448380779 Call Girls In Civil Lines Women Seeking Men08448380779 Call Girls In Civil Lines Women Seeking Men
08448380779 Call Girls In Civil Lines Women Seeking Men
 
Install Stable Diffusion in windows machine
Install Stable Diffusion in windows machineInstall Stable Diffusion in windows machine
Install Stable Diffusion in windows machine
 
[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdf[2024]Digital Global Overview Report 2024 Meltwater.pdf
[2024]Digital Global Overview Report 2024 Meltwater.pdf
 
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmaticsKotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
Kotlin Multiplatform & Compose Multiplatform - Starter kit for pragmatics
 
Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...
Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...
Transforming Data Streams with Kafka Connect: An Introduction to Single Messa...
 
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
Tech-Forward - Achieving Business Readiness For Copilot in Microsoft 365
 
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
#StandardsGoals for 2024: What’s new for BISAC - Tech Forum 2024
 
Salesforce Community Group Quito, Salesforce 101
Salesforce Community Group Quito, Salesforce 101Salesforce Community Group Quito, Salesforce 101
Salesforce Community Group Quito, Salesforce 101
 
Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...Swan(sea) Song – personal research during my six years at Swansea ... and bey...
Swan(sea) Song – personal research during my six years at Swansea ... and bey...
 
Pigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food ManufacturingPigging Solutions in Pet Food Manufacturing
Pigging Solutions in Pet Food Manufacturing
 

Bgp fine tuning

  • 2. Network Connectivity– High Level CE R1 4500 Site -1 VLAN-1 10.1.1.0/24 VLAN-2 10.2.2.0/24 VLAN-3 10.3.3.0/24 AS 65200 Remote Site ISP CE R2 4500 Site -2 VLAN-1 20.1.1.0/24 VLAN-2 20.2.2.0/24 VLAN-3 20.3.3.0/24 AS 65201 CE R3 4500 Site -3 VLAN-1 30.1.1.0/24 VLAN-2 30.2.2.0/24 VLAN-3 30.3.3.0/24 AS 65208 AS 65000 EBGP EIGRP * All AS Numbers and IP Addresses are symbolic
  • 3. Control Plane – Routing Protocols • EIGRP – Interior Gateway Routing – Handles Local Routing Advertisements and Neighbourship with Regional Routers – Fully Converged and has the routing updates from the regional sites • BGP – Exterior Gateway Routing – Handles External Routing Advertisements & Neighbourship with Service Provider – Unique Private AS’s are configured for the sites. – Hub and Spoke Design.
  • 4. • Sites are isolated from External Network. – Incase of failure on the Link towards Service Provider. Control Plane – Routing Concerns
  • 5. Redistributing BGP learned routes to EIGRP. ! router eigrp 1 redistribute bgp 65200 metric 10000 100 100 100 100 ! router bgp 65200 no synchronization bgp log-neighbor-changes Advertising Local VLAN’s to BGP network 10.1.1.0 mask 255.255.255.0 network 10.2.2.0 mask 255.255.255.0 network 10.3.3.0 mask 255.255.255.0 neighbor 52.52.52.2 remote-as 65000 no auto-summary ! Site 1 - CE Redistributing BGP learned routes to EIGRP. ! router eigrp 1 redistribute bgp 65201 metric 10000 100 100 100 100 ! router bgp 65201 no synchronization bgp log-neighbor-changes Advertising local VLAN’s to BGP network 20.1.1.0 mask 255.255.255.0 network 20.2.2.0 mask 255.255.255.0 network 20.3.3.0 mask 255.255.255.0 neighbor 53.53.53.2 remote-as 65000 no auto-summary ! Site 2 - CE Redistributing BGP learned routes to EIGRP. ! router eigrp 1 redistribute bgp 65208 metric 10000 100 100 100 100 ! router bgp 65208 no synchronization bgp log-neighbor-changes Advertising local VLAN’s to BGP network 30.1.1.0 mask 255.255.255.0 network 30.2.2.0 mask 255.255.255.0 network 30.3.3.0 mask 255.255.255.0 neighbor 54.54.54.2 remote-as 65000 no auto-summary ! Site 3 - CE • Unique AS’s for all sites (Hub and Spoke Design). • Only Local networks are advertised to BGP. Current BGP Configurations * All AS Numbers and IP Addresses are symbolic
  • 6. Proposed Control Plane Changes - Routing • EIGRP – No changes required • BGP – Configure all the CE routers to advertise all the regional Networks to BGP – AS path Pre-pending
  • 7. Proposed Control Plane Changes - BGP • Results – 2 back-up paths for all the networks. – Control over advertising networks. – Indian admin can influence the routing decision of other AS. – Optimal routing as possible.
  • 8. Proposed BGP Configurations – AS paths prepend. • AS paths prepend. – The only global BGP metric available to influence the best path selection is the autonomous system path length. By varying the length of the autonomous system path, a BGP speaker can influence the best path selection by a peer further away.
  • 9. Proposed Control Plane Changes – Task List • Ensure the Reachability of Regional Sites through EIGRP. • Configure all the CE routers to advertise all the regional Networks to BGP. • Pre-pend respective AS number to respective network when advertised to the neighbor.
  • 10. Proposed Control Plane Changes– BGP AS path prepend list. • Access list. – 3 standard access list matching each local site networks • Route-map. – Route map prepends AS number to BGP updates for networks that are permitted by access list. • Apply outgoing policy. – apply the outgoing policy route map for the application of attributes to specific routes in BGP peering.
  • 11. ! router bgp 65200 no synchronization bgp log-neighbor-changes !--- The next lines announce all the local sites !--- networks to BGP peers. network 10.1.1.0 mask 255.255.255.0 network 10.2.2.0 mask 255.255.255.0 network 10.3.3.0 mask 255.255.255.0 network 20.1.1.0 mask 255.255.255.0 network 20.2.2.0 mask 255.255.255.0 network 20.3.3.0 mask 255.255.255.0 network 30.1.1.0 mask 255.255.255.0 network 30.2.2.0 mask 255.255.255.0 network 30.3.3.0 mask 255.255.255.0 !--- The next line configures eBGP with ISP. neighbor 52.52.52.2 remote-as 65000 !--- This is the outgoing policy route map for !--- prepending AS attributes to specific routes. neighbor 52.52.52.2 route-map INDIA_NETWORKS out no auto-summary ! Site 1 - CE ! router bgp 65201 no synchronization bgp log-neighbor-changes !--- The next lines announce all the local sites !--- networks to BGP peers. network 10.1.1.0 mask 255.255.255.0 network 10.2.2.0 mask 255.255.255.0 network 10.3.3.0 mask 255.255.255.0 network 20.1.1.0 mask 255.255.255.0 network 20.2.2.0 mask 255.255.255.0 network 20.3.3.0 mask 255.255.255.0 network 30.1.1.0 mask 255.255.255.0 network 30.2.2.0 mask 255.255.255.0 network 30.3.3.0 mask 255.255.255.0 !--- The next line configures eBGP with ISP. neighbor 54.54.54.2 remote-as 65000 !--- This is the outgoing policy route map for !--- prepending AS attributes to specific routes. neighbor 54.54.54.2 route-map INDIA_NETWORKS out no auto-summary ! Site 2 - CE ! router bgp 65208 no synchronization bgp log-neighbor-changes !--- The next lines announce all the local sites !--- networks to BGP peers. network 10.1.1.0 mask 255.255.255.0 network 10.2.2.0 mask 255.255.255.0 network 10.3.3.0 mask 255.255.255.0 network 20.1.1.0 mask 255.255.255.0 network 20.2.2.0 mask 255.255.255.0 network 20.3.3.0 mask 255.255.255.0 network 30.1.1.0 mask 255.255.255.0 network 30.2.2.0 mask 255.255.255.0 network 30.3.3.0 mask 255.255.255.0 !--- The next line configures eBGP with ISP. neighbor 53.53.53.2 remote-as 65000 !--- This is the outgoing policy route map for !--- prepending AS attributes to specific routes. neighbor 53.53.53.2 route-map INDIA_NETWORKS out no auto-summary ! Site 3 - CE Proposed BGP Configurations – Edge Routers * All AS Numbers and IP Addresses are symbolic
  • 12. !--- These set the access lists. !--- These set the access list for local networks. ip access-list standard LOCAL permit 10.1.1.0 0.0.0.255 permit 10.2.2.0 0.0.0.255 permit 10.3.3.0 0.0.0.255 !--- These set the access list for Site 3 site networks. ip access-list standard Site 3 permit 20.1.1.0 0.0.0.255 permit 20.2.2.0 0.0.0.255 permit 20.3.3.0 0.0.0.255 !--- These set the access list for Site 2 site networks. ip access-list standard Site 2 permit 30.1.1.0 0.0.0.255 permit 30.2.2.0 0.0.0.255 permit 30.3.3.0 0.0.0.255 ! Site 1 - CE !--- These set the access lists. !--- These set the access list for local networks. ip access-list standard LOCAL permit 30.1.1.0 0.0.0.255 permit 30.2.2.0 0.0.0.255 permit 30.3.3.0 0.0.0.255 !--- These set the access list for Site 3 site networks. ip access-list standard Site 3 permit 20.1.1.0 0.0.0.255 permit 20.2.2.0 0.0.0.255 permit 20.3.3.0 0.0.0.255 !--- These set the access list for Site 1 site networks. ip access-list standard Site 1 permit 10.1.1.0 0.0.0.255 permit 10.2.2.0 0.0.0.255 permit 10.3.3.0 0.0.0.255 ! Site 2 - CE !--- These set the access lists. !--- These set the access list for local networks. ip access-list standard LOCAL permit 20.1.1.0 0.0.0.255 permit 20.2.2.0 0.0.0.255 permit 20.3.3.0 0.0.0.255 !--- These set the access list for Site 2 site networks. ip access-list standard Site 2 permit 30.1.1.0 0.0.0.255 permit 30.2.2.0 0.0.0.255 permit 30.3.3.0 0.0.0.255 !--- These set the access list for Site 1 site networks. ip access-list standard Site 1 permit 10.1.1.0 0.0.0.255 permit 10.2.2.0 0.0.0.255 permit 10.3.3.0 0.0.0.255 ! Site 3 - CE Proposed BGP Configurations – Edge Routers * All AS Numbers and IP Addresses are symbolic
  • 13. !--- These set the route-map. !--- Here, the route map not prepends AS to BGP !--- updates for networks that are permitted by !--- access list LOCAL. ! route-map INDIA_NETWORKS permit 10 match ip address LOCAL ! !--- Here, the route map prepends AS 65200 (local) & !--- 65208 (Site 3 AS) to BGP updates for networks !--- that are permitted by access list Site 3. ! route-map INDIA_NETWORKS permit 20 match ip address Site 3 set as-path prepend 65200 65208 !–making least preference ! !--- Here, the route map prepends AS 65200 (local) & !--- 65201 (Site 2 AS) to BGP updates for networks !--- that are permitted by access list Site 2. ! route-map INDIA_NETWORKS permit 30 match ip address Site 2 set as-path prepend 65200 65201 !–making least preference ! Site 1 - CE !--- These set the route-map. !--- Here, the route map not prepends AS to BGP !--- updates for networks that are permitted by !--- access list LOCAL. ! route-map INDIA_NETWORKS permit 10 match ip address LOCAL ! !--- Here, the route map prepends AS 65208 (Site 3 !--- AS) to BGP updates for networks that are !--- permitted by access list Site 3. ! route-map INDIA_NETWORKS permit 20 match ip address Site 3 set as-path prepend 65208 ! !--- Here, the route map prepends AS 65200 (Site 1 !-- - AS) to BGP updates for networks that are !--- permitted by access list Site 1. ! route-map INDIA_NETWORKS permit 30 match ip address Site 1 set as-path prepend 65200 ! Site 2 - CE !--- These set the route-map. !--- Here, the route map not prepends AS to BGP !--- updates for networks that are permitted by !--- access list LOCAL. ! route-map INDIA_NETWORKS permit 10 match ip address LOCAL ! !--- Here, the route map prepends AS 65201 (Site 2 !--- AS) to BGP updates for networks that are !--- permitted by access list Site 2. ! route-map INDIA_NETWORKS permit 20 match ip address Site 2 set as-path prepend 65201 ! !--- Here, the route map prepends AS 65208 (local) & !--- 65200 (Site 1 AS) to BGP updates for networks !--- that are permitted by access list Site 1. ! route-map INDIA_NETWORKS permit 30 match ip address Site 1 set as-path prepend 65208 65200 !–making least preference ! Site 3 - CE Proposed BGP Configurations – Edge Routers * All AS Numbers and IP Addresses are symbolic
  • 14. Remote Site#sh ip bgp Network Next Hop Metric LocPrf Weight Path *> 1.1.1.0/24 0.0.0.0 0 32768 i *> 10.1.1.0/24 51.51.51.2 0 65000 65200 i *> 10.2.2.0/24 51.51.51.2 0 65000 65200 i *> 10.3.3.0/24 51.51.51.2 0 65000 65200 i *> 20.1.1.0/24 51.51.51.2 0 65000 65208 i *> 20.2.2.0/24 51.51.51.2 0 65000 65208 i *> 20.3.3.0/24 51.51.51.2 0 65000 65208 i *> 30.1.1.0/24 51.51.51.2 0 65000 65201 i *> 30.2.2.0/24 51.51.51.2 0 65000 65201 i *> 30.3.3.0/24 51.51.51.2 0 65000 65201 i Remote Site# Remote Site#sh ip bgp Network Next Hop Metric LocPrf Weight Path *> 1.1.1.0/24 0.0.0.0 0 32768 i *> 10.1.1.0/24 51.51.51.2 0 65000 65200 i *> 10.2.2.0/24 51.51.51.2 0 65000 65200 i *> 10.3.3.0/24 51.51.51.2 0 65000 65200 i *> 20.1.1.0/24 51.51.51.2 0 65000 65208 i *> 20.2.2.0/24 51.51.51.2 0 65000 65208 i *> 20.3.3.0/24 51.51.51.2 0 65000 65208 i *> 30.1.1.0/24 51.51.51.2 0 65000 65208 65201 i *> 30.2.2.0/24 51.51.51.2 0 65000 65208 65201 i *> 30.3.3.0/24 51.51.51.2 0 65000 65208 65201 Remote Site# Remote Site#sh ip bgp Network Next Hop Metric LocPrf Weight Path *> 1.1.1.0/24 0.0.0.0 0 32768 i *> 10.1.1.0/24 51.51.51.2 0 65000 65200 i *> 10.2.2.0/24 51.51.51.2 0 65000 65200 i *> 10.3.3.0/24 51.51.51.2 0 65000 65200 i *> 20.1.1.0/24 51.51.51.2 0 65000 65200 65200 65208 i *> 20.2.2.0/24 51.51.51.2 0 65000 65200 65200 65208 i *> 20.3.3.0/24 51.51.51.2 0 65000 65200 65200 65208 i *> 30.1.1.0/24 51.51.51.2 0 65000 65200 65200 65201 i *> 30.2.2.0/24 51.51.51.2 0 65000 65200 65200 65201 i *> 30.3.3.0/24 51.51.51.2 0 65000 65200 65200 65201 Remote Site# All WAN Links Are UP Site 2 WAN Link Is DOWN Site 2 & Site 3 WAN Links Are DOWN Appropriate AS Numbers Prepended AS Numbers Prepended AS Numbers Proposed BGP Configurations – Results * All AS Numbers and IP Addresses are symbolic
  • 15. Proposed BGP Configurations – Results • Results – 2 back-up paths for all the networks. • 3 sites are advertising all the local networks to BGP – Control over advertising networks. • AS numbers are indicating the original sites and transiting paths – Indian admin can influence the routing decision of other AS. • Remote sites are depending on our advertising AS attribute for selecting the best path. – Optimal routing as possible.