SlideShare a Scribd company logo
1 of 7
Configuring a Cisco Router as a PPPoE Client for DSL connectivity
PPPoE: Point-to-Point Protocol over Ethernet. The PPP over Ethernet Client feature
provides PPP over Ethernet (PPPoE) Client support on routers on customer premises.
Configuring a Cisco routers as a PPPoE client for DSL connectivity, there are two cases,
one for the Ethernet interfaces, and another for the ATM interfaces
A. PPPoE on Ethernet interfaces—PPPoE functionality is configured on a CPE
router with two Ethernet interfaces. One Ethernet interface is subscriber-facing,
the other provider facing.
B. PPPoE on ATM interfaces—PPPoE functionality is configured on a CPE router
with one Ethernet interface and one ATM interface. The Ethernet interface is
subscriber-facing whereas the ATM interface is provider-facing.
Note: I noticed that on some books no one mentioned the configuration of IP domain
lookup command and ISP DNS options in DHCP server configuration. Without these
DSL connection will not work. Also pay attention if DSL connection did not work, to check
the state of all interfaces by using show ip interface brief and make sure to issue no
shutdown command on all of them.
A. PPPoE on Ethernet interfaces
DSL configuration brief steps:
1. Internal Ethernet interface configuration
2. External Ethernet interface configuration
3. Dialer interface configuration
4. Configuring Access List
5. NAT/PAT configuration
6. Configuring IP domain Lookup
7. DHCP server services configuration
8. Static default route configuration
DSL configuration detailed steps:
1. Internal Ethernet interface configuration
interface FastEthernet 0/1
description internal interface
ip address 172.16.1.1 255.255.255.0
1
ip nat inside
no shut
OR (incase you are using Cisco 877 router)
interface Vlan1
description internal interface
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
2. External Ethernet interface configuration
Interface FastEthernet 0/0
Description DSL interface
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no shut
3. Dialer interface configuration
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username USERNAME password P@ssw0rd (this is the password that
ISP gave it to you
ppp chap hostname HOSTNAME (This is the username that ISP gave it to you)
ppp chap password P@ssw0rd
no shut
4. Configuring Access List
ip access-list extended DSL_ACCESSLIST
100 permit ip 10.10.10.0 0.0.0.255 any
5. Configuring NAT/PAT
ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload
2
6. Configuring IP domain Lookup
ip domain lookup
ip name-server Primary DNS IP address (obtained from your ISP)
ip name-server Secondary DNS IP address (obtained from your ISP)
7. DHCP server services configuration
ip dhcp pool DSL_DHCP
network 10.10.10.0 /29
dns-server Primary DNS IP address Secondary DNS IP address (obtained from your
ISP)
default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address)
import all
8. Static default route configuration
Finally, configure a static default route. It should point to the dialer interface rather
than an IP address as in the below example.
ip route 0.0.0.0 0.0.0.0 dialer 1
B. PPPoE on ATM interfaces
DSL configuration brief steps:
1. Internal Ethernet interface configuration
2. External ATM interface configuration (in case you are using Cisco 877 Router)
3. Dialer interface configuration
4. Configuring Access List
5. NAT/PAT configuration
6. Configuring IP domain Lookup
7. DHCP server services configuration
8. Static default route configuration
DSL configuration detailed steps:
1. Internal VLAN interface configuration (using Cisco 877 Router)
interface Vlan1
description internal interface
3
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
OR (if you are using configurable internal Ethernet interface)
interface FastEthernet 0/1
description internal interface
ip address 172.16.1.1 255.255.255.0
ip nat inside
no shut
2. External ATM interface configuration
interface ATM 0
description DSL interface
ip directed-broadcast
ip mask-reply
ip route-cache flow
no ip address
dsl operating-mode auto
pvc 8/35
no shutdown
pppoe-client dial-pool-number 1
3. Dialer interface configuration
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username USERNAME password P@ssw0rd (this is the password that
ISP gave it to you
ppp chap hostname HOSTNAME (This is the username that ISP gave it to you)
ppp chap password P@ssw0rd
no shut
4. Configuring Access List
ip access-list extended DSL_ACCESSLIST
4
100 permit ip 10.10.10.0 0.0.0.255 any
5. Configuring NAT/PAT
ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload
6. Configuring IP domain Lookup
ip domain lookup
ip name-server Primary DNS IP address (obtained from your ISP)
ip name-server Secondary DNS IP address (obtained from your ISP)
7. DHCP server services configuration
ip dhcp pool DSL_DHCP
network 10.10.10.0 /29
dns-server Primary DNS IP address Secondary DNS IP address (obtained from your
ISP)
default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address)
import all
8. Static default route configuration
Finally, configure a static default route. It should point to the dialer interface rather
than an IP address as in the below example.
ip route 0.0.0.0 0.0.0.0 dialer 1
More related:
Cisco Router 1941 Commands
How to recover Cisco 1921 router default password?
Cisco 2911 SNMP not working
How To Recover Cisco Router Password
The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900
More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog
3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale
original new Cisco networking equipments, including Cisco Catalyst switches, Cisco
5
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
6
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
6

More Related Content

What's hot

Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...
Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...
Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...
Manassé Achim kpaya
 

What's hot (20)

Soal Modul A Linux Environment LKS SMK NTB 2018
Soal Modul A Linux Environment LKS SMK NTB 2018Soal Modul A Linux Environment LKS SMK NTB 2018
Soal Modul A Linux Environment LKS SMK NTB 2018
 
Hpe Intelligent Management Center
Hpe Intelligent Management CenterHpe Intelligent Management Center
Hpe Intelligent Management Center
 
DHCP Snooping
DHCP SnoopingDHCP Snooping
DHCP Snooping
 
HSRP ccna
HSRP ccna HSRP ccna
HSRP ccna
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
HOTSPOT on MikroTik Router
HOTSPOT on MikroTik RouterHOTSPOT on MikroTik Router
HOTSPOT on MikroTik Router
 
Iptables in linux
Iptables in linuxIptables in linux
Iptables in linux
 
Pfsense
PfsensePfsense
Pfsense
 
Monitoramento de Vulnerabilidades com Zabbix, RHEL e Yum Security Plugin
Monitoramento de Vulnerabilidades com Zabbix, RHEL e Yum Security PluginMonitoramento de Vulnerabilidades com Zabbix, RHEL e Yum Security Plugin
Monitoramento de Vulnerabilidades com Zabbix, RHEL e Yum Security Plugin
 
Rapport installation round cube centos 7
Rapport installation round cube centos 7Rapport installation round cube centos 7
Rapport installation round cube centos 7
 
DHCP Protocol
DHCP ProtocolDHCP Protocol
DHCP Protocol
 
Basics of firewall, ebtables, arptables and iptables
Basics of firewall, ebtables, arptables and iptablesBasics of firewall, ebtables, arptables and iptables
Basics of firewall, ebtables, arptables and iptables
 
2011 cisco icons 6_8_11
2011 cisco icons 6_8_112011 cisco icons 6_8_11
2011 cisco icons 6_8_11
 
Soal Linux Actual - ITNSA LKS SMK Tingkat Provinsi NTB 2021
Soal Linux Actual - ITNSA LKS SMK Tingkat Provinsi NTB 2021Soal Linux Actual - ITNSA LKS SMK Tingkat Provinsi NTB 2021
Soal Linux Actual - ITNSA LKS SMK Tingkat Provinsi NTB 2021
 
Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...
Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...
Mise en place d'un système de messagerie sous debian avec: postfix, dovecot, ...
 
Rapport sécurité
Rapport sécuritéRapport sécurité
Rapport sécurité
 
Configuration DHCP
Configuration DHCPConfiguration DHCP
Configuration DHCP
 
CCNA
CCNACCNA
CCNA
 
SITE TO SITE IPSEC VPN TUNNEL B/W CISCO ROUTERS
SITE TO SITE IPSEC VPN TUNNEL B/W CISCO ROUTERSSITE TO SITE IPSEC VPN TUNNEL B/W CISCO ROUTERS
SITE TO SITE IPSEC VPN TUNNEL B/W CISCO ROUTERS
 
4 protocole de redondance(hsrp-vrrp-glbp)
4 protocole de redondance(hsrp-vrrp-glbp)4 protocole de redondance(hsrp-vrrp-glbp)
4 protocole de redondance(hsrp-vrrp-glbp)
 

Viewers also liked (7)

Pppoe,pppoa
Pppoe,pppoaPppoe,pppoa
Pppoe,pppoa
 
CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06   configuração básica de roteadores ciscoCCNA 4.1 - Capítulo 06   configuração básica de roteadores cisco
CCNA 4.1 - Capítulo 06 configuração básica de roteadores cisco
 
Subnetting and routing
Subnetting and routingSubnetting and routing
Subnetting and routing
 
Network switches, functions & role in networks
Network switches, functions & role in networksNetwork switches, functions & role in networks
Network switches, functions & role in networks
 
Http Vs Https .
Http Vs Https . Http Vs Https .
Http Vs Https .
 
Dhcp ppt
Dhcp pptDhcp ppt
Dhcp ppt
 
Internet control message protocol
Internet control message protocolInternet control message protocol
Internet control message protocol
 

Similar to Configuring a Cisco Router as a PPPoE Client for DSL Connectivity

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
robertoxe
 
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxCCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
keturahhazelhurst
 
CCNA Network Services
CCNA Network ServicesCCNA Network Services
CCNA Network Services
Dsunte Wilson
 
KPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalKPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_final
Fisal Anwari
 

Similar to Configuring a Cisco Router as a PPPoE Client for DSL Connectivity (20)

Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
scg basic
scg basicscg basic
scg basic
 
Nat 03
Nat 03Nat 03
Nat 03
 
Nat 07
Nat 07Nat 07
Nat 07
 
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docxCCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
CCNA Connecting NetworksSA ExamLab 13 CCNA Connecting Netwo.docx
 
Day 17.1 nat pat
Day 17.1 nat pat Day 17.1 nat pat
Day 17.1 nat pat
 
Chapter 15 : routing concepts
Chapter 15 : routing conceptsChapter 15 : routing concepts
Chapter 15 : routing concepts
 
CCNA Network Services
CCNA Network ServicesCCNA Network Services
CCNA Network Services
 
CCNA Icnd110 s05l04
CCNA Icnd110 s05l04CCNA Icnd110 s05l04
CCNA Icnd110 s05l04
 
CCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing ConceptsCCNAv5 - S2: Chapter4 Routing Concepts
CCNAv5 - S2: Chapter4 Routing Concepts
 
KPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_finalKPUCC-Rs instructor ppt_chapter4_final
KPUCC-Rs instructor ppt_chapter4_final
 
Chapter 04 - Routing Concepts
Chapter 04 - Routing ConceptsChapter 04 - Routing Concepts
Chapter 04 - Routing Concepts
 
How to configure static nat on cisco routers
How to configure static nat on cisco routersHow to configure static nat on cisco routers
How to configure static nat on cisco routers
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4CCNA 2 Routing and Switching v5.0 Chapter 4
CCNA 2 Routing and Switching v5.0 Chapter 4
 
N at
N atN at
N at
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
520scg basic
520scg basic520scg basic
520scg basic
 

More from 3Anetwork com

Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series
3Anetwork com
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet
3Anetwork com
 

More from 3Anetwork com (20)

Cisco sfp modules
Cisco sfp modulesCisco sfp modules
Cisco sfp modules
 
Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview
 

Recently uploaded

Russian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girls
Russian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girlsRussian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girls
Russian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girls
Monica Sydney
 
一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样
一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样
一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样
ayvbos
 
Abu Dhabi Escorts Service 0508644382 Escorts in Abu Dhabi
Abu Dhabi Escorts Service 0508644382 Escorts in Abu DhabiAbu Dhabi Escorts Service 0508644382 Escorts in Abu Dhabi
Abu Dhabi Escorts Service 0508644382 Escorts in Abu Dhabi
Monica Sydney
 
一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制
一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制
一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制
pxcywzqs
 
pdfcoffee.com_business-ethics-q3m7-pdf-free.pdf
pdfcoffee.com_business-ethics-q3m7-pdf-free.pdfpdfcoffee.com_business-ethics-q3m7-pdf-free.pdf
pdfcoffee.com_business-ethics-q3m7-pdf-free.pdf
JOHNBEBONYAP1
 
Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...
Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...
Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...
gajnagarg
 
一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样
一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样
一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样
ayvbos
 

Recently uploaded (20)

Mira Road Housewife Call Girls 07506202331, Nalasopara Call Girls
Mira Road Housewife Call Girls 07506202331, Nalasopara Call GirlsMira Road Housewife Call Girls 07506202331, Nalasopara Call Girls
Mira Road Housewife Call Girls 07506202331, Nalasopara Call Girls
 
Story Board.pptxrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr
Story Board.pptxrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrStory Board.pptxrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr
Story Board.pptxrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr
 
Russian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girls
Russian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girlsRussian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girls
Russian Call girls in Abu Dhabi 0508644382 Abu Dhabi Call girls
 
一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样
一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样
一比一原版(Flinders毕业证书)弗林德斯大学毕业证原件一模一样
 
Abu Dhabi Escorts Service 0508644382 Escorts in Abu Dhabi
Abu Dhabi Escorts Service 0508644382 Escorts in Abu DhabiAbu Dhabi Escorts Service 0508644382 Escorts in Abu Dhabi
Abu Dhabi Escorts Service 0508644382 Escorts in Abu Dhabi
 
一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制
一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制
一比一原版(Offer)康考迪亚大学毕业证学位证靠谱定制
 
20240508 QFM014 Elixir Reading List April 2024.pdf
20240508 QFM014 Elixir Reading List April 2024.pdf20240508 QFM014 Elixir Reading List April 2024.pdf
20240508 QFM014 Elixir Reading List April 2024.pdf
 
pdfcoffee.com_business-ethics-q3m7-pdf-free.pdf
pdfcoffee.com_business-ethics-q3m7-pdf-free.pdfpdfcoffee.com_business-ethics-q3m7-pdf-free.pdf
pdfcoffee.com_business-ethics-q3m7-pdf-free.pdf
 
Nagercoil Escorts Service Girl ^ 9332606886, WhatsApp Anytime Nagercoil
Nagercoil Escorts Service Girl ^ 9332606886, WhatsApp Anytime NagercoilNagercoil Escorts Service Girl ^ 9332606886, WhatsApp Anytime Nagercoil
Nagercoil Escorts Service Girl ^ 9332606886, WhatsApp Anytime Nagercoil
 
Tadepalligudem Escorts Service Girl ^ 9332606886, WhatsApp Anytime Tadepallig...
Tadepalligudem Escorts Service Girl ^ 9332606886, WhatsApp Anytime Tadepallig...Tadepalligudem Escorts Service Girl ^ 9332606886, WhatsApp Anytime Tadepallig...
Tadepalligudem Escorts Service Girl ^ 9332606886, WhatsApp Anytime Tadepallig...
 
Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...
Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...
Top profile Call Girls In Dindigul [ 7014168258 ] Call Me For Genuine Models ...
 
20240507 QFM013 Machine Intelligence Reading List April 2024.pdf
20240507 QFM013 Machine Intelligence Reading List April 2024.pdf20240507 QFM013 Machine Intelligence Reading List April 2024.pdf
20240507 QFM013 Machine Intelligence Reading List April 2024.pdf
 
Meaning of On page SEO & its process in detail.
Meaning of On page SEO & its process in detail.Meaning of On page SEO & its process in detail.
Meaning of On page SEO & its process in detail.
 
Trump Diapers Over Dems t shirts Sweatshirt
Trump Diapers Over Dems t shirts SweatshirtTrump Diapers Over Dems t shirts Sweatshirt
Trump Diapers Over Dems t shirts Sweatshirt
 
20240509 QFM015 Engineering Leadership Reading List April 2024.pdf
20240509 QFM015 Engineering Leadership Reading List April 2024.pdf20240509 QFM015 Engineering Leadership Reading List April 2024.pdf
20240509 QFM015 Engineering Leadership Reading List April 2024.pdf
 
一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样
一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样
一比一原版(Curtin毕业证书)科廷大学毕业证原件一模一样
 
APNIC Updates presented by Paul Wilson at ARIN 53
APNIC Updates presented by Paul Wilson at ARIN 53APNIC Updates presented by Paul Wilson at ARIN 53
APNIC Updates presented by Paul Wilson at ARIN 53
 
Vip Firozabad Phone 8250092165 Escorts Service At 6k To 30k Along With Ac Room
Vip Firozabad Phone 8250092165 Escorts Service At 6k To 30k Along With Ac RoomVip Firozabad Phone 8250092165 Escorts Service At 6k To 30k Along With Ac Room
Vip Firozabad Phone 8250092165 Escorts Service At 6k To 30k Along With Ac Room
 
Ballia Escorts Service Girl ^ 9332606886, WhatsApp Anytime Ballia
Ballia Escorts Service Girl ^ 9332606886, WhatsApp Anytime BalliaBallia Escorts Service Girl ^ 9332606886, WhatsApp Anytime Ballia
Ballia Escorts Service Girl ^ 9332606886, WhatsApp Anytime Ballia
 
2nd Solid Symposium: Solid Pods vs Personal Knowledge Graphs
2nd Solid Symposium: Solid Pods vs Personal Knowledge Graphs2nd Solid Symposium: Solid Pods vs Personal Knowledge Graphs
2nd Solid Symposium: Solid Pods vs Personal Knowledge Graphs
 

Configuring a Cisco Router as a PPPoE Client for DSL Connectivity

  • 1. Configuring a Cisco Router as a PPPoE Client for DSL connectivity PPPoE: Point-to-Point Protocol over Ethernet. The PPP over Ethernet Client feature provides PPP over Ethernet (PPPoE) Client support on routers on customer premises. Configuring a Cisco routers as a PPPoE client for DSL connectivity, there are two cases, one for the Ethernet interfaces, and another for the ATM interfaces A. PPPoE on Ethernet interfaces—PPPoE functionality is configured on a CPE router with two Ethernet interfaces. One Ethernet interface is subscriber-facing, the other provider facing. B. PPPoE on ATM interfaces—PPPoE functionality is configured on a CPE router with one Ethernet interface and one ATM interface. The Ethernet interface is subscriber-facing whereas the ATM interface is provider-facing. Note: I noticed that on some books no one mentioned the configuration of IP domain lookup command and ISP DNS options in DHCP server configuration. Without these DSL connection will not work. Also pay attention if DSL connection did not work, to check the state of all interfaces by using show ip interface brief and make sure to issue no shutdown command on all of them. A. PPPoE on Ethernet interfaces DSL configuration brief steps: 1. Internal Ethernet interface configuration 2. External Ethernet interface configuration 3. Dialer interface configuration 4. Configuring Access List 5. NAT/PAT configuration 6. Configuring IP domain Lookup 7. DHCP server services configuration 8. Static default route configuration DSL configuration detailed steps: 1. Internal Ethernet interface configuration interface FastEthernet 0/1 description internal interface ip address 172.16.1.1 255.255.255.0 1
  • 2. ip nat inside no shut OR (incase you are using Cisco 877 router) interface Vlan1 description internal interface ip address 172.16.1.1 255.255.255.0 ip nat inside no shut 2. External Ethernet interface configuration Interface FastEthernet 0/0 Description DSL interface no ip address pppoe enable pppoe-client dial-pool-number 1 no shut 3. Dialer interface configuration interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 ppp authentication chap pap callin ppp pap sent-username USERNAME password P@ssw0rd (this is the password that ISP gave it to you ppp chap hostname HOSTNAME (This is the username that ISP gave it to you) ppp chap password P@ssw0rd no shut 4. Configuring Access List ip access-list extended DSL_ACCESSLIST 100 permit ip 10.10.10.0 0.0.0.255 any 5. Configuring NAT/PAT ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload 2
  • 3. 6. Configuring IP domain Lookup ip domain lookup ip name-server Primary DNS IP address (obtained from your ISP) ip name-server Secondary DNS IP address (obtained from your ISP) 7. DHCP server services configuration ip dhcp pool DSL_DHCP network 10.10.10.0 /29 dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP) default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address) import all 8. Static default route configuration Finally, configure a static default route. It should point to the dialer interface rather than an IP address as in the below example. ip route 0.0.0.0 0.0.0.0 dialer 1 B. PPPoE on ATM interfaces DSL configuration brief steps: 1. Internal Ethernet interface configuration 2. External ATM interface configuration (in case you are using Cisco 877 Router) 3. Dialer interface configuration 4. Configuring Access List 5. NAT/PAT configuration 6. Configuring IP domain Lookup 7. DHCP server services configuration 8. Static default route configuration DSL configuration detailed steps: 1. Internal VLAN interface configuration (using Cisco 877 Router) interface Vlan1 description internal interface 3
  • 4. ip address 172.16.1.1 255.255.255.0 ip nat inside no shut OR (if you are using configurable internal Ethernet interface) interface FastEthernet 0/1 description internal interface ip address 172.16.1.1 255.255.255.0 ip nat inside no shut 2. External ATM interface configuration interface ATM 0 description DSL interface ip directed-broadcast ip mask-reply ip route-cache flow no ip address dsl operating-mode auto pvc 8/35 no shutdown pppoe-client dial-pool-number 1 3. Dialer interface configuration interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 ppp authentication chap pap callin ppp pap sent-username USERNAME password P@ssw0rd (this is the password that ISP gave it to you ppp chap hostname HOSTNAME (This is the username that ISP gave it to you) ppp chap password P@ssw0rd no shut 4. Configuring Access List ip access-list extended DSL_ACCESSLIST 4
  • 5. 100 permit ip 10.10.10.0 0.0.0.255 any 5. Configuring NAT/PAT ip nat inside source list DSL_ACCESSLIST interface dialer 1 overload 6. Configuring IP domain Lookup ip domain lookup ip name-server Primary DNS IP address (obtained from your ISP) ip name-server Secondary DNS IP address (obtained from your ISP) 7. DHCP server services configuration ip dhcp pool DSL_DHCP network 10.10.10.0 /29 dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP) default-router 10.10.10.1 (internal VLAN or Ethernet interface Ip address) import all 8. Static default route configuration Finally, configure a static default route. It should point to the dialer interface rather than an IP address as in the below example. ip route 0.0.0.0 0.0.0.0 dialer 1 More related: Cisco Router 1941 Commands How to recover Cisco 1921 router default password? Cisco 2911 SNMP not working How To Recover Cisco Router Password The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900 More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog 3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale original new Cisco networking equipments, including Cisco Catalyst switches, Cisco 5
  • 6. routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 6
  • 7. routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 6