SlideShare a Scribd company logo
1 of 5
Download to read offline
Mirroring of boot Disk and two separate partitions which are placed on two other disks :-
So in all there are Four disks :-
1. Disk 0 and Disk 1(Mirror)
/ 10 GB
Swap 8 GB
/usr 10 GB
/var 5 GB
/tmp 5 GB
2. Disk 2 and Disk 3 (Mirror)
/oracle 20 GB
/archive 20 GB
We will assume that the OS is already installed on the Server and /, swap, /usr, /var and
/tmp partitions are already in place.
STEP 1) Important precaution:
Copy /etc/vfstab and /etc/system before you go ahead:
cp -p /etc/system /etc/system.orig."date"
cp -p /etc/vfstab /etc/vfstab.orig."date"
In case /etc/system gets messed up, we can still use the command boot
-a from the OK prompt and specify by using:
/etc/system.orig."date"
STEP 2) We will use disk 1 for mirroring the root disk ie Disk 0.
3) Create a small slice of 100 Mbyte (10 Mbyte is also fine) for storing
volume databases on the "rootdisk" and label the disk.
ONLY Required if there is no space left on the disk!!!!!!!!
If you have free space on disk 0 then skip to step 4
If you don't have any space on your root disk, create a small slice by
deleting and re-adding swap space.
Make sure that there is not a lot of activity on the box while you do
this.
3.1) To list your swap, use: swap -l
(It's good if you have more than one slice configured as swap.)
3.2) Execute:
swap –d /dev/dsk/c1t0dos1
Change your partition table to incorporate a new slice by reducing the
size or cylinder length of the swap partition.
3.3) Execute:
swap –a /dev/dsk/c1t0dos1
STEP 4) The VTOC (volume table of contents) on the root disk and root
mirror must be the same. Copy the VTOC using prtvtoc and fmthard.
# prtvtoc /dev/rdsk/c?t?d?s2 | fmthard -s - /dev/rdsk/c?t?d?s2
STEP 5) Create metadatabases on the small slice created on rootdisk:
# metadb -f -a -c3 c1t0d0s7 (Slice 7 is my small slice here)
# metadb -a -c3 c0t1d0s7 (Slice 7 on rootmirror)
STEP 6) Now we can create a mirror for each and every slice in the
partition table.
For root or / partition:
# metainit -f d11 1 1 c0t0d0s0
# metainit d12 1 1 c0t1d0s0
(create a md d10 and attach one submirror)
# metainit d10 -m d11
Info Only!(sets up system files for root (/) metadevice, that is,
changes to /etc/system and /etc/vfstab)
# metaroot d10
# lockfs -fa (clear improper file locks on all mounted UFS file
systems)
STEP 7) Naming convention for other metadisks follow. (Note for those
who are new to this software: We will not do metaroot and lockfs steps
on other file systems.)
The submirrors will be named d11, d12 and so on.
In d12, 1 is the submirror number, and 2 is the slice number.
If we have swap on partition/slice 1, we would do this:
# metainit -f d21 1 1 c0t0d0s1
# metainit d22 1 1 c0t1d0s1
# metainit d20 -m d21
STEP 8) Repeat for as many file systems you have on your boot disk.
STEP 9) Make changes to your /etc/vfstab. The md entry for root will
already be updated by the metaroot command.
A sample copy of /etc/vfstab looks like this:
#device device mount FS fsck mount mount
#to mount to fsck point type pass at boot options
#
fd - /dev/fd fd - no -
/proc - /proc proc - no -
##/dev/dsk/c1t1d0s1 - - swap - no -
/dev/md/dsk/d20 - - swap - no -
/dev/md/dsk/d10 /dev/md/rdsk/d10 / ufs 1 no -
##/dev/dsk/c1t1d0s7 /dev/rdsk/c1t1d0s7 /export/home ufs 2 yes -
/dev/md/dsk/d70 /dev/md/rdsk/d70 /export/home ufs 2 yes -
##/dev/dsk/c1t1d0s3 /dev/rdsk/c1t1d0s3 /opt/uc4 ufs 2 yes -
/dev/md/dsk/d30 /dev/md/rdsk/d30 /opt/uc4 ufs 2 yes -
swap - /tmp tmpfs - yes -
NOTE : Repeat Step 4, 7, 8 and 9 for the partitions on the other disks ie /oracle and
/archive etc….
STEP 10) Configure your dump device using dumpadm.
STEP 11) Make the following entry in the /etc/system file, in the mdd info
section:
set md:mirrored_root_flag=1
When the root disk becomes unavailable, the database copies stored
on the root disk are also unavailable.
Solaris Volume Manager software expects more than 50 percent of the
databases to be available to boot up normally or else it may complain
about the insufficient number of database replicas. The preceding
change is made in order for Solaris Volume Manager software to boot
up with at least 50 percent of the copies.
STEP 12) Execute:
sync; sync; init 6
STEP 13) Once the system comes up, attach the other submirror:
# metattach d0 d20
(Note: It's "metattach" and not "metaattach")
# metattach d1 d21
and so on.
STEP 14) To see whether the FS syncing is done or not, do this:
metastat | grep progress
STEP 15) Determine the device path to the boot devices for both the
primary and mirror:
ls -l /dev/dsk/c0t1d0s0 /dev/dsk/c0t0d0s0
lrwxrwxrwx 1 root root 43 Dec 23 17:51 /dev/dsk/c0t0d0s0 -> 
../../devices/pci@1c,600000/scsi@2/sd@0,0:a
lrwxrwxrwx 1 root root 43 Dec 23 17:51 /dev/dsk/c0t1d0s0 -> 
../../devices/pci@1c,600000/scsi@2/sd@1,0:a
# eeprom "nvramrc=devalias rootdisk /pci@1c,600000/scsi@2/disk@1,0
devalias rootmirror /pci@1c,600000/scsi@2/disk@0,0"
(Please note the change "sd" to "disk" in using ls -l output.)
# eeprom "use-nvramrc?=true"
You can also change the boot-device values so that the system tries to
boot from the mirror in case one of them is not available.
# eeprom boot-device="rootdisk rootmirror net"
STEP 16) Once the syncing is complete, test your system by removing
the root disk.

More Related Content

Similar to Mirroring the root_disk under solaris SVM

101 2.1 design hard disk layout
101 2.1 design hard disk layout101 2.1 design hard disk layout
101 2.1 design hard disk layoutAcácio Oliveira
 
101 2.1 design hard disk layout v2
101 2.1 design hard disk layout v2101 2.1 design hard disk layout v2
101 2.1 design hard disk layout v2Acácio Oliveira
 
2.1 design hard disk layout v2
2.1 design hard disk layout v22.1 design hard disk layout v2
2.1 design hard disk layout v2Acácio Oliveira
 
Disk suit 4 setup and installation
Disk suit 4 setup and installationDisk suit 4 setup and installation
Disk suit 4 setup and installationppratish
 
x86_64 Hardware Deep dive
x86_64 Hardware Deep divex86_64 Hardware Deep dive
x86_64 Hardware Deep diveNaoto MATSUMOTO
 
Andresen 8 21 02
Andresen 8 21 02Andresen 8 21 02
Andresen 8 21 02FNian
 
MINCS - containers in the shell script (Eng. ver.)
MINCS - containers in the shell script (Eng. ver.)MINCS - containers in the shell script (Eng. ver.)
MINCS - containers in the shell script (Eng. ver.)Masami Hiramatsu
 
How to solve misalignment lun netapp on linux servers by Ivan
How to solve misalignment lun netapp on linux servers by IvanHow to solve misalignment lun netapp on linux servers by Ivan
How to solve misalignment lun netapp on linux servers by IvanIvan Silva
 
Inspection and maintenance tools (Linux / OpenStack)
Inspection and maintenance tools (Linux / OpenStack)Inspection and maintenance tools (Linux / OpenStack)
Inspection and maintenance tools (Linux / OpenStack)Gerard Braad
 
How to mount and unmount filesystem
How to mount and unmount filesystemHow to mount and unmount filesystem
How to mount and unmount filesystemCOMSATS
 
Pdn multipath io-pvm-ver1.0.0
Pdn multipath io-pvm-ver1.0.0Pdn multipath io-pvm-ver1.0.0
Pdn multipath io-pvm-ver1.0.0pdnsoftco
 

Similar to Mirroring the root_disk under solaris SVM (20)

Real time systems
Real time systemsReal time systems
Real time systems
 
101 2.1 design hard disk layout
101 2.1 design hard disk layout101 2.1 design hard disk layout
101 2.1 design hard disk layout
 
101 2.1 design hard disk layout v2
101 2.1 design hard disk layout v2101 2.1 design hard disk layout v2
101 2.1 design hard disk layout v2
 
2.1 design hard disk layout v2
2.1 design hard disk layout v22.1 design hard disk layout v2
2.1 design hard disk layout v2
 
Dev ops
Dev opsDev ops
Dev ops
 
Mac os x mount ntfs
Mac os x mount ntfsMac os x mount ntfs
Mac os x mount ntfs
 
Disk suit 4 setup and installation
Disk suit 4 setup and installationDisk suit 4 setup and installation
Disk suit 4 setup and installation
 
Alta disponibilidad en GNU/Linux
Alta disponibilidad en GNU/LinuxAlta disponibilidad en GNU/Linux
Alta disponibilidad en GNU/Linux
 
Solaris
SolarisSolaris
Solaris
 
x86_64 Hardware Deep dive
x86_64 Hardware Deep divex86_64 Hardware Deep dive
x86_64 Hardware Deep dive
 
Andresen 8 21 02
Andresen 8 21 02Andresen 8 21 02
Andresen 8 21 02
 
Xen time machine
Xen time machineXen time machine
Xen time machine
 
MINCS - containers in the shell script (Eng. ver.)
MINCS - containers in the shell script (Eng. ver.)MINCS - containers in the shell script (Eng. ver.)
MINCS - containers in the shell script (Eng. ver.)
 
Ch12 system administration
Ch12 system administration Ch12 system administration
Ch12 system administration
 
How to solve misalignment lun netapp on linux servers by Ivan
How to solve misalignment lun netapp on linux servers by IvanHow to solve misalignment lun netapp on linux servers by Ivan
How to solve misalignment lun netapp on linux servers by Ivan
 
Inspection and maintenance tools (Linux / OpenStack)
Inspection and maintenance tools (Linux / OpenStack)Inspection and maintenance tools (Linux / OpenStack)
Inspection and maintenance tools (Linux / OpenStack)
 
Linux
LinuxLinux
Linux
 
How to mount and unmount filesystem
How to mount and unmount filesystemHow to mount and unmount filesystem
How to mount and unmount filesystem
 
os
osos
os
 
Pdn multipath io-pvm-ver1.0.0
Pdn multipath io-pvm-ver1.0.0Pdn multipath io-pvm-ver1.0.0
Pdn multipath io-pvm-ver1.0.0
 

Recently uploaded

Roles & Responsibilities in Pharmacovigilance
Roles & Responsibilities in PharmacovigilanceRoles & Responsibilities in Pharmacovigilance
Roles & Responsibilities in PharmacovigilanceSamikshaHamane
 
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptxPOINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptxSayali Powar
 
Gas measurement O2,Co2,& ph) 04/2024.pptx
Gas measurement O2,Co2,& ph) 04/2024.pptxGas measurement O2,Co2,& ph) 04/2024.pptx
Gas measurement O2,Co2,& ph) 04/2024.pptxDr.Ibrahim Hassaan
 
Solving Puzzles Benefits Everyone (English).pptx
Solving Puzzles Benefits Everyone (English).pptxSolving Puzzles Benefits Everyone (English).pptx
Solving Puzzles Benefits Everyone (English).pptxOH TEIK BIN
 
MICROBIOLOGY biochemical test detailed.pptx
MICROBIOLOGY biochemical test detailed.pptxMICROBIOLOGY biochemical test detailed.pptx
MICROBIOLOGY biochemical test detailed.pptxabhijeetpadhi001
 
Employee wellbeing at the workplace.pptx
Employee wellbeing at the workplace.pptxEmployee wellbeing at the workplace.pptx
Employee wellbeing at the workplace.pptxNirmalaLoungPoorunde1
 
DATA STRUCTURE AND ALGORITHM for beginners
DATA STRUCTURE AND ALGORITHM for beginnersDATA STRUCTURE AND ALGORITHM for beginners
DATA STRUCTURE AND ALGORITHM for beginnersSabitha Banu
 
Final demo Grade 9 for demo Plan dessert.pptx
Final demo Grade 9 for demo Plan dessert.pptxFinal demo Grade 9 for demo Plan dessert.pptx
Final demo Grade 9 for demo Plan dessert.pptxAvyJaneVismanos
 
How to Make a Pirate ship Primary Education.pptx
How to Make a Pirate ship Primary Education.pptxHow to Make a Pirate ship Primary Education.pptx
How to Make a Pirate ship Primary Education.pptxmanuelaromero2013
 
Difference Between Search & Browse Methods in Odoo 17
Difference Between Search & Browse Methods in Odoo 17Difference Between Search & Browse Methods in Odoo 17
Difference Between Search & Browse Methods in Odoo 17Celine George
 
EPANDING THE CONTENT OF AN OUTLINE using notes.pptx
EPANDING THE CONTENT OF AN OUTLINE using notes.pptxEPANDING THE CONTENT OF AN OUTLINE using notes.pptx
EPANDING THE CONTENT OF AN OUTLINE using notes.pptxRaymartEstabillo3
 
call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️
call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️
call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️9953056974 Low Rate Call Girls In Saket, Delhi NCR
 
Framing an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdf
Framing an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdfFraming an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdf
Framing an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdfUjwalaBharambe
 
ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...
ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...
ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...JhezDiaz1
 
Introduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher EducationIntroduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher Educationpboyjonauth
 
Full Stack Web Development Course for Beginners
Full Stack Web Development Course  for BeginnersFull Stack Web Development Course  for Beginners
Full Stack Web Development Course for BeginnersSabitha Banu
 
Computed Fields and api Depends in the Odoo 17
Computed Fields and api Depends in the Odoo 17Computed Fields and api Depends in the Odoo 17
Computed Fields and api Depends in the Odoo 17Celine George
 
“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...
“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...
“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...Marc Dusseiller Dusjagr
 

Recently uploaded (20)

Roles & Responsibilities in Pharmacovigilance
Roles & Responsibilities in PharmacovigilanceRoles & Responsibilities in Pharmacovigilance
Roles & Responsibilities in Pharmacovigilance
 
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptxPOINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
POINT- BIOCHEMISTRY SEM 2 ENZYMES UNIT 5.pptx
 
Gas measurement O2,Co2,& ph) 04/2024.pptx
Gas measurement O2,Co2,& ph) 04/2024.pptxGas measurement O2,Co2,& ph) 04/2024.pptx
Gas measurement O2,Co2,& ph) 04/2024.pptx
 
Solving Puzzles Benefits Everyone (English).pptx
Solving Puzzles Benefits Everyone (English).pptxSolving Puzzles Benefits Everyone (English).pptx
Solving Puzzles Benefits Everyone (English).pptx
 
MICROBIOLOGY biochemical test detailed.pptx
MICROBIOLOGY biochemical test detailed.pptxMICROBIOLOGY biochemical test detailed.pptx
MICROBIOLOGY biochemical test detailed.pptx
 
Employee wellbeing at the workplace.pptx
Employee wellbeing at the workplace.pptxEmployee wellbeing at the workplace.pptx
Employee wellbeing at the workplace.pptx
 
DATA STRUCTURE AND ALGORITHM for beginners
DATA STRUCTURE AND ALGORITHM for beginnersDATA STRUCTURE AND ALGORITHM for beginners
DATA STRUCTURE AND ALGORITHM for beginners
 
Final demo Grade 9 for demo Plan dessert.pptx
Final demo Grade 9 for demo Plan dessert.pptxFinal demo Grade 9 for demo Plan dessert.pptx
Final demo Grade 9 for demo Plan dessert.pptx
 
TataKelola dan KamSiber Kecerdasan Buatan v022.pdf
TataKelola dan KamSiber Kecerdasan Buatan v022.pdfTataKelola dan KamSiber Kecerdasan Buatan v022.pdf
TataKelola dan KamSiber Kecerdasan Buatan v022.pdf
 
How to Make a Pirate ship Primary Education.pptx
How to Make a Pirate ship Primary Education.pptxHow to Make a Pirate ship Primary Education.pptx
How to Make a Pirate ship Primary Education.pptx
 
Difference Between Search & Browse Methods in Odoo 17
Difference Between Search & Browse Methods in Odoo 17Difference Between Search & Browse Methods in Odoo 17
Difference Between Search & Browse Methods in Odoo 17
 
EPANDING THE CONTENT OF AN OUTLINE using notes.pptx
EPANDING THE CONTENT OF AN OUTLINE using notes.pptxEPANDING THE CONTENT OF AN OUTLINE using notes.pptx
EPANDING THE CONTENT OF AN OUTLINE using notes.pptx
 
call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️
call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️
call girls in Kamla Market (DELHI) 🔝 >༒9953330565🔝 genuine Escort Service 🔝✔️✔️
 
Framing an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdf
Framing an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdfFraming an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdf
Framing an Appropriate Research Question 6b9b26d93da94caf993c038d9efcdedb.pdf
 
ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...
ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...
ENGLISH 7_Q4_LESSON 2_ Employing a Variety of Strategies for Effective Interp...
 
Introduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher EducationIntroduction to ArtificiaI Intelligence in Higher Education
Introduction to ArtificiaI Intelligence in Higher Education
 
Model Call Girl in Bikash Puri Delhi reach out to us at 🔝9953056974🔝
Model Call Girl in Bikash Puri  Delhi reach out to us at 🔝9953056974🔝Model Call Girl in Bikash Puri  Delhi reach out to us at 🔝9953056974🔝
Model Call Girl in Bikash Puri Delhi reach out to us at 🔝9953056974🔝
 
Full Stack Web Development Course for Beginners
Full Stack Web Development Course  for BeginnersFull Stack Web Development Course  for Beginners
Full Stack Web Development Course for Beginners
 
Computed Fields and api Depends in the Odoo 17
Computed Fields and api Depends in the Odoo 17Computed Fields and api Depends in the Odoo 17
Computed Fields and api Depends in the Odoo 17
 
“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...
“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...
“Oh GOSH! Reflecting on Hackteria's Collaborative Practices in a Global Do-It...
 

Mirroring the root_disk under solaris SVM

  • 1. Mirroring of boot Disk and two separate partitions which are placed on two other disks :- So in all there are Four disks :- 1. Disk 0 and Disk 1(Mirror) / 10 GB Swap 8 GB /usr 10 GB /var 5 GB /tmp 5 GB 2. Disk 2 and Disk 3 (Mirror) /oracle 20 GB /archive 20 GB We will assume that the OS is already installed on the Server and /, swap, /usr, /var and /tmp partitions are already in place. STEP 1) Important precaution: Copy /etc/vfstab and /etc/system before you go ahead: cp -p /etc/system /etc/system.orig."date" cp -p /etc/vfstab /etc/vfstab.orig."date" In case /etc/system gets messed up, we can still use the command boot -a from the OK prompt and specify by using: /etc/system.orig."date" STEP 2) We will use disk 1 for mirroring the root disk ie Disk 0. 3) Create a small slice of 100 Mbyte (10 Mbyte is also fine) for storing volume databases on the "rootdisk" and label the disk. ONLY Required if there is no space left on the disk!!!!!!!! If you have free space on disk 0 then skip to step 4 If you don't have any space on your root disk, create a small slice by deleting and re-adding swap space.
  • 2. Make sure that there is not a lot of activity on the box while you do this. 3.1) To list your swap, use: swap -l (It's good if you have more than one slice configured as swap.) 3.2) Execute: swap –d /dev/dsk/c1t0dos1 Change your partition table to incorporate a new slice by reducing the size or cylinder length of the swap partition. 3.3) Execute: swap –a /dev/dsk/c1t0dos1 STEP 4) The VTOC (volume table of contents) on the root disk and root mirror must be the same. Copy the VTOC using prtvtoc and fmthard. # prtvtoc /dev/rdsk/c?t?d?s2 | fmthard -s - /dev/rdsk/c?t?d?s2 STEP 5) Create metadatabases on the small slice created on rootdisk: # metadb -f -a -c3 c1t0d0s7 (Slice 7 is my small slice here) # metadb -a -c3 c0t1d0s7 (Slice 7 on rootmirror) STEP 6) Now we can create a mirror for each and every slice in the partition table. For root or / partition: # metainit -f d11 1 1 c0t0d0s0 # metainit d12 1 1 c0t1d0s0 (create a md d10 and attach one submirror) # metainit d10 -m d11 Info Only!(sets up system files for root (/) metadevice, that is, changes to /etc/system and /etc/vfstab)
  • 3. # metaroot d10 # lockfs -fa (clear improper file locks on all mounted UFS file systems) STEP 7) Naming convention for other metadisks follow. (Note for those who are new to this software: We will not do metaroot and lockfs steps on other file systems.) The submirrors will be named d11, d12 and so on. In d12, 1 is the submirror number, and 2 is the slice number. If we have swap on partition/slice 1, we would do this: # metainit -f d21 1 1 c0t0d0s1 # metainit d22 1 1 c0t1d0s1 # metainit d20 -m d21 STEP 8) Repeat for as many file systems you have on your boot disk. STEP 9) Make changes to your /etc/vfstab. The md entry for root will already be updated by the metaroot command. A sample copy of /etc/vfstab looks like this: #device device mount FS fsck mount mount #to mount to fsck point type pass at boot options # fd - /dev/fd fd - no - /proc - /proc proc - no - ##/dev/dsk/c1t1d0s1 - - swap - no - /dev/md/dsk/d20 - - swap - no - /dev/md/dsk/d10 /dev/md/rdsk/d10 / ufs 1 no - ##/dev/dsk/c1t1d0s7 /dev/rdsk/c1t1d0s7 /export/home ufs 2 yes - /dev/md/dsk/d70 /dev/md/rdsk/d70 /export/home ufs 2 yes - ##/dev/dsk/c1t1d0s3 /dev/rdsk/c1t1d0s3 /opt/uc4 ufs 2 yes - /dev/md/dsk/d30 /dev/md/rdsk/d30 /opt/uc4 ufs 2 yes - swap - /tmp tmpfs - yes - NOTE : Repeat Step 4, 7, 8 and 9 for the partitions on the other disks ie /oracle and /archive etc…. STEP 10) Configure your dump device using dumpadm.
  • 4. STEP 11) Make the following entry in the /etc/system file, in the mdd info section: set md:mirrored_root_flag=1 When the root disk becomes unavailable, the database copies stored on the root disk are also unavailable. Solaris Volume Manager software expects more than 50 percent of the databases to be available to boot up normally or else it may complain about the insufficient number of database replicas. The preceding change is made in order for Solaris Volume Manager software to boot up with at least 50 percent of the copies. STEP 12) Execute: sync; sync; init 6 STEP 13) Once the system comes up, attach the other submirror: # metattach d0 d20 (Note: It's "metattach" and not "metaattach") # metattach d1 d21 and so on. STEP 14) To see whether the FS syncing is done or not, do this: metastat | grep progress STEP 15) Determine the device path to the boot devices for both the primary and mirror: ls -l /dev/dsk/c0t1d0s0 /dev/dsk/c0t0d0s0 lrwxrwxrwx 1 root root 43 Dec 23 17:51 /dev/dsk/c0t0d0s0 -> ../../devices/pci@1c,600000/scsi@2/sd@0,0:a lrwxrwxrwx 1 root root 43 Dec 23 17:51 /dev/dsk/c0t1d0s0 -> ../../devices/pci@1c,600000/scsi@2/sd@1,0:a # eeprom "nvramrc=devalias rootdisk /pci@1c,600000/scsi@2/disk@1,0 devalias rootmirror /pci@1c,600000/scsi@2/disk@0,0"
  • 5. (Please note the change "sd" to "disk" in using ls -l output.) # eeprom "use-nvramrc?=true" You can also change the boot-device values so that the system tries to boot from the mirror in case one of them is not available. # eeprom boot-device="rootdisk rootmirror net" STEP 16) Once the syncing is complete, test your system by removing the root disk.