Conalep tlalnepantla 1

1,963 views

Published on

0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
1,963
On SlideShare
0
From Embeds
0
Number of Embeds
2
Actions
Shares
0
Downloads
9
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Conalep tlalnepantla 1

  1. 1. Gómez Morales Ricardo David Conalep Tlalnepantla 1 Gómez Morales Ricardo Grupo: 202 Turno: Matutino Elaboración de documentos digitales avanzados
  2. 2. Gómez Morales Ricardo David Leer las longitudes de un rectángulo y calcular la superficie y el perímetro. Entradas: largo, ancho Salidas: perímetro, área Pseudocódigo Inicio Leer largo Leer ancho Perímetros largo + ancho * 2 Área largo * ancho Imprimir perímetro Imprimir área Fin
  3. 3. Gómez Morales Ricardo David Escribir un pseudocódigo que intercambie el valor de dos variables Entrada: X, Y, Z (auxiliar) Salida: X, Y Pseudocódigo Inicio Leer X Leer Y Z O Z Y Y X X Z Imprimir X Imprimir y Fin
  4. 4. Gómez Morales Ricardo David Escribir un pseudocódigo que intercambie el valor de dos variables Entrada: val1, val2, aux Salida: val1, val2 Pseudocódigo Inicio Leer val1 Leer val2 Aux O Aux val2 Val2 val1 Val1 aux Imprimir Val1 Imprimir Val2 Fin
  5. 5. Gómez Morales Ricardo David Escribir un pseudocódigo que realice la suma de dos variables y que imprima el resultado Entrada: C, I Leer C Leer I Resultado C + I Imprimir resultado Salida: Resultado Fin
  6. 6. Gómez Morales Ricardo David Elabore un pseudocódigo que calcule el área de un triangulo Entrada: base, altura Salida: área Pseudocódigo Inicio Leer base Leer altura Área base * altura / 2 Escribir “el área del triangulo es: “. Área Fin
  7. 7. Gómez Morales Ricardo David Dado como dato la calificación de un alumno en un examen, escriba “APROBADO” en caso que la calificación sea mayor a 8. Entrada: calif Salida: Aprobado Pseudocódigo Inicio Escribir: “Dame una calificación” Leer: calif SI calif > 8 ENTONCES Imprimir: “Aprobado” Fin
  8. 8. Gómez Morales Ricardo David Dado como dato el sueldo de un trabajador aplícale un aumento del 15% si su sueldo es inferior a $1000. Escribe en este caso “EL NUEVO SUELDO DEL TRABAJADOR ES:”. Entrada: sueldo, amento Salida: nuevo _ sueldo PSEUDOCODIGO Inicio Escribir: “Dame el sueldo” Leer: sueldo SI sueldo < 1000 ENTONCES Aumento sueldo *.15 Nuevo _ sueldo sueldo + aumento Imprimir: “El nuevo sueldo del trabajador es:”, nuevo _ sueldo FIN SI FIN
  9. 9. Gómez Morales Ricardo David Escribe un algoritmo para que un alumno del poli pague $200 de inscripción, esto si tiene un promedio de 9 o más. Con base a sus calificaciones, determine si alcanza este promedio y de ser así escriba “EL ALUMNO TIENE BECA”, solicite 7 calificaciones. Entrada: acum, calf1, calf2, cal3, calf4, calf5, cal6, calf7, prom Salida: “El alumno tiene beca”, “promedio” Escribir: “Introduce tus siete calificaciones” Leer: calf1, cal2, calf3, calf4, calf5, calf6, calf7 acum 0 + calf1 + calf2 +calf3 + cal4 + calf5 + calf6 + calf7 prom acum / 7 SI prom >= 9 ENTONCES Escribir: “El alumno tiene beca:”, prom” FIN SI FIN
  10. 10. Gómez Morales Ricardo David Desarrolla un algoritmo que indique si un número es par y que escriba dicho número junto con el letrero “ES UN NUMERO PAR” Entrada: num, residuo Salida: “Es un numero par” PSEUDOCODIGO Inicio Escribir: “Dame un numero” Leer: num residuo1 num MOD 2 SI residuo = 0 ENTONCES Escribir: “Es un numero par” FIN SI FIN
  11. 11. Gómez Morales Ricardo David Con base en la edad proporcionada, determine y escriba si la persona es mayor o menor de edad. Entrada: edad Salida:” es mayor de edad”, “es menor de edad” PSEUDOCODIGO Inicio Escribir: “Dame tu edad” Leer: edad SI edad >=18 ENTONCES Escribir: “Es mayor de edad” SI NO Escribir: “Es menor de edad” FIN SI FIN
  12. 12. Gómez Morales Ricardo David Desarrolle un algoritmo que muestre las 4 operaciones aritméticas y permita elegir una opción y realicen la operación con 2 datos enteros dados como entrada escribe el resultado y realiza el diagrama de flujo y la prueba de escritorio. Entrada: Res Salida: Num1, num2 Pseudocódigo Inicio Escribir”Elige una opción” Escribir “1. Suma” Escribir “2. Resta” Escribir “3. Multiplicación “ Escribir “4.Division” Leer opción SI opción IGUAL Valor1: Escribir “Dame dos numero” Leer num 1 Leer num 2 Escribir “La suma de los dos números es:”, (num1 + num2) Valor2: Escribir “dame dos números” Leer num1 Leer num2 Escribir “la resta de los dos números es:”, (num1 - num2) Valor3: Escribir “Dame dos números”
  13. 13. Gómez Morales Ricardo David Leer num1 Leer num2 Escribir “La multiplicación de los dos números es:”, (num1 * num2) Valor4: Escribir “Dame dos números” Leer num1 Leer num 2 Escribir “la división de los dos números es:”, (num1 /num2) De otra forma: Escribir “opción no valida” FIN SI MULTIPLE FIN
  14. 14. Gómez Morales Ricardo David Desarrolle un algoritmo que dada una calificación escriba los siguientes letreros 10 FELICIDADES 9 MUY BIEN 8 SIGUE ADELANTE 7 PUEDES MEJORAR 6 O MENOS LO SIENTO REPROBASTE Variable: calf Inicio Pseudocódigo Escribir “Dame la calificación” Leer la calf SI calf IGUAL Valor 10: Escribir”Felicidades” Valor 9: Escribir “Muy bien” Valor 8: Escribir “Sigue adelante” Valor 7: Escribir “Puedes mejorar” Valor >=6: Escribir “Lo siento no aprobaste” De otra manera: Escribir “Opción no valida” FIN SI MULTIPLE
  15. 15. Gómez Morales Ricardo David Calcule la suma de los num del 1 al 10 y escríbala. Hacer prueba de escritorio y su diagrama de flujo Variables Suma, inc tipo entero Pseudocódigo Inicio PARA inc=1 HASTA 10 HACER Suma = suma + inc FIN PARA Escribir “La suma de todos ellos es:”, suma FIN
  16. 16. Gómez Morales Ricardo David Desarrolle un algoritmo que pida un número del 1 al 10 y escriba su tabla de multiplicar. Hacer la prueba de escritorio y su diagrama de flujo Variables Multiplicación, inc tipo entero Num, tipo real Pseudocódigo Inicio Escribir “Dame un num del 1 al 10” Leer num PARA inc=1 HASTA 10 HACER Multiplicación=inc * num Escribir INC “* “, numero, “= “, resultado FIN PARA FIN
  17. 17. Gómez Morales Ricardo David

×