Proiect didactic Profesor:  Andrei Andreea Adina Disciplina:  Informatică Unitatea de învăţare:  Principiile programării s...
Cuprins <ul><li>Competenţe generale </li></ul><ul><li>Obiective  operaţionale </li></ul><ul><li>Strategii  didactice </li>...
Competenţe generale: <ul><li>Identificarea datelor care intervin într-o problemă şi a relaţiilor dintre acestea </li></ul>
Obiective  operaţionale:  <ul><li>Obiective cognitive: </li></ul><ul><ul><li>să  identifice datele de intrare şi datele de...
Strategii  didactice <ul><li>1. Principii  didactice: </li></ul><ul><ul><li>principiul  participării  şi  învăţării  activ...
<ul><li>4. Forme  de organizare: </li></ul><ul><ul><li>frontală; </li></ul></ul><ul><ul><li>individuală; </li></ul></ul><u...
Structura repetitivă
Structura repetitivă <ul><li>În cadrul structurii repetitive o secvenţă este executată în mod repetat atât timp cât o anum...
Structura repetitivă <ul><li>Clasificarea Structurii repetitive: </li></ul><ul><ul><li>cu număr cunoscut de paşi </li></ul...
Structura repetitivă <ul><li>Unde, </li></ul><ul><li>i – se numeşte contor   </li></ul><ul><li>a  – valoare iniţială </li>...
Structura repetitivă <ul><li>Principiul de execuţie: </li></ul><ul><li>Pas 1 : Contorul i primeşte valoarea iniţială a; </...
Aplica ţii
1.Să se calculeze suma S = 1 + 2 + 3 + … + n, unde n este un număr natural citit de la tastatură. <ul><li>întreg i, n, S; ...
2. Să se calculeze suma S = 1*3 + 2*5 + 3*7 + … + n(2n+1), unde n este un număr natural citit de la tastatură. <ul><li>înt...
3. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează câte sunt divizibile cu 7. <u...
4. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează câte sunt pozitive şi pare. <...
5. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează maximul dintre ele. <ul><li>î...
6. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează suma numerelor pare. <ul><li>...
7. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează produsul numerelor impare. <u...
8. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează suma cifrelor unităţilor core...
9. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează media aritmetică a  numerelor...
 
Leg ături către site-uri suport <ul><li>http://lumeaalgoritmilor.uv.ro/structurarepetitiva.htm </li></ul><ul><li>http://ww...
Bibliografia   <ul><li>Informatică - Manual clasa aIX-a, Mariana Miloşescu, </li></ul><ul><li>Tudor Sorin  -  Manual de IN...
Upcoming SlideShare
Loading in...5
×

Proiect tic a_2b_andrei_andreea adina

646

Published on

proiect de lectie

Published in: Education
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
646
On Slideshare
0
From Embeds
0
Number of Embeds
0
Actions
Shares
0
Downloads
12
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Proiect tic a_2b_andrei_andreea adina

  1. 1. Proiect didactic Profesor: Andrei Andreea Adina Disciplina: Informatică Unitatea de învăţare: Principiile programării structurate Subiectul: Structura repetitivă
  2. 2. Cuprins <ul><li>Competenţe generale </li></ul><ul><li>Obiective operaţionale </li></ul><ul><li>Strategii didactice </li></ul><ul><ul><li>Principii didactice </li></ul></ul><ul><ul><li>Metode de învăţământ </li></ul></ul><ul><ul><li>Procedee de instruire </li></ul></ul><ul><ul><li>Forme de organizare </li></ul></ul><ul><ul><li>Forme de dirijare a învăţării </li></ul></ul><ul><ul><li>Resurse </li></ul></ul><ul><li>Structura repetitivă </li></ul><ul><li>Aplicaţii, Rezolvări </li></ul><ul><li>Bibliografie </li></ul>
  3. 3. Competenţe generale: <ul><li>Identificarea datelor care intervin într-o problemă şi a relaţiilor dintre acestea </li></ul>
  4. 4. Obiective operaţionale: <ul><li>Obiective cognitive: </li></ul><ul><ul><li>să identifice datele de intrare şi datele de ieşire; </li></ul></ul><ul><ul><li>să recunoască structurile de control: liniară, decizională; </li></ul></ul><ul><ul><li>să identifice elementele care intervin în cazul structurii repetitive cu număr cunoscut de paşi; </li></ul></ul><ul><li>Obiective formative </li></ul><ul><li>- obiective psihomotorii: </li></ul><ul><ul><ul><li>să-şi formeze deprinderi de lucru specifice temei de studiu; </li></ul></ul></ul><ul><ul><ul><li>să-şi dezvolte gândirea logică, capacitatea de generalizare si problematizare; </li></ul></ul></ul><ul><li>- afective </li></ul><ul><ul><ul><li>să aprecieze corect soluţiile oferite de colegi; </li></ul></ul></ul><ul><ul><ul><li>să se implice cu plăcere şi interes la toate etapele lecţiei; </li></ul></ul></ul>
  5. 5. Strategii didactice <ul><li>1. Principii didactice: </li></ul><ul><ul><li>principiul participării şi învăţării active; </li></ul></ul><ul><ul><li>principiul asigurării progresului gradat al performanţei; </li></ul></ul><ul><ul><li>principiul conexiunii inverse; </li></ul></ul><ul><li>2. Metode de învăţământ : </li></ul><ul><ul><li>- metode de comunicare orala: conversaţia, explicaţia, problematizarea; </li></ul></ul><ul><ul><li>- metode de acţiune: exerciţiul, lucrul cu manualul; </li></ul></ul><ul><li>3. Procedee de instruire: </li></ul><ul><ul><li>conversaţia de consolidare; </li></ul></ul><ul><ul><li>problematizarea prin crearea situaţiilor problemă; </li></ul></ul>
  6. 6. <ul><li>4. Forme de organizare: </li></ul><ul><ul><li>frontală; </li></ul></ul><ul><ul><li>individuală; </li></ul></ul><ul><li>5. Forme de dirijare a învăţării: </li></ul><ul><ul><li>dirijată de profesor sau prin materialele didactice; </li></ul></ul><ul><ul><li>independentă; </li></ul></ul><ul><li>6. Resurse: </li></ul><ul><ul><li>pedagogice – Informatică, manual clasa aIX-a, Mariana Miloşescu, alte ghiduri pentru profesori </li></ul></ul><ul><ul><li>oficiale – programa şcolară; </li></ul></ul><ul><ul><li>temporale – 50 min </li></ul></ul><ul><ul><li>psihologice – cunoştinţe dobândite de elevi până la această dată; </li></ul></ul><ul><ul><li>colectiv eterogen (interesat de obiect); </li></ul></ul>
  7. 7. Structura repetitivă
  8. 8. Structura repetitivă <ul><li>În cadrul structurii repetitive o secvenţă este executată în mod repetat atât timp cât o anumită condiţie este îndeplinită. </li></ul>
  9. 9. Structura repetitivă <ul><li>Clasificarea Structurii repetitive: </li></ul><ul><ul><li>cu număr cunoscut de paşi </li></ul></ul><ul><ul><li>cu număr necunoscut de paşi </li></ul></ul><ul><ul><ul><li>cu test iniţial </li></ul></ul></ul><ul><ul><ul><li>cu test final </li></ul></ul></ul>
  10. 10. Structura repetitivă <ul><li>Unde, </li></ul><ul><li>i – se numeşte contor </li></ul><ul><li>a – valoare iniţială </li></ul><ul><li>b – valoare finală </li></ul><ul><li>p – valoarea cu care este incrementat contorul </li></ul>p entru i = a,b,p execută      secvenţă Sfârşit_pentru
  11. 11. Structura repetitivă <ul><li>Principiul de execuţie: </li></ul><ul><li>Pas 1 : Contorul i primeşte valoarea iniţială a; </li></ul><ul><li>Pas 2 : Se verifică dacă contorul i este mai mic </li></ul><ul><li>sau egal decât valoarea finală b; Dacă condiţia </li></ul><ul><li>este îndeplinită se execută Pas 3; Dacă condiţia </li></ul><ul><li>nu este îndeplinită se va executa instrucţiunea ce </li></ul><ul><li>urmează structurii pentru. </li></ul><ul><li>Pas 3 : Se execută secvenţa, se incrementează </li></ul><ul><li>valoarea contorului cu valoarea p </li></ul>
  12. 12. Aplica ţii
  13. 13. 1.Să se calculeze suma S = 1 + 2 + 3 + … + n, unde n este un număr natural citit de la tastatură. <ul><li>întreg i, n, S; </li></ul><ul><li>început citeste n ; S← 0; pentru i← 1,n, 1 execută S ← S + i </li></ul><ul><li>sf ârşit_pentru; </li></ul><ul><li>scrie S </li></ul><ul><li>sfârşit </li></ul>
  14. 14. 2. Să se calculeze suma S = 1*3 + 2*5 + 3*7 + … + n(2n+1), unde n este un număr natural citit de la tastatură. <ul><li>întreg i, n, S, k; </li></ul><ul><li>început citeste n ; S← 0; pentru i← 1,n, 1 execută </li></ul><ul><li>k= i * (2*i + 1); S ← S + k; </li></ul><ul><li>sf ârşit_pentru; </li></ul><ul><li>scrie S sfârşit </li></ul>
  15. 15. 3. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează câte sunt divizibile cu 7. <ul><li>întreg x, nr, i, n; </li></ul><ul><li>început citeste n; nr ← 0; pentru i← 1,n, 1 execută </li></ul><ul><li>citeşte x; </li></ul><ul><li>daca (x%7=0) atunci nr ← nr + 1 </li></ul><ul><li>sfârşit dacă; </li></ul><ul><li>sfârşit pentru; scrie nr; </li></ul><ul><li>sfârşit </li></ul>
  16. 16. 4. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează câte sunt pozitive şi pare. <ul><li>întreg x, nr, i, n; </li></ul><ul><li>Început </li></ul><ul><li>citeste n; nr ← 0; </li></ul><ul><li>pentru i← 1,n, 1 execută </li></ul><ul><li>citeşte x; </li></ul><ul><li>daca ((x>0) AND (x%2=0)) atunci nr ← nr + 1 </li></ul><ul><li>sfârşit dacă; </li></ul><ul><li>sfârşit pentru; </li></ul><ul><li>scrie nr; </li></ul><ul><li>sfârşit </li></ul>
  17. 17. 5. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează maximul dintre ele. <ul><li>întreg x, i, n, max; </li></ul><ul><li>început citeste n,x; max ← x; pentru i← 2,n, 1 execută </li></ul><ul><li>citeşte x; </li></ul><ul><li>daca (x>max) atunci max ← x </li></ul><ul><li>sfârşit dacă; </li></ul><ul><li>sfârşit pentru; </li></ul><ul><li>scrie max;sfârşit </li></ul>
  18. 18. 6. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează suma numerelor pare. <ul><li>întreg x, i, n, S; </li></ul><ul><li>început citeste n; S ← 0; pentru i← 1,n, 1 execută </li></ul><ul><li>citeşte x; </li></ul><ul><li>daca (x%2=0) atunci S ← S+ x </li></ul><ul><li>sfârşit dacă; </li></ul><ul><li>sfârşit pentru; </li></ul><ul><li>scrie S; </li></ul><ul><li>sfârşit </li></ul>
  19. 19. 7. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează produsul numerelor impare. <ul><li>întreg x, i, n, P; </li></ul><ul><li>început citeste n; P ← 1; pentru i← 1,n, 1 execută </li></ul><ul><li>citeşte x; </li></ul><ul><li>daca(x%2=1)atunci P←P*x </li></ul><ul><li>sfârşit dacă; </li></ul><ul><li>sfârşit pentru; scrie S; </li></ul><ul><li>sfârşit; </li></ul>
  20. 20. 8. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează suma cifrelor unităţilor corespunzătoare fiecărui număr. <ul><li>întreg x, nr, i, n, S; </li></ul><ul><li>început citeste n; S ← 0; pentru i← 1,n, 1 execută </li></ul><ul><li>citeşte x; </li></ul><ul><li>S ← S + x%10; </li></ul><ul><li>sfârşit pentru; </li></ul><ul><li>scrie S; </li></ul><ul><li>sfârşit </li></ul>
  21. 21. 9. Se citeşte de la tastatură un şir de n numere naturale. Scrieţi un algoritm care afişează media aritmetică a numerelor pozitive. <ul><li>întreg x, i, n, nr; real ma; </li></ul><ul><li>început citeste n; nr ← 0; pentru i← 1,n, 1 execută </li></ul><ul><li>citeşte x; </li></ul><ul><li>daca (x>0) atunci </li></ul><ul><li>ma ← ma + x; nr ← nr + 1 </li></ul><ul><li>sfârşit dacă; </li></ul><ul><li>sfârşit pentru; scrie ma/nr; </li></ul><ul><li>sfârşit </li></ul>
  22. 23. Leg ături către site-uri suport <ul><li>http://lumeaalgoritmilor.uv.ro/structurarepetitiva.htm </li></ul><ul><li>http://www.didactic.ro/materiale-didactice/26597_structura-repetitiv-si-259-cu-contor </li></ul><ul><li>http://informaticasite.ro/rezolvari-probleme/pseudocod/Algoritmi-in-pseudocod.html </li></ul><ul><li>http://www.scribd.com/doc/18643757/18/Ciclul-sau-structura-repetitiv%C4%83 </li></ul>
  23. 24. Bibliografia <ul><li>Informatică - Manual clasa aIX-a, Mariana Miloşescu, </li></ul><ul><li>Tudor Sorin - Manual de INFORMATICĂ, clasa a IX-a, profilul real-intensiv (varianta C++) </li></ul><ul><li>Dana Lica - Manual de INFORMATICĂ, clasa a IX-a, profilul real-intensiv </li></ul>
  1. A particular slide catching your eye?

    Clipping is a handy way to collect important slides you want to go back to later.

×