Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.
1
Малоизвестные
хитрости работы в
Конфигураторе 8.3
2
План вебинара
1. Конфигуратор как рабочий инструмент программиста 1С
2. Полезные фичи конфигуратора 1С, о которых не все...
3
Конфигуратор как рабочий инструмент программиста 1С
Конфигуратор 1С 8.3 — среда разработки
информационных систем на базе...
4
Закладки
Список закладок
Нажимаем клавиши «Ctrl + Shift + F2», и перед нами откроется окно с полным списком
установленны...
5
Контекстная подсказка
Настройка с помощью пункта меню Сервис — Параметры, закладка Модули —
Контекстная подсказка
Нажима...
6
Контекстная подсказка
Существует документ “Система стандартов и методик разработки конфигураций для
платформы 1С:Предпри...
7
Группировка строк программного кода
Для выделения области текста введены две новые инструкции препроцессора
#Область и #...
8
Выделение цветом конструкций
9
Выделение цветом конструкций
10
Выделение цветом конструкций
11
Окно «Локальные переменные»
Реализовано в версии 8.3.7.1759
12
Окно «Локальные переменные»
Значения примитивных типов вы можете изменить прямо в ячейке «Значение»:
А для изменения др...
13
Встраивание часто используемых обработок в интерфейс
В платформе 1С предприятие есть очень удобные стандартные функции:...
14
Встраивание часто используемых обработок в интерфейс
15
Встраивание часто используемых обработок в интерфейс
Список обработок:
1. Активные пользователи - "v8res://mngbase/Stan...
16
Замена стандартной обработки 1С собственным вариантом
Изменение стандартной обработки.
Подмена стандартной обработки.
17
Инструменты рефакторинга
Команды:
“Выделить фрагмент”
“Переименовать”
“Преобразовать модальный вызов”
“Преобразовать в ...
18
Выделить фрагмент
19
Переименовать
20
Преобразовать модальный вызов
21
Преобразовать в асинхронную процедуру
22
Выделить в асинхронную процедуру
23
Источники
1. http://www.koderline.ru/expert/programming/article-
vspomogatelnye-funktsii-v-1s/
2. http://курсы-по-1с.рф...
24
Спасибо за внимание!
Если у Вас возникли вопросы – свяжитесь с нами.
Мы всегда рады помочь!
Upcoming SlideShare
Loading in …5
×

Малоизвестные хитрости работы в Конфигураторе 8.3

1,033 views

Published on

Компания Кодерлайн провела вебинар на тему «Малоизвестные хитрости работы в Конфигураторе 8.3»

Вебинар будет интересен программистам, разработчикам, заинтересованным лица.

Ведущий: Сергей ТИМОФЕЕВ – инженер-программист 1С.

Описание:
На вебинаре рассмотрели малоизвестные механизмы платформы 8.3
Программа вебинара:
1. Конфигуратор как рабочий инструмент программиста 1С;
2. Полезные фичи конфигуратора 1С, о которых не все знают:
• закладки;
• контекстная подсказка;
• группировка строк;
• выделение цветом конструкций;
• окно «Локальные переменные»;
• встраивание часто используемых обработок в интерфейс;
• замена стандартной обработки 1С собственным усовершенствованным вариантом;
• быстрое отображение объектов, захваченных в хранилище;
• инструменты рефакторинга.

Будем благодарны за ваши отзывы :)

Published in: Technology
  • Be the first to comment

  • Be the first to like this

Малоизвестные хитрости работы в Конфигураторе 8.3

  1. 1. 1 Малоизвестные хитрости работы в Конфигураторе 8.3
  2. 2. 2 План вебинара 1. Конфигуратор как рабочий инструмент программиста 1С 2. Полезные фичи конфигуратора 1С, о которых не все знают: • закладки • контекстная подсказка • группировка строк • выделение цветом конструкций • окно «Локальные переменные» • встраивание часто используемых обработок в интерфейс • замена стандартной обработки 1С собственным вариантом • быстрое отображение объектов, захваченных в хранилище • инструменты рефакторинга
  3. 3. 3 Конфигуратор как рабочий инструмент программиста 1С Конфигуратор 1С 8.3 — среда разработки информационных систем на базе платформы «1С Предприятие». Разработка прикладного решения обычно называется программирование или конфигурированием 1С. С помощью данной среды возможно произвести не только доработку какого-либо решения но и разработать собственную, полноценную конфигурацию.
  4. 4. 4 Закладки Список закладок Нажимаем клавиши «Ctrl + Shift + F2», и перед нами откроется окно с полным списком установленных закладок Нажимаем ALT + F2 и получаем закладку (слева от строки отобразиться квадратик). По закладкам легко передвигаться нажатием клавиши F2
  5. 5. 5 Контекстная подсказка Настройка с помощью пункта меню Сервис — Параметры, закладка Модули — Контекстная подсказка Нажимаем ALT + F2 и получаем закладку (слева от строки отобразиться квадратик). По закладкам легко передвигаться нажатием клавиши F2
  6. 6. 6 Контекстная подсказка Существует документ “Система стандартов и методик разработки конфигураций для платформы 1С:Предприятие 8”, в котором описаны рекомендации фирмы “1С” к разрабатываемому программному коду. http://its.1c.ru/db/v8std#browse:13:-1 Следующей полезной особенностью новой контекстной подсказки является возможность отображать параметры пользовательских процедур и функций.
  7. 7. 7 Группировка строк программного кода Для выделения области текста введены две новые инструкции препроцессора #Область и #КонецОбласти. #Область ПОИСК_КОНТРАГЕНТОВ Функция ПоискКонтрагентаПоПаспортнымДанным() //Код КонецФункции Функция ПоискКонтрагентаПоНаименованию() //Код КонецФункции #КонецОбласти #Область ИМПОРТ_КОНТРАГЕНТОВ Функция ИмпортКонтрагентаИзExcel() //Код КонецФункции Функция ИмпортКонтрагентаИзJSON() //Код КонецФункции #КонецОбласти
  8. 8. 8 Выделение цветом конструкций
  9. 9. 9 Выделение цветом конструкций
  10. 10. 10 Выделение цветом конструкций
  11. 11. 11 Окно «Локальные переменные» Реализовано в версии 8.3.7.1759
  12. 12. 12 Окно «Локальные переменные» Значения примитивных типов вы можете изменить прямо в ячейке «Значение»: А для изменения других значений вы можете воспользоваться окном ввода выражений:
  13. 13. 13 Встраивание часто используемых обработок в интерфейс В платформе 1С предприятие есть очень удобные стандартные функции: 1. Активные пользователи; 2. Журнал регистрации; 3. Поиск ссылок на объект; 4. Проведение документов; 5. Удаление помеченных объектов; 6. Управление внешними источниками данных; 7. Управление итогами; 8. Управление полнотекстовым поиском; 9. Управление расширениями конфигурации
  14. 14. 14 Встраивание часто используемых обработок в интерфейс
  15. 15. 15 Встраивание часто используемых обработок в интерфейс Список обработок: 1. Активные пользователи - "v8res://mngbase/StandardActiveUsers.epf"; 2. Журнал регистрации - "v8res://mngbase/StandardEventLog.epf"; 3. Поиск ссылок на объект - "v8res://mngbase/StandardFindByRef.epf"; 4. Проведение документов - "v8res://mngbase/StandardDocumentsPosting.epf"; 5. Удаление помеченных объектов - "v8res://mngbase/StandardDeleteMarkedObjects.epf"; 6. Управление внешними источниками данных - "v8res://mngbase/StandardExternalDataSourcesManagement.epf"; 7. Управление итогами - "v8res://mngbase/StandardTotalsManagement.epf"; 8. Управление полнотекстовым поиском - "v8res://mngbase/StandardFullTextSearchManagement.epf"; 9. Управление расширениями конфигурации - "v8res://mngbase/StandardExtensionsManagement.epf"; И еще одна обработка. Не входит в стандартные, но тоже полезна для ознакомления. 10. Конструктор запросов на управляемых формах - "v8res://mngbase/QueryWizard.epf";
  16. 16. 16 Замена стандартной обработки 1С собственным вариантом Изменение стандартной обработки. Подмена стандартной обработки.
  17. 17. 17 Инструменты рефакторинга Команды: “Выделить фрагмент” “Переименовать” “Преобразовать модальный вызов” “Преобразовать в асинхронную процедуру” “Выделить в асинхронную процедуру”
  18. 18. 18 Выделить фрагмент
  19. 19. 19 Переименовать
  20. 20. 20 Преобразовать модальный вызов
  21. 21. 21 Преобразовать в асинхронную процедуру
  22. 22. 22 Выделить в асинхронную процедуру
  23. 23. 23 Источники 1. http://www.koderline.ru/expert/programming/article- vspomogatelnye-funktsii-v-1s/ 2. http://курсы-по-1с.рф/articles/статьи-по-платформе- улучшения-в-8-3/ 3. http://v8.1c.ru/o7/201506debug/index.htm 4. http://iantonov.me/page/neskolko-poleznyh-vozmozhnostej- redaktora-koda-1spredprijatie-8-o-kotoryh-ne-vse-znajut 5. https://infostart.ru/public/538300/ 6. http://infostart.ru/public/369487/ 7. http://programmist1s.ru/konfigurator-1s/ 8. http://v8.1c.ru/o7/201312ref/
  24. 24. 24 Спасибо за внимание! Если у Вас возникли вопросы – свяжитесь с нами. Мы всегда рады помочь!

×