• Share
  • Email
  • Embed
  • Like
  • Save
  • Private Content
Aula04
 

Aula04

on

  • 935 views

Aula 04 - L

Aula 04 - L

Statistics

Views

Total Views
935
Views on SlideShare
856
Embed Views
79

Actions

Likes
0
Downloads
0
Comments
0

1 Embed 79

http://www.paiossin.com 79

Accessibility

Categories

Upload Details

Uploaded via as Microsoft PowerPoint

Usage Rights

© All Rights Reserved

Report content

Flagged as inappropriate Flag as inappropriate
Flag as inappropriate

Select your reason for flagging this presentation as inappropriate.

Cancel
  • Full Name Full Name Comment goes here.
    Are you sure you want to
    Your message goes here
    Processing…
Post Comment
Edit your comment

    Aula04 Aula04 Presentation Transcript

    • Lógica de programação Prof: Eduardo Rossit Paiossin
    • Conteúdo da aula– Estruturas de controle sequencial, condicional simples, condicional composto e condicional encadeada.– Capítulo 3 do livro
    • Estruturas de controle• Como vimos até agora para fazer um algoritmo são necessários vários comandos dentro de uma determinada estrutura. Como num quebra cabeças em que as peças (comandos) são colocados em lugares específicos (estruturas) Essas estruturas chamadas “Estruturas de controle” permitem o controle do fluxo de execução dos comandos.
    • Estruturas de controle sequencial• A estrutura de controle sequencial é a que conhecemos. Essa estrutura significa executar os passos a passos conforme a ”receita” de procedimentos.• Essa estrutura é também conhecida como estrutura de comandos Linear. Algoritmo <Escreva_Nome> Início NOME: literal leia PESSOA escreva PESSOA fim
    • Estruturas de controle condicional• Vem da necessidade de se tomar decisões.• Diariamente nos vemos obrigados a tomar decisões e cada decisão implica em ações e/ou resultados diferentes. Na logica de programação isso também ocorre. Para tomar uma decisão devemos utilizar uma estrutura de controle condicional, também conhecida como Estrutura de controle Decisória ou de Decisão ou Estrutura de Controle Alternativa.
    • Estruturas de controle condicional simples• Para entendermos esta estrutura vamos pensar no seguinte problema.• Leia o valor das vendas de um funcionário; se o valor das vendas ultrapassar R$1000,00 reais o funcionário receberá um bônus de R$ 10,00.• Para solucionar esse problema temos que fazer a pergunta: “o valor das vendas ultrapassou R$1000,00?” se a resposta for positiva adicione ao salário do funcionário R$ 10,00.
    • Estruturas de controle condicional simples• Exemplo (pseudocodigo):• se VENDA > 1000• então SALARIO <- SALARIO + 10• fim-se
    • Estruturas de controle condicional simples• Exemplo: (Fluxograma) N <condição> S comandos
    • Exercício• Crie o algoritmo para os itens a seguir, representando-os em pseudocódigo:1. Ler dois números e verificar qual é menor e qual é maior.2. Ler os nomes e os pesos de duas pessoas e imprimir os dados da pessoa mais gorda.
    • Exercício - Respostas1. Pseudocódigo: início | NUM1, NUM2 : numérico | leia "Digite o primeiro número:", NUM1 | leia "Digite o segundo número:", NUM2 | se NUM1 > NUM2 | | então escreva "O número ",NUM1," é o maior." | | escreva "O número ",NUM2," é o menor." | fim-se | se NUM1 < NUM2 | | então escreva "O número ",NUM2," é o maior." | | escreva "O número ",NUM1," é o menor." | fim-se fim
    • Exercício - Respostas2. Pseudocódigo: início | NOME1, NOME2 : literal | PESO1, PESO2 : numérico | leia "Digite o primeiro nome:", NOME1 | leia "Digite o peso da primeira pessoa:", PESO1 | leia "Digite o segundo nome:", NOME2 | leia "Digite o peso da segunda pessoa:", NUM2 | se PESO1 > PESO2 | | então escreva "A pessoa ",NOME1," é a mais gorda com ",PESO1,"quilos." | fim-se | se PESO1 < PESO2 | | então escreva "A pessoa ",NOME2," é a mais gorda com ",PESO2,"quilos." | fim-se fim
    • Estruturas de controle condicional composta• Difere-se da “condicional simples” pelo fato de que a condicional simples possibilita a execução de comandos apenas se a condição for verdadeira, já a “condicional composta” permite a execução te comandos tanto se a condição for verdadeira quanto se for falsa.
    • Estruturas de controle condicional composta• Exemplo: (pseudocódigo)MEDIA: numéricoleia MEDIAse MEDIA >= 5.0 então escreva “Aluno aprovado” senão escreva “Aluno reprovado”fim-se
    • Estruturas de controle condicional composta• Exemplo: (Fluxograma) S N <condição> comandos comandos
    • ExercícioObserve o trecho do algoritmo a seguir.início | se X >= Y | | então W  falso | | senão W  verdadeiro | fim-sefim O valor armazenado na variável W é verdadeiro se: ( )X<Y ( )X>Y ( ) X >= Y ( ) X <= Y ( )X=Y ( ) Nenhuma das anteriores
    • Exercício - CorreçãoObserve o trecho do algoritmo a seguir.início | se X >= Y | | então W  falso | | senão W  verdadeiro | fim-sefim O valor armazenado na variável W é verdadeiro se: ( X)X<Y ( )X>Y ( ) X >= Y ( ) X <= Y ( )X=Y ( ) Nenhuma das anteriores
    • Estruturas de controle condicional composta encadeada• Utilizamos esta estrutura de controle para problemas em que que temos vários testes/decisões para tomar e uma decisão depende da outra.
    • Estruturas de controle condicional composta encadeada• Exemplo (pseudocodigo) Algoritmo <Calcula_media> Inicio NOTA1, NOTA2, MEDIA: numérico leia NOTA1, NOTA2 MEDIA <- (NOTA1+NOTA2)/2 se MEDIA > 6 então escreva “Média superior a 6” senão se MEDIA = 6 então escreva “Média igual a 6” senão escreva “Média inferior a média mínima” fim-se fim-se fim
    • Estruturas de controle condicional composta encadeada <condição> comandos <condição2> comandos comandos
    • Exercícios1) Uma empresa paga a seus funcionários R$ 1,00 de comissão para cada produto vendido, entretanto, se forem vendidos mais de 250 produtos, o valor aumenta para R$ 1,50. Se a quantidade for superior a 500 produtos, o valor da comissão sobe para R$ 2,00. Monte um algoritmo para ler o nome de um funcionário e a quantidade de produtos que ele vendeu. Esse algoritmo também deverá imprimir o nome do funcionário e o total de comissão que ele vai receber.
    • Exercícios - RespostaPseudocódigo: início | FUNCIONARIO : literal | QTDVENDIDA, COMISSAO : numérico | leia "Digite o nome do funcionário:", FUNCIONARIO | leia "Digite a quantidade de produtos vendidos:",QTDVENDIDA | se QTDVENDIDA > 500 | | então COMISSAO QTDVENDIDA * 2 | | senão se QTDVENDIDA <= 500 e QTDVENDIDA > 250 | | | então COMISSAO QTDVENDIDA * 1,5 | | | senão COMISSAO QTDVENDIDA | | fim-se | fim-se | escreva "Funcionário: ",FUNCIONARIO | escreva "Valor da comissão: ",COMISSAO fim
    • Exercícios – Para entregar1) Faça um pseudocódigo e um fluxograma que leia um número inteiro e mostre uma mensagem indicando se este número é par ou ímpar, e se é positivo ou negativo.
    • Exercícios – Para entregar2) Desenvolva um pseudocódigo e um fluxograma que: Leia 4 (quatro) números; Calcule o quadrado de cada um; Se o valor resultante do quadrado do terceiro for >= 1000, imprima-o e finalize; Caso contrário, imprima os valores lidos e seus respectivos quadrados.
    • Exercícios – Para entregar3) Elabore um algoritmo que dada a idade de um atleta classifique-o em uma das seguintes categorias: Infantil A = 5 a 7 anos Infantil B = 8 a 11 anos Juvenil A = 12 a 13 anos Juvenil B = 14 a 17 anos Adultos = Maiores de 18 anos
    • • Bibliografia Para a preparação da aula foi utilizado o livro do curso entregue pelo SENAC