EXCEL – LEZIONEEXCEL – LEZIONE
FUNZIONI PARTEFUNZIONI PARTE
11
FUNZIONI DI UTILIZZO SPECIFICO :FUNZIONI DI UTILIZZO SPECIF...
Come trattare il testoCome trattare il testo
in Excelin Excel ??
 Determinare seDeterminare se
alcune cellealcune celle
c...
Esempi di stringheEsempi di stringhe
 La stringa “0815546734” è un numero diLa stringa “0815546734” è un numero di
telefo...
Caratteristiche delleCaratteristiche delle
stringastringa
 Lunghezza predefinita – In ExcelLunghezza predefinita – In Exc...
Funzioni di estrazioneFunzioni di estrazione
 Essendo una stringa una sequenza diEssendo una stringa una sequenza di
cara...
Esempi delle funzioniEsempi delle funzioni
DESTRA e SINISTRADESTRA e SINISTRA
 La funzioneLa funzione
=DESTRA(“ALBERTO”;2...
Estrazione di unaEstrazione di una
qualunque sequenza diqualunque sequenza di
carattericaratteri
 Si i caratteri devono e...
Funzione SEFunzione SE
 E’ una funzione di controllo che permetteE’ una funzione di controllo che permette
di eseguire de...
Sintassi del SESintassi del SE
 Test è una condizione sulle celle o su unTest è una condizione sulle celle o su un
valore...
Esempio 1Esempio 1
Prendiamo la tabella ePrendiamo la tabella e
supponiamo di volersupponiamo di voler
scrivere SI e NO al...
Esempio 1 - FormulaEsempio 1 - Formula
 Basterà scrivere la formula:Basterà scrivere la formula:
=SE(B2>5;”SI”;”NO”) per ...
SE nidificatiSE nidificati
 La verifica di più condizioni simultaneamente comportaLa verifica di più condizioni simultane...
Come scriverla in unCome scriverla in un
foglio di lavoro ?foglio di lavoro ?
Scrivo SE per il primo Test:Scrivo SE per il...
Risolvere il problema:Risolvere il problema:
 Su un insieme di prodotti si applica uno sconto del 10% se laSu un insieme ...
Upcoming SlideShare
Loading in...5
×

Excel Funzioni per la manipolazione delle stringhe, funzioni condizionali semplici

634

Published on

Funzioni di Excel per la manipolazione di stringhe, e condizionali

Published in: Technology
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total Views
634
On Slideshare
0
From Embeds
0
Number of Embeds
3
Actions
Shares
0
Downloads
0
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Excel Funzioni per la manipolazione delle stringhe, funzioni condizionali semplici

  1. 1. EXCEL – LEZIONEEXCEL – LEZIONE FUNZIONI PARTEFUNZIONI PARTE 11 FUNZIONI DI UTILIZZO SPECIFICO :FUNZIONI DI UTILIZZO SPECIFICO : FUNZIONI DI TRATTAMENTO TESTO;FUNZIONI DI TRATTAMENTO TESTO; SE MULTIPLISE MULTIPLI
  2. 2. Come trattare il testoCome trattare il testo in Excelin Excel ??  Determinare seDeterminare se alcune cellealcune celle contengono dellecontengono delle parti di testoparti di testo specifico.specifico.  Il testo in Excel èIl testo in Excel è considerato allaconsiderato alla stregua di unstregua di un qualunque linguaggioqualunque linguaggio di programmazionedi programmazione una stringauna stringa sequenza finita disequenza finita di carattericaratteri alfanumerici.alfanumerici.
  3. 3. Esempi di stringheEsempi di stringhe  La stringa “0815546734” è un numero diLa stringa “0815546734” è un numero di telefono ma comunque una sequenzatelefono ma comunque una sequenza alfanumericaalfanumerica  La stringa “0001” potrebbe essere unLa stringa “0001” potrebbe essere un codice di una merce di magazzinocodice di una merce di magazzino  ““LTRGPP73E59F839Z” potrebbe essereLTRGPP73E59F839Z” potrebbe essere un codice fiscale ma comunque unaun codice fiscale ma comunque una stringa.stringa.
  4. 4. Caratteristiche delleCaratteristiche delle stringastringa  Lunghezza predefinita – In ExcelLunghezza predefinita – In Excel inserendo la funzioneinserendo la funzione =Lunghezza(Stringa) il programma=Lunghezza(Stringa) il programma calcola la lunghezza ad esempiocalcola la lunghezza ad esempio =Lunghezza(“ciao”) fornisce come risultato=Lunghezza(“ciao”) fornisce come risultato 4.4.
  5. 5. Funzioni di estrazioneFunzioni di estrazione  Essendo una stringa una sequenza diEssendo una stringa una sequenza di caratteri posso estrarre dei carattericaratteri posso estrarre dei caratteri specifici a sinistra e a destra.specifici a sinistra e a destra.  Le funzioni si denominano SINISTRA eLe funzioni si denominano SINISTRA e DESTRA con la sintassi:DESTRA con la sintassi: SINISTRA(STRINGA;LUNGHEZZA)SINISTRA(STRINGA;LUNGHEZZA) DESTRA(STRINGA;LUNGHEZZA)DESTRA(STRINGA;LUNGHEZZA)
  6. 6. Esempi delle funzioniEsempi delle funzioni DESTRA e SINISTRADESTRA e SINISTRA  La funzioneLa funzione =DESTRA(“ALBERTO”;2) fornisce la=DESTRA(“ALBERTO”;2) fornisce la sottostringa “TO”;sottostringa “TO”; =SINISTRA(“ALBERTO”;3) fornisce la=SINISTRA(“ALBERTO”;3) fornisce la sottostringa “ALB”;sottostringa “ALB”;
  7. 7. Estrazione di unaEstrazione di una qualunque sequenza diqualunque sequenza di carattericaratteri  Si i caratteri devono essere estratti aSi i caratteri devono essere estratti a partire dall’interno della stringa nonpartire dall’interno della stringa non dall’esterno si utilizza la funzione:dall’esterno si utilizza la funzione: STRINGA.ESTRAI(Stringa;inizio;lunghezza)STRINGA.ESTRAI(Stringa;inizio;lunghezza) ad esempioad esempio STRINGA.ESTRAI(“ALBERTO”;3;3) restituisceSTRINGA.ESTRAI(“ALBERTO”;3;3) restituisce la sottostringa “BER”la sottostringa “BER”
  8. 8. Funzione SEFunzione SE  E’ una funzione di controllo che permetteE’ una funzione di controllo che permette di eseguire delle operazioni in base aldi eseguire delle operazioni in base al risultato di una condizione (Test). Neglirisultato di una condizione (Test). Negli algoritmi la condizione si rappresentaalgoritmi la condizione si rappresenta graficamentegraficamente test Istruzione istruzione vero falso In un foglio tale struttura si traduce in: =SE(TEST;ISTRUZIONE;ISTRUZIONE)
  9. 9. Sintassi del SESintassi del SE  Test è una condizione sulle celle o su unTest è una condizione sulle celle o su un valore o testo ad esempiovalore o testo ad esempio A1>A2A1>A2 A1=4A1=4 C1<3C1<3 A1=“SUFFICIENTE”A1=“SUFFICIENTE” Istruzione sono le azioni da intraprendereIstruzione sono le azioni da intraprendere se si verifica e non si verifica il test.se si verifica e non si verifica il test.
  10. 10. Esempio 1Esempio 1 Prendiamo la tabella ePrendiamo la tabella e supponiamo di volersupponiamo di voler scrivere SI e NO allascrivere SI e NO alla colonna superato.colonna superato. ALUNNO VOTO SUPERATO ESPOSITO 4 ANTONINI 5 GIANCHI 7 ERRICO 5
  11. 11. Esempio 1 - FormulaEsempio 1 - Formula  Basterà scrivere la formula:Basterà scrivere la formula: =SE(B2>5;”SI”;”NO”) per la riga 2=SE(B2>5;”SI”;”NO”) per la riga 2 e così via per le altre righe.e così via per le altre righe.
  12. 12. SE nidificatiSE nidificati  La verifica di più condizioni simultaneamente comportaLa verifica di più condizioni simultaneamente comporta l’utilizzo di SE nidificati.l’utilizzo di SE nidificati. Una struttura algoritmica potrebbe essere:Una struttura algoritmica potrebbe essere:
  13. 13. Come scriverla in unCome scriverla in un foglio di lavoro ?foglio di lavoro ? Scrivo SE per il primo Test:Scrivo SE per il primo Test: =SE(TEST 1;SE(TEST 2;I2;I1);I3))=SE(TEST 1;SE(TEST 2;I2;I1);I3)) si noti che la funzione nidificata interna sisi noti che la funzione nidificata interna si esegue nel Vero.esegue nel Vero. Fare attenzione alle parentesi.Fare attenzione alle parentesi.
  14. 14. Risolvere il problema:Risolvere il problema:  Su un insieme di prodotti si applica uno sconto del 10% se laSu un insieme di prodotti si applica uno sconto del 10% se la quantità supera le 10 unità ma inferiore a 50; del 14% da 50 fino aquantità supera le 10 unità ma inferiore a 50; del 14% da 50 fino a 100 prodotti; del 20% oltre).Calcolare l’importo totale dovuto dai100 prodotti; del 20% oltre).Calcolare l’importo totale dovuto dai vari clienti secondo il prospetto riportatovari clienti secondo il prospetto riportato Notiamo un SE a tre livelli di nidificazione per rispettare tutte le possibilità richieste dal problema.

×