Broffice calc prf_marcat_praet_2013

684 views

Published on

  • Be the first to comment

  • Be the first to like this

Broffice calc prf_marcat_praet_2013

  1. 1. Professor Fenelon Portilho INFORMÁTICA PARA CONCURSOS PRF 1
  2. 2. O EDITAL 2) Edição de textos, planilhas e apresentações (ambiente BrOffice) 2
  3. 3. Primeiros passos O Calc é um programa freeware e gratuito que faz parte do LibreOffice e possibilita a criação, edição e apresentação de planilhas eletrônicas. 3
  4. 4. 4
  5. 5. A JANELA DO LibreOffice Calc 11.048.576 linhas Colunas A-AMJ Alça de preenchimento Clicando com o botão direito do mouse na palavra soma temos outras opções 5
  6. 6. Noções Básicas Cada planilha contém colunas que são dispostas lado a lado, e linhas que correm de cima a baixo, assim, são traçadas as linhas de grade da planilha. As colunas são rotuladas com letras e as linhas são numeradas. Cada planilha possui 1.048.576 linhas e as colunas vão até AMJ. O endereço da célula ativa pode ser visualizado na Barra de Endereços. Na figura a cima a célula ativa é D8. Célula: é o cruzamento, a intersecção de uma linha com uma coluna. É aqui que colocaremos valores, referências e formatos. Valores: Um valor pode representar um dado numérico ou textual entrado pelo usuário ou pode ser resultado de uma fórmula ou função. Fórmulas: A fórmula é uma expressão matemática dada ao computador (o usuário tem que montar a fórmula) para calcular um resultado, é a parte inteligente da planilha; sem as fórmulas a planilha seria um amontoado de textos e números. Funções: São fórmulas pré-definidas para pouparem tempo e trabalho na criação de uma equação. Edição dos dados O Calc aceita a inserção de dados dos tipos: textos, números, datas, horas e fórmulas. Para se familiarizar com o manuseio das ferramentas de edição do Calc vamos criar uma lista de endereços. Quando iniciar o Calc observe que a primeira célula da planilha é a célula com endereço A1 e já está ativa toda vez que se abre uma planilha nova.
  7. 7. Movimentação na planilha 7
  8. 8. TIPOS DE FUNÇÕES 8
  9. 9. BrOffice.org Algumas extensões Formato do documento Texto e Modelo de Texto do OpenDocument Extensão do arquivo *.odt e *.ott Documento mestre do OpenDocument *.odm Documento HTML .html Modelo de documento HTML *.oth Planilha e Modelo de Planilha do OpenDocument *.ods e *.ots Desenho e Modelo de Desenho do OpenDocument *.odg e *.otg Apresentação e Modelo de Apresentação do OpenDocument *.odp e *.otp 9
  10. 10. A tela de abertura do Calc 10
  11. 11. O MENU DE ATALHO DO CALC 11
  12. 12. FORMATANDO CÉLULAS NO CALC 12
  13. 13. FORMATAÇÕES Algumas possibilidades do CALC 13
  14. 14. CÉLULAS CONTENDO TEXTO 14
  15. 15. OS OPERADORES DO CALC + (sinal de adição) Adição =(3+3) – (sinal de subtração) Subtração =(3–1) * (asterisco) Multiplicação =(3*3) / (sinal de divisão) Divisão =(3/3) % (sinal de porcentagem) Porcentagem =(20%) ^ (acento circunflexo) Exponenciação =(3^2) = (sinal de igual) Igual a =(A1=B1) > (sinal de maior que) Maior que =(A1>B1) < (sinal de menor que) Menor que =(A1<B1) <>(sinal de menor e maior que) Diferente =(A1<>B1) <=(sinal de menor e igual) Menor ou igual =(A1<>B1) >=(sinal de maior e igual) Maior ou igual =(A1<>B1) 15
  16. 16. Operadores do CALC & (E comercial) Conecta, ou concatena, dois valores para produzir um valor de texto contínuo (“bem"&"sucedido) : (dois-pontos) Operador de intervalo, que produz uma referência para todas as células entre duas referências, incluindo as duas referências (B5:B15) ; (ponto e vírgula) Operador de união, que combina diversas referências em uma referência (SOMA(B5:B15;D5:D15)) (exclamação) Operador de interseção, que produz sobre referência a células comuns a duas referências no CALC (B7:B7!C6:C8) . (Ponto) No CALC serve para separar a célula da planilha quando o cálculo indica uma célula em outra planilha (Soma(B2;Plan1.C1)) 16
  17. 17. Os operadores 17
  18. 18. UTILIZANDO FUNÇÕES =SOMA(A1:A5) SOME O CONTEÚDO DAS CÉLULAS A1 ATÉ A5 =SOMA(A1;A5;B2) =SOMA(A1:A5;B2) SOME O CONTEÚDO DAS CÉLULAS A1, A5 E B2 SOME O CONTEÚDO DAS CÉLULAS A1 ATÉ A5 E EM SEGUIDA ADICIONE O VALOR DE B2 =SOMA(A:A;D:D) SOME O CONTEÚDO DAS COLUNAS A e D =SOMA(D4;45) SOME O CONTEÚDO DA CÉLULA D4 COM O NÚMERO 45 =SOMA(D4;D4) SOME O CONTEÚDO DA CÉLULA D4 COM ELA MESMA =SOMA(Plan2:Plan5.C3) SACHA=SOMA(XUXA;SZAFIR) SOME AS CÉLULAS C3 DA PLANILHA 2 ATÉ PLANILHA 5 ( só possível com : - escreva Plan e não PLAN e não se esqueça que no Calc a ! vira . ) SOME O CONTEÚDO DAS CÉLULAS BATIZADAS COM O NOME DE XUXA E SZAFIR (coloque o resultado na célula SACHA) 18
  19. 19. ENTENDENDO EXPRESSÕES =SOMA(IV:IV;D:D) =SOMA(AB:AB;333:333) =SOMA(P:GA;222:333) SOME O CONTEÚDO DAS COLUNAS IV e D SOME O CONTEÚDO DA COLUNA AB e LINHA 333 SOME O CONTEÚDO DAS COLUNAS P ATÉ GA COM LINHAS 222 ATÉ 333 19
  20. 20. Como ficam as operações 20
  21. 21. Prova CESPE Agente PF 2012 29 Em uma planilha CALC, para somar os valores contidos nas células de B2 até B16 e colocar o resultado na célula B17, é suficiente que o usuário digite, na célula B17, a fórmula =SOMA(B2:B16) e tecle Enter. Certa, porque cobra conhecimento básico de soma em intervalo de células 21
  22. 22. E 22
  23. 23. Os botões do Calc 23
  24. 24. Células contendo texto no Calc 24
  25. 25. AS PRIORIDADES NO CALC 1) POTENCIAÇÃO ^ 2) MULTIPLICAÇÃO E DIVISÃO * / 3) SOMA E SUBTRAÇÃO + =5+3*2-4^2/2*3-5 =5+3*2-16/2*3-5 =5+6-16/2*3-5 =5+6-8*3-5 =5+6-24-5 -18 25
  26. 26. ALTERANDO AS PRIORIDADES =5+(3*(2-4)^((2/2)*3)-5) =5+(3*(2-4)^(1*3)-5) =5+(3*-2^3-5) =5+(3*-8-5) =5+(-24-5) =5+(-29) =5-29 = -24 26
  27. 27. OS INTERVALOS DE CÉLULAS 27
  28. 28. As funções aninhadas = 8*(SOMA(A1;MULT(C3:C8))) 28
  29. 29. Algumas funções • Soma - =Soma(A1;A2) – Soma(5;3) – 8 – Aceita : e ; • Média - =Média(A1:A5) - Média(5;3) – 4 – Aceita : e ; • Moda – Modo - = Modo(A1;A5) – Modo(5;8;3;8) = 8 - Aceita : e ; #n/d – amodal – bimodal(menor) • Mínimo – =Mínimo(A1;A5) - =Mínimo(2;3;5) – 2 – Aceita : e ; • Máximo – =Máximo(A1;A5) – =Máximo(2;4;5) – 5 – Aceita : e ; • Menor – =Menor(A1:A5;2) - Cuidado com repetições – Só aceita : com ; • Maior – =Maior(A1:A5;2) - Cuidado com repetições - Só aceita : com ; • Mediana – =Med(A1:A5) – =Med(2;5;4) – 4 – Aceita : e ; 29
  30. 30. Algumas funções • Multiplicação – Mult(A1;A5) - =Mult(2;5) – 10 – Aceita : e ; • Potência – =Potência(A1;2) - =Potência(A1;A5) – Os números podem ser inteiros, fracionários ou decimais) – Só aceita ; • AGORA - =AGORA() - 6/07/2010 21:00 • HOJE - =HOJE() – 6/07/2010 • INT(6,89) – 6 • =ARRED(6,85;1) – 6,9 - ARRED(86,85;-1) – 90 – ARRED(8,68;-1) – 10 • =CONT.VALORES(intervalo) – Conta quantas células contêm algum conteúdo no intervalo. • =CONT.NUM(intervalo) – Conta quantas células contêm números no intervalo. • =CONTAR.VAZIO(intervalo) – Conta quantas células estão vazias no intervalo. • =E(8=8; 6=8) = Falso – Retorna Verdadeiro somente se os dois blocos forem verdadeiros • =OU(5=5; 4=2) = Verdadeiro – Retorna Verdadeiro se pelo menos um dos blocos for verdadeiro. 30
  31. 31. C 31
  32. 32. APLICANDO PROTEÇÃO 32
  33. 33. AS LISTAS(séries) 1º TRIMESTRE 2º TRIMESTRE 3º TRIMESTRE 33
  34. 34. OS ERROS 34
  35. 35. Os códigos de erros 35
  36. 36. Os códigos de erros 36
  37. 37. A REFERÊNCIA CIRCULAR 37
  38. 38. Copiando e colando células 38
  39. 39. Editar – colar especial no Calc 39
  40. 40. PRATICANDO COPIAR E COLAR VAMOS SUPOR QUE UMA PESSOA COPIE O CONTEÚDO DA CÉLULA D5 QUE CONTENHA A FÓRMULA = B3 + F12 E COLE EM H8 D5 = B3 + F12 SE FOSSE: H8 = F6 + J15 D5 = B$3 + $F12 + $C$3 H8 = F$3 + $F15 + $C$3 SE QUISERMOS COLAR EM B1, FICARÁ: D5 = B3 + F12 SE FOSSE: D5 = B$3 + XUXA + $C$3 B1 = ?? + D8 O que resultaria em erro de referência #REF! H8 = F$3 + XUXA + $C$3 Os nomes de células também não se alteram 40
  41. 41. A FUNÇÃO SOMASE 41
  42. 42. A FUNÇÃO SE 42
  43. 43. E 43
  44. 44. A FUNÇÃO CONT.SE 44
  45. 45. CRIANDO GRÁFICOS INSERIR – GRÁFICO – NO CALC 45
  46. 46. O MENU ARQUIVO 46
  47. 47. O MENU ARQUIVO – Salvar Como 47
  48. 48. O MENU ARQUIVO – Visualizando Página 48
  49. 49. O MENU ARQUIVO – Imprimir 49
  50. 50. Menu EDITAR 50
  51. 51. Menu EDITAR 51
  52. 52. MENU EXIBIR 52
  53. 53. MENU INSERIR 53
  54. 54. Inserindo Função 54
  55. 55. Inserindo Função Continuação 55
  56. 56. MENU FORMATAR 56
  57. 57. MENU FORMATAR 57
  58. 58. FORMATAÇÃO CONDICIONAL 58
  59. 59. Menu Ferramentas 59
  60. 60. Rastreando Precedentes 60
  61. 61. Rastreando Dependentes 61
  62. 62. MENU DADOS 62
  63. 63. CLASSIFICANDO 63
  64. 64. Usando os botões de classificação A classificação através dos botões sempre ignora a primeira linha do intervalo selecionado pois a considera como linha de cabeçalho. Sempre classifica pela primeira coluna. 64
  65. 65. O AUTOFILTRO 65
  66. 66. Menu Janela – Congelando 66
  67. 67. Questão de concurso anterior 67
  68. 68. 68
  69. 69. 69
  70. 70. 70
  71. 71. 71
  72. 72. =/= do CALC 72
  73. 73. 73
  74. 74. Errado =/= do CALC Certo 74

×