SlideShare a Scribd company logo
ΕΝΔΕΙΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ ΑΕΠΠ ΠΛΗΡΟΦΟΡΙΚΗΣ
ΘΕΜΑ Α
Α1) 1. Σωστό 2. Λάθος 3.Λάθος 4. Σωστό 5.Λάθος
Α2) 1.α 2.γ 3.β 4.β 5.α
Α3) Οι τυπικές επεξεργασίες πινάκων είναι ;
• Υπολογισμός αθροισμάτων στοιχείων του πίνακα
• Εύρεση μεγίστου η του ελαχίστου στοιχείου
• Ταξινόμηση των στοιχείων του πίνακα
• Αναζήτηση ενός στοιχείου του πίνακα
• Συγχώνευση δύο πινάκων
Α4) α) Γράφος είναι μία δομή που αποτελείται από ένα σύνολο κόμβων (η σημείων η κορυφών) και ένα σύνολο
γραμμών (η ακμών η τόξων) που ενώνουν μερικούς ή όλους τους κόμβους. Ο γράφος αποτελεί την πιο γενική
δομή δεδομένων ,με την έννοια ότι όλες οι προηγούμενες δομές (δενδρα,λίστες) μπορούν να θεωρηθούν
περιπτώσεις γράφων
β) Οι τύποι των γράφων είναι δύο οι κατευθυνόμενοι γράφοι και οι μη κατευθυνόμενοι γράφοι.
ΘΕΜΑ Β
Β1) i <- 1
ΟΣΟ i <= 10 ΕΠΑΝΑΛΑΒΕ
j <- 20
ΟΣΟ j >= 1 ΕΠΑΝΑΛΑΒΕ
ΓΡΑΨΕ i* j
j <- j - 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
i <- i + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Β2) 1. Ι MOD 2=1 2. A[I,j]  κ 3. κ+2 4. λ 5 λ  λ+3
ΕΠΙΜΕΛΕΙΑ: ΠΑΝΟΠΟΥΛΟΣ ΧΡΗΣΤΟΣ, ΦΛΩΡΟΣ
ΓΙΑΝΝΗΣ, ΔΙΑΛΕΚΤΑΚΗΣ ΜΑΚΗΣ
ΕΤΟΣ : 2024
ΜΑΘΗΜΑ : ΑΕΠΠ ΤΑΞΗ : Γ’ ΛΥΚΕΙΟΥ
Β3)
Β4)
Α)
ΣΥΝΑΡΤΗΣΗ F(x):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: a
ΠΡΑΓΜΑΤΙΚΕΣ:y
ΑΡΧΗ
a<- 10.5
y<- x^2+4*a
F <-y
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Β)
ΔΙΑΒΑΣΕ a
b<- F(a)
ΓΡΑΨΕ α,b
ΘΕΜΑ Γ
ΠΡΟΓΡΑΜΜΑ ΘΓ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: MAX, I, CΕΠ, C, S, B, CMAX
ΧΑΡΑΚΤΗΡΕΣ: ON, MAXON
ΠΡΑΓΜΑΤΙΚΕΣ: MO
ΑΡΧΗ
MAX ← -1
CΕΠ ← 0
C ← 0
ΔΙΑΒΑΣΕ ON
ΟΣΟ ON <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
S ← 0
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 6
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ B
ΜΕΧΡΙΣ_ΟΤΟΥ B >= 0 ΚΑΙ B <= 100
S ← S + B
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
MO ← S/6
ΓΡΑΨΕ ON,MO
ΑΝ MO > 60 ΤΟΤΕ
ΓΡΑΨΕ 'ΕΠΙΤΥΧΩΝ'
CΕΠ ← CΕΠ + 1
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΑΠΟΤΥΧΩΝ'
ΤΕΛΟΣ_ΑΝ
ΑΝ MO > MAX ΤΟΤΕ
MO ← MAX
MAXON ← ON
CMAX ← 1
ΑΛΛΙΩΣ_ΑΝ MAX = MO ΤΟΤΕ
CMAX ← CMAX + 1
ΤΕΛΟΣ_ΑΝ
C ← C + 1
ΔΙΑΒΑΣΕ ON
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ CMAX = 1 ΤΟΤΕ
ΓΡΑΨΕ MAXON
ΑΛΛΙΩΣ
ΓΡΑΨΕ CMAX
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ CΕΠ/C*100
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
ΘΕΜΑ Δ
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ
!Δ1α
ΜΕΤΑΒΛΗΤΕΣ
ΧΑΡΑΚΤΗΡΕΣ:ΟΝ[10] , ΟΝΟΜΑ
!ΛΟΓΙΚΕΣ:
ΑΚΕΡΑΙΕΣ:Ι , J , ΘΕΣΗ
ΠΡΑΓΜΑΤΙΚΕΣ:ΠΩΛ[10,12] , MAX , ΣΠΩΛ1 , ΣΠΩΛ2 , ΣΠΩΛ
ΑΡΧΗ
!Δ1β
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
ΔΙΑΒΑΣΕ ΟΝ[Ι]
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 12
ΔΙΑΒΑΣΕ ΠΩΛ[Ι,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Δ2
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 12
MAX ΠΩΛ[1,J]
ΘΕΣΗ1
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 10
ΑΝ ΠΩΛ[Ι,J]>ΜΑΧ ΤΟΤΕ
MAX ΠΩΛ[1,J]
ΘΕΣΗΙ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΟΝ[ΘΕΣΗ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Δ3
ΣΠΩΛ10
ΣΠΩΛ20
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
ΣΠΩΛ1ΣΠΩΛ1+ ΠΩΛ[Ι,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ J ΑΠΟ 7 ΜΕΧΡΙ 2
ΣΠΩΛ2ΣΠΩΛ2+ ΠΩΛ[Ι,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΣΠΩΛ1>ΣΠΩΛ2 ΤΟΤΕ
ΓΡΑΨΕ ‘ΟΙ ΠΩΛΗΣΕΙΣ ΤΟΥ 1ΟΥ
ΕΞΑΜΗΝΟΥ ΕΙΝΑΙ ΜΕΓΑΛΥΤΕΡΕΣ ΑΠΟ ‘
& ‘ΤΙΣ ΠΩΛΗΣΕΙΣ ΤΟΥ 2ΟΥ
ΕΞΑΜΗΝΟΥ΄
ΑΛΛΙΩΣ_ΑΝ ΣΠΩΛ2>ΣΠΩΛ1 ΤΟΤΕ
ΓΡΑΨΕ ‘ΟΙ ΠΩΛΗΣΕΙΣ ΤΟΥ 2ΟΥ
ΕΞΑΜΗΝΟΥ ΕΙΝΑΙ ΜΕΓΑΛΥΤΕΡΕΣ ΑΠΟ ‘
& ‘ΤΙΣ ΠΩΛΗΣΕΙΣ ΤΟΥ 1ΟΥ
ΕΞΑΜΗΝΟΥ΄
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘ΟΙ ΠΩΛΗΣΕΙΣ ΤΟΥ 1ΟΥ
ΚΑΙ ΤΟΥ 2ΟΥ
ΕΙΝΑΙ ΙΣΕΣ’
ΤΕΛΟΣ_ΑΝ
!Δ4
ΔΙΑΒΑΣΕ ΟΝΟΜΑ
ΘΕΣΗ ΑΝΑΖ(ΟΝ,ΟΝΟΜΑ)
ΑΝ ΘΕΣΗ=0 ΤΟΤΕ
ΓΡΑΨΕ ‘’ ΑΝΥΠΑΡΚΤΟΣ ΠΩΛΗΤΗΣ’
ΑΛΛΙΩΣ
ΣΠΩΛ0
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 12
ΣΠΩΛ  ΣΠΩΛ + ΠΩΛ[ΘΕΣΗ,J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΣΠΩΛ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
!Δ5
ΣΥΝΑΡΤΗΣΗ ΑΝΑΖ(ΟΝ,ΟΝΟΜΑ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΧΑΡΑΚΤΗΡΕΣ:ΟΝ[10],ΟΝΟΜΑ
ΛΟΓΙΚΕΣ:ΒΡΕΘΗΚΕ
ΑΚΕΡΑΙΕΣ:Ι,ΘΕΣΗ
!ΠΡΑΓΜΑΤΙΚΕΣ:
ΑΡΧΗ
ΒΡΕΘΗΚΕΨΕΥΔΗΣ
ΘΕΣΗ0
Ι1
ΟΣΟ Ι<=10 ΚΑΙ ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
ΑΝ ΟΝ [Ι]=ΟΝΟΜΑ ΤΟΤΕ
ΒΡΕΘΗΚΕ ΑΛΗΘΗΣ
ΘΕΣΗΙ
ΤΕΛΟΣ_ΑΝ
ΙΙ+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝΑΖΘΕΣΗ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
ΑΠΑΝΤΗΣΕΙΣ - ΠΑΝΕΛΛΗΝΙΕΣ 2024 - 3 - πληροφορική.pdf

More Related Content

More from athinadimi

Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdfΑπαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
athinadimi
 
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdfΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdf
athinadimi
 
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdfΑπαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
athinadimi
 
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdfΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdf
athinadimi
 
Απαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdf
Απαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdfΑπαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdf
Απαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdf
athinadimi
 
ΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdfΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
athinadimi
 
Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024
Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024
Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024
athinadimi
 
ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024
ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024
ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024
athinadimi
 
Το θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα Ελληνικά
Το θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα ΕλληνικάΤο θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα Ελληνικά
Το θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα Ελληνικά
athinadimi
 
Θέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdf
Θέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdfΘέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdf
Θέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdf
athinadimi
 

More from athinadimi (10)

Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdfΑπαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
 
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdfΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ_ΠΑΝΕΛΛΗΝΙΕΣ-2024.pdf
 
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdfΑπαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
Απαντήσεις Χημείας - ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
 
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdfΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΛΑΤΙΝΙΚΑ__ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ.pdf
 
Απαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdf
Απαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdfΑπαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdf
Απαντήσεις Μαθηματικών-Πανελλήνιες-2024-3.pdf
 
ΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdfΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
ΑΠΑΝΤΗΣΕΙΣ_ΑΡΧΑΙΑ ΕΛΛΗΝΙΚΑ-ΠΑΝΕΛΛΗΝΙΕΣ 2024.pdf
 
Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024
Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024
Οι απαντήσεις στα Αρχαία: Τα θέματα που έπεσαν στις Πανελλήνιες 2024
 
ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024
ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024
ΑΠΑΝΤΗΣΕΙΣ ΕΚΘΕΣΗ ΕΠΑΛ ΓΙΑ ΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ 2024
 
Το θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα Ελληνικά
Το θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα ΕλληνικάΤο θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα Ελληνικά
Το θέμα που έπεσε στην Έκθεση στα ΕΠΑΛ και ολα τα θέμα στα Νέα Ελληνικά
 
Θέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdf
Θέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdfΘέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdf
Θέματα και Απαντήσεις - Νεοελληνική Γλώσσα 2024.pdf
 

ΑΠΑΝΤΗΣΕΙΣ - ΠΑΝΕΛΛΗΝΙΕΣ 2024 - 3 - πληροφορική.pdf

  • 1. ΕΝΔΕΙΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ ΑΕΠΠ ΠΛΗΡΟΦΟΡΙΚΗΣ ΘΕΜΑ Α Α1) 1. Σωστό 2. Λάθος 3.Λάθος 4. Σωστό 5.Λάθος Α2) 1.α 2.γ 3.β 4.β 5.α Α3) Οι τυπικές επεξεργασίες πινάκων είναι ; • Υπολογισμός αθροισμάτων στοιχείων του πίνακα • Εύρεση μεγίστου η του ελαχίστου στοιχείου • Ταξινόμηση των στοιχείων του πίνακα • Αναζήτηση ενός στοιχείου του πίνακα • Συγχώνευση δύο πινάκων Α4) α) Γράφος είναι μία δομή που αποτελείται από ένα σύνολο κόμβων (η σημείων η κορυφών) και ένα σύνολο γραμμών (η ακμών η τόξων) που ενώνουν μερικούς ή όλους τους κόμβους. Ο γράφος αποτελεί την πιο γενική δομή δεδομένων ,με την έννοια ότι όλες οι προηγούμενες δομές (δενδρα,λίστες) μπορούν να θεωρηθούν περιπτώσεις γράφων β) Οι τύποι των γράφων είναι δύο οι κατευθυνόμενοι γράφοι και οι μη κατευθυνόμενοι γράφοι. ΘΕΜΑ Β Β1) i <- 1 ΟΣΟ i <= 10 ΕΠΑΝΑΛΑΒΕ j <- 20 ΟΣΟ j >= 1 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ i* j j <- j - 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ i <- i + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Β2) 1. Ι MOD 2=1 2. A[I,j]  κ 3. κ+2 4. λ 5 λ  λ+3 ΕΠΙΜΕΛΕΙΑ: ΠΑΝΟΠΟΥΛΟΣ ΧΡΗΣΤΟΣ, ΦΛΩΡΟΣ ΓΙΑΝΝΗΣ, ΔΙΑΛΕΚΤΑΚΗΣ ΜΑΚΗΣ ΕΤΟΣ : 2024 ΜΑΘΗΜΑ : ΑΕΠΠ ΤΑΞΗ : Γ’ ΛΥΚΕΙΟΥ
  • 2. Β3) Β4) Α) ΣΥΝΑΡΤΗΣΗ F(x):ΠΡΑΓΜΑΤΙΚΗ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: a ΠΡΑΓΜΑΤΙΚΕΣ:y ΑΡΧΗ a<- 10.5 y<- x^2+4*a F <-y ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ Β) ΔΙΑΒΑΣΕ a b<- F(a) ΓΡΑΨΕ α,b
  • 3. ΘΕΜΑ Γ ΠΡΟΓΡΑΜΜΑ ΘΓ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: MAX, I, CΕΠ, C, S, B, CMAX ΧΑΡΑΚΤΗΡΕΣ: ON, MAXON ΠΡΑΓΜΑΤΙΚΕΣ: MO ΑΡΧΗ MAX ← -1 CΕΠ ← 0 C ← 0 ΔΙΑΒΑΣΕ ON ΟΣΟ ON <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ S ← 0 ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 6 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ B ΜΕΧΡΙΣ_ΟΤΟΥ B >= 0 ΚΑΙ B <= 100 S ← S + B ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ MO ← S/6 ΓΡΑΨΕ ON,MO ΑΝ MO > 60 ΤΟΤΕ ΓΡΑΨΕ 'ΕΠΙΤΥΧΩΝ' CΕΠ ← CΕΠ + 1 ΑΛΛΙΩΣ ΓΡΑΨΕ 'ΑΠΟΤΥΧΩΝ' ΤΕΛΟΣ_ΑΝ ΑΝ MO > MAX ΤΟΤΕ MO ← MAX MAXON ← ON CMAX ← 1 ΑΛΛΙΩΣ_ΑΝ MAX = MO ΤΟΤΕ CMAX ← CMAX + 1 ΤΕΛΟΣ_ΑΝ C ← C + 1 ΔΙΑΒΑΣΕ ON ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ CMAX = 1 ΤΟΤΕ ΓΡΑΨΕ MAXON ΑΛΛΙΩΣ ΓΡΑΨΕ CMAX ΤΕΛΟΣ_ΑΝ ΓΡΑΨΕ CΕΠ/C*100 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
  • 4. ΘΕΜΑ Δ ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ !Δ1α ΜΕΤΑΒΛΗΤΕΣ ΧΑΡΑΚΤΗΡΕΣ:ΟΝ[10] , ΟΝΟΜΑ !ΛΟΓΙΚΕΣ: ΑΚΕΡΑΙΕΣ:Ι , J , ΘΕΣΗ ΠΡΑΓΜΑΤΙΚΕΣ:ΠΩΛ[10,12] , MAX , ΣΠΩΛ1 , ΣΠΩΛ2 , ΣΠΩΛ ΑΡΧΗ !Δ1β ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10 ΔΙΑΒΑΣΕ ΟΝ[Ι] ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 12 ΔΙΑΒΑΣΕ ΠΩΛ[Ι,J] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !Δ2 ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 12 MAX ΠΩΛ[1,J] ΘΕΣΗ1 ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 10 ΑΝ ΠΩΛ[Ι,J]>ΜΑΧ ΤΟΤΕ MAX ΠΩΛ[1,J] ΘΕΣΗΙ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ΟΝ[ΘΕΣΗ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !Δ3 ΣΠΩΛ10 ΣΠΩΛ20 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6 ΣΠΩΛ1ΣΠΩΛ1+ ΠΩΛ[Ι,J] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ J ΑΠΟ 7 ΜΕΧΡΙ 2 ΣΠΩΛ2ΣΠΩΛ2+ ΠΩΛ[Ι,J] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ ΣΠΩΛ1>ΣΠΩΛ2 ΤΟΤΕ ΓΡΑΨΕ ‘ΟΙ ΠΩΛΗΣΕΙΣ ΤΟΥ 1ΟΥ ΕΞΑΜΗΝΟΥ ΕΙΝΑΙ ΜΕΓΑΛΥΤΕΡΕΣ ΑΠΟ ‘ & ‘ΤΙΣ ΠΩΛΗΣΕΙΣ ΤΟΥ 2ΟΥ ΕΞΑΜΗΝΟΥ΄
  • 5. ΑΛΛΙΩΣ_ΑΝ ΣΠΩΛ2>ΣΠΩΛ1 ΤΟΤΕ ΓΡΑΨΕ ‘ΟΙ ΠΩΛΗΣΕΙΣ ΤΟΥ 2ΟΥ ΕΞΑΜΗΝΟΥ ΕΙΝΑΙ ΜΕΓΑΛΥΤΕΡΕΣ ΑΠΟ ‘ & ‘ΤΙΣ ΠΩΛΗΣΕΙΣ ΤΟΥ 1ΟΥ ΕΞΑΜΗΝΟΥ΄ ΑΛΛΙΩΣ ΓΡΑΨΕ ‘ΟΙ ΠΩΛΗΣΕΙΣ ΤΟΥ 1ΟΥ ΚΑΙ ΤΟΥ 2ΟΥ ΕΙΝΑΙ ΙΣΕΣ’ ΤΕΛΟΣ_ΑΝ !Δ4 ΔΙΑΒΑΣΕ ΟΝΟΜΑ ΘΕΣΗ ΑΝΑΖ(ΟΝ,ΟΝΟΜΑ) ΑΝ ΘΕΣΗ=0 ΤΟΤΕ ΓΡΑΨΕ ‘’ ΑΝΥΠΑΡΚΤΟΣ ΠΩΛΗΤΗΣ’ ΑΛΛΙΩΣ ΣΠΩΛ0 ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 12 ΣΠΩΛ  ΣΠΩΛ + ΠΩΛ[ΘΕΣΗ,J] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ΣΠΩΛ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ !Δ5 ΣΥΝΑΡΤΗΣΗ ΑΝΑΖ(ΟΝ,ΟΝΟΜΑ):ΑΚΕΡΑΙΑ ΜΕΤΑΒΛΗΤΕΣ ΧΑΡΑΚΤΗΡΕΣ:ΟΝ[10],ΟΝΟΜΑ ΛΟΓΙΚΕΣ:ΒΡΕΘΗΚΕ ΑΚΕΡΑΙΕΣ:Ι,ΘΕΣΗ !ΠΡΑΓΜΑΤΙΚΕΣ: ΑΡΧΗ ΒΡΕΘΗΚΕΨΕΥΔΗΣ ΘΕΣΗ0 Ι1 ΟΣΟ Ι<=10 ΚΑΙ ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ ΑΝ ΟΝ [Ι]=ΟΝΟΜΑ ΤΟΤΕ ΒΡΕΘΗΚΕ ΑΛΗΘΗΣ ΘΕΣΗΙ ΤΕΛΟΣ_ΑΝ ΙΙ+1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝΑΖΘΕΣΗ ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ