Ejemplos de algoritmos

1,808 views

Published on

Ejemplos para usar en PSEINT de estructuras secuenciales

Published in: Education
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
1,808
On SlideShare
0
From Embeds
0
Number of Embeds
58
Actions
Shares
0
Downloads
20
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Ejemplos de algoritmos

  1. 1. COMPUTACIÓN PROF. PABLO CONTRAMAESTRE pcontramaestre@gmail.com EJEMPLOS DE ALGORITMOS SECUENCIALES1) Ejercicio que lee un carácter y lo muestra por pantalla.Proceso Leer_Caracter Definir x Como Caracter Escribir "digite carácter" Leer x; Escribir "el carácter es:",xFinProceso2) Ejercicio que lee un número y lo muestra por pantalla.Proceso Leer_Numero Definir num Como Entero Escribir "digite un numero " Leer num; Escribir "El numero es: ",num;FinProceso3) Ejercicio que lee un numero y lo multiplica por si mismo!!Proceso doble_numero Definir num,doble Como Entero Escribir "digite numero" Leer num; doble = num * num Escribir "El doble del numero es = ",dobleFinProceso4) Ejercicio que lee un numero y saca el cubo del mismo!!Proceso cubo_numero Definir num,Cub Como Entero Escribir "digite numero" Leer num; Cub = num * num * num; Escribir "el cubo del numero es = ",cubFinProceso
  2. 2. 5) Algoritmo que lee un numero y da como resultado la suma de su doble mas su cuadradoProceso suma_numero_dob_cua Definir num,Dob,Cua,Sum Como Entero Escribir "digite numero" Leer num Dob= num + num Cua= num * num Sum= dob + cua Escribir "la suma de su doble mas su cuadrado es ",sumFinProceso6) Algoritmo que lee un numero y da como resultado su raíz cuadradaProceso raiz_cuadrada Definir num Como Entero //La variable Racua se define como Real, porque el resultado de una raíz //cuadrada puede no ser un numero entero Definir Racua Como Real Escribir "digite un numero" Leer num Racua= RAIZ(num) Escribir "la raiz cuadrada es = ",racuaFinProceso7) Algoritmo que lee dos números y da como resultado la suma del doble del 1ro mas el cuadrado del2doProceso doble_mas_cuadrado Definir a,b,Doba,Cuab,Sum Como Real Escribir "digite 1er numero" Leer a Escribir "digite 2do numero" Leer b Doba= a + a Cuab= b * b Sum= doba + cuab Escribir "La suma del doble del 1ro mas el cuadrado del 2do es = ",sumFinProceso

×