Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

ΑΕΠΠ: Δομή Επιλογής - Μέρος Α΄

1,446 views

Published on

Published in: Education
  • Be the first to comment

ΑΕΠΠ: Δομή Επιλογής - Μέρος Α΄

  1. 1. Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Νίκος Μιχαηλίδης http://users.sch.gr/nikmichailidis 1 12ο Φύλλο Ασκήσεων Δομή Επιλογής (Μέρος Α΄) Η δομή της επιλογής μπορεί να εμφανισθεί με τις παρακάτω μορφές :  Απλή Επιλογή  Σύνθετη Επιλογή  Πολλαπλή Επιλογή  Εμφωλευμένη Επιλογή Απλή Επιλογή Στην απλή επιλογή αν η λογική συνθήκη είναι αληθής εκτελείται το σύνολο των εντολών, ενώ αν είναι ψευδής η εκτέλεση του αλγορίθμου συνεχίζεται μετά τη δεσμευμένη λέξη ΤΕΛΟΣ_ΑΝ παραλείποντας το σύνολο των εντολών. Σύνταξη σε ΓΛΩΣΣΑ Διάγραμμα Ροής ΑΝ < λογική συνθήκη > ΤΟΤΕ Σύνολο Εντολών ΤΕΛΟΣ_ΑΝ Σύνθετη Επιλογή Στη σύνθετη επιλογή αν η λογική συνθήκη είναι αληθής εκτελείται το σύνολο των εντολών 1, ενώ αν είναι ψευδής εκτελείται το σύνολο των εντολών 2. Σύνταξη σε ΓΛΩΣΣΑ Διάγραμμα Ροής ΑΝ < λογική συνθήκη > ΤΟΤΕ Σύνολο Εντολών 1 ΑΛΛΙΩΣ Σύνολο Εντολών 2 ΤΕΛΟΣ_ΑΝ Συνθήκη Σύνολο Εντολών ΝΑΙ ΟΧΙ Συνθήκη Σύνολο Εντολών 1 ΝΑΙ ΟΧΙ Σύνολο Εντολών 2
  2. 2. Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Νίκος Μιχαηλίδης http://users.sch.gr/nikmichailidis 2 ΑΣΚΗΣΗ 1Η Ένα προϊόν πωλείται ως εξής :  Για λιγότερα από 100 τεμάχια προς 12 € το ένα  Για 100 ή περισσότερα τεμάχια προς 10 € το ένα Δίνεται ο αριθμός των τεμαχίων που πουλήθηκαν μια φορά και ζητούνται τα χρήματα που εισπράχθηκαν. Μεταβλητές Εισόδου : Τ (τα τεμάχια που πουλήθηκαν) Μεταβλητές Εξόδου : Χ (Τα χρήματα που εισπράχθηκαν) Αλγόριθμος 1. Διαβάζω τα τεμάχια και τα καταχωρώ στη μεταβλητή Τ. 2. Ελέγχω την τιμή της μεταβλητής Τ. 3. Υπολογίζω το κόστος των τεμαχίων στη Χ. 4. Τυπώνω το περιεχόμενο της μεταβλητής Χ. Λογικό Διάγραμμα Πρόγραμμα σε ΓΛΩΣΣΑ Ν Ο Αρχή Τ Χ Τέλος ΠΡΟΓΡΑΜΜΑ Τεμάχια ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Τ ΠΡΑΓΜΑΤΙΚΕΣ: Χ ΑΡΧΗ ! Εισαγωγή τιμής για την μεταβλητή Τ ΓΡΑΨΕ 'Πόσα Τεμάχια πουλήθηκαν;' ΔΙΑΒΑΣΕ Τ ! υπολογισμός χρημάτων ΑΝ Τ < 100 ΤΟΤΕ Χ <- 12* Τ ΑΛΛΙΩΣ Χ <- 10* Τ ΤΕΛΟΣ_ΑΝ ΓΡΑΨΕ 'Τα χρήματα είναι: ', Χ, ' € ' ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τ < 100 Χ  10 * ΤΧ  12 * Τ
  3. 3. Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Νίκος Μιχαηλίδης http://users.sch.gr/nikmichailidis 3 ΑΣΚΗΣΗ 2Η Δίνεται ακέραιος αριθμός . Να βρεθεί και να τυπωθεί ολογράφως το υπόλοιπο της διαίρεσης του με το 3. Τα πιθανά υπόλοιπα της διαίρεσης οποιουδήποτε ακέραιου με το 3 είναι τα 0, 1 και 2. Μετά την εύρεση λοιπόν του υπολοίπου ελέγχουμε την τιμή του και τυπώνουμε αυτή ολογράφως. Ανάλυση Μεταβλητές Εισόδου : Χ (Ο ακέραιος αριθμός) Μεταβλητές Ενδιάμεσες : Υ (Υπόλοιπο διαίρεσης) Μεταβλητές Εξόδου : Δεν υπάρχουν 1. Διαβάζω τον ακέραιο αριθμό Χ. Αλγόριθμος 2. Υπολογίζω το υπόλοιπο της διαίρεση του ακέραιου Χ με το 3. 3. Ελέγχω το υπόλοιπο. Λογικό Διάγραμμα Πρόγραμμα σε ΓΛΩΣΣΑ Αρχή Χ ΠΡΟΓΡΑΜΜΑ Υπόλοιπο_3 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Υ ΑΡΧΗ ! Εισαγωγή τιμής για τη μεταβλητή Χ ΓΡΑΨΕ 'Δώσε μια ακέραια τιμή' ΔΙΑΒΑΣΕ Χ ! Υπολογισμός του Υ Υ <- Χ MOD 3 ΑΝ Υ = 0 ΤΟΤΕ ΓΡΑΨΕ 'ΜΗΔΕΝ' ΤΕΛΟΣ_ΑΝ ΑΝ Υ = 1 ΤΟΤΕ ΓΡΑΨΕ 'ΕΝΑ' ΤΕΛΟΣ_ΑΝ ΑΝ Υ = 2 ΤΟΤΕ ΓΡΑΨΕ 'ΔΥΟ' ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Υ = 0 ΝΑΙ ΟΧΙ Υ  Χ mod 3 Υ = 1 ΝΑΙ ΟΧΙ Υ = 2 ΝΑΙ ΟΧΙ ΜΗΔΕΝ ΕΝΑ ΔΥΟ Τέλος

×