Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.
2
El objetivo de este material, es desarrollar algunos conceptos utilizados en la
lógica de programación de computadores, pa...
Definición de Algoritmo
Un Algoritmo es crear paso a paso,
de forma ordenada una solución
para un problema o tarea.
Ejempl...
Actividad 1
Diseñemos un algoritmo de 10 pasos para lavado de los dientes.
1. _____________________________
2. ___________...
Actividad 2
Diseñemos un algoritmo de 10 pasos para ir al cine.
1. _____________________________
2. ______________________...
Tomado de: http://www.cuentocuentos.net/dibujo-colorear/968/laberintos-02.html
1-Traza con una línea roja la solución
para...
Reflexiona sobre la actividad 3:
¿Consideras que en la solución de los laberintos se realizaron algoritmos?
Si___
No___
Ac...
Definición de Bucle
Un Bucle es la repetición de uno o varios pasos
en un Algoritmo, nos facilita el proceso, sobre
todo c...
¿Qué ventajas encuentras al utilizar Bucles?
Actividad 5
_________________________________________________________________...
Diseña dos algoritmos en los que se utilicen bucles.
No es necesario que utilices todas las líneas, solo utilizas las que
...
Definición de Condicionales
Un Condicional nos ayuda a tomar decisiones,
con el fin de establecer qué camino seguir.
Ejemp...
La siguiente es la apariencia de la entrada a un correo electrónico, vamos a ver
el algoritmo que se necesita.
Algoritmo
I...
Explica que hace el siguiente algoritmo.
Algoritmo
Inicio
Leer color
Si color = negro
Imprima ‘color oscuro’
Si_no
Imprima...
Diseñe un algoritmo que lea un nombre y un apellido, luego imprima un saludo
al usuario con su nombre y apellido, dibuje l...
Operadores
Ayudan a relacionar, comparar y a realizar
operaciones en el diseño de un algoritmo.
Aritméticos Descripción
+ ...
En los siguientes algoritmos utilizamos los conectores Y – O.
Ejercicio Resuelto
Algoritmo
Inicio
Leer usuario, contraseña...
Encierra con un círculo los operadores que encuentres en los siguientes
algoritmos.
Actividad 9
Algoritmo
Inicio
Leer usua...
1. Diseña el algoritmos de una calculadora.
2. Diseña el algoritmo de un videojuego de carrera de autos.
3. Diseña el algo...
20
Cuadernillo de lógica y Algoritmos para niños de primaria.
Upcoming SlideShare
Loading in …5
×

Cuadernillo de lógica y Algoritmos para niños de primaria.

12,524 views

Published on

Con este material se puede iniciar la enseñanza de algoritmos y lenguajes de programación a niños de Primaria.

Published in: Education
  • Be the first to comment

Cuadernillo de lógica y Algoritmos para niños de primaria.

  1. 1. 2
  2. 2. El objetivo de este material, es desarrollar algunos conceptos utilizados en la lógica de programación de computadores, para que los niños los adopten en sus procesos académicos, logrando mejorar la capacidad de razonar, organizar y ordenar soluciones de manera lógica. Al lograr que el estudiante se apropie de conceptos tales como: algoritmos, variables, bucles, ciclos, condicionales, entre otros, lo fortalecerá para que cuando inicie en el aprendizaje de asignaturas complejas, esté formado con una estructura cimentada y podrá resolver problemas con bases sólida en lógica y pensamiento sistemático. Presentación 3
  3. 3. Definición de Algoritmo Un Algoritmo es crear paso a paso, de forma ordenada una solución para un problema o tarea. Ejemplo: Un Algoritmo para lavarse las manos: 1. Inicio 2. Abrimos la llave 3. Mojamos las manos 4. Aplicamos jabón 5. Enjuagamos 6. Cerramos la llave 7. Secamos las manos 8. Fin Se pueden agregar más pasos o disminuir el proceso, esto depende; lo que se quiere es solucionar ordenadamente el problema. 4
  4. 4. Actividad 1 Diseñemos un algoritmo de 10 pasos para lavado de los dientes. 1. _____________________________ 2. _____________________________ 3. _____________________________ 4. _____________________________ 5. _____________________________ 6. _____________________________ 7. _____________________________ 8. _____________________________ 9. _____________________________ 10._____________________________ Inicio Fin 5
  5. 5. Actividad 2 Diseñemos un algoritmo de 10 pasos para ir al cine. 1. _____________________________ 2. _____________________________ 3. _____________________________ 4. _____________________________ 5. _____________________________ 6. _____________________________ 7. _____________________________ 8. _____________________________ 9. _____________________________ 10._____________________________ 6
  6. 6. Tomado de: http://www.cuentocuentos.net/dibujo-colorear/968/laberintos-02.html 1-Traza con una línea roja la solución para resolver el laberinto. 2-Traza con una línea roja la solución para resolver el laberinto y con una línea azul una segunda opción. Actividad 3 Inicio Fin Inicio Fin 7
  7. 7. Reflexiona sobre la actividad 3: ¿Consideras que en la solución de los laberintos se realizaron algoritmos? Si___ No___ Actividad 4 Explica tu respuesta. _________________________________________________________________________ _________________________________________________________________________ _________________________________________________________________________ ¿Cuál es tu conclusión acerca del segundo laberinto? ___________________________________________________________ ___________________________________________________________ ___________________________________________________________ ___________________________________________________________ ___________________________________________________________ ___________________________________________________________ 8
  8. 8. Definición de Bucle Un Bucle es la repetición de uno o varios pasos en un Algoritmo, nos facilita el proceso, sobre todo cuando estamos escribiendo el algoritmo. Ejemplo: Una profesora necesita confirmar los datos de seis estudiantes, vamos a diseñar el algoritmo. Inicio Abre la planilla del curso Lee nombre y apellido del estudiante 1 Estudiante confirma datos Lee nombre y apellido del estudiante 2 Estudiante confirma datos Lee nombre y apellido del estudiante 3 Estudiante confirma datos Lee nombre y apellido del estudiante 4 Estudiante confirma datos Lee nombre y apellido del estudiante 5 Estudiante confirma datos Lee nombre y apellido del estudiante 6 Estudiante confirma datos Fin Bucle Inicio Abre la planilla del curso Repite 6 veces: Lee nombre y apellido del estudiante Estudiante confirma datos Fin 9
  9. 9. ¿Qué ventajas encuentras al utilizar Bucles? Actividad 5 _________________________________________________________________________ _________________________________________________________________________ _________________________________________________________________________ ¿En qué situación de la casa o del colegio podemos utilizar bucles? _______________________________________________________________________ _______________________________________________________________________ _______________________________________________________________________ _______________________________________________________________________ ______________________________________________________________________ Analiza la siguiente situación: El timbre que indica que inicia o finaliza cada hora de clases en el colegio, ¿se puede considerar como un bucle?, explica. ___________________________________________________________ ___________________________________________________________ ___________________________________________________________ ___________________________________________________________ 10
  10. 10. Diseña dos algoritmos en los que se utilicen bucles. No es necesario que utilices todas las líneas, solo utilizas las que necesites. Actividad 6 _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ _______________________ Nombre:____________________ ____________________________ Nombre:____________________ ____________________________ 11
  11. 11. Definición de Condicionales Un Condicional nos ayuda a tomar decisiones, con el fin de establecer qué camino seguir. Ejemplo: en un algoritmo necesitamos determinar si un estudiante aprueba o no un examen. Digamos que sí, si saca 100% y sino lo pierde. Inicio Leer nota Si nota = 100% Imprima ‘aprobó’ Si_no Imprima ‘no aprobó’ Fin_si Fin Explicación La palabra leer nota se emplea para capturar datos, un ejemplo es cuando accedemos a un correo electrónico; al abrir la página nos pide un usuario y una contraseña, a esto se le llama captura de datos. En este caso la captura es la nota del estudiante. La condición es : si el estudiante saca 100%, imprima (así se le llama a mostrar un mensaje en pantalla) ‘aprobó’, se le coloca comillas por que es un texto que se verá en la pantalla del sistema. Si no se cumple el 100% imprime ‘no aprobó’. El condicional tiene un fin, y luego se le asigna un fin al algoritmo. 12
  12. 12. La siguiente es la apariencia de la entrada a un correo electrónico, vamos a ver el algoritmo que se necesita. Algoritmo Inicio Leer usuario, contraseña Si usuario = invitado y contraseña=123 Imprima ‘acceso concedido’ Si_no Imprima ‘acceso denegado’ Fin_si Fin Ejercicio Resuelto Email Usuario: Contraseña: Para este algoritmo hemos utilizado además del condicional un operador: Y, que sirve para conectar las opciones, en el próximo tema ampliaremos este tema. . 13
  13. 13. Explica que hace el siguiente algoritmo. Algoritmo Inicio Leer color Si color = negro Imprima ‘color oscuro’ Si_no Imprima ‘color claro’ Fin_si Fin Actividad 7 ____________________________________ ____________________________________ ____________________________________ ____________________________________ ____________________________________ ____________________________________ ____________________________________ ____________________________________ 14
  14. 14. Diseñe un algoritmo que lea un nombre y un apellido, luego imprima un saludo al usuario con su nombre y apellido, dibuje la apariencia del programa. Actividad 8 Algoritmo _____________________________ _____________________________ _____________________________ _____________________________ _____________________________ _____________________________ _____________________________ _____________________________ Dibujo del Programa 15
  15. 15. Operadores Ayudan a relacionar, comparar y a realizar operaciones en el diseño de un algoritmo. Aritméticos Descripción + Suma - Resta * Multiplicación / División Lógicos Descripción And Y (debe cumplir las condiciones) Or O (debe cumplir una de las condiciones) Relación Descripción > Mayor que < Menor que = Igual a 16
  16. 16. En los siguientes algoritmos utilizamos los conectores Y – O. Ejercicio Resuelto Algoritmo Inicio Leer usuario, contraseña Si usuario = nuevo ycontraseña=123 Imprima ‘Bienvenido’ Si_no Imprima ‘Dato no encontrado’ Fin_si Fin Algoritmo Inicio Leer usuario, contraseña Si usuario = nuevo ocontraseña=123 Imprima ‘Bienvenido’ Si_no Imprima ‘Dato no encontrado’ Fin_si Fin La diferencia entre estos dos algoritmos es que en el primero los dos datos deben estar correctos: usuario y contraseña, para que muestre el mensaje Bienvenido. Y en el segundo puede estar correcto solo uno: usuario o contraseña para que muestre el mensaje Bienvenido. 17
  17. 17. Encierra con un círculo los operadores que encuentres en los siguientes algoritmos. Actividad 9 Algoritmo Inicio Leer usuario, contraseña Si usuario = nuevo y contraseña= 123 Imprima ‘Bienvenido’ Si_no Imprima ‘Dato no encontrado’ Fin_si Fin Algoritmo Inicio Leer número uno, número dos resultado=número1 + número2 imprima resultado Fin Algoritmo Inicio Leer datouno, datodos Si datouno>datodos imprima ‘el mayor es:’ datouno Si_no imprima ‘el menor es:’ datodos Fin_si Fin Algoritmo Inicio Leer nombre, apellido Si nombre= admin or apellido= user imprima ‘OK’ Si-no imprima ‘intente otra vez’ Fin_si Fin 18
  18. 18. 1. Diseña el algoritmos de una calculadora. 2. Diseña el algoritmo de un videojuego de carrera de autos. 3. Diseña el algoritmo de un buscador de Internet. Ejercicios 19 Algoritmo 1 __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ _________ Algoritmo 2 __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ _________ Algoritmo 3 __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ __________________ _________
  19. 19. 20

×