ΑΕΠΠ - Δομή Ακολουθίας

7,980 views

Published on

Μία παρουσίαση που καλύπτει τις ενότητες 7.10 και 2.4.1 του βιβλίου "Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον".

Published in: Education
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
7,980
On SlideShare
0
From Embeds
0
Number of Embeds
4,277
Actions
Shares
0
Downloads
220
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

ΑΕΠΠ - Δομή Ακολουθίας

  1. 1. Δομή ακολουθίας<br />Σαρημπαλίδης Ιωάννης<br />Φωτό από Kaddy<br />
  2. 2. Είναι μία από τις τρεις <br />βασικές δομές του δομημένου προγραμματισμού <br />
  3. 3. Εντολή 1<br />Στην ακολουθιακή δομή εντολών εκτελούμε τις εντολές με τη σειρά με την οποία εμφανίζονται στο πρόγραμμα.<br />Εντολή 2<br />Εντολή 3<br />
  4. 4. ΠΡΟΣΟΧΗ !!!<br />Κάθε φορά που εκτελούμε μία εντολή η οποία αλλάζει την τιμή μίας μεταβλητής αυτό έχει ως αποτέλεσμα η προηγούμενη τιμή αυτής της μεταβλητής να χάνεται.<br />Χ  4<br />Χ  5<br />Μετά την εκτέλεση των 2 εντολών η τελική τιμή της μεταβλητής Χ είναι 5. Η τιμή 4 χάθηκε.<br />
  5. 5. Ας δούμε τη δομή <br />ενός απλού προγράμματος<br />
  6. 6. Πρόγραμμα υπολογισμού του αθροίσματος δύο ακεραίων αριθμών <br />ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />
  7. 7. ΕΠΙΚΕΦΑΛΙΔΑ<br />ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />
  8. 8. ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />ΔΗΛΩΣΗ ΜΕΤΑΒΛΗΤΩΝ<br />
  9. 9. ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />ΑΡΧΗ<br />
  10. 10. ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />ΕΙΣΑΓΩΓΗ ΔΕΔΟΜΕΝΩΝ<br />
  11. 11. ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />ΠΡΑΞΕΙΣ<br />
  12. 12. ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />ΕΜΦΑΝΙΣΗ ΑΠΟΤΕΛΕΣΜΑΤΩΝ<br />
  13. 13. ΠΡΟΓΡΑΜΜΑ Άθροισμα_αριθμών<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />ΑΡΧΗ<br /> ΓΡΑΨΕ "Δώσε τον πρώτο αριθμό: "<br />ΔΙΑΒΑΣΕ Χ ΓΡΑΨΕ "Δώσε τον δεύτερο αριθμό: "<br /> ΔΙΑΒΑΣΕ Υ   <br />ΑΘΡ  Χ + Υ<br />ΓΡΑΨΕ"Το άθροισμα είναι : ", ΑΘΡ<br />ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣΆθροισμα_αριθμών<br />ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ<br />
  14. 14. Λίγα ακόμα πράγματα που πρέπει να ξέρουμε …<br />
  15. 15. Σταθερές<br />Αν υπάρχουν σταθερές τότε το τμήμα δηλώσεων των σταθερών τοποθετείται πριν το τμήμα δηλώσεων των μεταβλητών<br />ΣΤΑΘΕΡΕΣ<br />Π = 3.14<br />ΜΕΤΑΒΛΗΤΕΣ<br />ΑΚΕΡΑΙΕΣ : Χ, Υ, ΑΘΡ<br />
  16. 16. Σχόλια<br />Τα σχόλια δεν είναι εκτελέσιμες εντολές. <br />Απλά μας βοηθάνε να καταλάβουμε <br />τι κάνει το πρόγραμμα. <br />Ξεκινάνε πάντα με τον χαρακτήρα !<br />! Αυτό είναι ένα σχόλιο<br />
  17. 17. Εντολές<br />Αν μία εντολή πρέπει να συνεχιστεί και στην επόμενη γραμμή τότε ο πρώτος χαρακτήρας της επόμενης γραμμής θα είναι ο χαρακτήρας &<br />ΓΡΑΨΕ "Αυτή η εντολή δεν χωράει<br />& σε μία γραμμή."<br />
  18. 18. ΣΑΣ ΕΥΧΑΡΙΣΤΩ<br />Περισσότερα μπορείτε να βρείτε στο <br />http://pliroforikiatschool.blogspot.com<br />

×