Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

oso.. epanalabe..

254 views

Published on

  • Login to see the comments

  • Be the first to like this

oso.. epanalabe..

  1. 1. Δομή Επανάληψης: ΟΣΟ… ΕΠΑΝΑΛΑΒΕ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Εκπαιδευτικό σενάριο για την Γ’ Λυκείου «Give me your PIN…» Ζαπρούδη Ελίνα, MSc Πληροφοριακών Συστημάτων Καθηγήτρια 4ου ΓΕ.Λ. ΣΕΡΡΩΝ elza.serr@gmail.com
  2. 2. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ ΜΕΡΟΣ Γ’. ΦΥΛΛΟ ΔΡΑΣΤΗΡΙΟΤΗΤΩΝ ΣΚΟΠΟΣ: Η κατανόηση της επαναληπτικής Δομής: Όσο… Επανάλαβε… Τέλος_Επανάληψης ΣΤΟΧΟΙ: Μετά την ολοκλήρωση του φύλλου δραστηριοτήτων θα: • περιγράφετε λεκτικά, τα βήματα της συγκεκριμένης επαναληπτικής δομής. • «μεταφράζετε» την μορφή της επαναληπτικής δομής σε ΓΛΩΣΣΑ και σε Διάγραμμα Ροής. • εφαρμόζετε την επαναληπτική δομή στην επίλυση προβλημάτων. • προβληματίζεστε και θα αναζητάτε την βέλτιστη λύση. Ζαπρούδη Ελίνα 2
  3. 3. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ Βήμα 1. Επαναλαμβάνω καθημερινά… Δραστηριότητα 1. Έχεις τρεις ευκαιρίες!!! Δραστηριότητα 1.1 Repeat… • Έχετε έρθει πολλές φορές στην θέση να σας ζητείται το PIN για την ενεργοποίηση του κινητού σας τηλεφώνου, ή πιθανώς στο ΑΤΜ της τράπεζας μισθοδοσίας των γονιών σας, όπου έχετε ακριβώς τρεις προσπάθειες να δώσετε το σωστό PIN. • Επίσης όταν πάτε σε κάποια υπηρεσία (π.χ. συμβατικό ταχυδρομείο, τράπεζα κ.λ.π.) όπου πρέπει να τηρηθεί σειρά προτεραιότητας έχετε παρατηρήσει ότι υπάρχει ηλεκτρονική συσκευή η οποία δείχνει την σειρά προτεραιότητας του πελάτη. • Μπορείτε να σκεφτείτε άλλα παραδείγματα όπου επαναλαμβάνετε κάποια διαδικασία; Δραστηριότητα 1.2 Ας «παίξουμε» με τα παραπάνω… Προσπαθήστε να εκτελέσετε το παράδειγμα με το PIN για την ενεργοποίηση του κινητού σας τηλεφώνου. Γίνετε 3-μελής ομάδα στην οποία το πρώτο μέλος είναι ο προγραμματιστής ο οποίος μετρά το πλήθος των επαναλήψεων έως ότου δοθεί το σωστό PIN και επικοινωνεί με την «μηχανή», στο δεύτερο είναι το κινητό σας τηλέφωνο με την Οθόνη όπου εμφανίζει τα κατάλληλα μηνύματα και επικοινωνεί με τον χρήστη του τηλεφώνου και στο τρίτο μέλος είναι ο χρήστης του κινητού τηλεφώνου. Δραστηριότητα 1.3 Ισόπλευρα γεωμετρικά σχήματα.. Ζωγραφίστε ένα τετράγωνο στο τετράδιό σας. Επαναλαμβάνετε κάποιες ενέργειες; Περιγράψτε συνοπτικά, τον τρόπο με τον οποίο εργαστήκατε. Ζαπρούδη Ελίνα 3
  4. 4. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ ΕΙΣΗΓΗΣΗ ( *Παρουσίαση (Αρχείο OSO.pptx) ) Ζαπρούδη Ελίνα 4
  5. 5. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ Ζαπρούδη Ελίνα 5
  6. 6. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ Εμείς θα ασχοληθούμε με το πρόβλημα του κινητού τηλεφώνου, όπου ο χρήστης έχει τρεις προσπάθειες για να δώσει τον σωστό κωδικό (PIN), ώστε αυτό να τεθεί σε κανονική λειτουργία. Ζαπρούδη Ελίνα 6
  7. 7. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ Βήμα 2. Συνεργάζομαι – Διερευνώ. Δραστηριότητα 2. Πόσες φορές πρέπει να στο επαναλάβω;; 2.1. Επανάλαβε.. επανάλαβε… Γίνετε 2-μελής ομάδα και τρέξτε το αρχείο epanalipsi1.exe το οποίο υπάρχει στον φάκελό σας και παρατηρείστε την επανάληψη κάποιων ενεργειών. Επίσης. τρέξτε το αρχείο epanalipsi2.exe και παρατηρείστε και πάλι την επανάληψη κάποιων ενεργειών. Για περισσότερη οπτικοποίηση δείτε τα Διαγράμματα Ροής που βρίσκονται στα αρχεία: epanalipsi1.fpp & epanalipsi2.fpp 2.2 Πότε πρέπει να τερματίσω;;; Παρακολουθώντας την διαδικασία της επανάληψης κάποιων ενεργειών στα προηγούμενα αρχεία, απαντήστε συνεργατικά ανά δύο στα παρακάτω ερωτήματα του test: epanalipsi_hot_potatoes.htm , το οποίο θα βρείτε στο φάκελό σας. Ζαπρούδη Ελίνα 7
  8. 8. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ Ζαπρούδη Ελίνα 8
  9. 9. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ 2.3 Ποια είναι τα βήματα ; a) 1η περίπτωση: Να συμπληρώσετε τον πίνακα τιμών και να δημιουργήσετε το Διάγραμμα Ροής για το παρακάτω τμήμα κώδικα: ΓΛΩΣΣΑ Πίνακας Τιμών Διάγραμμα Ροής a<- 5 ΟΣΟ a>1 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ a^2 a<- a-2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ a Έξοδος b) 2η περίπτωση: Πόσες φορές εκτελείται το παρακάτω τμήμα προγράμματος; a<- 1 ΟΣΟ a>1 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ 2*a a<- a-1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ (*Καμία επανάληψη) c) 3η περίπτωση: Πόσες φορές εκτελείται το παρακάτω τμήμα προγράμματος; a<- -10 ΟΣΟ a<1 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ 10*a a<- a-2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ (*Ατέρμων Βρόχος) Ζαπρούδη Ελίνα 9
  10. 10. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ 2.4 Πάλι; Προσπάθησε να διατυπώσεις τους δύο αλγορίθμους των αρχείων epanalipsi1.exe & epanalipsi2.exe. Στην συνέχεια, σύγκρινέ τους με τους κώδικες σε ΓΛΩΣΣΑ που θα βρεις στον φάκελό σου, με ονόματα epanalipsi1.γλώσσα & epanalipsi2.γλώσσα. Ζαπρούδη Ελίνα 10
  11. 11. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ Βήμα 3. Προβληματίζομαι.. Εφαρμόζω.. Δραστηριότητα 3. Δώστε μου τις λύσεις!!! Δραστηριότητα 3.1 Η λύση της Μαρίας! Στο «ζήτημα» του κινητού τηλεφώνου ή του ΑΤΜ, όπου μας ζητείτε το σωστό PIN έχοντας τρεις προσπάθειες να απαντήσουμε, η λύση που έδωσε η Μαρία είναι η παρακάτω: ΠΡΟΓΡΑΜΜΑ KODIKOS ΜΕΤΑΒΛΗΤΕΣ ΧΑΡΑΚΤΗΡΕΣ: PASSWORD, CODE ΑΚΕΡΑΙΕΣ: i ΑΡΧΗ PASSWORD <- "123456" ΓΡΑΨΕ "Give me your code.You have three tries..." ΔΙΑΒΑΣΕ CODE ΟΣΟ CODE <> PASSWORD ΚΑΙ i <= 3 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ "Try again" ΓΡΑΨΕ "Give me your code." ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ CODE = PASSWORD ΤΟΤΕ ΓΡΑΨΕ "Welcome" ΑΛΛΙΩΣ ΓΡΑΨΕ "End" ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Στην λύση αυτή υπάρχουν τέσσερα σοβαρά λάθη από τα οποία τα 3 είναι παραλείψεις.. Μπορείτε να τα εντοπίσετε; Ζαπρούδη Ελίνα 11
  12. 12. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ Δραστηριότητα 3.2 Are you sure? Παρακάτω δίνεται μία από τις σωστές λύσεις.. Είναι άραγε η καλύτερη;;; ΠΡΟΓΡΑΜΜΑ KODIKOS ΜΕΤΑΒΛΗΤΕΣ ΧΑΡΑΚΤΗΡΕΣ: PASSWORD, CODE ΑΚΕΡΑΙΕΣ: i ΑΡΧΗ PASSWORD <- "123456" ΓΡΑΨΕ "Give me your code.You have three tries..." ΔΙΑΒΑΣΕ CODE i <- 1 ΟΣΟ CODE <> PASSWORD ΚΑΙ i <= 2 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ "Try again" ΓΡΑΨΕ "Give me your code." ΔΙΑΒΑΣΕ CODE i <- i + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ CODE = PASSWORD ΤΟΤΕ ΓΡΑΨΕ "Welcome" ΑΛΛΙΩΣ ΓΡΑΨΕ "End" ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Δραστηριότητα 3.3 I’m waiting… Μπορείτε να διατυπώσετε τις δικές σας λύσεις στο προηγούμενο πρόβλημα σε ΓΛΩΣΣΑ; Χρησιμοποιείστε την εφαρμογή ΔΙΕΡΜΗΝΕΥΤΗΣ ΤΗΣ ΓΛΩΣΣΑΣ, ώστε να πετύχετε τη δική σας λύση. Ζαπρούδη Ελίνα 12
  13. 13. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ ΑΣΚΗΣΕΙΣ ΓΙΑ ΤΟ ΣΠΙΤΙ Άσκηση 1η : Ερωτήσεις Σωστού-Λάθους Η ομάδα εντολών η οποία βρίσκεται μέσα στον βρόχο επανάληψης της δομής επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ.. εκτελείται όσο η συνθήκη είναι ψευδής. Σ Λ Η ομάδα εντολών η οποία βρίσκεται μέσα στον βρόχο επανάληψης της δομής επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ.. εκτελείται τουλάχιστον μία φορά. Σ Λ Άσκηση 2η : a) Τι θα εμφανίσει καθένα από τα ακόλουθα τμήματα προγράμματος: x <- 5 ΟΣΟ x>1 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ x x <- x-1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ x <- 100 ΟΣΟ x >o ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ x x <- x DIV 2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ b) Ποιά θα είναι η τιμή του x μετά την επανάληψη σε καθένα από τα δύο τμήματα. c) Πόσες φορές θα εκτελεστούν οι εντολές μέσα σε κάθε επανάληψη; Άσκηση 3η : Ζαπρούδη Ελίνα 13
  14. 14. Δομή Επανάληψης ΟΣΟ.. ΕΠΑΝΑΛΑΒΕ a) Να γράψετε τμήματα κώδικα σε ΓΛΩΣΣΑ τα οποία εκτελούν τα ακόλουθα: • Διάβασμα 10 αριθμών και εμφάνιση αθροίσματος και ΜΟ αυτών • Διάβασμα 10 αριθμών και εύρεση και εμφάνιση του Μέγιστου αυτών. b) Να γράψετε τμήματα κώδικα σε ΓΛΩΣΣΑ τα οποία εκτελούν τα ακόλουθα: • Διάβασμα αριθμών μέχρι να δοθεί το 0 και εμφάνιση αθροίσματος και ΜΟ αυτών. • Διάβασμα ονομάτων και βαθμών μέχρι να δοθεί ως όνομα το κενό ως χαρακτήρας και εμφάνισης του ονόματος με τον μεγαλύτερο βαθμό. Άσκηση 4η : Να κατασκευαστεί ΠΡΟΓΡΑΜΜΑ που να δέχεται το όνομα και την ηλικία σε έτη κάθε ατόμου μίας ομάδας πληθυσμού και να εμφανίζει τη μέση ηλικία του πληθυσμού καθώς και το όνομα και την ηλικία του γηραιότερου. Το ΠΡΟΓΡΑΜΜΑ θα τερματίζει όταν δοθεί η τιμή «*» στη θέση του ονόματος. Ζαπρούδη Ελίνα 14

×