SlideShare a Scribd company logo
1 of 6
Configuration Example 10: Controlling Route Redistribution Based on Tag
Values

In Figure 14-4, Router B is learning six routes via EIGRP. The EIGRP routes are redistributed into OSPF with the
classful routes assigned a tag of 2 and the classless routes a tag of 1. Router A is redistributing the OSPF external routes
into RIP-2. The policy is to redistribute only the classless routes into RIP-2. This can be accomplished using a route map
and an IP access list. Because the external routes have been tagged, a route map can be used that redistributes only routes
with a tag value equal to 1. Configure the routers as shown in the listing that follows the figure. Initially, all OSPF routes
will be redistributed into RIP-2 on Router A.

Figure 14-4 A Route Map Can Be Used to Control Route Redistribution Based on the Tag Value

Router A
interface Loopback0
  ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
  bandwidth 64
  ip address 10.1.1.9 255.255.255.252
  no ip mroute-cache
!
interface Serial0/1
  bandwidth 64
  ip address 10.1.1.1 255.255.255.252
  clockrate 64000
!
router ospf 1
  network 10.1.1.0 0.0.0.3 area 0
!
router rip
  version 2
  redistribute ospf 1 metric 1
  passive-interface Serial0/1
  network 10.0.0.0
  no auto-summary




  Router B
  interface Loopback0
   ip address 2.2.2.2 255.255.255.255
  !
  interface Serial0
   bandwidth 64
   ip address 10.1.1.2 255.255.255.252
   no ip directed-broadcast
  !
  interface Serial1
   bandwidth 64
ip address 10.1.1.5 255.255.255.252
 clockrate 64000
!
!
router eigrp 1
 network 10.0.0.0
!
router ospf 1
 redistribute eigrp 1 subnets route-map set-tags
 network 10.1.1.0 0.0.0.3 area 0
!
access-list 1 permit 6.0.0.0 0.15.255.255
access-list 1 permit 146.6.0.0 0.0.15.255
access-list 1 permit 206.6.6.0 0.0.0.15
access-list 1 permit 10.1.1.4 0.0.0.3
route-map set-tags permit 10
 match ip address 1
 set tag 1
!
route-map set-tags permit 20
 set tag 2




Router C
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
 ip address 5.5.5.5 255.0.0.0
!
interface Loopback2
 ip address 6.6.6.6 255.240.0.0
!
interface Loopback3
 ip address 145.5.5.5 255.255.0.0
!
interface Loopback4
 ip address 146.6.6.6 255.255.240.0
!
interface Loopback5
 ip address 205.5.5.5 255.255.255.0
!
interface Loopback6
 ip address 206.6.6.6 255.255.255.240
!
interface Serial0
 bandwidth 64
 ip address 10.1.1.6 255.255.255.252
 no ip directed-broadcast
!
router eigrp 1
 network 5.0.0.0
 network 6.0.0.0
 network 10.0.0.0
 network 145.5.0.0
 network 146.6.0.0
 network 205.5.5.0
 network 206.6.6.0
 no auto-summary


Router D
interface Serial0/1
 ip address 10.1.1.10 255.255.255.252
 clockrate 64000
!
router rip
 version 2
network 10.0.0.0
Verify that Router D is receiving the redistributed OSPF routes from Router A.




 rtrD#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
 BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
 default
       U - per-user static route, o - ODR
 Gateway of last resort is not set
 R    205.5.5.0/24 [120/1] via 10.1.1.9, 00:00:01, Serial0/1
      206.6.6.0/28 is subnetted, 1 subnets
 R       206.6.6.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R    5.0.0.0/8 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      6.0.0.0/12 is subnetted, 1 subnets
 R       6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      172.16.0.0/24 is subnetted, 1 subnets
 R       172.16.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R    145.5.0.0/16 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      10.0.0.0/30 is subnetted, 3 subnets
 C       10.1.1.8 is directly connected, Serial0/1
 R       10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R       10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      146.6.0.0/20 is subnetted, 1 subnets
R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:05, Serial0/1
Modify the configuration on Router A so that only OSPF routes with a tag value of 1 get redistributed into
RIP.



 Router A
 router rip
   version 2
   redistribute ospf 1 metric 1 route-map check-tags
   passive-interface Serial0/1
   network 10.0.0.0
   no auto-summary
 !
 route-map check-tags permit 10
match tag 1



Verification

Verify that the only OSPF routes redistributed into RIP on Router A are those routes with a tag value of 1.

 rtrD#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
 BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
     i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
 default
       U - per-user static route, o - ODR
 Gateway of last resort is not set
      206.6.6.0/28 is subnetted, 1 subnets
 R       206.6.6.0 [120/1] via 10.1.1.9, 00:00:01, Serial0/1
      6.0.0.0/12 is subnetted, 1 subnets
 R       6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      10.0.0.0/30 is subnetted, 3 subnets
 C       10.1.1.8 is directly connected, Serial0/1
 R       10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
 R       10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1
      146.6.0.0/20 is subnetted, 1 subnets
R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1

More Related Content

Recently uploaded

Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfAddepto
 
DevEX - reference for building teams, processes, and platforms
DevEX - reference for building teams, processes, and platformsDevEX - reference for building teams, processes, and platforms
DevEX - reference for building teams, processes, and platformsSergiu Bodiu
 
How to write a Business Continuity Plan
How to write a Business Continuity PlanHow to write a Business Continuity Plan
How to write a Business Continuity PlanDatabarracks
 
Time Series Foundation Models - current state and future directions
Time Series Foundation Models - current state and future directionsTime Series Foundation Models - current state and future directions
Time Series Foundation Models - current state and future directionsNathaniel Shimoni
 
What is DBT - The Ultimate Data Build Tool.pdf
What is DBT - The Ultimate Data Build Tool.pdfWhat is DBT - The Ultimate Data Build Tool.pdf
What is DBT - The Ultimate Data Build Tool.pdfMounikaPolabathina
 
The Ultimate Guide to Choosing WordPress Pros and Cons
The Ultimate Guide to Choosing WordPress Pros and ConsThe Ultimate Guide to Choosing WordPress Pros and Cons
The Ultimate Guide to Choosing WordPress Pros and ConsPixlogix Infotech
 
The State of Passkeys with FIDO Alliance.pptx
The State of Passkeys with FIDO Alliance.pptxThe State of Passkeys with FIDO Alliance.pptx
The State of Passkeys with FIDO Alliance.pptxLoriGlavin3
 
Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Commit University
 
TrustArc Webinar - How to Build Consumer Trust Through Data Privacy
TrustArc Webinar - How to Build Consumer Trust Through Data PrivacyTrustArc Webinar - How to Build Consumer Trust Through Data Privacy
TrustArc Webinar - How to Build Consumer Trust Through Data PrivacyTrustArc
 
Passkey Providers and Enabling Portability: FIDO Paris Seminar.pptx
Passkey Providers and Enabling Portability: FIDO Paris Seminar.pptxPasskey Providers and Enabling Portability: FIDO Paris Seminar.pptx
Passkey Providers and Enabling Portability: FIDO Paris Seminar.pptxLoriGlavin3
 
Artificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxArtificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxhariprasad279825
 
Generative AI for Technical Writer or Information Developers
Generative AI for Technical Writer or Information DevelopersGenerative AI for Technical Writer or Information Developers
Generative AI for Technical Writer or Information DevelopersRaghuram Pandurangan
 
From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .Alan Dix
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfAlex Barbosa Coqueiro
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLScyllaDB
 
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Mark Simos
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii SoldatenkoFwdays
 
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek SchlawackFwdays
 
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptxThe Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptxLoriGlavin3
 
unit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptxunit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptxBkGupta21
 

Recently uploaded (20)

Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdf
 
DevEX - reference for building teams, processes, and platforms
DevEX - reference for building teams, processes, and platformsDevEX - reference for building teams, processes, and platforms
DevEX - reference for building teams, processes, and platforms
 
How to write a Business Continuity Plan
How to write a Business Continuity PlanHow to write a Business Continuity Plan
How to write a Business Continuity Plan
 
Time Series Foundation Models - current state and future directions
Time Series Foundation Models - current state and future directionsTime Series Foundation Models - current state and future directions
Time Series Foundation Models - current state and future directions
 
What is DBT - The Ultimate Data Build Tool.pdf
What is DBT - The Ultimate Data Build Tool.pdfWhat is DBT - The Ultimate Data Build Tool.pdf
What is DBT - The Ultimate Data Build Tool.pdf
 
The Ultimate Guide to Choosing WordPress Pros and Cons
The Ultimate Guide to Choosing WordPress Pros and ConsThe Ultimate Guide to Choosing WordPress Pros and Cons
The Ultimate Guide to Choosing WordPress Pros and Cons
 
The State of Passkeys with FIDO Alliance.pptx
The State of Passkeys with FIDO Alliance.pptxThe State of Passkeys with FIDO Alliance.pptx
The State of Passkeys with FIDO Alliance.pptx
 
Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!Nell’iperspazio con Rocket: il Framework Web di Rust!
Nell’iperspazio con Rocket: il Framework Web di Rust!
 
TrustArc Webinar - How to Build Consumer Trust Through Data Privacy
TrustArc Webinar - How to Build Consumer Trust Through Data PrivacyTrustArc Webinar - How to Build Consumer Trust Through Data Privacy
TrustArc Webinar - How to Build Consumer Trust Through Data Privacy
 
Passkey Providers and Enabling Portability: FIDO Paris Seminar.pptx
Passkey Providers and Enabling Portability: FIDO Paris Seminar.pptxPasskey Providers and Enabling Portability: FIDO Paris Seminar.pptx
Passkey Providers and Enabling Portability: FIDO Paris Seminar.pptx
 
Artificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptxArtificial intelligence in cctv survelliance.pptx
Artificial intelligence in cctv survelliance.pptx
 
Generative AI for Technical Writer or Information Developers
Generative AI for Technical Writer or Information DevelopersGenerative AI for Technical Writer or Information Developers
Generative AI for Technical Writer or Information Developers
 
From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdf
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQL
 
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
Tampa BSides - Chef's Tour of Microsoft Security Adoption Framework (SAF)
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko
 
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
"Subclassing and Composition – A Pythonic Tour of Trade-Offs", Hynek Schlawack
 
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptxThe Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
 
unit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptxunit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptx
 

Featured

PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024Neil Kimberley
 
Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)contently
 
How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024Albert Qian
 
Social Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsSocial Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsKurio // The Social Media Age(ncy)
 
Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024Search Engine Journal
 
5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summarySpeakerHub
 
ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd Clark Boyd
 
Getting into the tech field. what next
Getting into the tech field. what next Getting into the tech field. what next
Getting into the tech field. what next Tessa Mero
 
Google's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search IntentGoogle's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search IntentLily Ray
 
Time Management & Productivity - Best Practices
Time Management & Productivity -  Best PracticesTime Management & Productivity -  Best Practices
Time Management & Productivity - Best PracticesVit Horky
 
The six step guide to practical project management
The six step guide to practical project managementThe six step guide to practical project management
The six step guide to practical project managementMindGenius
 
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...RachelPearson36
 
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...Applitools
 
12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at WorkGetSmarter
 
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...DevGAMM Conference
 
Barbie - Brand Strategy Presentation
Barbie - Brand Strategy PresentationBarbie - Brand Strategy Presentation
Barbie - Brand Strategy PresentationErica Santiago
 

Featured (20)

PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024PEPSICO Presentation to CAGNY Conference Feb 2024
PEPSICO Presentation to CAGNY Conference Feb 2024
 
Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)Content Methodology: A Best Practices Report (Webinar)
Content Methodology: A Best Practices Report (Webinar)
 
How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024How to Prepare For a Successful Job Search for 2024
How to Prepare For a Successful Job Search for 2024
 
Social Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie InsightsSocial Media Marketing Trends 2024 // The Global Indie Insights
Social Media Marketing Trends 2024 // The Global Indie Insights
 
Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024Trends In Paid Search: Navigating The Digital Landscape In 2024
Trends In Paid Search: Navigating The Digital Landscape In 2024
 
5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary5 Public speaking tips from TED - Visualized summary
5 Public speaking tips from TED - Visualized summary
 
ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd ChatGPT and the Future of Work - Clark Boyd
ChatGPT and the Future of Work - Clark Boyd
 
Getting into the tech field. what next
Getting into the tech field. what next Getting into the tech field. what next
Getting into the tech field. what next
 
Google's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search IntentGoogle's Just Not That Into You: Understanding Core Updates & Search Intent
Google's Just Not That Into You: Understanding Core Updates & Search Intent
 
How to have difficult conversations
How to have difficult conversations How to have difficult conversations
How to have difficult conversations
 
Introduction to Data Science
Introduction to Data ScienceIntroduction to Data Science
Introduction to Data Science
 
Time Management & Productivity - Best Practices
Time Management & Productivity -  Best PracticesTime Management & Productivity -  Best Practices
Time Management & Productivity - Best Practices
 
The six step guide to practical project management
The six step guide to practical project managementThe six step guide to practical project management
The six step guide to practical project management
 
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
Beginners Guide to TikTok for Search - Rachel Pearson - We are Tilt __ Bright...
 
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
Unlocking the Power of ChatGPT and AI in Testing - A Real-World Look, present...
 
12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work12 Ways to Increase Your Influence at Work
12 Ways to Increase Your Influence at Work
 
ChatGPT webinar slides
ChatGPT webinar slidesChatGPT webinar slides
ChatGPT webinar slides
 
More than Just Lines on a Map: Best Practices for U.S Bike Routes
More than Just Lines on a Map: Best Practices for U.S Bike RoutesMore than Just Lines on a Map: Best Practices for U.S Bike Routes
More than Just Lines on a Map: Best Practices for U.S Bike Routes
 
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
Ride the Storm: Navigating Through Unstable Periods / Katerina Rudko (Belka G...
 
Barbie - Brand Strategy Presentation
Barbie - Brand Strategy PresentationBarbie - Brand Strategy Presentation
Barbie - Brand Strategy Presentation
 

Cisco Ospf Route Redistribution

  • 1. Configuration Example 10: Controlling Route Redistribution Based on Tag Values In Figure 14-4, Router B is learning six routes via EIGRP. The EIGRP routes are redistributed into OSPF with the classful routes assigned a tag of 2 and the classless routes a tag of 1. Router A is redistributing the OSPF external routes into RIP-2. The policy is to redistribute only the classless routes into RIP-2. This can be accomplished using a route map and an IP access list. Because the external routes have been tagged, a route map can be used that redistributes only routes with a tag value equal to 1. Configure the routers as shown in the listing that follows the figure. Initially, all OSPF routes will be redistributed into RIP-2 on Router A. Figure 14-4 A Route Map Can Be Used to Control Route Redistribution Based on the Tag Value Router A interface Loopback0 ip address 1.1.1.1 255.255.255.255 ! interface Serial0/0 bandwidth 64 ip address 10.1.1.9 255.255.255.252 no ip mroute-cache ! interface Serial0/1 bandwidth 64 ip address 10.1.1.1 255.255.255.252 clockrate 64000 ! router ospf 1 network 10.1.1.0 0.0.0.3 area 0 ! router rip version 2 redistribute ospf 1 metric 1 passive-interface Serial0/1 network 10.0.0.0 no auto-summary Router B interface Loopback0 ip address 2.2.2.2 255.255.255.255 ! interface Serial0 bandwidth 64 ip address 10.1.1.2 255.255.255.252 no ip directed-broadcast ! interface Serial1 bandwidth 64
  • 2. ip address 10.1.1.5 255.255.255.252 clockrate 64000 ! ! router eigrp 1 network 10.0.0.0 ! router ospf 1 redistribute eigrp 1 subnets route-map set-tags network 10.1.1.0 0.0.0.3 area 0 ! access-list 1 permit 6.0.0.0 0.15.255.255 access-list 1 permit 146.6.0.0 0.0.15.255 access-list 1 permit 206.6.6.0 0.0.0.15 access-list 1 permit 10.1.1.4 0.0.0.3 route-map set-tags permit 10 match ip address 1 set tag 1 ! route-map set-tags permit 20 set tag 2 Router C interface Loopback0 ip address 3.3.3.3 255.255.255.255 ! interface Loopback1 ip address 5.5.5.5 255.0.0.0 ! interface Loopback2 ip address 6.6.6.6 255.240.0.0 ! interface Loopback3 ip address 145.5.5.5 255.255.0.0
  • 3. ! interface Loopback4 ip address 146.6.6.6 255.255.240.0 ! interface Loopback5 ip address 205.5.5.5 255.255.255.0 ! interface Loopback6 ip address 206.6.6.6 255.255.255.240 ! interface Serial0 bandwidth 64 ip address 10.1.1.6 255.255.255.252 no ip directed-broadcast ! router eigrp 1 network 5.0.0.0 network 6.0.0.0 network 10.0.0.0 network 145.5.0.0 network 146.6.0.0 network 205.5.5.0 network 206.6.6.0 no auto-summary Router D interface Serial0/1 ip address 10.1.1.10 255.255.255.252 clockrate 64000 ! router rip version 2 network 10.0.0.0
  • 4. Verify that Router D is receiving the redistributed OSPF routes from Router A. rtrD#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR Gateway of last resort is not set R 205.5.5.0/24 [120/1] via 10.1.1.9, 00:00:01, Serial0/1 206.6.6.0/28 is subnetted, 1 subnets R 206.6.6.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 5.0.0.0/8 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 6.0.0.0/12 is subnetted, 1 subnets R 6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 172.16.0.0/24 is subnetted, 1 subnets R 172.16.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 145.5.0.0/16 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 10.0.0.0/30 is subnetted, 3 subnets C 10.1.1.8 is directly connected, Serial0/1 R 10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 146.6.0.0/20 is subnetted, 1 subnets R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:05, Serial0/1
  • 5. Modify the configuration on Router A so that only OSPF routes with a tag value of 1 get redistributed into RIP. Router A router rip version 2 redistribute ospf 1 metric 1 route-map check-tags passive-interface Serial0/1 network 10.0.0.0 no auto-summary ! route-map check-tags permit 10 match tag 1 Verification Verify that the only OSPF routes redistributed into RIP on Router A are those routes with a tag value of 1. rtrD#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default U - per-user static route, o - ODR Gateway of last resort is not set 206.6.6.0/28 is subnetted, 1 subnets R 206.6.6.0 [120/1] via 10.1.1.9, 00:00:01, Serial0/1 6.0.0.0/12 is subnetted, 1 subnets R 6.0.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 10.0.0.0/30 is subnetted, 3 subnets C 10.1.1.8 is directly connected, Serial0/1 R 10.1.1.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 R 10.1.1.4 [120/1] via 10.1.1.9, 00:00:02, Serial0/1 146.6.0.0/20 is subnetted, 1 subnets
  • 6. R 146.6.0.0 [120/1] via 10.1.1.9, 00:00:02, Serial0/1