Presentacion Pseint

11,561 views

Published on

0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
11,561
On SlideShare
0
From Embeds
0
Number of Embeds
25
Actions
Shares
0
Downloads
188
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Presentacion Pseint

  1. 1. Universidad José Antonio Paéz COMO REALIZAR ALGORITMOS UTILIZANDO PSEINT Yamilitza Camacho
  2. 2. PSeInt es la abreviatura de Pseudo Intérprete, un editor de programación diseñado específicamente para estudiantes que quieran comprender la lógica de la programación sin conocimientos previos de la materia. PSeInt incluye en su editor diversas herramientas para que podamos crear y almacenar programas en este peculiar lenguaje, ejecutarlos directamente desde su interfaz, o incluso corregir posibles defectos que encontremos en su desarrollo. DEFINICIÒN
  3. 3. <ul><li>CARACTERÍSTICAS DE PSEINT: </li></ul><ul><ul><li>Presenta herramientas de edición básicas para escribir algoritmos en pseudocodigo en español </li></ul></ul><ul><li>Permite la edición simultánea de múltiple algoritmos </li></ul><ul><li>Presenta ayudas para la escritura </li></ul><ul><ul><ul><li>Autocompletado </li></ul></ul></ul><ul><li>Ayudas Emergentes </li></ul><ul><li>Plantillas de Comandos </li></ul><ul><li>Coloreado de Sintaxis </li></ul>
  4. 4. <ul><ul><li>Puede ejecutar los algoritmos escritos </li></ul></ul><ul><li>Permite ejecutar el algoritmo paso a paso controlando la velocidad e inspeccionando expresiones </li></ul><ul><li>Puede confeccionar automáticamente la tabla de prueba de escritorio </li></ul><ul><li>Determina y marca los errores de sintaxis y en tiempo de ejecución </li></ul><ul><li>Genera diagramas de flujo a partir del algoritmo escrito </li></ul>FUNCIONALIDADES DE PSEINT:
  5. 5. Proceso sin_titulo // Juego simple que pide al usuario que adivine un numero en 5 intentos intentos<-5; num_secreto <- azar(100)+1; Escribir &quot;Adivine el numero (de 1 a 100):&quot;; Leer num_ingresado; Mientras num_secreto<>num_ingresado & intentos>0 Hacer Si num_secreto>num_ingresado Entonces Escribir &quot;Muy bajo&quot;; Sino Escribir &quot;Muy alto&quot;; FinSi Escribir &quot;Le quedan &quot;,intentos,&quot; intentos:&quot;; Leer num_ingresado; intentos <- intentos-1; FinMientras Si intentos=0 Entonces Escribir &quot;El numero era: &quot;,num_secreto; Sino Escribir &quot;Exacto! Usted adivino en &quot;,11-intentos,&quot; intentos.&quot;; FinSi FinProceso EJERCICIO A REALIZAR
  6. 6. PANTALLA PRINCIPAL
  7. 7. EJEMPLO EN PSEINT
  8. 8. DIAGRAMA DE FLUJO CON PSEINT
  9. 9. EJECUCIÒN DEL EJEMPLO

×