Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

Lógica de programação - comando Caso - VisualG

2,765 views

Published on

Curso de Lógica de Programação da Bóson, com Fábio dos Reis.
Comando caso - Escolhas múltiplas

http://www.bosontreinamentos.com.br

Published in: Technology
  • Be the first to comment

Lógica de programação - comando Caso - VisualG

  1. 1. Comando Caso Bóson Treinamentos Fábio dos Reis
  2. 2. Comando Caso (Switch / Case) O comando caso é utilizado para que seja possível escolher uma opção dentre várias existentes, eliminando a necessidade de se usar diversos Se..Então encadeados. Isso simplifica a codificação do algoritmo, e facilita sua depuração e atualização. Esse comando testa uma condição, e dependendo do resultado, executará os códigos associados. Bóson Treinamentos Fábio dos Reis
  3. 3. Comando Caso - Sintaxe A sintaxe pode variar um pouco de uma linguagem para outra, e no VisualG você a usará assim: escolha <variável / expressão) caso <valor1> comandos a executar caso <valor2> comandos a executar caso <valor3> comandos a executar outrocaso comandos-padrão fimescolha Bóson Treinamentos Fábio dos Reis
  4. 4. Exemplo: var x: literal inicio escreval (“Digite uma letra:”) leia (x) escolha x caso “a” escreva(“Você digitou a letra A”) caso “b” escreva(“Você digitou a letra B”) outrocaso escreva(“Você digitou uma outra letra”) fimescolha Bóson Treinamentos Fábio dos Reis
  5. 5. Slides da Bóson Treinamentos Acesse nosso site: www.bosontreinamentos.com.br Canal no Youtube: https://www.youtube.com/user/bosontreinamentos Facebook: https://www.facebook.com/groups/bosontreinamentos/?fref =ts Bóson Treinamentos Fábio dos Reis

×