Informatica - Excel Intermedio

2,935 views

Published on

Nozioni di MS Excel per chi già ne conosce i fondamenti.

Published in: Technology
0 Comments
6 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
2,935
On SlideShare
0
From Embeds
0
Number of Embeds
27
Actions
Shares
0
Downloads
0
Comments
0
Likes
6
Embeds 0
No embeds

No notes for slide

Informatica - Excel Intermedio

  1. 1. FRANCESCO VENUTO INFORMATICA EXCEL INTERMEDIO 2008
  2. 2. <ul><li>NOTA INIZIALE </li></ul>NOTA INIZIALE Per evidenziare : non fanno parte delle finestre di EXCEL
  3. 3. <ul><li>USI POSSIBILI: </li></ul><ul><ul><li>Analisi di dati (da più fonti) </li></ul></ul><ul><ul><li>Creazione report aziendali </li></ul></ul><ul><ul><li>Budget complessi </li></ul></ul><ul><ul><li>Previsioni </li></ul></ul><ul><ul><li>Supporto decisionale </li></ul></ul>EXCEL…AVANZATO?
  4. 4. PARTE I <ul><li>FORMULE E FUNZIONI </li></ul>
  5. 5. FUNZIONI (PUNTO DI PARTENZA) <ul><li>Excel propone decine di funzioni </li></ul><ul><li>Usarle, comporle in FORMULE è compito nostro: </li></ul><ul><ul><li>SAPERLE USARE </li></ul></ul><ul><ul><li>AVER CHIARI RIFERIMENTI </li></ul></ul><ul><ul><ul><li>RELATIVI (A4) </li></ul></ul></ul><ul><ul><ul><li>ASSOLUTI ($A$4) </li></ul></ul></ul><ul><ul><li>AVERE CHIARE LE PRECEDENZE </li></ul></ul>
  6. 6. LE FUNZIONI <ul><li>Divise in tipologie: </li></ul><ul><ul><li>Matematiche </li></ul></ul><ul><ul><li>Testo </li></ul></ul><ul><ul><li>Logiche </li></ul></ul><ul><ul><li>Informative </li></ul></ul><ul><ul><li>Finanziarie </li></ul></ul><ul><ul><li>Data/Ora </li></ul></ul><ul><ul><li>Statistiche </li></ul></ul><ul><ul><li>Database </li></ul></ul>
  7. 7. INSERIRE UNA FUNZIONE =NOME_FUNZ(arg1;arg2;…)
  8. 8. LE FUNZIONI MATEMATICHE <ul><li>Breve elenco delle principali: </li></ul><ul><ul><li>Seni, coseni, arcoseni… </li></ul></ul><ul><ul><li>Arrotonda (difetto, eccesso), Tronca </li></ul></ul><ul><ul><li>Prodotto, Fattoriale, Exp </li></ul></ul><ul><ul><li>Somma, Somma.se </li></ul></ul>
  9. 9. LE FUNZIONI DI TESTO <ul><li>Lavorano su ‘stringhe’: </li></ul><ul><ul><li>Concatena, Annulla spazi </li></ul></ul><ul><ul><li>Destra, Sinistra, Estrai </li></ul></ul><ul><ul><li>Maiusc & Minusc </li></ul></ul><ul><ul><li>Ricerca, rimpiazza, Ripeti </li></ul></ul>
  10. 10. LE FUNZIONI LOGICHE <ul><li>Lavorano su uno o più operandi: </li></ul><ul><ul><li>E, O, NON </li></ul></ul><ul><ul><li>SE </li></ul></ul><ul><ul><li>VERO, FALSO </li></ul></ul><ul><li>Usiamole per creare formule ‘nostre’ </li></ul><ul><li>CONCETTO DI SCELTA </li></ul>
  11. 11. DATA/ORA: le date per Excel <ul><li>Excel tratta le date da numeri </li></ul><ul><li>Il 1 gennaio 1900, ore 0:00 vale 1 (sui PC) </li></ul><ul><li>Ogni giorno (24 ore) aggiunge 1 </li></ul><ul><ul><li>Il 5 gennaio, ore 0:00 vale 5 </li></ul></ul><ul><li>Ogni ora vale 1/24=0.042 </li></ul><ul><ul><li>Il 5 gennaio 1900, ore 10:00 vale 5,42 </li></ul></ul><ul><ul><li>Il 5 gennaio 1900, ore 12:00 vale 5,5 </li></ul></ul><ul><li>Excel è bravo a calcolare differenze tra date </li></ul><ul><ul><li>Perché sono differenze tra numeri </li></ul></ul>
  12. 12. DATA/ORA: le date per Excel <ul><li>Che valore corrisponde al 25/12/2010, h 12.30? </li></ul><ul><ul><li>Quasi 111 anni dal 1/1/1900 </li></ul></ul><ul><ul><li>Precisamente 40537 giorni </li></ul></ul><ul><ul><li>Ore 12 e 30…moltiplico 12.5 x 0.042 </li></ul></ul><ul><ul><li>ottengo circa 0.52 </li></ul></ul><ul><li>Quindi 40537 + 0.52 = 40537.52 </li></ul><ul><li>Se vedo numeracci del genere dopo aver inserito date è colpa del formato </li></ul><ul><li>Cambio il numero in data e tutto va a posto </li></ul>
  13. 13. LE FUNZIONI DI DATA/ORA <ul><li>Possono estrarre o comporre date: </li></ul><ul><ul><li>Anno, mese, giorno(.settimana) </li></ul></ul><ul><ul><li>Ora, minuti, secondi </li></ul></ul><ul><ul><li>Data.valore, orario.valore </li></ul></ul><ul><li>(EXCEL) la data è un numero </li></ul>
  14. 14. LE FUNZIONI FINANZIARIE <ul><li>Con Excel potete calcolare: </li></ul><ul><ul><li>Ammortamenti </li></ul></ul><ul><ul><li>Rate dei mutui </li></ul></ul><ul><ul><li>Tassi d’interesse </li></ul></ul><ul><ul><li>Rendimenti </li></ul></ul>
  15. 15. LE FUNZIONI STATISTICHE <ul><li>Il piatto forte di Excel: </li></ul><ul><ul><li>Conta (se, valori, numeri) </li></ul></ul><ul><ul><li>Medie (aritm., geom.) </li></ul></ul><ul><ul><li>Varianza, Dev. Std. </li></ul></ul><ul><ul><li>Test </li></ul></ul>
  16. 16. FORMULE COMPLESSE <ul><li>E’ possibile usare in serie più funzioni </li></ul><ul><li>Ogni funzione argomento di un’altra </li></ul><ul><ul><li>Funz1(funz2;funz3;[…]) </li></ul></ul><ul><li>Sembra astruso ma è MOLTO frequente </li></ul>
  17. 17. FORMULE COMPLESSE (ESEMPIO: catena di SE) <ul><li>Problema: </li></ul>La colonna B deve indicare: - 1000 se in A ho un Venditore - 700 se in A ho un Assistente - 2000 se in A ho un Responsabile CHE FORMULA USO?
  18. 18. FORMULE COMPLESSE (SOLUZIONE: catena di SE) <ul><li>=SE( A2=&quot;Venditore&quot;;1000 ;SE( A2=&quot;Assistente&quot;;700 ; 2000 )) </li></ul>=SE(Test;se_vero;se_falso) SE B2 è “Venditore“ risultato: 1000 ALTRIMENTI SE B2 è “Assistente“ risultato: 700 ALTRIMENTI risultato: 2000
  19. 19. PARTE II <ul><li>EXCEL E I DATI </li></ul>
  20. 20. TRATTARE I DATI <ul><li>Una tabella è qualcosa di statico </li></ul><ul><li>Un insieme di dati è qualcosa di più. Posso: </li></ul><ul><ul><li>Ordinarli </li></ul></ul><ul><ul><li>Raggrupparli </li></ul></ul><ul><ul><li>Filtrarli </li></ul></ul><ul><ul><li>importarli ed esportarli in molti formati, non limitati al concetto di tabella </li></ul></ul>
  21. 21. I DATI: DEFINIZIONI <ul><li>Dati  tabella </li></ul><ul><ul><li>Ogni riga è detta RECORD </li></ul></ul><ul><ul><ul><li>Il record è logicamente connesso </li></ul></ul></ul><ul><ul><li>Ogni colonna è detta ATTRIBUTO </li></ul></ul><ul><ul><li>(di solito ha un’intestazione) </li></ul></ul><ul><ul><li>Ogni cella è detta campo </li></ul></ul>
  22. 22. IL MENU DATI - 1 <ul><li>Da questo menu potete </li></ul><ul><li>Ordinare o filtrare i record </li></ul><ul><li>Inserire i dati come in un modulo </li></ul><ul><li>Inserire subtotali automatici </li></ul><ul><li>Convalidare i dati secondo le esigenze </li></ul>
  23. 23. IL MENU DATI - 2 <ul><li>Inoltre potete </li></ul><ul><li>Ordinare o filtrare i record </li></ul><ul><li>Inserire i dati come in un modulo </li></ul><ul><li>Inserire subtotali automatici </li></ul><ul><li>Convalidare i dati secondo le esigenze </li></ul>

×