Algoritmo Variaveis

769 views

Published on

Definições sobre:
- Variaveis e Constantes
- Tipos de Dados
- Operadores de Atribuição
- Operadores Aritméticos
- Operadores Lógicos

Tire suas Dúvidas: andrevallenobre@gmail.com

Published in: Technology
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
769
On SlideShare
0
From Embeds
0
Number of Embeds
5
Actions
Shares
0
Downloads
12
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Algoritmo Variaveis

  1. 1. Algoritmo Estruturado Prof. André Nobre
  2. 2. Tipos de Dados • Opções que nunca irão mudar ao declarar variáveis: – Inteiros – Reais; – Caracteres; – Lógicos;
  3. 3. Constantes e Variáveis • Exemplos de declaração: Var Nome : Caractere; Idade : Inteiro; Media,N1,N2 : Real; Status : Logico;
  4. 4. Constantes e Variáveis • Exemplos de nomes Validos: • nome1 • informacao •x • N_41 • resp_soma
  5. 5. Constantes e Variáveis • Exemplos de nomes Validos: • nome1 • informacao •x • N_41 • resp_soma
  6. 6. Constantes e Variáveis • Exemplos de nomes Invalidos: • 1nome • informação • #x • N 41 • Inteiro
  7. 7. Constantes e Variáveis • Exemplos de nomes Invalidos: • 1nome • informação • #x • N 41 • Inteiro(nome reservado para declaração de variáveis)
  8. 8. Constantes e Variáveis • Atribuição de Valores: A atribuição de dados a uma variável ou constante é efetuada através do comando de atribuição normalmente simbolizado por Exemplo: <- Cont <- 100; Curso := “Redes”; ou :=
  9. 9. Operadores e Expressões • Operadores Aritméticos: + / * (Subtração) (Adição) (Divisão) (Multiplicação)
  10. 10. Operadores e Expressões • Operadores Relacionais: = <> > < >= <= (Igualdade) (Desigualdade) (Maior que) (Menor que) (Maior ou igual) (Menor ou igual)
  11. 11. Operadores e Expressões • Operadores Lógicos: E Ou Não (Conjunção) (Disjunção) (Negação)
  12. 12. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  13. 13. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  14. 14. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  15. 15. Operadores e Expressões • Expressões: são combinações de constantes, variáveis e operadores para produzir um resultado. Ex.: Total := SubTotal - Desc; Media := (N1+N2)/2; Juros := (Total * 8)+Total;
  16. 16. Comando de Entrada • Leia Exemplo: Leia(nota1); Leia(nome); Leia(“Media ”); Aspas só para String, nunca para Variável.
  17. 17. Comando de Saída • Escreva Exemplo: Escreva(“Digite a Nota:”); Escreva(“Digite o Nome:”, nome); Escreva(Media);
  18. 18. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  19. 19. Exemplo de Algoritmo Nome do Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  20. 20. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Inicio e Fim Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  21. 21. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Declaração de Variáveis Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim
  22. 22. Exemplo de Algoritmo Programa SomaDeDoisValores var SOMA : real; Inicio Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Escreva(“Resposta=”,SOMA); Fim Blocos estruturados de comandos
  23. 23. Programação NÃO Estruturada Programa SomaDeDoisValores Inicio var SOMA : real; Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Se SOMA > 10 então Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Senão se SOMA > 20 então Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Senão se SOMA > 30 então Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); FimSe Fim
  24. 24. Programação Estruturada Programa SomaDeDoisValores Inicio var SOMA : real; Escreva(“Entre com o valor de A e B”); Leia(A,B); SOMA := A + B; Se SOMA > 10 então Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Escreva(“Valor Maior que 10!”); Senão se SOMA > 20 então Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Escreva(“Valor Maior que 20!”); Senão se SOMA > 30 então Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); Escreva(“Valor Maior que 30!”); FimSe Fim
  25. 25. Comando Condicional • Se Exemplo 1: Se Nota >= 7 então Escreva(“Aluno Aprovado”); FimSe;
  26. 26. Comando Condicional • Se Exemplo 2: Se Nota >= 7 então Escreva(“Aluno Aprovado”); senão se nota <= 4 Escreva(“Aluno Aprovado”); senão Escreva(“Aluno Aprovado”); FimSe;
  27. 27. Exercícios 7. Faça um algoritmo onde o usuario deverá digitar um numero de 1 a 3 e exibir os resultados: – – – – 8. Igual a 1 -> “Ruim!” Igual a 2 -> “Bom!” Igual a 3 -> “Ótimo!” Maior que 3 ou menor que 1 -> “Erro!” Faça um algoritmo exiba a mensagem conforme o sexo informado: – Feminino = “Você é bonita!” – Masculino = “Você é Bonito!” 9. Faça um algoritmo no qual o professor informa 2 notas e baseado na média exiba os resultados: – >= 7 -> Aprovado – <7 e >=4 -> Recuperação – <4 -> Reprovado – >10 ou <0 -> Erro!
  28. 28. Comando de Repetição • Enquanto Exemplo: Enquanto N < 5 faça Escreva(“Numero= ”,N); N := N + 1; FimEnquanto;

×