Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

Análisis del problema presentacion

326 views

Published on

  • Be the first to comment

  • Be the first to like this

Análisis del problema presentacion

  1. 1. Análisis del problemaEstudiantes :Andrés Alfonso SánchezDiana Alejandra rodriguez E.
  2. 2. Matrices en pseintRealice un algoritmo que permitaimprimir en pantalla los datos que alalmacenar en las filas A un numerodeterminado de valores numéricos porel cuadrado de los mismos en lascolumnas B con un numerodeterminado de valores numéricos.
  3. 3. formular problema almacenar datos en las filas A un numero determinado de valores numéricospor el cuadrado de los mismos en las columnas B con un numero determinadode valores numéricos.
  4. 4. Datos disponibles Datos de tipo numérico Filas =A COLUMNAS=B
  5. 5. RESTRICCIONES No se saben los números No se sabe el tamaño de filas A por columnas B.
  6. 6. Proceso necesario Matriz Arreglo bidimensional Ciclo Para
  7. 7. RESULTADO ESPERADO mostrar en pantalla las filas al cuadrado por las columnas con los númerosalmacenados
  8. 8. seudocodigo Proceso matriz Dimension A(100) Dimension B(100) Escribir "cuantos numeros va a almacenar" Leer num Escribir ("digite", num, "a almacenar") Para i<-1 hasta num Con Paso 1 Hacer Leer A(i) FinPara t<-1; Para i<-1 hasta num Con Paso 1 Hacer B(t)<- A(i)^2 t<-t+1 FinPara Escribir "el vector original es" Para i<-1 hasta num Con Paso 1 Hacer Escribir A(i) FinPara Escribir "los numeros elevados al cuadrado son" Para i<-1 hasta t-1 Con Paso 1 Hacer Escribir B(i) FinPara FinProceso

×