Successfully reported this slideshow.
We use your LinkedIn profile and activity data to personalize ads and to show you more relevant ads. You can change your ad preferences anytime.

なでしこで、なんか作ってみた

763 views

Published on

Published in: Entertainment & Humor
  • Be the first to comment

  • Be the first to like this

なでしこで、なんか作ってみた

  1. 1. 2010-04-15-YanoLab.LT なでしこで、なんか作ってみた M1 村上
  2. 2. なでしこについて <ul><li>なでしことは? </li><ul><li>クジラ飛行机(くじらひこうづくえ)氏が制作した
  3. 3. インタプリタ方式のスクリプト型の言語 </li></ul><ul><li>名前の由来はサッカー日本女子代表
  4. 4. 「なでしこジャパン」より
  5. 5. 同作者の「ひまわり」の後継言語 </li></ul></ul>
  6. 6. なでしこの特徴 <ul>日本語 でプログラミングできる </ul>
  7. 7. たとえば・・・ #include<stdio.h> int main(void) { int x=0; puts(“x の値を入力” ); scanf(“%d”, &x); if(x == 1){ printf(“x は 1 です ”); }else{ printf(“x は 1 ではありません ”); } }
  8. 8. なでしこで書くと xは0 「xの値を入力」と尋ねて、xに代入。 もし、xが「 1 」ならば   「 x は 1 です」と表示。 違えば   「 x は 1 ではありません」と表示。
  9. 9. 比較 #include<stdio.h> int main(void) { int x=0; puts(“x の値を入力” ); scanf(“%d”, &x); if(x == 1){ printf(“x は 1 です ”); } else{ printf(“x は 1 ではありません ”); } } xは0 「xの値を入力」と尋ねて、xに代入。 もし、xが「 1 」ならば   「 x は 1 です」と表示。 違えば   「 x は 1 ではありません」と表示。
  10. 10. 開発ゼミが楽しそうだったので <ul><li>電卓作ってみた </li></ul>
  11. 11. いいわけ <ul><li>1 日で適当に作った。バグ勘弁
  12. 12. ソースぐちゃぐちゃ
  13. 13. ÷ 0って何?おいしいの? </li></ul>
  14. 14. 感想 <ul><li>プログラム入門にはいいかも
  15. 15. とりあえず全角半角混じりソース気持ち悪い
  16. 16. 小学生とかに遊びとしてプログラム組ませたりも出来そう
  17. 17. 開発環境が標準で用意されてる
  18. 18. GUI が意外と充実してる
  19. 19. Word や Excel と連携が取れるらしい
  20. 20. でもやっぱりソース気持ち悪い </li></ul>
  21. 21. まとめ <ul><li>興味があったらやってみてもいいかも
  22. 22. 日本語でソースを書く気持ち悪さを
  23. 23. 体験できる </li></ul>

×