Compter le nombre de caractères avec Excel (formules nbcar, substitue et sommeprod)

1,377 views

Published on

Tutoriel pour apprendre à compter le nombre de caractères sur Excel. Comment utiliser la formule nbcar d'Excel ? Comment utiliser la formule substitue d'Excel ? Comment utiliser la formule sommeprod d'Excel ?

Published in: Software
0 Comments
0 Likes
Statistics
Notes
  • Be the first to comment

  • Be the first to like this

No Downloads
Views
Total views
1,377
On SlideShare
0
From Embeds
0
Number of Embeds
3
Actions
Shares
0
Downloads
3
Comments
0
Likes
0
Embeds 0
No embeds

No notes for slide

Compter le nombre de caractères avec Excel (formules nbcar, substitue et sommeprod)

  1. 1. Votre Assistante – Le Blog : http://www.votreassistante.net/blog - le 02/01/2014 Compter le nombre de caractères avec Excel (formules nbcar, substitue et sommeprod) Grâce à Excel, vous pouvez compter le nombre de caractères (lettres, chiffres, signes de ponctuation, espace…) de manière automatique de différentes façons. Pour compter le nombre de caractères avec Excel, vous utiliserez la formule NBCAR. Compter le nombre de caractères d’une chaîne de caractères saisie : Cette formule peut être utilisée sans référence à une cellule. Vous débuterez donc la formule par =NBCAR(). Entre parenthèse et entre guillemets, vous saisirez votre chaîne de caractères comme dans cet exemple : =NBCAR("Votre Assistante") Ce qui vous donnera : 16 Compter le nombre de caractères présents dans une cellule : Placez-vous sur une cellule vide d’Excel et saisissez la formule suivante : =NBCAR(A1) A1 étant la cellule où se trouvent les caractères à compter. Compter le nombre de caractères présents dans une cellule sans les espaces : Pour qu’Excel ne prenne pas en compte les espaces dans une chaîne de caractères lors de son calcul, vous devrez utiliser la formule SUBSTITUE. Celle-ci fonctionne de la même manière que lorsque vous utilisez la fonction Rechercher-remplacer d’Excel. Nous allons donc demander à Excel de remplacer, dans son calcul, les espaces par rien afin que la formule NBCAR effectue son calcul pour le reste des caractères. Voici la formule à utiliser pour compter les caractères de la cellule A1 : =NBCAR(SUBSTITUE(A1;" ";)) Compter le nombre de caractères présents dans une plage de cellules : Pour cela, vous utiliserez la formule SOMMEPROD. Celle-ci va calculer la somme suivant un critère. Ce qui donnera cette formule pour calculer la plage de cellules A1 à A3 : =SOMMEPROD(NBCAR(A1:A3)) Article écrit par Lydia Provin du blog Votre Assistante – Le Blog : http://www.votreassistante.net/blog 1

×