Algoritmos e programação - Aula 7

6,898 views

Published on

Slides referentes a 7ª aula da disciplina de Algoritmos e Programação, realizada no dia 25/02/2011

Published in: Technology
0 Comments
3 Likes
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
6,898
On SlideShare
0
From Embeds
0
Number of Embeds
56
Actions
Shares
0
Downloads
240
Comments
0
Likes
3
Embeds 0
No embeds

No notes for slide

Algoritmos e programação - Aula 7

  1. 1. Algoritmos e Programação Thyago Maia Tavares de Farias Aula 7
  2. 2. Sumário <ul><li>Estruturas de Repetição ; </li></ul><ul><ul><li>Repita...ate ; </li></ul></ul>
  3. 3. Estruturas de Repetição <ul><li>Até o momento, quando existe a necessidade de repetir uma (ou mais) instruções, a única saída é repetir o(s) comando(s); </li></ul><ul><li>Tal solução é ineficiente considerando que quanto maior o número de repetições maior será o número de instruções; </li></ul><ul><ul><li>Ex.: Escrever um algoritmo que exiba na tela a frase “Sport campeão de 87” 300 vezes; </li></ul></ul><ul><li>Solução: Utilizar estruturas de repetição; </li></ul>
  4. 4. Estruturas de Repetição <ul><li>Saõ estruturas sintáticas que permitem que um trecho de algoritmo (lista de comandos) seja repetido em um determinado número de vezes; </li></ul><ul><li>Em Portugol, temos três estruturas de repetição: repita...ate , enquanto...faca e para...faca ; </li></ul>
  5. 5. Repita...ate <ul><li>Nesta estrutura, todas as instruções são executadas e uma expressão lógica é avaliada; </li></ul><ul><li>Isto se repete até que a avaliação da condição resulte em FALSO ; </li></ul><ul><li>Cada repetição da lista de instruções contidas na estrutura é chamada de iteração ; </li></ul><ul><li>A estrutura Repita...ate também é conhecida como laço de repetição ; </li></ul>
  6. 6. Repita...ate <ul><li>Utilizamos as palavras reservadas repita e ate para formar o laço de repetição; </li></ul><ul><li>Forma geral: </li></ul><ul><li>repita </li></ul><ul><li>// Lista de instruções </li></ul><ul><li>ate expressão lógica </li></ul>
  7. 7. Repita...ate <ul><li>Exemplo - Algoritmo que escreve os números de 1 a 10: </li></ul><ul><li>algoritmo “Mostra10” </li></ul><ul><li>var numero: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>numero <- 1 </li></ul><ul><li>repita </li></ul><ul><li>escreva(numero) </li></ul><ul><li>numero <- numero + 1 // contador </li></ul><ul><li>ate numero > 10 </li></ul><ul><li>fimalgoritmo </li></ul>
  8. 8. Repita...ate <ul><li>Exemplo 2 - Algoritmo que escreve os números PARES entre 1 e 10: </li></ul><ul><li>algoritmo “Mostra10” </li></ul><ul><li>var numero: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>numero <- 1 </li></ul><ul><li>repita </li></ul><ul><li>se (numero % 2 = 0) entao </li></ul><ul><li>escreva(numero) </li></ul><ul><li>fimse </li></ul><ul><li>numero <- numero + 1 // contador </li></ul><ul><li>ate numero > 10 </li></ul><ul><li>fimalgoritmo </li></ul>
  9. 9. Repita...ate <ul><li>Atenção: Cuidado com laços infinitos ! Devemos nos certificar que em algum momento a expressão lógica próxima a palavra reservada ate será FALSA! </li></ul>
  10. 10. Repita...ate <ul><li>Exemplo 3 – Algoritmo com um laço infinito: </li></ul><ul><li>algoritmo “lacoInfinito” </li></ul><ul><li>var contador: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>repita </li></ul><ul><li>contador <- 1 </li></ul><ul><li>escreva(contador) </li></ul><ul><li>contador <- contador + 1 </li></ul><ul><li>ate contador = 10 </li></ul><ul><li>fimalgoritmo </li></ul>
  11. 11. Repita...ate <ul><li>Exemplo 4 – Algoritmo com um menu: </li></ul><ul><li>algoritmo “menu” </li></ul><ul><li>var opcao: inteiro </li></ul><ul><li>inicio </li></ul><ul><li>repita </li></ul><ul><li>escreval(“Cadastro de Clientes”) </li></ul><ul><li>escreval(“1 - Incluir”) </li></ul><ul><li>escreval(“2 - Alterar”) </li></ul><ul><li>escreval(“3 - Consultar”) </li></ul><ul><li>escreval(“4 - Excluir”) </li></ul><ul><li>escreval(“5 - Sair”) </li></ul><ul><li>leia(opcao) </li></ul><ul><li>ate opcao = 5 </li></ul><ul><li>fimalgoritmo </li></ul>
  12. 12. Exercícios <ul><li>Escreva um algoritmo que some os números entre 1 e 10, escrevendo o resultado final; </li></ul><ul><li>Faça um algoritmo que repita 10 vezes a seguinte frase: A CBF é uma vergonha! </li></ul><ul><li>Faça um algoritmo que lê número inteiros até que um número negativo seja digitado; </li></ul><ul><li>Faça um algoritmo que lê a idade de 15 pessoas e mostre a quantidade de pessoas que possui a idade entre 0 e 12 anos; </li></ul>

×