Algoritmos e Programação - Aula 4

2,942 views

Published on

Algoritmos e Programação - Aula 4

Published in: Technology
0 Comments
1 Like
Statistics
Notes
  • Be the first to comment

No Downloads
Views
Total views
2,942
On SlideShare
0
From Embeds
0
Number of Embeds
66
Actions
Shares
0
Downloads
59
Comments
0
Likes
1
Embeds 0
No embeds

No notes for slide

Algoritmos e Programação - Aula 4

  1. 1. Profº Thyago M iP fº Th MaiaAlgoritmos e Programação Aula 4
  2. 2. Sumário S áiEstruturas Condicionais
  3. 3. Estruturas Condicionais• Na vida real tomamos decisões a todo momento, momento baseadas em escolhas;• Em algoritmos, chamamos tais decisões de condições;• Associada a uma condição, existirá uma possível alternativa; • Exemplo: Se o Sport não vencer o Santa Cruz na próxima partida, seu técnico será demitido;
  4. 4. Estruturas Condicionais• Analisando o exemplo anterior: • A condição d exemplo: “ S t não vencer o di ã do l “o Sport ã Santa Cruz”; • Possíveis decisões baseadas na condição: Sim (Verdadeiro) ou não (Falso); • Logo, condições geram respostas lógicas! • Se a condição for verdadeira, a ação “demitir o demitir técnico” será executada; • Caso contrário (senão) o técnico continuará no (senão), Sport;
  5. 5. Estruturas Condicionais• Para criarmos estruturas condicionais simples em Portugol, utilizamos as palavras reservadas Portugol se, entao e fimse;• Sintaxe: Se (condicao) entao // Instruções fimse
  6. 6. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_se” l i l Var numero: inteiro Inicio escreva(“Digite um número: ”) leia(numero) se(numero>3)entao escreva(“O número é maior que 3!”) fimse fimalgoritmo
  7. 7. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_senha” l i l h Var senha: literal Inicio escreva(“Digite a senha: ”) leia(senha) se(senha=“soueu123”)entao escreva(“Acesso liberado!”) fimse fimalgoritmo
  8. 8. Estruturas Condicionais• Para criarmos estruturas condicionais com duas opções de escolha em Portugol utilizamos as Portugol, palavras reservadas se, entao, senao e fimse;• Sintaxe: Se (condicao) entao // Instruções que serão executadas se // a condição for verdadeira Senao // Instruções que serão executadas se // a condição for falsa fimse
  9. 9. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_se_senao” l i l Var numero: inteiro Inicio escreva(“Digite um número: ”) leia(numero) se(numero>3)entao escreva(“O número é maior que 3!”) senao escreva(“O número é maior ou igual a 3!”) fimse fimalgoritmo
  10. 10. Estruturas Condicionais• Exemplo: Algoritmo “exemplo_senha_2” l i l h 2 Var senha: literal Inicio escreva(“Digite a senha: ”) leia(senha) se(senha=“soueu123”)entao escreva(“Acesso liberado!”) senao escreva(“Acesso proibido!”) fimse fimalgoritmo
  11. 11. Estruturas Condicionais• Exemplo: Faça um algoritmo que lê um número inteiro e verifica se o mesmo é par ou ímpar;
  12. 12. Estruturas CondicionaisAlgoritmo “Al it “par_impar” i ”Var numero: inteiroInicio escreva(“Digite um numero: ”) leia(numero) se(numero % 2 = 0)entao escreva(“O número é PAR”) senao escreva( O escreva(“O número é ÍMPAR”) ÍMPAR ) fimsefimalgoritmo

×